Subject: Re: Multihoming Issues

From: "J. Noel Chiappa" <[email-masked]>
Date: Fri, 30 Aug 2002 18:54:45 -0400

> From: Scott  Bradner <[email-masked]>

    > in case anyone is interested in facts on this topic 

Ptack! I have never known the IETF to let facts get in the way of a good
(albeit ultimately pointless) argument about routing.

	Noel

---

From: "Michel Py" <[email-masked]>
Date: Fri, 30 Aug 2002 18:55:08 -0700

> Sister Sibling wrote:
> The IETF is recommending that the DNS mechanisms to
> support IPv6 stay essentially the same as those already
> in use with IPv4 today. To our opinion, in the realm of
> multi-homed networks, the techniques used in IPv4 can't
> all be applied since they have scaling problems.
> Specifically, if the same prefix is advertised by multiple
> ISPs, the routing tables will grow as a function of the
> number of multihomed sites.

I fail to see the relation between DNS and the number of
prefixes being advertised.

As far as scalability is concerned, it is clear that the
mechanism currently being used with IPv4 is not very
scalable, but is reserved to multihomed ISPs/LIRs at this
time and it is generally admitted that one prefix per LIR
would remain a reasonably manageable number even in the
long run. End-sites will likely require a multihoming
solution that is aggregatable.

                       _   ____  __      __  ____   _    _   _    _
Michel Py             | | |  _ \ \ \    / / / ___| | \  / | | |  | |
Sr. Network Engineer  | | | |_| | \ \  / / | |__   |  \/  | | |__| |
CNE, MCSE, CNP        | | |  __/   \ \/ /  |  _ \  | \  / | |  __  |
CCIE #6673            | | | |       \  /   | |_| | | |\/| | | |  | |
[email-masked]          |_| |_|        \/     \___/  |_|  |_| |_|  |_|

                        http://arneill-py.sacramento.ca.us/ipv6mh

---

From: "Michel Py" <[email-masked]>
Date: Sat, 31 Aug 2002 09:09:29 -0700

> Caitlin Bestler wrote:
> The potential mismatch between IPv6 and classic DNS
> is that an IPv6 unicast address is structured in two
> parts: the network identifier (the high 64 bits) and
> an Interface ID (the low 64 bits).

This is equally true for IPv4: The network part, whose bits are "1"s in
the subnet mask, and the host part, whose bits are "0"s in the subnet
mask.

> Half of the Interface IDs are globally unique, the
> other half are assigned locally within the network.

I wonder where you got that from. The entire IID is assigned with EUI-64
and we just had a long thread on the ipv6 list about not using it for
routing purposes.

> For the half that are globally unique, a query system
> could be defined to look up that address and return
> the network(s) where it was found.

This likely creates a circular reference: routing is required for DNS to
work; therefore routing should not depend on DNS.

Michel.