Subject: Eating our own Dog Food...could the IAB and IESG use SIP for conference calls

From: Richard Shockey <[email-masked]>
Date: Mon, 24 Mar 2003 19:04:17 -0500

Like many of us I was moved my Harald's appeal for suggestions for helping 
to cut down costs in the IETF.

I certainly endorse the idea of considering Canada or Mexico as possible 
sites for future IETF meetings, but I suspect that the weekly teleconferece 
calls that the IAB and IESG have represent a significant line item for the 
Secretariat.

In case anyone has not heard, SIP is quite capable of handling this type of 
task and there are a variety of commercial as well as open source Client 
User Agents as well as commercial products and services that could help 
reduce this cost.

I'm sure the SIP working group could help the Secretariat identify products 
and services that could make this essential function more productive and 
operate at less cost.

Richard Shockey, Senior Manager, Strategic Technology Initiatives
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 815.333.1237
<mailto:[email-masked]> or <mailto:[email-masked]>
  <http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: "Jim Fleming" <[email-masked]>
Date: Tue, 25 Mar 2003 09:05:45 -0600

Do you think that Americans are interested in continuing to eat the dog food fed to them by the I* society ?

http://www.ietf.org/internet-drafts/draft-ietf-ipr-technology-rights-03.txt
S. Bradner
"The policies are also intended to benefit the Internet community
and the public at large, while respecting the legitimate rights of IPR holders."
=====

The I* society (small s...aka The Big Lie Society) does not appear to respect anyone's rights.
The I* society simply takes what it wants, does not reference other people's work (prior art, etc.),
and attempts to do ethnic cleansing on networks to only allow economic advantage to flow to their insiders...
Via censorship and control of the media and the view presented to governments, the I* society attempts
to shape history to match their reality...which is not the truth...

Educated and enlightened people learn the truth and pass it on from one generation to the next...
...the I* society has yet to figure out a way to control what is in all people's meatspace brains...
Truth-seeking people have to protect themselves and route around the dictatorial regimes of the I* society...
The InterNAT is one of the first steps in setting up that protection...
===================================
===================================
===================================

----- Original Message ----- 
From: <[email-masked]>
To: <IETF-Announce:>
Cc: <[email-masked]>
Sent: Tuesday, March 25, 2003 7:12 AM
Subject: I-D ACTION:draft-ietf-ipr-technology-rights-03.txt

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Intellectual Property Rights Working Group of the IETF.
> 
> Title : Intellectual Property Rights in IETF Technology
> Author(s) : S. Bradner
> Filename : draft-ietf-ipr-technology-rights-03.txt
> Pages : 14
> Date : 2003-3-24
> 
> The IETF policies about intellectual property rights (IPR), such as
> patent rights, relative to technologies developed in the IETF are
> designed to ensure that IETF working groups and participants have as
> much information about any IPR constraints on a technical proposal as
> possible.  The policies are also intended to benefit the Internet
> community and the public at large, while respecting the legitimate
> rights of IPR holders.  This memo details the IETF policies
> concerning IPR related to technology worked on within the IETF. It
> also describes the objectives that the policies are designed to meet.
> This memo updates RFC 2026 and, with RFC XXXY, replaces Section 10 of
> RFC 2026. [note to RFC editor - replace XXXY with number of IETF SUB]
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-ipr-technology-rights-03.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-ietf-ipr-technology-rights-03.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-ietf-ipr-technology-rights-03.txt".
> 
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 25 Mar 2003 08:46:23 -0600

There are excellent SIP voice conferencing bridges available, such as
from snom AG and eDial. They can be used with various soft clients such
as the Windows Messenger, HotSIP Active Contacts or the Pingtel instant
expressa, or any SIP phone.

I have taken the liberty of copying here the contacts for snom AG and
eDial, in case this will be pursued. I wonder if snom AG or eDial would
just give the IESG and IAB access to their conference servers?

Would there be interest to have access to a WorldCom SIP conference
bridge?

Thanks, Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Richard Shockey
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Sip] Eating our own Dog Food...could the IAB and 
> IESG use SIP for conference calls
> 
> 
> 
> Richard Shockey, Senior Manager, Strategic Technology 
> Initiatives NeuStar Inc.
> Voice +1 571.434.5651 Cell : +1 314.503.0640,  Fax: +1 
> 815.333.1237 > <mailto:[email-masked]> or 
> 
<mailto:[email-masked]>
  <http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: Jiri Kuthan <[email-masked]>
Date: Tue, 25 Mar 2003 16:01:10 +0100

That's great idea. We can help with our free SIP server (www.iptel.org/ser/) 
and hosting the services.

-Jiri

At 03:46 PM 3/25/2003, Henry Sinnreich wrote:
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip

---

From: "Christopher Allen" <[email-masked]>
Date: Tue, 25 Mar 2003 08:30:30 -0800

Richard Shockey <[email-masked]> wrote:
> Like many of us I was moved my Harald's appeal for suggestions for
> helping to cut down costs in the IETF.
>
> I certainly endorse the idea of considering Canada or Mexico as
> possible sites for future IETF meetings, but I suspect that the
> weekly teleconferece calls that the IAB and IESG have represent a
> significant line item for the Secretariat.
>
> In case anyone has not heard, SIP is quite capable of handling this
> type of task and there are a variety of commercial as well as open
> source Client User Agents as well as commercial products and services
> that could help reduce this cost.
>
> I'm sure the SIP working group could help the Secretariat identify
> products and services that could make this essential function more
> productive and operate at less cost.

Bill Woodock of Packet Clearing House <[email-masked]> has set up a SIP network
where you dial an ASN (and optionally an extension) that will ring various NOCs.
Currently they are using Cisco phones, but there is no reason why software SIP
based phones shouldn't work as well.

http://www.pch.net/inoc-dba/

~-~
INTER-NOC HOTLINE PHONE SYSTEM
Packet Clearing House operates the Inter-Network Operations Center Dial-By-ASN
(INOC-DBA) hotline phone system, a global voice telephony network that connects
the network operations centers and security incident response teams of critical
Internet infrastructure providers such as backbone carriers, Internet service
providers, and Internet exchanges as well as critical individuals within the
policy, regulatory, Internet governance, security and vendor communities. The
INOC-DBA is a closed system, ensuring secure and authenticated communications,
and uses a combination of highly redundant directory services and direct
peer-to-peer communications between stations to create a resilient,
high-survivability network. It carries both routine operational traffic and
emergency-response traffic.
~-~

It may make sense to have the IESG members to have access to this emergency
network in general, besides for its use in IESG business.

I don't believe at this point that they have conferencing services available,
only point-to-point calls, but I'm fairly certain from some discussions that
I've had with some SIP conferencing tool vendors that we should be able to get
them to donate those services as well. We might even be able to get Cisco to
donate some phones.

-- Christopher Allen

----------------------------------------------------------------------
.. Christopher Allen                            Alacrity Management ..
.. <ChristopherA at AlacrityManagement.com>   1563 Solano Ave. #353 ..
.. o510/649-4030  f510/649-4034                  Berkeley, CA 94707 ..

---

From: "RL 'Bob' Morgan" <[email-masked]>
Date: Tue, 25 Mar 2003 09:37:00 -0800 (PST)

On Mon, 24 Mar 2003, Richard Shockey wrote:

> sites for future IETF meetings, but I suspect that the weekly
> teleconferece calls that the IAB and IESG have represent a significant
> line item for the Secretariat.
>
> In case anyone has not heard, SIP is quite capable of handling this type
> of task and there are a variety of commercial as well as open source
> Client User Agents as well as commercial products and services that
> could help reduce this cost.

Are there existence proofs of IETF-style WGs conferencing via SIP these
days?  I don't know anything about these services, but it seems to me that
to be practical, a SIP-capable conf call service would also have to
support plain-old telephony callers as well.

 - RL "Bob"

---

From: "Dan Freedman" <[email-masked]>
Date: Tue, 25 Mar 2003 08:43:59 -0700

Agreed. To enable access from behind firewalls (ie: homes, hotels,
conferences, airports, Asia, ...), we can donate a B2BUA-based NAT traversal
solution for SIP (same one that Pulver's Free World Dialup uses). It sits
near the proxy, with nothing needed on the client end.

Bottom line: In addition to helping the IESG and IAB, it will help SIP to
have more IETF participants gaining experience with it.

  -Dan

Dan Freedman, CEO, Jasomi Networks, Inc.
2033 Gateway Place, Suite 500, San Jose, CA, 95110
Phone   +1.403.680.2351
Fax     +1.403.269.2993
Email   [email-masked]
SIP     [email-masked]
Web     www.jasomi.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Jiri
Kuthan
Sent: Tuesday, March 25, 2003 8:01 AM
To: Henry Sinnreich; 'Richard Shockey'; [email-masked]
Cc: [email-masked]; Scott Petrack; Christian Stredicke

-Jiri

At 03:46 PM 3/25/2003, Henry Sinnreich wrote:
>> teleconferece

---

From: Bill Woodcock <[email-masked]>
Date: Tue, 25 Mar 2003 08:33:30 -0800 (PST)

> based phones shouldn't work as well.

Actually, only about three-quarters of the phones are Ciscos, to the best
of my knowledge; meaning that there are more than a hundred non-Cisco
(mostly open-source software) phones on the network as well.

A lot of the IAB and IESG folks are already on the INOC network.  Should
we put some effort into getting the remainder (and newly-appointed) folks
on as well?

                                -Bill

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 25 Mar 2003 20:13:37 +0100

Thanks for the idea!
injecting a slight dash of cold water....

- the actual cost of "Teleconferences and Long Distance charges" in 2002 
were USD 82.210 (unaudited) (vs 54.400 for 2001). A significant fraction of 
that, but far from all, is the IESG teleconferences.
- we've already switched teleconference providers once to reduce costs, 
going from call-everyone to most-people-call-in.
- the costliest part of the IESG teleconferences has been the callout: 
international participants (last year, France, the Netherlands, Norway and 
Sweden when they are at home, hotels literally anywhere in the world when 
they are travelling) are called rather than calling in. You don't want to 
discuss with your boss why you had to make a 2 1/2 hour international call 
at hotel room rates if you can avoid it......
- it's absolutely essential that one be able to participate in the IESG 
telecon from just about anything that one can dial from - we've had 
participants on cellphones from trains, in airport lounges, hotel rooms and 
other places. So SIP-only won't work for some time yet.
- even at work, several of us have problems with firewalls; about half the 
IESG uses Jabber during sessions - the reason many of the others don't is 
that they can't get Jabber through their corporate firewalls. So "pure 
Internet SIP" won't work for all of us any time soon.

So I think this is a good idea, PROVIDED THAT:

- The SIP teleconference bridge provider is able to provide either 
800-number access or callout services to normal telephones in most corners 
of the world
- The voice quality, operator quality and call stability is competitive 
(yes, we've got the "there's an echo on this conference - can you figure 
out who is echoing and fix it" request down to a matter of routine)

A "normal" teleconference provider that *also* allows SIP dialin over the 
Internet would probably be perfect. If you have one - send email to me - 
PRIVATELY - and I will forward to the relevant parties at the secretariat.

               Harald

--On mandag, mars 24, 2003 19:04:17 -0500 Richard Shockey 
<[email-masked]> wrote:

> Client User Agents as well as commercial products and services that could
> help reduce this cost.
>

---

From: "Jim Fleming" <[email-masked]>
Date: Tue, 25 Mar 2003 14:15:51 -0600

NAT traversal....????

http://www.spectrum.ieee.org/select/1098/int.html
NATs are a no-no
HEATH: I was going to say that IEEE Spectrum should make it very clear that this group's consensus would appear to be: let's
discourage NATs--I mean the manufacture of them at all--because there is a real need for IPv6.

HUITEMA: It's more than that. There is a real need for security and you can't have security with NATs.

CERF: NAT is a guaranteed spoofing box in effect.

============================================================

----- Original Message ----- 
From: "Dan Freedman" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 25, 2003 9:43 AM
Subject: RE: [Sip] Eating our own Dog Food...could the IAB and IESG use SIP for conference calls

  -Dan

-----Original Message-----

-Jiri

---

From: "Dan Freedman" <[email-masked]>
Date: Tue, 25 Mar 2003 14:10:28 -0700

I agree - much better if you don't have NAT. 

I'm not qualified to discuss the best way to accelerate the advantages that
the Internet brings to everyone's lives while simultaneously encouraging
people to move to IPv6. But if the powers-that-be wish there to be a VoIP
solution that supports people who, through no fault of their own, find
themselves behind NAT (ie: at hotels, etc.), then we're happy to provide the
solution. If not, then at least we might all benefit from the resulting
debate.

	Dan

Dan Freedman, CEO, Jasomi Networks, Inc.
2033 Gateway Place, Suite 500, San Jose, CA, 95110
Phone +1.403.680.2351
Fax      +1.403.269.2993
Email   [email-masked]
Web    www.jasomi.com

-----Original Message-----
From: Jim Fleming [mailto:[email-masked]] 
Sent: Tuesday, March 25, 2003 1:16 PM
To: [email-masked]; [email-masked]

NAT traversal....????

http://www.spectrum.ieee.org/select/1098/int.html
NATs are a no-no
HEATH: I was going to say that IEEE Spectrum should make it very clear that
this group's consensus would appear to be: let's
discourage NATs--I mean the manufacture of them at all--because there is a
real need for IPv6.

HUITEMA: It's more than that. There is a real need for security and you
can't have security with NATs.

----- Original Message ----- 
From: "Dan Freedman" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, March 25, 2003 9:43 AM
Subject: RE: [Sip] Eating our own Dog Food...could the IAB and IESG use SIP
for conference calls

  -Dan

-----Original Message-----

-Jiri

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 25 Mar 2003 16:36:14 -0600

>So "pure Internet SIP" won't work for all of us any time soon.

Glad to clear up the confusion on this point. People on the PSTN can
dial in and can be called from the SIP conferencing server by using a
service provider that has standard PSTN-SIP gateways. The typical SIP
voice conference has both PSTN users and SIP users. Works quite well for
everybody.

IM can also be used at the same time, by those who prefer it to real
time voice. Several SIP clients do both, actually video and data as
well.

Thanks, Henry

> Behalf Of Harald Tveit Alvestrand
> Sent: Tuesday, March 25, 2003 1:14 PM
> To: Richard Shockey; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sip] Eating our own Dog Food...could the IAB 
> and IESG use SIP for conference calls
> 
> 
> Thanks for the idea!
> > possible sites for future IETF meetings, but I suspect that 
> the weekly 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: S Woodside <[email-masked]>
Date: Wed, 26 Mar 2003 15:15:12 -0500

To connect VoIP with my other email. One of the most interested user 
groups for fixed wireless networks is people with no telecomms 
infrastructure to speak of. That is to say, much of the developing 
world. In these places VoIP is a very popular application for a few 
reasons ... first because there might not be PSTN available, and even 
if it is, because it makes international calls affordable (e.g. to 
relatives in more affluent places), and finally because illiteracy 
prevents people from user email and other lower-bandwidth apps.

simon

--
www.simonwoodside.com -- 99% Devil, 1% Angel