Subject: RE: beauty of freedom

From: "Spencer Dawkins" <[email-masked]>
Date: Wed, 5 Mar 2003 09:59:28 -0600

I remember when telephony vendors sold 

o calling line ID (CLID) as a feature, and then 
o call blocking based on CLID as a feature, and then
o CLID delivery supression as a feature, and then
o call blocking for anonymous calls as a feature, and then ...

It's great to have guarenteed lifetime employment for
software developers, but are we sure spam plus spam
supression is making the world a better place?

Spencer, half :-}

> -----Original Message-----
> From: Bill Cunningham [mailto:[email-masked]]
> Sent: Wednesday, March 05, 2003 6:32 AM
> To: [email-masked]
> Subject: beauty of freedom
> 
> 
> Just something to throw out....
> 
> I was browsing an ftp site a few days ago and came across 
> some interesting
> downloads that got me thinking.
> 
> On the same site (and the same page) I saw a piece of 
> software to abtain
> email addresses to send of spam :O , and on the same page, a 
> filter to block
> spam. With all this talk of stopping spam, isn't some good 
> spam blocking
> good enough?
> 
> 
> 
> 
> _______________________________________________
> This message was passed through 
> [email-masked], which is a sublist of 
> [email-masked]. Not all messages are passed. Decisions on what 
> to pass are made solely by Raffaele D'Albenzio.
>

---

From: Melinda Shore <[email-masked]>
Date: Tue, 11 Mar 2003 14:25:45 -0500

> supression is making the world a better place?

This is a tremendous problem in firewall-land, where there's
a continuing arms race that's moving firewall functionality
further and further up the stack.  Entities like port
numbers and IP addresses are terrible descriptors of higher
level policy, but on the other hand increasing use of
encryption across firewall traversal points is rendering
traffic content inspection useless (that's a good thing).

On a third hand, service providers want to be able to
concentrate service management function in their own
networks, and you'll notice that at this upcoming meeting,
in addition to the OPES working group, there are two BOF
(pads and intersec) that are dealing with this issue to a
greater or lesser extent.  The tension between trying to
provide those services in a way that's both secure and
architecturally sound and trying to maintain some level of
end-to-end integrity is a pretty serious problem for the
IETF right now.  

I'd like to hope that any lessons we've learned from
firewalls about bad design leading to escalation and
ultimately failure in the face of technology short can be
applied to spam protection, too.

Melinda