Subject: callplot tool for generating call flows

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 18 Mar 2004 12:45:31 -0500

One of the challenges in producing an Internet Draft is the creation of 
ASCII art call flow diagrams (aka sequence diagrams), such as those in 
http://www.ietf.org/rfc/rfc3665.txt. I tend to do a lot of these in the 
drafts I write.

To make the process easier, a colleague of mine, Dave Ladd, wrote a tool 
called callplot. Callplot takes a source file that describes the 
callflow, and then compiles it into an ASCII art version suitable for 
inclusion in Internet drafts. It does automatic message numbering, 
labeling, and so on. It can also spit out other formats that can be 
included in MS Office documents, for example.

To illustrate, running callplot on this input:

opt/columnPitch/15
guy/f/Fred
guy/b/Barney
f->b/Please
note/b/Gives bowling ball
b->f/Stuff
b..f/RTP
f->b/Thank You
b->f/You're Welcome

produces this diagram:

         Fred          Barney
           |              |
           |              |
           |              |
           |Please        |
           |------------->|
           |              |
           |              |
           |              |Gives bowling ball
           |              |
           |              |
           |              |
           |Stuff         |
           |<-------------|
           |              |
           |              |
           |RTP           |
           |..............|
           |              |
           |              |
           |Thank You     |
           |------------->|
           |              |
           |              |
           |You're Welcome|
           |<-------------|
           |              |
           |              |
           |              |
           |              |

I think this tool would be useful to the IETF community at large. As a 
result, we've decided to make the tool open source, available at 
sourceforge at:

http://sourceforge.net/projects/callplot

Callplot is written in Java. Please feel free to download, use, and 
provide improvements on this tool.

Thanks,
Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 24 Mar 2004 14:04:29 -0800

Thank you, Jonathan!

I think this is a good example of "community problem solving" - solve it 
once, share, and it's solved for all of us!

              Harald

--On 18. mars 2004 12:45 -0500 Jonathan Rosenberg <[email-masked]> 
wrote:

> _______________________________________________
> This message was passed through [email-masked], which
> is a sublist of [email-masked]. Not all messages are passed. Decisions on
> what to pass are made solely by IETF_CENSORED ML Administrator
> ([email-masked]).
>
>

---

From: "Felix, Zhang" <[email-masked]>
Date: Thu, 25 Mar 2004 09:12:25 +0800

It's really a great job, but I can't download the software from the following address, http://sourceforge.net/projects/callplot

who can do me a favor to send me a copy.

---

From: Ross Finlayson <[email-masked]>
Date: Wed, 24 Mar 2004 18:09:40 -0800

At 05:12 PM 3/24/04, Felix, Zhang wrote:
>It's really a great job, but I can't download the software from the 
>following address, http://sourceforge.net/projects/callplot

FYI, this is because the Chinese government's firewall apparently blocks 
access to the whole of "sourceforge.net".  Apparently, there's something 
'subversive' there :-(

         Ross.

---

From: "Jeroen Massar" <[email-masked]>
Date: Thu, 25 Mar 2004 03:31:50 +0100

Ross Finlayson wrote:

> FYI, this is because the Chinese government's firewall 
> apparently blocks access to the whole of "sourceforge.net".  Apparently, 
> there's something 'subversive' there :-(

Then I guess the solution is to start using IPv6 and use
IPv6gate (http://ipv6gate.sixxs.net) already used by many
chinese people who are using IPv6. At least Asian sites
seem to be the biggest users of the thing as they are able
to read all IPv4 sites that are blocked ;)

[insert slogan: IPv6: Freedom to the people ]

Greets,
 Jeroen

---

From: "Felix, Zhang" <[email-masked]>
Date: Thu, 25 Mar 2004 10:49:40 +0800

so who can send me a copy, I will upload to my personal website and then share with all Chinese delegates.

Thanks ahead.