Subject: Re: survey on Friday IETF sessions

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 01 Aug 2004 11:30:34 -0700

Simon Leinen wrote:

>>this error could be due to the fact that I did not attend Seoul but
>>did attned MPLS and will attend SD. [...]
>>    
>>
>
>maybe not - I also got such an error, although I did attend both
>IETF58 and 59.  Looks like a file permission problem.
>  
>
It was a file permission problem, caused by a broken install script 
which munged a
heap of file permissions.  Occured just a couple of days ago, so 
shouldn't be the reason for the
response numbers.  If you look at the "Responses over time" page, it's 
pretty clear that the
response numbers have already petered out some time ago.

Anyway, the problem is fixed now.

    Henrik

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Simon Leinen <[email-masked]>
Date: Sun, 01 Aug 2004 19:30:41 +0200

Bill Manning writes:
> perhaps the reason there has not been more participation in your survey is
> associated w/ the following:

> "A problem occurred in a Python script. Here is the sequence of
> function calls leading up to the error, in the order they occurred."

Regards,
-- 
Simon.

 /www/cgi-bin/pyht.py
  313 #                except:
  314 #                    cachefile = None
  315         include(filename)
  316 #            print "<!-- Cache out of date (cache: %s - dir: %s)  -->" % (timestr(filetime(cachename)), timestr(dirtime(".")))
  317 #            if not cachefile:
include = <function include>, filename = '/www/ietf/survey/attendance/index.pyht'

 /www/cgi-bin/pyht.py in include(filename='/www/ietf/survey/attendance/index.pyht')
  215 
  216                     if string.find(code, "\n") > -1:
  217                         exec code in execglobals, execlocals
  218                     else:
  219                         res = eval(code, execglobals, execlocals)
code = '\nimport re, time, sys, string\n\nif "submit" in ...wresults("index.survey", tally("index.survey"))\n\n', global execglobals = {'__builtins__': <module '__builtin__' (built-in)>, 'args': {'attend-friday-afternoon': 'maybe (depends on the meeting)', 'attend-friday-evening': 'maybe (depends on the meeting)', 'attend-friday-morning': 'maybe (depends on the meeting)', 'contributor-58': 'I had no conflicts for groups I contributed to.', 'contributor-59': 'I had no conflicts for groups I contributed to.', 'how-schedule': 'attend the whole meeting?', 'ietf58-arrival': 'Before Sunday', 'ietf58-departure': 'Fri AM', 'ietf59-arrival': 'Sun AM', 'ietf59-departure': 'Fri AM', ...}, 'basename': <function basename>, 'dirname': <function dirname>, 'env': {'REDIRECT_UNIQUE_ID': 'QQ0nxNVArsMAAEZKlog', 'H...g', 'PATH_INFO': '/survey/attendance/index.pyht'}, 'escape': <function <lambda>>, 'filetext': <function filetext>, 'filetime': <function filetime>, 'form': FieldStorage(None, None, [MiniFieldStorage('surv...iFieldStorage('submit', 'Submit Questionnaire')]), 'header': <function header>, ...}, execlocals = {'Area': 'Attendance', 'Formname': '', '__name__': 'embedded-code-at-line-50', 'area': 'attendance', 'base': 'index', 'datenow': '01 Aug 2004 17:26', 'ext': '.survey', 'filebase': 'index', 'filedate': <function filedate>, 'fileext': '.pyht', ...}

 /home/www/subj/job/ietf/survey/attendance/<string>

IOError: [Errno 13] Permission denied: 'index-130.129.128.233.result'
      args = (13, 'Permission denied')
      errno = 13
      filename = 'index-130.129.128.233.result'
      strerror = 'Permission denied'

---

From: John C Klensin <[email-masked]>
Date: Fri, 06 Aug 2004 21:31:13 -0400

IMPORTANT! This message has been blind-carbon-copied to you.
Do not reply-to-all or forward it without the author's 
permission.

An additional thought about Friday meetings that the survey 
doesn't capture...

Whether the problem is "Friday" or "after four days", our 
meetings are intense enough that many of the people who are 
participating in several WGs, the plenaries, etc., end up in a 
state by Friday such that they aren't real functional (terms 
like "wasted" and "zombie" come to mind).  Especially since that 
high-activity group includes all, or almost all, of the IAB and 
IESG, Friday sessions seem to have rather low productivity or at 
least discussions that are unusually risky in terms of reaching 
well-thought-out conclusions.

Many years ago, we tried having the IESG meet Friday mornings 
(in a meeting slot) to give them an opportunity to reprise the 
week, identify issues, make plans, highlight things needing 
cross-area attention, etc.   We finally gave it up after 
noticing that we spent a lot of time staring at each other, 
unable to form complete sentences and showing other signs of 
mental exhaustion.

Unless we can figure out a way to reduce the level of exhaustion 
that comes with our present schedule, I'd question the 
productivity of adding a full extra day, even if no other 
considerations applied.  For example, I've not in favor of it, 
but Friday (or fifth-day) sessions would make a lot more sense 
to me if we dropped all evening sessions, including the 
plenaries, and moved them into the daytime.

Or perhaps I'm just getting old :-(

      john