Subject: admin director (was The other parts of the report..)

From: [email-masked] (scott bradner)
Date: Fri, 10 Sep 2004 08:49:53 -0400 (EDT)

imo we should start a search for a Administrative Director now

Scott

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Scott W Brim <[email-masked]>
Date: Fri, 10 Sep 2004 09:29:38 -0400

> imo we should start a search for a Administrative Director now

Does it have to be a hire, or can it be contracted, like anything else?

---

From: John C Klensin <[email-masked]>
Date: Fri, 10 Sep 2004 10:07:57 -0400

> imo we should start a search for a Administrative Director now

Good idea, except...

	* We have only the vaguest of job descriptions
	
	* We don't know who the individual would actually be
	working for organizationally, which could make a
	difference in who would be interested
	
	* We don't know enough about organizational structure to
	be able to have a serious discussion about benefits,
	etc., which could make a difference.  We don't even
	know, for sure, if we have budget for salary, since that
	presumably would need to be approved by the Board of
	ISOC and/or the hypothetical foundation.
	
	* We can't make any assurances about how long the job
	commitment is good for, because we don't have a
	structure to put around it.  

And, with regard to the "contractor" question, there are two
ways of doing "contractor":

	(1) The individual is hired as an independent
	contractor, and hence is responsible for his or her own
	insurance, benefits, taxes, etc., but is otherwise
	essentially an employee.  In particular, we select the
	individual who is going to be in the role.  The problem
	with those models is that sometimes the taxing
	authorities don't like them and pronounce words that, in
	US-speak are "statutory employee".  Those are _very_ bad
	words; for an explanation contact your friendly attorney
	or accountant.
	
	(2) We hire a company to supply us someone.  Problem is
	that, at the bottom line, they pick the someone. 

Neither of these are consistent with the level of control which
the IETF leadership (or their spokespeople) think they need.  Of
course, that is another unresolved issue.

Sorry.

      john

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 Sep 2004 16:55:09 +0200

We have to bootstrap somehow. Asking ISOC to hire someone, on
a fixed term contract of employment, would work for me. Of course,
the team that searches for and interviews the candidates has to
start by writing a job description.

     Brian

---

From: John C Klensin <[email-masked]>
Date: Mon, 13 Sep 2004 12:25:17 -0400

Brian,

Based on the experiences of the last month or so, I'm not
enthused --to put it mildly-- to put "write a job description"
into the hands of a committee appointed by unknown methods, with
an unknown set of instructions, and supervised by groups who
have no obvious charter (or experience) for this type of work.
You may well be right that "the person" is important, but I
think the current environment is going to make it hard to hire
the right person, or to have confidence that we have done so,
especially with all of the surrounding uncertainty about
structure and mission.  

The notion that we are going to hire this person in parallel
with writing and getting proposals on RFPs that he or she will
have to manage also makes no organization sense to me.   Before,
so that the person can participate in the RFP effort (which I
think was the original plan) makes sense.  After, so the person
taking the job understands what he or she has to work with...
maybe not ideal, but workable.  But "in parallel" is the sort of
thing that, IMO, would cause anyone competent, experienced, and
who understands the issues to be extremely reluctant to consider
the job.  And I can't believe that we want to bias the selection
process against the competent, experience, and comprehending.

So, if "be specific about what this job is about" is going to be
delegated from "community review and approval of a proposal that
is presumably based on Carl's report" to "a team that writes a
job description", then I think the community needs to review and
approve that job description before any hiring effort starts.

Otherwise, we seem to be sliding backwards into these decisions.
And that just is not, IMO, the way to work through a "you bet
the entire future of the IETF" process.

    john

--On Monday, 13 September, 2004 16:55 +0200 Brian E Carpenter
<[email-masked]> wrote:

>> Neither of these are consistent with the level of control
>> which the IETF leadership (or their spokespeople) think they
>> need.  Of course, that is another unresolved issue.
>> 
>> Sorry.
>> 
>>       john
>> 
>>

---

From: Carl Malamud <[email-masked]>
Date: Mon, 13 Sep 2004 11:12:14 -0700 (PDT)

> approve that job description before any hiring effort starts.

There is a sample job description in Appendix E.  It is written in
a certain style, and I know there are other ways to write job
descriptions.  If somebody else wnats to take a crack at it, that
would be great.  I'm working on an -02 rev and comments are most
welcome.

Regards,

Carl

---

From: "Soininen Jonne (Nokia-NET/Helsinki)" <[email-masked]>
Date: Tue, 14 Sep 2004 16:14:42 +0300

Hello everybody,

I think before proceeding with hiring a person we should have a bit more
discussion on the responsibilities and tasks for the admin director. I
think Carl's proposal is a good first cut on these. However, it is just
that.

On the actual proposal, I was wondering if the current job description,
which seems to be more of a draft announcement, is basically bit too
concentrated on the meeting part responsibilities. I think we also have
things like IETF tools etc. of which the admin director should be
somewhat responsible.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Sep 2004 11:18:00 +0200

John,

I fully agree. To me the only sequence of events that makes sense is

1. Agree on the job description. (But it needs to drafted by a small
group first.)

2. Ask ISOC to fund a position for 1 year, and hire someone. (But
the IETF leadership has to be intimately involved in the
hiring process.)

3. Have the new person develop a budget model and the RFP. (But
the IETF community gets to review the draft RFP.)

4. Worry about whether to create a separate legal entity later.

    Brian

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 15 Sep 2004 12:01:02 +0200

Brian,

your timeline looks very deliberate and formally correct.
However, I worry about the ability of the IETF to work constructively while 
knowing that its future is still in flux for that long.

So I put some dates in.

> 1. Agree on the job description. (But it needs to drafted by a small

September/October 2004. We have a draft job description in appendix E of 
the report, and very few (no?) specific comments on that draft.

> the IETF leadership has to be intimately involved in the

Budget approval: October/November. Not a problem, I think.
If search takes 3 months: February 2005 for the hire.

> the IETF community gets to review the draft RFP.)

If the person does not know the IETF intimately: May 2005 (3 months).
Considerably shorter if person accepts previous work - but that runs into 
almost the same issues as "RFP sent out before hire".

Contracts: Fall 2005.

> 4. Worry about whether to create a separate legal entity later.

2006?

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 15 Sep 2004 12:46:32 +0200

--On tirsdag, september 14, 2004 16:14:42 +0300 "Soininen Jonne 

> things like IETF tools etc. of which the admin director should be

Appendix E is a draft call for applications, of which half is the job 
description, so it's no surprise it reads like a draft announcement :-)

The job description is:

You will be expected to:
   o  Serve as the day-to-day chief operating officer of the IETF,
      managing a number of contractors and working with a number of
      volunteers.
   o  Provide primary support for budgeting and financial reporting
      processes.
   o  Serve as the primary staff resource for the governing body of the
      administrative entity for the IETF.
   o  Work with your contractors and members of the IETF community to
      provide adequate support and planning for 3 IETF meetings
      annually, and for frequent meetings and teleconferences of the
      IAB, IESG, and other bodies that support the IETF.
   o  Work with our liaison organizations, such as the RFC Editor and
      the IANA.
   o  Coordinate the standards-making support process, in particular the
      periodic meetings of the IESG.

Only one of these bullets (the fourth) touches on the meeting stuff. I 
don't think it is possible to say less than that.

I have some other specific comments:

- I don't believe the RFC Editor and IANA are liaison organizations. ICANN 
is a liaison organization, but the IETF IANA function is work done under an 
MoU, and the RFC-Editor is doing work under contract.
I'd rephrase this as:
"Work with the organizations responsible for RFC publication and parameter 
registration, maintaining their contract relationship and coordination with 
the other functions of the IETF".

- I believe the "coordinate.... the periodic meetings of the IESG" is part 
of the work that should be done by the "clerk's office" under contract, so 
I don't believe that belongs in the job description as written either. I'd 
just stop the sentence after the comma.

But your mileage (and expectations of this person) may vary....