Subject: Re: [dnsop] Re: Root Anycast (fwd)

From: Dean Anderson <[email-masked]>
Date: Thu, 30 Sep 2004 20:31:52 -0400 (EDT)

The following message pretty clearly illustrates the frivolous nature of
John Brown's "dispute", as he is quite well aware that DNSSEC requires TCP
queries of the root servers, and in fact has been //advocating// for it.  
And he is also aware of other upcoming technologies and developments that
will both increase the size of the packets and hence increase the number
of TCP connections made on the root servers.

It is completely frivolous to claim that 'DNS queries are "mostly UDP",
and that we need not worry about TCP queries'.  We already know that at
present and historically that UDP is the common case.  Taking cheap shots
in frivolous disputes is no way to work on problems.

		--Dean

---------- Forwarded message ----------
Date: Mon, 14 Oct 2002 23:57:00 -0600
From: John M. Brown <[email-masked]>
To: 'Masataka Ohta' <[email-masked]>,
     "'Loomis, Rip'" <[email-masked]>
Cc: [email-masked]
Subject: RE: Interim signing of the root zone.

anycast root opens the root system up to more capture,
even if its localized capture, its still capture.

Who decides on who can "anycast" the zone and how do
we know its the right zone ?

signing the root, by whatever means is decided upon, helps
assure that the data is in fact "the original stuff".

If the country of Futuro (make believe) decides to run its
own "root" via an anycast system, and they change the
NS RR set for .JP, how are users going to know that?

maybe I'm just naive.....

john brown

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Masataka Ohta
> Sent: Monday, October 14, 2002 10:31 PM
> To: Loomis, Rip
> Cc: [email-masked]'
> Subject: Re: Interim signing of the root zone.
> 
> 
> Rip
> 
> > > > as dnssec is finally approaching deployment, it seems  imprudent to 
> > > > rush into a not obviously critical anycast deployment when a 
> > > > little patience would seem harmless.
> > 
> > > DNSSEC, or any CA-based security, is not really secure and is 
> > > undeployable for any practical security.
> > 
> > With all due respect, you've made such claims/statements on  the list 
> > before,
> 
> And the only counter argument was:
> 
> 	My teacher taught me differently, I think.
> 
> > Please feel free to back up that opinion
> > with fact, or don't waste peoples' time with it.
> 
> If security is compromized, who pays how much?
> 
> Have you ever checked the reality of terms and conditions of CAs?
> 
> > Better yet, if you think things are slightly broken then propose a
> > fix. If you think things are *very* broken then propose a workable
> > alternative and explain why things are so broken.
> 
> The current DNS is working well with weak security replying on ISPs.
> 
> Those who need additional security should share a secret end 
> to end without introducing intellignet intermediate entities of CAs.
> 
> So, I don't think I have to propose a workable alternative.
> 
> Nonetheless, I proposed anycast root, which improves security 
> against spoofed route.
> 
> On the other hand, DNSSEC is unworkable as evidenced by the 
> failed deployment attempt for so many years.
> 
> Observing the failure, I gave an explanation why it is hopeless.
> 
> 							Masataka Ohta
> #-------------------------------------------------------------
> ---------
> # To unsubscripbe, send a message to <[email-masked]>.
> 

#----------------------------------------------------------------------
# To unsubscripbe, send a message to <[email-masked]>.

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Dean Anderson <[email-masked]>
Date: Thu, 30 Sep 2004 20:59:53 -0400 (EDT)

On Thu, 30 Sep 2004, Jim Reid wrote:

> >>>>> "Iljitsch" == Iljitsch van Beijnum <[email-masked]> writes:
> 
>     Iljitsch> I think the ship has sailed a long time on whether this
>     Iljitsch> was going to happen at all. However, now would be a good
>     Iljitsch> time to start a discussion on how much anycasting is
>     Iljitsch> enough. It would be good to keep a reasonable number of
>     Iljitsch> root servers non-anycasted.
> 
> The usual good sense and wise judgement of the root server operators
> will see that this happens anyway. I doubt if there's any group of
> people who are more sensitive to avoiding single points of failure.

Lack of "Good sense and wise judgement" is one of the principal problems
that got anycast deployed without adequate discussion.  Then we could talk
about incompatible and undiscussed AXFR modifications, childish personal
attacks, etc, etc, etc that also demonstrate bad judgement and bad sense.

		--Dean