Subject: Re: Re: MARID back from the grave?

From: John Loughney <[email-masked]>
Date: Sun, 27 Feb 2005 8:23:58 +0200

Hi Keith,

Working groups have a charter, which I think should be viewed as a contract for what the working group will work on / develop.  When a working group wants to adopt a new draft, they need to have permission from the AD and may even need to revise the charter to be able to adopt the work.

This, I think, shows a clear intent by the WG chair and the AD that a draft has some merit and at least an informal commitment to progressing the document.

I don't see it as a binding contract, but it does imply that the draft should progress.

John
> 
> From: Keith Moore <[email-masked]>
> Date: 2005/02/27 Sun AM 05:18:57 EET
> To: kw2578 <[email-masked]>
> CC: [email-masked],  [email-masked],  [email-masked]
> Subject: Re: MARID back from the grave?
> 
> > Graham,
> > 
> > You are right. WG dtafts have a more official standing iin the IETF,
> > they will, most likely, become an RFC. 
> 
> I hope not.  When a WG agrees to consider a draft it should not be taken
> as an assurance that the draft will be published as an RFC.  Too many
> WGs work far beyond their chartered deadlines because they haven't 
> finished all of their working drafts - often because those drafts turned
> out to be bad ideas or not sufficiently well-understood or robust to 
> warrant standardization (or sometimes, even publication).
> 
> Keith
> 
> 
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Keith Moore <[email-masked]>
Date: Sun, 27 Feb 2005 02:06:33 -0500

On Feb 27, 2005, at 1:23 AM, John Loughney wrote:

> Working groups have a charter, which I think should be viewed as a 
> contract for what the working group will work on / develop.  When a 
> working group wants to adopt a new draft, they need to have permission 
> from the AD and may even need to revise the charter to be able to 
> adopt the work.
>
> This, I think, shows a clear intent by the WG chair and the AD that a 
> draft has some merit and at least an informal commitment to 
> progressing the document.
>

IMHO, charters should not be bound to specific documents.   It's one 
thing to say "WG X will produce a document describing protocol Y", 
quite another to say "WG X shall publish 
draft-ietf-x-joe's-specification-for-y".  It's up to the WG, not the 
ADs, to decide which specification to submit to IESG to meet a 
particular charter requirement.  And WGs should be able to change their 
minds about such things.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 28 Feb 2005 08:55:42 +0100

Keith Moore wrote:

> thing to say "WG X will produce a document describing protocol Y", quite 
> another to say "WG X shall publish 

I agree with this.  In fact I think it should take rough consensus to 
keep a draft from becoming a WG draft.  Alternatives are good!

Eliot