Subject: Re: Last Call: 'The telnet URI Scheme' to Proposed Standard

From: Larry Masinter <[email-masked]>
Date: Mon, 07 Feb 2005 16:55:23 -0800

I think it would be much more useful if we could update the
document sufficiently to consider the telnet URI scheme
for Draft Standard or Full Standard.

The protocol itself meets the qualifications for a full
Standard document; it is widely deployed with multiple independent
implementations and has been quite stable for a long time.

I think the document itself needs a better discussion of
the limited use, security risks, and implementation methods
for the user/password fields in a "telnet" URI, however.

Larry
-- 
http://larry.masinter.net

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Tom Petch" <[email-masked]>
Date: Thu, 10 Feb 2005 13:58:56 +0100

<inline>
Tom Petch
----- Original Message -----
From: "Larry Masinter" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 08, 2005 1:55 AM
Subject: Re: Last Call: 'The telnet URI Scheme' to Proposed Standard

> implementations and has been quite stable for a long time.
mmmm protocol?  Telnet protocol is indeed as you describe but what is a URI?
STD66 defines it as an identifier of a resource and allows much flexibility as
to the nature of that resource so I see it as part of a namespace which makes
these RFC more like an IANA action, cataloging the identifier and its semantics.
What constitutes an implementation?  A web browser that parses it successfully?

Is this even Standards track?  I don't know:-(

<snip>

---

From: Sam Hartman <[email-masked]>
Date: Thu, 10 Feb 2005 13:01:06 -0500

>>>>> "Tom" == Tom Petch <[email-masked]> writes:

    Tom> Is this even Standards track?  I don't know:-(

It's my understanding that with the exception of widely deployed URIs
documented for informational purpose, both the old and new URI
registration guidelines encourage standards-track URIs.

--Sam