Subject: RE: Last Call: 'The wais URI Scheme' to Historic

From: Larry Masinter <[email-masked]>
Date: Mon, 07 Feb 2005 17:10:24 -0800

I previously sent my comments to the IESG, but I was
asked to re-raise the issue on the IETF mailing list
because  "... The IESG at this point 
seems to want public guidance on a document by document
basis..." on the topic of how to move old documents
or protocols to Historic status. In this case, it is
the raft of URI schemes currently only documented in
RFC 1738.

So, to recap:

I think it is good to update the URI scheme documents
that are in widespread, current and growing use:
"ftp", "file", "telnet" to move these beyond their
"Proposed Standard" status, update the descriptions,
and bring the results along on standards track, by
insuring that the documents are consistent with
widespread interest.

I think it is a bad idea to issue new documents for
URI schemes merely to move those schemes to Historic
status, "wais", "prospero", and even "gopher". I include
"gopher" even though there may be active or even new
"gopher" client implementations, because I don't believe
the gopher protocol or the gopher URI scheme will ever
move to full standard.

Does anyone see any real need to issue a new
document on the "gopher" URI scheme merely
to declare it "Historic"?

Larry
-- 
http://larry.masinter.net

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Dean Anderson <[email-masked]>
Date: Tue, 8 Feb 2005 09:09:28 -0500 (EST)

I'm in agreement with the purpose of updating these (and probably other 
documents) to reflect the current state of affairs.

My comment is that the it is RFCs that move through the process, not parts
of RFCs. So, it would seem to me that an update to RFC 1738 needs to be
written: that drops wais, etc, and includes telnet, etc to be moved to
Proposed Standard status. RFC 1738 can then move to Historic.  If there
are still experimental URIs, then they should be documented as such,
reflecting their current status.

Maybe you are doing that already, and I missed it or it wasn't clear. If 
so, I'm sorry.

		--Dean

-- 
Av8 Internet   Prepared to pay a premium for better service?
www.av8.net         faster, more reliable, better service
617 344 9000

---

From: Sam Hartman <[email-masked]>
Date: Tue, 08 Feb 2005 13:53:38 -0500

>>>>> "Larry" == Larry Masinter <[email-masked]> writes:

    Larry> Does anyone see any real need to issue a new document on
    Larry> the "gopher" URI scheme merely to declare it "Historic"?

Yes.  Our process currently requires a document action or protocol
action to move a document to historic.  This could be done for each
URL, or a document could be published noting that except for certain
URI schemes, the schemes defined in 1738 are moved to historic.

As I read the note from the IESG to you, the question was not whether
a document was needed to move something to historic.  The question was
whether gopher should be published at historic or proposed.  

--Sam

---

From: Pekka Savola <[email-masked]>
Date: Tue, 8 Feb 2005 23:09:30 +0200 (EET)

> URI schemes, the schemes defined in 1738 are moved to historic.

Well, there is:

http://www.ofcourseimright.com/oldstandards.html

Maybe there is no need for these "is Historic" documents, but rather 
this could be addressed by revising (and progressing) the 
specification (taking the obsolete stuff out) which introduced them in 
the first place?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 09 Feb 2005 15:12:42 +0100

Larry Masinter wrote:

> status, "wais", "prospero", and even "gopher".

AFAIK the idea is to split 1738 into the included URI schemes
(you forgot to mention news: and nntp:).  When that's ready
1738 can be moved to "historic", or "obsoleted by" [list of
the individual documents, incl. wais: and prospero:]

Then it's also possible to move some individual documents to
"historic".  But not all, some of us still use news:, gopher:,
file:, ftp:, and telnet:.  Maybe not always in the original
sense for gopher:, but it's still nice to create URLs for 
simple "open [- send query] - get answer - close" protocols.

> I don't believe the gopher protocol or the gopher URI scheme
> will ever move to full standard.

There's nothing to replace it, if it's (ab)used to create
whois / rwhois / finger / echo / daytime / etc. URLs.  And
"historic" isn't the same as "obsolescent".  Why not wait until
it's dead before you bury it ?
                              Bye, Frank
-- 
Discussed in <http://article.gmane.org/gmane.org.w3c.uri:201>