Subject: Re: RFC Editor Function SOW Review

From: Todd Glassey <[email-masked]>
Date: Tue, 18 Jul 2006 14:10:05 -0400 (EDT)

Hmmmm... The SOW MUST define all the elements of the Editor's responsibility and all the specific tasks they perform as well as the SLA's for those Tasks. It also MUST address the SOD (Separation of Duties) within the Editor's work since they are altering the IP submitted.

Without that ther is no comprehensive model for evaluating how well the IETF met its standards and whether it caused damage to others in the process.

Todd Glassey as an Auditor.

-----Original Message-----
>From: Brian E Carpenter <[email-masked]>
>Sent: Jul 18, 2006 5:18 AM
>To: Pete Resnick <[email-masked]>
>Cc: IETF Administrative Director <[email-masked]>, IETF Announcement list <[email-masked]>
>Subject: Re: RFC Editor Function SOW Review
>
>Pete,
>
>Pete Resnick wrote:
>> On 7/10/06 at 8:34 AM -0400, IETF Administrative Director wrote:
>> 
>>> we seek comments on the Statement of Work located at:
>>> http://koi.uoregon.edu/~iaoc/
>> 
>> 
>> - The SOW has nothing about performance expectations (i.e., what is 
>> noted in section 4 of draft-mankin-pub-req-10). Though I don't think the 
>> SOW should have hard requirements in this regard 
>> (draft-mankin-pub-req-10 doesn't), I do think we need to give some 
>> estimate of how many documents they're going to see and their expected 
>> throughput. A bid is going to have to be based on how fast they think 
>> they need to do the editing.
>
>Indeed, and that has to be part of the SLA component of final contract.
>But the numbers in the final SLA may also be part of a price negotiation.
>I agree we need to put SLA numbers in the RFP, for comparison purposes.
>
>> 
>> - The SOW mentions the Editorial Board for Independent submissions, but 
>> doesn't say where it comes from. I take it from the slides at the 
>> Thursday plenary that this is still in flux, but at least there should 
>> be a note indicating that this is going to be filled in later.
>
>Correct.
>
>    Brian
>> 
>> I've already written privately about some nits. Here are couple more:
>> 
>> - Strike A-1-g-3. It's redundant with A-1-g-1.
>> - Change "category" to "stream" in A-4-b. "Category" doesn't make any 
>> sense there (or if it does, it's undefined.)
>> 
>> pr
>
>_______________________________________________
>Ietf mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Marcus Leech" <[email-masked]>
Date: Tue, 18 Jul 2006 14:40:22 -0400

>Todd Glassey as an Auditor.
Methinks you've drunk too deeply of the SOX Kool-Aid, Todd.    Along 
what lines would you
  suggest that the RFC Editor "separate its duties"?

Perhaps you would also reccommend that the guy who replaces the air 
freshener blocks
  in the mens bathroom not also be the same guy who fixes the plumbing?  
Or maybe the
  guy who diagnoses your automotive problems be different from the guy 
who actually
  fixes it?  Perhaps in the RFC-Editor function, the person who fixes 
missing commas
  and semi-colons, should be different from the person who addresses 
clarity and
  normative reference issues?  Yup, that's an efficient use of 
everyone's time and money.

SOD was designed to prevent certain types of financial faud in 
*financial software development and
  deployment processes*, and other similar processes where separation of 
duty is essential
  to maintain certain properties of the overall process.  SOX-mania has 
become a toxin that has
  clouded most peoples thinking in this area, and I'm loathe to accept 
that IETF processes
  must be held hostage to an ill-conceived set of guidelines promulgated 
by the
  utterly-irrelevant-to-the-IETF Public Companies Accounting Oversight 
Board.  The IETF isn't
  a publically-traded company, last time I checked, and even if it were, 
the SOD
  provisions of SOX (and Audit Standard 2, which clearly you've consumed 
wholesale) clearly
  wouldn't apply.

I suggest, Todd, that you switch to another beverage, because the SOX 
Kool-Aid is
  clearly doing neither you nor anybody else any good.

-- 

Marcus Leech                            Mail:   Dept 1A12, M/S: 04352P16
Security Standards Advisor        Phone: (ESN) 393-9145  +1 613 763 9145
Strategic Standards
Nortel Networks                          [email-masked]

---

From: Joe Touch <[email-masked]>
Date: Fri, 21 Jul 2006 09:03:34 -0700

Marcus Leech wrote:
> Todd Glassey wrote:
> 
>> Hmmmm... The SOW MUST define all the elements of the Editor's
>> responsibility and all the specific tasks they perform as well as the
>> SLA's for those Tasks. It also MUST address the SOD (Separation of
>> Duties) within the Editor's work since they are altering the IP
>> submitted.
>>
>> Without that ther is no comprehensive model for evaluating how well
>> the IETF met its standards and whether it caused damage to others in
>> the process.
>>

It isn't; one is typically a janitor, the other a plumber.

>  normative reference issues?

Clarity and normative reference issues are often content specific. They
require knowledge of Internet protocols and their interrelationships
(even if the IESG approves the doc doesn't mean the doc is written
clearly in that regard).

General text editing is not content specific.

If you think you can find someone knowledgable enough in the Internet
who wants to burn their time fixing typos, please do. I suspect a
separation of duties will be necessary otherwise.

Joe