Subject: RE: Mandatory numeric examples in crypto-RFCs?

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 26 Jul 2006 09:17:23 -0700

I provided these examples in XKMS and the general feedback on doing so was very positive. We found that implementations were much more likely to interop having been written from the spec alone than without the examples. It also helped identify ambiguities in the specification as people reported ambiguities in the text where they resorted to the examples for checking. 

> -----Original Message-----
> From: Hadmut Danisch [mailto:[email-masked]] 
> Sent: Wednesday, July 26, 2006 10:41 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Mandatory numeric examples in crypto-RFCs?
> 
> Hi,
> 
> I am currently debugging some ISAKMP problems and thus using 
> RFCs like 2085, 2412, etc. about cryptographic algorithms and 
> data formats. 
> 
> 
> Such RFCs are sometimes a little bit ambiguous or difficult to read
> since details are spread around the paper. When implementing such
> algorithms or data parsers, you don't know whether the implementation
> is correct without a test case, e.g. feeding in some examples and
> check whether the result is what is expected.
> 
> 
> I'd therefore propose that every RFC dealing with crypto algorithms or
> data formats has to have a mandatory appendix section with examples to
> be used as a test case. (Every I-Draft should have.)
> 
> E.g. when describing key agreements precise examples of the random
> numbers and secrets, byte sequences of example messages, and the
> results (signatures, keys,...) should be given allowing to do a simple
> check of any implementation to see, whether the implementation works
> in principle, and does not have such common bugs like wrong padding,
> byte order problems etc.
> 
> 
> 
> regards
> Hadmut
> 
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Bob Braden <[email-masked]>
Date: Mon, 31 Jul 2006 12:07:39 -0700 (PDT)

> be used as a test case. (Every I-Draft should have.)

The RFC Editor notes that we were CC'd on this message.  That
seems to imply that you wish us to enforce this requirement.
We wonder: is this limited to standards-track documents?
(If so, the IESG would be a more appropriate place to
enforce your suggestion.)

The RFC Editor could take on this as a requirement for all RFC
publication, but note that it involves a content decision that is
outside the normal and current limits of the RFC editorial function.
In the past, the RFC Editor was basically motivated by a desire
to serve the IETF community, and we would have been happy to
undertake this.  It is not clear that this will continue to
be the case in the future.  Certainly, IAB action will be
required to realize your request.

RFC Editor/bb