Subject: Re: Minutes and jabber logs

From: Todd Glassey <[email-masked]>
Date: Tue, 18 Jul 2006 13:56:29 -0400 (EDT)

Jabber Logs are part of NOTEWELL and if they are not maintaned then NOTEWELL is a bigger problem than it already is. Sorry... if NOTEWELL is put in place to capture participation - then ***all*** participation must be captured and available to anyone reviewing any initiative...

Todd Glassey, CISM CIFI
as an IT Auditor

-----Original Message-----
>From: Spencer Dawkins <[email-masked]>
>Sent: Jul 18, 2006 8:02 AM
>To: [email-masked]
>Subject: Re: Minutes and jabber logs
>
>Sorry, I should have responded to the first notes on-list...
>
>
>> Just a reminder of what our process rules (RFC 2418) say:
>>
>>    All working group sessions (including those held outside of the IETF
>>    meetings) shall be reported by making minutes available.  These
>>    minutes should include the agenda for the session, an account of the
>>    discussion including any decisions made, and a list of attendees. The
>>    Working Group Chair is responsible for insuring that session minutes
>>    are written and distributed, though the actual task may be performed
>>    by someone designated by the Working Group Chair. The minutes shall
>>    be submitted in printable ASCII text ...
>>
>> We don't insist on the list of attendees when that is in the blue sheets,
>> but it's clear that the minutes have to be readable ("an account of the
>> discussion including any decisions made") and that is not usually
>> the state of a raw jabber log. It's important, since the decisions taken
>> in a meeting have to be confirmed on the list - if the minutes are
>> properly written, it's enough to ask for agreement on the minutes.
>>
>> A carefully edited jabber log can of course be just fine.
>
>You know, there was a day when "he said/she said" minutes were actually 
>discouraged at the IETF... not that I've found a pointer to that written 
>down anywhere, but people often pointed this out when I started volunteering 
>to take notes (somewhere around the Yokohama timeframe).
>
>Since this was my suggestion, I should point out that my "carefully edited" 
>NON-jabber minutes look a heckuva lot like what working group chairs often 
>post as their minutes, without summary, in the proceedings.
>
>My opinion, which is not the only one available on earth, is that
>
>if one working group chair (and preferably all of the working group's 
>chairs) reviews careful jabber logs, which I was suggesting could be checked 
>for accuracy by anyone else participating in the meeting, either onsite or 
>remotely, while the jabbering scribe was still typing, and
>
>reviews the audio for anything that is still unclear and violates either 
>memory or sanity, and
>
>then summarizes the accummulated notes in a clear fashion saying
>
>- these were the topics,
>
>- these were the issues that were discussed,
>
>- these were the major points that were raised,
>
>- these were the sense-of-the-room calls that will be verified on the 
>mailing list,
>
>and then sends the summary, pointers to the presentations, pointers to the 
>jabber log, and pointers to the audio to the working group mailing list for 
>review, which is a lot more likely to happen with a summary,
>
>and then posts all of this to the proceedings,
>
>that would be a great leap forward from what is produced today.
>
>For reference, my (non-jabber) notes from Montreal were
>
>BEHAVE - 19KB
>SIP - 31 KB
>SIPPING -52 KB
>SIPSEC - 14 KB
>
>and, since I'm rereading them today for my own trip report, it's not that 
>easy to go through the non-jabber notes, either.
>
>*I* wish that I'd had help from other people in producing them, and the only 
>way I know how to collaboratively produce this kind of semi-transcript is 
>using jabber. Other opinions may be present on this mailing list...
>
>Thanks,
>
>Spencer 
>
>
>
>_______________________________________________
>Ietf mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ietf

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Todd Glassey <[email-masked]>
Date: Tue, 18 Jul 2006 14:21:00 -0400 (EDT)

Elliot -

-----Original Message-----
>From: Eliot Lear <[email-masked]>
>Sent: Jul 18, 2006 5:59 AM
>To: David Harrington <[email-masked]>
>Cc: [email-masked]
>As someone who has both done a lot of jabber scribing and is also a WG
>chair and has also remotely participated, I agree with Dave Harrington
>on each of his points.  Putting these two threads back together,
>however, let me suggest the following:
>
>    * No minute taker is perfect.  This includes the jabber scribe
>      (especially this one).

Thats unacceptable

>    * It is useful for the chairs to be able to "grep" the official
>      jabber takers' capture of what went on in the room, both when
>      developing minutes, and when controversies arise as they sometimes
>      do.  They tend to be far more succinct than a full audio replay.

Jabber represents a part of NOTEWELL and MUST be captured in iesentirety or eliminated from the process totally.

>    * Properly jabbered minutes can suffice as the basis from which a
>      summary can be made.  

No they cannot - and this is a grossly incompetent statement - it is unfounded and ANY auditor or reviewer of the processes of the IETF's would tell you this is not true from a forensics standpoint.  Sorry... but each stream from any meeting needs its own Table of Contents and if the streams are not equal to each other then there is an issue.

> However,
>    * All of this depends on a fully functional network, something that
>      we cannot yet take for granted.  Although it generally performed
>      well, there were a few hiccups.  

The IETF is then 'getting' that there is a mechanical cost to the processes yit wants to use eh? cool... a little reality is good now and then.

> While we can aspire for more
>      reliability, I don't think we should predicate our minutes on it.

So then what you are saying is that truth in the meeting process is not important and that the IETF is above reporach... You realize that putting such a plan as this in place may open the participant's in a meeting to litigation against the IETF and that group as a whole, which would permanently end all the efforts for participating in the IETF that anyone with SOX or other regulatory requirements would be stuck under...

>    * While the audio was generally VERY good this last conference (I
>      relied on it for the few meetings I took part in), there were a
>      few bad patches.  I view jabbering and audio as quite complimentary.
>    * The side conversations in the jabber log to me are often as
>      relevant as what's being said by individuals.  In the case of WAE,
>      there were several very lively discussions, including one that
>      contained facts that caught an AD by surprise.
>    * Regarding input to the microphone, a better solution than having
>      the jabber scribe voice a remote participant's comment would be to
>      find a way for the remote participant to actually voice it.  I
>      wonder if this isn't an area we could ask the IAD and interested
>      volunteers to explore, and perhaps experiment with.

VoIP solution from Cisco for the Meetings?

>Eliot