Subject: RE: IETF IPv6 platform configuration

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Wed, 5 Jul 2006 12:51:54 -0700

If memory serves me right there is a subway terminal built into the foundation of the Delta International. Where the other end of the subway goes is another matter. 

> -----Original Message-----
> From: Ken Raeburn [mailto:[email-masked]] 
> Sent: Wednesday, July 05, 2006 9:55 AM
> To: ietf Mailing List
> Cc: [email-masked]
> Subject: Re: IETF IPv6 platform configuration 
> 
> On Jun 11, 2006, at 20:00, IETF Secretariat wrote:
> > All,
> > As you’re all aware, on 06/06/06 NSS successfully launched IPv6 
> > services for IETF Web, Mail, and FTP.
> 
> Has anyone had FTP work for them when not in "passive" mode 
> since this configuration change was made?
> 
> My site's got a clunky old ftp-based mirror script in use 
> which at first glance doesn't seem to know anything about 
> passive mode, and it hasn't fetched any new RFCs since a 
> month ago.  Running ftp directly (over ipv4, from a couple of 
> machines, one of which has no ipv6 configuration and no 
> recent software changes) doesn't work either, commands like 
> LIST get back "failed to establish connection"  
> immediately.
> 
> I'm probably going to throw away the mirror script anyway and 
> switch to rsync, but I'm still curious to know whether this 
> is some weird problem with our configuration (maybe a 
> surprise related to the ipv6 changes?), or an intentional 
> (but unannounced?) or unintentional configuration change in 
> ftp support at the server side....
> 
> Ken
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Lindberg, Jon" <[email-masked]>
Date: Thu, 6 Jul 2006 12:02:30 -0400

We are looking into this and will post a response as soon as we have
some more information.  As always, thanks for the notification!!

Jon Lindberg
NSS

-----Original Message-----
From: Bill Fenner [mailto:[email-masked]] 
Sent: Thursday, July 06, 2006 10:46 AM
To: Ken Raeburn
Cc: [email-masked]; ietf Mailing List
Subject: Re: IETF IPv6 platform configuration

My recent experiences with ftp.ietf.org:

EPSV doesn't work - it gives a port which it then isn't listening on
(or, more likely since we get no response at all, a firewall blocks
connections to):

ftp> ls
---> EPSV
229 Entering Extended Passive Mode (|||42065|)
ftp: connect for data channel: Operation timed out

[simultaneously in another window]
compost% telnet ftp.ietf.org 42065
Trying 156.154.16.149...
telnet: connect to address 156.154.16.149: Operation timed out

EPRT for IPv4 doesn't work - it returns an error "Bad EPRT protocol."

---> EPRT |1|192.20.225.40|56318|
500 Bad EPRT protocol.

Apparently, the FTP server doesn't want to allow EPRT with IPv4.
("1" is IPv4).  It's not using the 522 "I don't support that protocol"
error code, but is also saying that it doesn't support that
protocol.

PORT doesn't work - it returns an immediate error "Failed to establish
connection".

---> PORT 192,20,225,40,219,254
200 PORT command successful. Consider using PASV.
---> LIST
425 Failed to establish connection.

tcpdump shows that it didn't send any packets trying to establish
a connection to 192.20.225.40 and the 425 error comes too
quickly to have tried.

It looks like 3 out of 4 data channel establishment mechanisms
are broken with this FTP server software and configuration for
IPv4.  I didn't test with IPv6.

  Bill