Subject: NAT TRAVERSAL IN SIP THROUGH IMS

From: "Ashfaaq H Poonawala" <[email-masked]>
Date: Thu, 19 Oct 2006 11:10:34 -0500

Dear All,
I am a Masters Student at Southern Methodist University, Dallas TX.

I am doing a project on NAT traversal in SIP in the IMS network. I am discussing the problems for the RTP packets while NAT traversal. One of the solution to it is the STUN and TURN servers.

I would really appreciate if I were to get more details in it. Also are there more problems apart of RTP packets?

Thanks,
Ashfaaq Poonawala

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 19 Oct 2006 14:49:33 -0700

3GPP owns the IMS specification, not the IETF.  I know there was a recent
contribution to 3gpp for using STUN (and TURN and ICE) for NAT traversal.

In the IETF, STUN is a standard (RFC3489), TURN is being standardized in the
BEHAVE working group and ICE (which is related to STUN and TURN) is being
standardized in the MMUSIC working group.  A list of working groups, their
documents, and their mailing list information is available from
http://www.ietf.org.

As to 'are there more problems apart of RTP packets?', if you're asking if
NATs cause problems for things other than RTP, the answer is yes.  The
BEHAVE working group is chartered to describe the best practices around NATs
(for the NATs and for applications that hope to run over them).  For some
additional SIP specific techniques for dealing with NATs, see also
draft-ietf-sip-outbound-04.txt.

-d

> -----Original Message-----
> From: Ashfaaq H Poonawala [mailto:[email-masked]] 
> Sent: Thursday, October 19, 2006 9:11 AM
> To: [email-masked]
> Subject: NAT TRAVERSAL IN SIP THROUGH IMS
> 
> Dear All,
> I am doing a project on NAT traversal in SIP in the IMS 
> network. I am discussing the problems for the RTP packets 
> while NAT traversal. One of the solution to it is the STUN 
> and TURN servers.
>  
> I would really appreciate if I were to get more details in 
> it. Also are there more problems apart of RTP packets?
>  
> Thanks,
> Ashfaaq Poonawala
>