Subject: RE: Last Call: 'DNSSEC Lookaside Validation (DLV)' to Informational RFC (draft-weiler-dnssec-dlv)

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 30 Oct 2006 13:41:23 -0800

It's a question of the model.

The people making the non-comments on the draft are the people that one would expect to have the expertise to resolve the issues which are sufficiently detailed and DNS specific that it is not reasonable to expect the IESG to decide them.

It is reasonable to comment that the document should be marked experimental rather than informational. It would be reasonable to say that what the document describes might become a de-facto standard even though nobody intends this and that WG review is therefore approriate.

The objection 'there might be an inconsistency here' is always applicable. It certainly applies to the vast majority of standards regardless of source. It is therefore an information-free comment.

I agree with Olaf's suggestion that there be an action on the document author to add a section explaining the relationship of the draft to existing experimental practice. It seems to me that this is entirely appropriate in a document marked 'experimental'. I don't think that it is appropriate for the IESG to be tasked with evaluating the quality of this work.

My point here is that the IESG should not accept responsibility for ensuring that specifications do not fail.

Instead I believe that the IESG should make it very clear that responsibility lies with the working groups and not attempt to save the WGs from the consequences of their own folly except in rare circumstances. Those being that there is a clearly identified flaw in a proposal that has potential to damage the wider Internet, or that there is a procedural irregularity in the WG itself.

The main job of the IESG should be to protect WGs from the folly of other WGs. There being enough of that to make a full time occupation.

> -----Original Message-----
> From: Joe Abley [mailto:[email-masked]] 
> Sent: Monday, October 30, 2006 4:07 PM
> To: Hallam-Baker, Phillip
> Cc: John C Klensin; Geoff Huston; Bernard Aboba; [email-masked]
> Subject: Re: Last Call: 'DNSSEC Lookaside Validation (DLV)' 
> to Informational RFC (draft-weiler-dnssec-dlv)
> 
> 
> On 30-Oct-2006, at 11:38, Hallam-Baker, Phillip wrote:
> 
> > When the statement is "I haven't compared draft-weiler-dnssec-
> > dlv-01 with the ISC tech note closely, but since the text 
> is different 
> > it seems likely that implementations based on one would 
> likely differ 
> > from those" it should go straight to the bit bucket.
> 
> OK. The two documents have a common heritage (as the 
> respective acknowledgements sections indicate) but it's not 
> clear from either document whether they describe precisely 
> the same thing as the other.  
> I have read both documents and have noted the lack of text in 
> either of them which would clarify this issue.
> 
> If they describe the same thing, then hooray, but let them 
> say so rather than requiring people to infer things from their titles.
> 
> 
> Joe
> 
> 

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: Joe Abley <[email-masked]>
Date: Mon, 30 Oct 2006 16:43:29 -0500

On 30-Oct-2006, at 16:41, Hallam-Baker, Phillip wrote:

> I agree with Olaf's suggestion that there be an action on the  
> document author to add a section explaining the relationship of the  
> draft to existing experimental practice. It seems to me that this  
> is entirely appropriate in a document marked 'experimental'.

That was all I was suggesting.

> I don't think that it is appropriate for the IESG to be tasked with  
> evaluating the quality of this work.

I didn't suggest that they should be.

Apologies if my commentary suggested otherwise.

Joe