Subject: Re: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for Media Control) to Informational RFC

From: "Pete Cordell" <[email-masked]>
Date: Mon, 8 Oct 2007 15:22:10 +0100

I quickly looked at this and noticed that the XML instance examples don't
match the schema because the instance does not make reference to the
namespace.  i.e., to match the schema, the example should be:

   <media_control xmlns="urn:ietf:params:xml:ns:media_control">

      <vc_primitive>
       <to_encoder>
         <picture_fast_update/>
       </to_encoder>
     </vc_primitive>

   </media_control>

My expectation is that the instance is actually more authorative in terms of 
what the authors are looking for. If that is the case, the schema should be 
modified along the lines of:

   <xsd:schema id="TightMediaControl"
    xmlns:xsd="http://www.w3.org/2001/XMLSchema">
    ...

i.e. remove the targetNamespace declarations.

You may have your reasons not to, but if not, you may want to consider using 
schema's documentation features instead of the XML comments; e.g.:

<xsd:complexType name="vc_primitive">
    <xsd:annotation><xsd:documentation>
        Video control primitive.
    </xsd:documentation></xsd:annotation>

    <xsd:sequence>
     ...

HTH,

Pete.
--
=============================================
Pete Cordell
Codalogic
for XML Schema to C++ data binding visit
 http://www.codalogic.com/lmx/
=============================================
----- Original Message ----- 
From: "The IESG" <[email-masked]>
To: "IETF-Announce" <[email-masked]>
Sent: Monday, October 08, 2007 2:29 PM
Subject: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for
Media Control) to Informational RFC

> The IESG has received a request from an individual submitter to consider
> the following document:
>
> - 'XML Schema for Media Control '
>   <draft-levin-mmusic-xml-media-control-11.txt> as an Informational RFC
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2007-11-05. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-levin-mmusic-xml-media-control-11.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=9391&rfc_flag=0
>
>
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf-announce
>

_______________________________________________
Ietf mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ietf

---

From: "Even, Roni" <[email-masked]>
Date: Sun, 14 Oct 2007 11:53:49 +0200

Pete,
Thanks , we are reviewing to see if the example reflects existing implementations
Roni Even

> -----Original Message-----
> From: Pete Cordell [mailto:[email-masked]]
> Sent: Monday, October 08, 2007 4:22 PM
> To: [email-masked]
> Cc: [email-masked]; Even, Roni; [email-masked]
> Subject: Re: Last Call: draft-levin-mmusic-xml-media-control (XML Schema
> for Media Control) to Informational RFC
>

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 25 Oct 2007 14:29:35 +0200

Hi Pete,

After consulting with my co-authors our view is that industry implemented the solution as specified in the example, so we need to revise the schema based on Pete's suggestion to

<?xml version="1.0" encoding="utf-8"?>

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified" id="TightMediaControl">

      <xs:element name="media_control">

            <xs:complexType>

                  <xs:sequence>

                        <xs:element name="vc_primitive" type="vc_primitive" minOccurs="0" maxOccurs="unbounded"/>

                        <xs:element name="general_error" type="xs:string" minOccurs="0" maxOccurs="unbounded"/>

                  </xs:sequence>

            </xs:complexType>

      </xs:element>

      <!-- Video control primitive.  -->

      <xs:complexType name="vc_primitive">

            <xs:sequence>

                  <xs:element name="to_encoder" type="to_encoder"/>

                  <xs:element name="stream_id" type="xs:string" minOccurs="0" maxOccurs="unbounded"/>

            </xs:sequence>

      </xs:complexType>

      <!-- Encoder Command:

                Picture Fast Update

           -->

      <xs:complexType name="to_encoder">

            <xs:choice>

                  <xs:element name="picture_fast_update"/>

            </xs:choice>

      </xs:complexType>

</xs:schema>

This also means that we will not have the target name space so we do not need to register it with IANA as specified in section 9.2.

If this is correct I will submit a revised revsion.

Thanks

Roni Even

> My expectation is that the instance is actually more authorative in terms

> of

> what the authors are looking for. If that is the case, the schema should

> be

> You may have your reasons not to, but if not, you may want to consider

> using

> > http://www.ietf.org/internet-drafts/draft-levin-mmusic-xml-media-

> control-11.txt

> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=93

> 91&rfc_flag=0

---

From: "Pete Cordell" <[email-masked]>
Date: Thu, 25 Oct 2007 14:07:05 +0100

Hi Roni,

This looks fine to me.  The only thing I would say is that I think the 
elementFormDefault="qualified" is redundant because there is no namespace to 
qualify the elements with.

Pete.

P.S. Sorry for the delay in responding to this.  I have been away for a few 
days.
--
=============================================
Pete Cordell
Codalogic
for XML Schema to C++ data binding visit
 http://www.codalogic.com/lmx/
=============================================

----- Original Message ----- 
From: "Even, Roni" <[email-masked]>
To: "Pete Cordell" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Colin Perkins" 
<[email-masked]>; "Cullen Jennings" <[email-masked]>; <[email-masked]>; 
<[email-masked]>
Sent: Thursday, October 25, 2007 1:29 PM
Subject: RE: Last Call: draft-levin-mmusic-xml-media-control (XML Schema for 
Media Control) to Informational RFC

Hi Pete,

After consulting with my co-authors our view is that industry implemented 
the solution as specified in the example, so we need to revise the schema 
based on Pete's suggestion to

<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
elementFormDefault="qualified" id="TightMediaControl">

            <xs:complexType>

                  <xs:sequence>

                        <xs:element name="vc_primitive" type="vc_primitive" 
minOccurs="0" maxOccurs="unbounded"/>

                        <xs:element name="general_error" type="xs:string" 
minOccurs="0" maxOccurs="unbounded"/>

                  </xs:sequence>

            </xs:complexType>

      </xs:element>

            <xs:sequence>

                  <xs:element name="stream_id" type="xs:string" 
minOccurs="0" maxOccurs="unbounded"/>

            </xs:sequence>

      </xs:complexType>

      <!-- Encoder Command:

                Picture Fast Update

           -->

            <xs:choice>

            </xs:choice>

      </xs:complexType>

</xs:schema>

This also means that we will not have the target name space so we do not 
need to register it with IANA as specified in section 9.2.

Thanks

Roni Even

---

From: "Pete Cordell" <[email-masked]>
Date: Thu, 25 Oct 2007 14:07:05 +0100

Hi Roni,

Pete.

----- Original Message ----- 
From: "Even, Roni" <[email-masked]>
To: "Pete Cordell" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; "Colin Perkins" 

Hi Pete,

            <xs:complexType>

                  <xs:sequence>

                  </xs:sequence>

            </xs:complexType>

      </xs:element>

            <xs:sequence>

            </xs:sequence>

      </xs:complexType>

      <!-- Encoder Command:

                Picture Fast Update

           -->

            <xs:choice>

            </xs:choice>

      </xs:complexType>

</xs:schema>

Thanks

Roni Even