Subject: Question regarding domain name in a web URL

From: [email-masked]
Date: Thu, 28 Aug 2008 10:12:21 +0530

Hi,

I have one question regarding domain name in a web URL. (I am a newcomer 
to this discussion forum and this is my first post, so please excuse me if 
this is not the correct question to be asked on this forum, and kindly 
guide me to the correct forum).

Is "www.my.domain.again.my.domain.com" a valid URL on INTERNET?
I know that "http://my.domain.again.my.domain.com" can be a valid INTERNET 
DNS address, but not sure about something like 
"http://www.my.domain.again.my.domain.com" (NOTE THE "www"- Does "www" has 
any significance in this URL when it comes to DNS name resolution?).

I couldn't find any document or forum which clearly rules out something 
like the above URL as an invalid one OR not as per IETF (or any other 
relevent) specs.
Just wanted to check if something like "www.my.domain.again.my.domain.com" 
can be published on INTERNET DNS as valid site URL or not? If the answer 
is "no", please specify the reason or point me to relevent 
documentation/specification.

Thanks for your time.

Regards,
Darshan

____________________________________________
=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 28 Aug 2008 09:07:37 +0200

> Is "www.my.domain.again.my.domain.com" a valid URL on INTERNET?

It's a valid relative URL, but I think that's not what you want
to know...   

> I know that "http://my.domain.again.my.domain.com" can be a
> valid INTERNET DNS address

...the other way around it makes sense:  Your first string is a
syntactically valid DNS domain name, and your second string is
a valid HTTP URL for this domain.  Just in case you could add a
trailing dot to your first string, and a trailing slash to your
second string.  For technical details about URIs please look in
<http://tools.ietf.org/html/rfc3986>.

If you have questions about RFC 3986 better ask them on the URI
list [email-masked], see <http://dir.gmane.org/gmane.org.w3c.uri>.

> Does "www" has any significance in this URL when it comes to
> DNS name resolution?

Yes, the strings without www are different, you could end up at
a different host.  Or in the case of the URL you could get a
different homepage or an error.  Often Web servers arrange that
you get the same content, but that is not required.  Check out
RFC 4367 for some details.

 Frank
--  
Please don't post on IETF lists with private disclaimers, see
<http://www.ietf.org/maillist.html>.