Subject: Re: Unicode.org Software Internationalisation Standards &Specifications

From: linuxa linux <[email-masked]>
Date: Sun, 2 Nov 2008 12:48:09 +0000 (GMT)

Doug, Thanks for your response that shows your knowledge and expertise about internet / computer things, common sense, organisational topics and also the replacing k/K to unicode 0915 glyph shape issue.

"........You might as well send your message to your MP or to the Queen, for all the good it will do to send it to IETF."

Airing the issue to the internet / computer community.

"I don't speak for their mailing-list administrator........."

The Unicode.org website home page copy that I quoted is not factual.

"Accusing an organization of process failure and insensitivity and stubbornness is not usually a productive way to get them to come around to your point of view."

The Unicode.org website page copy that I quoted is not factual.

"You have stipulated that this constitutes........"

The Unicode.org website page copy that I quoted is not factual.  There should be some limitations.  They don't have a demo that proves the first quote and the Unicode.org is not a framework.

".......You are accusing Unicode of things it is not responsible for.  This is like blaming the weatherman when it rains."

The Unicode.org website page copy that I quoted is not factual.  There should be some limitations.  They should clarify what they are not responsible for.  Their home page copy that I quoted is a trap for Unicode.org and readers.

"You are trying to change the basic form of a letter that has existed in the Latin alphabet for over two thousand years, on the basis of an association between the K glyph and the intersection of three rivers, derived loosely from a secondary Krishna text.  ["that the letter K represents suicide and needs to be changed"] You are trying to change the basic form of a letter recognized by billions of people, and one of your first moves is to approach an international standards-making organization, which does NOT standardize the Latin alphabet itself and is NOT in the business of deciding what letters are supposed to look like, and accuse them of improper conduct because they do not immediately modify their charts and develop new fonts based on your views, which so far I have only heard from ONE person.  To say you are outside the mainstream would be a serious understatement."

The latin / roman k/K letter needs to be replaced to another shape for reasons you know.  You have to understand that issue is beyond organisational management because it is related to human life.  Approaching Unicode.org and IETF.org was essential because they claim to have various controls over internet / computer transmitted language.  Some helpful interim things should be put in place, leadership and management is much needed.  Unicode.org website home page communicates the wrong impression and they should correct that. 

"Style of what?....Content of what?  The standard is described in excruciating detail at http://www.unicode.org/versions/Unicode5.1.0/ ......Unicode doesn't tell people how to design user interfaces.  That is completely up to application developers, as it should be.....See http://www.unicode.org/consortium/join.html .....Unicode doesn't tell people how to build applications, whether open-source or proprietary.  Do you feel it should?"

Thus Unicode.org has not any framework.  Certain programmers thus become baffled.  The Unicode.org home page copy that I quoted is not factual.  There should be some limitations. 

"It does not say that it will take you by the hand and show you how to program, configure, or use a computer in any language."

Unicode.org are unjustly saying things on the website home page copy that I quoted, they are not communicating there what they are not responsible for.  They are leaving this to other imaginations and trapping themselves and others.

"Unicode makes it possible to put tens of thousands of different characters on a .....a plain-text document"  

I refer to .txt files, are you also suggesting that you can put save a .txt file on the computer that has unicode 0915 glyph shape?

"What sort of "framework" are you looking for to accomplish your goals? Be specific, please, for once."

I was being specific that there is not any framework about Style, Content, User Interface, Membership and Extensions, these generic areas that can help Software Internationalisation otherwise certain programmers would not get baffled for example at particular opensource code applications when they are asked to remove all k/K letters and replace them with unicode 0915 glyph shape.  There should be some catch-all process / principle at header and footer of a code for example BBCode / HTML has this and this principle perhaps should be considered to ease the burden.  I am not a coder / programmer thus I am not sure whether this way is possible.

"......It can *only* mean granting of favors, such as employment or political status, to personal relatives regardless of their qualifications.  You can say "corporate nepotism" if you like and English speakers will automatically interpret this as "someone in a corporation was made vice-president because he was someone else's brother, not because he deserved it."  Nobody will interpret this as "collusion between corporations" or "unfair bias."  You need to pick another word that really means what you want it to mean.  Nobody can stop you from misusing this word if you insist, but they are within their rights to laugh and ignore you."

I saw the Wikipedia "nepotism" meaning and it includes "friends" not only "relatives."  Thus "nepotism" is a problem at organisational and corporate networks.  This includes Unicode.org and IETF.org.  Leadership and management are required to prevent this.  

"When the day comes when you convince a SIGNIFICANT number of Latin-script users, worldwide, that the letter K represents suicide and needs to be changed, THEN it is time to approach the standards organizations *respectfully* and ask them to make changes that reflect a change that a SIGNIFICANT number of people have already adopted.  It needs to be something people see in newspapers and on street signs and on television.  Until then, this effort will not be seen constructively."

I repeat.....The latin / roman k/K letter needs to be replaced to another shape for reasons you know.  You have to understand that issue is beyond organisational management because it is related to human life.  Approaching Unicode.org and IETF.org was essential because they claim to have various controls over internet / computer transmitted language.  Some helpful interim things should be put in place, leadership and management is much needed.  Unicode.org website home page communicates the wrong impression and they should correct that.

John,  Thanks for your response.

Unicode.org don't want to listen anymore when it relates to their website home page because they blocked my message to the mailing list that was critical about this.  Unicode.org should say categorically they are not responsible for framework.  However they are communicating the wrong impression to the internet / computer community.

Regards

Meeku
http://twitter.com/nepotism

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Joe Baptista" <[email-masked]>
Date: Sun, 2 Nov 2008 10:08:28 -0400

This all smells bad.

regards
joe baptista

On Sun, Nov 2, 2008 at 8:48 AM, linuxa linux <[email-masked]>wrote:

> Doug, Thanks for your response that shows your knowledge and expertise
> about internet / computer things, common sense, organisational topics and
> also the replacing k/K to unicode 0915 glyph shape issue.
>
> "........You might as well send your message to your MP or to the Queen,
> for all the good it will do to send it to IETF."
>
> "Accusing an organization of process failure and insensitivity and
> stubbornness is not usually a productive way to get them to come around to
> your point of view."
>
> The Unicode.org website page copy that I quoted is not factual.  There
> should be some limitations.  They don't have a demo that proves the first
> quote and the Unicode.org is not a framework.
>
>
> ".......You are accusing Unicode of things it is not responsible for.  This
> is like blaming the weatherman when it rains."
>
> The Unicode.org website page copy that I quoted is not factual.  There
> should be some limitations.  They should clarify what they are not
> responsible for.  Their home page copy that I quoted is a trap for
> Unicode.org and readers.
>
>
> "You are trying to change the basic form of a letter that has existed in
> the Latin alphabet for over two thousand years, on the basis of an
> association between the K glyph and the intersection of three rivers,
> derived loosely from a secondary Krishna text.  ["that the letter K
> represents suicide and needs to be changed"] You are trying to change the
> basic form of a letter recognized by billions of people, and one of your
> first moves is to approach an international standards-making organization,
> which does NOT standardize the Latin alphabet itself and is NOT in the
> business of deciding what letters are supposed to look like, and accuse them
> of improper conduct because they do not immediately modify their charts and
> develop new fonts based on your views, which so far I have only heard from
> ONE person.  To say you are outside the mainstream would be a serious
> understatement."
>
> The latin / roman k/K letter needs to be replaced to another shape for
> reasons you know.  You have to understand that issue is beyond
> organisational management because it is related to human life.  Approaching
> Unicode.org and IETF.org was essential because they claim to have various
> controls over internet / computer transmitted language.  Some helpful
> interim things should be put in place, leadership and management is much
> needed.  Unicode.org website home page communicates the wrong impression and
> they should correct that.
>
>
> "Style of what?....Content of what?  The standard is described in
> excruciating detail at http://www.unicode.org/versions/Unicode5.1.0/......Unicode doesn't tell people how to design user interfaces.  That is
> completely up to application developers, as it should be.....See
> http://www.unicode.org/consortium/join.html .....Unicode doesn't tell
> people how to build applications, whether open-source or proprietary.  Do
> you feel it should?"
>
> Thus Unicode.org has not any framework.  Certain programmers thus become
> baffled.  The Unicode.org home page copy that I quoted is not factual.
>  There should be some limitations.
>
>
> "It does not say that it will take you by the hand and show you how to
> program, configure, or use a computer in any language."
>
> Unicode.org are unjustly saying things on the website home page copy that I
> quoted, they are not communicating there what they are not responsible for.
>  They are leaving this to other imaginations and trapping themselves and
> others.
>
>
> I refer to .txt files, are you also suggesting that you can put save a .txt
> file on the computer that has unicode 0915 glyph shape?
>
>
> I was being specific that there is not any framework about Style, Content,
> User Interface, Membership and Extensions, these generic areas that can help
> Software Internationalisation otherwise certain programmers would not get
> baffled for example at particular opensource code applications when they are
> asked to remove all k/K letters and replace them with unicode 0915 glyph
> shape.  There should be some catch-all process / principle at header and
> footer of a code for example BBCode / HTML has this and this principle
> perhaps should be considered to ease the burden.  I am not a coder /
> programmer thus I am not sure whether this way is possible.
>
>
> "......It can *only* mean granting of favors, such as employment or
> political status, to personal relatives regardless of their qualifications.
>  You can say "corporate nepotism" if you like and English speakers will
> automatically interpret this as "someone in a corporation was made
> vice-president because he was someone else's brother, not because he
> deserved it."  Nobody will interpret this as "collusion between
> corporations" or "unfair bias."  You need to pick another word that really
> means what you want it to mean.  Nobody can stop you from misusing this word
> if you insist, but they are within their rights to laugh and ignore you."
>
> I saw the Wikipedia "nepotism" meaning and it includes "friends" not only
> "relatives."  Thus "nepotism" is a problem at organisational and corporate
> networks.  This includes Unicode.org and IETF.org.  Leadership and
> management are required to prevent this.
>
>
> "When the day comes when you convince a SIGNIFICANT number of Latin-script
> users, worldwide, that the letter K represents suicide and needs to be
> changed, THEN it is time to approach the standards organizations
> *respectfully* and ask them to make changes that reflect a change that a
> SIGNIFICANT number of people have already adopted.  It needs to be something
> people see in newspapers and on street signs and on television.  Until then,
> this effort will not be seen constructively."
>
> I repeat.....The latin / roman k/K letter needs to be replaced to another
> shape for reasons you know.  You have to understand that issue is beyond
> organisational management because it is related to human life.  Approaching
> Unicode.org and IETF.org was essential because they claim to have various
> controls over internet / computer transmitted language.  Some helpful
> interim things should be put in place, leadership and management is much
> needed.  Unicode.org website home page communicates the wrong impression and
> they should correct that.
>
>
> Unicode.org don't want to listen anymore when it relates to their website
> home page because they blocked my message to the mailing list that was
> critical about this.  Unicode.org should say categorically they are not
> responsible for framework.  However they are communicating the wrong
> impression to the internet / computer community.
>
>
>
>
> Regards
>
>
> Meeku

-- 
Joe Baptista
www.publicroot.org
PublicRoot Consortium
----------------------------------------------------------------
The future of the Internet is Open, Transparent, Inclusive, Representative &
Accountable to the Internet community @large.
----------------------------------------------------------------
 Office: +1 (360) 526-6077 (extension 052)
    Fax: +1 (509) 479-0084
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: linuxa linux <[email-masked]>
Date: Sun, 2 Nov 2008 14:42:43 +0000 (GMT)

Sorry about this error, "The Unicode.org website page copy that I quoted is not factual" and similar.  I should clarify here, not that my gleaning and copy/pasting quotation from the Unicode.org website home page is unfactual, the Unicode.org content itself from their website home page is unfactual.

Regards

Meeku

--- On Sun, 2/11/08, Joe Baptista <[email-masked]> wrote:

> From: Joe Baptista <[email-masked]>
> Subject: Re: Unicode.org Software Internationalisation Standards &Specification
> To: [email-masked]
> Cc: [email-masked], [email-masked]
> Date: Sunday, 2 November, 2008, 2:08 PM
> This all smells bad.
> 
> regards
> joe baptista
> 
> > excruciating detail at
> http://www.unicode.org/versions/Unicode5.1.0/......Unicode
> doesn't tell people how to design user interfaces.  That
> is
> > "Unicode makes it possible to put tens of
> thousands of different characters
> > on a .....a plain-text document"
> >
> > "What sort of "framework" are you
> looking for to accomplish your goals? Be
> > specific, please, for once."
> >

---

From: "Doug Ewell" <[email-masked]>
Date: Sun, 2 Nov 2008 09:37:56 -0700

My last attempt to get through before PLONK.

"linuxa linux" <linuxalinux at yahoo dot co dot uk> wrote:

> "Unicode makes it possible to put tens of thousands of different 
> characters on a .....a plain-text document"
>
> I refer to .txt files, are you also suggesting that you can put save a 
> .txt file on the computer that has unicode 0915 glyph shape?

No plain-text file, anywhere, in any language, in any character 
encoding, specifies the glyph shape.  That is outside the domain of 
plain text.

This e-mail, which is written in plain text, does not specify anything 
about the shapes of the letters, so even though I see it in Lucida Sans 
Unicode, 10 point, you might see it rendered entirely differently.  You 
might see it in a serif font, or cursive, or in bold block capitals.  If 
you were blind, you might not see it at all; you might hear it read to 
you by a screen reader.

If you want the letter between J and L to be represented with a specific 
glyph, you have two choices:

1.  Use U+004B or U+006B, the correct CHARACTER, but specify a 
particular font that renders that character as if it were U+0915.

2.  Use U+0915 directly, which destroys searching and sorting, but which 
will usually be rendered the way you want (or as a box).

The right thing to do, before carrying on this crusade against Unicode, 
would be to read and learn about the difference between "characters" and 
"glyphs."  See http://unicode.org/reports/tr17/#CharactersVsGlyphs.  It 
is much easier to criticize than learn, however, so I doubt you will do 
this.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

---

From: linuxa linux <[email-masked]>
Date: Sun, 2 Nov 2008 17:52:51 +0000 (GMT)

I don't want to discuss further this topic because I have received flamage accusations.  I was reading that link you send however it is a bit complex for the non-coder / non-programmer.

Have a good weekend.

--- On Sun, 2/11/08, Doug Ewell <[email-masked]> wrote:

> From: Doug Ewell <[email-masked]>
> Subject: Re: Unicode.org Software Internationalisation Standards &Specifications
> To: [email-masked]
> Cc: [email-masked]
> Date: Sunday, 2 November, 2008, 4:37 PM
> thousands of different characters on a .....a plain-text
> document"
> > 
> > I refer to .txt files, are you also suggesting that
> you can put save a .txt file on the computer that has
> unicode 0915 glyph shape?
> 
> No plain-text file, anywhere, in any language, in any
> character encoding, specifies the glyph shape.  That is
> outside the domain of plain text.
> 
> This e-mail, which is written in plain text, does not
> specify anything about the shapes of the letters, so even
> though I see it in Lucida Sans Unicode, 10 point, you might
> see it rendered entirely differently.  You might see it in a
> serif font, or cursive, or in bold block capitals.  If you
> were blind, you might not see it at all; you might hear it
> read to you by a screen reader.
> 
> If you want the letter between J and L to be represented
> with a specific glyph, you have two choices:
> 
> 1.  Use U+004B or U+006B, the correct CHARACTER, but
> specify a particular font that renders that character as if
> it were U+0915.
> 
> 2.  Use U+0915 directly, which destroys searching and
> sorting, but which will usually be rendered the way you want
> (or as a box).
> 
> The right thing to do, before carrying on this crusade
> against Unicode, would be to read and learn about the
> difference between "characters" and
> "glyphs."  See
> http://unicode.org/reports/tr17/#CharactersVsGlyphs.  It is
> much easier to criticize than learn, however, so I doubt you
> will do this.
> 
> --