Subject: Solutions to the IDN Problems Discussed

From: linuxa linux <[email-masked]>
Date: Mon, 3 Nov 2008 21:01:34 +0000 (GMT)

February 2008 I had a dialogue with ICANN about Internationalised Domain Names / Internationalized Domain Names and I would like to now make this public on the IETF mailing list because they mention problems and also possible solutions for a better way.

- - - - - 1.
Complaint about .ORG Registry IDN - Asian
Tuesday, 19 February, 2008 8:23 AM
From: "linuxa linux" <[email-masked]>View contact details
To: [email-masked], [email-masked], [email-masked]
Cc: [email-masked]

.COM / .NET have for several years had
Internationalised Domain Names for Asian Languages. 
.ORG is probably as old a suffix / gTLD as them. 
However yesterday I have been told by the .ORG
registry that you appointed for .ORG, that they cannot
give out any time / timeline or even year that they
will implement Internationalised Domain Names for
Asian Languages.  I complain on behalf of myself and
others about this slow way the .ORG registry is
behaving.

Please answer my and others concerns urgently.

Regards

Meeku
..............

- - - - - 2.

RE: Complaint about .ORG Registry IDN - Asian
Tuesday, 19 February, 2008 9:34 AM
From: "Tina Dam" <[email-masked]>View contact details
To: "linuxa linux" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Dear Meeku,
Thank you for your email. The implementation of IDNs under existing TLDs have been done differently for each TLD. Some have followed a very careful approach and are initially only offering a few additional characters (in addition to the historic "a,b,c...,z"/"0,1,2...9"/"-") in order to make sure that everything will still work well for the users.

These introductions are entirely done based on technical and business decisions by the registries. .org is required to follow the IDN Guidelines, however, that does not require them to offer all characters available.

If you would like to make registrations of domain names using characters from some of the Asian languages then please use the TLDs that currently offer such. Your registrar should be able to provide you with more details about which TLDs are available for you.

I hope this is addressing your concerns. Please don't hesitate to let me know if you have any follow-up questions.

Kind regards,

Tina Dam
Director, IDN Program
ICANN

- - - - - 3.

RE: Complaint about .ORG Registry IDN - Asian
Tuesday, 19 February, 2008 8:19 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Tina

Thank you for your response.  I see some problems with
your not being critical of the .ORG registry that
ICANN / you granted the license via not translating
key things on your email.

- the latest registry that took control of the .ORG
suffix is meant to look after particular human
interests, however this registry is not doing this job
for .ORG because the vast majority of the world's
languages have not being given Internationalised
Domain Name facilities on the .ORG suffix

- the .ORG is a gTLD representing the world's
languages however the vast majority of the world's
languages are barred as a result from
Internationalised Domain Name facilities by this
registry that took control of the .ORG suffix
breaching human rights

- thus any license / operation from ICANN to the
registry that took control of the .ORG suffix is under
the above 2 standards and I would be grateful if you
take a critical view.

I also want to complain about the way
Internationalised Domain Name for .COM / .NET etc have
generally been handled from a technical perspective. 
Though I am not an technical expert I can see as a
user the poor service the user is getting.

- The identity of the Internationalised Domain Name
cannot be maintained throughout the Internet and
world-wide web as the registrant-user of a
Internationalised Domain Name has to give 2 website
and email address, one based on their specific
language and another that's is punycode machine code,
just in case the previous does not work

- There has not been any ample evidence showing what
is being done to stop the problem from occurring

- the punycode machine code website and email address
is a lower service level for a user compared to a
non-punicode website and email address 

- all these problems impact on the Internationalised
Domain Name from a user perspective

I also want to complaint about the fact that the
Internationalised Domain Name system is not
multilingual at the domain naming level (the field
between the "http://www" and ".com/net etc" suffixes)
as you cannot mix different languages with each other.

- Specifically I have a need for this from a
religious, philosphical and spiritual reasons and I
mentioned this on an October 2007 email.

Regards

Meeku

- - - - - 4.

RE: Complaint about .ORG Registry IDN - Asian
Thursday, 21 February, 2008 9:49 PM
From: "Tina Dam" <[email-masked]>View contact details
To: "linuxa linux" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Hello Meeku,
I am sorry that we disagree on some of these topics. I have inserted some comments to your points in the below. I am not sure I have understood your concerns completely because some of them seen contradictory. Please see below. However, I hope this helps out. Please let me know if you have any follow-up concerns or questions.

Best regards,
Tina Dam
ICANN

> -----Original Message-----
> From: linuxa linux [mailto:[email-masked]]
> Sent: Tuesday, February 19, 2008 12:20 PM
> To: Tina Dam; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: Complaint about .ORG Registry IDN - Asian
>
> Tina
>
> Thank you for your response.  I see some problems with
> your not being critical of the .ORG registry that
> ICANN / you granted the license via not translating
> key things on your email.
>
> - the latest registry that took control of the .ORG
> suffix is meant to look after particular human
> interests, however this registry is not doing this job
> for .ORG because the vast majority of the world's
> languages have not being given Internationalised
> Domain Name facilities on the .ORG suffix

I think the way that .org is approaching IDN implementation is a safe way for their users. The IDNA protocol is under revision and in addition you have pointed out the user experience issues that we have seen under com and net as examples about how things can go wrong if not enough safe guard is applied. Having a phased approach and making sure that registration policies and variant tables are in place in certain scripts and across the communities that use these scripts is what PIR is doing and in my mind that is a safe approach.

> - the .ORG is a gTLD representing the world's
> languages however the vast majority of the world's
> languages are barred as a result from
> Internationalised Domain Name facilities by this
> registry that took control of the .ORG suffix
> breaching human rights

See above and please keep in mind that you as a user are free to choose any TLD you like that provide the service that you are looking for. You can find the list of all of these that currently are available at http://www.iana.org

> - thus any license / operation from ICANN to the
> registry that took control of the .ORG suffix is under
> the above 2 standards and I would be grateful if you
> take a critical view.
>
>
> I also want to complain about the way
> Internationalised Domain Name for .COM / .NET etc have
> generally been handled from a technical perspective.
> Though I am not an technical expert I can see as a
> user the poor service the user is getting.

.com and .net was the first TLDs where you could make IDN registrations. This goes back to 2001. It was however a trial period and the registry for com and net at the time did not make any promises that the domain names would work in applications to the user. Since then we have learned a lot and the rules for registration at verisign have changed to follow the IDN guidelines. If you have any specific concerns about the way this is handled please let me know and I will pass that on to ICANN's compliance team for review.

If your concern is raised due to the different experience you get as a user depending on the application you are using then there is unfortunately not much more icann can do today than what we already are doing - informing and making recommendations towards implementation efforts. However, it is naturally up to the various application developers to determine whether or not they want to implement IDns and also how. Again, as a user you have a choice. For example you can decide to use the browser that gives you the best experience that you are looking for.

> - The identity of the Internationalised Domain Name
> cannot be maintained throughout the Internet and
> world-wide web as the registrant-user of a
> Internationalised Domain Name has to give 2 website
> and email address, one based on their specific
> language and another that's is punycode machine code,
> just in case the previous does not work

We agree. That is why enabling the domain names as IDNs is not sufficient and does not create a multilingual internet. Market demand towards applications is the only way this truly can work. ICANN is supporting that and agree with you here.

> - There has not been any ample evidence showing what
> is being done to stop the problem from occurring

See above, icann is not in control of application development.

> - the punycode machine code website and email address
> is a lower service level for a user compared to a
> non-punicode website and email address

The email protocol for IDNs is not finalized yet. It is under development within the IETF as all other standards and protocols are. As soon as it is final application providers can choose to implement it or not. Their decision likely depends on market demand.

> - all these problems impact on the Internationalised
> Domain Name from a user perspective

Understood.

>
> I also want to complaint about the fact that the
> Internationalised Domain Name system is not
> multilingual at the domain naming level (the field
> between the "http://www" and ".com/net etc" suffixes)
> as you cannot mix different languages with each other.

There is no requirement to use "www" in a web URL. That then leaves "http" which is a protocol identifier. I can imagine that it would be possible for a browser developer to make a local mapping between "http" in some other script and into "http" in latin script - as a localized solution. However, I have not seen any of those. This is outside ICANNs mandate. In terms of the top levels (.com, .net, .org, .cn, etc) this is what the current IDN Program is trying to address - namely the introduction of IDns that the top level. So that the domain names you register are fully localized. So it is on the way and it is a high priority to ICANN.

>
> - Specifically I have a need for this from a
> religious, philosphical and spiritual reasons and I
> mentioned this on an October 2007 email.
>
>
> Regards
>
>
> Meeku

- - - - - 5.

RE: Complaint about .ORG Registry IDN - Asian
Thursday, 21 February, 2008 11:19 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Tina

What is the contradiction about my 3 complaints:

1.  How the new registry is not doing it's job for IDN
at the.ORG suffix when .COM / .NET suffixes has been
using them for several years and I am alleging this is
breach of human rights? For example you call an
international conference / convention and you only
have  one group doing their interests, this is not
doing a good job and is also human rights breach.

2.  Why is the punycode machine code being brought
into the user experience for IDN features on the the
gTLD suffix like .COM / .NET that includes both
websites and emails with the user having to quote
machine code URLs and email addresses to others as a
safe measure? (Thus this also is a job issue and
breach of human rights) For example you have the
polished non-punycode non-machine code ("Names") for
some and for others they have to quote also the
punycode machine code (More "Numbers") for their
internet and world wide web.

3.  Why are not any multilingual facilities at the
domain naming level - you have ignored this bit as you
have only dealt with the first bit: "http://www" and
the last bit: "suffix,"  not the middle  bit: for
example "ICANN" and "IANA" (domain naming level) -
there is not any possibility of registering a domain
that contains more than 1 language script for example,
English and Sanskrit etc, you cannot register the
domain ICANN-ICANN where the first ICANN has english
script and the second ICANN has sanskrir script, can
you? (Again, this also is a job issue and breach of
human rights) For example you allow some to register
domains without knowing their punycode machine code
and for others they need to know their punycode
machine code and at the international conference /
convention there is not any multilingual sharing
allowed or for example you have only a very limited
cuisine and not an international cuisine buffet
allowing cusines from around the world to mingle and
mix with each other.  I need multilingual feature at
gTLD / gTLD IDN domain naming level for religious,
spiritual and philosophical reasons.

Thus what are the gTLD standards specifically about
here?  I am saying they are not license / operations. 
The gTLD standards are also about doing the gTLD IDN
job and satisfying basic human rights, can we agree on
this?  Once we agree that about this then we can move
forward and compare the performance between the this
and what has actually happened.

Unfortunately when you compare the two, what has
happened is an imbalance between standards and the
performance.  The performance has been slack because
the standards have not filtered to the performance. 

Regards

Meeku

- - - - - 6.

RE: Complaint about .ORG Registry IDN - Asian
Friday, 22 February, 2008 12:00 AM
From: "Tina Dam" <[email-masked]>View contact details
To: "linuxa linux" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Dear Meeku, please see my comments below. And also please re-read my original reply to you for more details on this.

Tina

> -----Original Message-----
> From: linuxa linux [mailto:[email-masked]]
> Sent: Thursday, February 21, 2008 3:20 PM
> To: Tina Dam; [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: Complaint about .ORG Registry IDN - Asian
>
> Tina
>
> What is the contradiction about my 3 complaints:
>
> 1.  How the new registry is not doing it's job for IDN
> at the.ORG suffix when .COM / .NET suffixes has been
> using them for several years and I am alleging this is
> breach of human rights? For example you call an
> international conference / convention and you only
> have  one group doing their interests, this is not
> doing a good job and is also human rights breach.

You were unhappy with the com/net implementation. .org is taking a more conservative approach based on the experience in com/net that showed a bad user experience. There is nothing in the contract with pir that requires them to implement idns in any other way than what they are doing today. The rest is a business decision and they have chosen a careful approach that is safe for their users. As you said, com/net initially did not. We and they learned that lesson.

> 2.  Why is the punycode machine code being brought
> into the user experience for IDN features on the the
> gTLD suffix like .COM / .NET that includes both
> websites and emails with the user having to quote
> machine code URLs and email addresses to others as a
> safe measure? (Thus this also is a job issue and
> breach of human rights) For example you have the
> polished non-punycode non-machine code ("Names") for
> some and for others they have to quote also the
> punycode machine code (More "Numbers") for their
> internet and world wide web.

I did not like that either. However that has to do with applications online. It is your choice as a user to use them or not - or which ones to use. ICANN has no control over software being made available online. If we did we would have much bigger problems than Punycode in address bars.

> 3.  Why are not any multilingual facilities at the
> domain naming level - you have ignored this bit as you
> have only dealt with the first bit: "http://www" and
> the last bit: "suffix,"  not the middle  bit: for
> example "ICANN" and "IANA" (domain naming level) -
> there is not any possibility of registering a domain
> that contains more than 1 language script for example,
> English and Sanskrit etc, you cannot register the
> domain ICANN-ICANN where the first ICANN has english
> script and the second ICANN has sanskrir script, can
> you? (Again, this also is a job issue and breach of
> human rights) For example you allow some to register
> domains without knowing their punycode machine code
> and for others they need to know their punycode
> machine code and at the international conference /
> convention there is not any multilingual sharing
> allowed or for example you have only a very limited
> cuisine and not an international cuisine buffet
> allowing cusines from around the world to mingle and
> mix with each other.  I need multilingual feature at
> gTLD / gTLD IDN domain naming level for religious,
> spiritual and philosophical reasons.

Ok so I did not understand your original question on this. On the second level you cannot mix scripts unless there is a linguistic reason for doing so. That means that you cannot mic for example latin and Cyrillic...if would cause confusion and did so initially under com and net. Any other way will damage the uniqueness nature of the DNS and that would destroy the internet as we have it today.

>
> Thus what are the gTLD standards specifically about
> here?  I am saying they are not license / operations.
> The gTLD standards are also about doing the gTLD IDN
> job and satisfying basic human rights, can we agree on
> this?  Once we agree that about this then we can move
> forward and compare the performance between the this
> and what has actually happened.

The relationship between icann and the registries is outlined in the contracts and these contracts are available online. If you like to go into the content of these then I will refer you to some of my colleagues as this is not my work area. However, in relation to IDN implementation PIR is not in violation of their agreement.

> Unfortunately when you compare the two, what has
> happened is an imbalance between standards and the
> performance.  The performance has been slack because
> the standards have not filtered to the performance.

Maybe you should participate in the technical work at the IETF where standards and protocols are being developed. These are considered the secure way of running a TLD and as such all registries are required to follow them. If this is causing performance problems that affect you then I am sorry about that. Technology only go so far and in regards to IDNs they set some limitations that also where the case with the ASCII domains, however they are likely to be felt more like unfair limitations in relation to IDNs. They are not however and because of that there is nothing I can do to assist you further, unless you have some more specific concerns that you would like to address.

> Regards
> Meeku

- - - - - 7.

RE: Complaint about .ORG Registry IDN - AsianFriday, 22 February, 2008 11:05 AM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

Here is the response about standards versus
performance:

1.I don't know how much responsibility you have been
given for ICANN, gTLD and gTLD IDN and whether you are
only following someone else or others or yourself. 
Certainly I have been let down about the first
complaint as you are not fully giving meaning to the
acronyms ICANN, IDN and gTLD.
2.I don't know why you are critical about the IDN
implementation at .COM / .NET where people can
register IDN domains and why you are not allowing the
same punycode machine code treatment for ASCII based
english / european domains to be implemented. 
Certainly I have been let down about the second
complaint as you are not giving equal punycode machine
code treatment to all languages and scripts.
3.I don't know why you are refusing to allow the
domain naming space to become multilingual and saying
that making the domain naming space multilingual will
destroy the internet and word wide web.  Certainly I
have been let down about the third complaint as you
are not dealing with the second complaint about
punycoding ASCII english / european scripts that is
impacting on the third complaint because punycoding
the domain naming space can make it multilingual.

Regards

Meeku

- - - - - 8.

RE: Complaint about .ORG Registry IDN - AsianFriday, 22 February, 2008 5:41 PM
From: "Tina Dam" <[email-masked]>View contact details
To: "linuxa linux" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>

Dear Meeku,
Please read my responses to you again. I will try to address your concerns one more time in the below. If this is not satisfactory to you then please feel free to pass your complaint on in the system. For example that could be to the ICANN ombudsman that then will review your complaint and my responses and make a determination as to whether I have addressed these adequately.

Unless you have new concerns or new questions or new complaints about this topic, I consider this case closed.

Best regards,
Tina Dam
Director, IDN Program
ICANN

> -----Original Message-----
> From: linuxa linux [mailto:[email-masked]]
> Sent: Friday, February 22, 2008 3:06 AM
> To: Tina Dam; [email-masked]
> Cc: [email-masked]
> Subject: RE: Complaint about .ORG Registry IDN - Asian
>
> Here is the response about standards versus
> performance:
>
> 1.I don't know how much responsibility you have been
> given for ICANN, gTLD and gTLD IDN and whether you are
> only following someone else or others or yourself.
> Certainly I have been let down about the first
> complaint as you are not fully giving meaning to the
> acronyms ICANN, IDN and gTLD.

I don't understand this complaint. If you are talking about my position at ICANn then I am in charge of all IDN related matters.

> 2.I don't know why you are critical about the IDN
> implementation at .COM / .NET where people can
> register IDN domains and why you are not allowing the
> same punycode machine code treatment for ASCII based
> english / european domains to be implemented.
> Certainly I have been let down about the second
> complaint as you are not giving equal punycode machine
> code treatment to all languages and scripts.

You mentioned yourself that com/net implementation of IDNs gave a bad customer experience. That is correct and both ICANN and verisign agreed to that. It was however in the testbed in 2001 and many things have been changed since as we have learned about idns - hence the customer experience has improved. Regarding equal "punycode machine treatment to all languages and scripts", first please understand that the IDNA protocol that turns strings into Punycode does not understand languages it merely take the characters requested and based on the properties that these have in Unicode it will develop a Punycode string or return an error. The protocol is developed by the IETF and is used by all registries. It has nothing to do with ICANN and there is nobody at icann making decisions about what characters should be valid and which should not. In relation to what characters the various registries decide to support, I have addressed that already and as you can see
 in my previous replies I find that PIR are conforming to the IDN standards and as such to their contract with icann. If you are not happy with the characters they allow under .org then please choose another tld. Various tlds are available so that customer and users can make their own choices of which one they would like to use.

> 3.I don't know why you are refusing to allow the
> domain naming space to become multilingual and saying
> that making the domain naming space multilingual will
> destroy the internet and word wide web.  Certainly I
> have been let down about the third complaint as you
> are not dealing with the second complaint about
> punycoding ASCII english / european scripts that is
> impacting on the third complaint because punycoding
> the domain naming space can make it multilingual.

I don't know where you are getting this from. If there is a person in the world that would like to see the Internet fully multilingual it would be me. However, ICANN's mandate only reaches so far and we cannot force application developers and providers to internationalize their products. I have NEVER expressed that making the Internet multilingual will destroy the internet, actually the contrary I what I continuously express: if we don't work toward internationalization of the internet then it will be destroyed due to alternate root systems and the like.

> Regards
> Meeku

- - - - - 9.

RE: Complaint about .ORG Registry IDN - Asian
Friday, 22 February, 2008 7:47 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

I really would not like to this to be dealt with any
further by the nepotistic ICANN-family because there
is not any real opensource volunteering.

Regarding the new information that you mention:

1.  You say you are incharge but there is not any
standard reaching at the performance level by the
registry that controls .ORG as they have made the .ORG
into not being a gTLD as the majority of the languages
are not being supported.  Had the earlier registry not
had control of the .ORG taken away, they would have
made .ORG multilingual like they have for .COM and
.NET years ago.

2.  Firstly punycode machine code has allowed IDNs and
the .COM / .NET registry has even produced free
software, see also their specific IDN website
www.IDNnow.com.  The user experience has suffered
because of ICANN has not used punycode machine code
(NUMBERS) throughout the suffixes, it presumes that
NUMBERS are only the digital and decimal code and it
does not consider punycode to be NON-NAMES or as a
shorthand NUMBERS. Then when it comes to NAMES there
ICANN considers these to be ASCII-based languages only
and for Non-ASCII-based languages ICANN considers them
to be punycode machine code.  How can NAMES be
considered to be punycode machine code and if
ASCII-based languages are considered to be NAMES then
for Non-ASCII based languages to have equal virtue
treatment why are ASCII-based languages also not made
to rely only on punycode machine code like the
Non-ASCII based languages.  Thus it is suggested that
ICANN - Internet Corporation for Assigned Names and
Numbers change it's name by not having "Names" in it's
wording as it is not relevant from an equal virtue for
all languages treatment.  When all languages are
punycoded machine coded at the domain naming space
then applications like browsers, email clients,
webmail etc will all become compliant to punycode
machine code and the users will get a better
experience.

3.  You / ICANN are your own enemy because you say you
like multilingual but then when it comes to
implementing it, you say you won't and I should take
my compliant to the ICANN-ombudsman.  Make the whole
internet system dually-based on both digital decimal
code and punycode machine code linked.

I am not a technical expert, thus my understanding
could be flawed, thus I would like say sorry for any
errors throughout this.  

Regards

Meeku

- - - - - 10.

Solutions to the IDN Problems Discussed
Saturday, 23 February, 2008 10:16 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

I would be interested to find your views about these
solutions without being told, 'hey, contact the ICANN
Ombudsman and follow the complaint procedure.'

1.  A punycode machine url primary whois [Whois 1] for
all domains names that also include the the ASCII
script languages domain names (I presume that whois is
the base-setter / decider for each domain name
throughout the Internet and the world wide web)  This
way would make the application providers change their
software quicker to multilingual. 

You could have the existing (secondary) whois [Whois2]
not as base-setter / decider but as a supporting
language script translator only. 

2.  Maintain the IDN rollout integrity by allocating
the the unused IDN languages work of a slow to
implement registry like with the .ORG suffix by the
PIR registry to another registry that can implement
IDNs almost immediately viz-a-viz Verisign, the .COM /
.NET registry.  

Regards

Meeku

- - - - - 11.

Re: Solutions to the IDN Problems Discussed
Sunday, 24 February, 2008 9:31 AM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

Correction:  Where it says "1.  A punycode machine url
primary whois [Whois 1] for all domains names"

I meant this:

"1.  A punycode machine CODE primary whois [Whois 1]
for all domains names"

Regards

Meeku

- - - - - 12.

Re: Solutions to the IDN Problems Discussed
Sunday, 24 February, 2008 1:54 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

Sorry what I meant was:

"........1.  A punycode-machine-code-domain-names
primary whois [Whois 1] for all domains
names........."

Regards

Meeku

- - - - - 13.

Re: Solutions to the IDN Problems Discussed
Sunday, 24 February, 2008 9:13 PM
From: "linuxa linux" <[email-masked]>View contact details
To: "Tina Dam" <[email-masked]>, [email-masked]
Cc: "[email-masked]" <[email-masked]>

There is a problem with solution #1 - it already
exists :) though for semi-ASCII language and
Internationalised domain names it does not work :(
because I visited this website
http://www.nameisp.com/puny.asp and did  an experiment
with total-ASCII language domain names and the
punycode representation was the same as the domain
name.  Thus there is a problem with punycode machine
code presently, as it "cheats" and does not "code" the
total-ASCII language domain names like it does with
semi-ASCII language and Internationalised domain
names.

Having identified the base-setter / decider problem
either the punycode needs to be changed to "punycode2"
that "codes" even the total-ASCII language domain
names and does not just facsimile the domain names; or
another  punycode alternative needs to identified,
however this will require extra work as you have IDNs
that are on the registries based on punycode.

Then after this being done a machine-code-domain-names
primary whois [Whois 1] for all domains that also
includes the total-ASCII script languages domain names
can happen with the existing (secondary) whois
[Whois2] not being the Internet and world wide web
base-setter / decider but being only a supporting
language script translator only for registering domain
names and ownership. 

Putting this into action will automatically mean that
whatever code: "punycode2" or punycode alternative
will    get the software application developers to
alter their existing and new applications to a
multilingual standard much faster than what has
happened in the past.

Regards

Meeku

- - - - - 14.

(This IETF mailing list email also has been copied to [email-masked], [email-masked], [email-masked], [email-masked])

- - - - - 

Regards

Meeku
http://twitter.com/nepotism

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Roger Jørgensen" <[email-masked]>
Date: Mon, 3 Nov 2008 22:44:19 +0100

sometime its said you shouldn't feed the trolls but right now I think
its necessary todo so. Could you please stop posting all of this
nonsens on this list? So please take your private problems elsewhere.

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
...
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Joe Baptista" <[email-masked]>
Date: Mon, 3 Nov 2008 18:51:20 -0500

This whole thread makes no sense.  I think you should be able to register
idns at .org.  You just need to know the punycode equivalent.  Let say you
wanted to register apple.org in russian which is
яблоко.org<http://xn--90ascmb1h.org>.
The punycode equivalent is xn--90ascmb1h.org.

The only way the registration would be blocked is if they have specifically
disallowed all domain names that start with xn--.  In that case they are
intentionally disallowing registrations of idns.

regards
joe baptista

On Mon, Nov 3, 2008 at 4:01 PM, linuxa linux <[email-masked]>wrote:

> February 2008 I had a dialogue with ICANN about Internationalised Domain
> Names / Internationalized Domain Names and I would like to now make this
> public on the IETF mailing list because they mention problems and also
> possible solutions for a better way.
>
>
> - - - - - 1.
> To: "linuxa linux" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> Thank you for your email. The implementation of IDNs under existing TLDs
> have been done differently for each TLD. Some have followed a very careful
> approach and are initially only offering a few additional characters (in
> addition to the historic "a,b,c...,z"/"0,1,2...9"/"-") in order to make sure
> that everything will still work well for the users.
>
> These introductions are entirely done based on technical and business
> decisions by the registries. .org is required to follow the IDN Guidelines,
> however, that does not require them to offer all characters available.
>
> If you would like to make registrations of domain names using characters
> from some of the Asian languages then please use the TLDs that currently
> offer such. Your registrar should be able to provide you with more details
> about which TLDs are available for you.
>
> I hope this is addressing your concerns. Please don't hesitate to let me
> know if you have any follow-up questions.
>
> Kind regards,
>
>
> Tina Dam
> Director, IDN Program
> ICANN
>
> - - - - - 3.
>
> To: "linuxa linux" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> I am sorry that we disagree on some of these topics. I have inserted some
> comments to your points in the below. I am not sure I have understood your
> concerns completely because some of them seen contradictory. Please see
> below. However, I hope this helps out. Please let me know if you have any
> follow-up concerns or questions.
>
> Best regards,
> Tina Dam
> ICANN
>
> I think the way that .org is approaching IDN implementation is a safe way
> for their users. The IDNA protocol is under revision and in addition you
> have pointed out the user experience issues that we have seen under com and
> net as examples about how things can go wrong if not enough safe guard is
> applied. Having a phased approach and making sure that registration policies
> and variant tables are in place in certain scripts and across the
> communities that use these scripts is what PIR is doing and in my mind that
> is a safe approach.
>
>
> See above and please keep in mind that you as a user are free to choose any
> TLD you like that provide the service that you are looking for. You can find
> the list of all of these that currently are available at
> http://www.iana.org
>
>
> .com and .net was the first TLDs where you could make IDN registrations.
> This goes back to 2001. It was however a trial period and the registry for
> com and net at the time did not make any promises that the domain names
> would work in applications to the user. Since then we have learned a lot and
> the rules for registration at verisign have changed to follow the IDN
> guidelines. If you have any specific concerns about the way this is handled
> please let me know and I will pass that on to ICANN's compliance team for
> review.
>
> If your concern is raised due to the different experience you get as a user
> depending on the application you are using then there is unfortunately not
> much more icann can do today than what we already are doing - informing and
> making recommendations towards implementation efforts. However, it is
> naturally up to the various application developers to determine whether or
> not they want to implement IDns and also how. Again, as a user you have a
> choice. For example you can decide to use the browser that gives you the
> best experience that you are looking for.
>
> We agree. That is why enabling the domain names as IDNs is not sufficient
> and does not create a multilingual internet. Market demand towards
> applications is the only way this truly can work. ICANN is supporting that
> and agree with you here.
>
>
> The email protocol for IDNs is not finalized yet. It is under development
> within the IETF as all other standards and protocols are. As soon as it is
> final application providers can choose to implement it or not. Their
> decision likely depends on market demand.
>
> There is no requirement to use "www" in a web URL. That then leaves "http"
> which is a protocol identifier. I can imagine that it would be possible for
> a browser developer to make a local mapping between "http" in some other
> script and into "http" in latin script - as a localized solution. However, I
> have not seen any of those. This is outside ICANNs mandate. In terms of the
> top levels (.com, .net, .org, .cn, etc) this is what the current IDN Program
> is trying to address - namely the introduction of IDns that the top level.
> So that the domain names you register are fully localized. So it is on the
> way and it is a high priority to ICANN.
>
> >
> Dear Meeku, please see my comments below. And also please re-read my
> original reply to you for more details on this.
>
> Tina
>
>
> You were unhappy with the com/net implementation. .org is taking a more
> conservative approach based on the experience in com/net that showed a bad
> user experience. There is nothing in the contract with pir that requires
> them to implement idns in any other way than what they are doing today. The
> rest is a business decision and they have chosen a careful approach that is
> safe for their users. As you said, com/net initially did not. We and they
> learned that lesson.
>
>
> I did not like that either. However that has to do with applications
> online. It is your choice as a user to use them or not - or which ones to
> use. ICANN has no control over software being made available online. If we
> did we would have much bigger problems than Punycode in address bars.
>
> Ok so I did not understand your original question on this. On the second
> level you cannot mix scripts unless there is a linguistic reason for doing
> so. That means that you cannot mic for example latin and Cyrillic...if would
> cause confusion and did so initially under com and net. Any other way will
> damage the uniqueness nature of the DNS and that would destroy the internet
> as we have it today.
>
>
> >
> The relationship between icann and the registries is outlined in the
> contracts and these contracts are available online. If you like to go into
> the content of these then I will refer you to some of my colleagues as this
> is not my work area. However, in relation to IDN implementation PIR is not
> in violation of their agreement.
>
> Maybe you should participate in the technical work at the IETF where
> standards and protocols are being developed. These are considered the secure
> way of running a TLD and as such all registries are required to follow them.
> If this is causing performance problems that affect you then I am sorry
> about that. Technology only go so far and in regards to IDNs they set some
> limitations that also where the case with the ASCII domains, however they
> are likely to be felt more like unfair limitations in relation to IDNs. They
> are not however and because of that there is nothing I can do to assist you
> further, unless you have some more specific concerns that you would like to
> address.
>
> >
> > Regards
> >
> >
> > Meeku
>
> - - - - - 7.
>
> Please read my responses to you again. I will try to address your concerns
> one more time in the below. If this is not satisfactory to you then please
> feel free to pass your complaint on in the system. For example that could be
> to the ICANN ombudsman that then will review your complaint and my responses
> and make a determination as to whether I have addressed these adequately.
>
> I don't understand this complaint. If you are talking about my position at
> ICANn then I am in charge of all IDN related matters.
>
>
> You mentioned yourself that com/net implementation of IDNs gave a bad
> customer experience. That is correct and both ICANN and verisign agreed to
> that. It was however in the testbed in 2001 and many things have been
> changed since as we have learned about idns - hence the customer experience
> has improved. Regarding equal "punycode machine treatment to all languages
> and scripts", first please understand that the IDNA protocol that turns
> strings into Punycode does not understand languages it merely take the
> characters requested and based on the properties that these have in Unicode
> it will develop a Punycode string or return an error. The protocol is
> developed by the IETF and is used by all registries. It has nothing to do
> with ICANN and there is nobody at icann making decisions about what
> characters should be valid and which should not. In relation to what
> characters the various registries decide to support, I have addressed that
> already and as you can see
>  in my previous replies I find that PIR are conforming to the IDN standards
> and as such to their contract with icann. If you are not happy with the
> characters they allow under .org then please choose another tld. Various
> tlds are available so that customer and users can make their own choices of
> which one they would like to use.
>
> I don't know where you are getting this from. If there is a person in the
> world that would like to see the Internet fully multilingual it would be me.
> However, ICANN's mandate only reaches so far and we cannot force application
> developers and providers to internationalize their products. I have NEVER
> expressed that making the Internet multilingual will destroy the internet,
> actually the contrary I what I continuously express: if we don't work toward
> internationalization of the internet then it will be destroyed due to
> alternate root systems and the like.
>
> > Regards
> >
> >
> > Meeku
>
> - - - - - 9.
>
> (This IETF mailing list email also has been copied to [email-masked],
> [email-masked], [email-masked], [email-masked])
>
> - - - - -
>
>
> Regards
>
>
>
> Meeku

-- 
Joe Baptista
www.publicroot.org
PublicRoot Consortium
----------------------------------------------------------------
The future of the Internet is Open, Transparent, Inclusive, Representative &
Accountable to the Internet community @large.
----------------------------------------------------------------
 Office: +1 (360) 526-6077 (extension 052)
    Fax: +1 (509) 479-0084
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf