Subject: What basis we have to construct NHAF for IBGP and EBGP?

From: Venkateshwaran R <[email-masked]>
Date: Sat, 22 Nov 2008 09:39:03 +0530 (IST)

Hi 

I am Venkateshwaran(Venkat in short) from Chennai, India.

Please clarify my doubt in BGP4+ how next hop field is constructed?

Setup
=====
Three routers RT1 , RT2 and RT3.
RT1 and RT2 are in same AS 100.  RT3 is different AS 200.
RT1 and RT3 is connected with RT2.

Under this setup i need to clarify the following:

1.  How the next hop field is going to be constructed for MP_REACH_NLRI attribute?

   I simulated the same scenario against cisco and zebra.  

   Cisco sends ipv6 global address alone to RT1. To RT3 it sends both ipv6 global address and link local address.

   Zebra sends both ipv6 global address and link local address to RT1 and RT3.

    Why this different behavior?  Kindly Please clarify me in what basis we have to construct NHAF for IBGP and EBGP?

Regards
Venkat

      Add more friends to your messenger and enjoy! Go to http://messenger.yahoo.com/invite/

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "AJ Jaghori" <[email-masked]>
Date: Sat, 22 Nov 2008 16:29:24 -0500

Venkat,

Can you provide some further configs on R1 and R3?  I'm a bit confused
as to how Cisco is advertising these routes?

On 11/21/08, Venkateshwaran R <[email-masked]> wrote:
>     Why this different behavior?  Kindly Please clarify me in what basis we
> have to construct NHAF for IBGP and EBGP?
>
> Regards
> Venkat
>
>
>
>
>

-- 
AJ Jaghori
Chief Network Architect | Author | Professor
[email-masked]
M: 703.362.5002
_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: Venkateshwaran R <[email-masked]>
Date: Mon, 24 Nov 2008 16:46:35 +0530 (IST)

Hi Jaghori

Thanks for you response.

Actually R1 and R3 routers are our simulation routers. Simply those routers are responding TCP packets and BGP messages to maintain the session with R2.

Our application simulates like BGP router.

Here R1 establishes IBGP connection against R2. 
Similarly R3 establishes EBGP connection against R2.

Following commands has been configured on R2.

R2#router bgp 100
R2#neighbor R1 remote-as 100
R2#neighbor R3 remote-as 200
R2#address-family ipv6 unicast
R2#neighbor R1 activate
R2#neighbor R3 activate
R2#network 5ffe::/64

Once a TCP connection has established against R1 , R2 has to advertise 5ffe::/64 to R1.  Similarly against R3.

If R2 is cisco
==============
In R1 i am getting UPDATE message with ipv6 global address alone in NHAF.
In R3 i am getting UPDATE message with ipv6 global address and link local addres in NHAF.

If R2 is zebra
==============

In R1 i am getting UPDATE message with ipv6 global address and link local addres in NHAF.

In R3 i am getting UPDATE message with ipv6 global address and link local addres in NHAF.

Hope you understand my setup.  Please clarify if i am wrong.

Regards
Venkat

--- On Sun, 23/11/08, AJ Jaghori <[email-masked]> wrote:

> From: AJ Jaghori <[email-masked]>
> Subject: Re: What basis we have to construct NHAF for IBGP and EBGP?
> To: [email-masked], [email-masked]
> Date: Sunday, 23 November, 2008, 2:59 AM
> Venkat,
> 
> > 1.  How the next hop field is going to be constructed
> for MP_REACH_NLRI
> > attribute?
> >
> >    Cisco sends ipv6 global address alone to RT1. To
> RT3 it sends both ipv6
> > global address and link local address.
> >
> >    Zebra sends both ipv6 global address and link local
> address to RT1 and
> > RT3.
> >
> >       Add more friends to your messenger and enjoy! Go
> to
> > http://messenger.yahoo.com/invite/
> >

      Get perfect Email ID for your Resume. Grab now http://in.promos.yahoo.com/address