Subject: Re: [P2PSIP] How to describe the processing power

From: "Das, Saumitra" <[email-masked]>
Date: Wed, 12 Nov 2008 01:12:09 -0800

Dear Song,

   Processing power would be more informational in terms of CPU load. A good example of what would be useful would be to look at the comon monitoring tool (http://summer.cs.princeton.edu/status/) for the planetlab testbed. It uses the following metrics for selecting nodes based on CPU and I have found such selection to be very useful in determining the performance of a slice on the machine.

>From the comon site, these are some metrics that may be useful

"CPU Speed
Busy CPU
Sys CPU
Free CPU
These fields give some insight into the CPU behavior of the node. The CPU Speed is just the speed of the processor in gigahertz. The Busy CPU field gives the % of time the CPU is utilized, and the Sys CPU field specifies what percentage of time the CPU is spending in the OS. Both of these values are the maximum values over the past 5 minutes. The Free CPU indicates how much of the CPU a spin-loop was able to obtain, giving some insight into how much of the node's CPU a new slice would receive."

We could define these fields and leave it optional as to whether all of them are required. i.e. running a spin-loop may be expensive for some devices.

Best,

Saumitra

www.saumitra.info

Date: Tue, 11 Nov 2008 15:12:21 +0800

From: Song Haibin <[email-masked]>

Subject: [P2PSIP] How to describe the processing power

To: [email-masked]

Message-ID: <[email-masked]>

Content-Type: text/plain; charset=us-ascii

Dear all,

In p2psip diagnostics draft

http://tools.ietf.org/id/draft-zheng-p2psip-diagnose-03.txt

, we have some doubt about how to describe one of the diagnostic

information: processing power. We propose to use the unit of MIPS to describe it. However, the Max number of connections may be another choice.

Do you have any good suggestions?

Best Regards,

Song Haibin

Email: [email-masked]<mailto:[email-masked]>

Skype: alexsonghw

_______________________________________________
Ietf mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ietf

---

From: "Roni Even" <[email-masked]>
Date: Thu, 13 Nov 2008 16:34:32 +0200

Song Haibin,

Your response " It is also useful in selecting peer for a neighbor table
entry, when there are multiple choices existing and for the overlay
management to collect the overall status of the overlay."  does also address
Bruce question. My view is that the pure CPU power or CPU current usage are
good but the question is if they are relevant for the decision  since the
user may limit the amount of resources it wants to allocate for the p2p
application. This may be based on percentage from the link or number of
connections. 

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Song Haibin
Sent: Thursday, November 13, 2008 5:07 AM
To: 'Das, Saumitra'; [email-masked]
Cc: [email-masked]
Subject: Re: [P2PSIP] How to describe the processing power

Dear Das,

See inline.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Das, Saumitra
Sent: Wednesday, November 12, 2008 5:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [P2PSIP] How to describe the processing power

Dear Song,

   Processing power would be more informational in terms of CPU load. A good
example of what would be useful would be to look at the comon monitoring
tool (http://summer.cs.princeton.edu/status/) for the planetlab testbed. It
uses the following metrics for selecting nodes based on CPU and I have found
such selection to be very useful in determining the performance of a slice
on the machine.

[Song] It is also useful in selecting peer for a neighbor table entry, when
there are multiple choices existing and for the overlay management to
collect the overall status of the overlay. 

>From the comon site, these are some metrics that may be useful

"CPU Speed
Busy CPU
Sys CPU
Free CPU
These fields give some insight into the CPU behavior of the node. The CPU
Speed is just the speed of the processor in gigahertz. The Busy CPU field
gives the % of time the CPU is utilized, and the Sys CPU field specifies
what percentage of time the CPU is spending in the OS. Both of these values
are the maximum values over the past 5 minutes. The Free CPU indicates how
much of the CPU a spin-loop was able to obtain, giving some insight into how
much of the node's CPU a new slice would receive."

We could define these fields and leave it optional as to whether all of them
are required. i.e. running a spin-loop may be expensive for some devices.

[Song] This is helpful. I'm very glad to see this monitoring tool in the
planetlab testbed. If it works well in the planet lab, we may have it
included in the diagnostics draft after discussion. I also see other useful
metrics for other parameters in the page
(http://summer.cs.princeton.edu/status/).

 

Best,

Saumitra

www.saumitra.info

To: [email-masked]

Dear all,

information: processing power. We propose to use the unit of MIPS to
describe it. However, the Max number of connections may be another choice.

 

Best Regards,

Song Haibin

Email: [email-masked]

Skype: alexsonghw

---

From: Song Haibin <[email-masked]>
Date: Thu, 13 Nov 2008 11:06:36 +0800

Dear Das,

See inline.

  _____  

Dear Song,

"CPU Speed
Busy CPU
Sys CPU
Free CPU

 

Best,

Saumitra

www.saumitra.info

To: [email-masked]

Dear all,

 

Best Regards,

Song Haibin

Skype: alexsonghw

---

From: "Bruce Lowekamp" <[email-masked]>
Date: Thu, 13 Nov 2008 11:13:43 -0500

There are still a lot of open research questions for metrics like
this, but I think it's fine to include something like that in
diagnostics.  What you really want is something like max messages
forwarded per second and then current load as a factor of that, which
would factor in both cpu load and network load.  But in general,
things like that are really hard to compute, which is why what ends up
being reported is utilization and maybe capacity if it can be
measured.

I think the most important characteristic for metrics to be reported
via diagnostics is that they be well-defined and possible to measure,
so an implementer knows how to measure what is being requested and the
user knows what it means.

Also need to make sure whatever diagnostics are defined leverage
existing stuff whenever possible.  A lot of thought has gone into
existing stuff through groups like IPPM, so coming up with new ways to
measure network performance probably isn't going to be worthwhile.

Bruce

On Thu, Nov 13, 2008 at 9:34 AM, Roni Even <[email-masked]> wrote:
> ________________________________
>
> P2PSIP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/p2psip
>
>

---

From: "Das, Saumitra" <[email-masked]>
Date: Thu, 13 Nov 2008 10:32:21 -0800

If there is an API for setting the amount of resources in RELOAD implementations, would this be done per usage or overall for RELOAD. That would affect what and how we report stuff in the diagnostics.
I think the comon CPU stats are still useful along with which we could report some number set up by the user that specifies the resources.

Different topology plugin apps could then use different heuristics to perform neighbor selection based on this information depending on what they are aimed at. I agree that what is proposed here should both help debug an overlay as well as help in populating some metrics data which can then be used by topology plugins.

On a related note, would metrics collected using a Chord topology plugin be useful to a Pastry topology plugin. Due to the use of nodeids it may be hard to reuse this information across topology plugins.

Thanks,
Saumitra

From: Roni Even [mailto:[email-masked]]
Sent: Thursday, November 13, 2008 6:35 AM
To: 'Song Haibin'; Das, Saumitra; [email-masked]
Cc: [email-masked]
Subject: RE: [P2PSIP] How to describe the processing power

Song Haibin,
Your response " It is also useful in selecting peer for a neighbor table entry, when there are multiple choices existing and for the overlay management to collect the overall status of the overlay."  does also address Bruce question. My view is that the pure CPU power or CPU current usage are good but the question is if they are relevant for the decision  since the user may limit the amount of resources it wants to allocate for the p2p application. This may be based on percentage from the link or number of connections.

Roni Even

From: [email-masked] [mailto:[email-masked]] On Behalf Of Song Haibin
Sent: Thursday, November 13, 2008 5:07 AM
To: 'Das, Saumitra'; [email-masked]
Cc: [email-masked]
Subject: Re: [P2PSIP] How to describe the processing power

Dear Das,

See inline.

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Das, Saumitra
Sent: Wednesday, November 12, 2008 5:12 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [P2PSIP] How to describe the processing power

Dear Song,

[Song] It is also useful in selecting peer for a neighbor table entry, when there are multiple choices existing and for the overlay management to collect the overall status of the overlay.

"CPU Speed
Busy CPU
Sys CPU
Free CPU

[Song] This is helpful. I'm very glad to see this monitoring tool in the planetlab testbed. If it works well in the planet lab, we may have it included in the diagnostics draft after discussion. I also see other useful metrics for other parameters in the page (http://summer.cs.princeton.edu/status/).

Best,

Saumitra

www.saumitra.info

To: [email-masked]

Dear all,

Best Regards,

Song Haibin

Skype: alexsonghw

---

From: "Das, Saumitra" <[email-masked]>
Date: Thu, 13 Nov 2008 10:56:11 -0800

Hi Song,

I agree that this could be used for various things like

1.       Overall overlay status information for the overlay deployer

2.       Peer selection for neighbor table entries by topology plugins

3.       And maybe also designating functionalities to nodes based on metrics observed

Yes, there are other metrics from comon related to memory usage, bandwidth use which may also be useful.

Thanks
Saumitra

From: Song Haibin [mailto:[email-masked]]
Sent: Wednesday, November 12, 2008 7:07 PM
To: Das, Saumitra; [email-masked]
Cc: [email-masked]
Subject: RE: [P2PSIP] How to describe the processing power

Dear Das,

See inline.

Dear Song,

"CPU Speed
Busy CPU
Sys CPU
Free CPU

Best,

Saumitra

www.saumitra.info

To: [email-masked]

Dear all,

Best Regards,

Song Haibin

Skype: alexsonghw