Subject: RE: draft-ietf-ltru-4645bis-10.txt issue with preferred value for YU

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 2 Mar 2009 09:49:02 -0800

Hi Tex,

I don't think this is probably appropriate, at least for this list to consider.

1. You haven't posted to LTRU's mailing list, only ietf-languages@, yet.

2. Even if draft-4645bis is approved, the process for language tags (in either RFC 4646 or its proposed successor) allow you to register the information you want, if you think it was inappropriately omitted.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Monday, March 02, 2009 3:43 AM
> To: [email-masked]
> Subject: Ietf Digest, Vol 10, Issue 4
> 
> Send Ietf mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www.ietf.org/mailman/listinfo/ietf
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Ietf digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: Internet Society joins Liberty Alliance Management Board:
>       Why? (Patrik F?ltstr?m)
>    2. draft-ietf-ltru-4645bis-10.txt issue with preferred value for
>       YU (Tex Texin)
>    3. Terminal room at IETF74 (Dearlove, Christopher (UK))
>    4. Identity Services Beyond Web SSO (was RE: [TLS] TLS WG Chair
>       Comments	on draft-ietf-tls-authz-07) (Josh Howlett)
>    5. New IETF Journal available now (Volume 4, Issue 3) (Mirjam
> Kuehne)
>    6. Re: Internet Society joins Liberty Alliance Management Board:
>       Why? (Olaf Kolkman)
> 
> 
> -------------------------------------------------------------------
> ---
> 
> Message: 1
> Date: Mon, 2 Mar 2009 07:23:10 +0100
> From: Patrik F?ltstr?m <[email-masked]>
> Subject: Re: Internet Society joins Liberty Alliance Management
> Board:
> 	Why?
> To: John C Klensin <[email-masked]>
> Cc: Hannes Tschofenig <[email-masked]>,	"Lynn St.
> Amour"
> 	<[email-masked]>,	Dave CROCKER <[email-masked]>,
> 	[email-masked], [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"; Format="flowed";
> 	DelSp="yes"
> 
> On 2 mar 2009, at 04.12, John C Klensin wrote:
> 
> > I am not suggesting trying to undo this decision, but believe
> > that, as ISOC adds sufficient technically-qualified staff to
> > engage in activities like this on its own, we need to work,
> > collectively, on better ways to facilitate communication in a
> > timely basis in the future.  In particular, we need to work
> > fairly hard to avoid a situation in which the IETF and ISOC end
> > up with different positions on an issue with external visibility
> > and consequences.  To do so would damage the credibility of all
> > concerned.
> 
> This I completely agree with, we have to avoid such situations.
> 
> But we have to also to work hard on not to create a chicken out of
> a
> feather. Instead learn and do things even better next time.
> 
> Regarding Liberty Alliance, I think we should let Lucy coordinate
> some
> more information for the IETF that can be presented in due time. As
> she said, she will (as well as I) be in San Francisco and we are
> all
> happy to talk.
> 
>     Patrik
> 
> -------------- next part --------------
> A non-text attachment was scrubbed...
> Name: PGP.sig
> Type: application/pgp-signature
> Size: 186 bytes
> Desc: This is a digitally signed message part
> Url : <http://www.ietf.org/mail-
> archive/web/ietf/attachments/20090302/28633679/attachment.sig>
> 
> ------------------------------
> 
> Message: 2
> Date: Mon, 2 Mar 2009 01:05:18 -0800
> From: "Tex Texin" <[email-masked]>
> Subject: draft-ietf-ltru-4645bis-10.txt issue with preferred value
> for
> 	YU
> To: <[email-masked]>,	<[email-masked]>
> Message-ID: <005e01c99b16$0b00d700$21028500$@com>
> Content-Type: text/plain; charset="utf-8"
> 
> With respect to the proposed update to the Language Subtag Registry
> draft-ietf-ltru-4645bis-10:
> 
> 
> 
> I would like to lodge an objection to the deletion of the
> Preferred-Value for language subtag YU.
> 
> 
> 
> This change breaks the equivalence class relation between YU and CS.
> It detrimentally changes the behavior of existing implementations.
> 
> The loss of the relationship between YU and CS makes documents that
> were believed to be tagged equivalently, to no longer be equivalent.
> 
> 
> 
> There is also no benefit to this change.
> 
> 
> 
> To be concrete, assume a user attempts to find documents for
> languages from Yugoslavia.
> 
> Using the then current registry data, a query tool noting the
> preferred value relationship, matches either xx-YU and xx-CS.
> 
> 
> 
> Another user searches for documents for Serbia.
> 
> A query tool using the current registry data noting the preferred
> value relationship, matches either xx-YU and xx-CS.
> 
> 
> 
> The results are in some sense accurate and complete, given the
> history of the subtag.
> 
> 
> 
> After this change in the preferred value relationship, the query
> tool does not know to search for both xx-YU and xx-CS, since the
> registry does not indicate a relationship. Only one or the other
> subtag is used for each query. However, the query results are now
> incomplete since some documents for xx-YU have been tagged with the
> one-time preferred tag of xx-CS.
> 
> 
> 
> Comments in the registry are not a solution. Comments are a good
> thing for recording rationale and tangential history. However,
> implementers are not going to go thru and read the comments on any
> or all tags in order to make a correct implementation. They are
> going to implement based on the schema and operate with the data
> values.
> 
> 
> 
> The registry should stay as it is with respect to YU and retain CS
> as the preferred value.
> 
> As CS is now being used as a preferred value, deprecated or not,
> there isn't a compelling motivation to remove the preferred value
> for YU.
> 
> 
> 
> Please eliminate this needless change that breaks applications
> relying on the relationship between YU and CS.
> 
> 
> 
> tex
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-
> archive/web/ietf/attachments/20090302/0249ec2d/attachment.htm>
> 
> ------------------------------
> 
> Message: 3
> Date: Mon, 2 Mar 2009 10:04:21 -0000
> From: "Dearlove, Christopher (UK)" <[email-masked]>
> Subject: Terminal room at IETF74
> To: <[email-masked]>
> Message-ID:
> 	<[email-masked].
> NET>
> Content-Type: text/plain;	charset="us-ascii"
> 
> 
> I believe this to be on-topic for this list based on the
> summary of on-topic subjects. However I don't see any
> similar subjects recently, so apologies if there is a
> batter place, and a pointer to it would be appreciated.
> 
> I have had it confirmed by the secretariat that the terminal
> room at IETF 74 will not contain any machines, presumably
> just network connections.
> 
> When I first attended an IETF meeting (IETF56) the terminal
> room contained several machines, sometimes barely enough.
> But over the years the number has declined, along I suspect
> with their usage. There have been machine-free terminal rooms
> in the past. As like most people I've brought a laptop, I
> haven't monitored the situation closely.
> 
> But now, if I come to IETF74, I won't have a laptop with me.
> Corporate policy, based on recent US legal decisions, is that
> I may not take a laptop (or PDA etc.) into the USA. This is
> not subject to modification. Obviously even a machine in the
> terminal room would be a very poor second, but it seems even
> that is out.
> 
> There are obviously broader issues regarding US meetings. But
> I will limit myself here to the narrower issue, and to simply
> bringing it to attention.
> 
> --
> Christopher Dearlove
> Technology Leader, Communications Group
> Networks, Security and Information Systems Department
> BAE Systems Advanced Technology Centre
> West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
> Tel: +44 1245 242194  Fax: +44 1245 242124
> 
> BAE Systems (Operations) Limited
> Registered Office: Warwick House, PO Box 87,
> Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
> Registered in England & Wales No: 1996687
> 
> *******************************************************************
> *
> This email and any attachments are confidential to the intended
> recipient and may also be privileged. If you are not the intended
> recipient please delete it from your system and notify the sender.
> You should not copy it or use it for any purpose nor disclose or
> distribute its contents to any other person.
> *******************************************************************
> *
> 
> 
> 
> ------------------------------
> 
> Message: 4
> Date: Mon, 2 Mar 2009 10:28:20 -0000
> From: "Josh Howlett" <[email-masked]>
> Subject: Identity Services Beyond Web SSO (was RE: [TLS] TLS WG
> Chair
> 	Comments	on draft-ietf-tls-authz-07)
> To: "Hannes Tschofenig" <[email-masked]>
> Cc: Josh Howlett <[email-masked]>, [email-masked]
> Message-ID:
> 	<[email-masked]
> na.ac.uk>
> Content-Type: text/plain;	charset="us-ascii"
> 
> Hi Hannes,
> 
> Hans wrote:
> > Josh wrote:
> > > Hans wrote:
> > > > Josh wrote:
> > > > >I have a long list of applications, collected from within
> this
> > > > >community, with which they would like to use SAML-based
> > > > > authorisation;
> > > >
> > > > Interesting. Any interest to share it with us?
> > >
> > > I'm in the process of trying to flesh it out at the moment, in
> > > a collaboration with some of the communities concerned, so
> > > that we can articulate some concrete use-cases. At the moment
> > > the list covers pretty much everything that is presently used
> > > in an Inter-Institutional context (AFS, SSH, VNC, RDP, SIP,
> > > SMTP, NEA, ...).
> >
> > Looking forward to see more about it.
> 
> http://www.terena.org/activities/tf-emc2/beyond_web/index.html
> 
> "The European academic community has found many use cases for
> federated
> digital identity in applications other than those accessible
> through a
> web browser. Going beyond the browser limits constitutes a
> fundamental
> requirement to fulfill the promise of Identity Management in
> simplifying
> service administrators' tasks and enhancing the user experience."
> 
> All are welcome to participate providing there's an R&E angle,
> however
> flimsy and contrived ;-)
> 
> best regards, josh.
> 
> JANET(UK) is a trading name of The JNT Association, a company
> limited
> by guarantee which is registered in England under No. 2881024
> and whose Registered Office is at Lumen House, Library Avenue,
> Harwell Science and Innovation Campus, Didcot, Oxfordshire. OX11
> 0SG
> 
> 
> 
> ------------------------------
> 
> Message: 5
> Date: Mon, 2 Mar 2009 12:42:19 +0100
> From: Mirjam Kuehne <[email-masked]>
> Subject: New IETF Journal available now (Volume 4, Issue 3)
> To: [email-masked], [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
> 
> [Apologies for duplicate emails]
> 
> Hello,
> 
> The new issue of the IETF Journal - Volume 4, Issue 3 - is now
> available at http://ietfjournal.isoc.org
> 
> You can read this publication online or choose to download the full
> issue in PDF format. You can also keep up to date with the latest
> issue of the IETF Journal by subscribing to one of our RSS or Atom
> feeds.
> 
> For comments or suggestions, please do not hesiate to contact us at
> [email-masked].
> 
> Kind Regards,
> Mirjam Kuehne
> Internet Society
> 
> 
> 
> ------------------------------
> 
> Message: 6
> Date: Mon, 2 Mar 2009 12:43:25 +0100
> From: Olaf Kolkman <[email-masked]>
> Subject: Re: Internet Society joins Liberty Alliance Management
> Board:
> 	Why?
> To: IETF Discussion <[email-masked]>
> Cc: Hannes Tschofenig <[email-masked]>,	Dave Crocker
> 	<[email-masked]>, "Lynn St.Amour" <[email-masked]>
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"; Format="flowed";
> 	DelSp="yes"
> 
> 
> On 1 mrt 2009, at 23:49, Lynn St.Amour wrote:
> 
> >
> > PS. Re: your side note below on the makeup of the ISOC Board,
> we'll
> > update the list to show the community or mechanism that appoints/
> > elects Trustees.   In the meantime, the IETF appoints 3 Trustees
> > (out of 13, 12 voting and me non-voting).  The current IETF
> > appointees to the ISOC Board are: Patrik F?ltstr?m, Ted Hardie
> and
> > Bert Wijnen.
> 
> 
> 
> Also note that the IAB is to select a new IETF appointee. See
> http://www.ietf.org/mail-archive/web/ietf-
> announce/current/msg05771.html
>   for the list of nominees.
> 
> --Olaf
> 
> 
> -------------- next part --------------
> A non-text attachment was scrubbed...
> Name: PGP.sig
> Type: application/pgp-signature
> Size: 235 bytes
> Desc: This is a digitally signed message part
> Url : <http://www.ietf.org/mail-
> archive/web/ietf/attachments/20090302/35c108b2/attachment.sig>
> 
> ------------------------------
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
> 
> 
> End of Ietf Digest, Vol 10, Issue 4
> ***********************************

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 2 Mar 2009 17:36:07 -0800

Hi -

> From: "Phillips, Addison" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, March 02, 2009 9:49 AM
> Subject: RE: draft-ietf-ltru-4645bis-10.txt issue with preferred value for YU
>
> Hi Tex,
> 

Tex's posting came after the document shepherd (co-chair Martin Duerst)
had sent the information to our AD requesting that the IESG consider
publishing it.  So although the IESG has not yet (AFAIK) acted on the
request, much less issued an IETF last call, I can understand why
[email-masked] might be included.

I have already responded to it on both lists, even though I think the
issue is probably of little interest to most on the [email-masked] list.
Unless instructed to do otherwise by our AD, I would suggest that
all follow-on discussion be directed to [email-masked]

> 1. You haven't posted to LTRU's mailing list, only ietf-languages@, yet.

Tex's message was posted to *both* lists.

> 2. Even if draft-4645bis is approved, the process for language tags
> (in either RFC 4646 or its proposed successor) allow you to register
> the information you want, if you think it was inappropriately omitted.
...

Correct.

Randy

---

From: "Tex Texin" <[email-masked]>
Date: Tue, 3 Mar 2009 02:10:33 -0800

Hi guys,

I sent the message to this list (as well as LTRU) in the belief I was
following the instructions given to me...
(My mail actually preceded Martin's request to the AD.)

I admit to confusion about the suggestion I can register the change after
4645bis is accepted.
4645bis changes a code that exists already. I shouldn't have to reregister
it to restore it.
If anything, have 4645bis go forward without the change, and the change can
be discussed separately.

I'll pursue the discussion on the ltru list as requested and respond to
Randy's other comments there.

tex

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Randy Presuhn
Sent: Monday, March 02, 2009 5:36 PM
To: [email-masked]
Subject: Re: draft-ietf-ltru-4645bis-10.txt issue with preferred value for
YU

Hi -

...

Correct.

Randy