Subject: Problems accessing www.ietf.org over IPv6

From: Robert Moskowitz <[email-masked]>
Date: Mon, 30 Mar 2009 17:56:50 -0400

I have a /48 native IPv6 prefix routed to my home lab.

I come back from IETF, and Firefox 3.0.6 is hanging accessing
www.ietf.org on my duo-stack Centos 5.2 laptop.

I do a ping6 and can get to www.ietf.org, so it is not a routing
problem.  I run wireshark and I see IPv4 and IPv6 tcp sessions.

In the end I have to disable IPv6 in Firefox to get to the ietf home
page.  Doesn't see right, I had no trouble with this at the meeting and
all I did was suspend my system to go home.  I rebooted here (horrors,
rebooting a Linux system) jsut to see if there was something hanging
around from ietf.

---

From: John Jason Brzozowski <[email-masked]>
Date: Mon, 30 Mar 2009 18:01:18 -0400

Do you have a host-based firewall running?  ip6tables perhaps?

ip6tables -L

John
=========================================
John Jason Brzozowski
Comcast Corporation
e) mailto:[email-masked]
m) 609-377-6594
=========================================

> From: Robert Moskowitz <[email-masked]>
> Date: Mon, 30 Mar 2009 17:56:50 -0400
> To: "[email-masked]" <[email-masked]>
> Subject: Problems accessing www.ietf.org over IPv6
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Jeroen Massar <[email-masked]>
Date: Tue, 31 Mar 2009 00:09:29 +0200

> www.ietf.org on my duo-stack Centos 5.2 laptop.

That is called a Path MTU issue.

As you have a Linux box, install the tracepath6 tool (iputils-tracepath
on Debian, probably similar package for an RPM distro) and then do a
"tracepath6 www.ietf.org" and you will see where it goes wrong, then
contact your provider and pass them that info.

It is kinda funny to see big old AT&T hanging behind OCCAID; I hope the
secretariat is not paying AT&T too much for that kind of 'transit'.
(seems that Sprint and Telia also have the route but don't play transit
for AT&T thus the only transit for AT&T is OCCAID...) Lets hope that
improves soon...

Greets,
 Jeroen

--

jeroen@purgatory:~$ tracepath6 www.ietf.org
 1 : [LOCALHOST]                      pmtu 1500
 2:  gehenna.ch.unfix.org                       1.581ms pmtu 1480
 3:  xen-gw.zrh.sixxs.net                      26.816ms
 4:  ipman.zrh.sixxs.net                       29.298ms
 5:  ge0-3.br01.zrh254.ipv6.ip-man.net         29.472ms
 6:  pos3-0.cr01.gva02.ipv6.ip-man.net         33.045ms
 7:  srp1-0.cr01.gva16.ipv6.ip-man.net         33.928ms
 8:  pos2-0.br01.ams254.ipv6.ip-man.net        51.227ms
 9:  amsix.r1.ams2.nl.opencarrier.eu           53.085ms
10:  opencarrier-ams-px.occaid.net             71.227ms
11:  bbr01-p1-0.nwrk01.occaid.net             143.202ms asymm 12
12:  r1.mdtnj.ipv6.att.net                    194.826ms
13:  2001:1890:61:9017::2                     270.532ms
14:  mail.ietf.org                            263.312ms reached
     Resume: pmtu 1480 hops 14 back 51