Subject: Re: designate an email address for testing at any provider

From: Nick Levinson <[email-masked]>
Date: Tue, 31 Mar 2009 17:30:34 -0700 (PDT)

I'm puzzled. If you said the logistics are too time-consuming to carry out because providers are unlikely to agree on a guaranteed-to-bounce address, that would make sense and I'd probably drop it.

But you mention routing, mapping of domains to providers, and many ways of handling mail. How email is routed from anyone to a provider has nothing to do with what the address says to the left of the "@" sign. How many domains a provider has is relevant only insofar as each domain represents an email service provider. The policies of ICANN, IANA, a TLD registry operator, or a registrar or reseller hardly matter. If they don't use a domain at all but only an IP address, either IPv4 or IPv6, that doesn't matter either. If what's on the right of the "@" sign gets to an email service provider, what's on the left should guarantee a bounce. There should be one bouncing address at each domain or IP. Who handles it once an email arrives at a domain or an IP address does not matter. What method they apply to handling it doesn't matter. All they have to do is bounce it. How a provider does the bouncing is up to the provider. Probably if I email
 [email-masked] it'll bounce (Bill probably has some other address, although I haven't tried). They already know how to bounce. That step doesn't have to change.

The only difficulty is picking the one address no one has given to a customer. That's probably not impossible.

-- 
Nick

---

From: "J.D. Falk" <[email-masked]>
Date: Thu, 02 Apr 2009 17:47:50 -0600

Nick Levinson wrote:

> I'm puzzled. If you said the logistics are too time-consuming to carry
> out because providers are unlikely to agree on a guaranteed-to-bounce
> address, that would make sense and I'd probably drop it.

They're saying providers are unlikely to /implement/ a guaranteed-to-bounce 
address.  In other words: even if you write & submit an RFC (which you can 
do on your own, without asking [email-masked] first), nobody will follow it.

I think there's a slim chance that some providers might be okay with the 
idea, so my advice to you would be to go and ask them.  Start with 
real-world implementations at big, influential sites, and design the 
standard from there.

-- 
J.D. Falk
Return Path Inc
http://www.returnpath.net/