Subject: Change control

From: SM <[email-masked]>
Date: Wed, 19 Jan 2011 14:20:39 -0800

Hello,

This is the second time in a year that I came across a case where a 
non-IETF group sought to maintain change control over a draft.  In 
the first case, several iterations of the draft were posted and the 
author solicited comments on an IETF mailing list.

   (a) By making an IETF Submission, is an author allowing the IETF to have
       change control on the work?

   (b) Is it appropriate to use a WG mailing list to discuss a work on
       which the IETF does not have change control?

   (c) If the IETF Submission is covered by the WG Charter, can the WG
       enhance the original contribution in accordance with the IETF
       Standards Process by adopting it as a WG work item?

Regards,
-sm

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 19 Jan 2011 17:58:12 -0500

Hi,

On Wed, Jan 19, 2011 at 5:20 PM, SM <[email-masked]> wrote:
> Hello,
>
> This is the second time in a year that I came across a case where a non-IETF
> group sought to maintain change control over a draft.  In the first case,
> several iterations of the draft were posted and the author solicited
> comments on an IETF mailing list.
>

It depends. That's why there are different versions of the boilerplate
depending on what rights the submitter is granting to the IETF.

>      which the IETF does not have change control?

Generally, yes. There's nothing wrong is such discussion if there
appears to be a WG consensus to do so. You refer to this hypothetical
submission as a "work", which is a technically correct copyright term,
but I believe you are thinking of it as a standards specification or a
part of or an amendment to such a specification. But it can just be
that the submitter wanted to use the draft format as a convenient way
to make a statement to the WG, presumably a statement relevant to what
the WG is doing. In such a case, the whole point would be
consideration and, if appropriate, discussion of that statement in the
WG.

>      Standards Process by adopting it as a WG work item?

It depends. That's why there are different versions of the
boilerplate. If the submitter has denied the IETF permission to
produce derivative works, then it seems improper to attempt to adopt
that draft as a WG draft. That's because being a WG draft implies WG
change control. However, the ideas in the draft could be used in a WG
draft.

> -sm

Thanks,
Donald

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 19 Jan 2011 18:46:33 -0500

What is?

I generally reserve change control over non WG IDs because I have
experienced people hijacking a draft, changing the principles entirely and
adding their name.

Since there is an explicit allowance for that in the IPR regime, I don't see
why this would be an issue.

On Wed, Jan 19, 2011 at 5:20 PM, SM <[email-masked]> wrote:

> non-IETF group sought to maintain change control over a draft.  In the first
> case, several iterations of the draft were posted and the author solicited
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

-- 
Website: http://hallambaker.com/

---

From: Martin Rex <[email-masked]>
Date: Thu, 20 Jan 2011 03:43:33 +0100 (MET)

>        change control on the work?

It is up to the author to include a suitable Copyright statement in
I-Ds that he uploads/submits to the IETF for publication as I-D.

You may find useful information about this here:

  http://tools.ietf.org/html/bcp78#section-3

>        which the IETF does not have change control?

Ideally, a WG should keep the focus on the work that it chartered
_itself_ to work on.  WG chairs are entrusted with significant
discretion to contain discussions on the WG-list either within
chartered scope or when off-topic at acceptable levels--or
occasionally gauge WG consensus for rechartering.

>        Standards Process by adopting it as a WG work item?

Copyright must be _granted_ by the author, so it is the other way round.
Before an individual submission I-D can be adopted as a WG item,
the contributor must grant the necessary rights (to produce derivative
works) to the IETF.

That's how I understand the second paragraph here:
http://tools.ietf.org/html/bcp78#page-7

While the inclusion of the respective Copyright boilerplate by the
author in the the submission is technically sufficient,
I would consider it a courtesy to ask the original author for
consent anyway, especially if it is about a new I-D
(rather than an older RFC).

-Martin

---

From: SM <[email-masked]>
Date: Thu, 20 Jan 2011 10:56:12 -0800

>depending on what rights the submitter is granting to the IETF.

I'll reproduce the notice for completeness:

   "This document is subject to BCP 78 and the IETF Trust's Legal
    Provisions Relating to IETF Documents
    (http://trustee.ietf.org/license-info) in effect on the date of
    publication of this document.  Please review these documents
    carefully, as they describe your rights and restrictions with respect
    to this document.  Code Components extracted from this document must
    include Simplified BSD License text as described in Section 4.e of
    the Trust Legal Provisions and are provided without warranty as
    described in the Simplified BSD License."

I gather that an IETF Submission with the above notice allows the 
IETF to have change control on the work.

>consideration and, if appropriate, discussion of that statement in the

I was thinking of it in terms of "work", BCP 78 and BCP 79.  Thanks 
for providing a better perspective.

At 15:46 19-01-11, Phillip Hallam-Baker wrote:
>experienced people hijacking a draft, changing the principles 
>entirely and adding their name.
>
>Since there is an explicit allowance for that in the IPR regime, I 
>don't see why this would be an issue.

Some people post drafts with the notice quoted above.  They have not 
given any thought to the "explicit allowance" and end up being 
unhappy when they are asked to give up control.  The first case (see 
my previous message) wasn't a pleasant situation.

>http://tools.ietf.org/html/bcp78#page-7

Yes.

For what it's worth, there was a case where changes to the SDO 
specification, which was not an IETF Submission, are only accepted 
from members of the SDO.  There is a parallel with the IETF here as 
Contributions require acceptance of the Note Well, i.e. changes are 
only accepted from IETF participants.

>(rather than an older RFC).

Agreed.

Regards,
-sm

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 20 Jan 2011 12:53:28 -0800

To be honest, I'm not even clear on what the issue is.

If an organization creates a BCP in its own context based on the experiences of its constituents, and then the IETF uses that material to inform its own BCP on the same subject, and reasonable permission and attribution are given, what constitutes "change control"?  The IETF controls its version, and the other organization controls its own.

For example, OpenBSD was forked from NetBSD.  Who now has change control?  Does that even mean anything?

Apart from copyright matters, I think the only problem arises when there's debate over whose version is the "official" one.  But that's a matter of the perception that exists outside of the two organizations.  Otherwise, aren't they merely two perspectives on the same subject matter, and that's that?

-MSK

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 20 Jan 2011 16:16:09 -0500

That is why I really want to see a specific example of harm (which I note SM
has refused to do).

This is the sort of case where it is very easy to make the wrong decision if
people are allowed to waffle on about what they imagine to be high principle
when the rules were made the way they are to support important real world
requirements.

If we are to discuss this further, I want to see an example.

<eom>

On Thu, Jan 20, 2011 at 3:53 PM, Murray S. Kucherawy <[email-masked]>wrote:

> If an organization creates a BCP in its own context based on the
> experiences of its constituents, and then the IETF uses that material to
> inform its own BCP on the same subject, and reasonable permission and
> attribution are given, what constitutes "change control"?  The IETF controls
> its version, and the other organization controls its own.
>
> Apart from copyright matters, I think the only problem arises when there's
> debate over whose version is the "official" one.  But that's a matter of the
> perception that exists outside of the two organizations.  Otherwise, aren't
> they merely two perspectives on the same subject matter, and that's that?
>
> -MSK

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 20 Jan 2011 13:57:49 -0800

The only thing I can dream up (without an example) is that the submitting organization's version of something and the IETF's version end up diverging, and the submitting organization doesn't like that.  To wit, the submitting organization wanted the added credibility of the "RFC" label without any substantive changes to the material.  But that strikes me as a failure of due diligence more than anything.

Caveat emptor.

From: Phillip Hallam-Baker [mailto:[email-masked]]
Sent: Thursday, January 20, 2011 1:16 PM
To: Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: Change control

That is why I really want to see a specific example of harm (which I note SM has refused to do).

This is the sort of case where it is very easy to make the wrong decision if people are allowed to waffle on about what they imagine to be high principle when the rules were made the way they are to support important real world requirements.

<eom>

On Thu, Jan 20, 2011 at 3:53 PM, Murray S. Kucherawy <[email-masked]<mailto:[email-masked]>> wrote:
To be honest, I'm not even clear on what the issue is.

-MSK
_______________________________________________
Ietf mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ietf