Subject: Fwd: FCC IPv6 Working Paper Released

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 5 Jan 2011 16:56:40 -0500

This seems like a document that might interest some on this list...

> From: "Robert Cannon" <[email-masked]>
> Date: January 5, 2011 11:24:51 AM EST
> Subject: FCC IPv6 Working Paper Released
> 
> Last week the FCC released a new working paper Potential Impacts on Communications From IPv4 Exhaustion & IPv6 Transition.
>  
> http://hraunfoss.fcc.gov/edocs_public/attachmatch/DOC-303870A1.pdf
>  
> Abstract
>  
> The Internet is in transition.  The original address space, IPv4, is nearly exhausted; the Internet is in the progress of migrating to the new IPv6 address space. 
> 
> The Internet Protocol version 4 (IPv4) developed in the late 1970s has the capacity for about 4 billion unique addresses.  It would have been hard to imagine in the 1970s that 4 billion addresses were not going to be enough.  But by the early 1990s, Internet engineers recognized that the supply of addresses was relatively limited compared to likely demand, and they set to work designing a successor to IPv4.  They developed a new Internet Protocol, IPv6, with a vastly increased address space: 340 trillion trillion trillion addresses.
> 
> Broadband Internet access has become essential to the United States and the rest of the world. The exhaustion of IPv4 addresses and the transition to IPv6 could result in significant, but not insurmountable, problems for broadband Internet services.  In the short term, to permit the network to continue to grow, engineers have developed a series of kludges. These kludges include more efficient use of the IPv4 address resource, conservation, and the sharing of IPv4 addresses through the use of Network Address Translation (NAT).  While these provide partial mitigation for IPv4 exhaustion, they are not a long-term solution, increase network costs, and merely postpone some of the consequences of address exhaustion without solving the underlying problem. Some of these fixes break end-to-end connectivity, impairing innovation and hampering applications, degrading network performance, and resulting in an inferior version of the Internet.  These kludges require capital investment and ongoing operational costs by network service providers, diverting investment from other business objectives. Network operators will be confronted with increased costs to offer potentially inferior service.
> 
> The short term solutions are necessary because there is not enough time to completely migrate the entire public Internet to "native IPv6" where end users can communicate entirely via IPv6.  Network protocol transitions require significant work and investment, and with the exhaustion of IPv4 addresses looming, there is insufficient time to complete the full IPv6 transition.
> 
> But the short-term solutions are problematic. The "solution to the solution" is to complete the transition to a native IPv6 network.  A native IPv6 network will restore end-to-end connectivity with a vastly expanded address space, will improve network performance, and should decrease costs.  Completing the transition of the public Internet to IPv6 will take time.
>  
> FCC Staff Working Papers are intended to stimulate discussion and critical comment within the FCC, as well as outside the agency, on issues that may affect communications policy.  The analyses and conclusions set forth are those of the authors and do not necessarily reflect the view of the FCC, other Commission staff members, or any Commissioner.
>  
> Initial feedback on the paper has been positive. If you have any question, please feel free to contact me.
>  
> Robert
>  
> ~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
> Robert Cannon
> Senior Counsel for Internet Law
> Office of Strategic Planning and Policy Analysis
> Federal Communications Commission
> 202 418 2421
>  
> ** Non Public :: For Internal Use Only ** 
> 
>

---

From: Yoav Nir <[email-masked]>
Date: Thu, 6 Jan 2011 01:15:27 +0200

Sigh.

You'd think they would have learned by now.

"A native IPv6 network will restore end-to-end connectivity with a vastly expanded address space..."

On Jan 5, 2011, at 11:56 PM, Richard L. Barnes wrote:

From: "Robert Cannon" <[email-masked]<mailto:[email-masked]>>
Date: January 5, 2011 11:24:51 AM EST
Subject: FCC IPv6 Working Paper Released

Abstract

Robert

<ATT00001..txt>

---

From: John Levine <[email-masked]>
Date: 5 Jan 2011 23:23:14 -0000

>This seems like a document that might interest some on this list...

It's not bad, but it's basically a well written summary of the
conventional wisdom about IPv6.  As we all know, some of the
conventional wisdom is more grounded in reality, some less.

>> http://hraunfoss.fcc.gov/edocs_public/attachmatch/DOC-303870A1.pdf

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. http://jl.ly

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 06 Jan 2011 08:41:57 +0900

> with a vastly expanded address space..."

That's true but the problem is that the end to end connectivity
is utterly lost during the transition from IPv4 to IPv6 network
(dual stacking was abandoned).

On the other hand, IPv4 address space extended by PR-IP (port
restricted IP such as Address+Port, end to end NAT and port
enhanced ARP) is large enough and the end to end connectivity
is always kept.

						Masataka Ohta

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 6 Jan 2011 12:07:08 -0500

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of John Levine [[email-masked]]

It's not bad, but it's basically a well written summary of the
conventional wisdom about IPv6.  As we all know, some of the
conventional wisdom is more grounded in reality, some less.
_______________________________________________

Nonetheless, it's better than nothing -- the "conventional" wisdom is known by only a small subset of the people who ought to know it (and considerably more wisdom as well).

Dale