Subject: Gen-ART LC review of draft-zhu-mobileme-doc-04

From: "Roni Even" <[email-masked]>
Date: Fri, 4 Mar 2011 16:01:33 +0200

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments you
may receive.

Document: draft-zhu-mobileme-doc-04

Reviewer: Roni Even

Review Date:2011-3-4

IETF LC End Date: 2011-3-18

IESG Telechat date:

Summary: This draft is almost ready for publication as Informational   RFC.

Major issues:

Minor issues:

In section 5 and in section 6.1 second bullet you mention that the end to
end connection is TCP while in other places like section 3, 4th paragraph
you mention that UDP is used to tunnel packet end to end.  So what are the
TCP connections used for? 

Nits/editorial comments:

---

From: Lixia Zhang <[email-masked]>
Date: Sat, 5 Mar 2011 21:51:49 -0800

On Mar 4, 2011, at 6:01 AM, Roni Even wrote:

> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Please resolve these comments along with any other Last Call comments you may receive.
> 
> Review Date:2011–3–4
> IETF LC End Date: 2011–3–18
> IESG Telechat date:
>  
> In section 5 and in section 6.1 second bullet you mention that the end to end connection is TCP while in other places like section 3, 4th paragraph you mention that UDP is used to tunnel packet end to end.  So what are the TCP connections used for?

section 3 talks about the use of UDP encapsulation for end host's data packets.

section 5 and section 6.1 refer to TCP connections used by user applications running on end hosts.

>  
> Nits/editorial comments:
>  
>  
>  
> 
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: "Roni Even" <[email-masked]>
Date: Mon, 7 Mar 2011 13:08:30 +0200

Hi,

My impression from reading the document and according to figure 1 was that
all end host communication was done in a UDP tunnel. So what is the relation
of the TCP connection to BTMM.

Roni Even

From: Lixia Zhang [mailto:[email-masked]] 
Sent: Sunday, March 06, 2011 7:52 AM
To: Roni Even
Cc: [email-masked]; [email-masked];
'IETF-Discussion list'
Subject: Re: Gen-ART LC review of draft-zhu-mobileme-doc-04

Reviewer: Roni Even

Review Date:2011-3-4

IESG Telechat date:

Major issues:

Minor issues:

section 3 talks about the use of UDP encapsulation for end host's data
packets.

section 5 and section 6.1 refer to TCP connections used by user applications
running on end hosts.

Nits/editorial comments:

---

From: Stuart Cheshire <[email-masked]>
Date: Mon, 07 Mar 2011 05:34:57 -0800

On 7 Mar 2011, at 3:08 AM, Roni Even wrote:

> Hi,
> My impression from reading the document and according to figure 1  
> was that all end host communication was done in a UDP tunnel. So  
> what is the relation of the TCP connection to BTMM.
> Roni Even

Question: When you use IPSEC VPN, what are the TCP connections used for?

Answer: Every application that uses TCP today still uses TCP when TCP  
is running over the IPSEC VPN.

BTMM is an IPv6 overlay network, tunneled over IPv4. Every TCP-based  
application you run is still a TCP-based application.

Stuart Cheshire <[email-masked]>
* Wizard Without Portfolio, Apple Inc.
* www.stuartcheshire.org