Subject: Re: Last Call: <draft-ietf-genarea-datatracker-community-06.txt> (Requirements for Internet-Draft Tracking by the IETF Community in the Datatracker) to Informational RFC

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Mar 2011 16:26:30 -0500

Paul -

1) If we publish this as an RFC, note that imgur.com will only keep an image if it's viewed at least once every three months.

2) In the list of things constituting an "update to an RFC", could you call out marking an RFC as Historic, and changing the
maturity level of an RFC in place (such as was done for 5652)

3) 2.1.2 talks of the ease of use to create a datatracker account. I think we have that already through the tools system.
Are you thinking this will require the creation of a different system?

RjS

On Mar 4, 2011, at 4:46 PM, The IESG wrote:

> 
> The IESG has received a request from the General Area Open Meeting WG
> (genarea) to consider the following document:
> - 'Requirements for Internet-Draft Tracking by the IETF Community in the
>   Datatracker'
>  <draft-ietf-genarea-datatracker-community-06.txt> as an Informational
> RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2011-03-18. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-genarea-datatracker-community/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-genarea-datatracker-community/
> 
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Mar 2011 16:46:03 -0500

One additional thought -

How much would the list of attributes in 2.1.6 need to be expanded to make one of these user-defined lists
enough to satisfy the initial "Reporting Requirements" in section 4.3 of draft-ietf-genarea-datatracker-iana-rfced-extns-00?
Should we add the ability to match against the values (or absence of value) of a state for the various state machines tracked by the tracker?

RjS

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 15 Mar 2011 09:02:15 -0700

On 3/14/11 2:26 PM, Robert Sparks wrote:
> Paul -
>
> 1) If we publish this as an RFC, note that imgur.com will only keep
> an image if it's viewed at least once every three months.

Good catch. I have added a note in the upcoming -08 that the sentence 
removed before publication. FWIW, I do not know whether or not there is 
an intention to publish this document as an RFC.

> 2) In the list of things constituting an "update to an RFC", could
> you call out marking an RFC as Historic, and changing the maturity
> level of an RFC in place (such as was done for 5652)

Sure. Done in -07.

> 3) 2.1.2 talks of the ease of use to create a datatracker account. I
> think we have that already through the tools system. Are you thinking
> this will require the creation of a different system?

Getting a Datatracker account is different than getting a Tools account. 
Currently, going to <https://datatracker.ietf.org/> does not show you 
how to get a Datatracker account. Even if you try the meme of "try to 
log in and see what happens if you fail", you do not get presented with 
a "here's how to get a Datatracker account" message. If we expect these 
tools to be widely-used, we need to be sure that it is easier than it is 
today to get a Datatracker account.

On 3/14/11 2:46 PM, Robert Sparks wrote:
> enough to satisfy the initial "Reporting Requirements" in section
> 4.3  of draft-ietf-genarea-datatracker-iana-rfced-extns-00?
> Should we add the ability to match against the values (or absence of
> value) of a state for the various state machines tracked by the
> tracker?

Given that the document is completely new and has had thin review so 
far, we might be better off waiting for it to progress and doing a 
revision to the tool than waiting to know what the actual states are. 
Note that the wording in that section is quite indefinite: "For example, 
the initial set of discrepancies could include...". It would be easy to 
add more attributes to the ones in 2.1.6 later.

--Paul Hoffman