Subject: Re: Last Call: <draft-ietf-mboned-ssmping-08.txt> (Multicast Ping Protocol) to Proposed Standard

From: Tim Chown <[email-masked]>
Date: Tue, 5 Jul 2011 22:10:18 +0100

I think this draft specifies a very useful protocol, which we have used at our site and which has been a valuable multicast debugging tool.

The specification and implementations have evolved over maybe 5-6 years or so.  The implementations we've used have been of various stages of the protocol's development.  A student at our site implemented an earlier version of the protocol successfully.  I don't believe we've used a version at our site based on the spec in the final version of the text, so I can't comment on that specifically.

There are some parts of the text that I think indicate the protocol has evolved over a length of time; if it were rewritten from scratch it would probably be somewhat more compact, due to some level of repetition of aspects of the protocol.  However, I think it's more important to get the protocol published now, so I would support publishing it as is.  

The protocol is defined in a fairly loose way, but the core elements are tight enough for implementation.  This is reflected in the text at the start of Section 6.

I noticed one nit in terms of the client ID. In Section 2 the text says:
"At runtime, a client generates a client ID that is unique for the ping test.  This ID is included in all messages sent by the client."
Then later in the more detailed spec, the text says:
"A client SHOULD always include this option in all messages (both Init and Echo Request)."
I would have expected the inclusion of the Client ID to be a MUST, based on the earlier explanation.  If it is a SHOULD, the introduction text should say "this ID is usually included in all messages sent by the client".

It would be nice to consider mechanisms to discover 'public' ssmping test servers, but that's a separate text :)

Tim

On 20 Jun 2011, at 18:51, The IESG wrote:

> 
> The IESG has received a request from the MBONE Deployment WG (mboned) to
> consider the following document:
> - 'Multicast Ping Protocol'
>  <draft-ietf-mboned-ssmping-08.txt> as a Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2011-07-04. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
> The Multicast Ping Protocol specified in this document allows for
> checking whether an endpoint can receive multicast, both Source-
> Specific Multicast (SSM) and Any-Source Multicast (ASM).  It can also
> be used to obtain additional multicast-related information such as
> multicast tree setup time.  This protocol is based on an
> implementation of tools called ssmping and asmping.
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-mboned-ssmping/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-mboned-ssmping/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Stig Venaas <[email-masked]>
Date: Tue, 05 Jul 2011 14:40:24 -0700

> I would have expected the inclusion of the Client ID to be a MUST, based on the earlier explanation.  If it is a SHOULD, the introduction text should say "this ID is usually included in all message…

Yes, I think it should be changed to say "usually". A basic client could
work without including the ID. But there are good reasons to include it
as listed in the draft.

Stig

> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned