Subject: Re: [homegate] HOMENET working group proposal

From: Keith Moore <[email-masked]>
Date: Fri, 1 Jul 2011 09:35:53 -0400

On Jul 1, 2011, at 4:53 AM, Mark Townsley wrote:

> The idea is not to go out of our way for IPv4, but if the topic is IP agnostic anyway, so be it. To be clear, there is no *requirement* to support IPv4 here. However, there is no requirement to avoid IPv4 *if* it doesn't cause significant concession in the IPv6 design either.
> 
> This cuts both ways, if there is something that is working well in IPv4 that we need to carry over to IPv6 with simple extensions, we'll do that and capitalizing on that running-code should be considered a good thing. We don't want to invent new v6 protocols from scratch that don't work with IPv4 when there is no need. For example (and I think this is hinted at in the charter), we might use naming and service discovery that already exists for IPv4, adapted the the v6 homenet. This doesn't mean we need to re-invent a v6-only naming system from scratch - i'd much rather use one that is there, which very well may support v4 and v6. 
> 
>> 
>> please don't constrain home networks to work only within the confines of IPv4 brain damage.
> 
> What I think I am saying here is that we will do our best to perform as if our brains are not damaged, and equally try to avoid damaging our brains in the process.

+1

Keith

---

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Thu, 30 Jun 2011 12:11:31 -0400

"Gone" isn't so important as "not worth expending any more energy on.". So I'm with Keith and would like to find some words like "when it doesn't take any more work."

- Ralph

On Jun 30, 2011, at 12:00 PM, "Fernando Gont" <[email-masked]> wrote:

> On 06/30/2011 12:46 PM, Keith Moore wrote:
>> I'd like for this group to relax the "wherever possible" bit, so as to not preclude solutions where IPv6 can do a better job than IPv4.
>> 
>> IPv4 is a dinosaur gasping for its last breaths.
> 
> Just curious: when you expect IPv4 to be gone? (including "gone" from
> home and enterprise networks)
> 
> Thanks,
> -- 
> Fernando Gont
> e-mail: [email-masked] || [email-masked]
> PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1
> 
> 
> 
> _______________________________________________
> fun mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fun

---

From: "Stephen [kiwin] PALM" <[email-masked]>
Date: Thu, 30 Jun 2011 09:17:22 -0700

It is not for "us" to decide when a user's network is not worth expending
any more energy on. They have deployed their network...
and do not want to expend any more energy themselves.  If their SP deploys
IPv6 inelegantly, the user would have a lot of frustration/work.  Which
will generate many expensive tech support calls... and potentially lost customers.

It's not the protocols... it's the DEPLOYED APPLICATIONS and DEVICES that users have.

regards, kiwin

On 6/30/2011 9:11 AM, Ralph Droms (rdroms) wrote:
> On Jun 30, 2011, at 12:00 PM, "Fernando Gont"<[email-masked]>  wrote:
>

-- 
Stephen [kiwin] Palm   Ph.D.                          E:  [email-masked]
Senior Technical Director                             T: +1-949-926-PALM
Broadcom Broadband Communications Group               F: +1-949-926-7256
Irvine, California                               W: http://www.kiwin.com
Secondary email accounts:  [email-masked]  [email-masked]
[email-masked]  [email-masked]  [email-masked]  [email-masked]

---

From: "Ralph Droms (rdroms)" <[email-masked]>
Date: Thu, 30 Jun 2011 12:21:37 -0400

> will generate many expensive tech support calls... and potentially lost customers.

Agreed that we need to avoid any disruptions of existing networks, devices and deployment scenarios.  I think we should avoid expending energy on *new* functions for IPv4.

- Ralph

---

From: Mark Townsley <[email-masked]>
Date: Thu, 30 Jun 2011 18:33:58 +0200

On Jun 30, 2011, at 5:46 PM, Keith Moore wrote:

> 
> On Jun 30, 2011, at 5:57 AM, Mark Townsley wrote:
> 
>> 
>> I think the consensus we had in the past BoFs and discussion in and around this topic can be summed up as stating that homenet deliverables will:
>> 
>> - coexist with (existing) IPv4 protocols, devices, applications, etc.
>> - operate in a (future) IPv6-only home network in the absence of IPv4
>> - be IP-agnostic whenever possible
> 

Yes, and I think that IPv6 should naturally do a better job than IPv4 in the cases where it can. 

My original mail had this restatement of the above, which I think gets closer to what you want:

>> However, when we can define something that is needed for IPv6 in a way that is also useful for IPv4 without making significant concessions, we should go ahead and do so.

- Mark

> homegate mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/homegate

---

From: Mark Townsley <[email-masked]>
Date: Fri, 1 Jul 2011 10:53:37 +0200

On Jun 30, 2011, at 6:36 PM, Keith Moore wrote:

> On Jun 30, 2011, at 12:33 PM, Mark Townsley wrote:
>>>> 
> when the group can define something that is useful in IPv6, it shouldn't matter whether it's also useful for IPv4.

- Mark

---

From: Keith Moore <[email-masked]>
Date: Fri, 1 Jul 2011 14:30:58 -0400

Anytime we develop standards, the standards apply to future products.  There's no point in defining standards for applications and devices that are already deployed.

Sure, it's nice to have backward compatibility.  But I don't think anyone is likely to propose standards for HOMENET that will significantly break compatibility with existing products.  It's not as if the set of applications and devices that one uses in a home network is disjoint from the set of applications and devices used in other networks.   And it's reasonable to expect that users of existing applications and devices might need to do some special-case configuration to get those applications and devices to continue to work.  

Just to pick one example, if a legacy device is v4-only, and the only access available is NATted v4 or native v6, there might be a need to configure the device to be externally accessible using a v6 address.  The home network might support v4 internally but there might not be v4 service available outside that enclave.

Backward compatibility = good.  Insisting that home networks always use the same kludges that are used now = bad.

Maybe the right answer is that the HOMENET group should consider what means are needed to provide some measure of compatibility with legacy devices and applications, that might continue to be used with networks meeting the new standards.  The working group seems like it's in a much better position than the IETF list to propose reasonable compromises on these issues.

Keith

On Jun 30, 2011, at 12:17 PM, Stephen [kiwin] PALM wrote:

> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf

---

From: Kenneth Voort <[email-masked]>
Date: Fri, 01 Jul 2011 16:03:55 -0400

I would also add that future IPv6 capable devices should allow end users to reach the IPv6 Internet
from an IPv4-only provider through some means, perhaps tunneling, with no or minimal administrator
intervention. I can see many providers remaining IPv4-only long into the future.

On 11-06-30 5:57 AM, Mark Townsley wrote:
> In other words, anything we do for the IPv6 homenet cannot actively break what's already running on IPv4. Also, trying to define what the IPv4 home network should be has long reached a point of diminishing returns given the effort in doing so coupled with our ability to significantly affect what's already deployed. There's still hope we can help direct IPv6, as such that is homenet's primary focus.  However, when we can define something that is needed for IPv6 in a way that is also useful for IPv4 without making significant concessions, we should go ahead and do so. 
> 
> - Mark

- -- 
Kenneth Voort - kenneth {at} voort <SPAMGUARD> {dot} ca
FDF1 6265 EBAB C05C FD06 1AED 158E 14D6 37CD E87F | pgp encrypted email preferred

---

From: Doug Barton <[email-masked]>
Date: Fri, 01 Jul 2011 13:13:41 -0700

> intervention. I can see many providers remaining IPv4-only long into the future.

This is an area that we very clearly do not need to get involved in 
because it will solve itself due to market forces. Right now there is no 
IPv6-only content that anyone cares about. When that changes, users will 
start demanding that their provider give them access to it, or vote with 
their feet.

That said, I don't see IPv6-only content happening any time in the next 
5 years, at least. Content providers do not want to cut themselves off 
from 99.9% of their potential user base.

What's going to encourage IPv6 adoption on the content side are things 
like smart phones that use it natively (which is already happening). 
Content providers will see (and many are already seeing) that it is in 
their own best interest to get their content up on IPv6.

The ISP side will be dragged kicking and screaming into the IPv6 world 
in the next couple of years as the IPv4 addresses really do dry up, and 
the cost of obtaining more on the gray market begins to exceed the cost 
of deploying IPv6. And of course, some just won't make the transition, 
and will ultimately fail. C'est la vie.

To summarize my main point once again, there is nothing for the IETF to 
do here, the problem will take care of itself.

Doug

-- 

	Nothin' ever doesn't change, but nothin' changes much.
			-- OK Go

	Breadth of IT experience, and depth of knowledge in the DNS.
	Yours for the right price.  :)  http://SupersetSolutions.com/

---

From: Keith Moore <[email-masked]>
Date: Fri, 1 Jul 2011 17:14:25 -0400

On Jul 1, 2011, at 4:03 PM, Kenneth Voort wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

+1

---

From: Keith Moore <[email-masked]>
Date: Fri, 1 Jul 2011 17:17:51 -0400

On Jul 1, 2011, at 4:13 PM, Doug Barton wrote:

> This is an area that we very clearly do not need to get involved in because it will solve itself due to market forces. Right now there is no IPv6-only content that anyone cares about. When that changes, users will start demanding that their provider give them access to it, or vote with their feet.

Whenever people talk about the Internet as if it were just about "access to content", I have to wonder.    The Internet has always been more about conversation than content.  

> To summarize my main point once again, there is nothing for the IETF to do here, the problem will take care of itself.

Quite the contrary.  We still don't have a good transition mechanism that HOMENET could specify.   6to4 has problems as we're now painfully aware; configured tunnels and Teredo have different problems.  There's still room for work in this space if better solutions can be identified.  Though it doesn't seem appropriate to ask the HOMENET WG to develop them.

Keith

---

From: Doug Barton <[email-masked]>
Date: Sat, 02 Jul 2011 18:31:47 -0700

On 07/01/2011 14:17, Keith Moore wrote:
>>> I would also add that future IPv6 capable devices should allow
>>> end users to reach the IPv6 Internet from an IPv4-only provider
>>> through some means, perhaps tunneling, with no or minimal
>>> administrator intervention. I can see many providers remaining
>>> IPv4-only long into the future.
>>
>> because it will solve itself due to market forces. Right now there
>> is no IPv6-only content that anyone cares about. When that changes,
>> users will start demanding that their provider give them access to
>> it, or vote with their feet.
>
> Whenever people talk about the Internet as if it were just about
> "access to content", I have to wonder.    The Internet has always
> been more about conversation than content.

The overwhelming majority of Internet users are consumers of content. 
Some of that content is stuff like Skype, instant messaging, etc.

The overwhelming majority of businesses that make the Internet work are 
the content providers, and the ISPs that enable the consumers of that 
content to reach it.

Failure to recognize these 2 critical facts leads to producing standards 
documents that have no relevance in the real world.

>> To summarize my main point once again, there is nothing for the
>> IETF to do here, the problem will take care of itself.
>
> Quite the contrary.  We still don't have a good transition mechanism
> that HOMENET could specify.

And as I pointed out in the bits of my message that you snipped, we 
don't need one.

Doug

--

---

From: Keith Moore <[email-masked]>
Date: Sat, 2 Jul 2011 23:43:49 -0400

On Jul 2, 2011, at 9:31 PM, Doug Barton wrote:

> The overwhelming majority of Internet users are consumers of content. Some of that content is stuff like Skype, instant messaging, etc.

The point is that the Internet is not primarily about producers in the center doling out content to users at the edge.  Granted, netflix uses a lot of bandwidth.  But a lot of what has driven use of the Internet, and continues to drive it, is users engaging in conversation of one form or another.  This was true when email and Usenet were the apps consuming the most bandwidth, and it's true today for Skype, Facebook, Youtube, IM, blogs, etc.

Meanwhile, traditional producer-to-consumer media channels of all types are steadily dying.   They tend to blame it on copyright violation, or "free" access to content on the Internet.  The real problem is that most of what they produce is crap.  They're stuck in an old model that says that a few people should decide what's good for everybody else, but now people are in a position to decide what's good for themselves and/or create their own content.

> The overwhelming majority of businesses that make the Internet work are the content providers, and the ISPs that enable the consumers of that content to reach it.
> 
> Failure to recognize these 2 critical facts leads to producing standards documents that have no relevance in the real world.

Insistence on sticking to anachronistic models of "the real world" will do the same thing.   

Keith

---

From: Roger Jørgensen <[email-masked]>
Date: Fri, 8 Jul 2011 09:46:00 +0200

On Thu, Jun 30, 2011 at 4:57 AM, Fernando Gont <[email-masked]> wrote:
> On 06/29/2011 11:38 PM, Cameron Byrne wrote:
>
>> The opportunity for restoring e2e is one of the great opportunities of
>> ipv6
>
> This assumes that e2e reachability is a desired property for all networks.

A very good point, there are a few network that break e2e on purpose.
But I guess this mostly affect enterprises and not the general
Internet part, and still I would guess that the network on the
"inside" for those enterprises still use e2e quite heavily so it's
still relevant.

-- 

Roger Jorgensen           |
[email-masked]          | - IPv6 is The Key!
http://www.jorgensen.no   | [email-masked]