Subject: RE: GEN-ART review for draft-li-pwe3-ms-pw-pon-03

From: "Lihongyu(Hongyu)" <[email-masked]>
Date: Wed, 06 Jul 2011 01:30:49 +0000

Hi Kathleen and Matthew,

Thank you for your review and comment. I have updated the draft according to most of your comments.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, June 27, 2011 9:09 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: Lihongyu(Hongyu); Robin Zheng(Ruobin); [email-masked]
Subject: GEN-ART review for draft-li-pwe3-ms-pw-pon-03 

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at
< http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please wait for direction from your document shepherd
or AD before posting a new version of the draft.

Document:  draft-li-pwe3-ms-pw-pon-03
Reviewer:  Kathleen Moriarty
Review Date: June 27, 2011
IETF LC End Date:
IESG Telechat date: June 28, 2011

Summary:  This document is ready with nits.

Major issues:

Minor issues:

Nits/editorial comments:

The acronym PW is used in the abstract and is not defined until the introduction.  Please fix.

Paragraph 7 of the introduction, last sentence:
Change from "Besides coding and
   maintenance of these new protocols, a much powerful CPU and more
   memory are also necessary for them to run smoothly."
To: "Besides coding and
   maintenance of these new protocols, a much more powerful CPU and more
   memory are also necessary for them to run smoothly."
If you do not want to repeat the word more, consider the word additional to replace the second instance of more.

Last paragraph of Section 4:
Consider changing from: "OMCI supports the configuration of a number of PW types including
   TDM, ATM, and Ethernet, and the protocol can also be used to allow
   the ONU to notify the OLT of the status of the AC."
To: "OMCI supports the configuration of a number of PW types including
   TDM, ATM, and Ethernet.  The protocol can also be used to allow
   the ONU to notify the OLT of the status of the AC."

---

From: "Lihongyu(Hongyu)" <[email-masked]>
Date: Wed, 06 Jul 2011 01:46:15 +0000

Hi Kathleen and Matthew,

Thank you for your review and comments. I have updated the draft according to most of your comments. I don't think it is right to talk about VCCV or complicated OAM mechanism in current draft. Probably there could be a new draft talking about this in the future. As for details about configuration parameters via OMCI, ITU-T is the right and better place to define and reference. ITU-T G.988 has all the details.

To all,

Besides, I made another two modification.
a) Modify all GPON to G-PON, according latest ITU-T G.987
b) Add XG-PON support. From MPLS PW or IETF point of view, XG-PON is exactly the same as G-PON, even though they have XGEM. In current draft, all "G-PON" related terminology could be simply add a "X" prefix and apply to XG-PON system directly. So, we would not need another draft for XG-PON.

Cheers,
Hongyu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, June 27, 2011 9:09 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: Lihongyu(Hongyu); Robin Zheng(Ruobin); [email-masked]
Subject: GEN-ART review for draft-li-pwe3-ms-pw-pon-03 

Major issues:

Minor issues:

Nits/editorial comments: