Subject: I-D Working groups and mailing list

From: Hector Santos <[email-masked]>
Date: Thu, 04 Aug 2011 00:13:05 -0400

I would like to propose that new I-D submissions include information 
about the existence of a Working Group, if any, and/or discussion 
group list address, if any, for to join and participate in the 
development of the I-D or simply to follow it.

I think I have read some I-D that including this useful information, 
but most do not. Its one the first things I look for.

I was going to suggest the same for an RFC, but it could be the WG was 
closed down by this time.

Just a thought if it makes sense.

-- 
Hector Santos, CTO
http://www.santronics.com
http://santronics.blogspot.com

---

From: Bill McQuillan <[email-masked]>
Date: Thu, 4 Aug 2011 00:11:38 -0700

> Just a thought if it makes sense.

+100

Perhaps it could be included in the ID-Announce message.

-- 
Bill McQuillan <[email-masked]>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 04 Aug 2011 10:36:46 +0200

> Perhaps it could be included in the ID-Announce message.

+1

This should be mandatory in IDs.

---

From: Peter Koch <[email-masked]>
Date: Thu, 4 Aug 2011 11:04:12 +0200

> This should be mandatory in IDs.

I-D announcements are already copied to the relevant WG for WG drafts.
Non-WG drafts may have the WG name in between '-' in the filename,
allowing an easy identification of the WG the author thinks the draft is
relevant to. A discussion mailing list is not mandatory for a draft
and it could be that the author is still looking.  As a courtesy to
the reader, i've used this kind of hint in the past where applicable.
But please, let us not add another mandatory boilerplate piece of text.

-Peter

---

From: Mykyta Yevstifeyev <[email-masked]>
Date: Thu, 04 Aug 2011 12:09:14 +0300

> But please, let us not add another mandatory boilerplate piece of text.

I think it's possible to add an additional text field in the I-D 
Submission tools allowing the author/editor to specify the link to the 
page which would lead the reader in the discussion and copy such link in 
the I-D announce and/or Datatracker page.  And at the author's/editor's 
discretion, such link may be put in the draft's body.

Mykyta

>
> -Peter
> _______________________________________________
> Ietf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf
>

---

From: John C Klensin <[email-masked]>
Date: Thu, 04 Aug 2011 09:47:32 -0400

--On Thursday, August 04, 2011 10:36 +0200 Julian Reschke
<[email-masked]> wrote:

>>> I would like to propose that new I-D submissions include
>>> information about the existence of a Working Group, if any,
>>> and/or discussion group list address, if any, for to join
>>> and participate in the development of the I-D or simply to
>>> follow it.
>> 
>>> I think I have read some I-D that including this useful
>>> information, but most do not. Its one the first things I
>>> look for.
>...

> This should be mandatory in IDs.

Many of us think this is a good idea.  Many of us have been
including it when we remember and are easily reminded to include
it in the next update when we do not.  

Reminding people is probably a good idea.  Including an explicit
placeholder for this in templates would probably be a good idea.
It would make a good habit.

But there are circumstances in which the appropriate mailing
list is not known at the time of posting and others in which
permission to use an obvious mailing list requires pre-approval
that might significantly delay posting of a draft.

What we don't need, IMO, is more rules, especially rules that
would then need exception procedures, open up opportunities for
appeals about approval processes and the use of particular
lists, etc. 

   john

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 04 Aug 2011 07:04:52 -0700

...
> What we don't need, IMO, is more rules,

Make the rule a SHOULD.  That allows exceptions.

When issuing an I-D, there needs to be a clear, affirmative obligation to help 
readers participate in discussion about the draft.

I suggested a requirement like this quite a few years ago and arguments similar 
to John's were invoked to kill it.

Based on how rare discussion venue citation remain, it's time to make the matter 
more explicit and formal.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 4 Aug 2011 10:11:06 -0400

> >>> From: Hector Santos

We already have mechanisms like this in place.  Most I-Ds include the
relevant WG in their name, and the extremely popular XML2RFC format
has a <workgroup> element for specifying the relevant WG.  And the I-D
submission tool checks that field.  (I just got bitten by that.)  The
XML2RFC tool carries the <workgroup> value into the page headers of
the text form (at least in some circumstances).

Once one knows the WG name, one can go through www.ietf.org to find
the information about the WG, including its mailing list.  (Though one
has to know some lore to do this successfully.)

> From: John C Klensin
> would then need exception procedures, [...]

Indeed, yes.  Our most limited resource is the labor of the real staff
and the volunteers, and we should not introduce a change that would
consume their labor unless there is a significant benefit to be
obtained.

Dale

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 4 Aug 2011 10:12:08 -0400

> From: [email-masked] [[email-masked]] On Behalf Of Bill McQuillan [[email-masked]]
>

In a lot of situations, the I-D submission tool knows the name of the relevant working group
and could include its mailing list address in the announcement automatically.

Dale

---

From: Julian Reschke <[email-masked]>
Date: Thu, 04 Aug 2011 16:16:21 +0200

On 2011-08-04 16:11, Worley, Dale R (Dale) wrote:
> has a<workgroup>  element for specifying the relevant WG.  And the I-D

Since when does the ID submission tool check the XML???

> XML2RFC tool carries the<workgroup>  value into the page headers of

Indeed.

Best regards, Julian

---

From: Dave CROCKER <[email-masked]>
Date: Thu, 04 Aug 2011 07:54:48 -0700

On 8/4/2011 7:11 AM, Worley, Dale R (Dale) wrote:
> Once one knows the WG name,

And when there is no working group that the document is associated with?

In addition, there is a certain degree of exclusionary culture that comes with a 
requirement that a new reader know how to derive a mailing list address from a 
cryptic working group reference or go through the work to find it.

One might argue that this is a test of their resolve and that we want to filter 
against overly casual participation, but that seems an odd bit of logic.

d/

-- 

   Dave Crocker

---

From: Hector Santos <[email-masked]>
Date: Thu, 04 Aug 2011 11:09:54 -0400

I don't know if there is a need for "template" changes or some formal 
section in the write up, but it would seem to me that an author who 
has reached a level of getting WG assigned and/or even started a 
mailing list (IETF or otherwise) would be very eager to announce it in 
a new I-D (01?) submission.  But then again, I can imagine some that 
don't wish to expose this for whatever reason, perhaps to keep the 
"team" light (and private) until they feel its ready public work - or 
not.

Dave CROCKER wrote:
> In addition, there is a certain degree of exclusionary culture that 
> comes with a requirement that a new reader know how to derive a mailing 
> list address from a cryptic working group reference or go through the 
> work to find it.
> 
> One might argue that this is a test of their resolve and that we want to 
> filter against overly casual participation, but that seems an odd bit of 
> logic.
> 
> d/

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 4 Aug 2011 10:33:29 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Koch
> Sent: Thursday, August 04, 2011 2:04 AM
> To: IETF Discussion
> Subject: Re: I-D Working groups and mailing list
> 

+1.  I don't agree that there's a problem to solve here.  The IESG is already in place to prevent end-runs around established procedure or conflicts with active working groups.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 4 Aug 2011 10:38:32 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Hector Santos
> Sent: Thursday, August 04, 2011 8:10 AM
> To: [email-masked]
> Cc: [email-masked]

OK, now I *really* don't know what the proposal is.

If we're not creating something formal, then the rules/procedures we have in place now are sufficient.  Those are:

If a WG has been created and "owns" the document, then the document has the WG name in its filename and usually says the name of the working group at the top of the first page.

If it's an individual submission associated with a working group, it has the first of those two.

If it's an individual submission not tracking a working group, the work may or may not benefit from some explicit association, and none is required.

In any case, I'm now quite confused about what change is being proposed here.

---

From: Hector Santos <[email-masked]>
Date: Thu, 04 Aug 2011 21:32:15 -0400

How my suggestion was to be done, I left as open ended for the IETF 
vets to consider if it makes sense, how its done and/or if already 
provided, maybe highlight that info. Whatever. But most of all, I was 
mostly suggesting a technical writing style or helpful guideline to 
authors to consider. Those who thinks it benefits readers will add the 
info when possible.  Those who don't, well, won't.

Not a big deal.

---

From: Julian Reschke <[email-masked]>
Date: Fri, 05 Aug 2011 10:45:27 +0200

> and could include its mailing list address in the announcement automatically.

...which of course does only help those readers who get to the ID via 
the announcement.

In my experience, many ID authors actually forget to consider where to 
send feedback. Thus making this something to be checked upon ID 
submission (maybe with a way to opt-out) might be helpful.

Best regards, Julian

---

From: Dave CROCKER <[email-masked]>
Date: Fri, 05 Aug 2011 08:52:28 -0700

On 8/5/2011 1:45 AM, Julian Reschke wrote:
> In my experience, many ID authors actually forget to consider where to send
> feedback. Thus making this something to be checked upon ID submission (maybe
> with a way to opt-out) might be helpful.

+1

When something is a routine expectation it is reasonable to build it into the 
model explicitly so that it (or its absence) can be detected structurally.

That said, the <note> construct works quite well, for those who remember to use 
it...

d/
-- 

   Dave Crocker

---

From: John C Klensin <[email-masked]>
Date: Sun, 07 Aug 2011 12:19:04 -0400

--On Thursday, August 04, 2011 10:38 -0700 "Murray S. Kucherawy"
<[email-masked]> wrote:

>...
>> I don't know if there is a need for "template" changes or
>> some formal section in the write up, but it would seem to me
>> that an author who has reached a level of getting WG assigned
>...
> If we're not creating something formal, then the
> rules/procedures we have in place now are sufficient.  Those
> are:
> 
> If a WG has been created and "owns" the document, then the
> document has the WG name in its filename and usually says the
> name of the working group at the top of the first page.
> 
> If it's an individual submission not tracking a working group,
> the work may or may not benefit from some explicit
> association, and none is required.
> 

Murray,

While I agree this has exploded out of control and into the
weeds, I think there is one fundamental issue.  That is whether
someone can easily find the right mailing list on which to
discuss a posted draft.  Modulo distractions, the responses
seem, in my highly prejudiced view, to fall into the following
categories:

(1) We should modify the posting tools and instructions to the
Secretariat so that no I-D can be posted unless a mailing list
reference appears (and probably appears in a designated format
and place).

(2) For WG-ish documents, it is easy enough to figure out where
the discussion forum is, at least if you have a clue.  The
advocates for (1) point out that clues are not universally
distributed.

(3) Especially for non-WG documents, some of us are fearful of a
requirement to designate a discussion forum as a prerequisite
for posting a document, especially since some documents are
posted in order to initiate a discussion of forum.  In
principle, all such documents could be pointed to the IETF list.
That is not necessarily an optimal solution even though it would
likely be the effect of requiring an announcement as in (1).

(4) Others (probably a partially overlapping group with (3))
just find more rules and requirements for more boilerplate
undesirable.  They would (at least mostly) be happy if lots of
off-list notes went to authors of I-Ds for which the discussion
forum wasn't clear, asking them about the discussion forum and
recommending that it be included in the next draft.   That might
actually encourage discussion and would be as, or more,
effective at retraining authors than more rules.

   john

---

From: Keith Moore <[email-masked]>
Date: Mon, 8 Aug 2011 14:05:23 -0400

On Aug 8, 2011, at 1:28 PM, Murray S. Kucherawy wrote:

>> From: John C Klensin [mailto:[email-masked]]
>> Sent: Sunday, August 07, 2011 9:19 AM
>> To: Murray S. Kucherawy; [email-masked]
>> Subject: RE: I-D Working groups and mailing list
>> 
> This is my preference.  If the author(s) don't include a "discuss this here" section, then they're inviting direct comments, and maybe that's what they prefer.  If not, they will quickly learn to either find or create a forum, even if that's just [email-masked], and mention such in the draft.

+1

Keith

---

From: [email-masked]
Date: Mon, 08 Aug 2011 13:34:27 -0700 (PDT)

> > recommending that it be included in the next draft.

But flip it around and see what you get: Why should I, as a document author who
wants to notify people where the discussion of the draft should take place, be
forced to use either an ad-hoc location in the document or have to send out a
bunch of additional emails? Why can't there be an *OPTIONAL* well known
location in our draft format (and corresponding XML element(s)) that automated
tools can pick up on so at a minimum this information can go out as part of the
new draft notifications?

In other words, the issue of whether or not there's a well defined way  to
incorporate this information is almost entirely orthogonal to whether or not we
require it's presence.

> > That might

> This is my preference.  If the author(s) don't include a "discuss this here"
> section, then they're inviting direct comments, and maybe that's what they
> prefer.

In that case the author can simply list their own address as the discussion
contact point. Why should have dig through an entire document looking for this
information or check my email for a separate message about it?

> If not, they will quickly learn to either find or create a forum, even if
> that's just [email-masked], and mention such in the draft.

> If it ain't broke, don't fix it.

But what we have now *is* broken, or at least fairly suboptimal.

				Ned

---

From: John C Klensin <[email-masked]>
Date: Mon, 08 Aug 2011 17:08:35 -0400

--On Monday, August 08, 2011 13:34 -0700
[email-masked] wrote:

>> > undesirable.  They would (at least mostly) be happy if lots
>> > of off-list notes went to authors of I-Ds for which the
>> > discussion forum wasn't clear, asking them about the
>> > discussion forum and recommending that it be included in
>> > the next draft.
> 
> But flip it around and see what you get: Why should I, as a
> document author who wants to notify people where the
> discussion of the draft should take place, be forced to use
> either an ad-hoc location in the document or have to send out a
> bunch of additional emails? Why can't there be an *OPTIONAL*
> well known location in our draft format (and corresponding XML
> element(s)) that automated tools can pick up on so at a
> minimum this information can go out as part of the new draft
> notifications?
> 
> In other words, the issue of whether or not there's a well
> defined way  to incorporate this information is almost
> entirely orthogonal to whether or not we require it's presence.

Absolutely.  If whomever is maintaining the tool sets wants to
provide that as an option element (or equivalent) for whatever
source language they are supporting, I have no problem with it
at all (and would be happy to convert my ad hoc mechanisms for
supplying that information to use it as I revise documents).  We
disagree in that I don't personally think it is worth the
trouble because I think we could as easily advise people to use
either a last subsection of an Introduction section or a <note>,
but I'm not maintaining the tools and therefore don't feel
entitled to a vote.

I have only two concerns:

(1) I don't want to see this made a requirement, largely because
I think it could easily turn into a bureaucratic mess.

(2) I don't want to see it (or anything else) back us into
either a requirement that everyone use xml2rfc or a requirement
that the source for I-Ds be submitted along with the formatted
ASCII-text versions.  So, while "optional well known location in
our draft format" is fine with me, tools that are expected to
pick information up by parsing XML and reading XML elements
aren't... simply because they would require that I-Ds be
prepared in XML and that the XML be generally available at
posting time.

    john

---

From: [email-masked]
Date: Mon, 08 Aug 2011 16:44:54 -0700 (PDT)

> I think it could easily turn into a bureaucratic mess.

It certainly does not make sense for it to be a requirement for drafts in
general. I'm less sure when it comes to drafts under active discussion - I
really don't have a problem with "repost that so everyone knows where to go".

> prepared in XML and that the XML be generally available at

I agree with trying to keep things this way, but I also think that as the
community's tools become more refined and sophisticated some amount of lossage
associated with their non-use is going to be unavoidable.

				Ned