Subject: RE: Gen-ART LC Review of draft-shiomoto-ccamp-switch-programming

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 10 Aug 2011 19:35:05 +0100

Hi Ben,

Thanks for reading.

> Nits/editorial comments:
> 
> -- section 1, paragraph 4: "...with relation to the programming..."
> 
> ... in relation to...

Yeah. RFC Editor note if Stewart is watching (although I'm guessing the RFC
Editor might just fix this anyway).

> -- 3.1, last paragraph:
> 
> Note that the references say SHOULD rather than MUST. Using "must not" here,
> even non-normatively, seems a bit overstated.

Disagree. The caveat is that we are defining something different. We are looking
at the case where we want to know that it is safe to start sending data. We are
using the existence of some "SHOULD" statements in related RFCs that describe
related behavior, to derive a "must" that covers when it is known to be safe.

Cheers,
Adrian

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 11 Aug 2011 10:40:37 +0100

> related behavior, to derive a "must" that covers when it is known to be safe.

Point 1 in the RFC editor's note, point 2 assumed to be addressed by the 
above email.

Stewart

---

From: Ben Campbell <[email-masked]>
Date: Wed, 10 Aug 2011 13:46:21 -0500

> related behavior, to derive a "must" that covers when it is known to be safe.

Okay, that makes sense. It might not hurt (but would be okay not to) to add a sentence explaining that this doc suggests a stronger requirement than in the source RFCs in order to be sure of safety.

Thanks!

Ben.