Subject: Re: [Idr] Last Call: <draft-ietf-idr-deprecate-as-sets-05.txt> (Deprecation of the use of BGP AS_SET, AS_CONFED_SET.) to Informational RFC

From: Randy Bush <[email-masked]>
Date: Fri, 12 Aug 2011 07:11:57 +0900

> The IESG has received a request from the Inter-Domain Routing WG (idr) to
> consider the following document:
> - 'Deprecation of the use of BGP AS_SET, AS_CONFED_SET.'
>   <draft-ietf-idr-deprecate-as-sets-05.txt> as an Informational RFC

i have read and support this document.  AS-Sets are essentially unused,
the deprecation is needed for the sidr work, and their removal will make
many research and ops tools which run against bgp announcements easier.

randy

---

From: Mattia Rossi <[email-masked]>
Date: Mon, 15 Aug 2011 09:39:47 +1000

> many research and ops tools which run against bgp announcements easier.

Writing and working with such research tools I can only support this 
document as well. In fact I'm usually ignoring AS-Sets, as their use is 
already extremely rare, and they just complicate the code.

Mat