Subject: Progress with Open Internet endowment

From: Russ Housley <[email-masked]>
Date: Thu, 2 Aug 2012 16:27:58 -0400

Our current totals as of noon today, the Open Internet Endowment has received $19,245 from 54 donors.  Thanks to all.

It would be great to reach $25,000 (or more) from 75 donors (or more) by lunch tomorrow.  Please help if you can.

There will be a table at the Bits-N-Bites tonight.  People will be at the table to answer any questions you might have.

Thanks,
  Russ

---

From: Russ Housley <[email-masked]>
Date: Fri, 3 Aug 2012 12:59:21 -0400

As of Friday morning, we are very close to the goal.  As of 9:00 AM this morning, we have $24,905 from 80 donors.  Please help if you can.

Thanks,
  Russ

---

From: Russ Housley <[email-masked]>
Date: Fri, 3 Aug 2012 14:47:33 -0400

Thank you!   We made it.  We received $26,255 from 90 donors.

Thanks agin,
  Russ