Subject: Thinking about text production and the "Draft" word processor

From: Dean Willis <[email-masked]>
Date: Tue, 12 Mar 2013 16:03:31 -0500

I stumbled on a link to a rather interesting "word processor" called Draft:

https://draftin.com/

The main claim to fame here is support for collaborative writing and review with better incremental/history  management than certain other browser-centric document production tools.

It also uses a wiki-like inline markup language for formatting, which it translates to HTML markup for display.

This raises some thoughts:

1) Something like Draft might make a simpler tool for I-D collaboration than github (which I used recently for a large I-D project). An author team could make use of it as-is.

2) Perhaps a wiki-like formatting language could be adapted to I-D writing; it could be made to generate XML2RFC output instead of HTML.

If we had a "Draft" that generated XML2RFC (particularly with a bi-directional transform) and a closely-mated issue tracker, the combination might be very cool.

--
Dean Willis

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 12 Mar 2013 17:43:06 -0400

On Mar 12, 2013, at 17:03, Dean Willis <[email-masked]> wrote:

> a wiki-like inline markup language

Well, actually it uses markdown, which seems to have a rather large penetration when it comes to writing-oriented markup.

If you want to use markdown for collaborating on RFC-style documents, there are tools like kramdown-rfc2629 or pandoc2rfc (both on github).

(The remaining problem is that the version control system offered by our tools is still SVN only, but that is probably still a great lowest common denominator.)

Grüße, Carsten