Subject: Re: Appointment of Scott Mansfield as new IETF Liaison Manager to the ITU-T

From: David Kessens <[email-masked]>
Date: Wed, 27 Mar 2013 14:26:37 -0700

Russ, Jari, IAB,

Recently, there has been a lot of discussion in the IETF about diversity.

A lot of people observed that the IETF is not good in fostering a culture
that naturally promotes diversity and that is attractive for younger people
to join. One way to make the IETF more accessible and approachable is to
stop making appointments for open positions by recruiting only behind closed
doors.

I am very disappointed that the IAB again has chosen to fill a position
without a clear and open call for volunteers. 

We can talk a long time about diversity in this community, but it is time to
take concrete actions.

David Kessens
PS This message doesn't in any way intends to doubt Scott's skills.
   I am disappointed about the process used.
---

On Wed, Mar 27, 2013 at 03:13:33PM -0400, IAB Chair wrote:
> The IAB has just notified the ITU-T that Scott mansfield will be the new IETF Liaison Manager to the ITU-T.
> 
> Please congratulate Scott when you see him. He has done a good job as liaison manager for MPLS, and I am sure he will do a good job in his new role.
> 
> Please thank Eliot Lear for his past service in this role.  Eliot no has a seat on the IAB, and I am sure he will provide valuable support for Scott.
> 
> Thanks,
>  Russ
> 
> = = = = = = = = = =
> 
> Liaison Statement: Appointment of Scott Mansfield as new IETF Liaison Manager to the ITU-T
> Submission Date: 27 March 2013
> From: The IAB (Russ Housley)
> To: ITU-T TSAG ([email-masked])
> Cc: IAB <[email-masked]>, The IAB Executive Director <[email-masked]>, [email-masked] <[email-masked]>, IESG <[email-masked]>
> Title: Appointment of Scott Mansfield as new IETF Liaison Manager to the ITU-T
> 
> The IAB would like to bring to the ITU-T's attention the appointment of Mr. Scott Mansfield as the new IETF Liaison Manager to the ITU-T.
> 
> The IETF Liaison Manager to the ITU-T sees to the day to day aspects of the relationship with the ITU-T, provides guidance to the IESG, IAB, and the IETF as a whole on strategic matters involving both organizations. In addition, Mr. Mansfield will work closely with our other liaison managers to assure consistency of approach across technologies, as well as see that liaisons from the ITU-T to the IETF are appropriately allocated and responded to. We expect Mr. Mansfield to play a significant supporting role in strategic discussions between the IETF and ITU leadership.
> 
> Mr. Scott Mansfield has over twenty of experience in software development and network management. He is a Principal Engineer in Ericsson’s DUIB Technology Network Architecture group. A long time technologist, Scott has built object-oriented workflow systems for the US Treasury Department, The United States Naval Reserve, Federal Express, and the United Parcel Service. Scott has also been the Lead Architect for Ericsson’s North American Mobile Backhaul Solutions, before moving into a position of Standards Engineer. Scott has been Ericsson’s MEF Coordinator for the past 5 years and is also an active contributor to the IETF and the ITU-T, and has been liaison manager from the IETF to ITU-T for MPLS for the past two years.
> 
> The IAB thanks the outgoing Liaison Manager, Mr. Eliot Lear, for his valuable service.
> 
> For the IAB,
> Russ Housley
> IAB Chair

David Kessens
---

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 28 Mar 2013 13:13:44 +0000

David

In this particular case the candidate pool would have been tiny,
because the criteria would surely have included being experienced
with both the ITU process and the IETF liaison process, including
knowing and understanding the liaison history. Therefore it
seems unlikely that there would be any candidate that the IAB
did not already know about. So whilst I agree in general,
this is not a case that should raise any concerns.

Scott BTW is an excellent choice and is well qualified on all of the
above counts.

- Stewart (who did not take part in the selection process)

On 27/03/2013 21:26, David Kessens wrote:
> .

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: John C Klensin <[email-masked]>
Date: Thu, 28 Mar 2013 10:02:12 -0400

--On Thursday, March 28, 2013 13:13 +0000 Stewart Bryant
<[email-masked]> wrote:

> David
> 
> In this particular case the candidate pool would have been
> tiny, because the criteria would surely have included being
> experienced with both the ITU process and the IETF liaison
> process, including knowing and understanding the liaison
> history.

You might have added "and has access to the considerable time
and travel resources needed to play in that particular pond",
which would make the pool even smaller.

> Therefore it seems unlikely that there would be any
> candidate that the IAB did not already know about. So whilst I
> agree in general, this is not a case that should raise any
> concerns.

While I agree that the pool is too limited to contribute
significantly to diversity other than, perhaps, on gender or age
grounds (at least the first is significant), the IAB's "already
knowing about" who might be in that pool is different from the
IAB assuming it knows who is available.  The only way to get to
the latter answer is to ask and, apparently, the question wasn't
asked.

In addition, IMO, there might have been a slight advantage in
another sort of diversity.  Given the long and difficult history
between the IETF and ITU-T over MPLS-related issues, a perfect
candidate might have had all of the attributes that Scott does
but with little or no prior identification with MPLS work.   The
candidate pool with that collection of attributes might turn out
to be empty or the tradeoffs might still have come out the same
way, but we don't know.

> Scott BTW is an excellent choice and is well qualified on all
> of the above counts.

I absolutely agree with this and I'm confident that he will do a
fine job. 

What I, and I assume David, are questioning is simply the
process that is used.    For me, it seems especially odd when
compared to the liaison position to the ICANN Board.  Both are
very important to the IETF community.  Both involve
organizations with which the IETF has a complicated and
multidimensional relationship.  Both involve issues that are
very sensitive.   Yet the IAB conducted an open call for
volunteers, followed by an open call for community comments, for
one position and simply announced the appointment for the other.
I think an explanation of the difference would be helpful for
everyone.

best,
   john

---

From: David Kessens <[email-masked]>
Date: Thu, 28 Mar 2013 10:04:08 -0700

Stewart,

> this is not a case that should raise any concerns.

This is exactly the reaction that makes me worried: if the pool of
candidates is already considered to be thin to begin with, it makes even
more sense to do a call for volunteers to make 100% sure that nobody gets
overlooked. 

It's not a healthy culture to only allow positions to be filled from the
inside crowd. It's time to fix that.

David Kessens
---

---

From: John E Drake <[email-masked]>
Date: Thu, 28 Mar 2013 17:07:23 +0000

Smoke filled rooms

Irrespectively Yours,

John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> David Kessens
> Sent: Thursday, March 28, 2013 10:04 AM
> To: Stewart Bryant
> Cc: [email-masked]
> Subject: Re: Appointment of Scott Mansfield as new IETF Liaison Manager
> to the ITU-T
> 
> 
> Stewart,
> 
> with
> > both the ITU process and the IETF liaison process, including knowing
> > and understanding the liaison history. Therefore it seems unlikely
> > that there would be any candidate that the IAB did not already know
> > about. So whilst I agree in general, this is not a case that should
> > raise any concerns.
> 
> candidates is already considered to be thin to begin with, it makes
> even more sense to do a call for volunteers to make 100% sure that
> nobody gets overlooked.
> 
> It's not a healthy culture to only allow positions to be filled from
> the inside crowd. It's time to fix that.
> 
> David Kessens
> ---

---

From: Melinda Shore <[email-masked]>
Date: Thu, 28 Mar 2013 09:19:00 -0800

On 3/28/13 5:13 AM, Stewart Bryant wrote:
> Therefore it

Wow.

Allow me to suggest that even if you think this is true,
going through an open, transparent process will provide
an answer to questions about insiderism and would be in
the best interest of the organization from a process point
of view.

Melinda

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 28 Mar 2013 18:28:47 +0100

> Recently, there has been a lot of discussion in the IETF about diversity.

Is it just me or is the liaison manager for the politically tempestuous ITU-T relationship really about the worst possible position to exercise this point on?

Choose your battles; this one is not a productive one.

Grüße, Carsten

---

From: Dave Crocker <[email-masked]>
Date: Thu, 28 Mar 2013 11:05:38 -0700

On 3/28/2013 6:13 AM, Stewart Bryant wrote:
> did not already know about.

Stuart,

It's important that you used the word "unlikely", since it underscores 
the legitimacy of the problem being raised: The issue is not that there 
probably would not have been a better choice, but the lack of certitude 
about it.

Further, the rationale you offer essentially is one of efficiency, but 
open processes rarely stand the scrutiny of 'efficiency' concerns.

d/
-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: John C Klensin <[email-masked]>
Date: Thu, 28 Mar 2013 14:50:40 -0400

--On Thursday, March 28, 2013 18:28 +0100 Carsten Bormann
<[email-masked]> wrote:

> Is it just me or is the liaison manager for the politically
> tempestuous ITU-T relationship really about the worst possible
> position to exercise this point on?
> 

Carsten,

I think there may be two, possibly three, separate issues here.

(1) Suppose the IAB had said, borrowing from your words, "this
position is so politically tempestuous that we've concluded it
would be unwise to appoint anyone unless he or she is now
serving in an SG liaison role or has been actively involved in
the liaison oversight activities in the last year".   That would
lead to a small pool, but, speaking from the perspective of
someone who would meet that qualification, I'd think it would be
reasonable (whether I agree or not).  If that were among the
IAB's criteria for the appointment, a discussion within and
about that small group would be sufficient and a public call for
candidates would be a waste of the time of both the community
and the IAB except, perhaps, for symbolic purposes.   Perhaps
that is more or less what happened, in which case all we have is
an instance of less-than-ideal communication.

(2) Given that the pool is small under any scenario, should
there have been a public call for candidate applications?    I
tend to agree with David about that -- an open call for
candidates can only increase the IAB's and the community's
confidence that everyone plausible and willing has been
considered.  On the other hand and referring to the above, if
the IAB defined the pool so that a public call would just be
window-dressing then I, for one, appreciate their not wasting
everyone's time.  I also don't have an opinion as to whether
they should have posted the criteria they were going to use and
issued a public call for comment on them.  Again, precisely
because this is a sensitive job, that is not an obviously good
idea, especially if the comments were likely to explode onto
public lists or, in the worst case, an effort by the other body
to influence the choice of candidates.

(3) If they had issued a public call for candidates, should they
have been required to make the names public and ask for
community comment on those names?  I'm sure that some would
argue that they should.  You would presumably say "politically
tempestuous relationship" and "no".  While I would agree with
you, I would generalize it and suggest that the IAB should
never, or almost never, issue such a list of names and public
call for comments about candidates for a liaison position.   My
reason would be that one doesn't want to encourage
second-guessing by the other body, even if as mild as "what does
it mean that they sent us Alice instead of Bob", much less
efforts by the other body to influence the choice.  So, again
comparing the apparent handling of the ITU-T and ICANN liaison
roles, I think both represent less-than-optimal judgment on the
IAB's part, one to expose too little and the other to expose too
much.  But I don't know all of the facts or the IAB's reasoning
and might change my mind if I did. 

YMMD.
   john

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Thu, 28 Mar 2013 22:22:19 +0000

That was the British use of the term "unlikely".

Stewart

Sent from my iPad

On 28 Mar 2013, at 14:05, "Dave Crocker" <[email-masked]> wrote:

> It's important that you used the word "unlikely", since it underscores the legitimacy of the problem being raised: The issue is not that there probably would not have been a better choice, but the lack of certitude about it.
> 
> Further, the rationale you offer essentially is one of efficiency, but open processes rarely stand the scrutiny of 'efficiency' concerns.
> 
> d/
> -- 
> Dave Crocker

---

From: Michael StJohns <[email-masked]>
Date: Thu, 28 Mar 2013 21:03:25 -0400

The IETF and various members occasionally break out in back seat driver's syndrome. It's disappointing. 

We need to remember that we are organized more as a republic than a democracy.  We select various folks through the Nomcom process to make decisions on various things.  E.g.. the IESG for standards advancement, the IAOC for meeting venue select and the IAB for appointment of liaisons.  

The process for selecting and appointing liaisons is the purview of the IAB and not currently subject to external review - and I don't find any problem with that.  Among other things, liaisons have to be acceptable to both sides of the liaison relationship.   Trying to fill that slot like we might an IESG slot (e.g. advertising, running them through the nomcom and then having the IAB appoint them) really makes little sense.  Also, since liaison's have no specific term (I think that's the case - I'm not going to go research it right now), if a better fit comes along (e.g. someone volunteers) there is really no bar to the IAB replacing the current liaison by the issuance of a single email.  (And this is the point where I ask David if he's got a better candidate).

Seriously - can we stop second guessing the IESG, IAB and IAOC on everything?  If there is a wide held belief that we need to revise the scope of responsibilities for any of these bodies, let's address THAT problem  (I haven't heard there is - but I may have missed something) rather than caviling about decisions that probably have little if any direct impact on the ability of the IETF to create standards.

Mike

---

From: Dave Crocker <[email-masked]>
Date: Thu, 28 Mar 2013 22:13:33 -0700

On 3/28/2013 6:03 PM, Michael StJohns wrote:
> Seriously - can we stop second guessing the IESG, IAB and IAOC on everything?

That's not what's being done, Mike, and such hyperbole doesn't 
facilitate meaningful exchange.

There have been two exceptions raised -- one about diversity and this 
second about open solicitation of candidates.  Both have been concrete 
and targeted criticisms, with plenty of thoughtful postings in their 
respective threads.

d/

---

From: David Kessens <[email-masked]>
Date: Thu, 28 Mar 2013 22:14:15 -0700

Mike,

On Thu, Mar 28, 2013 at 09:03:25PM -0400, Michael StJohns wrote:
>
> The process for selecting and appointing liaisons is the purview of the
> IAB and not currently subject to external review - and I don't find any
> problem with that.

I fully agree with this.

All I am asking for is a call for volunteers.

I am not even asking for publication of the resulting list of volunteers to
allow for public comments.

The IAB, the IESG or whatever body in the IETF that needs to fill a position
cannot possibly know all possible candidates for a position. The IETF is not
a small community any longer where everybody knows each other. It is very
easy to overlook good potential candidates. An open call helps the bodies
that make the decisions to find as many candidates as possible. How can
potential candidates even know that somebody is looking for a candidate if
the potential candidate is not part of the incrowd him/herself ?

And yes, I speak from experience: I have been an Area Director and I did
open calls for volunteers whenever a position needed to filled. It involves
some extra work but I did find that there were many more capable people that
could fullfill the roles than I would have thought before I initiated such a
call (the pool of candidates often turned out to much heathier than my
initial guess of a "thin" pool).

David Kessens
---

---

From: Michael StJohns <[email-masked]>
Date: Fri, 29 Mar 2013 03:22:06 -0400

At 10:02 AM 3/28/2013, John C Klensin wrote:
>   For me, it seems especially odd when

The ICANN position of IETF Liaison is defined in the ICANN charter and has a specific fixed term, as such it gets handled via a call for volunteers and an appointment by the IAB.   AFAIK - there is no "IETF appoints a liaison to the ITU-T board" position defined. I believe the actual "liaison" status is between the IETF/ISOC and the ITU-T and the IETF ITU-T liaison acts more as a point of contact than anything else.  I find it telling that RFC6756 doesn't even mention a role for a specified person designated as liaison.

I would assume this accounts for the difference.  (Formal role vs informal/ad hoc role).

Mike

---

From: Michael StJohns <[email-masked]>
Date: Fri, 29 Mar 2013 03:33:16 -0400

>All I am asking for is a call for volunteers.

If it's within their purview, they get to decide what process they'll follow.  If they need volunteers, I expect them to ask us.  If they already have someone to do the job and they're happy with them, I expect them to get on with it.  I don't think this needs to be a rule.  And I think it's mostly unnecessary.

>allow for public comments.

And that would be a second bridge too far.

>the potential candidate is not part of the incrowd him/herself ?

Liaison's generally have very little authority.  They act primarily as a point of presence.  And for things like the ITU-T, you really need to get someone who has a firm anchor in the other organization.  Back in pre-history (my first term on the IAB), most of the liaison requests come in from other organizations (e.g. will you accept X as a liaison) rather than the IETF seeking to appoint someone to represent us.  There are lot of nuances and there will be organizations where we want to ask for volunteers, organizations where the IAB is looking for one specific set of skills and finds it, and organizations where we'll say "yeah, sure, X can be a liaison".  

>open calls for volunteers whenever a position needed to filled.

You had open calls for volunteers for working group chairs?

> It involves

Fair - but these are apples and oranges.  What worked well for you in your area, might work well for one organization, be a total political disaster for another and scare off the guy who just wanted to pass on something from a third.

Can't we just trust the IAB to do its job?  If we can't, then we either need to change the scope of the job, or select a whole new IAB.

Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 29 Mar 2013 08:02:06 +0000

On 29/03/2013 07:33, Michael StJohns wrote:
> If it's within their purview, they get to decide what process they'll follow.  

Of course, and I didn't hear anybody suggesting that we need to update some
BCP or other for this. But for a whole lot of reasons, including the case
of a collective blind spot in the IAB, calling for volunteers is a
suggestion that IMHO the IAB would do well to adopt in future.

Anyone who reads RFC 4052, 4053 and 4691 will realise that they are not
volunteering for a trivial job.

    Brian