Subject: Re: Internet Draft Final Submission Cut-Off Today

From: Roberto Peon <[email-masked]>
Date: Mon, 4 Mar 2013 13:53:32 -0800

There was a fire in the office, three desks away from mine last week during
the weekend. Sprinklers came on.
If my computer had either caught fire, or been exposed to too much water
(luckily neither happened) the draft would have been lost.

I still fail to see why the solution is to ban *submissions*. It seems like
a better solution is one of visibility for those who need to triage.

-=R

On Thu, Feb 28, 2013 at 12:13 AM, Brian E Carpenter <
[email-masked]> wrote:

> Ned,
>
> On 27/02/2013 19:21, [email-masked] wrote:
> >> On 02/27/2013 01:49 PM, Carsten Bormann wrote:
> >> > On Feb 27, 2013, at 19:18, [email-masked] wrote:
> >> >
> >> >> routing around obstacles
> >> > It turns out for most people the easiest route around is submitting
> >> in time.
> >> >
> >> > That is actually what counts here: how does the rule influence the
> >> behavior of people.
> >> >
> >> > Chair hat: WORKSFORME.  (And, if I could decide it, WONTFIX.)
> >> +1.
> >
> >> As far as I can tell, the deadline actually serves the purpose of
> >> getting people to focus on IETF and update their documents sufficiently
> >> prior to the meeting, that it's reasonable to expect meeting
> >> participants to read the drafts that they intend to discuss.   And I say
> >> this as someone who, as an author, has often found the deadline to be
> >> very inconvenient.
> >
> > And your evidence for this is .. what exactly? Yes, the deadline makes
> the
> > drafts show up a bit sooner, but I rather suspect that the overwhelming
> > majority of people don't bother to do much reading in the inverval. I
> > certainly
> > don't.
>
> Just to present another view, I certainly do.
>
> I agree that this is more important for -00 drafts, and that looking at
> the diffs *may* be sufficient for updated drafts. However, with hundreds
> of documents coming down the pipe shortly before the meeting, I firmly
> believe that the two deadlines are essential in order to achieve any
> kind of systematic triage and decide what needs careful reading.
>
> I think many of us have a wide range of interests that make this
> triage important.
>
>   Brian
>

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 04 Mar 2013 18:05:31 -0700

On 3/4/13 2:53 PM, Roberto Peon wrote:
> There was a fire in the office, three desks away from mine last
> week during the weekend. Sprinklers came on. If my computer had
> either caught fire, or been exposed to too much water (luckily
> neither happened) the draft would have been lost.

Nothing is stopping you from using source control. :-)

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Roberto Peon <[email-masked]>
Date: Mon, 4 Mar 2013 19:11:52 -0800

I think you mean backup solution, source control won't help on its own :)
-=R

On Mon, Mar 4, 2013 at 5:05 PM, Peter Saint-Andre <[email-masked]>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>
> iQIcBAEBAgAGBQJRNUTaAAoJEOoGpJErxa2pOFUP+wVEi8afThphqWQbv1yU6hcf
> W+ZcBao62aUue+Kek86kbfGaEaxmwLqwltJPReJQb8lTUIYcNPu0Fu1eZ9zEcbsX
> 6Zq1TEyPxCc+9BjytU2c5ZOOaA6jdGDDK57/rY8Rnx92w7W4ads2dY9wgDXSwiUt
> sXL6WpIhRDD2MDWVzmu7dDP5FzrlzQtk4xdZo4vJRk5LXVpVVCUKerHYXquuCdj/
> 1xWMHXNGfVP2rCymfgcSiwOGjOBKzzfyQ5j2YXK/Fj9uEFjIkIaECYPFEeRH64qJ
> i1wbPqbMpJeoMzE82me0Ba1lDwiH93W4eUXUqBEIGsZ0WgoaNhYs/PqMikMGVk77
> aZ2fKwCNNt0GmjmKf3MaRCwSAoaIfHqjFkxEhasOIz4u4kB2Gdq0JVjRSVH/sX09
> CXrFt9as1z7NxF7nvQkTK1pFDxOZiKcDkNUfiOX47C372QjXITfyqA5Tcy0AR8ZM
> 7TRcf0lKBnl84XHEAXDeFfv9mFC8W2ozM3OtJVTBsM1rXVLsPs7hei1HHspytRUB
> WmrDI3C49OIOT4xSMG12rQ1G66WC0KPckzLmxsJbEwryW6gx1hQMz0reeRDticID
> LAdNHAn4CJv3+fEQcAqpk8EI204vdhXLaKIgsZk+XiB+ktK9TYmapC2LUzJmDSYq
> xT1G6WR9Mynm3TixX0nS
> =1HLF
> -----END PGP SIGNATURE-----
>

---

From: David Morris <[email-masked]>
Date: Mon, 4 Mar 2013 19:22:31 -0800 (PST)

> I think you mean backup solution, source control won't help on its own :)

Source control, assuming the traditional server implementation, is one
form of backup solution ... but I agree, the requirement is a backup
solution where the backup is protected from the hazards the individual
computer would be subjected to.

Draft submission is hardly the best way to protect work.

---

From: Roberto Peon <[email-masked]>
Date: Mon, 4 Mar 2013 19:50:07 -0800

No disagreement. It is merely *a* way, and, popping back to the original
topic, it is better to allow the submission and deny the visibility than to
disallow the submission

-=R

On Mon, Mar 4, 2013 at 7:22 PM, David Morris <[email-masked]> wrote:

> > On Mon, Mar 4, 2013 at 5:05 PM, Peter Saint-Andre <[email-masked]
> >wrote:
> >

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 7 Mar 2013 10:34:29 +0100

Oh, and one more data point:

The Internet-Draft archive also functions as a timestamped signed public archival record of our "inventions".
(Which are often trivial, but triviality won't stop patenting of copycats, while a good priority more likely will.)

This function is effectively suspended for six weeks a year.

Grüße, Carsten

PS.: (If that sounds like I'm contradicting myself that's only because we haven't found the right solution yet.)

On Feb 27, 2013, at 19:49, Carsten Bormann <[email-masked]> wrote:

> It turns out for most people the easiest route around is submitting in time.
> 
> That is actually what counts here: how does the rule influence the behavior of people.
> 
> Grüße, Carsten

---

From: Elwyn Davies <[email-masked]>
Date: Thu, 07 Mar 2013 10:09:39 +0000

Submission allowed; publication postponed?

/Elwyn

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 7 Mar 2013 12:17:08 +0200

submission allowed + publication posted but not fully considered in the WG discussions?

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 07 Mar 2013 10:56:43 +0000

> (Which are often trivial, but triviality won't stop patenting of copycats, while a good priority more likely will.)

FWIW, I think that's an incidental good side-effect but shouldn't
drive what we do here.

My take is that I don't care about this, so long as drafts that
are discussed at meetings are posted early enough to allow folks
a chance to read them. The current rule achieves that well enough,
as could a less coarse-grained rule. I've not seen a worked out
proposal for such a less coarse-grained rule that achieves that
yet.

S

---

From: Eric Burger <[email-masked]>
Date: Sun, 10 Mar 2013 08:27:10 -0400

I do but don't care. With my IETF hat on, the whole point of the cut-off is to enforce a physical barrier to ensure we do not ever hear, "I posted this draft yesterday, let's talk about it" in a work group. With my legal services hat on, with the US joining the rest of the world with first-to-file, those few weeks of publication could mean the difference between a free and open standard and a NPE swooping in and attempting to tax the industry.

---

From: Dave Crocker <[email-masked]>
Date: Sun, 10 Mar 2013 08:46:13 -0400

> I do but don't care. With my IETF hat on, the whole point of the cut-off is to enforce a physical barrier to ensure we do not ever hear, "I posted this draft yesterday, let's talk about it" in a wo…

If that were a problem for all working groups, all the time, it might 
make at least some sense.  But it isn't, so it doesn't.

It also entirely underestimates the ability of participants to generate 
new, unreasonable demands...

Ultimately the problem you are using for justification is a matter of 
good working group management.

Solve it with better management, not artificial barriers that are 
imposed on everyone and that can be trivially routed around, albeit 
without the benefits of using the I-D mechanism.

d/
-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Brian Trammell <[email-masked]>
Date: Sun, 10 Mar 2013 08:57:08 -0400

On 10 Mar 2013, at 8:46, Dave Crocker <[email-masked]> wrote:

> If that were a problem for all working groups, all the time, it might make at least some sense.  But it isn't, so it doesn't.
> 
> It also entirely underestimates the ability of participants to generate new, unreasonable demands...
> 
> Ultimately the problem you are using for justification is a matter of good working group management.
> 
> Solve it with better management, not artificial barriers that are imposed on everyone and that can be trivially routed around, albeit without the benefits of using the I-D mechanism.
> 
> d/
> -- 
> Dave Crocker

---

From: Brian Trammell <[email-masked]>
Date: Sun, 10 Mar 2013 09:12:01 -0400

> Solve it with better management, not artificial barriers that are imposed on everyone and that can be trivially routed around, albeit without the benefits of using the I-D mechanism.

+1 (and apologies for the jet-lag-induced empty post)...

There's a big difference between a -01 revision of an individual draft which substantially replaces the content of its -00, and a last-minute revision -22 of a long-standing working group draft that fixes a minor point that's been well-discussed on the list with clear consensus for the change. A week before a WG meeting, it's just as unrealistic to expect people to be able to discuss the former if it's posted as it is to expect them _not_ to post the latter on a private server somewhere and point to that in the discussion.

This seems like something that could be left to the discretion of the chairs on setting the agenda for each WG meeting, as long as there's transparency in the criteria that will be used to decide whether a recently-submitted draft can be discussed on the agenda. An announcement from the chairs here would suffice, from something simple like 

"The traditional two-week period applies: drafts to be discussed in Berlin must be submitted before Monday July 15",

or a slightly fuzzier: 

"Priority in the working group agenda will be given to working group drafts before individual drafts, then to draft revisions submitted earlier than later, as we believe we can have a more productive discussion on work that more people have had a chance to read."

Different WGs have different workflows, though, so allowing the chairs to do this on a per-WG basis seems reasonable.

Cheers,

Brian

---

From: Scott Brim <[email-masked]>
Date: Sun, 10 Mar 2013 10:35:27 -0400

> This seems like something that could be left to the discretion of the
> chairs on setting the agenda for each WG meeting, as long as there's
> transparency in the criteria that will be used to decide whether a
> recently-submitted draft can be discussed on the agenda.

Yes, place the decision in the WGs.  Once upon a time in a WG far away
we did say "You can submit drafts and discuss them on the mailing list
any time you want, but the agenda for the meeting will be set two weeks
in advance."

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 10 Mar 2013 15:15:43 +0000

> any time you want, but the agenda for the meeting will be set two weeks

Please don't. Currently we receive a flood of a few hundred drafts two
weeks before each meeting, which gives time for some triage. I do not
wish to receive a few hundred drafts on the first day of the meeting,
with no time for triage, but that would be the inevitable end-point if
the deadline was abolished. (Unless there has been an unannounced change
in human nature, of course.)

   Brian

---

From: Scott Brim <[email-masked]>
Date: Sun, 10 Mar 2013 11:30:23 -0400

> in human nature, of course.)

but you can disallow them yourself.

---

From: Cullen Jennings <[email-masked]>
Date: Sun, 10 Mar 2013 10:44:51 -0500

> in human nature, of course.)

+1