Subject: Gen-ART Last Call Review of draft-ietf-ospf-ipv4-embedded-ipv6-routing-07

From: Ben Campbell <[email-masked]>
Date: Tue, 26 Mar 2013 18:17:46 -0500

I am the assigned Gen-ART reviewer for this draft. For background on
Gen-ART, please see the FAQ at

<http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.

Please resolve these comments along with any other Last Call comments
you may receive.

Document:  draft-ietf-ospf-ipv4-embedded-ipv6-routing-07
Reviewer:  Ben Campbell
Review Date: 2013-03-26
IETF LC End Date: 2013-03-29

Summary: The draft is mostly ready for publication as an informational RFC, but I have some editorial comments that might be worth considering prior to publication.

Major issues:

None

Minor issues:

None

Nits/editorial comments:

-- Please expand the "P" in "P Router" in the first mention. 

-- section 3.1, paragraph 2: "... and also at least some of their network core facing interfaces along with some P routers in the IPv6 network."

This seems vague. Do you mean to say that each must have one or more of their core facing interfaces in the topology? Can "some P routers" be stated more precisely in terms of the requirements for a particular AFXLBR? 

-- 3.1, paragraph 3, 2nd sentence:

The sentence is hard to parse. Comma usage seems off, and the antecedent of "it" is unclear. I suggest breaking it into multiple simpler sentences.

-- 3.2: "... following sub-sections"

Explicit references would be helpful, if this text is ever quoted outside the draft. 

-- 3.4:

inconsistent hyphenation of "MTID" vs "MT-ID"

"In addition, the MT bit in the OSPFv3 Option field must be set."

Did you mean that to be an all-caps MUST? I'm neutral on whether it is required, but you did use MUST for similar text in the previous section.

-- 4.1, last 2 paragraphs:

Is the 2119 language in these paragraphs new normative language, or restatements of normative text in the referenced RFC? If the latter, it would be better use descriptive rather than normative language here.

-- 5, 2nd paragraph : " ... the IPv4 networks and IPv6 networks belong to separate and independent Autonomous Systems"

The draft has other assertions that appear to say that they are all assumed to be in the same autonomous system. (E.g. Section 3.3)

-- 8:

Which is the backdoor? The direct ipv4 route, or the imbedded route? I can infer the answer to that, but not until the last sentence.

-- 11, 4th paragraph:

What's the antecedent of "this engineering practice"? This draft? The use of the the same SA?

-- 11, last paragraph:

Again, what is the antecedent of "this engineering practice"? Aren't the security details of that what this section is about in general? 

-- references:

draft-ietf-ospf-mt-ospfv3-03 has been updated to 04.

---

From: Dean cheng <[email-masked]>
Date: Wed, 27 Mar 2013 17:30:50 +0000

Hi Ben,

Thanks for the review and comments;
we'll post a new revision soon.

Dean

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Tuesday, March 26, 2013 4:18 PM
> To: [email-masked]
> Cc: [email-masked] Review Team; IETF-Discussion list
> Subject: Gen-ART Last Call Review of draft-ietf-ospf-ipv4-embedded-
> ipv6-routing-07
> 
> Summary: The draft is mostly ready for publication as an informational
> RFC, but I have some editorial comments that might be worth considering
> prior to publication.
> 
> Major issues:
> 
> None
> 
> Minor issues:
> 
> None
> 
> Nits/editorial comments:
> 
> -- section 3.1, paragraph 2: "... and also at least some of their
> network core facing interfaces along with some P routers in the IPv6
> network."
> 
> This seems vague. Do you mean to say that each must have one or more of
> their core facing interfaces in the topology? Can "some P routers" be
> stated more precisely in terms of the requirements for a particular
> AFXLBR?
> 
> The sentence is hard to parse. Comma usage seems off, and the
> antecedent of "it" is unclear. I suggest breaking it into multiple
> simpler sentences.
> 
> Did you mean that to be an all-caps MUST? I'm neutral on whether it is
> required, but you did use MUST for similar text in the previous section.
> 
> Is the 2119 language in these paragraphs new normative language, or
> restatements of normative text in the referenced RFC? If the latter, it
> would be better use descriptive rather than normative language here.
> 
> -- 5, 2nd paragraph : " ... the IPv4 networks and IPv6 networks belong
> to separate and independent Autonomous Systems"
> 
> The draft has other assertions that appear to say that they are all
> assumed to be in the same autonomous system. (E.g. Section 3.3)
> 
> -- 8:
> 
> Which is the backdoor? The direct ipv4 route, or the imbedded route? I
> can infer the answer to that, but not until the last sentence.
> 
> -- 11, 4th paragraph:
> 
> Again, what is the antecedent of "this engineering practice"? Aren't
> the security details of that what this section is about in general?
> 
> -- references:
>