Subject: Weekly posting summary for [email-masked]

From: Thomas Narten <[email-masked]>
Date: Fri, 07 Jun 2013 00:53:03 -0400

Total of 146 messages in the last 7 days.
 
script run at: Fri Jun  7 00:53:03 EDT 2013
 
    Messages   |      Bytes        | Who
--------+------+--------+----------+------------------------
 10.27% |   15 |  9.96% |   125797 | [email-masked]
  4.11% |    6 |  6.44% |    81389 | [email-masked]
  5.48% |    8 |  3.76% |    47556 | [email-masked]
  4.11% |    6 |  4.30% |    54259 | [email-masked]
  3.42% |    5 |  3.58% |    45181 | [email-masked]
  3.42% |    5 |  3.28% |    41450 | [email-masked]
  3.42% |    5 |  3.16% |    39894 | [email-masked]
  3.42% |    5 |  2.36% |    29749 | [email-masked]
  2.74% |    4 |  2.53% |    31911 | [email-masked]
  2.74% |    4 |  2.18% |    27483 | [email-masked]
  1.37% |    2 |  3.38% |    42690 | [email-masked]
  2.74% |    4 |  1.86% |    23539 | [email-masked]
  1.37% |    2 |  3.15% |    39833 | [email-masked]
  2.05% |    3 |  1.88% |    23809 | [email-masked]
  2.05% |    3 |  1.68% |    21225 | [email-masked]
  2.05% |    3 |  1.62% |    20488 | [email-masked]
  1.37% |    2 |  2.29% |    28971 | [email-masked]
  2.05% |    3 |  1.54% |    19411 | [email-masked]
  0.68% |    1 |  2.80% |    35397 | [email-masked]
  2.05% |    3 |  1.37% |    17285 | [email-masked]
  0.68% |    1 |  2.66% |    33542 | [email-masked]
  1.37% |    2 |  1.73% |    21883 | [email-masked]
  1.37% |    2 |  1.64% |    20761 | [email-masked]
  1.37% |    2 |  1.50% |    18953 | [email-masked]
  1.37% |    2 |  1.44% |    18207 | [email-masked]
  1.37% |    2 |  1.37% |    17302 | [email-masked]
  1.37% |    2 |  1.35% |    17078 | [email-masked]
  1.37% |    2 |  1.27% |    16048 | [email-masked]
  1.37% |    2 |  1.10% |    13834 | [email-masked]
  1.37% |    2 |  1.09% |    13711 | [email-masked]
  1.37% |    2 |  1.06% |    13376 | [email-masked]
  1.37% |    2 |  0.94% |    11882 | [email-masked]
  1.37% |    2 |  0.92% |    11641 | [email-masked]
  0.68% |    1 |  1.60% |    20151 | [email-masked]
  1.37% |    2 |  0.88% |    11081 | [email-masked]
  1.37% |    2 |  0.87% |    10956 | [email-masked]
  0.68% |    1 |  0.95% |    12013 | [email-masked]
  0.68% |    1 |  0.88% |    11066 | [email-masked]
  0.68% |    1 |  0.73% |     9244 | [email-masked]
  0.68% |    1 |  0.67% |     8504 | [email-masked]
  0.68% |    1 |  0.66% |     8340 | [email-masked]
  0.68% |    1 |  0.63% |     7996 | [email-masked]
  0.68% |    1 |  0.63% |     7948 | [email-masked]
  0.68% |    1 |  0.62% |     7882 | [email-masked]
  0.68% |    1 |  0.61% |     7654 | [email-masked]
  0.68% |    1 |  0.61% |     7651 | [email-masked]
  0.68% |    1 |  0.60% |     7579 | [email-masked]
  0.68% |    1 |  0.59% |     7486 | [email-masked]
  0.68% |    1 |  0.55% |     6960 | [email-masked]
  0.68% |    1 |  0.55% |     6886 | [email-masked]
  0.68% |    1 |  0.53% |     6748 | [email-masked]
  0.68% |    1 |  0.52% |     6615 | [email-masked]
  0.68% |    1 |  0.52% |     6609 | [email-masked]
  0.68% |    1 |  0.51% |     6418 | [email-masked]
  0.68% |    1 |  0.50% |     6367 | [email-masked]
  0.68% |    1 |  0.50% |     6353 | [email-masked]
  0.68% |    1 |  0.50% |     6328 | [email-masked]
  0.68% |    1 |  0.49% |     6164 | [email-masked]
  0.68% |    1 |  0.45% |     5654 | [email-masked]
  0.68% |    1 |  0.44% |     5502 | [email-masked]
  0.68% |    1 |  0.41% |     5235 | [email-masked]
  0.68% |    1 |  0.41% |     5212 | [email-masked]
  0.68% |    1 |  0.40% |     5074 | [email-masked]
--------+------+--------+----------+------------------------
100.00% |  146 |100.00% |  1263211 | Total

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 7 Jun 2013 10:33:21 +0200

Hi thomas,

AB> Comment on the summary report>

 I recommend to add a column for subjects (number of subjects),
because the number of subject participated in is very important is
such summary.
 I think the pupose of this summary should be added as well in each
post, I don't know why, only I expect the purpose is that it informs
of work volume or overhead in such list.

AB

---

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2013 14:39:54 +0000

> because the number of subject participated in is very important is

It has always been my assumption that the point of this summary was to give us all a reality check when we say too much on the IETF mailing list.   Saying things on the IETF mailing list is very expensive because it addresses the entire IETF; we should choose our words carefully, and say no more than is absolutely necessary.   So I think that total volume is really the most important metric—I was very upset a month or so ago when I noticed that I'd been the most voluminous poster, and I've tried to avoid being the top poster again since then.

---

From: Thomas Narten <[email-masked]>
Date: Fri, 07 Jun 2013 10:49:23 -0400

What the weekly stats really ought to tally up is the readers/postings
ratio, so that folk would get more direct feedback as to whether what they are
posting is actually being read...

My strong suspicion would be that there is strong negative correlation
between frequency of posts and actual readers of those posts...

Also, I suspect that many people do not realize that a significant
chunk of IETF contributers are no longer subscribed to the ietf list
due to signal to noise ratio concerns...

Thomas

---

From: Andy Bierman <[email-masked]>
Date: Fri, 7 Jun 2013 08:48:05 -0700

> due to signal to noise ratio concerns...
So why not move the signal?
Put IETF Last Call mail on [email-masked] and leave this list for
everything else.

I don't really want people counting their bytes when they are concerned
about
a technical issue in an I-D.  It may take several exchanges for a
disagreement
to be resolved.  Social pressure to stay out of the top-N report could have
a negative impact on last call debates.

Thomas
Andy

---

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2013 15:52:14 +0000

On Jun 7, 2013, at 11:48 AM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:
So why not move the signal?
Put IETF Last Call mail on [email-masked]<mailto:[email-masked]> and leave this list for everything else.

The discussion still has to happen somewhere.   I certainly am not restricting my meaningful participation in last calls, but even in that case it is important to be restrained and not get into long fruitless discussions, which, I am afraid, I am wont to do.

---

From: Tim Chown <[email-masked]>
Date: Fri, 7 Jun 2013 17:03:02 +0100

On 7 Jun 2013, at 16:52, Ted Lemon <[email-masked]> wrote:

> On Jun 7, 2013, at 11:48 AM, Andy Bierman <[email-masked]> wrote:
>> Put IETF Last Call mail on [email-masked] and leave this list for everything else.
> 

It's a significant problem for those who *have* to read the threads, in particular document authors, WG chairs, and ADs. Hats off to them for keeping up with it where they need to.

As another example, the v6ops list has recently also had four threads run well over the 100 message count, specifically end to end response time, ULA usage, "being careful" about ULAs and the semantic prefix thread. 

Of course, a healthy debate is a good thing, as is having an open process for discussion. If we had very few comments that would certainly not be good either. But I fear that some valuable contributions are either being drowned out, or that some people with valuable input are being put off contributing.

Tim

---

From: David Morris <[email-masked]>
Date: Fri, 7 Jun 2013 09:04:50 -0700 (PDT)

As long as the summary has been brought up ...

I've wondered for some time whether the reported bytes is the
whole message I send included context quotes, or if there is
an attempt by the summary logic to factor out quoted
content.

Dave Morris

---

From: Ted Lemon <[email-masked]>
Date: Fri, 7 Jun 2013 16:11:12 +0000

> an attempt by the summary logic to factor out quoted

A penalty for top-posting sounds okay to me!

---

From: Andy Bierman <[email-masked]>
Date: Fri, 7 Jun 2013 09:11:36 -0700

On Fri, Jun 7, 2013 at 8:52 AM, Ted Lemon <[email-masked]> wrote:

> The discussion still has to happen somewhere.   I certainly am not
> restricting my meaningful participation in last calls, but even in that
> case it is important to be restrained and not get into long fruitless
> discussions, which, I am afraid, I am wont to do.
>
>

Some people consider the last call discussions to be signal
and the rest (vast majority) of discussions to be noise.
They would subscribe to a last-call mailing list, but not this one.

Andy

---

From: joel jaeggli <[email-masked]>
Date: Fri, 07 Jun 2013 18:12:36 +0200

On 6/7/13 6:03 PM, Tim Chown wrote:
> On 7 Jun 2013, at 16:52, Ted Lemon <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>>> Put IETF Last Call mail [email-masked] 
>>> <mailto:[email-masked]>and leave this list for everything else.
>>
>> restricting my meaningful participation in last calls, but even in 
>> that case it is important to be restrained and not get into long 
>> fruitless discussions, which, I am afraid, I am wont to do.
>
> It's a significant problem for those who *have* to read the threads, 
> in particular document authors, WG chairs, and ADs. Hats off to them 
> for keeping up with it where they need to.
>
> As another example, the v6ops list has recently also had four threads 
> run well over the 100 message count, specifically end to end response 
> time, ULA usage, "being careful" about ULAs and the semantic prefix 
> thread.
v6ops had a single draft which attracted ~1100 messages over the course 
of a year so this isn't new or unusual over there. A small number of 
posters tend to be the majority of the volume on several topics, so if 
you're reading to understand the positions of the working group or to 
measure consensus on the list some judicious sorting is required.
> Of course, a healthy debate is a good thing, as is having an open 
> process for discussion. If we had very few comments that would 
> certainly not be good either. But I fear that some valuable 
> contributions are either being drowned out, or that some people with 
> valuable input are being put off contributing.

---

From: Tim Chown <[email-masked]>
Date: Fri, 7 Jun 2013 17:33:35 +0100

On 7 Jun 2013, at 17:12, joel jaeggli <[email-masked]> wrote:

> v6ops had a single draft which attracted ~1100 messages over the course of a year so this isn't new or unusual over there. A small number of posters tend to be the majority of the volume on several topics, so if you're reading to understand the positions of the working group or to measure consensus on the list some judicious sorting is required.

Indeed.  Sorting and sifting through 500+ emails about one homenet topic over on 6man was similarly challenging (for the homenet arch text).  And many of those long v6ops threads were/are relevant to that.

It would be nice to determine some way to keep discussions open, without creating unnecessary volume, and repeating already raised arguments. 

Maybe the answer isn't email for judging consensus. As an outsider, I've seen the IESG/AD system, which seems to essentially allow positions on drafts to be expressed, and easily viewed at a glance. Maybe that's part of the answer, somehow. Some "position" view on a draft, that people can update/edit as the list discussion goes on, that becomes more useful "at a glance" for WG chairs and document editors?

We could continue as is with emails, but I've heard of a number of (very wise and valued) past contributors who no longer express their views, because of the problem of volume.

Or maybe it's not a valid concern.

Tim

---

From: Thomas Narten <[email-masked]>
Date: Fri, 07 Jun 2013 12:51:09 -0400

> an attempt by the summary logic to factor out quoted

Original script is here:
http://www.hactrn.net/hacks/mh-list-traffic/mh-list-traffic

I don't think I've modified it other than to keep it running under my
local setup.

>From my perspective, the intention/usefulness of the weekly posting is
to give folk a high-level view of who is posting and how often. It is
not uncommon to see certain individuals stand out. In some cases, that
makes perfect sense -- and the signal level is high. In other cases,
it shows (IMO) people who are too quick to post and who (too often)
say predictable things if you've read previous threads on the same
general topic. YMMV.

Beyond that (e.g., tweaking the priorities of how rankings are done),
I don't see much point.  Different people will have different opinions
on what to give priority to, and this is ultimately a judgement call.

Thomas

---

From: Michael Richardson <[email-masked]>
Date: Fri, 07 Jun 2013 13:48:01 -0400

>>>>> "Andy" == Andy Bierman <[email-masked]> writes:
    Andy> So why not move the signal?
    Andy> Put IETF Last Call mail on [email-masked] and leave this list for
    Andy> everything else.

Okay, that would work for me.
Where would the reply-to: on those posts be set to?

I also don't think we ever solved the problem of moderation of @ietf.org
lists.  Specifically, I'd like it so that once I'm subscribed to one
@ietf.org list, that I could post to all of them. (Well, I wouldn't
post, I'd be replying in most cases)

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Bob Hinden <[email-masked]>
Date: Fri, 7 Jun 2013 10:57:19 -0700

Thomas,

> say predictable things if you've read previous threads on the same

I agree with your conclusion.  

I also wish that the signal level was higher.  The IETF list is important because we need to have a place where IETF wide issues can be discussed.  That doesn't work if many people unsubscribe due to the the low signal to noise level.  I hope that that people who consistently show up at the top of the posting summary will moderate their behavior.

Bob

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 7 Jun 2013 11:09:33 -0700

I like the idea of a separate list for last calls. It would not solve
the issue of noise for all of us (and not reduce the overall amount of
emails), but it would separate general discussions from IETF LCs. I
have IETF emails filtered by mailing list into different IMAP folders,
and thus a separation could be useful for me.

Ulrich

On Fri, Jun 7, 2013 at 9:11 AM, Andy Bierman <[email-masked]> wrote:
>> restricting my meaningful participation in last calls, but even in that case
>> it is important to be restrained and not get into long fruitless

---

From: Juliao Braga <[email-masked]>
Date: Fri, 07 Jun 2013 15:17:43 -0300

+1

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 08 Jun 2013 07:52:38 +1200

Rule 1 for complex and divergent mail threads is to change the
Subject header when the subject changes. If you don't do that,
your mail is rather likely to get junked.

I think that IETF last call threads should stay on the main IETF
discussion list. That is exactly the right place for them.
It's rather trivial to filter them into a dedicated folder;
I have one called 'lastcallsin', that also picks up most
WG Last Call threads, although those have less standardised
subject headers.

   Brian

---

From: Melinda Shore <[email-masked]>
Date: Fri, 07 Jun 2013 12:00:27 -0800

> discussion list. That is exactly the right place for them.

I tend to think so, as well.  You never know when someone's
going to stumble over something and make a comment that matters.
The cost is that you get jackasses being loud and petty, but frankly
you'd get that on a last call mailing list, anyway, since IETF
last calls have in a few cases been known to function as jackass
magnets.

It seems to me that the real problem isn't last calls, it's
people not understanding that behaving badly has a cost associated
with it, and that cost is that they're alienating people they'd
(apparently) like to work with and demolishing their chances of
getting an editorship or moving into leadership roles.

Melinda

---

From: John C Klensin <[email-masked]>
Date: Fri, 07 Jun 2013 18:58:57 -0400

--On Friday, 07 June, 2013 10:57 -0700 Bob Hinden
<[email-masked]> wrote:

> Thomas,
> 
>> From my perspective, the intention/usefulness of the weekly
>> posting is to give folk a high-level view of who is posting
>> and how often. It is not uncommon to see certain individuals
>> stand out. In some cases, that makes perfect sense -- and the
>...
> I also wish that the signal level was higher.  The IETF list
> is important because we need to have a place where IETF wide
> issues can be discussed.  That doesn't work if many people
> unsubscribe due to the the low signal to noise level.

Agreed so far.

>  I hope
> that that people who consistently show up at the top of the
> posting summary will moderate their behavior.

And it is getting to that conclusion from the above that often
troubles me about the posting summary list rankings.  Assuming a
significant issues shows up on the list, whether in conjunction
with a Last Call or something else.  Posting a comment and then
following up the comments of others with a couple of more
postings constitutes three messages in a week, which is pretty
reasonable.  On the other hand, if there are four such issues in
a single week (it happens) then that same individual gets
"credited" with a dozen messages, which would make the top of
the list in many weeks.  

Because things do often seem to happen in clusters, the summary
list might be improved significantly by adding a four-week
average and rankings based on it.  That would help distinguish
the regular heavy posters from those whose numbers went up
because of a particular issue or set of issues in a given week
or two.

What that still wouldn't help with is distinguishing from a
theoretical very active and diligent IETF participant who
reviews and comments on every document that goes into Last Call
push every other issue discussed on the list and a troll who
comments on every Last Call and on other issues that he, she, or
it might even generate.  To measure that difference, one would
need a measure of the useful and relevant information content of
a message, not just a character/byte count.

best,
   john

---

From: Arturo Servin <[email-masked]>
Date: Fri, 07 Jun 2013 20:02:24 -0300

I have mixed opinions, filters in general work well (some false
positives like these ones that are moved to my "Last Call" filter) but
in general it is ok.

	But I would not oppose to a new list for LC only.

Regards,
as

---

From: Glen Zorn <[email-masked]>
Date: Sat, 08 Jun 2013 13:31:14 +0700

> discussion list. That is exactly the right place for them.

Since I've requested (read "begged" ;-) for such threads to be moved to 
their own list on several occasions, I disagree again.

> WG Last Call threads, although those have less standardised

This would appear to work consistently only as long as 'Rule 1' above is 
not followed.

---

From: <[email-masked]>
Date: Sat, 8 Jun 2013 11:09:19 +0100

I believe that last calls must stay on this ietf list.

Any last-call-only list must be *in addition* to the ietf list, with all announcements crossposted, and anyone sensitive to general discussion can subscribe to that instead.

Last calls need wide exposure.

(I'm acked in at least one RFC as a result of discussion on this list as a result of last call.)

I'd go further and say that if you're contributing to an ietf workgroup, subscribing to ietf and ietf-announce should be mandatory for posting rights in that group. Sure, you can filter the mails to /dev/null, but getting a broad idea of what's going on is a good thing, no? I'm willing to bet that at least half of our design problems have resulted from people doing narrowly-focused work in only one group or area...

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Glen Zorn [[email-masked]]
Sent: 08 June 2013 07:31
To: [email-masked]
Subject: Re: Best list for IETF last calls [was: Weekly posting summary for     [email-masked]]

---

From: Ray Pelletier <[email-masked]>
Date: Sat, 8 Jun 2013 08:58:10 -0400

> due to signal to noise ratio concerns...

This list has 2155 subscribers.

Rough, quick count numbers:
56 sent messages week ending 31 May
58 week ending 24 May
87 week ending 3 May
56 week ending 5 April
82 Week ending 8 March
28 week ending 8 Feb
68 week ending 11 Jan

Average:  62 or 3% on the list

Quick glance looks like same people most of the time sending messages

Would be interesting to just report on Last Call mail.  You might find justification 
there by itself to create a Last-Call list.

Ray

---

From: Ray Pelletier <[email-masked]>
Date: Sat, 8 Jun 2013 09:03:12 -0400

On Jun 8, 2013, at 6:09 AM, <[email-masked]> <[email-masked]> wrote:

> I'd go further and say that if you're contributing to an ietf workgroup, subscribing to ietf and ietf-announce should be mandatory for posting rights in that group.

The ietf list has 2,155 subscribers, Announce, 3,203 with 915 duplicates, for total unique addresses of 4,442.

Ray

> Sure, you can filter the mails to /dev/null, but getting a broad idea of what's going on is a good thing, no? I'm willing to bet that at least half of our design problems have resulted from people doing narrowly-focused work in only one group or area...
> 
> Lloyd Wood

---

From: SM <[email-masked]>
Date: Sat, 08 Jun 2013 11:09:04 -0700

>"credited" with a dozen messages, which would make the top of

I'll reuse some text from IETF 55:

  - Decisions are taken by backroom deals, intimidation and
    mob psychology

  - People unsubscribe in disgust in droves

Many years ago the following criticism was made against another body:

   "The process is stacked in favour of multinationals with expense accounts
    who can afford to talk on the phone for two hours a week and jet to world
    capitals for meetings."

The IESG once said that it prefers that comments on Last Calls be 
sent to the [email-masked] list.  The IESG also said that authors, 
working group Chairs and the responsible Area Director are presumed 
to see all such messages.

Is posting the summary list ranking a form of intimidation?  I don't 
know.  If [email-masked] is a failure as significant issues are not 
showing up on the list (see quoted text above) or if the IESG prefers 
that comments on Last Calls be sent to some other list it can say 
that.  If people unsubscribing in droves is a problem, the IESG could 
recommend having two hour phone calls a week and meetings in world 
capitals for Last Calls.  If the IESG believes that it is more 
practical to take decisions through backroom deals it can use a 
non-public list for handling Last Calls.

If a significant number of people cannot act or conduct themselves in 
a proper way, especially toward others, it is a social problem.  If 
people cannot filter the [email-masked] mailing list, it is a 
technical problem.  The IETF has published a specification which 
describes a language for filtering email messages at time of final 
delivery.  After reading the latest messages to the list I might conclude that:

  (i)   people do not know about the mail filtering language

  (ii)  people are having technical difficulties using email

  (iii) it might rain tomorrow

As an off-topic comment, there are are alternative ways in making a 
decision; the best judgement of the most experienced or IETF Consensus.

Regards,
-sm

---

From: Melinda Shore <[email-masked]>
Date: Sat, 08 Jun 2013 11:55:51 -0800

> decision; the best judgement of the most experienced or IETF Consensus.

I don't think it's off-topic.  Consensus (rough or otherwise) requires
that at some point people can live with decisions with
which they disagree.  To the extent that we've seen recent misbehavior
on this list, it's from only one person who's rejecting the consensus
and rejecting the process.  It's really annoying but I don't think
it's particularly disruptive.  If it becomes disruptive, there's a
rarely-used hammer: the PR action.

Melinda

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 09 Jun 2013 08:20:52 +1200

> rarely-used hammer: the PR action.

I agree. Whatever misbehaviour Melinda means hasn't troubled me;
it must be a user or a thread that I filter to junk.
Disagreement is fine as long as people in the end understand
when they're in the rough and not in the consensus.

There are times when this list annoys me too, but it is far from
a failure IMHO.

   Brian

---

From: Andy Bierman <[email-masked]>
Date: Sat, 8 Jun 2013 18:20:02 -0700

Hi,

I'm not sure how the desire for IETF Last Call discussions
to be on a dedicated and constrained mailing list in any way
implies that this generalized and unconstrained list is somehow a failure.

Filtering by subject line is unreliable.
For example, please provide a filter that will
not have any false positives or negatives over the
past 20,000 emails on this list. Do we have tools that make sure
no human has altered any subject line inappropriately?
Filtering by mailing list address is much easier and more reliable.

Andy

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 09 Jun 2013 13:27:15 +1200

> Filtering by mailing list address is much easier and more reliable.

True, but it's a much coarser implement. Indeed, I mainly filter
to 'junk' rather than 'trash' so that once in a while I can
check for false positives. False negatives aren't that big a
problem in practice; the delete key works quickly.

   Brian

---

From: Randy Bush <[email-masked]>
Date: Sun, 09 Jun 2013 12:42:18 +0200

> I'm not sure how the desire for IETF Last Call discussions to be on a
> dedicated and constrained mailing list

many years ago, a housing development thought they had a bad crime rate.
so they built a fence around it and only let residents in.  the crime
rate stayed the same.  funny thing.

procmail is your friend.

randy

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Sun, 09 Jun 2013 17:45:17 -0300

As long the subject clearly identifies a last call request thread, I
don't see why the LC's cannot stay here.

There are already too many mailing lists in the world.

My humble opinion.

~Carlos