Subject: Re: The Nominating Committee Process: Eligibility

From: [email-masked] (Noel Chiappa)
Date: Thu, 27 Jun 2013 09:34:47 -0400 (EDT)

> From: John Curran <[email-masked]>

    > the proposed language also increases the possibility of "capture" (i.e.
    > the ability of an single organization to inappropriately skew the
    > outcome of the process) 

Why not just say directly that 'to prevent "capture", no more than X% of
the NomCom may work for a single organization' (where X is 15% or so, so
that even if a couple collude, they still can't get control).

	Noel

---

From: Eliot Lear <[email-masked]>
Date: Thu, 27 Jun 2013 15:42:28 +0200

> that even if a couple collude, they still can't get control).

It's already in RFC 3777.  No more than 2 per company.

---

From: David Meyer <[email-masked]>
Date: Thu, 27 Jun 2013 06:51:10 -0700

> It's already in RFC 3777.  No more than 2 per company.

BTW, while I understand the spirit of 3777 on this point, I have
always found the restriction somewhat at odds with our belief (hope?)
that we represent ourselves and the best interest of the Internet at
the IETF. In addition, a central ethic (IMO anyway) of the IETF has
always been to honor individualism and independence, so I find it a
bit strange that in the NomCom context we're all just corporate (or
otherwise) drones. All of that said, evidently reality doesn't always
match our ideals, hence clauses like the one you cite from 3777. --dmm

---

From: John Curran <[email-masked]>
Date: Thu, 27 Jun 2013 10:12:20 -0400

> that even if a couple collude, they still can't get control).

There are already controls for that, but folks who engage in games such as
this generally make use of consultants/proxies/etc. which are not at all
apparent.  I'm not citing this as a huge risk, but one which could occur
if the in-person requirement drops to a single meeting. (i.e. due to the 
large pool of remote participants that one could enlist and fund a single
on-site attendance if the goal was to seat an particular IAB or IESG member.)

FYI,
/John

Disclaimers: My views alone (& not part of any group seeking NomCom capture... :-)

---

From: Michael StJohns <[email-masked]>
Date: Thu, 27 Jun 2013 11:07:35 -0400

>It's already in RFC 3777.  No more than 2 per company.

But that's still problematic.  The current rules basically give any company who provides >= 30% of the Nomcom volunteer pool an ~85.1% chance of having 2 members (sum of all percentages from 2-10 members), a 12.1% chance of having 1 and a 2.8% chance of having 0.  

I believe the proposal as stated would further exacerbate that problem - not for a given company, but for pretty much locking small companies and individuals out of the Nomcom.  Once scenario for this - both benign intentions and non-benign - is that a company instead of sending one person to all the meetings starts rotating the opportunity to attend the IETF among a number of people - say 5.  So instead of the potential of say 30 volunteers from one company, we now suddenly have 150.  And me with my single person consultancy - still only has 1 slot to volunteer.

While it would be good to have more people involved, it would be bad in the ways in which larger companies could game the system.

So - I'm not a big fan of the proposal without a lot more analysis of the unintended consequences - and there WILL be unintended consequences.

Mike

---

From: Scott Brim <[email-masked]>
Date: Thu, 27 Jun 2013 11:13:19 -0400

On Thu, Jun 27, 2013 at 11:07 AM, Michael StJohns <[email-masked]> wrote:
> Once scenario for this - both benign intentions and non-benign - is that a company instead of sending one person to all the meetings starts rotating the opportunity to attend the IETF among a number of people - say 5.

Some already do.

---

From: Michael StJohns <[email-masked]>
Date: Thu, 27 Jun 2013 11:30:14 -0400

>> Once scenario for this - both benign intentions and non-benign - is that a company instead of sending one person to all the meetings starts rotating the opportunity to attend the IETF among a numb…

But those 5 are not Nomcom eligible at this time.  (And that was the "benign" intention I mentioned before...)

Mike

---

From: Michael StJohns <[email-masked]>
Date: Thu, 27 Jun 2013 11:38:57 -0400

At 09:51 AM 6/27/2013, David Meyer wrote:
>the IETF. 

This is where acculturation comes in.  You and I are old hands - we've been doing this almost too long to remember.  This is built into our personal perception of the IETF.  Sadly - I think this attitude has become less and less prevalent, both in the newer companies that have sent people and in the newer people.  Part of this appears to be a belief that the IETF is exactly like all the other standards bodies and can be managed/manipulated by throwing people at it.   Given the current buy-in for the nomcom is about $6K per year per person (based on about a $4K per person direct cost - I don't know how to reasonably estimate the indirect costs of lost production because of travel if any), that provides at least a small barrier to entry to that type of manipulation, as does the acculturation that actually happens if they attend 3/5 meetings.

I really wish the IETF were a group of individuals, but I don't think that's ever been completely true, and I have then impression its getting to the point where its not even mostly true.

Mike

>In addition, a central ethic (IMO anyway) of the IETF has

---

From: David Meyer <[email-masked]>
Date: Thu, 27 Jun 2013 08:44:19 -0700

> I really wish the IETF were a group of individuals, but I don't think that's ever been completely true, and I have then impression its getting to the point where its not even mostly true.

Agree with all of your points Mike. --dmm

---

From: John C Klensin <[email-masked]>
Date: Thu, 27 Jun 2013 13:23:17 -0400

--On Thursday, June 27, 2013 11:07 -0400 Michael StJohns
<[email-masked]> wrote:

>...
> But that's still problematic.  The current rules basically
> give any company who provides >= 30% of the Nomcom volunteer
> pool an ~85.1% chance of having 2 members (sum of all
> percentages from 2-10 members), a 12.1% chance of having 1 and
> a 2.8% chance of having 0.  

And, of course, a few related companies or one with subsidiaries
that it claims are independent and a desire to game the system
can easily do so today to produce a highly-likely larger number
of members, perhaps even a majority.   We are clearly vunerable
in that area but, perhaps inevitably, have gone down multiple
ratholes as soon as we try to tighten the specifically
anti-capture rules further.  In particular, trying to
second-guess a company's assertions about what entities are
independent of it is just fraught with problems even thought
such assertions can be used to subvert any, or almost any, "no
more than X from one company/interest" rule.

> I believe the proposal as stated would further exacerbate that
> problem - not for a given company, but for pretty much locking
> small companies and individuals out of the Nomcom.  Once
> scenario for this - both benign intentions and non-benign - is
> that a company instead of sending one person to all the
> meetings starts rotating the opportunity to attend the IETF
> among a number of people - say 5.  So instead of the potential
> of say 30 volunteers from one company, we now suddenly have
> 150.  And me with my single person consultancy - still only
> has 1 slot to volunteer.

Yes, but...

(i) Some reasonable set of "demonstrate clue" provisions, if
adopted along with the "demonstrate participation" ones, would
tend to counter that, and might even reduce the available 30 (or
whatever number one picks).

(ii) A notion of "some remote participation is ok if you can
demonstrate clue/ groking the IETF in some other way" actually
helps to protect your ability to volunteer if you suddenly
missed a few consecutive meetings and that of other one-person
consultancies (including, in the interest of full disclosure,
me) and academics like Brian) who have discovered that, as
in-person attendance rises, they need to be selective about face
to face attendance.  If one (and, equivalently, one's one-person
consultancy) can't volunteer, the likelihood of being selected
are zero (and really easy to calculate).

(iii) Unless all of those 150 people were actually participating
actively and contributing to IETF work, the company's actual
ability to influence the standards process would go down.  

> While it would be good to have more people involved, it would
> be bad in the ways in which larger companies could game the
> system.

While I agree, I think it would be really unfortunate if we
discarded opportunities to get a broader spectrum of people
involved because of fears that come company or companies might
misbehave.  I think at least two things work in our favor in the
latter regard.  We can try to educate participants and their
organizations about how little marginal commercial advantage
they would gain by, e.g., getting an extra person on the IETF
and be sure that our other procedures and safeguards reinforce
that.  For example, the reputational harm a company, to say
nothing of the individuals involved, would suffer from a few
recalls based on collusion in support of company positions would
far exceed any possible advantages from having more people in
leadership positions.   I think there is also evidence of courts
and competitiveness/ antitrust authorities being _very_
unsympathetic to organizations who try to subvert open standards
processes.  They, of course, also have the resources and
authority to untangle relationships that we do not.

best,
   john

---

From: Arturo Servin <[email-masked]>
Date: Thu, 27 Jun 2013 18:24:06 +0100

Yes, but instead of 150 volunteers from other organizations we could
have 500. So the probabilities are back to the same.

/as

---

From: Scott Brim <[email-masked]>
Date: Thu, 27 Jun 2013 13:50:11 -0400

These days I don't contribute much to the IETF, so I hesitate to say
much, but I care about it a lot and may contribute again someday.
IMHO ...

Once I lived in Japan for a year and got to think I understood
Japanese culture, but finally realized I had hardly scratched the
surface.  Once, in Germany, I thought Germans were a lot like
Americans, but finally realized I had no idea how different they were.
 And so on.  Likewise, people may think they understand how the IETF
"works", and deduce from that what IETF culture means, when they have
just begun to grasp it.

The IETF mission is already vulnerable.  Most of the time we can hold
the culture together, although it takes a lot of work as unanimity has
already begun falling apart.  If we want to change the mission and
culture, that's okay but we should do so consciously and explicitly.
The NomCom is pivotal for the IETF being able to do its work, to
fulfill its mission, in the future.  People who "know" how the IETF
works but do not have enough experience in the culture will not know
how to express it well, in difficult and subtle situations.  I'm not
talking about knowledge of information, I'm talking about mastery of a
trade -- something that comes with a lot of experience practicing it.

Because of that, weakening requirements for NomCom participation
greatly increases the probability that our culture will fracture, and
our mission statement lose meaning, before we have a chance to agree
on what they should become.  I supported the proposal to require a few
old-timers on every NomCom a few years ago.  I'm quite against the
idea of lowering requirements now.  I would only entrust the future of
the IETF to those who have enough experience and hard-earned wisdom to
make the difficult decisions that are required.  Those who participate
in the process but are not really deep in the culture are already
well-represented through the vehicles for contributing to the NomCom
process.

Scott

---

From: Michael Richardson <[email-masked]>
Date: Thu, 27 Jun 2013 14:46:51 -0400

> well-represented through the vehicles for contributing to the NomCom

Just as long as you understand that you are influencing the diversity of the nomcom itself.

The people involved will be older, work for bigger companies, and have a
tendancy to be white, north american, male, and not have small
children (or rather, not have made the choice to stay home with child).

Since people tend to pick people who look like them, that means that nomcom
will pick people who are less diverse.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Scott Brim <[email-masked]>
Date: Thu, 27 Jun 2013 15:17:17 -0400

> Just as long as you understand that you are influencing the diversity of the nomcom itself.

Yes, we need to cultivate more talent and more viewpoints while
simultaneously using hard-earned wisdom and encouraging growth of that
wisdom in the less experienced.  I'm looking for the proposal from a
few years ago for a balance like that in the NomCom, but haven't found
it yet.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 27 Jun 2013 20:38:30 +0100

> children (or rather, not have made the choice to stay home with child).

I can support what Scott says if (and only if) we divide up the composition of
NomCom.  Taken to its extreme, what Scott says might return a NomCom made up
only of people over 65 who have previously served on the IAB/IESG.

But the same applies to SM's draft. Taken to its extreme, SM's draft might
return a NomCom made up only of people who have absolutely no idea how the IETF
functions today, and (more importantly) why.

I think you can rely on each person actually on NomCom to speak their mind and
deliver from their experience (and we can rely on the NomCom chair to tease that
out). So surely we can say something like:
2 old-timers chosen randomly from a list of old-timers
4 people who have been around the IETF a lot (e.g. 3 out of last 5 meetings)
3 people who have worked in the IETF quite a bit (e.g.  front page of > 2 RFCs)
3 people who have evidence of participation in technical work on mailing lists.
Each person is only allowed to be placed in one pool before selection.

I would like to see SM reconsider his Section 2 along these lines (although not
with these precise definitions).

Adrian

---

From: S Moonesamy <[email-masked]>
Date: Thu, 27 Jun 2013 16:38:25 -0700

>Each person is only allowed to be placed in one pool before selection.

I'll comment on the above.  I have seen the request about 
reconsidering Section 2 of the draft and I am not ignoring it.

Someone would have to create a list of old-timers.

I think I understand what you mean by "around the IETF a lot".  I'll 
skip that for now.

The front page of more than two RFCs can create an incentive to:

  (a) generate more RFCs

  (b) add more names to the author list

There are a few ideas (including the above quoted text) which could 
be combined to figure out one or more workable alternatives.

Regards,
S. Moonesamy

---

From: Scott Brim <[email-masked]>
Date: Thu, 27 Jun 2013 21:15:34 -0400

On Thursday, June 27, 2013, Scott Brim wrote:

> On Thu, Jun 27, 2013 at 2:46 PM, Michael Richardson <[email-masked]<javascript:;>>
> wrote:

Here it is: http://tools.ietf.org/id/draft-crocker-nomcom-process-00.txt

I was particularly thinking of section 3, but reading it all might be worth
your while.

Yes we need to cultivate new leadership but that must not override the more
important need for experience and wisdom in the vital functions of the
IETF.  Finding that balance is not a new concern, anywhere in the IETF --
25 years ago I was told that the best working groups have "six young turks
and six old farts".

John Klensin pointed out that there are other problems with the current
NomCom selection rules.  True.  I'm not defending the current rules, just
the principle of what the NomCom should be able to represent.  I have no
issues with changes to the NomCom process as long as they make the NomCom
better at what it is supposed to do.

Cheers ... Scott