Subject: Re: Last Call: <draft-jabley-dnsext-eui48-eui64-rrtypes-03.txt> (Resource Records for EUI-48 and EUI-64 Addresses in the DNS) to Proposed Standard

From: joel jaeggli <[email-masked]>
Date: Thu, 13 Jun 2013 17:39:32 +0200

I am told that draft has been revved again in response to discussion on 
the list.

http://www.ietf.org/rfcdiff?url2=draft-jabley-dnsext-eui48-eui64-rrtypes-05

Please direct your attention to the security considerations section. If 
it turns out that informational documentation of the two RR-Type 
assignments remains controversial, I will likely withdraw my sponsorship 
of this draft.

Thanks
joel

On 5/27/13 5:40 PM, joel jaeggli wrote:
> On 5/20/13 6:44 AM, The IESG wrote:
>> The IESG has received a request from an individual submitter to consider
>> the following document:
>> - 'Resource Records for EUI-48 and EUI-64 Addresses in the DNS'
>>    <draft-jabley-dnsext-eui48-eui64-rrtypes-03.txt> as Proposed Standard
>
> I would direct the attention of the commentors to draft 04
>
> http://www.ietf.org/internet-drafts/draft-jabley-dnsext-eui48-eui64-rrtypes-04.txt 
>
>
> Which addresses concerns expressed in IETF last call over the intended 
> status.
>
> It also incorporates edits proposed by John Klensin in his review.
>
> Notes: from the author:
>
>  - changed intended status to informational
>
>  - incorporation of John's suggestions in the Terminology section, to 
> indicate that we're using 2119 keywords even though this is not a 
> standards track document
>
>  - added a couple of sentences to the security considerations sections 
> to underscore the fact that this document specifies optional 
> mechanisms that people might well not use if privacy considerations 
> dictate otherwise
>
>>
>> The IESG plans to make a decision in the next few weeks, and solicits
>> final comments on this action. Please send substantive comments to the
>> [email-masked] mailing lists by 2013-06-17. Exceptionally, comments 
>> may be
>> sent to [email-masked] instead. In either case, please retain the
>> beginning of the Subject line to allow automated sorting.
>>
>> Abstract
>>
>>
>>     48-bit Extended Unique Identifiers (EUI-48) and 64-bit Extended
>>     Unique Identifiers (EUI-64) are address formats specified by the 
>> IEEE
>>     for use in various layer-2 networks, e.g. ethernet.
>>
>>     This document defines two new DNS resource record types, EUI48 and
>>     EUI64, for encoding ethernet addresses in the DNS.
>>
>
>
>>
>> The file can be obtained via
>> http://datatracker.ietf.org/doc/draft-jabley-dnsext-eui48-eui64-rrtypes/
>>
>> IESG discussion can be tracked via
>> http://datatracker.ietf.org/doc/draft-jabley-dnsext-eui48-eui64-rrtypes/ballot/ 
>>
>>
>>
>> No IPR declarations have been submitted directly on this I-D.
>>
>>
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 13 Jun 2013 17:55:22 +0200

> assignments remains controversial, I will likely withdraw my sponsorship 

the addition of 

    This document recommends that EUI-48 or EUI-64 addresses SHOULD NOT
    be published in the public DNS.

alleviates my worst fears.  though i wish it was a MUST NOT, i will not
insist.

thanks joe and joel.

randy

---

From: joel jaeggli <[email-masked]>
Date: Wed, 19 Jun 2013 06:29:25 -0700

Given that this document was revved twice and had it's requested status 
change during IETF last call in response to discussion criticism and new 
contribution I am going to rerun the last call.

Thanks
joel

On 5/20/13 6:44 AM, The IESG wrote:
> [email-masked] mailing lists by 2013-06-17. Exceptionally, comments may be
>     Unique Identifiers (EUI-64) are address formats specified by the IEEE

---

From: Randy Bush <[email-masked]>
Date: Thu, 20 Jun 2013 05:45:33 +0900

> contribution I am going to rerun the last call.

the recent changes resolved my issue.  thanks joe and joel.

randy

---

From: Mark Andrews <[email-masked]>
Date: Thu, 20 Jun 2013 08:44:43 +1000

> the recent changes resolved my issue.  thanks joe and joel.

I have read -05 and in my opinion it is good to go.o

Mark
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Olafur Gudmundsson <[email-masked]>
Date: Thu, 20 Jun 2013 09:39:20 -0400

On Jun 19, 2013, at 9:29 AM, joel jaeggli <[email-masked]> wrote:

> Given that this document was revved twice and had it's requested status change during IETF last call in response to discussion criticism and new contribution I am going to rerun the last call.

I reviewed this version and I think this is a fine document that I support. 
In particular the document goes out of its way to address the issues raised in prior 
IETF last call to the extent possible. 
The document is going to be the specification of two DNS RRtypes that have been allocated via expert review, we (DNS community) want to encore
that any such allocations be published as RFC's for future references. 

This document is not a product of any working group.

	Olafur (DNSEXT co-chair)

---

From: John C Klensin <[email-masked]>
Date: Thu, 20 Jun 2013 11:17:16 -0400

Olafur,

Based on reviewing the current draft and the handling of my
objections and other of others to the prior ones, I agree that
the document is ready for publication.  

However, I feel a need to comment on one of your observations
below because it seems to lie at the core of why this particular
document took up so much IETF list time and correspondence.
Most of that could have been avoided, IMO, and I think there is
something to be learned from it to which I hope you, the DNSEXT
WG, and Ted (as responsible AD) will pay attention.

--On Thursday, June 20, 2013 09:39 -0400 Olafur Gudmundsson
<[email-masked]> wrote:

> The document is going to be the specification of two DNS
> RRtypes that have been allocated via expert review, we (DNS
> community) want to encore that any such allocations be
> published as RFC's for future references. 

The IETF has historically had strong opinions about change
control, consensus, and the nature of recommendations.
Personally, I hope those opinions will continue and, if
anything, get stronger.

It seems to me that it is reasonable to say "we want a
lightweight registration procedure that imposes few if any
requirements on allocating an RR TYPE" or you can say "want to
ensure RFC publication" but that you don't get to say both at
once, especially when Standards Track or the IETF Stream are
involved.  If you (and DNSECT) want the very lightweight
registration procedure, then you should reasonably expect to
make sure that any documents are clearly informational (in
content and category) and to take your chances about
publication: Informational in either the IETF Stream or the
Independent Submission Stream could result in a "no" answer or,
more likely, requirements to justify the design decisions behind
the RRTYPEs as a condition of publication.  You can't "ensure"
anything because the relevant groups really do get to evaluate
both document quality and appropriateness for use.

By contrast, if the WG really does "want to ensure..." then it
would be appropriate to change the registration procedure so
that the I-Ds are posted and RFC publication is agreed to before
the RRTYPEs are registered so everyone can be sure that the two
match.    That could be coupled with some sort of provisional
arrangement while document review is in progress, if the WG
thought that was necessary.   Howver the bottom line, IMO, is
that, if you want RFCs and want those RFCs to accurately
describe an RRTYPE and there is going to be open review during
the RFC development process, you can't have lightweight
registration and then insist that an RFC be published to
match... at least IMO and, if the discussions of the recent Last
Calls are indicative, a significant part of the the community
may share that view.

So some review of the DNSEXT-specified procedures and
expectations may be in order.

regards,
   john

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 20 Jun 2013 12:36:12 -0400

> expectations may be in order.

I encourage you, then, to organize the BOF session that will spin up
the WG to achieve this.  DNSEXT is only still alive because our last
document hasn't been published.

But more generally, as a practical matter it is better that people
register their stuff with us than that they don't.  We have, in the
wild, a used EDNS0 option code that is all over the Internet.  It is
undocumented, and the code point isn't actually registered.  That
state of affairs is surely worse than that the IETF didn't get to
provide good advice to authors.  DNSEXT already tried to be the DNS
cops, and has failed miserably, partly because of the usual
get-off-my-lawn crowd and partly because people unfamiliar with the
IETF find its procedures a little arcane.

My view is that we need to be more pragmatic.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Doug Barton <[email-masked]>
Date: Thu, 20 Jun 2013 10:04:54 -0700

> My view is that we need to be more pragmatic.

I agree with at least a little of what each of Olafur, John, and Andrew 
have said; but I think there's a middle ground between "throw the doors 
wide open" and "everything we have tried before didn't work." At least I 
hope there is.

Perhaps we could have a non-WG mailing list so that people could submit 
proposals for review prior to the expert review process. Even some of 
the "get off my lawn" crowd offered good suggestions for this EUI case 
(make 1 record with a size field rather than 2 records) that could have 
made this whole process a lot smoother.

Doug

---

From: Ted Lemon <[email-masked]>
Date: Thu, 20 Jun 2013 17:10:20 +0000

On Jun 20, 2013, at 1:04 PM, Doug Barton <[email-masked]> wrote:
> Perhaps we could have a non-WG mailing list so that people could submit proposals for review prior to the expert review process. Even some of the "get off my lawn" crowd offered good suggestions for this EUI case (make 1 record with a size field rather than 2 records) that could have made this whole process a lot smoother.

You mean like "namedroppers"?

---

From: joel jaeggli <[email-masked]>
Date: Thu, 20 Jun 2013 10:14:10 -0700

On 6/20/13 10:04 AM, Doug Barton wrote:
>
> I agree with at least a little of what each of Olafur, John, and 
> Andrew have said; but I think there's a middle ground between "throw 
> the doors wide open" and "everything we have tried before didn't 
> work." At least I hope there is.
>
Well recall that we still have DNSOP, which along with the dnsext 
mailing list once the wg is closed is probably a reasonable place to 
get/look for feedback.
> Perhaps we could have a non-WG mailing list so that people could 
> submit proposals for review prior to the expert review process. Even 
> some of the "get off my lawn" crowd offered good suggestions for this 
> EUI case (make 1 record with a size field rather than 2 records) that 
> could have made this whole process a lot smoother.
My impression of the outcome of the procedure change for the registry is 
the wg didn't feel that there should be any particular obstacle  beyond 
expert review for registration. It is possible that reasonable people 
should disagree on the application of given rr-types and that they 
should be registered anyway.

In 30 years we've allocated ~120 rrtypes most of which we don't use   
anymore.

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 20 Jun 2013 13:27:05 -0400

On Thu, Jun 20, 2013 at 10:04:54AM -0700, Doug Barton wrote:

> submit proposals for review prior to the expert review process.

The WG list isn't going away with the WG.  The list is explicitly
called out as a good place to try out proposals, so people can in fact
do that today.

Best,

A
-- 
Andrew Sullivan
[email-masked]

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 20 Jun 2013 13:28:16 -0400

> You mean like "namedroppers"?

If only we still had that list.  Alas, it was the victim of politics.
Perhaps Randy Bush will bring it back to life.

A

-- 
Andrew Sullivan
[email-masked]

---

From: Doug Barton <[email-masked]>
Date: Thu, 20 Jun 2013 10:44:23 -0700

> called out as a good place to try out proposals, so people can in fact

I would argue that a fresh start here might be appropriate, although I 
wouldn't argue it strongly, and wouldn't object to using dnsext@ if that 
was the consensus.

---

From: Randy Bush <[email-masked]>
Date: Fri, 21 Jun 2013 04:54:15 +0900

> If only we still had that list.

any reports of its death are from questionable sources

> it was the victim of politics.

like much of life

randy

---

From: John C Klensin <[email-masked]>
Date: Thu, 20 Jun 2013 21:48:31 -0400

--On Thursday, June 20, 2013 12:36 -0400 Andrew Sullivan
<[email-masked]> wrote:

>...
> But more generally, as a practical matter it is better that
> people register their stuff with us than that they don't.  We
> have, in the wild, a used EDNS0 option code that is all over
> the Internet.  It is undocumented, and the code point isn't
> actually registered.  That state of affairs is surely worse
> than that the IETF didn't get to provide good advice to
> authors.  DNSEXT already tried to be the DNS cops, and has
> failed miserably, partly because of the usual get-off-my-lawn
> crowd and partly because people unfamiliar with the IETF find
> its procedures a little arcane.
> 

Andrew,

Just to be clear, I completely agree.  I thought that should
have been clear from the context of my note (context that you
omitted above).  I think that what I have referred to as the
lightweight registration procedure is just fine.  What I have
objected to since the first time a Last Call on the present
document was initiated is any assertion that, because something
is registered, it is entitled to be documented in the RFC
Series.   I object even more strongly to any implication that
such a registered RRTYPE should be accepted as a Standards Track
document without any further review because it is registered
already.

I thought that issue had been settled for this document by
reclassifying its intended status to Informational and
clarifying the relationship of the RRTYPEs to other
consideration, particularly privacy ones.  IMO, that
clarification along makes it worth publishing as an RFC, but the
notion of entitlement was, I thought, put to rest.

Consequently, I was mildly astonished when Olafur's comment
(which included the information that he is co-chair of DNSEXT)
included "...we (DNS community) want to encore [sic] that any
such allocations be published as RFC's for future references".  

So, once again and in short sentences:

(1) The present registration procedure does nothing to ensure
any such thing.

(2) There is nothing else in either IETF or RFC Editor
procedures that ensures RFC publication.  If a document
describing an already-registered RRTYPE is submitted and some AD
wants to sponsor it for publication as an individual submission
and puts it into a Last Call on that basis, the community may
pick at it, insist on changes, or even reach consensus that it
should not be published.

(3) I think the above is fine.  If someone (else) thinks that
RFC publication should be "ensured" for any RRTYPE allocation,
then they need to persuade whomever needs to be persuaded to
modify the registration procedure.   I would, personally, oppose
that change if it eliminated the possibility of quick,
lightweight, registrations but my opinion probably doesn't count
for much relative to the "DNS community" for which Olafur and/or
you are speaking.

best,
    john