Subject: Berlin BoFzilla

From: Tim Chown <[email-masked]>
Date: Wed, 19 Jun 2013 13:34:14 +0100

So I was looking at http://trac.tools.ietf.org/bof/trac/wiki/WikiStart to check the sdnssd BoF text, and was surprised to see a total of 15 proposed BoFs. That seems to be something of a record?

That people are coming to the IETF with proposals to do work is probably a healthy thing; it would be more worrying if there were no BoFs proposed. But if all the proposals are accepted, and they all lead to WGs being formed, that's a lot of new groups to be created, scheduled and supported.

In contrast, how many WGs have been closed in the past few months? I see there's http://trac.tools.ietf.org/wg/concluded from which I can see there are 10 WGs listed there which seem to have closed this year:
	iri 2013-01-19
	imapmove 2013-01-31
	csi 2013-02-12
	sipclf 2013-02-20
	bliss 2013-02-27
	simple 2013-02-27
	fecframe 2013-03-06
	krb-wg 2013-03-19
	eai 2013-03-19
	6tch 2013-04-19

I wonder how the volume and lifetimes of WGs has changed over the years, e.g. the number we have, how quickly they complete their work, etc. Has anyone been looking at this?

Tim

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 19 Jun 2013 14:49:43 +0200

Well, one of the BOFs is for 6Lo, which is meant to replace a WG (6LoWPAN) that is closing.

So make that 14 potential new WGs, but it is still a large number indeed.

(Actually, not all BOF descriptions are entirely explicit about the desire to have a new WG as an outcome...)

Grüße, Carsten

---

From: Jari Arkko <[email-masked]>
Date: Wed, 19 Jun 2013 16:05:47 +0300

Tim,

> was surprised to see a total of 15 proposed BoFs

That is a relatively big number. There is a very high attrition rate, however.

> 
> That people are coming to the IETF with proposals to do work is probably a healthy thing; it would be more worrying if there were no BoFs proposed.

Indeed! More is better.

> But if all the proposals are accepted, and they all lead to WGs being formed, that's a lot of new groups to be created, scheduled and supported.

The crux is getting good enough proposals that they actually deserve a BoF slot and eventually lead to a working group. As noted, many proposals do not even make the first cut.

> I wonder how the volume and lifetimes of WGs has changed over the years, e.g. the number we have, how quickly they complete their work, etc. Has anyone been looking at this?

We don't have a very good picture of that. My perception is that many of our working groups generally live quite long. That's fine when they are chartered to, e.g., maintain an important spec. But for new feature work, a faster turnaround rate might be preferable. Come in, do the work, close the working group, create a new working group for the next thing, etc. But for a good picture of the WG lifetimes, one would also have to look at rechartering.

I also think that the number of working groups at the IETF has been relatively stable over the years. There are also obvious limiting factors, like the number of slots in our meetings, for working groups that meet.

Jari