Subject: Forwarding AODV messages over a tunnel

From: "Thomas Meier" <[email-masked]>
Date: Wed, 5 Jun 2013 13:39:52 +0200 (CEST)

Hello,
 
I want to forward AODV messages over a tunnel (don't worry, it's not for a wormhole attack).
In the RFC3561 I can't find information about how to deal with the packet at the tunnel endpoint. Should I increment the hopcount of a RREQ by one or by the number of hops the tunnel has? Furthermore I'm wondering about which address to use for the previous node at the tunnel endpoint. Should this be the entrance of the tunnel or the "real" previous node?
If the tunnel entrance is used as previous node and the hopcount is only incremented by one, the tunnel would be prefered compared to a connection without a tunnel (like in wormhole attacks).
Is there some information on how to deal with a tunnel?
 
Thanks,
 
Thomas

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 6 Jun 2013 03:28:49 +0200

> I want to forward AODV messages over a tunnel (don't worry, it's not for a

its ok, but if it was my AODV network I will be worried. Tunneling is
not understood only if I know what network are you tunneling through!!

> In the RFC3561 I can't find information about how to deal with the packet at
> the tunnel endpoint.

IMHO, normal ways of packet tunnel

> Should I increment the hopcount of a RREQ by one or by
> the number of hops the tunnel has?

RREQ is not a packet, your question was on packets, that increment of
RREQ is done by AODV node received. So I think only once, because one
tunnel and between two aodv-nodes only.

> Furthermore I'm wondering about which
> address to use for the previous node at the tunnel endpoint. Should this be
> the entrance of the tunnel or the "real" previous node?

nothing is real when you are tunneling, so use the node address of
tunnel start. Overall I think the routing performance will not be good
only if the network elements of the tunnel is not mobile.

> If the tunnel entrance is used as previous node and the hopcount is only
> incremented by one, the tunnel would be prefered compared to a connection
> without a tunnel (like in wormhole attacks).

Not correct, you don't say your reason, so I don't know how to respond.

> Is there some information on how to deal with a tunnel?
In MANET documents I don't think there is importance of using
tunneling, I think it is not prefered. If used it will be an attack so
I am worried about what are you doing  :-)

AB