Subject: Re: stability of iana.org URLs

From: Amanda Baber <[email-masked]>
Date: Thu, 1 Aug 2013 01:10:06 -0700

Hi,

The link in RFC3315 is actually incorrect -- it should have been http://www.iana.org/assignments/enterprise-numbers, without the file extension, and there's an erratum about this. HTML was generally (if not exclusively) reserved for files that needed to include links to registration forms .

As Barry said, we do intend to keep that same short http://www.iana.org/assignments/example format working for every current page, even the newly-created ones. We also prefer to see that format used in documents, since we can't guarantee that the file extension used for the long version won't change. (This information will be appearing on the website in some form.)

Also, if you find that a formerly-valid URL (like one that used to have an .html exception) isn't redirecting to the current page, please report it to [email-masked]<mailto:[email-masked]>. A redirect should have been set up.

thanks,

Amanda Baber
IANA Request Specialist
ICANN

On Wed Jul 31 14:06:28 2013, [email-masked] wrote:
> > I just followed http://www.iana.org/assignments/enterprise-numbers.html
> > From RFC3315 (DHCPv6)'s reference section.  Ten years later, the URL
> > doesn't work.
> >
> > I know that things were reworked when we went to XML based storage, but
> > I thought that the old URLs would at least have a 301 error on them.
> >
> > I discovered that dropping the .html gets me the right data at:
> >   http://www.iana.org/assignments/enterprise-numbers
>
> Yes: that's the form that IANA would like you to use.  They changed
> their registries from HTML to XML, and the URLs changed.  Supposed
> they should decide to turn them all into JSON (aieeeeeeeee!)... the
> URLs would change again.  But the suffix-less version will always
> work.
>
> When I've done AD reviews of documents that cite IANA URLs, I've given
> the authors that feedback, and suggested the change to the suffix-less
> URLs.  I also intend to suggest to IANA (thanks to a document author,
> and I've since forgotten who it was; sorry) that they post permalinks
> in all the registries, so people will know which URL they ought to
> use, and not have to guess.
>
> Barry, Applications AD
>

---

From: [email-masked]
Date: Thu, 01 Aug 2013 10:26:24 -0700 (PDT)

> Also, if you find that a formerly-valid URL (like one that used to have an .html exception) isn't redirecting to the current page, please report it to [email-masked]<mailto:[email-masked]>. A redir…

Excellent, thanks.

				Ned

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 2 Aug 2013 11:12:22 +0000

Hi, Amanda,

In my experience, at some point, IANA was instructing authors to replace registry URLs (i.e., URLs to specific registries) with a generic pointer to http://www.iana.org instead. This had been based on text from RFC 5226, namely [1] and [2].

Before that there were URLs identifying the registry; and more recently as well, the guidance has been to include the suffex-less specific URL pointing to a registry, which is great.

If IANA guarantees that stability, URLs pointing to the specific registry are very useful IMHO.

Thanks,

-- Carlos.

[1] http://tools.ietf.org/html/rfc5226#section-4.2
4.2.  What to Put in Documents That Create a Registry
...
         that it is a part of should be clearly identified.  When
         referring to an already existing registry, providing a URL to
         precisely identify the registry is helpful.  All such URLs,
         however, will be removed from the RFC prior to final
         publication.  For example, documents could contain: [TO BE
         REMOVED: This registration should take place at the following
         location:  http://www.iana.org/assignments/foobar-registry]

[2] http://tools.ietf.org/html/rfc5226#section-5.1
5.1.  What to Put in Documents When Registering Values
        Note 2: When referring to an existing registry, providing a URL
        to precisely identify the registry is helpful.  Such URLs,
        however, should usually be removed from the RFC prior to final
        publication, since IANA URLs are not guaranteed to be stable in
        the future.  In cases where it is important to include a URL in
        the document, IANA should concur on its inclusion.

On Aug 1, 2013, at 10:10 AM, Amanda Baber <[email-masked]> wrote:

> Also, if you find that a formerly-valid URL (like one that used to have an .html exception) isn't redirecting to the current page, please report it to [email-masked]. A redirect should have been set up. 
> thanks,
> Amanda Baber
> IANA Request Specialist
> ICANN 
>