Subject: re: Last Call: <draft-bormann-cbor-04.txt> (Concise Binary Object Representation (CBOR)) to Proposed Standard

From: Randy Presuhn <[email-masked]>
Date: Tue, 13 Aug 2013 18:53:37 -0700 (GMT-07:00)

Hi -

>From: Yaron Sheffer <[email-masked]>
>Sent: Aug 13, 2013 2:11 PM
>To: IETF Discussion Mailing List <[email-masked]>
>Subject: re: Last Call: <draft-bormann-cbor-04.txt> (Concise Binary Object	Representation (CBOR)) to Proposed Standard
...
>- The "diagnostic notation" can be used very effectively for things like 
>configuration files, e.g. if an application already uses CBOR on the 
>wire. Therefore I would suggest to formalize it a bit more, so that we 
>also have interoperability at this level.

Do you envision it as an encoding for Netconf?

Randy

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 14 Aug 2013 10:31:09 +0300

Hi Randy,

I prefer to leave this question to people who know something about 
Netconf, i.e. not me.

But let me just say that, based on my thoroughly extensive 5-min. 
research, YANG seems to be incompatible with CBOR.

Thanks,
	Yaron

---

From: Randy Bush <[email-masked]>
Date: Wed, 14 Aug 2013 20:40:00 +0900

> YANG seems to be incompatible with CBOR.

so what does that say about yang, yang's suitability for netconf, cbor,
and cbor's suitability?

randy

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 14 Aug 2013 15:07:13 +0200

> so what does that say about yang, yang's suitability for netconf, cbor,

Good question.  I'm not sure the jury is even out on that yet.

Yaron reminded me that netconf is using XPath for various purposes, so a CBOR rendition of netconf would need to do the same that you would need for doing netconf with JSON: either replace XPath with something else (indeed causing some incompatibility), or explain how to use XPath with the CBOR/JSON translation of the YANG model (which might be interesting).

CBOR certainly has no trouble carrying around the data described by a YANG model.
(Indeed, CBOR's decimal fractions were inspired by YANG's.)
But then, I don't have an opinion whether adding a binary object representation to the netconf ecosystem is on the agenda.

Grüße, Carsten

---

From: Andy Bierman <[email-masked]>
Date: Wed, 14 Aug 2013 08:18:21 -0700

On Wed, Aug 14, 2013 at 12:31 AM, Yaron Sheffer <[email-masked]> wrote:
> Hi Randy,
>
> I prefer to leave this question to people who know something about Netconf,
> i.e. not me.
>
> But let me just say that, based on my thoroughly extensive 5-min. research,

Can you be more specific?
What is incompatible about YANG?

>         Yaron

Andy

>>> Subject: re: Last Call: <draft-bormann-cbor-04.txt> (Concise Binary
>>> Object      Representation (CBOR)) to Proposed Standard
>>
>> ...
>>>

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 14 Aug 2013 18:44:51 +0300

Hi Andy,

Please see Carsten's mail on this subject.

Thanks,
	Yaron

---

From: Andy Bierman <[email-masked]>
Date: Wed, 14 Aug 2013 10:57:22 -0700

> But then, I don't have an opinion whether adding a binary object representation to the netconf ecosystem is on the agenda.

I am not sure this is an actual problem.
NETCONF uses full XPath only if the :xpath capability
is supported.  The "select" expression represents
the data to be returned from the conceptual datastore
and possibly the state/statistics within the device.
The select expression is not related to the message on the wire.

There is also an "error-path" field that is returned in errors
that contains the absolute path of the message or data node
that caused the error.

Neither of these message fields should cause an encoding problem.
They are just strings at the message layer.

Andy