Subject: RPS Accessibility

From: Paul Aitken <[email-masked]>
Date: Fri, 02 Aug 2013 14:08:09 +0100

I've remotely participated in several IETFs.

I find that the biggest problem with remote attendance is the lack of 
visual cues. I've come to realise just how important these are in a meeting.
-are people paying attention, are they interested / confused / 
distracted / bored?

Also there's no way for local attendees (in the WG room) to know that 
remote attendees are "at the mic" and whose turn it is to speak.

There's been some discussion on the "87attendees" mailer about badge 
sensing at the mic - whether QR codes, NFC, or RFID. This could help 
remote attendees too.

eg, see what they did with NFC + mic here: 
http://www.5thbar.me/blog/2012/09/14/nfc-enabled-badges-at-the-5thbar-mobile-marketing-forum/ 

P.

---

From: [email-masked]
Date: Sat, 03 Aug 2013 12:41:10 +0200

Hi Paul,

interesting pointer, thanks! You might all want to have  a look at the  
UMPIRE experiment proposed by Meetecho starting from IETF83:

http://ietf83.conf.meetecho.com/index.php/UMPIRE_Project

The idea is definitely in-line with what you envisage. With the  
UMPIRE, you have an integrated means for moderating both local and  
remote participants in a seamless fashion. We would be glad to propose  
the experiment once more at the upcoming IETF in Vancouver.

Cheers,

Simon

Quoting Paul Aitken <[email-masked]>:

> I find that the biggest problem with remote attendance is the lack  
> of visual cues. I've come to realise just how important these are in  
> a meeting.
> Also there's no way for local attendees (in the WG room) to know  
> that remote attendees are "at the mic" and whose turn it is to speak.
>

-- 
                             _\\|//_
                             ( O-O )
    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                     Simon Pietro Romano
               Universita' di Napoli Federico II
                  Computer Science Department
         Phone: +39 081 7683823 -- Fax: +39 081 7684219
                 e-mail: [email-masked]

     <<Molti mi dicono che lo scoraggiamento ? l'alibi degli
    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
                          oooO
    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                           \ (    (   )
                            \_)    ) /
                                  (_/

---

From: Dan York <[email-masked]>
Date: Mon, 5 Aug 2013 09:15:32 +0000

On the topic of badge-sensing at the mic, I seem to recall that we had this working at an IETF sometime back in the RAI working groups. It was maybe 4 or 5 years ago and I think it may have been some student(s) under Henning Schulzrinne at Columbia... but I am not sure about that.  I remember that when you went to the mic you put your badge up to this sensor and your name appeared in the jabber room. We used it in several of the RAI sessions at that IETF. Unfortunately I don't remember how well it worked or why it wasn't continued. There may be someone out there who can provide some insight. (And if it was Henning's students we can just drop him a note.)

Dan

--
Dan York
[email-masked]
+1-802-735-1624
skype:danyork
http://twitter.com/danyork

On Aug 2, 2013, at 10:26 AM, "Paul Aitken" <[email-masked]> wrote:

> I find that the biggest problem with remote attendance is the lack of visual cues. I've come to realise just how important these are in a meeting.
> -are people paying attention, are they interested / confused / distracted / bored?
> 
> Also there's no way for local attendees (in the WG room) to know that remote attendees are "at the mic" and whose turn it is to speak.
> 
> There's been some discussion on the "87attendees" mailer about badge sensing at the mic - whether QR codes, NFC, or RFID. This could help remote attendees too.
> 
> eg, see what they did with NFC + mic here: http://www.5thbar.me/blog/2012/09/14/nfc-enabled-badges-at-the-5thbar-mobile-marketing-forum/ 
> 
> P.
> _______________________________________________
> iaoc-rps mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/iaoc-rps

---

From: Dave Crocker <[email-masked]>
Date: Tue, 06 Aug 2013 08:27:47 -0700

> On the topic of badge-sensing at the mic, I seem to recall that we had this working at an IETF sometime back in the RAI working groups. It was maybe 4 or 5 years ago and I think it may have been so…

It was an experiment.  It was awkward and inaccurate.  It also raised 
basic privacy concerns, what with wearing something that can be tracked 
as you move around.

An entirely different approach would be to have all speakers make a 
'reservation' into a single meetecho (or whatever) online queue, and 
then get called in order, whether local or remote and independent of 
what microphone they are at.  This gets accurate identification into the 
online system, with the entry task distributed.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Michael Richardson <[email-masked]>
Date: Tue, 06 Aug 2013 13:31:23 -0400

Dave Crocker <[email-masked]> wrote:
    > 'reservation' into a single meetecho (or whatever) online queue, and then get
    > called in order, whether local or remote and independent of what microphone
    > they are at.  This gets accurate identification into the online system, with
    > the entry task distributed.

+1.
And move the microphones to the people, rather than the other way around.

We can easily have three or four microphones that can play leap-frog around
the room.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Joe Abley <[email-masked]>
Date: Tue, 6 Aug 2013 14:13:27 -0400

On 2013-08-06, at 11:27, Dave Crocker <[email-masked]> wrote:

>> [...]  I remember that when you went to the mic you put your badge up to this sensor and your name appeared in the jabber room.

... and the main screen in the room, if we're thinking about the same experiment. I seem to think it might have been in Hiroshima.

> It was an experiment.  It was awkward and inaccurate.  It also raised basic privacy concerns, what with wearing something that can be tracked as you move around.

I thought it was less awkward and inaccurate than relying on poly-accented and rushed (or missing) announcements of name and affiliation through the microphone. It was an improvement for jabber scribes, wg chairs trying to do minutes, remote participants and people in the room who are interested in who is talking, but not interested enough to stand up and demand that the name and affiliation be repeated.

I remember the privacy concerns being expressed, but I also have been subscribed to more XXattendees mailing lists than I care to remember, and I had compartmentalised both sets of complaints into the same bucket that usually makes me unsubscribe from XXattendees by Tuesday.

The NFC badge idea was a good one, I think, and I think it should happen again (even if it's opt-in at registration time, to reduce anxiety for those worried about their loss of privacy in a public meeting.)

Or perhaps future IETFers.app releases could talk using bluetooth to a transponder duct-taped to the mic stand and realise the same outcomes (and if you don't like that, you can always touch "no" in the appropriate place on your phone).

Joe

---

From: Brian Rosen <[email-masked]>
Date: Tue, 6 Aug 2013 14:29:33 -0400

Could be an app that put you in the queue and used your
laptop/tablet/smartphone microphone to get the audio.

On Tuesday, August 6, 2013, Michael Richardson wrote:

>
> Dave Crocker <[email-masked] <javascript:;>> wrote:
> then get
> Michael Richardson <[email-masked] <javascript:;>>, Sandelman
> Software Works
>
>
>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Aug 2013 19:14:04 +0000

> It was an experiment.  It was awkward and inaccurate.  It also raised basic privacy concerns, what with wearing something that can be tracked as you move around.

Ironically, this IETF everyone who stayed at the Intercontinental was walking around with an RFID key in their pocket the whole meeting.   How many of us put them in faraday cages?

I thought the experiment in Hiroshima went well, and wish we had made it standard practice.   It is _really_ hard to get people to say their names consistently in a way that is intelligible to the note-taker; I would go so far as to say that this is unachievable.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Aug 2013 19:15:25 +0000

On Aug 6, 2013, at 11:27 AM, Dave Crocker <[email-masked]> wrote:
> An entirely different approach would be to have all speakers make a 'reservation' into a single meetecho (or whatever) online queue, and then get called in order, whether local or remote and independent of what microphone they are at.  This gets accurate identification into the online system, with the entry task distributed.

I would not mind this system intensely, but bear in mind that it requires everybody to bring a mobile device of some sort that can be used to do this registration, and they will have to keep that device out and active during all meetings.   If their battery dies, they can no longer participate, or will require exception handling.

---

From: "John Levine" <[email-masked]>
Date: 6 Aug 2013 19:19:29 -0000

>Ironically, this IETF everyone who stayed at the Intercontinental was walking around
>with an RFID key in their pocket the whole meeting.   How many of us put them in
>faraday cages?

I put all of my cards in a faraday cage, but perhaps that's just me,
and because I carry an RFID passport card.

R's,
John

---

From: Dave Crocker <[email-masked]>
Date: Tue, 06 Aug 2013 12:57:28 -0700

> I would not mind this system intensely, but bear in mind that it requires everybody to bring a mobile device of some sort that can be used to do this registration, and they will have to keep that d…

Lean over to a neighbor and ask them to put you into the queue.

d/

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Aug 2013 20:16:32 +0000

> We can easily have three or four microphones that can play leap-frog around

+1

Of course, then we need a facilitator to wrest it away from filibusterers or simply a mechanism for the chairs to mute a mic.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Aug 2013 20:30:05 +0000

On Aug 6, 2013, at 4:05 PM, Paul Aitken <[email-masked]> wrote:
> Could there be a conflict if IETF badges also have RFID tags attached, eg we get "Room 1283" at the mic?

No.  Only known IDs would register.   The RFID badge just has a number—it doesn't say "Room 1283."

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 6 Aug 2013 16:37:09 -0400

[to no one in particular]

Uhhh... I can't tell if you folks are being serious about this idea or not, but in case you are being serious... ISTM there's such a thing as too much technology being a bad thing.  If you think technical glitches now-and-then cause issues with remote participants today, wait until physical participants have to deal with glitches in something like this.  "KISS" isn't just a rock-band from the 70's, it's also a useful principle known to many today.

If the problem is "we don't know who's speaking", then fix that problem.  In WGs I go to, both the WG chairs and the jabber scribes regularly yell "NAME!" if someone forgets to say it.  Unlike DNS Ops, this isn't rocket science.

Besides, it's not a bad thing to make people get in mic lines, if for no other reason than to have a small barrier threshold for folks to decide it's worth it to say something.[1]

-hadriel
[1] yes, I recognize the irony in this statement, since I get up to the mic every 15 seconds and say inane things.  We can't stop all people like me from wasting meeting time, we can just reduce the number of similar people wasting time.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 6 Aug 2013 20:46:06 +0000

> If the problem is "we don't know who's speaking", then fix that problem.  In WGs I go to, both the WG chairs and the jabber scribes regularly yell "NAME!" if someone forgets to say it.  Unlike DNS…

This doesn't work very well.   In one meeting where I was scribing this IETF, I had to shout NAME at the same person several times, because he didn't state his name clearly enough for me to be sure I'd gotten it, and so it didn't stick.   I hate doing this—I think it's disruptive, and nobody likes getting yelled at.   I certainly don't like _having_ to yell.

---

From: Doug Barton <[email-masked]>
Date: Tue, 06 Aug 2013 13:47:33 -0700

> This doesn't work very well.   In one meeting where I was scribing this IETF, I had to shout NAME at the same person several times, because he didn't state his name clearly enough for me to be sure…

Then come up with an alternate proposal. Fixing this problem is 
non-optional.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 06 Aug 2013 17:02:03 -0400

Brian Rosen <[email-masked]> wrote:
    > Could be an app that put you in the queue and used your laptop/tablet/
    > smartphone microphone to get the audio.

I was thinking that too, but I didn't want to get ahead of the problem
statement of "mic access" :-)

---

From: Doug Barton <[email-masked]>
Date: Tue, 06 Aug 2013 14:15:34 -0700

On 08/06/2013 01:47 PM, Doug Barton wrote:
>>> If the problem is "we don't know who's speaking", then fix that
>>> problem.  In WGs I go to, both the WG chairs and the jabber scribes
>>> regularly yell "NAME!" if someone forgets to say it.  Unlike DNS Ops,
>>> this isn't rocket science.
>>
>> This doesn't work very well.   In one meeting where I was scribing
>> this IETF, I had to shout NAME at the same person several times,
>> because he didn't state his name clearly enough for me to be sure I'd
>> gotten it, and so it didn't stick.   I hate doing this—I think it's
>> disruptive, and nobody likes getting yelled at.   I certainly don't
>> like _having_ to yell.
>

Apologies if this came off as too terse, or even worse, insulting to 
Ted. I had a longer response in the works then decided to not go too far 
into the weeds, and may have trimmed a bit too much.

What I've seen in other groups that has worked is a volunteer to record 
the names of speakers *before* they get to the mic, and then each 
speaker is announced. Of course that's one more volunteer to find, but 
it's pretty light duty, and I suspect that some in our crowd would like 
to have the extra mic time. :)

In any case, we must fix these problems. All arguments of the form "But 
it's hard ..." are out of scope.

Perhaps what is necessary is a solution-focused group to hash out the 
problem space and come up with workable ideas? I would gladly 
participate in such a group.

Doug

---

From: [email-masked] (Martin Rex)
Date: Tue, 6 Aug 2013 23:36:13 +0200 (CEST)

Doug Barton wrote:
> Ted Lemon wrote:
>>
>> M, Hadriel Kaplan <[email-masked]> wrote:
>>> If the problem is "we don't know who's speaking", then fix that problem.
>>
>> This doesn't work very well. [...] nobody likes getting yelled at.
>> I certainly don't like _having_ to yell.
> 
> Then come up with an alternate proposal.
> Fixing this problem is non-optional.

I would neither want to yell at other, nor enjoy being yelled at.
Still I might need a reminder.  How about a visual cues that would/should
work for most participants in a f2f meeting?

Supply the chairs (~8 rooms?) with signs at least A4 size, or A3
maybe even using all caps and something like:

      TELL US YOUR NAME,
           PLEASE
      (and affiliation)

The chair could raise the sign towards persons at the mic when they forget,
slowly moving it up in the air and over the head (and ultimately waving it...)
until the message has been received.

Maybe attaching such a sign to the MIC from the start could
additionally improve the situation.

-Martin

---

From: "Robin Uyeshiro" <[email-masked]>
Date: Tue, 6 Aug 2013 11:45:54 -1000

I would think any kind of multiple non-fixed microphone setup (maybe even
fixed microphones) would need to be tested pretty thoroughly before use, as
feedback problems can ruin a discussion.  That would include laptop
microphones.  One way to alleviate this would be to require the use of
near-field microphones, mics that only pick up sounds generated close to the
mic. They are pretty cheap.  
 
Of course, this wouldn't apply to remote participants :)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Brian Rosen
Sent: Tuesday, August 06, 2013 8:30 AM
To: Michael Richardson
Cc: [email-masked]; [email-masked]
Subject: Re: RPS Accessibility

then get

+1.

--
Michael Richardson <[email-masked] <javascript:;> >, Sandelman
Software Works

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 6 Aug 2013 18:15:17 -0400

> This doesn't work very well.   In one meeting where I was scribing this IETF, I had to shout NAME at the same person several times, because he didn't state his name clearly enough for me to be sure…

Yeah, the best scenario (other than the person just remembering to say their name), is for the Chairs to remind them - because they have their own microphones so they don't have to actually yell.

But another thing that works well is to have the jabber scribe sit in a seat right next to the microphone, because then they don't have to yell either.

-hadriel

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 6 Aug 2013 20:41:58 -0400

Yes, a group from my lab did this, using short-range RFID. (The range was about 1-2 inches.) It required a bit of a setup which made it hard to replicate at scale, but it worked reasonably well.

Privacy concerns are an issue, but you'd have to be very close to the person to sense the card (and you can obviously leave it behind any time you'd want to) - it would be much more convenient to track people using BlueTooth or WiFi MAC addresses, if you'd be so inclined, or just use video cameras. Yes, you can use long-range directional antennas to increase your read range, but those would be rather hard to hide. As was mentioned, the hotel room cards use very much the same technology, and you can't really leave them behind when you leave the building.

Henning

---

From: Randy Bush <[email-masked]>
Date: Wed, 07 Aug 2013 06:22:39 +0200

> Ironically, this IETF everyone who stayed at the Intercontinental was
> walking around with an RFID key in their pocket the whole meeting.
> How many of us put them in faraday cages?

one.  i made it a habit

> I thought the experiment in Hiroshima went well

count me in the privacy concerns camp

randy

---

From: "John Levine" <[email-masked]>
Date: 7 Aug 2013 04:32:55 -0000

>> How many of us put them in faraday cages?

Two.  I have a wallet with a built-in tinfoil hat.

http://www.idstronghold.com/RFID-Blocking-Secure-Wallet-Bi-Fold-10-Slots/productinfo/IDSH7005/

---

From: Riccardo Bernardini <[email-masked]>
Date: Wed, 7 Aug 2013 08:26:24 +0200

Just thinking out aloud....

What about a web-cam (maybe a wireless one? Never tried to use
them...) right under the mic, so that it takes a picture of the badge
and shows it on the screen?  Everyone (right?) in a meeting has a
badge  wit his/her/its :) name and affiliation, so privacy concerns
are just comparable to those of wearing a badge.

Of course, this is not applicable to jabber participants, in that case
you need a different solution.

---

From: Keith Moore <[email-masked]>
Date: Wed, 07 Aug 2013 02:38:49 -0400

On 08/07/2013 02:26 AM, Riccardo Bernardini wrote:
> badge  wit his/her/its:)  name and affiliation, so privacy concerns
Except that this would preclude use of portable/wireless microphones to 
let people engage in more effective conversation.

Even if there continues to be some sort of queue or other discipline to 
determine who speaks next, we need to get away from the habit of forcing 
people to walk through narrow rows of chairs and stand in a queue behind 
a fixed-location microphone in order to speak.

Keith

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Aug 2013 14:51:08 +0000

On Aug 6, 2013, at 5:15 PM, Doug Barton <[email-masked]> wrote:
> What I've seen in other groups that has worked is a volunteer to record the names of speakers *before* they get to the mic, and then each speaker is announced. Of course that's one more volunteer to find, but it's pretty light duty, and I suspect that some in our crowd would like to have the extra mic time. :)

This is a bit low-tech, but would certainly work.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Aug 2013 14:52:40 +0000

> additionally improve the situation.

There were signs like this attached to all the mics in all the rooms at this IETF.   I never looked at them, and I doubt anybody else did either.   Certainly the evidence would suggest that they did not!   :}

---

From: Paul Aitken <[email-masked]>
Date: Tue, 06 Aug 2013 21:05:40 +0100

> walking around with an RFID key in their pocket the whole meeting.

Could there be a conflict if IETF badges also have RFID tags attached, 
eg we get "Room 1283" at the mic?

P.

---

From: Paul Aitken <[email-masked]>
Date: Tue, 06 Aug 2013 21:13:59 +0100

Joe Abley wrote:
> Or perhaps future IETFers.app releases could talk using bluetooth to a 
> transponder duct-taped to the mic stand and realise the same outcomes 
> (and if you don't like that, you can always touch "no" in the 
> appropriate place on your phone).

Instead of requiring additional hardware on the mic stand + duct tape:

    "Zoosh, a new technology developed by Sunnyvale startup Naratte
    <http://www.naratte.com/>, aims to deliver all the benefits of NFC
    (near-field communication) with any device that has a speaker and
    microphone. Instead of relying on NFC chips, Zoosh uses ultrasound
    to perform secure mobile transactions."

http://venturebeat.com/2011/06/19/narattes-zoosh-enables-nfc-with-just-a-speaker-and-microphone/

Obviously this requires everyone to carry an app-enabled device to the mic.

P.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Aug 2013 15:16:07 +0000

Dare I ask how many IETFers also kept their cell phones in faraday cages for the duration of the conference?

---

From: Hadriel Kaplan <[email-masked]>
Date: Wed, 7 Aug 2013 11:18:52 -0400

> are just comparable to those of wearing a badge.

Ummm... methinks female participants might find such a camera offensive.

-hadriel

---

From: Chris Elliott <[email-masked]>
Date: Wed, 7 Aug 2013 12:26:00 -0400

My wallet supposedly has a RFID-blocking layer, but I've not actually
tested it. I think the only RFID-capable thing in my wallet is my US
passport.

I used my cell phone in Berlin extensively, both roaming and on wifi,
obviously, so both radios were active for most of the time I was there.
Clearly, I'm not as para^G^G^G^Gconcerned about being tracked or hacked as
some others.

Chris.

-- 
Chris Elliott
[email-masked]

---

From: manning bill <[email-masked]>
Date: Wed, 7 Aug 2013 10:08:50 -0700

would this mandate wearing badges only in certain locations, e.g. over the left breast?

/bill

---

From: Scott Brim <[email-masked]>
Date: Wed, 7 Aug 2013 13:24:31 -0400

On Wed, Aug 7, 2013 at 12:26 PM, Chris Elliott <[email-masked]> wrote:
> My wallet supposedly has a RFID-blocking layer, but I've not actually tested
> it. I think the only RFID-capable thing in my wallet is my US passport.

Take a look at what's in your passport with an NFC tool.  For example,
you can retrieve the photo.

I keep my passport in a "cage" when I'm not handing it to someone.
I'm not concerned about my phone.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Aug 2013 17:28:38 +0000

> I'm not concerned about my phone.

Likewise.   The point being, handing everyone in IETF an RFID tag probably doesn't have new privacy implications for most of them, and giving them a faraday cage, as was done in Hiroshima, addresses the remaining implications for those people who do not carry powered-on cell phones or laptops for privacy reasons.   If you carry a powered on cell phone, I don't think you can argue that carrying an RFID tag with a simple number in it makes things any worse.

Actually, the main argument I'd make against IETF RFID tags is that it's more plastic to throw out.

---

From: Joe Abley <[email-masked]>
Date: Wed, 7 Aug 2013 13:43:06 -0400

On 2013-08-07, at 13:28, Ted Lemon <[email-masked]> wrote:

> [...] I don't think you can argue that carrying an RFID tag with a simple number in it makes things any worse.

That sounds right.

The purpose of the badge is to dilute your personal privacy and announce your identity to those close enough to see. You can't always tell who is looking at your badge. People who see your badge in more than one place can infer that you have moved between places. If you don't want people to see your badge, you can take it off.

The privacy concerns with badges seem very similar to the privacy concerns of carrying RFID tags.

I do not hear a lot of expressed concern about wearing a badge.

Joe

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 07 Aug 2013 14:01:35 -0400

On Wednesday, August 07, 2013 13:43:06 Joe Abley wrote:
> The purpose of the badge is to dilute your personal privacy and announce
> your identity to those close enough to see. You can't always tell who is
> looking at your badge. People who see your badge in more than one place can
> infer that you have moved between places. If you don't want people to see
> your badge, you can take it off.

In RFID terms, that's what the Faraday cage is for.

> I do not hear a lot of expressed concern about wearing a badge.

It's more common to have a pocket available than a Faraday cage.

Scott K

---

From: Scott Brim <[email-masked]>
Date: Wed, 07 Aug 2013 14:12:59 -0400

I hope the RFID badges transmit (optional) pictures as well, so when I
harvest them I can use them to associate names with faces.

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 7 Aug 2013 16:27:30 -0400

> you can retrieve the photo.

for US passports it seems you have to scan the inside of the back
cover, scanning from the outside doesn't find/activate the rfid token,
yes?

You also need to generate the key material to access the data (DOB +
expiry date of passport + passport number?)

> I'm not concerned about my phone.

it seems like simply not waving the passport around open is close to
good enough?
I recall seeing a blackhat/something-or-other demo with a briefcase
that'd read the token though? perhaps with enough wattage you can burn
through the rf shield in the cover?

---

From: Ole Jacobsen <[email-masked]>
Date: Wed, 7 Aug 2013 13:30:58 -0700 (PDT)

> it's more plastic to throw out.

Unless we adopt the WIDE practice where the tag is re-used from 
meeting to meeting. It's an elegant solution, and not that different
from the reason I own a complete set of Suica, Pasmo, ICOCA, PASPY
and London Oyster cards.

Ole

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Aug 2013 20:55:55 +0000

> from the reason I own a complete set of Suica, Pasmo, ICOCA, PASPY

That is where I was going with that remark, yes.   :)

---

From: Christian Huitema <[email-masked]>
Date: Thu, 8 Aug 2013 00:17:33 +0000

>> from the reason I own a complete set of Suica, Pasmo, ICOCA, PASPY and 
>> London Oyster cards.
>

Why bother with RFID tags, or badges? Simply register with your cell phone. We can then scan your Wi-Fi and Blue-Tooth signals when you approach the mic.

-- Christian Huitema

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 7 Aug 2013 21:39:55 -0400

As far as I know, the simple metallically-coated anti-static plastic bag that's provided with EZPass (and similar electronic toll systems) is quite effective and very cheap. Aluminum foil will also do in a pinch.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 7 Aug 2013 21:42:17 -0400

What we tried for our experiment was simple: you turn in your RFID card at the end of the meeting, and it is randomly re-used for the next one, i.e., a new number is assigned each meeting. Unfortunately, we only got a relatively small fraction of RFID badges back, if I recall correctly, as people presumably forgot to turn them in.

---

From: "John R Levine" <[email-masked]>
Date: 7 Aug 2013 22:28:51 -0400

> Why bother with RFID tags, or badges? Simply register with your cell 
> phone. We can then scan your Wi-Fi and Blue-Tooth signals when you 
> approach the mic.

You must not have seen my cell phone.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
"I dropped the toothpaste", said Tom, crestfallenly.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 8 Aug 2013 13:47:57 -0400

On Wed, Aug 7, 2013 at 8:17 PM, Christian Huitema <[email-masked]>wrote:

> phone. We can then scan your Wi-Fi and Blue-Tooth signals when you approach
> the mic.
>
> -- Christian Huitema
>

'Simply'

What is this simple technology of which you speak? I find that the best we
can do with electronic systems is about 99% and that takes a huge amount of
effort. I have a whole drawerful of bluetooth headsets and thats where they
will stay because none of them works well enough to be useful.

I have the whole Apple/Nest/Sonos/Windows/etc suite in the house. The UI
sucks because my phone takes about 45 seconds to context switch to a new
applet. Often it takes a lot longer as the applet begs to be updated for no
particular reason.

If we want to do simple then use a BARCODE.

A webcam is cheaper and easier to come by than wireless scanning devices.
They are just as reliable and there is only one device with a source of
power involved. We could easily add QR codes to the front and rear of the
badges.

A side benefit would be that we also equip ourselves for showing video of
people at the mic at the same time (should that prove desirable).

No privacy issues, much more robust. It even deals with the issue I have
occasionally had where I have had a plane delay and gone straight from the
airport to a WG meeting before picking up my badge. Rare exceptions like
that are easy to declare, just state it in advance at the mic. I doubt the
RFID cars and the associated readers will work as well. Trying to reuse my
cell phone is an exercise in the crazy.

-- 
Website: http://hallambaker.com/

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Aug 2013 18:44:03 +0000

On Aug 8, 2013, at 1:47 PM, Phillip Hallam-Baker <[email-masked]> wrote:
> What is this simple technology of which you speak? I find that the best we can do with electronic systems is about 99% and that takes a huge amount of effort. I have a whole drawerful of bluetooth headsets and thats where they will stay because none of them works well enough to be useful.

I am fairly sure Christian was being ironic.

---

From: Christian Huitema <[email-masked]>
Date: Thu, 8 Aug 2013 20:52:40 +0000

> I am fairly sure Christian was being ironic.

:-)

I was. On the other hand, there are systems out there that will, for example, track customers as they move in a shop. They do that by listening to the Bluetooth radios. They definitely do not requests the customers to install an application or pair their devices. An extract form a research paper on the subject (http://www.gim-international.com/issues/articles/id1443-Bluetooth_Tracking.html) asserts that "Bluetooth tracking on the basis of MAC addresses does not violate privacy law. In fact, it simply makes use of a general Bluetooth function: scanning for nearby devices. Everyone is free to use this function, for instance when turning on a mobile phone in a public place." So it must be just fine.

-- Christian Huitema

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 8 Aug 2013 19:41:43 -0400

Hmmm didn't a certain large company whose name rhymes with scroogle
recently get whacked with a huge fine for violating privacy in a similar
manner in the EU?

Like you say, must be just fine it says so on the net.

On Thu, Aug 8, 2013 at 4:52 PM, Christian Huitema <[email-masked]>wrote:

> >> What is this simple technology of which you speak? I find that the best
> we can do with electronic systems is about 99% and that takes a huge amount
> of effort. I have a whole drawerful of bluetooth headsets and thats where
> they will stay because none of them works well enough to be useful.
> >
> I was. On the other hand, there are systems out there that will, for
> example, track customers as they move in a shop. They do that by listening
> to the Bluetooth radios. They definitely do not requests the customers to
> install an application or pair their devices. An extract form a research
> paper on the subject (
> http://www.gim-international.com/issues/articles/id1443-Bluetooth_Tracking.html)
> asserts that "Bluetooth tracking on the basis of MAC addresses does not
> violate privacy law. In fact, it simply makes use of a general Bluetooth
> function: scanning for nearby devices. Everyone is free to use this
> function, for instance when turning on a mobile phone in a public place."
> So it must be just fine.
>
> -- Christian Huitema
>
>
>
>
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 08 Aug 2013 20:22:38 -0400

On 08/08/2013 07:41 PM, Phillip Hallam-Baker wrote:
> recently get whacked with a huge fine for violating privacy in a 
> similar manner in the EU?

The rules are different for large companies with funny names.

Keith

---

From: George Michaelson <[email-masked]>
Date: Fri, 9 Aug 2013 10:31:29 +1000

When next you walk into a target or big W, ask to see the conditions of
entry. Along with implied consent to have your bags checked at any time,
you have probably given consent to be video'ed and tracked at their behest.
The poster is on the wall somewhere usually. Your statutory rights cannot
be abrogated but equally, the grey areas have been 'informed'.

BT tracking inside the store is passive collection of data you are
radiating. The store's use of the BT location and timing of presence
against shelves is private information of immense value to them. They share
it for mutual benefit with suppliers, or for money. I doubt they give much
away.

The large international scroogle rhyming company was compiling third party
uses of the data to inform location as a service, and were not solely
collecting information inside their own physical territory you entered,
with implied consent: they were harvesting data in the public space and
then providing insight into that data into the public space.

They relate because its harvesting RF. They don't relate in much else to my
mind.

-G

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 8 Aug 2013 20:48:51 -0400

> be abrogated but equally, the grey areas have been 'informed'.

The efficacy of such notices has not been tested in court and when they are
tested it is likely to cost the target about $2 million+ in legal fees.

Since the IETF meets around the world the last thing we need is to spend
time checking the legality of the badge at the mic system. And even though
the IETF is not likely to be a target, I would hate to have some of the
less popular with governments organizations I am involved in copy what the
IETF does and then find themselves being targeted with a selective
prosecution.

Barcodes have the potential to work really well and require almost no
change from current practice. The only downside to a barcode is that they
are slightly easier to forge. Though in the IETF context, forgery would
likely consist of people copying other people's badges for fun rather than
to avoid paying.

---

From: George Michaelson <[email-masked]>
Date: Fri, 9 Aug 2013 11:02:39 +1000

Philip, I'm not disagreeing. I responded to Keith's mail relating what we
do to what was done harvesting WiFi. Like the store, we're in a room. we're
in a world of implied and actual consent (you do actually have to give some
consents when you register for IETF)

-G

On Fri, Aug 9, 2013 at 10:48 AM, Phillip Hallam-Baker <[email-masked]>wrote:

> On Thu, Aug 8, 2013 at 8:31 PM, George Michaelson <[email-masked]>wrote:
>
> The efficacy of such notices has not been tested in court and when they
> are tested it is likely to cost the target about $2 million+ in legal fees.
>

---

From: Keith Moore <[email-masked]>
Date: Thu, 08 Aug 2013 21:05:24 -0400

On 08/08/2013 08:48 PM, Phillip Hallam-Baker wrote:
> change from current practice.

Except that current practice is broken anyway and we desperately need to 
change it, not add more mechanisms to reinforce continued use of it.

Actually I think all of this emphasis on being able to reliably identify 
every speaker is a bit beside the point.   With rare exceptions, who is 
speaking is not nearly as relevant as what is being said.   Of course 
there are times when it's important or useful to know who is speaking - 
say if it's an AD, or the document author/editor, or a person with whom 
there needs to be a followup discussion.   But when we find ourselves 
working so hard to make sure that we can reliably identify every speaker 
(and perhaps also to exclude anonymous / pseudonymous input), maybe 
that's a distraction.   Maybe we should instead be concentrating on how 
to make sure that our standards have been written in light of a wide 
degree of input about requirements, are technically sound, and have 
enjoyed thorough review.

Would being able to reliably know exactly who said everything that was 
said in a WG meeting visibly improve the quality of our standards?   If 
the answer is not a clear "yes" (and I don't think it is) then I suggest 
that this topic is a distraction.

Keith

---

From: George Michaelson <[email-masked]>
Date: Fri, 9 Aug 2013 11:07:46 +1000

On Fri, Aug 9, 2013 at 11:05 AM, Keith Moore <[email-masked]>wrote:

> said in a WG meeting visibly improve the quality of our standards?   If the
> answer is not a clear "yes" (and I don't think it is) then I suggest that
> this topic is a distraction.
>
> Keith
>
>
With this I heartily agree. I think there is nothing to see here which will
really make much difference, or cannot be solved in other ways after the
event anyway. The problem is not one which technology can solve, because
the problem isn't that kind of problem.

---

From: Mark Andrews <[email-masked]>
Date: Fri, 09 Aug 2013 11:18:50 +1000

In message <[email-masked]>
> be abrogated but equally, the grey areas have been 'informed'.

You expect to video'ed and bag checked for stock loss prevention.  There
is no implied consent for anything else.  You don't need to track mobile
phones for stock loss prevention.
 
> They relate because its harvesting RF. They don't relate in much else to my

The main difference is the levels of encryption used in the two standards.
For WiFi there are still a large percentage of networks sending in the clear.
For BlueTooth there were no non-encrypted channels in the base spec (1.0)
support for them was added in 1.1 [1].

With BlueTooth you get presence.
With WiFi you get presence + data

Mark

[1] http://en.wikipedia.org/wiki/Bluetooth#Bluetooth_v1.1
-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Fri, 9 Aug 2013 09:39:12 -0400

On Aug 8, 2013, at 9:05 PM, Keith Moore <[email-masked]> wrote:
> Would being able to reliably know exactly who said everything that was said in a WG meeting visibly improve the quality of our standards?   If the answer is not a clear "yes" (and I don't think it is) then I suggest that this topic is a distraction.

If you mean will it improve what is written on the page, probably not.   Will it decrease the likelihood of someone participating without identifying themself, and then violating the IPR rules?   Possibly.

AFAIK that's why we do it.   Not so much because it is an iron-clad preventative, but because it to some degree removes the illusion of anonymity that might tempt someone to do something like that, or just be careless about it.

---

From: Keith Moore <[email-masked]>
Date: Sat, 10 Aug 2013 09:50:59 -0400

> AFAIK that's why we do it.   Not so much because it is an iron-clad preventative, but because it to some degree removes the illusion of anonymity that might tempt someone to do something like that,…

If it's that important to catch people violating the IPR rules, perhaps 
we need to hire a court reporter for every WG meeting, and not rely on 
volunteer Jabber scribes to accurately capture what is said and who said it.

Keith

---

From: Scott Kitterman <[email-masked]>
Date: Sat, 10 Aug 2013 10:52:35 -0400

On Friday, August 09, 2013 09:39:12 Ted Lemon wrote:
> If you mean will it improve what is written on the page, probably not.  
> Will it decrease the likelihood of someone participating without
> identifying themself, and then violating the IPR rules?   Possibly.
> 
> AFAIK that's why we do it.   Not so much because it is an iron-clad
> preventative, but because it to some degree removes the illusion of
> anonymity that might tempt someone to do something like that, or just be
> careless about it.

Unless you're checking identification provided by sources all agree are 
trustworthy, you've done nothing of the sort.  You may be able to attach an 
unverified identifier to a group of statements, but there's still no firm 
connection to identity (I'm not arguing in favor of one, but it seems a bit 
silly to expend resources to protect against something you aren't actually 
protecting against).

Scott K

---

From: Ted Lemon <[email-masked]>
Date: Sat, 10 Aug 2013 11:13:38 -0400

> silly to expend resources to protect against something you aren't actually 

I think you misunderstand the threat model.