Subject: Re: stability of iana.org URLs

From: John Curran <[email-masked]>
Date: Thu, 1 Aug 2013 08:01:07 -0400

On Jul 31, 2013, at 10:11 AM, Peter Saint-Andre <[email-masked]> wrote:
> 
> That's true, but cool URIs don't change:
> 
> http://www.w3.org/Provider/Style/URI.html

Even cooler would have been URN's (e.g. urn:ietf:enterprise-numbers), 
which was designed specifically as a persistent handle to information
(ref: http://en.wikipedia.org/wiki/Uniform_resource_name) but alas, it 
was not to be.

/John

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 01 Aug 2013 15:29:04 +0200

On 8/1/13 2:01 PM, John Curran wrote:
> Even cooler would have been URN's (e.g.
> urn:ietf:enterprise-numbers), which was designed specifically as a
> persistent handle to information (ref:
> http://en.wikipedia.org/wiki/Uniform_resource_name) but alas, it 
> was not to be.

You're preaching to the choir:

https://datatracker.ietf.org/doc/draft-saintandre-iana-urn/

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 31 Jul 2013 14:40:41 +0000

Hi,

The link in RFC3315 is actually incorrect -- it should have been http://www.iana.org/assignments/enterprise-numbers, without the file extension, and there's an erratum about this. HTML was generally (I say "generally" because there may be exceptions Michelle would know about) reserved for files that needed to include links to registration forms, like MIME/Media Types (which will be converted to XML shortly) and URI Schemes.

As Barry said, we do intend to keep that same short http://www.iana.org/assignments/example format working for every current page, even the newly-created ones. We also prefer to see that format used in documents, since we can't guarantee that the file extension used for the long version won't change. (This information will be appearing on the website in some form.)

(BTW: I've never tried writing to [email-masked] from our ticketing system, so Barry, would you mind pushing this along if it never shows up there?)

Amanda Baber
IANA Request Specialist
ICANN 

On Wed Jul 31 14:06:28 2013, [email-masked] wrote:
> > I just followed http://www.iana.org/assignments/enterprise-numbers.html
> > From RFC3315 (DHCPv6)'s reference section.  Ten years later, the URL
> > doesn't work.
> >
> > I know that things were reworked when we went to XML based storage, but
> > I thought that the old URLs would at least have a 301 error on them.
> >
> > I discovered that dropping the .html gets me the right data at:
> >   http://www.iana.org/assignments/enterprise-numbers
> 
> Yes: that's the form that IANA would like you to use.  They changed
> their registries from HTML to XML, and the URLs changed.  Supposed
> they should decide to turn them all into JSON (aieeeeeeeee!)... the
> URLs would change again.  But the suffix-less version will always
> work.
> 
> When I've done AD reviews of documents that cite IANA URLs, I've given
> the authors that feedback, and suggested the change to the suffix-less
> URLs.  I also intend to suggest to IANA (thanks to a document author,
> and I've since forgotten who it was; sorry) that they post permalinks
> in all the registries, so people will know which URL they ought to
> use, and not have to guess.
> 
> Barry, Applications AD
>