Subject: Re: [Gen-art] Gen-ART LC review of draft-ietf-nfsv4-labreqs-04

From: Jari Arkko <[email-masked]>
Date: Thu, 21 Nov 2013 10:50:35 -0300

Roni: many thanks for the review.

> 
> Minor issues:
> 
> The document is not a requirement document. It is a use case, requirement and solution document so the abstract and the title are confusing.
> 
> I think it will be better to have the use case section before the requirements in section 3. Since the use cases are the reason for the rest of the document.
> 
> Section 3 is called requirements but it is not about requirements from a solution but also normative text about behavior of clients and servers.
> 
> This leads to the question why is it Informational document since it has normative recommendations for a solution.

Has there been a response to this? I can not find further e-mails relating to this topic, but I'm sorry if I just missed them. It would be good to get the authors/sponsoring AD to reply before we recommend approving the document.

FWIW, I have read the document and think that the requirements in Section 3 are perhaps more fine-grained that in most requirement documents, but they are not implementation requirements, and hence an informational document is OK from my perspective. 

> I also think that there is a need for IANA section to discuss requirements  for new LFSs.
> 

There was quite a lot of discussion of LFSes in the document, but I interpreted them in an abstract sense, i.e., there was no specific suggestions on additions to LFSes.

Jari

---

From: "Roni Even" <[email-masked]>
Date: Wed, 27 Nov 2013 09:14:47 +0200

Hi Jari,
I did not see any response.
As for my comment, I expected a requirement to list requirements from a
solution  that will be followed by a solution document. To me it reads more
like a solution description so it is more requirements from implementations.

Roni

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: 21 November, 2013 3:51 PM
> To: Roni Even; Martin Stiemerling
> Cc: [email-masked]; [email-masked];
[email-masked]
> Subject: Re: [Gen-art] Gen-ART LC review of draft-ietf-nfsv4-labreqs-04
> 
> 
> > The document is not a requirement document. It is a use case,
requirement
> and solution document so the abstract and the title are confusing.
> >
> > I think it will be better to have the use case section before the
requirements
> in section 3. Since the use cases are the reason for the rest of the
document.
> >
> > Section 3 is called requirements but it is not about requirements from a
> solution but also normative text about behavior of clients and servers.
> >
> > This leads to the question why is it Informational document since it has
> normative recommendations for a solution.
> 
> 
> Has there been a response to this? I can not find further e-mails relating
to this
> topic, but I'm sorry if I just missed them. It would be good to get the
> authors/sponsoring AD to reply before we recommend approving the
> document.
> 
> FWIW, I have read the document and think that the requirements in Section
3
> are perhaps more fine-grained that in most requirement documents, but they
> are not implementation requirements, and hence an informational document
is
> OK from my perspective.
> 
> > I also think that there is a need for IANA section to discuss
requirements  for
> new LFSs.
> >
> 
> There was quite a lot of discussion of LFSes in the document, but I
interpreted
> them in an abstract sense, i.e., there was no specific suggestions on
additions to
> LFSes.