Subject: Community Feedback: Turning off monthly IETF mailing list password reminder emails

From: Chris Griffiths <[email-masked]>
Date: Sat, 2 Nov 2013 17:19:20 -0700

Hello,

The IAOC would like to solicit feedback from the community to see if there are any concerns with having the Secretariat turn off the monthly mailing list password reminders for the IETF mailing lists going forward.  Due to an ever increasing community size as well as new mailing lists being added to the mailman servers over time, we see a large amount of mail at the beginning of every month that is causing some delays to email delivery during this time period in order to send out mass email subscription and password reminders to the community.  Since Mailman has the ability to do on-demand requests for password reset and subscription information for each mailing list, there is an alternative method to the current bulk sending of subscription information that the community can use.

We are planning to raise this at the Admin plenary on Wednesday at IETF 88 in Vancouver, but we would like to get your feedback on this issue.  

Thank you

Chris Griffiths
IAOC Chair

---

From: "John Levine" <[email-masked]>
Date: 3 Nov 2013 01:02:41 -0000

I run a bunch of lists (on majordomo2, but close enough) on my system
and have never sent monthly password reminders.  Nobody's ever asked
for them.

So yes, please, turn them off.

R's,
John

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 2 Nov 2013 22:19:20 -0700

1) Yes, please turn the reminders off.

> Since Mailman has the ability to do on-demand requests for password reset and subscription information for each mailing list, there is an alternative method to the current bulk sending of subscription information that the community can use.

2) If there is an easy way to obtain a list which mailing lists I’m currently subscribed to (beyond looking for the last password reminder mail), it is not documented very well.  Since mailman often drops subscribers after bouts of bounces, it is occasionally useful to compare that list to what you think it should be when such bouts end.

Grüße, Carsten

---

From: Riccardo Bernardini <[email-masked]>
Date: Sun, 3 Nov 2013 10:19:21 +0100

No objection to turning it off.  Actually, it would save me a "delete"
once a month.

---

From: t.p. <[email-masked]>
Date: Sun, 3 Nov 2013 10:58:34 +0000

----- Original Message -----
From: "Carsten Bormann" <[email-masked]>
To: "Chris Griffiths" <[email-masked]>
Cc: "IAOC List" <[email-masked]>; <[email-masked]>
Sent: Sunday, November 03, 2013 5:19 AM
<snip>

2) If there is an easy way to obtain a list which mailing lists I’m
currently subscribed to (beyond looking for the last password reminder
mail), it is not documented very well.  Since mailman often drops
subscribers after bouts of bounces, it is occasionally useful to compare
that list to what you think it should be when such bouts end.

<tp>

Keep it on.  Since mailman often drops subscribers for reasons unknown,
the monthy list of what I am currently subscribed to is an invaluable
check on what mischief mailman has done lately.

Tom Petch

Grüße, Carsten

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Sun, 03 Nov 2013 12:35:16 +0100

>check on what mischief mailman has done lately.

Note that mailman lets users turn these reminders on and off on an
individual basis; it should be possible to turn the option off for
all users and make 'off' the default, but let individual users turn
it back on if they so choose.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Hector Santos <[email-masked]>
Date: Sun, 03 Nov 2013 06:55:28 -0500

I like the occasional reminders, especially for list that are older 
and lesser to no mail. I hardly use the password stuff myself, so its 
just more of a reminder of the list subscriptions.  There are a few 
that have no mail and it helps to get an reminder of the list you are 
subscribed too.  In fact, I had switched mailers and it helped me the 
other day to see a reminder of a list to create a filter rule to move 
it its own folder.

If anything, lets not allow a 'technical detail' be the path of least 
resistance, i.e. just globally turning it off for all.  One solution 
is to make it optional (off by default) at the subscription level (per 
user), if not already there (but its on by default).  Change the 
script to every 2-4 months and spread out the load.

One small but big point I think, not everyone here is an "IETF 
regular."  The "weekend IETF warriors" need these electronic reminders 
of their participation and whats happening in the IETF.  So while it 
may be seen as "waste" to the regular folks, it is useful for others too.

Anyway, solve the technical problem -- we are good at that.... I 
think. :)

--
HLS

-- 
HLS

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 3 Nov 2013 08:28:17 -0500

I also like the reminders. Perhaps they could be made every other
month, but please don't get rid of them altogether.

Thanks,
Andy

On Sun, Nov 3, 2013 at 6:55 AM, Hector Santos <[email-masked]> wrote:
> I like the occasional reminders, especially for list that are older and
> lesser to no mail. I hardly use the password stuff myself, so its just more
> of a reminder of the list subscriptions.  There are a few that have no mail
> and it helps to get an reminder of the list you are subscribed too.  In
> fact, I had switched mailers and it helped me the other day to see a
> reminder of a list to create a filter rule to move it its own folder.
>
> resistance, i.e. just globally turning it off for all.  One solution is to
> make it optional (off by default) at the subscription level (per user), if
> not already there (but its on by default).  Change the script to every 2-4
> months and spread out the load.
>
> One small but big point I think, not everyone here is an "IETF regular."
> The "weekend IETF warriors" need these electronic reminders of their
> participation and whats happening in the IETF.  So while it may be seen as
> "waste" to the regular folks, it is useful for others too.
>
> Anyway, solve the technical problem -- we are good at that.... I think. :)
>
> --
> HLS
>
>
>> The IAOC would like to solicit feedback from the community to see if there
>> are any concerns with having the Secretariat turn off the monthly mailing
>> list password reminders for the IETF mailing lists going forward.  Due to an
>> ever increasing community size as well as new mailing lists being added to
>> the mailman servers over time, we see a large amount of mail at the
>> beginning of every month that is causing some delays to email delivery
>> during this time period in order to send out mass email subscription and
>> password reminders to the community.  Since Mailman has the ability to do
>> on-demand requests for password reset and subscription information for each
>> mailing list, there is an alternative method to the current bulk sending of
>> subscription information that the community can use.
>>
>> We are planning to raise this at the Admin plenary on Wednesday at IETF 88
>> in Vancouver, but we would like to get your feedback on this issue.
>>
>> Thank you
>>
>> Chris Griffiths
>> IAOC Chair
>>
>
> --
> HLS
>
>

---

From: Arturo Servin <[email-masked]>
Date: Sun, 3 Nov 2013 09:57:58 -0400

I like the default off and let the option to turn it on.

/as

---

From: Rich Kulawiec <[email-masked]>
Date: Sun, 3 Nov 2013 10:41:12 -0500

1. Personally, I like having them as-is.

2. Individual users can switch them on/off as they wish, either via
the web interface or via email.  (It might be good to include wording
about both methods in the initial welcome message sent to new subscribers.
Perhaps it might also be good to include the same in monthly reminders.)

3. Consider shifting the reminder date to something other than the
beginning of the month (which is Mailman's default).  People on many
Mailman-operated mailing lists tend to get inundated on the first
day of each month, so perhaps this might make the traffic more palatable.

---rsk

---

From: Sandy Wills <[email-masked]>
Date: Sun, 03 Nov 2013 10:52:05 -0500

I've been mostly a lurker here, but those monthly emails do serve a 
useful purpose.  Would the programming be very difficult to only send it 
out if there was a _change_ in subscription status?  That would return 
these emails to being signal, instead of being part of the noise.

-- 
Unable to locate coffee.
Operator halted.

---

From: Paul Wouters <[email-masked]>
Date: Sun, 3 Nov 2013 11:52:05 -0500 (EST)

> check on what mischief mailman has done lately.

opt-in not opt-out should be the default mode of such things.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 3 Nov 2013 12:16:33 -0500

> day of each month, so perhaps this might make the traffic more palatable.

I find them really irritating and I have many different email list
subscriptions on different email accounts. I do not want to waste time
disabling them piecemeal.

There is a protocol that allows for easy unsubscription from mailing lists
- the header contains the unsubscribe. And most intelligent anti-spam tools
will automatically unsubscribe if someone reports a message. In fact some
will do that rather too proactively, it seems I fell off the ietf mailing
list for a while because of something like that.

The principle should be 'don't send nobody nothing unless they ask first'.

-- 
Website: http://hallambaker.com/

---

From: David Morris <[email-masked]>
Date: Sun, 3 Nov 2013 10:31:55 -0800 (PST)

Or only send the reminders for lists which haven't sent any traffic for
the past week or so. This would reduce the load for the big busy lists,
but keep folks aware of the dormant lists.

On Sun, 3 Nov 2013, Sandy Wills wrote:

> I've been mostly a lurker here, but those monthly emails do serve a useful
> purpose.  Would the programming be very difficult to only send it out if there
> was a _change_ in subscription status?  That would return these emails to
> being signal, instead of being part of the noise.
> 
> > > > Since Mailman has the ability to do on-demand requests for password
> > > > reset and subscription information for each mailing list, there is an
> > > > alternative method to the current bulk sending of subscription
> > > > information that the community can use.
> > > 
> > > 
> > > 2) If there is an easy way to obtain a list which mailing lists I?m
> > > Gr??e, Carsten

---

From: Chris Griffiths <[email-masked]>
Date: Sun, 3 Nov 2013 11:53:55 -0800

> opt-in not opt-out should be the default mode of such things.

Paul,

Based on feedback so far, having this process be opt-in seems like a good idea if you still want your monthly fix of mail list details from the IETF :-)  

Brian Carpenter sent a great write-up that provides a good technical alternative to enable opt-in for this, see below. (Thank you Brian!)   How does this sound and does this meet your needs?  Anyone else have any feedback on this approach?

Thank you

On Nov 3, 2013, at 9:28 AM, Brian E Carpenter wrote:

> It's taken me two days, probably due to jet lag, but I have finally
> realised that this is a no-brainer.
> 
> When logged in as a subscriber to mailman, down among the Subscription Options,
> there is "Get password reminder email for this list?" which includes
> opt-in/opt-out  and a checkbox for "Set globally".
> 
> Switch them off by defaault, and advise people of this opt-in if they want them.
> 
> Done deal. Screen shot attached.
> 
> Regards
>   Brian Carpenter

---

From: "John Levine" <[email-masked]>
Date: 4 Nov 2013 04:01:36 -0000

>2) If there is an easy way to obtain a list which mailing lists I=92m
>mail), it is not documented very well.

It is very easy, and very poorly documented.

Point your web browser at the list member options page, which is the
link in the List-Unsubscribe: header.  (Unsubscribing is one of the
options.)  Log in with your e-mail address and the password in the
reminder mail.  If you don't have a reminder mail, there's a button on
that page to send you one.

Once you're logged in, scroll down a page, and you'll see a button
"List my other subscriptions".  Ta da!  The number of subscriptions
can be quite startling.  I found I have 48.

R's,
John

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 4 Nov 2013 17:43:05 +0000

Off by default, with the per-user option of turning reminders on. As a
result I suspect <5% of users will want a reminder.

The spare CPU cycles on the 1st of every month can be used to mine
bitcoins for the purchase of IETF meeting break cookies with greater
quantities of chocolate chips.

Jason

On 11/2/13, 8:19 PM, "Chris Griffiths" <[email-masked]> wrote:

>Hello,
>
>The IAOC would like to solicit feedback from the community to see if
>there are any concerns with having the Secretariat turn off the monthly
>mailing list password reminders for the IETF mailing lists going forward.
> Due to an ever increasing community size as well as new mailing lists
>being added to the mailman servers over time, we see a large amount of
>mail at the beginning of every month that is causing some delays to email
>delivery during this time period in order to send out mass email
>subscription and password reminders to the community.  Since Mailman has
>the ability to do on-demand requests for password reset and subscription
>information for each mailing list, there is an alternative method to the
>current bulk sending of subscription information that the community can
>use.
>
>We are planning to raise this at the Admin plenary on Wednesday at IETF
>88 in Vancouver, but we would like to get your feedback on this issue.
>
>Thank you
>
>Chris Griffiths
>IAOC Chair

---

From: Dave Crocker <[email-masked]>
Date: Mon, 04 Nov 2013 09:52:41 -0800

On 11/2/2013 5:19 PM, Chris Griffiths wrote:
> Due to an ever increasing community size as well as new mailing lists being added to the mailman servers over time, we see a large amount of mail at the beginning of every month that is causing some delays to email delivery during this time period in order to send out mass email subscription and password reminders to the community.

Chris,

Independent of whether reminders should default to off, your note ought 
to raise a question about IETF-run list operations processing capacity.

The monthly reminder's capacity load is the same as having every mailing 
list get one posting (and yes, probably at the same time.)

No matter what size our mailing lists are or how many we run, by current 
measures of common Internet email volume, the aggregate load for the 
IETF would normally be considered pretty small.  Perhaps some tens of 
thousands of messages.

If our current system configuration can't handle that easily, it 
probably  needs to get fixed.  (There was supposed to be an IAOC effort 
to move towards a more scalable operation, but I believe that stalled.)

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 4 Nov 2013 18:10:31 +0000

>to move towards a more scalable operation, but I believe that stalled.)

+1, more capacity seems called forŠ

Jason

---

From: Chris Griffiths <[email-masked]>
Date: Mon, 4 Nov 2013 10:22:47 -0800

On Nov 4, 2013, at 9:52 AM, Dave Crocker <[email-masked]> wrote:

> Independent of whether reminders should default to off, your note ought to raise a question about IETF-run list operations processing capacity.
> 
> The monthly reminder's capacity load is the same as having every mailing list get one posting (and yes, probably at the same time.)
> 
> No matter what size our mailing lists are or how many we run, by current measures of common Internet email volume, the aggregate load for the IETF would normally be considered pretty small.  Perhaps some tens of thousands of messages.
> 
> If our current system configuration can't handle that easily, it probably  needs to get fixed.  (There was supposed to be an IAOC effort to move towards a more scalable operation, but I believe that stalled.)

Dave,

I completely agree with your statements on capacity planning, and a plan is moving forward and is a priority for the team running it and we are tracking milestones and deliverables on these plans in the IAOC.  We are also discussing options and additional actions to continue to boost capacity and/or availability of IETF specific platforms which we will share transparently with the community as those discussions and plans are proposed.  

The specifics to capacity and monitoring for platforms like Mailman are fairly complex beyond simply sending bulk emails since there are a number of factors at play prior to even sending the bulk emails monthly which I agree are not a significant in number from a sender sense.  There is significant overhead monthly to the system in order generate the emails for each user and reference each mail list they are subscribed which is where one focus is to reduce this current impact on system resources, and I agree this is only part of the needed assessment and not a sliver bullet to deal with capacity.

Thank you

Chris

---

From: Dave Crocker <[email-masked]>
Date: Tue, 05 Nov 2013 05:45:31 -0800

On 11/4/2013 10:22 AM, Chris Griffiths wrote:
> a plan is moving forward and is a priority for the team running it and we are tracking milestones and deliverables on these plans in the IAOC.  We are also discussing options and additional actions to continue to boost capacity and/or availability of IETF specific platforms which we will share transparently with the community as those discussions and plans are proposed.

Chris,

Thanks for the followup.  It had seemed that the initiative for this, 
from last year, had stalled.  The only reference I've seen in the IAOC 
minutes was a pretty cryptic one in the September minutes.

If you can manage it, it might be good for the community to hear a 
summary of this project and its schedule, during the IAOC plenary.

d/

---

From: Chris Griffiths <[email-masked]>
Date: Tue, 5 Nov 2013 15:44:58 -0800

On Nov 5, 2013, at 5:45 AM, Dave Crocker <[email-masked]> wrote:

> Thanks for the followup.  It had seemed that the initiative for this, from last year, had stalled.  The only reference I've seen in the IAOC minutes was a pretty cryptic one in the September minutes.
> 
> If you can manage it, it might be good for the community to hear a summary of this project and its schedule, during the IAOC plenary.

Dave,

Of course, we will make sure we get the latest items into the presentation tomorrow.

Thank you