Subject: Re: Document Action: 'Terms used in Ruting for Low power And Lossy Networks' to Informational RFC (draft-ietf-roll-terminology-13.txt)

From: Glen Zorn <[email-masked]>
Date: Wed, 06 Nov 2013 16:01:54 +0700

You're joking, right?  14 revs, IESG review and still nobody asked what 
"Ruting" was?

On 11/06/2013 01:47 AM, The IESG wrote:
> The IESG has approved the following document:
> - 'Terms used in Ruting for Low power And Lossy Networks'
>    (draft-ietf-roll-terminology-13.txt) as Informational RFC
>
> This document is the product of the Routing Over Low power and Lossy
> networks Working Group.
>
> The IESG contact persons are Adrian Farrel and Stewart Bryant.
>
> A URL of this Internet Draft is:
> http://datatracker.ietf.org/doc/draft-ietf-roll-terminology/
>
>
>
>
> Technical Summary
>
>     This document provides a glossary of terminology used in routing
>     requirements and solutions for networks referred to as Low power and
>     Lossy Networks (LLN).  An LLN is typically composed of many embedded
>     devices with limited power, memory, and processing resources
>     interconnected by a variety of links.  There is a wide scope of
>     application areas for LLNs, including industrial monitoring, building
>     automation (e.g.  Heating, Ventilating, Air Conditioning, lighting,
>     access control, fire), connected home, healthcare, environmental
>     monitoring, urban sensor networks, energy management, assets
>     tracking, refrigeration.
>
> Working Group Summary
>
>     No concerns, the document had good support.
>
> Document Quality
>
>     There was good support in the working group towards getting the
>     definitions precise enough to be useful, but not overly specific.
>
>     This Informational document contains only terminology so cannot
>     be implemented, but the WG is actively using this document as a
>     base reference in other work.
>
>     There is no formal language in this document.
>
> Personnel
>
>     Document Shepherd: Michael Richardson <[email-masked]>
>     Responsible AD: Adrian Farrel <[email-masked]>
>
> RFC Editor Note
>
>     Document Title
>     s/Ruting/Routing/
>
>     Section 2 Directed Acyclic Graph:
>     s/edge v again/vertex v again/
>
>     Section 2
>     OLD
>     HVAC: Heating, Ventilation and Air Conditioning.  A term applied to
>     the comfort level of an internal space.
>     NEW
>     HVAC: Heating, Ventilation and Air Conditioning.  A term applied to
>     mechanisms used to maintain the comfort level of an internal space.
>     END
>
>     Section 2 Sleepy Node
>     s/When no in/When not in/
>

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 06 Nov 2013 15:34:31 +0100

>You're joking, right?  14 revs, IESG review and still nobody asked what 

(The document title was changed in the latest revision, it did not
contain the word earlier. And it has been spotted in this version.)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 07 Nov 2013 04:26:06 +1300

> contain the word earlier. And it has been spotted in this version.)

I think this deserves a few more words of explanation (we happened to
discuss it at the RFC Editor Advisory Group meeting yesterday).

The bug was introduced in the final rev before IESG approval.

It was noticed by, among others, the Gen-ART reviewer.

The General AD even put a short-term DISCUSS on the draft until the
bug was acknowledged by the authors. Clearly, it will be fixed
during editing.

However, the text of the approval message is generated automatically
from data in the tracker, so it automatically contained the bug.

Bottom line: the system worked.

   Brian

P.S. I assume that the correct title is 'Terms used in Rusting for Low Power and Lossy	Networks'.

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 6 Nov 2013 17:48:07 -0000

Right, thanks Brian.

I am surprised that this causes so much traffic, but anyway, the fault is mine as "responsible AD" (read "irresponsible AD"?)

The bug was introduced post IETF last call, and spotted immediately. It did not warrant a respin of the document and an RFC Editor Note was added to fix it. Several ADs noticed during IESG evaluation and made Comments or raised Discusses having failed to note the RFC Editor Note, but they cleaned them up after discussion.

As Brian says, the announcement text is auto-generated. But it is editable, and I should have edited it. I forgot / didn't notice.

As soon as the email came out I did notice (see my Twitter feed).

I raised a ticket with the Secretariat (who were shockingly having lunch at the time) and a revised announcement was sent as soon as they were back.

If I were not the person responsible for this error I would say "Nothing to see. Move along." But I leave you to judge.

Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Brian E
> Carpenter
> Sent: 06 November 2013 15:26
> To: Bjoern Hoehrmann
> Cc: [email-masked]
> Subject: Re: Document Action: 'Terms used in Ruting for Low power And Lossy
> Networks' to Informational RFC (draft-ietf-roll-terminology-13.txt)
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 6 Nov 2013 12:17:58 -0600

On Wednesday, November 6, 2013, Adrian Farrel wrote:

>
> I raised a ticket with the Secretariat (who were shockingly having lunch
> at the time) and a revised announcement was sent as soon as they were back.

For what it's worth, I think the Secretariat was actually sending out the
IETF Last Call for the CDNI Requirements doc I requested a few minutes
earlier. They may have been eating lunch, but they were also typing ...
pretty impressive, really.

If I were not the person responsible for this error I would say "Nothing to
> see. Move along." But I leave you to judge.
>