Subject: 6lowpan and metering infrastructure

From: Erhan Küçükgüzel <[email-masked]>
Date: Fri, 13 Dec 2013 13:39:20 +0200

Hello All,

I want to ask opinion about how can 6lowpan be fit into metering 
infrastructures.

ipv6 can bring IP addresses to each meter and meters can be reached over 
IP directly. But in that case, Control Center will have to query every 
meter _one by one_. How can IPv6 solve this processing load ?

Generally what is done is :
Collect data from locally close meters with Data Concentrator Unit (for 
example 1000 meters) using any radio and send all to Control Center via 
3G or ethernet... Lower processing load for Control Center.

Any piece of information or directing to information will be very helpful.

Regards,

Erhan Kucukguzel

---

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 13 Dec 2013 22:32:33 +0000

Hi Erhan,

Your question is on the more implementation and deployment side  of 6lowpan in the smart meters. The example of Data Concentrator Unit  you have provided, might resemble to some of the vendors' products as well.

I'll forward your question to the [email-masked]<mailto:[email-masked]>  mailing list - this is a wg which handles 6lowpan adaptation on multiple low-power L2 technologies.
There we can discuss, if there is a need for any document which can help with a typical use-case scenarios like yours.
BTW,  I am not sure if I understood the problem of processing load  in the context of IPv6  and Data Concentrator Unit. Perhaps you can explain the problem in more detail and discuss in 6lo mailing list in order to decide if this is a protocol question or an implementation issue.
https://ietf.org/wg/6lo/charter/

Best regards,
-Samita

From: ietf [mailto:[email-masked]] On Behalf Of Erhan Küçükgüzel
Sent: Friday, December 13, 2013 3:39 AM
To: [email-masked]
Subject: 6lowpan and metering infrastructure

Hello All,

I want to ask opinion about how can 6lowpan be fit into metering infrastructures.

ipv6 can bring IP addresses to each meter and meters can be reached over IP directly. But in that case, Control Center will have to query every meter one by one. How can IPv6 solve this processing load ?

Generally what is done is :
Collect data from locally close meters with Data Concentrator Unit (for example 1000 meters) using any radio and send all to Control Center via 3G or ethernet... Lower processing load for Control Center.

Regards,

Erhan Kucukguzel

---

From: Jorge Amodio <[email-masked]>
Date: Sat, 14 Dec 2013 04:12:13 -0600

Erhan,

Regardless on how you collect and aggregate meter data which is more in the application layer, 6LoWPAN provides you the benefits of having a uniform and "standard" platform with IPv6 support for the network layer. 

You can still use multiple communication technologies such as low power radios and aggregate data in a concentrator unit to be queried by your control center via 3G or Ethernet.

Now if your "concentrator" also serves as a gateway to each subnetwork of close-by meters, the individual meters will be reachable via IPv6 and give your control center the ability to send control commands and query them for data if needed. I assume that your concentrator unit has more resources than a meter and the volume of data is not substantial, then you will not have a lot more processing load on it or your control center infrastructure.

I agree with Samita that if you can share more specific details of your application to the WG you will give them a chance to evaluate the requirements of another real case scenario for the application of 6LoWPAN.

Regards
-Jorge

> On Dec 13, 2013, at 5:39 AM, Erhan Küçükgüzel <[email-masked]> wrote:
> 
> Hello All,
>