Subject: RE: [rtcweb] Straw Poll on Video Codec Alternatives

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Mon, 9 Dec 2013 23:32:10 +0000

I believe we are way off the acceptable process track here.

First, there was a discussion and a call for rough consensus at the last IETF in-person meeting. That call was not continued on the list, instead a lack of consensus was declared at the meeting.

Next, there was a proposal from the chairs to vote in a particular way, and a call for options on which to vote. It was claimed at that time that after the list was compiled, the act of taking such a vote would be taken to a consensus call. That never happened.

Instead the chairs are now conducting a "straw poll" of their own design, clearly in an effort to circumvent some very specific objections to the proposed instant-runoff vote with restricted participation. But again, instead of attempting to reach WG consensus for conducting such a poll, it has simply been foisted upon us.

I have not seen ANY replies to the message "Next Steps in Video Codec Selection Process" that indicate working group consensus of ANY KIND for conducting a poll in this format at this time or to follow the subsequent steps described in that message.

I am requesting that the chairs immediately suspend the "Straw Poll" described below until such time as there is Working Group consensus to spend the Working Group's time and energy conducting the poll and/or to continue with the subsequent steps called out in "Next Steps in Video Codec Selection Process" at http://www.ietf.org/mail-archive/web/rtcweb/current/msg10448.html

Matthew Kaufman

From: rtcweb [mailto:[email-masked]] On Behalf Of Ted Hardie
Sent: Monday, December 9, 2013 5:25 PM
To: [email-masked]; Gonzalo Camarillo; Richard Barnes; Magnus Westerlund; Cullen Jennings
Subject: [rtcweb] Straw Poll on Video Codec Alternatives

Dear WG,

This is the email announcing the straw poll across the video codec alternatives proposed to the WG. If you haven't read the "Next Steps in Video Codec Selection Process" (http://www.ietf.org/mail-archive/web/rtcweb/current/msg10448.html )then please do that before you continue to read.

The straw poll's purpose is to make it clear to the WG which of the alternatives that are favored or disfavored and what objections you have, if any, against a particular alternative. The WG chairs will use the information from this straw poll to identify an alternative to put as a single consensus question to the group. Thus, everyone that has an opinion on at least one alternative should answer this poll. Provide your poll input by replying to this email to the WG mailing list. The poll will run until the end of the 12th of January 2014.

As can be seen below, the poll lists the alternative that have proposed to the WG. For each alternative two questions are listed.

The first question is "Are you in favor of this option [Yes/No/Acceptable]:". These three levels allow you to indicate that you: Yes= I would be fine with the WG choosing this option. No = I really don't favor this, and it should not be picked. Acceptable = I can live with this option but I prefer something else to be picked.

The second question is "Do you have any objections to this option, if so please explain it:" If you have any objection at a minimum indicate it with a "Yes".   Please also add a short (1-sentence) summary of each of the objections you believe applies.  (If you wish to provide a longer explanation, please do so in a separate thread).  If you have no objection, leave that question blank.

Please provide input on as many of the alternatives as you like and feel comfortable to do. The more inputs, the more well informed decision the WG chairs can take when identifying the option to be brought forward for consensus. Any alternative that you chose to leave blank, will simply be considered as one without any input from you.

WG participants, please do not comment on anyone's input in this thread! If you want to comment, then create a separate thread and change the subject line to something else. Otherwise you are making life for the chairs very difficult to track the results of this straw poll.

If discussion causes you to update your position, please feel free to send an update via email on the straw poll thread prior to the closing date.

1.  All entities MUST support H.264

a.    Are you in favor of this option [Yes/No/Acceptable]:

b.    Do you have any objections to this option, if so please summarize them:

2.  All entities MUST support VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

3.  All entities MUST support both H.264 and VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

4.  Browsers MUST support both H.264 and VP8, other entities MUST support at least one of H.264 and VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

5.  All entities MUST support at least one of H.264 and VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

6.  All entities MUST support H.261

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

7.  There is no MTI video codec

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

8.  All entities MUST support H.261 and all entities MUST support at least one of H.264 and VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

9.  All entities MUST support Theora

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

10.  All entities MUST implement at least two of {VP8, H.264, H.261}

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

11.  All entities MUST implement at least two of {VP8, H.264, H.263}

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

12.  All entities MUST support decoding using both H.264 and VP8, and MUST support encoding using at least one of H.264 or VP8

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

13.  All entities MUST support H.263

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

14.  All entities MUST implement at least two of {VP8, H.264, Theora}

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

15.  All entities MUST support decoding using Theora.

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

16.  All entities MUST support Motion JPEG

.      Are you in favor of this option [Yes/No/Acceptable]:

a.    Do you have any objections to this option, if so please summarize them:

H.264 is a reference to the proposal in https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/<https://datatracker.ietf.org/doc/draft-burman-rtcweb-h264-proposal/>

VP8 is a reference to the proposal in https://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-vp8/<https://datatracker.ietf.org/doc/draft-alvestrand-rtcweb-vp8/>

Theora is a reference to Xiph.org Theora Specification from March 16, 2011 (http://www.xiph.org/theora/doc/Theora_I_spec.pdf)

H.263 is a reference to profile 0 level 70 defined in annex X of ITU-T rec H.263 (http://www.itu.int/rec/T-REC-H.263/)

H.261 is a reference to http://tools.ietf.org/html/rfc4587

Motion JPEG is a reference to http://tools.ietf.org/html/rfc2435

Thanks,

The Chairs

---

From: Martin Thomson <[email-masked]>
Date: Mon, 9 Dec 2013 16:51:16 -0800

On 9 December 2013 16:41, Brent Kelly <[email-masked]> wrote:

> 1.       See if there is group consensus on whether or not to take a vote.

One might choose to infer that there is not consensus to proceed with a
vote.  Though that might be tempered by adding "...at this moment."

---

From: Martin Thomson <[email-masked]>
Date: Mon, 9 Dec 2013 17:01:59 -0800

On 9 December 2013 16:53, Brent Kelly <[email-masked]> wrote:

> Maybe the poll should be to get consensus on whether to have a MTI codec
> vote “at this moment”.

Does not parse.  We have established IETF dogma that states that assessing
consensus using polls doesn't work.  I happen to have bought the dogma.

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 10 Dec 2013 09:28:02 +0100

Hi Matthew,

I hope I can answer your questions and resolve your objections.

On 2013-12-10 00:32, Matthew Kaufman (SKYPE) wrote:
> First, there was a discussion and a call for rough consensus at the last
> IETF in-person meeting. That call was not continued on the list, instead
> a lack of consensus was declared at the meeting.

No, it wasn't because the chairs did not believe there would emerge any
consensus on the mailing list based on the input provided during the
meeting.

> 
>  
> 
> Next, there was a proposal from the chairs to vote in a particular way,
> and a call for options on which to vote. It was claimed at that time
> that after the list was compiled, the act of taking such a vote would be
> taken to a consensus call. That never happened.

So this was a proposal for the a process. This proposal was heavily
debated and valid comments regarding issues was raised against it. Thus,
the chairs have selected to not proceed with the proposal. Instead we
will use this process.

> 
>  
> 
> Instead the chairs are now conducting a “straw poll” of their own
> design, clearly in an effort to circumvent some very specific objections
> to the proposed instant-runoff vote with restricted participation. But
> again, instead of attempting to reach WG consensus for conducting such a
> poll, it has simply been foisted upon us.

Yes, this process is intended to resolve all the major issues with the
previous proposal. It is designed to be open, provide more information
to all the WG participants about peoples positions and objections to the
various alternatives. It is information finding to enable us to take the
next step of identifying if there is any alternative we can make a
consensus call on.

> 
>  
> 
> I have not seen ANY replies to the message “Next Steps in Video Codec
> Selection Process” that indicate working group consensus of ANY KIND for
> conducting a poll in this format at this time or to follow the
> subsequent steps described in that message.

No, we have not requested WG consensus for this one. This is a decision
we chair have made ourselves. And the reason for this is while the
previous process proposal did require WG consensus to be used, this
information seeking is something we chairs can initiate, perform. In
this case we do believe that the time is best spent on performing this
pool rather than discussing if it is going to be done or not. The WG
will by the end of this poll have more information and a better
understanding of the positions and objections against the various
alternatives proposed.

> 
>  
> 
> I am requesting that the chairs immediately suspend the “Straw Poll”
> described below until such time as there is Working Group consensus to
> spend the Working Group’s time and energy conducting the poll and/or to
> continue with the subsequent steps called out in “Next Steps in Video
> Codec Selection Process” at
> http://www.ietf.org/mail-archive/web/rtcweb/current/msg10448.html
> 

The WG chairs believe they have good motivations and rights to call for
this straw poll. We will not suspend it. If you like to escalate your
objection please contact our Area Director Gonzalo Camarillo.

Regards

Magnus Westerlund

----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 10 Dec 2013 09:34:07 +0100

On 2013-12-10 01:41, Brent Kelly wrote:
> I agree with Matt. I thought the process was
> 
> 2.       If the group consensus is to take a vote, then get group
> consensus on **who** should be eligible to vote
> 
> 3.       Do the actual voting on the alternatives
> 
>  
> 
> The non-binding straw poll was not part of this process.
> 
>  

What you list above is the core of the chairs previous process proposal.
I like to stress "PROPOSAL". It got a lot of critique both in the WG and
by the larger IETF community. Thus we have abandoned it. We have
selected another path, which starts with this straw poll to better judge
the WG participants positions and objections against the various
alternatives.

cheers

Magnus Westerlund

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 10 Dec 2013 13:02:39 +0100

FWIW, I agree with the chairs that issuing a straw poll is completely 
within normal IETF processes, and something that does not require 
ascertaining WG consensus before one does it.

I'll certainly watch with great interest how the results of the poll 
(due more than a month from now) are treated by the chairs.

        Harald

---

From: Dave Crocker <[email-masked]>
Date: Tue, 10 Dec 2013 07:12:16 -0800

> (due more than a month from now) are treated by the chairs.

Perhaps I've been reading a different thread than you.

The issue that I see being raised is not whether a straw poll is 
'normal' within IETF processes but the question of whether the way it is 
being pursued is problematic.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Dave Cridland <[email-masked]>
Date: Tue, 10 Dec 2013 15:20:56 +0000

On Tue, Dec 10, 2013 at 3:12 PM, Dave Crocker <[email-masked]> wrote:

> The issue that I see being raised is not whether a straw poll is 'normal'
> within IETF processes but the question of whether the way it is being
> pursued is problematic.
>

I suspect that, having gone off the rails for a bit, the act or getting
back on track will inevitably be a little bumpy.

Do you see anything more than that?

Dave.

---

From: Brent Kelly <[email-masked]>
Date: Tue, 10 Dec 2013 00:41:40 +0000

2.       If the group consensus is to take a vote, then get group consensus on *who* should be eligible to vote

Kind regards,
E. Brent Kelly, Ph.D.
Principal Analyst/Consultant

KelCor, Inc.
tel: +1 435 563 2532
email: [email-masked]<mailto:[email-masked]> | web: www.kelcor.com<http://www.kelcor.com/>

twitter: @ebkell | blog: www.uccinsider.blogspot.com<http://www.uccinsider.blogspot.com/>

From: Matthew Kaufman (SKYPE) [mailto:[email-masked]]
Sent: Monday, December 09, 2013 4:32 PM
To: Ted Hardie; [email-masked]; Gonzalo Camarillo; Richard Barnes; Magnus Westerlund; Cullen Jennings; [email-masked]
Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives

Matthew Kaufman

From: rtcweb [mailto:[email-masked]] On Behalf Of Ted Hardie
Sent: Monday, December 9, 2013 5:25 PM
To: [email-masked]<mailto:[email-masked]>; Gonzalo Camarillo; Richard Barnes; Magnus Westerlund; Cullen Jennings
Subject: [rtcweb] Straw Poll on Video Codec Alternatives

Dear WG,

1.  All entities MUST support VP8

1.  All entities MUST support both H.264 and VP8

1.  Browsers MUST support both H.264 and VP8, other entities MUST support at least one of H.264 and VP8

1.  All entities MUST support at least one of H.264 and VP8

1.  All entities MUST support H.261

1.  There is no MTI video codec

1.  All entities MUST support H.261 and all entities MUST support at least one of H.264 and VP8

1.  All entities MUST support Theora

1.  All entities MUST implement at least two of {VP8, H.264, H.261}

1.  All entities MUST implement at least two of {VP8, H.264, H.263}

1.  All entities MUST support decoding using both H.264 and VP8, and MUST support encoding using at least one of H.264 or VP8

1.  All entities MUST support H.263

1.  All entities MUST implement at least two of {VP8, H.264, Theora}

1.  All entities MUST support decoding using Theora.

1.  All entities MUST support Motion JPEG

Thanks,

The Chairs

---

From: Brent Kelly <[email-masked]>
Date: Tue, 10 Dec 2013 00:53:27 +0000

Maybe the poll should be to get consensus on whether to have a MTI codec vote “at this moment”. ☺

Kind regards,
E. Brent Kelly, Ph.D.

KelCor, Inc.
tel: +1 435 563 2532

From: Martin Thomson [mailto:[email-masked]]
Sent: Monday, December 09, 2013 5:51 PM
To: Brent Kelly
Cc: Matthew Kaufman (SKYPE); Ted Hardie; [email-masked]; Gonzalo Camarillo; Richard Barnes; Magnus Westerlund; Cullen Jennings; [email-masked]
Subject: Re: [rtcweb] Straw Poll on Video Codec Alternatives

On 9 December 2013 16:41, Brent Kelly <[email-masked]<mailto:[email-masked]>> wrote:
1.       See if there is group consensus on whether or not to take a vote.

One might choose to infer that there is not consensus to proceed with a vote.  Though that might be tempered by adding "...at this moment."

---

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Tue, 10 Dec 2013 22:33:07 +0000

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> 
> No, we have not requested WG consensus for this one. This is a decision we
> chair have made ourselves. And the reason for this is while the previous
> process proposal did require WG consensus to be used, this information
> seeking is something we chairs can initiate, perform. In this case we do
> believe that the time is best spent on performing this pool rather than
> discussing if it is going to be done or not. The WG will by the end of this poll
> have more information and a better understanding of the positions and
> objections against the various alternatives proposed.

Spending the Working Group's time on picking an MTI video codec at this point is just as disruptive to the vital work the WG needs to complete as it would be for me to stand in the corner of the next WG meeting continuously blowing a vuvuzela.

Since taking up valuable meeting time on this topic and considerable mailing list thread with this topic, we are no closer to a decision, and much more importantly, it appears that zero progress has been made on nothing else that the WG has signed up to deliver.

> > I am requesting that the chairs immediately suspend the "Straw Poll"
> > spend the Working Group's time and energy conducting the poll and/or
> > to continue with the subsequent steps called out in "Next Steps in
> > Video Codec Selection Process" at
> The WG chairs believe they have good motivations and rights to call for this
> straw poll. We will not suspend it. If you like to escalate your objection please
> contact our Area Director Gonzalo Camarillo.

I believe that the "straw poll" is both a thinly veiled recasting of the original "vote" proposal *and* that the Working Group is having its time and energy wasted on this progress. 

As a result, I am not confident at this time that the chairs are directing the Working Group in a way that will produce its chartered output in a timely manner.

The Area Director is already copied and I would like this message considered as escalation of my previous objection and request to suspend the poll.

Matthew Kaufman

---

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Tue, 10 Dec 2013 22:48:02 +0000

Also please note that I am objecting to the lack of WG consensus on following the *entire list* of "next steps" called out in the introductory mail http://www.ietf.org/mail-archive/web/rtcweb/current/msg10448.html and not simply the act of the chairs calling for a straw poll.

If not simply a veiled version of the "vote" - which it is, given that the next step is that the chairs will identify "an option" based on the results of said straw poll and issue a consensus call on that single option - I do agree that a straw poll is something that does not *necessarily* require Working Group consensus to conduct. However, both the particular and detailed form of this straw poll, and that continuing this discussion has caused a major disruption to the Working Group progress on any other issues are both highly concerning, and that is what forms the basis for my objection and subsequent escalation.

For reference, the above-mentioned list is quoted here:

  -- Conduct a straw poll to gather information on which option might achieve consensus
  -- Chairs identify an option based on the results of the straw poll and issue a consensus call
  -- If there is consensus (as judged by Richard Barnes), the selected option is reflected in a WG document
  -- The WG document is confirmed via the normal process of WGLC and IETF LC

Matthew Kaufman

> From: ietf [mailto:[email-masked]] On Behalf Of Matthew Kaufman
> (SKYPE)
> Sent: Tuesday, December 10, 2013 10:33 PM
> To: Magnus Westerlund; Ted Hardie; [email-masked]; Gonzalo Camarillo;
> Richard Barnes; Cullen Jennings; [email-masked]
> Subject: RE: Matthew's Objections: was Re: [rtcweb] Straw Poll on Video
> Codec Alternatives
> 
> > No, we have not requested WG consensus for this one. This is a
> > decision we chair have made ourselves. And the reason for this is
> > while the previous process proposal did require WG consensus to be
> > used, this information seeking is something we chairs can initiate,
> > perform. In this case we do believe that the time is best spent on
> > performing this pool rather than discussing if it is going to be done
> > or not. The WG will by the end of this poll have more information and
> > a better understanding of the positions and objections against the various
> alternatives proposed.
> 
> Spending the Working Group's time on picking an MTI video codec at this
> point is just as disruptive to the vital work the WG needs to complete as it
> would be for me to stand in the corner of the next WG meeting continuously
> blowing a vuvuzela.
> 
> Since taking up valuable meeting time on this topic and considerable mailing
> list thread with this topic, we are no closer to a decision, and much more
> importantly, it appears that zero progress has been made on nothing else
> that the WG has signed up to deliver.
> 
> > > described below until such time as there is Working Group consensus
> > > to spend the Working Group's time and energy conducting the poll
> > > and/or to continue with the subsequent steps called out in "Next
> > > Steps in Video Codec Selection Process" at
> > The WG chairs believe they have good motivations and rights to call
> > for this straw poll. We will not suspend it. If you like to escalate
> > your objection please contact our Area Director Gonzalo Camarillo.
> 
> I believe that the "straw poll" is both a thinly veiled recasting of the original
> "vote" proposal *and* that the Working Group is having its time and energy
> wasted on this progress.
> 
> As a result, I am not confident at this time that the chairs are directing the
> Working Group in a way that will produce its chartered output in a timely
> manner.
> 
> The Area Director is already copied and I would like this message considered
> as escalation of my previous objection and request to suspend the poll.
> 
> Matthew Kaufman

---

From: Adam Roach <[email-masked]>
Date: Tue, 10 Dec 2013 17:23:01 -0600

> Spending the Working Group's time on picking an MTI video codec at this point is just as disruptive to the vital work the WG needs to complete as it would be for me to stand in the corner of the ne…

Then light a candle.

The working group is made of its participants, of which you are 
presumably one. Start a conversation about something else. I agree that 
there are other deliverables, and there's no reason we can't discuss and 
progress them in parallel with any codec-related discussions.

Start here; dive in anywhere:

http://tools.ietf.org/wg/rtcweb/

/a

____
P.S. FWIW, I think the chairs are doing a perfectly reasonable job under 
some of the most difficult circumstances I've seen in 16 years of IETF 
work. For the past couple of meeting cycles, the problem hasn't even 
been the codec discussions; it's been the hyperaggressive 
meta-conversations talking *about* the codec conversations. From that 
perspective, you *are* standing in the corner playing a vuvuzela as a 
member of a highly disruptive vuvuzela chorus. We formally have three 
chairs, which is already large for a working group. We really don't need 
the hundred or so participants to be back-seat chairs as well.

---

From: <[email-masked]>
Date: Tue, 10 Dec 2013 23:55:42 +0000

On 12/10/13 16:33, Matthew Kaufman (SKYPE) wrote:
>> Spending the Working Group's time on picking an MTI video codec at this point
>> is just as disruptive to the vital work the WG needs to complete as it would be for
>> me to stand in the corner of the next WG meeting continuously blowing a vuvuzela.
>
> Then light a candle.

...and curse the dorks.

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2013 16:01:30 -0800

> Then light a candle.

I continue to do this, but still find myself agreeing with Matthew.

---

From: "Matthew Kaufman (SKYPE)" <[email-masked]>
Date: Wed, 11 Dec 2013 07:45:32 +0000

> From: Adam Roach [mailto:[email-masked]]
> 
> The working group is made of its participants, of which you are presumably
> one. Start a conversation about something else. I agree that there are other
> deliverables, and there's no reason we can't discuss and progress them in
> parallel with any codec-related discussions.

At the in-person meetings, discussing the MTI video codec is agenda-exclusive of progressing any other document.

On the mailing list, discussing the MTI video codec is drowning out any other discussion (as many are simply ignoring the list entirely) and slowing the work on any other document (as many are time-limited as to their participation, and are using their limited time to figure out how to strategically respond to ranked-choice voting alternatives instead of how to progress other documents)

> P.S. FWIW, I think the chairs are doing a perfectly reasonable job under some
> of the most difficult circumstances I've seen in 16 years of IETF work. For the
> past couple of meeting cycles, the problem hasn't even been the codec
> discussions; it's been the hyperaggressive meta-conversations talking
> *about* the codec conversations. From that perspective, you *are* standing
> in the corner playing a vuvuzela as a member of a highly disruptive vuvuzela
> chorus. We formally have three chairs, which is already large for a working
> group. We really don't need the hundred or so participants to be back-seat
> chairs as well.

There are chairs for a reason, both at the in-person meetings and on the mailing list. The chairs *could* have shut down the conversation about the codecs and they *could* have shut down the meta-conversations about the codec discussion, but they have not. Instead they have consumed several hours of several meetings and on an issue that appears to be diverging, not converging (and consuming an ever greater percentage of the mailing list traffic), despite much other unfinished work... much of it requiring cooperation with other working groups in order to close. I believe that objecting to the actions of the chairs is a bigger lever towards real progress than trying to be the one tiny voice in the corner trying to progress something else unilaterally during this storm.

Matthew Kaufman

---

From: <[email-masked]>
Date: Wed, 11 Dec 2013 08:34:13 +0000

I believe this MTI codec discussion in rtcweb is actually a foretaste of what MTI security discussions will be like after draft-farrell-perpass-attack. Mandatory To Implement and discussion around that will basically stall everything.

Having three chairs in a group is a sign of dysfunction. DTNRG has three chairs... there security was pretty much MTI and promoted by the chairs. in rtcweb, the codec is MTI and promoted by the chairs. This is more than a coincidence or an analogy.

I've seen the future of the IETF. It lacks accord and progress - though it won't want for MTI and process.

Lloyd Wood
http://sat-net.com/L.Wood/

________________________________________
From: ietf [[email-masked]] On Behalf Of Matthew Kaufman (SKYPE) [[email-masked]]
Sent: 11 December 2013 07:45
To: Adam Roach; Magnus Westerlund; Ted Hardie; [email-masked]; Gonzalo Camarillo; Richard Barnes; Cullen Jennings; [email-masked]
Subject: RE: [rtcweb] Matthew's Objections: was Re: Straw Poll on Video Codec Alternatives

Matthew Kaufman

---

From: Ted Hardie <[email-masked]>
Date: Wed, 11 Dec 2013 08:56:08 -0800

Matthew,

Since you have escalated this to the area directors after Magnus's replay,
I will leave them to respond to your main request, but I have two
corrections to factual mis-statements:

On Tue, Dec 10, 2013 at 11:45 PM, Matthew Kaufman (SKYPE) <
[email-masked]> wrote:

> At the in-person meetings, discussing the MTI video codec is
> agenda-exclusive of progressing any other document.
>
>
As attending the actual meetings would have told (or even reading their
minutes), this is simply not true.  We have had sessions related to
resolving this issue, but in every case there have also been other topics
discussed during the same IETF meeting, albeit in sometimes in other
sessions.

> I believe that objecting to the actions of the chairs is a bigger lever
> towards real progress than trying to be the one tiny voice in the corner
> trying to progress something else unilaterally during this storm.
>
>
The chairs have gratefully received and pushed action on reviews received
on a variety of documents during this period, and there has been movement
on data channel and the security documents driven by those who have chosen
to continue to work on those issues.   If you choose to ignore that work to
focus on this issue, that's your choice of how to use your time, not an
imposition by the chairs.  Self-fulfilling prophecies tend to be, well,
self-fulling, but they need not be universal.

I invite you to submit a review of any document currently before the
working group, and I pledge to you that it will get attention from the
chairs, no matter what else is going on.

regards,

Ted Hardie

---

From: "Cullen Jennings (fluffy)" <[email-masked]>
Date: Thu, 12 Dec 2013 01:09:39 +0000

Let me try and answer what I think is your central issue here which is: why are we spending any time on this topic. 

We have heard from a significant number of people that they think it is important for WebRTC devices and applicaitons to be able to know that video will work between devices. It was the number one requested item when speaking to the various developers with products demonstrated at WebRTC Expo and a significant issue on this email list. It is one of the several topics the chairs are driving forward. We plan to continue to do try to drive it to resolution. Note resolution includes consensus for no MTI. 

However, we perfectly well understand that you, or others, may not want to spend time on the video MTI issue. Feel free to ignore the email threads if you believe the outcome is inevitable and put your time into some of the other things we are also driving forward. 

Cullen in my co-chair role (and I'm not speaking for my co-chairs but I am pretty sure they also want to drive this issue to resolution) 

On Dec 9, 2013, at 4:32 PM, Matthew Kaufman (SKYPE) <[email-masked]> wrote:

> Instead the chairs are now conducting a “straw poll” of their own design, clearly in an effort to circumvent some very specific objections to the proposed instant-runoff vote with restricted participation. But again, instead of attempting to reach WG consensus for conducting such a poll, it has simply been foisted upon us.
>  
> I have not seen ANY replies to the message “Next Steps in Video Codec Selection Process” that indicate working group consensus of ANY KIND for conducting a poll in this format at this time or to follow the subsequent steps described in that message.
>  
> I am requesting that the chairs immediately suspend the “Straw Poll” described below until such time as there is Working Group consensus to spend the Working Group’s time and energy conducting the poll and/or to continue with the subsequent steps called out in “Next Steps in Video Codec Selection Process” at http://www.ietf.org/mail-archive/web/rtcweb/current/msg10448.html

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 12 Dec 2013 02:27:05 +0100

* Cullen Jennings (fluffy) wrote:
>Let me try and answer what I think is your central issue here which is:
>why are we spending any time on this topic. 
>
>We have heard from a significant number of people that they think it is 
>important for WebRTC devices and applicaitons to be able to know that 
>video will work between devices. It was the number one requested item 
>when speaking to the various developers with products demonstrated at 
>WebRTC Expo and a significant issue on this email list. It is one of the 
>several topics the chairs are driving forward. We plan to continue to do 
>try to drive it to resolution. Note resolution includes consensus for no 
>MTI. 

To me, an important point is that some people are now investigating some
alternative options that have not been given much consideration before,
like the data points and samples regarding H.261 that have been sent to
the group's mailing list recently, which may open up new ways to find a
consensus. I think a straw poll is much more useful in this situation
than a vote or giving up.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 12 Dec 2013 10:44:57 +0100

Hi Matthew,

> The Area Director is already copied and I would like this message
> considered as escalation of my previous objection and request to
> suspend the poll.

there have been many emails around this topic. I assume you refer to the
fact that the WG should stop spending time on discussing video codecs
shortly and spend all its time on other chartered items instead.

Actually, I agree with that and I told the chairs so after our last
meeting in Vancouver. That is why the chairs are driving this issue to
its conclusion. The idea is to get consensus on whatever the WG can get
consensus on at this point (e.g., a particular codec as MTI, to
implement at least one of two codecs, no MTI at all, or any of the other
options being considered) and move on.

Cheers,

Gonzalo

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 12 Dec 2013 12:40:34 +0000

I also think it is important that we should be able to work between devices.

However the devices I want to work between are webRTC devices and SIP devices, and other devices that are currently using video codecs.

Unfortunately we seem to have got the mandatory to implement video codec stated in the charter (without any thought or real discussion in my view of the implications), but every suggestion that we need requirements to interwork with existing infrastructure has been shouted down by certain groups. However that does not mean that there is consensus not to do this, just that there is no position.

Yes one can deploy infrastructure to do transcoding, but inherently that costs (and why should one force the cost to be on someone wanting to interwork with existing infrastructure), and potentially loses video quality (and should therefore be reserved for where one wants to conference different codecs together rather than on end to end sessions).

So fundamentally we are trying to address the wrong set of documented requirements.

Regards

Keith

P.S. And I did ask a few messages back which documents the chairs want to work on with higher priority, and I have had no response. So obviously they only want the WG to work on video codec MTI.

> From: rtcweb [mailto:[email-masked]] On Behalf Of 
> Cullen Jennings (fluffy)
> Sent: 12 December 2013 01:10
> To: Matthew Kaufman (SKYPE)
> Cc: [email-masked]; [email-masked]
> Subject: [rtcweb] Why the Straw Poll
> 
> 
> Let me try and answer what I think is your central issue here 
> which is: why are we spending any time on this topic. 
> 
> We have heard from a significant number of people that they 
> think it is important for WebRTC devices and applicaitons to 
> be able to know that video will work between devices. It was 
> the number one requested item when speaking to the various 
> developers with products demonstrated at WebRTC Expo and a 
> significant issue on this email list. It is one of the 
> several topics the chairs are driving forward. We plan to 
> continue to do try to drive it to resolution. Note resolution 
> includes consensus for no MTI. 
> 
> However, we perfectly well understand that you, or others, 
> may not want to spend time on the video MTI issue. Feel free 
> to ignore the email threads if you believe the outcome is 
> inevitable and put your time into some of the other things we 
> are also driving forward. 
> 
> Cullen in my co-chair role (and I'm not speaking for my 
> co-chairs but I am pretty sure they also want to drive this 
> issue to resolution) 
> 
> 
> > First, there was a discussion and a call for rough 
> consensus at the last IETF in-person meeting. That call was 
> not continued on the list, instead a lack of consensus was 
> declared at the meeting.
> >  
> > Next, there was a proposal from the chairs to vote in a 
> particular way, and a call for options on which to vote. It 
> was claimed at that time that after the list was compiled, 
> the act of taking such a vote would be taken to a consensus 
> call. That never happened.
> >  
> > Instead the chairs are now conducting a "straw poll" of 
> their own design, clearly in an effort to circumvent some 
> very specific objections to the proposed instant-runoff vote 
> with restricted participation. But again, instead of 
> attempting to reach WG consensus for conducting such a poll, 
> it has simply been foisted upon us.
> >  
> > I have not seen ANY replies to the message "Next Steps in 
> Video Codec Selection Process" that indicate working group 
> consensus of ANY KIND for conducting a poll in this format at 
> this time or to follow the subsequent steps described in that message.
> >  
> _______________________________________________
> rtcweb mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtcweb
>