Subject: WG Chair as author of WG document

From: SM <[email-masked]>
Date: Fri, 20 Dec 2013 01:51:52 -0800

Hello,

 From draft-dhesikan-tsvwg-rtcweb-qos-00:

   [A WG Chair] "was one of the authors of this text in the original
   individual submission but was unceremoniously kicked off by the
   chairs when it became a WG version."

Is that the practice nowadays?

Regards,
-sm

---

From: Ted Lemon <[email-masked]>
Date: Fri, 20 Dec 2013 06:51:18 -0500

> Is that the practice nowadays?

No, and I suspect the text you are quoting is tongue-in-cheek. :)

It is preferable that WG chairs chair, and document authors auth, but there is no requirement to that effect.

---

From: Jari Arkko <[email-masked]>
Date: Fri, 20 Dec 2013 14:46:56 +0200

There is no hard and fast rule. Indeed many WG chairs have work or personal interest in the area of the group (how could it be otherwise?) and occasionally write drafts.

However, the preference is not to be an author. In particular, if you are an author you should not be the chair deciding or document shepherding about the topic. This is one reason why we have multiple chairs. 

In general, it is easy to get into a situation where it is difficult to progress a document because all the parties who should do something about the document are recused due to being authors. Having other people hold the pen and the chairs doing their chair job is a far better model.

Jari

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 20 Dec 2013 13:16:27 +0000

Hi,

> In general, it is easy to get into a situation where it is difficult to progress a document because all the parties who should do something about the document are recused due to being authors. 

We have a recent example of this in the WG that I co-chair. 

Regards,

Christer

---

From: Stephen Kent <[email-masked]>
Date: Fri, 20 Dec 2013 09:26:35 -0500

no. When my co-chair was a doc author, he recused himself from managing the
WG discussion and the IESG writeup process. no problem. But, I personally
believe a WG chair should not be a doc author (within the WG) very often.

Steve

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 20 Dec 2013 09:45:52 -0500

> believe a WG chair should not be a doc author (within the WG) very often.

I was just about to raise that as an example.

I don't often volunteer to chair working groups I plan to participate in
because I expect to either write documents or be very vocal in pushing for
a particular direction.

But when I did chair a working group there were often times when it would
be far easier to write the damn document myself than get someone else to do
it. Not for the core WG items but for pieces like media registrations for
work in other venues.

-- 
Website: http://hallambaker.com/

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Dec 2013 16:36:24 +0100

On 20 Dec 2013, at 15:45, Phillip Hallam-Baker <[email-masked]> wrote:

> But when I did chair a working group there were often times when it would be far easier to write the damn document myself than get someone else to do it.

This.

Now there still is a point in investing a little more work to get others to do the work:
More eyeballs see more issues, adding to the gene pool etc.

But there is a limit to how far this takes, and a policy that entirely forbids WG chairs from generating documents will just make sure that people competent in the subject can no longer be WG chairs.

Grüße, Carsten

PS.: And, as always in the IETF, every WG is different; what works well for, say, DICE may not be the right thing for, say, TLS.

---

From: Dave Crocker <[email-masked]>
Date: Fri, 20 Dec 2013 08:49:50 -0800

On 12/20/2013 4:46 AM, Jari Arkko wrote:
> However, the preference is not to be an author. In particular, if you
> are an author you should not be the chair deciding or document
> shepherding about the topic. This is one reason why we have multiple
> chairs.
>
> In general, it is easy to get into a situation where it is difficult
> to progress a document because all the parties who should do
> something about the document are recused due to being authors. Having
> other people hold the pen and the chairs doing their chair job is a
> far better model.

On 12/20/2013 7:36 AM, Carsten Bormann wrote:
 > But there is a limit to how far this takes, and a policy that
 > entirely forbids WG chairs from generating documents will just make
 > sure that people competent in the subject can no longer be WG
 > chairs.

The flexibility of the model for IETF working group management means 
that it can be tailored to the situation.  The problem with this is that 
it requires careful thought and sometimes-painful candor.  The 
trade-offs are between management complexity versus group efficiency.

In one extreme, a small, cohesive group, which has deep understanding of 
the work to be done, will probably function smoothly almost independent 
of who is running the group.  Having the chair be an author in such a 
case usually goes well.

In the other extreme, a large, divisive group working on a difficult 
topic needs extremely careful management.  This means both the choice of 
chairs and authors and they way they behave needs to be calculated with 
attention to avoiding problems while also making forward progress.

Remember that the ultimate goal of an IETF effort is community /use/ of 
what is produced.  Merely getting a document published isn't the 
important accomplishment.  Having the community use it is.  The ultimate 
point behind rough consensus is to develop the support that makes that 
use likely.

At the outset of a working group, these concerns require considering 
what is known about the group that is likely to participate, what is 
known about any current authors, what is known about potential chairs, 
and what is known about the work to be done.  Any indications of 
technical complexity or political or personal challenges makes it 
advisable to set up the working group with assignments that are more 
pristine and possibly less "convenient".

In other words, greater working group risk requires narrower working 
group management roles.

Changing authors, as a document is adopted, is merely one of the ways to 
attend to these issues.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 20 Dec 2013 19:13:06 +0100

It is ok to change authors when adopted or after, but I don't agree to do
changes on adopted big points of the work, even a DT (requested through
chairs or AD) should not directly change the adopted work only after
WG agreement. The chair should make sure no big point changes occur until
the WG agrees, even if he/she authored it.

AB

On Friday, December 20, 2013, Dave Crocker wrote:

> The flexibility of the model for IETF working group management means that
> it can be tailored to the situation.  The problem with this is that it
> requires careful thought and sometimes-painful candor.  The trade-offs are
> between management complexity versus group efficiency.
>
> the work to be done, will probably function smoothly almost independent of
> who is running the group.  Having the chair be an author in such a case
> usually goes well.
>
> In the other extreme, a large, divisive group working on a difficult topic
> needs extremely careful management.  This means both the choice of chairs
> and authors and they way they behave needs to be calculated with attention
> to avoiding problems while also making forward progress.
>
> what is produced.  Merely getting a document published isn't the important
> accomplishment.  Having the community use it is.  The ultimate point behind
> rough consensus is to develop the support that makes that use likely.
>
> At the outset of a working group, these concerns require considering what
> is known about the group that is likely to participate, what is known about
> any current authors, what is known about potential chairs, and what is
> known about the work to be done.  Any indications of technical complexity
> or political or personal challenges makes it advisable to set up the
> working group with assignments that are more pristine and possibly less
> "convenient".
>
> In other words, greater working group risk requires narrower working group
> management roles.
>

---

From: Scott Brim <[email-masked]>
Date: Fri, 20 Dec 2013 13:52:52 -0500

On rare occasions someone is simultaneously AD/Chair/Author 8-O

---

From: SM <[email-masked]>
Date: Fri, 20 Dec 2013 17:38:35 -0800

Hi Christer,
>We have a recent example of this in the WG that I co-chair.

Thanks to everyone who commented.  I wikified the comment at 
http://www.ietf.org/mail-archive/web/ietf/current/msg85055.html and 
unceremoniously credited Jari Arkko and Ted Lemon.  Please feel free 
to edit the text.

Regards,
-sm

---

From: Loa Andersson <[email-masked]>
Date: Sat, 21 Dec 2013 10:24:01 +0800

All,

I think we need to be careful if "changing" is "replacing". Some that have had an impact on a document need to respond e.g. to IPR polls. 

/Loa

Skickat från min iPhone

> 21 dec 2013 kl. 02:13 skrev Abdussalam Baryun <[email-masked]>:
> 
> It is ok to change authors when adopted or after, but I don't agree to do changes on adopted big points of the work, even a DT (requested through chairs or AD) should not directly change the adopted work only after WG agreement. The chair should make sure no big point changes occur until the WG agrees, even if he/she authored it.
> 
> AB
> 
>> The flexibility of the model for IETF working group management means that it can be tailored to the situation.  The problem with this is that it requires careful thought and sometimes-painful candor.  The trade-offs are between management complexity versus group efficiency.
>> 
>> In one extreme, a small, cohesive group, which has deep understanding of the work to be done, will probably function smoothly almost independent of who is running the group.  Having the chair be an author in such a case usually goes well.
>> 
>> In the other extreme, a large, divisive group working on a difficult topic needs extremely careful management.  This means both the choice of chairs and authors and they way they behave needs to be calculated with attention to avoiding problems while also making forward progress.
>> 
>> Remember that the ultimate goal of an IETF effort is community /use/ of what is produced.  Merely getting a document published isn't the important accomplishment.  Having the community use it is.  The ultimate point behind rough consensus is to develop the support that makes that use likely.
>> 
>> At the outset of a working group, these concerns require considering what is known about the group that is likely to participate, what is known about any current authors, what is known about potential chairs, and what is known about the work to be done.  Any indications of technical complexity or political or personal challenges makes it advisable to set up the working group with assignments that are more pristine and possibly less "convenient".
>> 
>> In other words, greater working group risk requires narrower working group management roles.
>> 
>> Changing authors, as a document is adopted, is merely one of the ways to attend to these issues.
>> 
>> d/
>> 
>> -- 
>> Dave Crocker