Subject: Chang'E 3

From: Michael Richardson <[email-masked]>
Date: Sat, 14 Dec 2013 19:33:30 -0500

The rover landing is rather exciting.
I'm wondering what the communication(s) protocol back to earth is.

(I'm hoping the answer will be MPTCP over IPv6 w/IPsec... )

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting for hire =-

---

From: <[email-masked]>
Date: Sun, 15 Dec 2013 01:01:56 +0000

http://spaceops2012.com/proceedings/documents/id1275505-Paper-001.pdf

Chinese Lunar missions Chang’E-1 and Chang’E-2 and the ESOC support: an example of systems interoperability
G. Billig, E. Sørensen,
European Space Operations Centre, Darmstadt
Xi Luhua
Beijing Aerospace Control Centre, Beijing

CCSDS has a legacy lock on the space domain.
The SLE space link extension is a TCP tunnel carrying link frames across the intenet for processing; doesn't work well at high rates.

Lloyd Wood
http://sat-net.com/L.Wood/dtn/interplanetary-internet.html

________________________________________
From: ietf [[email-masked]] On Behalf Of Michael Richardson [[email-masked]]
Sent: 15 December 2013 00:33
To: [email-masked]
Subject: Chang'E 3

---

From: <[email-masked]>
Date: Sun, 15 Dec 2013 04:17:09 +0000

...and the only TCP/IPv6/IPsec is space I'm aware of is described at
http://personal.ee.surrey.ac.uk/Personal/L.Wood/cleo/ipv6-in-space/

Lloyd Wood
http://sat-net.com/L.Wood/

---

From: Michael Richardson <[email-masked]>
Date: Tue, 24 Dec 2013 14:10:27 -0500

Thanks for the papers.
I read them... the systems interop paper didn't tell me much about the
underlying protocols, but at least I have some names I can google.

I wonder if the IETF 89 London Technical plenary would be interested in a
talk from you on interplanetary internet.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: <[email-masked]>
Date: Tue, 24 Dec 2013 19:42:25 +0000

Unlikely; as my views on interplanetary internet are someewhat  at odds with that of DTNRG.
And London is very a long way from where I work in the Pacific.

http://saratoga.sf.net was presented to TSVAREA at the last IETF.

Lloyd Wood
http://sat-net.com/L.Wood/dtn

________________________________________
From: [email-masked] [[email-masked]]
Sent: 24 December 2013 19:10
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]
Subject: Re: Chang'E 3

Thanks for the papers.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 24 Dec 2013 15:46:29 -0500

> Unlikely; as my views on interplanetary internet are someewhat  at odds with that of DTNRG.

Well, diverse opinions are sometimes good,

    > And London is very a long way from where I work in the Pacific.

I assumed, that you were at SSTL in the UK :-)

---

From: <[email-masked]>
Date: Wed, 25 Dec 2013 08:44:44 +0000

I have never worked for SSTL.

Lloyd Wood

________________________________________
From: [email-masked] [[email-masked]]
Sent: 24 December 2013 20:46
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]
Subject: Re: Chang'E 3

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 26 Dec 2013 17:40:07 +0100

Transport protocol for satellites depend on the applications, the network
dynamics, links and transmission channels. IMO the use of MPTCP for
Back2Earth may not be the best option making the communication complex, not
sure why did you hope to use it with this project.

AB

---

From: <[email-masked]>
Date: Fri, 27 Dec 2013 01:52:28 +0000

TCP won't work well from the Moon to Earth - slow start, congestion backoff as a reaction to lost/errored frames, makes for inefficient use of the space link. (And TCP may be a larger codebase than you want on an embedded system running on a constrained radhard processor)

We explored TCP's distance limitations in
http://personal.ee.surrey.ac.uk/Personal/L.Wood/publications/index.html#protocol-radius
Lloyd Wood, Cathryn Peoples, Gerard Parr, Bryan Scotney, Adrian Moore, TCP's protocol radius: the distance where timers prevent communication, Proceedings of the International Workshop on Space and Satellite Communications (IWSSC '07), Salzburg, Austria, 13-14 September 2007, pp. 163-167.

AFAIK vanilla ftp/TCP has (only?) been used on CHIPsat from LEO, but that did not have much data to transfer.

We designed http://saratoga.sf.net with the idea of a continuous UDP stream of data from Pluto in mind...

Lloyd Wood

________________________________________
From: ietf [[email-masked]] On Behalf Of Abdussalam Baryun [[email-masked]]
Sent: 26 December 2013 16:40
To: Michael Richardson
Cc: [email-masked]
Subject: Chang'E 3

Transport protocol for satellites depend on the applications, the network dynamics, links and transmission channels. IMO the use of MPTCP for Back2Earth may not be the best option making the communication complex, not sure why did you hope to use it with this project.

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 27 Dec 2013 07:01:42 +0100

So if TCP has problems then MPTCP has problems then they may not be
preferred for that satellite networking. For LEO SATNETs also there are
problems for using TCP. The UDP is a good solution in general but not
efficient, but always I think the SATNETs may need some special
internet transport protocols because they are having more dynamics in the
net's lower layers.

AB

On Friday, December 27, 2013, wrote:

> TCP won't work well from the Moon to Earth - slow start, congestion
> backoff as a reaction to lost/errored frames, makes for inefficient use of
> the space link. (And TCP may be a larger codebase than you want on an
> embedded system running on a constrained radhard processor)
>
> Lloyd Wood, Cathryn Peoples, Gerard Parr, Bryan Scotney, Adrian Moore,
> TCP's protocol radius: the distance where timers prevent communication,
> Proceedings of the International Workshop on Space and Satellite
> Communications (IWSSC '07), Salzburg, Austria, 13-14 September 2007, pp.
> 163-167.
>
> From: ietf [[email-masked] <javascript:;>] On Behalf Of Abdussalam
> Baryun [[email-masked] <javascript:;>]
> Cc: [email-masked] <javascript:;>
> Subject: Chang'E 3
>
> Michael Richardson <[email-masked] <javascript:;>>, Sandelman
> Software Works

---

From: <[email-masked]>
Date: Fri, 27 Dec 2013 11:29:44 +0000

AB

The Moon is arguably a satellite of Earth, but the distances are different from LEO and GEO. That affects TCP performance.

TCP was designed with geostationary satellite hops in mind - see eg RFC829. I use TCP across geostationary satellites daily.

I back up my statements with experience and references. What do you back yours with? Why is UDP inefficient?

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Abdussalam Baryun [[email-masked]]
Sent: 27 December 2013 06:01
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]; [email-masked]
Subject: Re: Chang'E 3

So if TCP has problems then MPTCP has problems then they may not be preferred for that satellite networking. For LEO SATNETs also there are problems for using TCP. The UDP is a good solution in general but not efficient, but always I think the SATNETs may need some special internet transport protocols because they are having more dynamics in the net's lower layers.

AB

Lloyd Wood

________________________________________
From: ietf [[email-masked]<javascript:;>] On Behalf Of Abdussalam Baryun [[email-masked]<javascript:;>]
Sent: 26 December 2013 16:40
To: Michael Richardson
Cc: [email-masked]<javascript:;>
Subject: Chang'E 3

AB

--
Michael Richardson <[email-masked]<javascript:;>>, Sandelman Software Works
 -= IPv6 IoT consulting for hire =-

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 27 Dec 2013 23:31:53 +0100

I was discussing/commenting on the subject as the thread
did about using space internet protocols on satellites, still no standards
for space.

AB

On Friday, December 27, 2013, wrote:

> AB
>
> The Moon is arguably a satellite of Earth, but the distances are different
> from LEO and GEO. That affects TCP performance.
>
> TCP was designed with geostationary satellite hops in mind - see eg
> RFC829. I use TCP across geostationary satellites daily.
>
> From: Abdussalam Baryun [[email-masked] <javascript:;>]
> Cc: [email-masked] <javascript:;>; [email-masked] <javascript:;>
> Subject: Re: Chang'E 3
>
> efficient, but always I think the SATNETs may need some special internet
> transport protocols because they are having more dynamics in the net's
> lower layers.
>
> AB
>
>
> From: ietf [[email-masked] <javascript:;><javascript:;>] On Behalf
> Of Abdussalam Baryun [[email-masked] <javascript:;>
> <javascript:;>]
> Cc: [email-masked] <javascript:;><javascript:;>
> Subject: Chang'E 3
>

---

From: <[email-masked]>
Date: Fri, 27 Dec 2013 23:57:08 +0000

AB

The people who have spent decades working in CCSDS, who developed and standardised the SCPS stack based on TCP/IP, who developed and standardised CFDP (which runs over TCP/IP), and who are currently standardising the bundle protocol as the latest effort to get space to adopt networking, would, of course, strongly disagree with your statement that there are still no standards for space.

http://en.wikipedia.org/wiki/CCSDS
http://public.ccsds.org/publications/archive/714x0b2.pdf
http://public.ccsds.org/publications/archive/727x0b2s.pdf
http://public.ccsds.org/sites/cwe/rids/Lists/CCSDS%207342R2/Attachments/734x2r2.pdf
But what do they know?

The ETSI group who standardised satellite communication and carriage of IP traffic with DVB-S2 (and extensions) and DVB-RCS , would, of course, strongly disagree with your statement that there are still no standards for space. 
http://www.etsi.org/technologies-clusters/technologies/satellite/
But what do they know?

Again, I'm backing my statements with references, so that they are not merely unsupported assertions.  (And why is UDP inefficient?)

Lloyd Wood
Sent: 27 December 2013 22:31

I was discussing/commenting on the subject as the thread did about using space internet protocols on satellites, still no standards for space.

AB

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Abdussalam Baryun [[email-masked]<javascript:;>]
Sent: 27 December 2013 06:01
To: Wood L  Dr (Electronic Eng)
Cc: [email-masked]<javascript:;>; [email-masked]<javascript:;>
Subject: Re: Chang'E 3

AB

Lloyd Wood

________________________________________
From: ietf [[email-masked]<javascript:;><javascript:;>] On Behalf Of Abdussalam Baryun [[email-masked]<javascript:;><javascript:;>]
Sent: 26 December 2013 16:40
To: Michael Richardson
Cc: [email-masked]<javascript:;><javascript:;>
Subject: Chang'E 3

AB

---

From: "Jiankang Yao" <[email-masked]>
Date: Mon, 30 Dec 2013 17:42:05 +0800

it is a interesting topic. ietf protocols may be extended to space.

Jiankang Yao

From: Abdussalam Baryun
Date: 2013-12-28 06:31
To: [email-masked]
CC: [email-masked]; [email-masked]
Subject: Re: Chang'E 3
I was discussing/commenting on the subject as the thread did about using space internet protocols on satellites, still no standards for space. 

AB

AB

Lloyd Wood

AB

Lloyd Wood

AB

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 30 Dec 2013 11:18:22 +0100

I agree with you. I wanted to discuss this because other organisations are
trying to standard for space, and this thread started a discussion as if
MPTCP is good option, or as if IETF has the solution, and I know IETF still
not standard space protocols, but if I was requested to discuss with
references, I only like to reference IETF works, so I will need some time
to find them and discuss with argument because some problems not solved
yet. I will try to reply to the request because I want to extend the
discussion to bring more interest in IETF.

AB

On Monday, December 30, 2013, Jiankang Yao wrote:

> ------------------------------
> Jiankang Yao
>
>  *From:* Abdussalam Baryun <javascript:_e({}, 'cvml',
> [email-masked]');>
> *Date:* 2013-12-28 06:31
> *To:* [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>
> *CC:* [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>; [email-masked] <javascript:_e({}, 'cvml',
> [email-masked]');>
> *Subject:* Re: Chang'E 3
>> The Moon is arguably a satellite of Earth, but the distances are
>> different from LEO and GEO. That affects TCP performance.
>>
>> From: ietf [[email-masked]<javascript:;>] On Behalf Of Abdussalam
>> Baryun [[email-masked]<javascript:;>]

---

From: <[email-masked]>
Date: Mon, 30 Dec 2013 12:15:53 +0000

jiankang,

i agree it is interesting. and that is why we have spent the last ten years on extending the internet to space, and running ietf protocols in space.
http://personal.ee.surrey.ac.uk/Personal/L.Wood/cleo
http://personal.ee.surrey.ac.uk/Personal/L.Wood/dtn

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: Jiankang Yao [[email-masked]]
Sent: 30 December 2013 09:42
To: Abdussalam Baryun; Wood L  Dr (Electronic Eng)
Cc: ietf
Subject: Re: Re: Chang'E 3

________________________________
Jiankang Yao

From: Abdussalam Baryun<mailto:[email-masked]>
Date: 2013-12-28 06:31
To: [email-masked]<mailto:[email-masked]>
CC: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Chang'E 3
I was discussing/commenting on the subject as the thread did about using space internet protocols on satellites, still no standards for space.

AB

Lloyd Wood

AB

Lloyd Wood

AB