Subject: Re: https at ietf.org

From: Doug Barton <[email-masked]>
Date: Thu, 05 Dec 2013 23:12:39 -0800

On 11/05/2013 04:34 PM, Tim Bray wrote:
> Wouldn’t it be a good idea for everything at *.ietf.org
> <http://ietf.org> to be served by HTTPS, and only by HTTPS?

Having read the thread, some thoughts for what they are worth.

IMO, as long as the substance of the RFCs themselves (and other 
appropriate material) are available over some channel that does not 
require encryption (say FTP for instance) I don't see any reason not to 
force https instead of http on IETF-related web sites. As others have 
pointed out however most resources are already available via https, so 
as a community we should probably be advertising that more widely, 
including using the https link wherever possible.

On a more practical level, I use the excellent Firefox search plugin for 
the tools site which is number 5 on the list here: 
http://mycroftproject.com/search-engines.html?name=rfc

It does this for searches (after my modification to use https):
https://tools.ietf.org/html/{searchTerms}

However when the results come back it's on an http page, instead of 
https. It would be nice if that redirect either always used https, or 
used https if it were called that way.

hth,

Doug

---

From: Warren Kumari <[email-masked]>
Date: Fri, 6 Dec 2013 14:23:49 -0500

On Dec 6, 2013, at 2:12 AM, Doug Barton <[email-masked]> wrote:

> IMO, as long as the substance of the RFCs themselves (and other appropriate material) are available over some channel that does not require encryption (say FTP for instance) I don't see any reason not to force https instead of http on IETF-related web sites. As others have pointed out however most resources are already available via https, so as a community we should probably be advertising that more widely, including using the https link wherever possible.
> 
> On a more practical level, I use the excellent Firefox search plugin for the tools site which is number 5 on the list here: http://mycroftproject.com/search-engines.html?name=rfc
> 
> However when the results come back it's on an http page, instead of https. It would be nice if that redirect either always used https, or used https if it were called that way.

And I have just updated my “Rewrite IETF ID URLs to Tools or Datareacker” Chrome extension to redirect to the ‘https://' versions of pages instead of the http:// ones.

This will rewrite the "official" IETF Internet Draft URLs (http://www.ietf.org/id/foo-42.txt) to the Tools (http://tools.ietf.org/html/foo-42) or Datatracker (http://datatracker.ietf.org/docs/foo) versions instead.

It was originally written back when the ID Announce (and similar) emails didn’t include links to the more friendly formats, but a number of folk find it useful. 

W

-- 
There are only 10 types of people in this world -- those who understand binary arithmetic and those who don't.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 08 Dec 2013 12:57:13 -0500

Warren Kumari <[email-masked]> wrote:
    > This will rewrite the "official" IETF Internet Draft URLs
    > (http://www.ietf.org/id/foo-42.txt) to the Tools
    > (http://tools.ietf.org/html/foo-42) or Datatracker
    > (http://datatracker.ietf.org/docs/foo) versions instead. 

In particular, it means that I can click on any link that arrives, and get
the link that I like to read best, and is easiest to "save to pocket"
which is an offline/tablet happy document reader.  (used to be called
"readitlater.com")

sadly, the reader is missing speed-reader options to force the scroll, and
it also has no ability to markup... but it does work on an airplane and
at a desktop.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works