Subject: Re: draft discussion lists

From: Eliot Lear <[email-masked]>
Date: Mon, 01 Sep 2014 20:25:31 +0200

On 9/1/14, 7:58 PM, Michael StJohns wrote:
> We seem to be getting  (or I seem to be noticing) a lot more drafts that aren't associated with a specific working group, or are pre-WG adoption. I'm finding myself at a loss for where to go on some of these to "discuss" that isn't off-topic for whatever list I might be directed to.  
>
>
>
>
> How about 

[all of that]...

Or actually using our working group process?

---

From: manning bill <[email-masked]>
Date: Mon, 1 Sep 2014 11:34:45 -0700

> Or actually using our working group process?

Well then you’d have to rein in the IAB… :)

There was a period of time when drafts included a pointer to the mailing list where discussion was expected to take place.
That useful bit of capability was dropped in the advance of progress.  It was determined that pre-WG discussions would usually 
get lost in transition to IETF sponsored lists, so everything should occur on IETF sponsored lists…  which never happens.  :)

/bill

---

From: Dave Cridland <[email-masked]>
Date: Mon, 1 Sep 2014 19:38:28 +0100

On 1 September 2014 19:25, Eliot Lear <[email-masked]> wrote:

> > We seem to be getting  (or I seem to be noticing) a lot more drafts that
> aren't associated with a specific working group, or are pre-WG adoption.
> I'm finding myself at a loss for where to go on some of these to "discuss"
> that isn't off-topic for whatever list I might be directed to.
> >
> >
> >
> >
> > How about
>
> [all of that]...
>
>
So we'll only discuss ideas that are written up as drafts, and we'll only
discuss them in a working group, and we'll only create a working group
around drafts that have traction, and we'll only consider a draft to have
traction if there's discussion, and we'll only discuss them in a working
group, and ...

Dave.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 01 Sep 2014 21:15:50 +0200

Dave,

On 9/1/14, 8:38 PM, Dave Cridland wrote:
>
> So we'll only discuss ideas that are written up as drafts, and we'll
> only discuss them in a working group, and we'll only create a working
> group around drafts that have traction, and we'll only consider a
> draft to have traction if there's discussion, and we'll only discuss
> them in a working group, and ...
>

Only is a bit much, but the point was that a number of important
documents DIDN'T use the WG process, and it turned into a mess.

Eliot

---

From: Dave Cridland <[email-masked]>
Date: Mon, 1 Sep 2014 20:34:33 +0100

On 1 September 2014 20:15, Eliot Lear <[email-masked]> wrote:

> only discuss them in a working group, and we'll only create a working group
> Only is a bit much, but the point was that a number of important documents
> DIDN'T use the WG process, and it turned into a mess.
>
>
I don't disagree, I'm just saying that if you enforce a set of mutually
exclusive conditions, you end up with an exclusive system. I'd suggest we
should be aiming to make it easy to bring new ideas to the table, even when
this does cause some noise.

The problem is that even the area-level working groups have to positively
adopt new drafts. I don't know the numbers of ad-sponsored, and pre-WG
drafts there are, but if they were effectively forced onto an area-level
working group as a working group of last resort, and would just die on the
vine if there was no interest, then there would always be a discussion
venue.

And no, I'm not saying that's a perfect solution.

Dave.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Sep 2014 08:29:21 +1200

On 02/09/2014 07:34, Dave Cridland wrote:
...
> And no, I'm not saying that's a perfect solution.

Nevertheless, for drafts that clearly belong to an area, it's much better
than nothing. And *this* list ought to be the place for drafts or ideas
that really don't fit naturally into any single area. You might even think
that the most innovative and unconventional ideas that only belong here
are exactly the most important ones.

(On a practical note, when I have occasion to react to a random draft
that doesn't indicate a discussion venue, I ask the authors "Where is
this being discussed?")

    Brian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 1 Sep 2014 16:39:10 -0500

On one point ...

On Mon, Sep 1, 2014 at 1:34 PM, manning bill <[email-masked]> wrote:

> >> We seem to be getting  (or I seem to be noticing) a lot more drafts
> that aren't associated with a specific working group, or are pre-WG
> adoption. I'm finding myself at a loss for where to go on some of these to
> "discuss" that isn't off-topic for whatever list I might be directed to.
> >>
> >>
> >> How about
> >
> > [all of that]...
> >
> >
> There was a period of time when drafts included a pointer to the mailing
> list where discussion was expected to take place.
> That useful bit of capability was dropped in the advance of progress.  It
> was determined that pre-WG discussions would usually
> get lost in transition to IETF sponsored lists, so everything should occur
> on IETF sponsored lists…  which never happens.  :)
>
>
I just checked with my fellow ADs, and haven't found anyone who's closely
vetting requests for mailing lists that we see submitted using the
procedure at the bottom of http://www.ietf.org/list/nonwg.html. I'd like
for the mailing list topics to be IETF related (or at least Internet
related), but that's the only thing I look at.

Please let us know if you have a problem requesting a non-WG mailing list.

Thanks,

Spencer, as AD

tl;dr :

I wasn't there at the time, but my understanding was that the non-WG
mailing list procedure was put in place for a few reasons, including these:

We had mailing lists (including working group mailing lists!) that were
hosted at domains that were no longer in use. This made chasing archives
complicated.

Not all IETF participants had an obvious place to create non-WG mailing
lists.

When non-WG mailing list topics morphed into WG mailing list topics, we
hoped people would have been aware of the IETF IPR policy, duty to
disclose, etc.

All of those problems return if we're restrictive about approving non-WG
mailing lists.

---

From: Nico Williams <[email-masked]>
Date: Mon, 1 Sep 2014 17:57:52 -0500

> documents DIDN'T use the WG process, and it turned into a mess.

I recall that BTNS WG was as difficult to get spun up as opportunistic
security (OS) was to get in front of the IESG w/o a WG.

The benefit of a WG is that once you have a charter the debate on that
ends.  But for something like OS the result would undoubtedly have been:
more wasted energy, more time to publish.  (It'd have taken much longer
to get to published state.  First we'd have needed a BoF.  Or two.  And
charter bashing.  We'd have to have found a WG chair(s).  We'd have to
have had the exact same discussions we already had.  If at the end of
WGLC people in the rough were passionate enough we'd have had more of
the same on [email-masked].  What would have been the benefit?

A WG would have to have had a more ambitious remit to be worthwhile.
Such as applying OS to a variety of application protocols... that are
currently the remit of other existing WGs, thus necessitating a lot more
negotiation.

If the issue here is that not using a WG means cluttering [email-masked],
well, we could separate IETF LCs from other topics.  But really, we
still need IETF LCs, and there's often going to be a lot of discussion.

Nico
--

---

From: Julian Reschke <[email-masked]>
Date: Tue, 02 Sep 2014 08:13:46 +0200

> that doesn't indicate a discussion venue, I ask the authors "Where is

+1

I actually believe this should be a required part of an internet draft.

Best regards, Julian

---

From: Melinda Shore <[email-masked]>
Date: Mon, 01 Sep 2014 22:37:42 -0800

> I actually believe this should be a required part of an internet draft.

I find myself being reflexively anti-new-process-requirements these
days.  Be that as it may, I was doing the librarianship thing during
a time when open vs. closed stacks was a highly contested question,
and one argument that was reliably and inevitably advanced in favor of
open stacks was that of the value of "tripping over a book in the
stacks."  That is to say, there were a lot of people who felt there
was value in introducing some (pseudo-) randomness into the process,
such that a person looking for information on a particular topic
accidentally came across something unrelated and it triggered something
innovative.  In the IETF context I do worry a bit that
overspecialization and "silos" are leading to situations in which
we're missing connections and related but perhaps orthogonal work.
I see that happening quite a bit on middlebox-related topics and I'm
suspicious that peeling nearly all draft discussion off a general
mailing list might lead to an increase in missed connections.

Many people have pointed this out before me, and I hope many will
after me because I think it's a serious concern.

Melinda

---

From: Michael Richardson <[email-masked]>
Date: Tue, 02 Sep 2014 09:27:31 -0400

Melinda Shore <[email-masked]> wrote:
    > days.  Be that as it may, I was doing the librarianship thing during a
    > time when open vs. closed stacks was a highly contested question, and
    > one argument that was reliably and inevitably advanced in favor of open
    > stacks was that of the value of "tripping over a book in the stacks."
    > That is to say, there were a lot of people who felt there was value in
    > introducing some (pseudo-) randomness into the process, such that a
    > person looking for information on a particular topic accidentally came
    > across something unrelated and it triggered something innovative.  In
    > the IETF context I do worry a bit that overspecialization and "silos"
    > are leading to situations in which we're missing connections and
    > related but perhaps orthogonal work.  I see that happening quite a bit
    > on middlebox-related topics and I'm suspicious that peeling nearly all
    > draft discussion off a general mailing list might lead to an increase
    > in missed connections.

I rather agree.  I would prefer that a random draft, if it doesn't have *WG*
in it, ought to have *AREANAME*, and the appropriate area list is the right
place.
We already have [email-masked] alias as well, but that's not an
open, archived list.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 2 Sep 2014 11:16:28 -0400

I don't think we need yet more mailing lists. Maybe it is just my
perception but it feels to me like there has been an explosion in the
number of non-WG mailing lists, most of which die due to lack of
participation.

Many drafts do have text up front on the first or second page inviting
comments to be set to some named mailing list or, alternatively, to
the authors. Requiring a "send comments to:" line in the first page
head or the like seems pretty reasonable to me.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 2 Sep 2014 23:35:22 +0000

On Sep 2, 2014, at 4:38 AM, Dave Cridland <[email-masked]> wrote:

> So we'll only discuss ideas that are written up as drafts, and we'll only discuss them in a working group, and we'll only create a working group around drafts that have traction, and we'll only consider a draft to have traction if there's discussion, and we'll only discuss them in a working group, and ...

No. But if someone takes the time to write a draft, Mike wants us to provide a place to discuss it. From my perspective, that isn’t silly.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 04:07:28 +0000

On Sep 2, 2014, at 3:58 AM, Michael StJohns <[email-masked]> wrote:

> 1) automatically creating a "discuss" list for each draft as it's published (separate from the send-to-authors address)
> 
> 2) providing a link to enroll in such list as part of the draft announcement and on the tracker page.
> 
> 3) providing tools for owners of the other lists (e.g. the working group list) to "adopt" the draft discuss email address either when the draft is adopted as a WG item, or if the wg deems the draft to be on-topic or better discussed by a wider audience.  If adopted, retain the email tagging of the email as a discussion on a particular draft.  Adoption should merge the subscription lists for the purpose of posting to the list.
> 
> 4) providing area-wide mailing lists (e.g. [email-masked], [email-masked]) etc for discussions less focused than appropriate for a WG but more focused than the IETF mailing list.  These should be different than the lists for the area advisory groups such as SAAG.   Have closed/ended WG emails default/merge to that mailing list if there isn't a reason to retain a separate list.
> 
> 
> Part of the above is a desire to segment the conversations a bit more than we're currently doing so as to reduce the noise level.  Part of it is to provide tools (e.g. markings that identify something that's specifically a draft discussion from that of being a WG discussion) for filtering on receipt.
> 
> Later, Mike

We actually do have several area-wide lists, such as appsarea@ and rtgwg@.

As of today, I see 1879 internet drafts. Of those, 1428 are named for working groups.

The place I primarily see not-wg-names is irtf drafts (draft-irtf-nmrg-an-gap-analysis), IAB drafts (draft-iab-doi), drafts from old working groups or non-wg lists (draft-tsou-behave-natx4-log-reduction), drafts whose authors haven’t decided what working group they target (draft-welzl-ecn-benefits, which could be in aqm or tsvwg) or are building towards what someone hopes will be such a group, and some where someone fat-fingered the name of a working group. There are at least some where someone is simply bringing up a topic (draft-wierenga-ietf-eduroam or draft-secretaries-good-practices). 

When I see a draft that is named draft-*-v6ops-*-00.txt, I have a bot that sends a note to v6ops@ to encourage folks to read and discuss it. I could imagine a bot at IETF central that did the same thing - when a -00 draft is posted and one of the “words” in its name corresponds to the name of a mailing list, the list is copied on the announcement. What folks do with it is up to them, of course; in our case, if the working group doesn’t say anything or uniformly pans it, the chairs assume it’s not interesting, and if folks say “hey, there’s something interesting here”, OK, it’s interesting. One way that *could* work would be that the upload tool prepopulates some field with the name of a mailing list, and if it doesn’t come up with one, forces the author to identify one or more mailing lists s/he would like notified. I know of at least some folks that file a draft and feel disappointed that nobody commented on it, but didn’t know to take that step. OK, this would make sure the step got taken.

---

From: Nico Williams <[email-masked]>
Date: Tue, 2 Sep 2014 23:14:44 -0500

On Wed, Sep 03, 2014 at 04:07:28AM +0000, Fred Baker (fred) wrote:
> The place I primarily see not-wg-names is irtf drafts
> (draft-irtf-nmrg-an-gap-analysis), IAB drafts (draft-iab-doi), drafts
> from old working groups or non-wg lists
> (draft-tsou-behave-natx4-log-reduction), drafts whose authors haven’t
> decided what working group they target (draft-welzl-ecn-benefits,
> which could be in aqm or tsvwg) or are building towards what someone
> hopes will be such a group, and some where someone fat-fingered the
> name of a working group. There are at least some where someone is
> simply bringing up a topic (draft-wierenga-ietf-eduroam or
> draft-secretaries-good-practices). 

A lot of WGs and WG work items start life as individual submission I-Ds.
The tracker nowadays tracks their transformation into WG work items.

Nico
--

---

From: Dave Crocker <[email-masked]>
Date: Tue, 02 Sep 2014 21:12:34 -0700

On 9/2/2014 9:07 PM, Fred Baker (fred) wrote:
> When I see a draft that is named draft-*-v6ops-*-00.txt, I have a bot that sends a note to v6ops@ to encourage folks to read and discuss it. I could imagine a bot at IETF central that did the same thing - when a -00 draft is posted and one of the “words” in its name corresponds to the name of a mailing list, the list is copied on the announcement.

+1

Simple, entirely implementable and possibly quite useful.

It's likely to encourage folk to declare the venue for discussions.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 04:25:51 +0000

> The tracker nowadays tracks their transformation into WG work items.

yes, but... there are individual submissions and individual submissions.

A draft named “draft-myname-mytopic” is a draft on mytopic submitted by byname. 
A draft named “draft-myname-targetgroup-mytopic” is a draft on mytopic submitted by byname to targetgroup. 

In the first case, the onus is pretty much on the author to get someone to read it. In the second case, assuming a working group or other list is notified, can reasonably expect someone to actually read it.

---

From: Nico Williams <[email-masked]>
Date: Tue, 2 Sep 2014 23:29:27 -0500

> In the first case, the onus is pretty much on the author to get someone to read it. In the second case, assuming a working group or other list is notified, can reasonably expect someone to actually…

Sure, because an individual submission I-D will not be updated once
it's replaced by a WG item, so if the premise is to react to
submissions, that works.

Though even then: it's the submitter's job to get the target WG to
adopt that item or the participants to review it independently of the
WG.  But if you want to help them get that attention, sure, why not.

Nico
--

---

From: John C Klensin <[email-masked]>
Date: Wed, 03 Sep 2014 08:08:43 -0400

--On Wednesday, September 03, 2014 04:25 +0000 "Fred Baker
(fred)" <[email-masked]> wrote:

>> A lot of WGs and WG work items start life as individual
>> submission I-Ds. The tracker nowadays tracks their
>> transformation into WG work items.
> 
> A draft named "draft-myname-mytopic" is a draft on mytopic
> submitted by byname.  A draft named
> "draft-myname-targetgroup-mytopic" is a draft on mytopic
> submitted by byname to targetgroup. 
> 
> In the first case, the onus is pretty much on the author to
> get someone to read it. In the second case, assuming a working
> group or other list is notified, can reasonably expect someone
> to actually read it.

Fred, I think this is a great model and that close
approximations to it have served us well in the past.   However,
since we have gone to an automated system, there is no
enforcement of that naming model, even by takedown, and it is
not even well-publicized.  If we were serious about it, it
should at least be described somewhere (the posting page if
nowhere else), software should make at least a minimal effort to
remind people of it (e.g., when a draft is uploaded who third
component matches a WG or similar acronym, the posting software
might explicitly ask if that targetgroup is an intended target
and, if desired, send out an announcement to that group), and/or
there should be a takedown procedure for documents whose names
deviate from the rules sufficiently to create confusion.

Instead, we have seen
   draft-authorname1-authorname2-targetgroup-mytopic
   draft-crypticacronym-mytopic
   draft-MadeUpOrganization-MadeUpGroup-CrypticTopic
etc., which don't help.

    john

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 12:42:31 +0000

It is described.

http://www.ietf.org/id-info/guidelines.html#naming and Section 7 of http://www.ietf.org/ietf-ftp/1id-guidelines.txt

---

From: John C Klensin <[email-masked]>
Date: Wed, 03 Sep 2014 09:08:08 -0400

--On Wednesday, September 03, 2014 12:42 +0000 "Fred Baker
(fred)" <[email-masked]> wrote:

> It is described.
> 
> http://www.ietf.org/id-info/guidelines.html#naming and Section
> 7 of http://www.ietf.org/ietf-ftp/1id-guidelines.txt

Yes, if one knows where to find them.  Now, how many people who
submit I-Ds, especially those who are new to the IETF within the
last half-dozen years, are aware of those pages?   If we are
serious about those guidelines, why isn't there a prominent
statement on the I-D Submission page and/or the "Internet
Drafts" page accessed from the main IETF page
(http://www.ietf.org/id-info/) indicating that there are
guidelines (not just for naming) and that people are expected to
follow them (at least unless there is strong reason to not do
so) and providing a link.  There _is_ a "Guidelines" link on the
latter, but it is about as non-prominent as one could make it
and gives not hint that people really need to read it before
writing I-Ds.  

Why are those rules apparently being ignored regularly with
absolutely no ill effects to the authors?   

We can't be taking them seriously when at least two IESG members
have posted using the 
   draft-CyrpticNameCombination-mytopic
form in recent years and then pushed the documents through to
BCP or Standards Track status?

Conversely, if we don't want to depend on naming conventions, we
could require that I-Ds either identify a workgroup in the
header or explicitly contain a [to be removed on RFC
publication] section or subsection with a reserved title that
specifies the discussion locale.  It the authors of a particular
document have no clue or don't intend community discussion, let
them say so.  The presence of that header of section title would
be really easy for the submission tool to check.

best,
      john

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 17:51:50 +0000

> absolutely no ill effects to the authors?

I can say what happens in my part of the world; I can’t make a general statement.

In my part of the world, the naming guideline for a working group draft is used by IETF tools, and as a result datatracker will or will not do various things with a draft. If the name contains the name of my working group, the working group will be notified to take a look at it, and my private tools will track it. If people file drafts without it, the process becomes manual, and they’re going to have to do that themselves and/or advise me to keep track of the draft.

---

From: Michael StJohns <[email-masked]>
Date: Wed, 03 Sep 2014 16:49:00 -0400

At 07:35 PM 9/2/2014, Fred Baker (fred) wrote:

>On Sep 2, 2014, at 4:38 AM, Dave Cridland <<mailto:[email-masked]>[email-masked]> wrote:
>

Yup - there are at least a few recent cases where there aren't good defaults in place for where to post for a draft, and where asking the author's wasn't really definitive. 

There's also the point that for some of those, I *really* don't want to join the wider mailing list as the S/N ratio is poor or simply isn't of great interest to me regularly.  Finally, there's the whole "exactly which subject line corresponds to comments on the draft and why did it change 5 times since the original post?" problem.

All of these can be worked around, but at the cost of additional already scarce reading/reviewing time.

The march of IDs is unrelenting.  I'd *really* like it if I didn't have to track down an author just to figure out where the document is being discussed.  Things like https://datatracker.ietf.org/doc/draft-johndoe-http2-large-header-blocks/ don't help the problem.  

Later, Mike

---

From: Melinda Shore <[email-masked]>
Date: Wed, 03 Sep 2014 13:06:57 -0800

On 9/3/14 12:49 PM, Michael StJohns wrote:
> There's also the point that for some of those, I *really* don't want to
> join the wider mailing list as the S/N ratio is poor or simply isn't of
> great interest to me regularly.  Finally, there's the whole "exactly
> which subject line corresponds to comments on the draft and why did it
> change 5 times since the original post?" problem.

It may be useful to include an 'email the authors' link on the
announcement, or more prominently elsewhere, (or even have it
generated for inclusion in the draft by xml2rfc), much like what's
on the datatracker page.

Melinda

---

From: Nico Williams <[email-masked]>
Date: Wed, 3 Sep 2014 16:23:50 -0500

Isn't there an e-mail address for every I-D based on the I-D handle?

I forget what it is.  It should just be
<draft-handle-excluding-version>@ietf.org.   That should go to the
authors, shepherd, AD.  Heck, [email-masked] would be nice too
(which should go to the authors).

---

From: Melinda Shore <[email-masked]>
Date: Wed, 03 Sep 2014 13:29:57 -0800

> Isn't there an e-mail address for every I-D based on the I-D handle?

Yes, that's what I was talking about.  Making that more prominent
might go some way towards addressing what's under discussion
here.

Melinda

---

From: Dave Crocker <[email-masked]>
Date: Wed, 03 Sep 2014 14:34:45 -0700

> might go some way towards addressing what's under discussion

The email address is for the author.

The requirement here is for a public group discussion venue.

d/

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 3 Sep 2014 21:55:58 +0000

> Isn't there an e-mail address for every I-D based on the I-D handle?

[email-masked].

It took me a while to find it. For some reason, it’s documented in the chairs wiki. Look at http://wiki.tools.ietf.org/group/wgchairs/ and search for "Useful Email Addresses”.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 03 Sep 2014 23:13:04 +0100

> The requirement here is for a public group discussion venue.

ADs can make mailing lists. If folks figure that trying this
out for a few drafts manually is worth doing I'd be fine with
helping there if for each such draft/list someone else is
willing to manage the list. Probably worth thinking through
exactly what to try some more though, but if/when you do,
then I'm game to try help as I can before we're ready for
tooling. (And if you want a list for that "what to try"
discussion, I'm game for that too if someone will manage
the list:-)

S.

---

From: Nico Williams <[email-masked]>
Date: Wed, 3 Sep 2014 17:22:30 -0500

> It took me a while to find it. For some reason, it’s documented in the chairs wiki. Look at http://wiki.tools.ietf.org/group/wgchairs/ and search for "Useful Email Addresses”.

That, yeah.  Thanks.  Maybe we need [email-masked] as well
(if there is none then that should be an alias of
[email-masked]).

I see the tracker has some of these mailto links as well.  Maybe I'll
remember that next time.