Subject: TSVDIR LC review: <draft-ietf-6man-resilient-rs-04.txt> (Packet loss resiliency for Router Solicitations) to Proposed Standard

From: Allison Mankin <[email-masked]>
Date: Mon, 16 Feb 2015 17:39:41 -0500

I am the assigned TSV Directorate reviewer for this draft.

Please resolve these comments along with any other Last Call comments you
may receive.

Document:  draft-ietf-6man-resilient-rs-04.txt
Reviewer: Allison Mankin
Review Date: 2015-02-16
IETF LC End Date: 2015-02-16
IESG Telechat date: N/A.

Summary: This draft is ready for publication as a standards track RFC.

This draft deals with the problem that packet loss of Router Solicitations
(RS)  can lead to an extended period of being disconnected from the
Internet.  The circumstances are well described and the solution specified
is sound from a transport point of view, and also it has a track record.
The draft directs hosts to use the retransmission algorithm from RFC 3315,
the DHCPv6 specification, which includes backoffs and a randomization
factor.  The draft specifies using this algorithm with no maximum
retransmission count (MRC) or maximum retransmission duration (MRD) and
shows that if there is an extended cause for a router to not reply, there
will be roughly one RS per hour from each host.

Major issues:
None found

Minor issues:
The Maximum Retransmission Time (MRT) is set to a value of 3600 seconds
instead of a smaller value from RFC 3315.  The rationale is cited
normatively from an individual internet-draft from 2012 but the correct
reference (and the one that may be cited normatively) is RFC 7083.  I find
that the datatracker is missing a replaced-by that would have led from the
2012 individual i-d through the WG i-d to the RFC.

On 2 February 2015 at 10:32, The IESG <[email-masked]> wrote:

>
> The IESG has received a request from the IPv6 Maintenance WG (6man) to
> consider the following document:
> - 'Packet loss resiliency for Router Solicitations'
>   <draft-ietf-6man-resilient-rs-04.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2015-02-16. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
>
> Abstract
>
>
>    When an interface on a host is initialized, the host transmits Router
>    Solicitations in order to minimize the amount of time it needs to
>    wait until the next unsolicited multicast Router Advertisement is
>    received.  In certain scenarios, these router solicitations
>    transmitted by the host might be lost.  This document specifies a
>    mechanism for hosts to cope with the loss of the initial Router
>    Solicitations.  Furthermore, on some links, unsolicited multicast
>    Router Advertisements are never sent and the mechanism in this
>    document is intended to work even in such scenarios.
>
>
>
>
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-6man-resilient-rs/
>
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-6man-resilient-rs/ballot/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 16 Feb 2015 19:29:49 -0600

Allison,

Thank you for the review!

Spencer

may receive.
> This draft deals with the problem that packet loss of Router
Solicitations (RS)  can lead to an extended period of being disconnected
from the Internet.  The circumstances are well described and the solution
specified is sound from a transport point of view, and also it has a track
record. The draft directs hosts to use the retransmission algorithm from
RFC 3315, the DHCPv6 specification, which includes backoffs and a
randomization factor.  The draft specifies using this algorithm with no
maximum retransmission count (MRC) or maximum retransmission duration (MRD)
and shows that if there is an extended cause for a router to not reply,
there will be roughly one RS per hour from each host.

---

From: Ole Troan <[email-masked]>
Date: Tue, 17 Feb 2015 11:28:26 +0100

Allison,

thank you very much for the review!

cheers,
Ole
(Document Shepherd)

> On 16 Feb 2015, at 23:39 , Allison Mankin <[email-masked]> wrote:
> 
> Please resolve these comments along with any other Last Call comments you may receive.
> 
> This draft deals with the problem that packet loss of Router Solicitations (RS)  can lead to an extended period of being disconnected from the Internet.  The circumstances are well described and the solution specified is sound from a transport point of view, and also it has a track record. The draft directs hosts to use the retransmission algorithm from RFC 3315, the DHCPv6 specification, which includes backoffs and a randomization factor.  The draft specifies using this algorithm with no maximum retransmission count (MRC) or maximum retransmission duration (MRD) and shows that if there is an extended cause for a router to not reply, there will be roughly one RS per hour from each host.
> 
> Major issues:
> None found
> 
> Minor issues:
> The Maximum Retransmission Time (MRT) is set to a value of 3600 seconds instead of a smaller value from RFC 3315.  The rationale is cited normatively from an individual internet-draft from 2012 but the correct reference (and the one that may be cited normatively) is RFC 7083.  I find that the datatracker is missing a replaced-by that would have led from the 2012 individual i-d through the WG i-d to the RFC.
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Suresh Krishnan <[email-masked]>
Date: Tue, 17 Feb 2015 23:58:10 -0500

Hi Allison,
   Thanks a lot for your review. I will update the reference for 
SOL_MAX_RT to RFC7083.

Thanks
Suresh

On 02/16/2015 05:39 PM, Allison Mankin wrote:
> from the Internet.  The circumstances are well described and the
> solution specified is sound from a transport point of view, and also it
> has a track record. The draft directs hosts to use the retransmission
> algorithm from RFC 3315, the DHCPv6 specification, which includes
> backoffs and a randomization factor.  The draft specifies using this
> algorithm with no maximum retransmission count (MRC) or maximum
> retransmission duration (MRD) and shows that if there is an extended
> cause for a router to not reply, there will be roughly one RS per hour
> from each host.
>
> Major issues:
> None found
>
> Minor issues:
> reference (and the one that may be cited normatively) is RFC 7083.  I
> find that the datatracker is missing a replaced-by that would have led
> from the 2012 individual i-d through the WG i-d to the RFC.
>
> On 2 February 2015 at 10:32, The IESG <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>     [email-masked] <mailto:[email-masked]> mailing lists by 2015-02-16.
>     Exceptionally, comments may be
>     sent to [email-masked] <mailto:[email-masked]> instead. In either
>     case, please retain the