Subject: RE: [lisp] OPS-Dir review of draft-ietf-lisp-introduction-11 [B]

From: "Black, David" <[email-masked]>
Date: Thu, 12 Feb 2015 14:50:32 +0000

I don't care what terms are used - it just needs to be absolutely clear that
the inner and outer multicast addresses are not the same and that mapping
between them (which could take a number of forms) is involved.

Thanks,
--David

> -----Original Message-----
> From: Dino Farinacci [mailto:[email-masked]]
> Sent: Thursday, February 12, 2015 8:15 AM
> To: Luigi Iannone
> Cc: Black, David; [email-masked]; [email-masked]; Albert Cabellos; Damien
> Saucez; [email-masked]
> Subject: Re: [lisp] OPS-Dir review of draft-ietf-lisp-introduction-11
> 
> > G-EID     =>  the EID multicast group G
> > G-RLOC =>  the RLOC multicast group G
> 
> "inner and outer group addresses" have been used in various LISP multicast
> documents.
> 
> Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 12 Feb 2015 06:56:53 -0800

They can be the same if the underlay provider wants to control overlay's group address allocation. 

Dino

> On Feb 12, 2015, at 6:50 AM, Black, David <[email-masked]> wrote:
>

---

From: "Black, David" <[email-masked]>
Date: Thu, 12 Feb 2015 14:58:51 +0000

"can be the same" is fine (i.e., if the mapping produces the same output as its input, that's ok, but mapping is involved).
The current draft text (as I read it) implies "are always the same" and that needs to be corrected.

Thanks,
--David

> Sent: Thursday, February 12, 2015 9:57 AM
> To: Black, David
> Cc: Luigi Iannone; [email-masked]; [email-masked]; Albert Cabellos; Damien
> Saucez; [email-masked]
> Subject: Re: [lisp] OPS-Dir review of draft-ietf-lisp-introduction-11 [B]
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 12 Feb 2015 07:37:12 -0800

Got it. Agree.

Dino

> On Feb 12, 2015, at 6:58 AM, Black, David <[email-masked]> wrote:
>

---

From: Luigi Iannone <[email-masked]>
Date: Fri, 13 Feb 2015 09:37:34 +0100

> On 12 Feb 2015, at 15:58, Black, David <[email-masked]> wrote:
> 

Excellent progress thanks.

So, no new terminology, just clarification that inner and outer multicast groups are in general different (unless specific cases where the underlay provider wants to introduce some tighter control on the overlay.

Did I get it right?

L.

---

From: "Black, David" <[email-masked]>
Date: Fri, 13 Feb 2015 13:51:06 +0000

Yes.  I think we've discussed and reached conclusions on everything except whether
to add text on the IPv6 UDP zero checksum topic.  Could I suggest submission of
a -12 version of the draft that captures everything that's been discussed/resolved?

Thanks,
--David

> From: Luigi Iannone [mailto:[email-masked]]
> Sent: Friday, February 13, 2015 3:38 AM
> To: Black, David
> Cc: Dino Farinacci; [email-masked]; [email-masked]; Albert Cabellos; Damien
> Saucez; [email-masked]
> > "can be the same" is fine (i.e., if the mapping produces the same output as
> its input, that's ok, but mapping is involved).
> So, no new terminology, just clarification that inner and outer multicast
> groups are in general different (unless specific cases where the underlay
> provider wants to introduce some tighter control on the overlay.
> 
> Did I get it right?
> 
> L.
> 
> 
> > Thanks,
> > --David
> >
> >> They can be the same if the underlay provider wants to control overlay's
> group
> >> address allocation.
> >>
> >> Dino
> >>
> >>