Subject: IETF Hackathon at IETF 92, March 21-22, Dallas, TX

From: IETF Secretariat <[email-masked]>
Date: Tue, 24 Feb 2015 09:01:52 -0800

The Internet Engineering Task Force (IETF) is holding a Hackathon to encourage developers to discuss, collaborate and develop utilities, ideas, sample code and solutions that show practical implementations of IETF standards. It takes place just before IETF 92, and it’s free and open to everyone.

All you need is a knowledge of networking technologies, and you’ll be guaranteed to learn something new and have fun!

Event details: https://developer.cisco.com/site/ietf-hackathon
Link to register: https://www.ietf.org/meeting/92/hackathon-signup.html

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 24 Feb 2015 09:57:47 -0800

> Link to register: https://www.ietf.org/meeting/92/hackathon-signup.html

I realize that these things are often not planned a long way in advance, but for future events, as much notice as possible would be helpful.

It’s now less than four weeks to the IETF meeting, and many of us have (non-refundable) flights already booked. People on tight budgets, like students — exactly the kind of new people we want to attract to things like a hackathon — are likely to have booked well in advance to save money. Sort-notice additions to the schedule like this inadvertently favor those with generous corporate travel budgets to cover airline change fees.

Stuart Cheshire

---

From: Dave Crocker <[email-masked]>
Date: Tue, 24 Feb 2015 10:01:02 -0800

On 2/24/2015 9:57 AM, Stuart Cheshire wrote:
> I realize that these things are often not planned a long way in
> advance, but for future events, as much notice as possible would be
> helpful.
> 
> It’s now less than four weeks to the IETF meeting, and many of us
> have (non-refundable) flights already booked.

+1

Very short notice is pretty common for these special activities
surrounding the IETF.

It would be worth getting some agreement on a reasonable deadline for
announcing them.  One month ain't it.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Warren Kumari <[email-masked]>
Date: Tue, 24 Feb 2015 13:21:19 -0500

> announcing them.  One month ain't it.

Yup, fully agree, one month is not long enough. Whoever[0] is
organizing this could have done better / gotten it organized earlier
--- however, I'm really glad that someone has actually bothered
organizing such a thing. If it turns out to be useful, perhaps it will
be announced earlier in the future. We kvetch about lack of running
code, missing implementations, etc - let's not also kvetch too much
when someone tries to organize something to improve the situation.

W
[0]: Apparently cisco...

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Xavier Marjou <[email-masked]>
Date: Tue, 24 Feb 2015 19:45:41 +0100

+1 regarding this late announcement

I also have to buy my non-refundable flights tickets 2 months before each
IETF meeting to benefit from the best prices. I know several participants
who have the same constraints.

Cheers,
Xavier

---

From: Melinda Shore <[email-masked]>
Date: Tue, 24 Feb 2015 09:58:29 -0900

On Feb 24, 2015 9:21 AM, "Warren Kumari" <[email-masked]> wrote:
>We kvetch about lack of running

I think "I'd participate but my travel plans are set" is a statement of
fact and only incidentally a complaint.  And incidentally, I'd participate
but my travel plans are set.

Melinda

---

From: Stuart Cheshire <[email-masked]>
Date: Tue, 24 Feb 2015 11:09:32 -0800

On 24 Feb, 2015, at 10:21, Warren Kumari <[email-masked]> wrote:

> I'm really glad that someone has actually bothered

I second this.

Thanks to the people who organized the hackathon.

My fear is that if 90% of IETF attendees have already booked their flights, that leaves the hackathon drawing from the remaining 10%. (The 10% who are too busy to get their flights booked yet.)

If this event is even a moderate success, let’s treat that as a positive sign and try again next time, with an earlier announcement.

Stuart Cheshire

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 24 Feb 2015 19:25:05 +0000

I¹ll take the blame for the unfortunately short notice. We started
planning only a couple weeks ago, and thought that having something at
IETF 92 is better than nothing.
Good news is, we will learn for the experience and have started plans for
a similar event at IETF 93. Now is not too early to reach out to me
regarding technologies and ideas you would like to see incorporated at
Prague in July.

Cheers,
Charles

On 2/24/15, 11:09 AM, "Stuart Cheshire" <[email-masked]> wrote:

>My fear is that if 90% of IETF attendees have already booked their
>flights, that leaves the hackathon drawing from the remaining 10%. (The
>10% who are too busy to get their flights booked yet.)
>
>If this event is even a moderate success, let¹s treat that as a positive
>sign and try again next time, with an earlier announcement.
>
>Stuart Cheshire
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 24 Feb 2015 14:48:29 -0500

There is an awful lot of blatant vendor advertising on the signup for this hackathon which seems inappropriate for IETF-related work.

	--Tom

> On Feb 24, 2015:12:01 PM, at 12:01 PM, IETF Secretariat <[email-masked]> wrote:
> 
>

---

From: Dave Crocker <[email-masked]>
Date: Tue, 24 Feb 2015 12:22:56 -0800

> IETF 92 is better than nothing.

It's important that we be careful not to consider this in terms of
blaming anyone about this (or any, IMO) specific event.  Each of the
activities -- certainly including this one -- is fully worthy.

However there is a long-standing pattern of late announcements of
special activities surrounding IETF Week.

I see this as a presumption about who can and will attend, namely the
hard-core devotees who have the funding and long-term commitment to attend.

The problem is with who this de facto excludes.

I think the important issue to for all of us to get our heads in a place
that worries about more advanced notice.  Once we think of 2- or 3-month
(or whatever we feel appropriate) deadlines, we will all come up with
ideas for activities as we usually do -- last-minute -- but relative to
the earlier deadline, rather than the actual event.

d/

---

From: Dean Bogdanovic <[email-masked]>
Date: Tue, 24 Feb 2015 20:55:12 +0000

Dave,

I agree with Tom's statement that there is too much corporate marketing around this hackathon.

> hard-core devotees who have the funding and long-term commitment to attend.

I fully disagree with this statement and it is very disrespectful. I know many people personally who have been coming to IETF for more then 25 years and they are interested in such a hackathon, but can't change their plans.
> The problem is with who this de facto excludes.

IMO, too many people

Dean

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 Feb 2015 16:09:53 -0500

> I agree with Tom's statement that there is too much corporate marketing around this hackathon.

I see the Cisco logo once, Cisco mentioned one other time, and Cisco DevNet mentioned one other time, on the event details page.   This is similar to the presentation of the Google and Time Warner logos on the meeting page.   I don't work for Cisco, and indeed the company I work for used to count Cisco as one of our major competitors, yet I do not find the "corporate marketing" for this event objectionable.

I hate to extend this conversation, because I think it's incredibly weird how much opprobrium has been expressed, but can you explain precisely what it is that you object to about the supposed corporate marketing of which you speak?

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 24 Feb 2015 16:20:15 -0500

> On Feb 24, 2015:4:09 PM, at 4:09 PM, Ted Lemon <[email-masked]> wrote:
> 

	If you take a look at the URL in question I think its self-explanatory why there is confusion about whether this is a vendor-sponsored event, a vendor event, or maybe something related to the IETF.  The fact that there are links here to register for DevNet, the Cisco logo, etc... is confusing at best as to what this is.

	One approach would have been to just direct people to the official IETF Hackathon page here:

https://www.ietf.org/meeting/92/hackathon-signup.html

	--Tom

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 Feb 2015 16:29:55 -0500

> The Internet Engineering Task Force (IETF) is holding a Hackathon to encourage developers to discuss, collaborate and develop utilities, ideas, sample code and solutions that show practical impleme…

This text, in an email from the IETF Secretariat, is immediately followed to a cisco.com URL.   So a disinterested reader would naturally assume that the event is an IETF event, and that Cisco is somehow involved in organizing it, or maybe is sponsoring it (e.g., paying for the room or something).   I do not actually know the truth of the matter, but the meeting info is very clear about what the hackathon is about.   So while I guess I can understand that you might be confused about who is sponsoring it, I am still at a loss as to why that's a problem.

---

From: Melinda Shore <[email-masked]>
Date: Tue, 24 Feb 2015 12:56:47 -0900

On 2/24/15 12:29 PM, Ted Lemon wrote:
> This text, in an email from the IETF Secretariat, is immediately
> followed to a cisco.com URL.   So a disinterested reader would
> naturally assume that the event is an IETF event, and that Cisco is
> somehow involved in organizing it, or maybe is sponsoring it (e.g.,
> paying for the room or something).   I do not actually know the truth
> of the matter, but the meeting info is very clear about what the
> hackathon is about.   So while I guess I can understand that you
> might be confused about who is sponsoring it, I am still at a loss as
> to why that's a problem.

I don't love it - it increases the difficulty of arguing that yes,
the IETF really is a vendor-independent organization just a wee bit
more - but I wonder if Cisco would not choose to sponsor something
like that if they couldn't slap their branding on it.  Why was the
announcement on Cisco's site, anyway?  Is this a Cisco event or
an IETF event?

Melinda

---

From: "John Levine" <[email-masked]>
Date: 25 Feb 2015 02:35:11 -0000

>My fear is that if 90% of IETF attendees have already booked their flights, that leaves the
>hackathon drawing from the remaining 10%. (The 10% who are too busy to get their flights booked
>yet.)

I booked my tickets months ago, but due to scheduling peculiarities,
I'm already flying in on Saturday.  So I guess I'll let everyone else
know how it went.

It's been a while since I've done serious programming so I hope it won't be
a problem to do the hacking in BLISS-10.

R's,
John

PS: Changing the hotel can be as painful as changing the flights if
the discounted room blocks are sold out.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 24 Feb 2015 22:10:07 -0500

> a problem to do the hacking in BLISS-10.

Hey, if you have a KX-10 running on your laptop that can get at the network, I say go for it!

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 25 Feb 2015 08:42:14 +0000

> 	There is an awful lot of blatant vendor advertising on the signup for this hackathon which seems inappropriate for IETF-related work.

Agreed. Why is this not simply on an IETF wiki?

It's also a bit confusing to see this advertised as an IETF hackathon when most of the listed technologies aren't (yet) IETF work items.

Lars

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 15:58:43 +0000

On 2/25/15, 12:42 AM, "Eggert, Lars" <[email-masked]> wrote:

>> 	There is an awful lot of blatant vendor advertising on the signup for
>>this hackathon which seems inappropriate for IETF-related work.
>
>It's also a bit confusing to see this advertised as an IETF hackathon
>when most of the listed technologies aren't (yet) IETF work items.

True, and hopefully the work at the Hackathon will provide useful input
into BOFs, etc., that helps make more informed decisions about whether and
how to proceed with forming working groups. If you have another technology
you would like to propose and for which we can identify a champion to help
drive it, we can add it, as we are doing today for SFC.

Cheers,
Charles

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 25 Feb 2015 16:04:24 +0000

Hi,

On 2015-2-25, at 16:58, Charles Eckel (eckelcu) <[email-masked]> wrote:
> how to proceed with forming working groups.

my point is that calling it an "IETF hackathon" sort of implies (at least to me) that IETF technologies would be hacked with, when in reality that's not the case in most of the listed examples. They maybe *intended* as input to the IETF, but they aren't IETF technologies (published as RFCs or at least adopted as WG work items.)

Lars

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 07:12:54 -0900

> drive it, we can add it, as we are doing today for SFC.

This whole process has been kind of odd and not at all
transparent.  Not sure why working group chairs weren't
approached for potential projects.  I just went through
the list of projects and it appears that Cisco is overrepresented
in the technologies being proposed.  This does not seem to be
an "IETF" hackathon, but rather a Cisco hackathon held in
at an IETF meeting.

Melinda

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 16:49:50 +0000

Just an FYI, we have added SFC as an additional technology for the
Hackathon. 

Services Function Chaining (SFC) in OpenDaylight (ODL)
* SFC architecture in OpenDaylight (SFC ODL page:
https://wiki.opendaylight.org/view/Service_Function_Chaining:Main)
* Work items will cover both control and data plane:
  * SFC Agent auto-provisioning (Python) and Yang models (Yang)
  * SFC-OVS integration (Java)
  * SFC/NSH Traceroute (Python, Standards work)
  * SFC Classifier (Python, Linux IPtables)
  * NETCONF integration (Java)
  * Review of SFC Yang models and feedback into ODL
  * Implementation of Variable Length NSH packets (MD Type 02) in the data
plane (Python)

We are still in the process of updating the event information and
registration pages to include SFC. If you go to register in the meantime
and do not see SFC listed as a technology, you can enter ³SFC² in the
³Other² area.
Also, please be aware that due to room capacity limits, registration is
capped at 40 participants.

Cheers,
Charles

On 2/24/15, 9:01 AM, "IETF Secretariat" <[email-masked]> wrote:

>
>The Internet Engineering Task Force (IETF) is holding a Hackathon to
>encourage developers to discuss, collaborate and develop utilities,
>ideas, sample code and solutions that show practical implementations of
>IETF standards. It takes place just before IETF 92, and it¹s free and
>open to everyone.
>
>All you need is a knowledge of networking technologies, and you¹ll be
>guaranteed to learn something new and have fun!
>

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 25 Feb 2015 11:58:02 -0500

> On Feb 25, 2015, at 11:12 AM, Melinda Shore <[email-masked]> wrote:
> 

I'm with you %100. As co-chair of 2 wgs and deeply involved in the yang modeling efforts going on here and externally - most of which is clearly related - I'm puzzled. Benoit, Juergen and I have also been running a yangathon - hackathon for yang models - for a year now at each meeting which seems like a good fit for an org wide hackathon. No one approached us for this either.

Tom

---

From: Ted Lemon <[email-masked]>
Date: Wed, 25 Feb 2015 12:04:09 -0500

On Feb 25, 2015, at 11:58 AM, Thomas Nadeau <[email-masked]> wrote:
> No one approached us for this either.

Nobody has visibility into all the activities of the IETF.   The way volunteer organizations work is that people scratch their own itch, and hopefully it's of collective benefit.   If this hackathon is a good idea (as a lot of people seem to believe) then it would be great if, now that it's been floated and is going to be tried, the next hackathon had more broad involvement of the community.

But the expectation that someone will approach you is kind of absurd.   If you want to be involved, approach the people who are already involved.   Don't wait for them to approach you.   Of course, you didn't know about this in advance--the first I heard of it was less than a week ago.   But now you know, and there are plans to do this at IETF 93; if you think a general hackathon framework at the IETF would be a good place for the yang hackathon work you are doing, then you should be involved in planning the IETF 93 hackathon.

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 08:37:41 -0900

On 2/25/15 8:04 AM, Ted Lemon wrote:
> But the expectation that someone will approach you is kind of absurd.

That's nonsense, Ted.  Nobody's saying "You didn't approach *me*".
What we're saying is that there are questions about where the list
of technologies came from, particularly given that 1) they're for
the most part technologies that have not been adopted as IETF
deliverables, and 2) they appear more aligned with Cisco's efforts
than with anything the IETF is doing.  If Cisco wants to have a
Cisco hackathon coinciding with an IETF meeting, awesome, but
let's not pretend this is an IETF event.

Who's paying for the room, the network, the food, the ... ?

I think an *IETF* hackathon is a great idea.  But between the
extremely late scheduling and the really weird content, this looks
like kind of a mess.  Might have made more sense to wait until
summer, give the thing a better chance of success because of
better planning.

Melinda

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 25 Feb 2015 13:00:47 -0500

It would be nice to tie this into CodeMatch for future events to track
connections between coding projects and drafts/RFCs.  We'll be providing an
update of our work on CodeMatch at the admin plenary.  We will also have a
UI expert at a table to get feedback on Sunday of the IETF for our mock-ups
and prototype work and hope you will visit the team, I believe noon-5PM.

Here is a link to high-level background information:
http://www.ietf.org/codematch/

Thanks,
Kathleen

On Wed, Feb 25, 2015 at 10:58 AM, Charles Eckel (eckelcu) <[email-masked]
> wrote:

-- 

Best regards,
Kathleen

---

From: Warren Kumari <[email-masked]>
Date: Wed, 25 Feb 2015 13:05:51 -0500

> summer, give the thing a better chance of success because of

Yup - I initially stuck up for the idea, and still think that the
*idea* is a good one, but I'm becoming worries about the execution.
The announcement page has a link to a "discussion forum", which
required me hunting down my cisco.com login.

I was hoping for more details there, but no luck...

I am still glad that someone is organizing this (flawed though it
might be), but I'd like to understand:
1: *who* exactly is organizing this? (Is it Cisco? The IETF? A joint thing?)
2: If the IETF getting sponsorship for this?
3: How are the projects being chosen? And by whom?
4: Is this under Note Well? Does Cisco own any IPR generated? Or the
IETF? or individuals?
5: This says it is being done at the Fairmont, and I'm assuming there
will be a need for network. Have the organizers arranged for this?
(Hint: I don't think the NOC team has heard anything about this...)

W

---

From: Ted Lemon <[email-masked]>
Date: Wed, 25 Feb 2015 13:42:07 -0500

> That's nonsense, Ted.  Nobody's saying "You didn't approach *me*".

Actually, that is _exactly_ what was said.

> of technologies came from

Come on, please lose the passive voice and own it.   _You_ have questions about where the list of technologies came from.   I can tell you where: the organizer(s) (I don't know if it's singular or plural, I wasn't involved) had a deadline, and they came up with some ideas, and they threw the spaghetti against the wall to see if it would stick.  Nobody has copious free time at IETF.   Everything is best-effort.   Getting things right is _always_ an iterative process.

> Might have made more sense to wait until

Best is the enemy of good enough.   I would rather see people try to do things and not do them perfectly than that they not try.   Speaking as someone who's tried a number of initiatives at the IETF, it is actually hard to organize them and get people to come, and after a while you stop trying because it's a skinner box where you always get a shock when you push the button.

We are smart people at the IETF, and _any_ proposal will have some obvious omission that we will spot.   If the way we express our discovery of this potential optimization is to use accusatory language that suggests that something improper has been done, as is _amazingly frequently the case_, then there's another IETF cynic we've created out of a formerly willing volunteer.

As a hint here, the right thing to say if you think the agenda is to Cisco-intensive is "I'd like to see more 'foo' in the next Hackathon," or even better, "how can I help," not "this looks fishy."

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 09:54:55 -0900

On 2/25/15 9:42 AM, Ted Lemon wrote:
> As a hint here, the right thing to say if you think the agenda is to
> Cisco-intensive is "I'd like to see more 'foo' in the next
> Hackathon," or even better, "how can I help," not "this looks
> fishy."

It does look fishy.  It's not at all clear whether or not
the IETF is paying for some of this, etc.  I'm trying to think
of something that's beyond reproach, and failing.  My mom, maybe.
And as I've said I'd like to participate in an IETF hackathon
(a Cisco one, not at all) but this was announced after I'd
already made my travel arrangements.

It's not *that* hard to send out email saying "Hey, we're
thinking of organizing a hackathon, anybody interested?"
It's unclear why nobody did that.

Melinda

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 25 Feb 2015 14:46:34 -0500

Sure, but that isn't a good excuse IMHO. I don't think anyone should approach me personally, but 
there are WG chair/WG/all-WG-chair mailing lists that are commonly used to communicate with the IETF leadership
and participants.

	But that is diverging from my original point. Why is there so much corporate advertising and branding on this?
Why can't we just use an IETF web/wiki for this?  Its a bit offensive to be courted with signup for Cisco's dev net program
after clicking on an apparently IETF-sponsored link. The point I was making earlier is that its inappropriate based 
on the IETF's past approach to these things. No one has given a good reason why either.

	--Tom

> On Feb 25, 2015:12:04 PM, at 12:04 PM, Ted Lemon <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 25 Feb 2015 14:48:55 -0500

On Feb 25, 2015, at 2:46 PM, Thomas D. Nadeau <[email-masked]> wrote:
> Its a bit offensive to be courted with signup for Cisco's dev net program

I think offensive is the wrong word.   It is a mistake, because most IETFers won't do it.   The right way to express this is to say "I don't think IETFers are going to do this, and I'm certainly not.   Can you set up an IETF mailing list and wiki for this?  Thanks!"

If the answer to that request is "hell no, we want the Cisco branding and won't do the hackathon without people registering for our developer thingy," then I'd definitely be right there with you in objecting, but can't we take it one step at a time?

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 25 Feb 2015 15:04:11 -0500

> On Feb 25, 2015:2:48 PM, at 2:48 PM, Ted Lemon <[email-masked]> wrote:
> 

	Thanks for your advice on etiquette Ted.  I'll keep that in mind for future communications.
In the time being I still think its in bad taste; at best its not the way we've done things at the IETF.

	--Tom

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 20:12:50 +0000

Hi Warren,

Fair questions. There are now answers to several of these on the community
page created for the Hackathon.
Please have a look and feel free to post any other questions or thoughts.

Cheers,
Charles

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 11:17:27 -0900

> Please have a look and feel free to post any other questions or thoughts.

The "community" page requires a Cisco login.  Regardless, wouldn't it
makes sense to answer the questions where they're being asked?

Melinda

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 20:25:42 +0000

Hi Melinda,

Perhaps, but I¹m trying to scale better, and keeping things in once place
helps. Similar questions have come from other IETF aliases as well as from
people outside of the IETF entirely.

Cheers,
Charles

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 11:27:02 -0900

> people outside of the IETF entirely.

Why does the "community" page require a Cisco login?  I really
don't understand what you're doing, here.

Melinda

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 20:54:27 +0000

We are using the Cisco community page to host the ongoing discussion
forum. Here is the info found there as to how IETF and Cisco are both
involved in the Hackathon (sorry for poor formatting resulting from
copy/paste).

IETF is providing the room and the network for the event.
Cisco DevNet is running the Hackathon, paying for food, prizes, etc.
* Hackathon information is hosted on the DevNet site: Cisco DevNet: IETF
Hackathon at IETF 92, March 21-22
<https://developer.cisco.com/site/ietf-hackathon/>
* Ongoing discussion is encourage, and is hosted within the Cisco
developer community page: IETF Hackathon
<https://communities.cisco.com/community/developer/ietf-hackathon>

All interested parties click to a reg form on the IETF site: IETF
Hackathon 2015 Dallas
<https://www.ietf.org/meeting/92/hackathon-signup.html>
* Registration is handled entirely by the IETF, in accordance with IETF
privacy requirements.
*  Registered attendees will not need to have become DevNet members.
* Registered attendees will be shown and reminded that their participation
is subject to the IETF Note Well: Note Well
<https://www.ietf.org/about/note-well.html>

A link to the same info is:
https://communities.cisco.com/message/175271#175271 (and yes, there is the
hassle of getting a CCO account if you do not have one).

Cheers,

Charles

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 12:03:22 -0900

On 2/25/15 11:57 AM, James Gannon wrote:
> Am I the only one who think that a rebranding on this might be the easiest solution for everyone?

I think it's by far the best solution.  The expectation that you'd
need a Cisco login and visit a Cisco web page to see responses to
questions raised on the IETF mailing list seems unreasonable to me.

If it's an IETF event, move the "community" page to an IETF resource.
We've got multiple wikis, and I really can't imagine who thought it
was a better idea to use an access-controlled Cisco one.

In the meantime, thanks to Charles for posting a little more
information to the mailing list.

Melinda

---

From: Nico Williams <[email-masked]>
Date: Wed, 25 Feb 2015 15:10:59 -0600

> makes sense to answer the questions where they're being asked?

Then it's not a community page, as you imply.

I've nothing against a vendor sponsoring an IETF hackathon.  I've
nothing against advertising for the sponsor on the hackathon page.  I've
not even got anything against the hackathon focusing on technologies of
interest to the sponsoring vendor: those of us who have other
technologies we'd rather work on can organize our own.  There may be a
question keeping general meeting revenue from funding such a constrained
*and* sponsored hackathon.

I've also got nothing against a vendor [whose employees participate at
the IETF] piggybacking on an IETF meeting by co-locating their events in
the same city, same general area of the same city, and even the same
conference venue, provided that they a) don't use IETF meeting revenue
to fund their events, and b) don't compete for time slots with the IETF.
We can't do anything about (b), of course, but we can do something about
(a).

I'm not happy with vendor logins on an IETF page of any kind.

Also, the IETF NOTE WELL should apply to any IETF hackathon, and any
deviation from that would definitely require discussion *ahead* of the
announcement of the hackathon.

BTW, this thread has already cost quite a lot of labor.  Setting rules
of the road for sponsoring IETF events related/overlapping/co-located
to/with an IETF meeting is key to not doing this again.

Nico
--

---

From: Jari Arkko <[email-masked]>
Date: Wed, 25 Feb 2015 13:15:34 -0800

Folks,

I wanted to clarify the situation with the Hackathon.

First off, this is intended to be an IETF event, for an additional opportunity to work on code, strengthen the linkage between running code and standards, and allow additional co-operation between the participants. The intent is to allow people to build and test what they want, and not have this limited in some fashion. The list on the web site is an initial guess which I hope interested parties can contribute to. Obviously we are hoping for technologies that are related to the things that the IETF works on, but I wouldn’t necessarily rule out work that is being proposed to be brought to the IETF, such as work related to BOFs.

The event has a sponsor, Cisco, who have volunteered to cover the costs. Such sponsorships are needed to arrange events or even the IETF meetings themselves. We greatly appreciate Cisco for offering to sponsor this event, thank you. I think it is appropriate to mention the sponsor, show logos, etc. as we do in other contexts. 

I do apologize for the late notice on this, and it is up to me really rather than Charles. The first ideas to develop something like this surfaced in Honolulu, and we could have provided information much sooner, had we had the time to work through a proposal late last year.

I hear the concerns about participants being able to change their flight plans loud and clear. There are also other meetings and events that IETF participants will attend during the weekend before the IETF. However, this is an experiment. I realise that we will not get as many participants as we would if we had announced this in Honolulu. But I for one would like to see what comes out of the experiment. If we have some people who find something like this useful, perhaps we can repeat the experience in Prague, with larger scale and more lead time.

And some of the confusion that we caused in thread is certainly useful lessons for future times. Please understand that we are learning how to do this. Where do we put event pages, what do we list on them, how much space do we need and will people show up, how much real new work will happen, are people too busy on the preceding days, … I do not have answers to these questions at this time. Maybe after Dallas we have some more experience.

Finally, I think the detailed content of this event could perhaps best be worked on a Wiki - the Code Sprint has used this model successfully. Perhaps moving the working areas to a wiki on the IETF server might be a good thing.

Jari

---

From: Warren Kumari <[email-masked]>
Date: Wed, 25 Feb 2015 16:49:29 -0500

> hassle of getting a CCO account if you do not have one).

Thank you, this answers many of my questions. You forgot to
cut-n-paste one of the (IMO) more useful answers from that page:

"What was the Hackathon not announced earlier?"
"Planning the Hackathon started with very little runway before IETF
92, Dallas. At the time, it was not clear if it would be possible to
do anything in Dallas, or if we would need to wait for IETF 93,
Prague. We were able to pull together a room, network, and champions
for a few technologies very quickly.

Presented with the choice of trying something last minute in Dallas
vs. waiting until Prague, we decided to go for Dallas. The rationale
was that due to the late notice, the Dallas Hackathon would be
relatively small and provide lots of good insights into how to do
things bigger, better, and MUCH earlier for IETF 93."

Cool.

W

---

From: Mary Barnes <[email-masked]>
Date: Wed, 25 Feb 2015 16:00:22 -0600

Why can't you setup a wiki page on the IETF tools page?    I'll chime in
with others, if this is an IETF event we shouldn't need to login to a
vendor's website (at all).

Regards,
Mary.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 25 Feb 2015 16:54:35 -0500

+1

> On Feb 25, 2015:4:03 PM, at 4:03 PM, Melinda Shore <[email-masked]> wrote:
>

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 25 Feb 2015 23:15:04 +0000

My biggest issue with this hackathon is requirement to register with Cisco DevNet. This tells me it is a corporate event, not an IETF event and am asking if Cisco DevNet org is trying to increase its membership.

And +1 to Melinda's email

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Wed, 25 Feb 2015 23:28:27 +0000

Hi Dean,

I think the short answer to your question is yes. A more complete version
of that answer is available at:
https://communities.cisco.com/message/175254#175254

I have verified that you do not need to register with Cisco DevNet to view
the content within the community setup for the Hackathon:
https://communities.cisco.com/community/developer/ietf-hackathon

You do need to login to post to it. This requirement could be relaxed,
thus allowing anonymous posts, but I don¹t view that as a particularly
good solution.

Cheers,
Charles

On 2/25/15, 3:15 PM, "Dean Bogdanovic" <[email-masked]> wrote:

>My biggest issue with this hackathon is requirement to register with
>Cisco DevNet. This tells me it is a corporate event, not an IETF event
>and am asking if Cisco DevNet org is trying to increase its membership.
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 25 Feb 2015 18:30:07 -0500

> On Feb 25, 2015:6:28 PM, at 6:28 PM, Charles Eckel (eckelcu) <[email-masked]> wrote:
> 
> Hi Dean,
> 

	A better solution would be to use IETF Infrastructure for this, or at least non-commercial like github.

	--Tom

---

From: Benson Schliesser <[email-masked]>
Date: Wed, 25 Feb 2015 18:30:34 -0500

Dean Bogdanovic wrote:
> Finally, I think the detailed content of this event could perhaps best
> be worked on a Wiki - the Code Sprint has used this model successfully.
> Perhaps moving the working areas to a wiki on the IETF server might be a
> good thing.

Just to explicitly reiterate something outlined in Jari's note:
This Hackathon is not a Cisco event, but rather an IETF event sponsored 
by Cisco. Thus one should be able to register via
https://www.ietf.org/meeting/92/hackathon-signup.html
without creating a Cisco DevNet account. Likewise the Note Well will 
apply to this Hackathon, it will meet in the IETF venue and plans to use 
IETF network, etc.

The fact that the primary source of information about this event has 
been hosted on a Cisco website rather than an IETF site is definitely 
unfortunate. But it doesn't change the nature of the event. I agree with 
Jari's conclusion that we should move the information to an IETF wiki. 
I'll follow up with the organizers to see that happen.

Despite all the frustration and confusion caused by the manner in which 
this event was coordinated and announced, I think it is meant to be a 
positive community-building exercise and I thank Cisco for sponsoring it.

Cheers,
-Benson

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 25 Feb 2015 18:45:54 -0500

> 	A better solution would be to use IETF Infrastructure for this, or at least non-commercial like github.

Last I checked, github was charging my employer for our use, and they
have plenty of offerings on their site to entice you to pay for it.

If one is going to complain about a corporation using their free
offerings in order to entice people to more commercial entanglements,
then one at least ought to be consistent about it.

A

-- 
Andrew Sullivan
[email-masked]

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 25 Feb 2015 18:47:32 -0500

> On Feb 25, 2015:6:45 PM, at 6:45 PM, Andrew Sullivan <[email-masked]> wrote:
> 

	For non-commercial use, github is free.  The IETF is considered a non-commercial organization. 

	--Tom

---

From: Andrew Sullivan <[email-masked]>
Date: Wed, 25 Feb 2015 19:16:34 -0500

> 	For non-commercial use, github is free.  The IETF is considered a non-commercial organization. 

I did not see anywhere in this thread the complaint that Cisco was
trying to charge people money for this hackathon.  AFAICT, it's just
as free from them.

I am perfectly prepared to say that this entire business could have
been handled in a way that didn't result in a huge thread on the IETF
list.  But complaining about one company's promotion of its products
by suggesting an alternative company that does something extremely
similar sounds to me like a complaint about the particular company,
and not about the technique.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Melinda Shore <[email-masked]>
Date: Wed, 25 Feb 2015 15:36:44 -0900

On Feb 25, 2015 3:16 PM, "Andrew Sullivan" <[email-masked]> wrote:

>But complaining about one company's promotion of its products

I don't think Github is the right answer here - we've got our own tools,
let's use them - but I don't think the situations are comparable in that
Github didn't organize the event, did not choose the subject technologies,
and is not offering prizes under the IETF banner as enticements to IETF
participants to work on things that aren't IETF work items but that they're
trying to get picked up.  So, I don't think they're that similar.  (Did
nobody really think about this?)

Melinda

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Thu, 26 Feb 2015 00:44:24 +0000

Hi Melinda,

I know it is short notice, but we can add another technology if you or someone else can act as a champion for it and help mentor other participants. That is all that is required. Otherwise, we can certainly add it to the list for IETF 93.

Cheers,
Charles

From: Melinda Shore <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 25, 2015 at 4:36 PM
To: Andrew Sullivan <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: IETF Hackathon at IETF 92, March 21-22, Dallas, TX

> and not about the technique.

I don't think Github is the right answer here - we've got our own tools, let's use them - but I don't think the situations are comparable in that Github didn't organize the event, did not choose the subject technologies, and is not offering prizes under the IETF banner as enticements to IETF participants to work on things that aren't IETF work items but that they're trying to get picked up.  So, I don't think they're that similar.  (Did nobody really think about this?)

Melinda

---

From: James Gannon <[email-masked]>
Date: Wed, 25 Feb 2015 20:57:59 +0000

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Melinda Shore
Sent: Wednesday, February 25, 2015 8:27 PM
To: Charles Eckel (eckelcu)
Cc: [email-masked]
Subject: Re: IETF Hackathon at IETF 92, March 21-22, Dallas, TX

On 2/25/15 11:25 AM, Charles Eckel (eckelcu) wrote:
> Perhaps, but I¹m trying to scale better, and keeping things in once 
> place helps. Similar questions have come from other IETF aliases as 
> well as from people outside of the IETF entirely.

Why does the "community" page require a Cisco login?  I really don't understand what you're doing, here.

Melinda

---

From: James Gannon <[email-masked]>
Date: Wed, 25 Feb 2015 23:34:32 +0000

Charles,
Don't get me wrong this sounds like an awesome event and I commend you for championing and organizing it but on your post here:

Why are Cisco and Cisco DevNet involved?
>This is just my own opinion, but I see the following reasons behind Cisco involvement.
>Cisco is a big supporter and active member of IETF, with a particular interest in open source development related to IETF standards
>Cisco DevNet is Cisco's developer program, an active community-based program within the industry
>DevNet has managed a number of Hackathons to-date, and has credibility in this space
>DevNet has a large community that may be interested in becoming involved with the Hackthon
>Involvement reinforces Cisco's position as a key industry player and active advocate of standards and open source development
>Involvement in the hackathon increases awareness of DevNet by engaging it actively with the IETF community

It seems like this is an (Awesome) Cisco devnet event that is being collocated at IETF92 rather than an IETF event.
Just my 2c.

-----Original Message-----
From: Charles Eckel (eckelcu) [mailto:[email-masked]] 
Sent: Wednesday, February 25, 2015 11:28 PM
To: Dean Bogdanovic; Thomas D. Nadeau
Cc: [email-masked]; James Gannon
Subject: Re: IETF Hackathon at IETF 92, March 21-22, Dallas, TX

Hi Dean,

I think the short answer to your question is yes. A more complete version of that answer is available at:
https://communities.cisco.com/message/175254#175254

I have verified that you do not need to register with Cisco DevNet to view the content within the community setup for the Hackathon:
https://communities.cisco.com/community/developer/ietf-hackathon

You do need to login to post to it. This requirement could be relaxed, thus allowing anonymous posts, but I don¹t view that as a particularly good solution.

Cheers,
Charles