Subject: The New RFC Editor Website

From: IETF Chair <[email-masked]>
Date: Wed, 7 Oct 2015 19:15:30 +0300

I wanted to introduce people to the new RFC Editor website
and send a link to Heather’s blog article about the changes:

https://www.rfc-editor.org
https://www.ietf.org/blog/2015/10/the-new-rfc-editor-website/

Jari Arkko,
IETF Chair

---

From: t.p. <[email-masked]>
Date: Sun, 11 Oct 2015 09:34:10 +0100

Will there ever be a web site redesign that does not generate a 404?
Probably not.

In this case, you get one when you look to see what feedback there has
been previously, to see if others are experiencing the same problems as
you are and the answer is, 404!  Has there been feedback about this
already? 404!

Tom Petch

----- Original Message -----
From: "IETF Chair" <[email-masked]>
To: "IETF Announcement List" <[email-masked]>
Cc: "Heather Flanagan (RFC Series Editor)" <[email-masked]>; "IETF"
<[email-masked]>
Sent: Wednesday, October 07, 2015 5:15 PM

Jari Arkko,
IETF Chair

---

From: Paul Wouters <[email-masked]>
Date: Sun, 11 Oct 2015 15:32:21 -0400

> On Oct 11, 2015, at 04:34, t.p. <[email-masked]> wrote:
> 

This comment is unnecessary. Imagine everyone took this attitude to you every time you made the tiniest mistake.

Paul

---

From: joel jaeggli <[email-masked]>
Date: Sun, 11 Oct 2015 20:13:21 -0700

> Will there ever be a web site redesign that does not generate a 404?

You didn't specify which url generated that. I woud hazard that it's the
IETF one.

You, should probably verify that your browser supports rfc3546 SNI as
part of TLS 1.0.

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Mon, 12 Oct 2015 08:38:05 -0700

> Will there ever be a web site redesign that does not generate a 404?

Of course not. Murphy's Law is a powerful force.

> 
> In this case, you get one when you look to see what feedback there
> has been previously, to see if others are experiencing the same
> problems as you are and the answer is, 404!  Has there been feedback
> about this already? 404!

Interesting; that worked before, and we haven't turned off http access
(if you go to
https://www.rfc-editor.org/rse/wiki/doku.php?id=webfeedback instead of
http://www.rfc-editor.org/rse/wiki/doku.php?id=webfeedback, which is
where that feedback link goes, it works. Well, it works for me. Your
mileage _shouldn't_ vary...)

Thanks for the report.

- -Heather

> 
> Tom Petch
>
>
> ----- Original Message ----- From: "IETF Chair" <[email-masked]> To:
> "IETF Announcement List" <[email-masked]> Cc: "Heather
> Flanagan (RFC Series Editor)" <[email-masked]>; "IETF"
> <[email-masked]> Sent: Wednesday, October 07, 2015 5:15 PM
>
>
> I wanted to introduce people to the new RFC Editor website and send a
> link to Heather’s blog article about the changes:
>
> Jari Arkko, IETF Chair

---

From: Dave Crocker <[email-masked]>
Date: Mon, 12 Oct 2015 08:44:26 -0700

> Of course not. Murphy's Law is a powerful force.

Seems like there's an easy solution to this:

     plan for having 404s.  then the plan will go wrong.

d/
-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Hector Santos <[email-masked]>
Date: Mon, 12 Oct 2015 13:47:37 -0400

The little I did, so far so good. It didn't break down in WEB 1.0 mode 
(javascript disabled). Searching was nicely done. Minor, Re-searching 
should keep the additional criteria form open.  Didn't see a way to 
get "re-started" with writing proposals. Can you search drafts?

Nice job.

--
HLS

On 10/7/2015 12:15 PM, IETF Chair wrote:
> and send a link to Heather�s blog article about the changes:
>

---

From: Hector Santos <[email-masked]>
Date: Mon, 12 Oct 2015 14:00:08 -0400

>       plan for having 404s.  then the plan will go wrong.

+1.  Define 404 as TBD pages, e.g. redirect to a "pretty" 404/resource 
missing IETF form with IETF-intelligent links.

-- 
HLS

---

From: Doug Royer <[email-masked]>
Date: Mon, 12 Oct 2015 14:34:43 -0600

> and send a link to Heather’s blog article about the changes:

Looks great to me - no 404 messages that I could find.

-- 

Doug Royer - (http://K7DMR.us / http://DougRoyer.US)
[email-masked]
714-989-6135

---

From: Jari Arkko <[email-masked]>
Date: Tue, 13 Oct 2015 14:03:40 +0300

Thanks for all the feedback, by the way.

Jari

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Tue, 13 Oct 2015 08:56:30 -0700

On 10/12/15 11:00 AM, Hector Santos wrote:
>>>> Will there ever be a web site redesign that does not generate
>>>> a 404? Probably not.
>>> 
> +1.  Define 404 as TBD pages, e.g. redirect to a "pretty"
> 404/resource missing IETF form with IETF-intelligent links.
> 

Good idea. I've added it to the list.

Thanks for the feedback, everyone!

- -Heather

---

From: [email-masked] (Martin Rex)
Date: Wed, 14 Oct 2015 16:47:36 +0200 (CEST)

The RFC Editor website currently provides URLs to a TXT (normative)
and PDF (non-normative) variant to an RFC, but no link to the
HTML-ized rfcmarkup version of the document on the tools.ietf.org
website, and neither a link to the datatracker about the document.

Personally, I'm using URLs to the tools-variant of RFCs and I-Ds
when quoting stuff in discussions, because one can use anchor tags
on the HTML-ized (rfcmarkup) versions of the document (by section/appendix
or by page) if the document isn't too old.

e.g.
   https://www.rfc-editor.org/info/rfc5681

   https://tools.ietf.org/html/rfc5681

   https://datatracker.ietf.org/doc/rfc5681/

I just noticed that the rfcmarkup page of rfc5681 does not link to
the datatracker.  I need to first navigate to the rfcmarkup of the
final I-D (draft-ietf-tcpm-rfc2581bis) in order to obtain a [Tracker]
URL at the top.

Curiously, the datatracker links to tools.ietf.org only for the html
version of the document, and to www.rfc-editor.org for the plain text
and pdf versions, whereas the tools rfcmarkup header links [txt|pdf]
locally on the tools server.

-Martin

---

From: t.p. <[email-masked]>
Date: Fri, 16 Oct 2015 10:54:27 +0100

----- Original Message -----
From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
To: "t.p." <[email-masked]>; "IETF" <[email-masked]>
Sent: Monday, October 12, 2015 4:38 PM
Subject: Re: The New RFC Editor Website

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>

And today, my mileage is consistently the same as yours; Murphy strikes
again!.

Tom Petch

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2
> Comment: GPGTools - http://gpgtools.org
>
> iQEcBAEBCAAGBQJWG9PdAAoJEER/xjINbZoGQIQH/09uTz8A1mYp9g9UtrwOYlL2
> XO3sb/JYT4bq2Zq/E2NpqDs89KwObeKLfy7c2nLjj+Tezw6i7EJbSNq+qJPwMjWM
> an9UUTMJTkUuxQnKUL+WGciv9D0b2KaCcJLNN9VKq0ey/YJYazR7RJmdxsodktP1
> IHfrXXeXECe5K967u2w+UEChJI0SAbe2GkKbmjoW/bsbm7OTIYeKmI/Yvjr6BwvP
> 1aQ0QQFJ8wW/dxqHNTQHLfsf+7o0YeyBVVLiKaWUKwG4FelcPX9yP4tpZ2+I0tjG
> 01hvOGEZlC3NRmBhmQPeAG3MCnxeqtjkMSxOkecLk97SQ35R2nRx+W/M8LHvgsw=
> =1e9i
> -----END PGP SIGNATURE-----
>
>