Subject: Re: Protocol Action: 'Captive-Portal Identification in DHCP / RA' to Proposed Standard (draft-wkumari-dhc-capport-16.txt)

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 9 Oct 2015 19:53:44 +0200

Hello,

Please allow me a comment on this RFC.

During my recent travel I encountered two hotspots which re-direct to 
"controller.access.network" FQDN in the URL bar of the browser.

It looked to me as a 'standardized' FQDN since the domain .network does 
not exist AFAIK, and since this was on two different hotspots (hotel and 
airport).  Is access.network a standardized domain? (I am thinking of a 
test domain or so).

If so then that might be the content of this DHCP/RA option proposed in 
the RFC?

Alex

Le 30/09/2015 03:32, The IESG a écrit :
> The IESG has approved the following document:
> - 'Captive-Portal Identification in DHCP / RA'
>    (draft-wkumari-dhc-capport-16.txt) as Proposed Standard
>
> This document has been reviewed in the IETF but is not the product of an
> IETF Working Group.
>
> The IESG contact person is Joel Jaeggli.
>
> A URL of this Internet Draft is:
> https://datatracker.ietf.org/doc/draft-wkumari-dhc-capport/
>
>
>
>
>
> Technical Summary
>
>     This document describes a DHCP option and an RA extension to inform
>     nodes that they are behind some sort of captive portal device, and
>     that they will need to authenticate to get Internet Access.
>
> Working Group Summary
>
>     This document was reviewed by the DHC working group, but was not adopted
>     there because the work is not in charter.   Because it defines new DHCP options,
>     it's not really in charter for 6man either. Taken forward as an AD sponsored
>     it has had abundant review. been the inspiration for a BOF and generally
>     received positive attention.
>
> Document Quality
>
>     Dan L??dtke has done an implementation of the router side of the RA option.
>     We are aware of no RA listener implementations nor DHCP client
>     implementations.   Because this document defines DHCP options,
>     any generally-configurable DHCP server or client can
>     readily be configured to support this new option, typically without recompilation.
>     The option question for this document is whether captive portal manufacturers
>     and, more importantly, DHCP client implementors and RA listener implementors
>     will see the extension as valuable and make use of it.
>
>     The reason for advancing it at this stage rather than waiting for widespread
>     adoption is that until a standard format is defined, the extension serves no
>     useful purpose and cannot be deployed.   By documenting this extension,
>     we hope to provide an opportunity for improvement in the way captive
>     portals are operated.
>
> Personnel
>
> Ted Lemon is the document shepherd.
> Joel Jaeggli is the responsible AD.
>
>

---

From: Jaap Akkerhuis <[email-masked]>
Date: Fri, 09 Oct 2015 20:05:55 +0200

> airport).  Is access.network a standardized domain? (I am thinking of a 

It seems to exist, see below.

	jaap

whois -h whois.donuts.co access.network

Domain Name: access.network
Domain ID: 4911f43c8419487cb1bf66d38c65baa5-D
WHOIS Server: http://whois.ovh.com
Referral URL: http://www.ovh.com
Updated Date: 2015-03-24T12:30:32Z
Creation Date: 2015-03-19T12:30:20Z
Registry Expiry Date: 2016-03-19T12:30:20Z
Sponsoring Registrar: OVH SAS
Sponsoring Registrar IANA ID: 433
Domain Status: clientDeleteProhibited https://www.icann.org/epp#clientDeleteProhibited
Domain Status: clientTransferProhibited https://www.icann.org/epp#clientTransferProhibited
Registrant ID: ovh550ac3710a4h
Registrant Name: Didier PLATEAU
Registrant Organization: Ucopia Communications
Registrant Street: 201 Avenue Pierre Brossolette
Registrant City: Montrouge
Registrant State/Province:
Registrant Postal Code: 92120
Registrant Country: FR
Registrant Phone: +33.140927390
Registrant Phone Ext:
Registrant Fax:
Registrant Fax Ext:
Registrant Email: [email-masked]
Admin ID: ovh550ac3720o99
Admin Name: Didier PLATEAU
Admin Organization: Ucopia Communications
Admin Street: 201 Avenue Pierre Brossolette
Admin City: Montrouge
Admin State/Province:
Admin Postal Code: 92120
Admin Country: FR
Admin Phone: +33.140927390
Admin Phone Ext:
Admin Fax:
Admin Fax Ext:
Admin Email: [email-masked]
Tech ID: ovh550ac3720o99
Tech Name: Didier PLATEAU
Tech Organization: Ucopia Communications
Tech Street: 201 Avenue Pierre Brossolette
Tech City: Montrouge
Tech State/Province:
Tech Postal Code: 92120
Tech Country: FR
Tech Phone: +33.140927390
Tech Phone Ext:
Tech Fax:
Tech Fax Ext:
Tech Email: [email-masked]
Name Server: dns200.anycast.me
Name Server: ns200.anycast.me
DNSSEC: signedDelegation
>>> Last update of WHOIS database: 2015-10-09T17:58:08Z <<<

For more information on Whois status codes, please visit https://www.icann.org/resources/pages/epp-status-codes-2014-06-16-en

Terms of Use: Users accessing the Donuts WHOIS service must agree to use the data only for lawful purposes, and under under no circumstances use the data to: Allow, enable, or otherwise support the transmission by e-mail, telephone, or facsimile of mass unsolicited, commercial advertising or solicitations to entities other than the registrar's own existing customers. Enable high volume, automated, electronic processes that send queries or data to the systems of Donuts or any ICANN-accredited registrar, except as reasonably necessary to register domain names or modify existing registrations. When using the Donuts Whois service, please consider the following: The Whois service is not a replacement for standard EPP commands to the SRS service. Whois is not considered authoritative for registered domain objects. The Whois service may be scheduled for downtime during production or OT&E maintenance periods. Queries to the Whois services are throttled. If too many queries are received from a single IP address within a specified time, the service will begin to reject further queries for a period of time to prevent disruption of Whois service access.

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 9 Oct 2015 20:09:11 +0200

> whois -h whois.donuts.co access.network

Ah, visibly the filters were not open when I tried that, sorry.  Thanks.

Alex

> Terms of Use: Users accessing the Donuts WHOIS service must agree to use the data only for lawful purposes, and under under no circumstances use the data to: Allow, enable, or otherwise support the transmission by e-mail, telephone, or facsimile of mass unsolicited, commercial advertising or solicitations to entities other than the registrar's own existing customers. Enable high volume, automated, electronic processes that send queries or data to the systems of Donuts or any ICANN-accredited registrar, except as reasonably necessary to register domain names or modify existing registrations. When using the Donuts Whois service, please consider the following: The Whois service is not a replacement for standard EPP commands to the SRS service. Whois is not considered authoritative for registered domain objects. The Whois service may be scheduled for downtime during production or OT&E maintenance periods. Queries to the Whois services are throttled. If too many queries are rec!
 eived fr
om a single IP address within a specified time, the service will begin to reject further queries for a period of time to prevent disruption of Whois service access.