Subject: email reminders say when a draft expires, but not that you can't submit?

From: <[email-masked]>
Date: Tue, 20 Oct 2015 05:58:46 +0000

Well, this is mildly irritating.

Had a bunch of warnings about drafts expiring:

***
IETF Secretariat <[email-masked]>
To	[email-masked] Oct 19 at 10:42 PM
The following draft will expire soon:

Name:    draft-wood-tsvwg-saratoga
Title:    Saratoga: A Scalable Data Transfer Protocol
State:    I-D Exists
Expires:  2015-10-20 (in 19 hours, 17 minutes)
***

Drafts were expiring sometime on the 20th of October (in, one presumes, the US, because no timezone was given, and the IETF is very much a US organisation. I live in Australia, no timezone for expiry time given on these emails.)

So I refreshed the draft ready to do the necessary six-month accounting. Only to discover that I-D submission had already closed at midnight UTC on the 19th because of the upcoming IETF meeting. Which wasn't mentioned in the email.

Why not state the earlier submission deadline as well as a hard limit? Why aren't timezones stated?

Bravo for https://datatracker.ietf.org/submit/ stating timezones, if not consistently.

Please file lack of timezones and lack of consideration of early submission deadlines as a bug.

thanks
Lloyd Wood
http://about.me/lloydwood

---

From: Randy Bush <[email-masked]>
Date: Tue, 20 Oct 2015 08:55:31 +0200

damned shame there is not a universal cordinated time

randy

---

From: Bob Hinden <[email-masked]>
Date: Tue, 20 Oct 2015 08:24:23 -0700

> On Oct 19, 2015, at 11:55 PM, Randy Bush <[email-masked]> wrote:
> 

Agree, it should have a UTC time.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Oct 2015 08:21:34 +1300

On 20/10/2015 18:58, [email-masked] wrote:
...
> Drafts were expiring sometime on the 20th of October (in, one presumes, the US, because no timezone was given, and the IETF is very much a US organisation. I live in Australia, no timezone for expi…

Agree that stating it precisely in UTC would not be a bad thing, but...

> So I refreshed the draft ready to do the necessary six-month accounting.

...if the only reason to re-post a draft is the expiry, it isn't worth
reposting, IMHO. In fact it's a bit deceptive: people might think the draft
is still under development when it isn't.

> Only to discover that I-D submission had already closed at midnight UTC on the 19th because of the upcoming IETF meeting. Which wasn't mentioned in the email.

Er, does it actually matter to anybody if the draft is refreshed with the same content
and a different date two weeks later?

> Why not state the earlier submission deadline as well as a hard limit?

See previous comment.

   Brian

---

From: Mark Andrews <[email-masked]>
Date: Wed, 21 Oct 2015 09:38:52 +1100

In message <[email-masked]>, Brian E Carpenter writes:
> > Drafts were expiring sometime on the 20th of October (in, one presumes, the US, because no timezone was given, and the IETF is very much a US org
> anisation. I live in Australia, no timezone for expiry time given on these emails.)
> 

In some cases this is due to chairs not processing the document in
a timely manner.  I've had wg last call write ups take over a year
on multiple documents (same working group, different sets of chairs)
despite multiple reminders to the chairs.

> > Only to discover that I-D submission had already closed at midnight UTC on the 19th
> because of the upcoming IETF meeting.  Which wasn't mentioned in the email.
> 

Yes.  A expired document is presumed to be abandoned.  You send the
wrong message by having a expired document.

I think the point is that the reminder should have the next submission
cut off date in it as well as the reopening date so people can plan
the work appopriately and the reminder should be timely enough that
you can do a update before the submission deadline.

Any reminders due between the submission cut off and a week after
the submission queue re-opens should be brought forward by the cut
off interval plus 2 weeks.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742                 INTERNET: [email-masked]

---

From: joel jaeggli <[email-masked]>
Date: Tue, 20 Oct 2015 16:03:30 -0700

The draft deadline is to provide for a break between the time of
submission and the meeting proper. a lot of work has to be done to
agendas, reading and so on in the interceeding two weeks. Nevertheless
we have an established system for  exception handling so if for whatever
reason a updated draft really needs to be posted in the next two weeks,
ask the responsible AD, and it will be addressed.

---

From: Mark Andrews <[email-masked]>
Date: Wed, 21 Oct 2015 10:15:26 +1100

> ask the responsible AD, and it will be addressed.

Why force people to use the exception mechanisms when a little bit
of proactive action can avoid the issue altogether?

Mark

---

From: joel jaeggli <[email-masked]>
Date: Tue, 20 Oct 2015 16:51:18 -0700

> of proactive action can avoid the issue altogether?

I doubt very much this is the sole reason where recourse to exception
handling is necessary.

This doesn't need to be debated it can simply be handled.

If it doesn't need to be addressed because it's not actually a problem
so much the better.

joel

---

From: Mark Andrews <[email-masked]>
Date: Wed, 21 Oct 2015 11:29:06 +1100

> If it doesn't need to be addressed because it's not actually a problem

Below is the last expire message due that I got.  You will note
that it was sent 9 days before the expiry was due but we now have
a 2 week embargo period (it used to 1 week for existing drafts and
9 days was barely enough time to get a revision in under the deadline,
but people gamed the system).  There is no indication of when the
embargo period will occur.

Name:     draft-ietf-dnsop-rfc6598-rfc6303
Title:    Add 100.64.0.0/10 prefixes to IPv4 Locally-Served DNS Zones Registry.
State:    I-D Exists
Expires:  2015-04-30 (in 1 week, 2 days)

How hard would it to be to add one or two lines saying when the
submission embargo will be to this message?

Mark

---

From: <[email-masked]>
Date: Wed, 21 Oct 2015 00:29:22 +0000

> off interval plus 2 weeks.

exactly. Give advance warning, get more drafts updated in a timely manner for meetings.

I mean, six months ago I submitted drafts before the expiry date and IETF meeting deadline, and now, six months later, it's after the meeting deadline, so the meeting's... er, slightly earlier in the cycle?

(in the case of http://saratoga.sf.net/ experience is slowly shaking out and improving nuances of draft text, and I'm learning that implementing complex transport protocols from scratch is a very slow process. No need to push a slightly updated draft through specially for Japan - it's not an exception.)

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf <[email-masked]> on behalf of joel jaeggli <[email-masked]>
Sent: Wednesday, 21 October 2015 10:03 AM
To: Mark Andrews; Brian E Carpenter
Cc: [email-masked]
Subject: Re: email reminders say when a draft expires, but not that you can't submit?

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 21 Oct 2015 04:56:04 +0000

> On Oct 20, 2015, at 7:15 PM, [email-masked] wrote:
> 
> Why force people to use the exception mechanisms when a little bit of proactive action can avoid the issue altogether?

What specifically are you asking? Are you asking the IESG to be proactive, or the working group chair, or the author(s)? In what specific way would you like people to be proactive?

---

From: <[email-masked]>
Date: Thu, 22 Oct 2015 04:40:16 +0000

https://datatracker.ietf.org/doc/search/?name=saratoga&activeDrafts=on

on the plus side, the draft tools seem to recognise that the tool is closed, so these drafts that expired after it was shut haven't actually expired yet...

Lloyd Wood
http://about.me/lloydwood
________________________________________
From: ietf <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Wednesday, 21 October 2015 11:29 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: email reminders say when a draft expires, but not that you can't submit?

Lloyd Wood

---

From: t.p. <[email-masked]>
Date: Thu, 22 Oct 2015 09:12:22 +0100

---- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, October 20, 2015 8:21 PM
> > Drafts were expiring sometime on the 20th of October (in, one
presumes, the US, because no timezone was given, and the IETF is very
much a US organisation. I live in Australia, no timezone for expiry time
given on these emails.)
> is still under development when it isn't.

Brian,

Yes but ...

For most of the life of the IETF, it has been difficult or impossible to
get hold of an expired draft.  At some point, the web site started
making this possible, but I have never seen a commitment to doing so on
into the future; and so many good innovations just vanish, perhaps
because the world at large did not take them on.

So yes, I would encourage a refresh unless and until it is clearly
stated that the latest version of an I-D, no matter how long ago it was
posted, will remain available in perpetuity,

Tom Petch

> > Only to discover that I-D submission had already closed at midnight
UTC on the 19th because of the upcoming IETF meeting. Which wasn't
mentioned in the email.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 22 Oct 2015 09:34:56 -0400

> posted, will remain available in perpetuity,

My understanding is that IETF is now committed to keeping the drafts
repository data forever unless there is a specific reason to delete
specific material (e.g. someone uploads the Windows source file in a
draft)

The main reason for the change was people like me who take expert
witness work, pointing out that we need the drafts repository as
valuable source material for our prior art searches. I used it only
last month when a plaintiff decided to go looking for hurt with a
third party subpoena.

I design Internet protocols that are intended to be unencumbered.
Consequently, I use twenty year old expired internet drafts in the
course of my daily business.

---

From: Mark Andrews <[email-masked]>
Date: Fri, 23 Oct 2015 09:13:47 +1100

In message <[email-masked]>, "Fred Baker (fred)" writes:
> > Why force people to use the exception mechanisms when a little bit of
> > proactive action can avoid the issue altogether?
>
> What specifically are you asking? Are you asking the IESG to be
> proactive, or the working group chair, or the author(s)? In what specific
> way would you like people to be proactive?

The last reminder I got had a 9 days until the draft expired.  The
reminder that triggered this thread had 1.x days and less time than
that to submit before the embargo.

That all reminders that would be sent out in the 9 days upto the
submissing embargo and all reminders that would be sent during the
submission embargo be brought forward to the T-9 days.

That the start and end times of the current/next submission embargo
be in the reminder emails.

The allows all authors 9 days in which to submit a update after the
reminder without encountering a embargo period.  It also allows
authors to plan their work schedule without having to go and lookup
when the next embargo period starts.

Getting a reminder, doing the work, then not being able to submit
it because you ran into the embargo period kind of defeats the
purpose of the reminder.

Mark