Subject: I-D "Unwritten Rules and Values of the IETF" (Mentoring)

From: <[email-masked]>
Date: Tue, 15 Dec 2015 18:29:29 +0000 (UTC)

Hello all,

I have just posted an I-D "Unwritten Rules and Values of the IETF".

https://datatracker.ietf.org/doc/draft-elkins-ietf-unwritten-rules-values/ 

I feel that having something like this will be of quite a bit of help to new people at the IETF, in particular, the mentees in the IETF mentoring program.

We would very much like to start the discussion and get consensus, if possible!

In the interests of not clogging up the IETF main list, if you would like to discuss, please register and comment on the mentoring email list.  Love to have your thoughts!
This is the list for mentoring discussions: https://www.ietf.org/mailman/listinfo/ietf-mentoring-discuss 

The abstract of this I-D is below:
Abstract 

The intent of this document is to speed up the process by which someone new to the IETF, can understand the objectives, fathom the environment, comprehend the culture, learn to navigate the problems, overcome the obstacles, and become a more productive IETF participant, in a shorter amount of time. Further, this document is intended to pass along the learning and experiences of people who have absorbed these values, perhaps in a much longer amount of time and with much greater effort and even hardship.  

Thanks,

Nalini ElkinsIETF Mentoring Program
Inside Products, Inc.
www.insidethestack.com
(831) 659-8360

---

From: Randy Bush <[email-masked]>
Date: Wed, 16 Dec 2015 14:23:51 +0900

a nice piece.  i am usually suspicious of, and disappointed in, social
documents.  this one may actually be quite helpful.  thank you.

randy

---

From: Alexey Eromenko <[email-masked]>
Date: Wed, 16 Dec 2015 09:06:18 +0200

Yes, I read few parts, and looks good.

Now, being new here, I really can't judge on the accuracy of the claims and
IETF values, but looks good.

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 16 Dec 2015 12:04:17 +0000

> documents.  this one may actually be quite helpful.  thank you.

I agree, it's not perfect (will send comments later) but I really like
the idea that we're all dandelions:-) Good job.

S.

---

From: <[email-masked]>
Date: Wed, 16 Dec 2015 14:41:02 +0000 (UTC)

>documents.  this one may actually be quite helpful.  thank you.

Thanks, Randy.   It means a lot to me to have you say that.
Nalini

---

From: <[email-masked]>
Date: Wed, 16 Dec 2015 14:45:36 +0000 (UTC)

>the idea that we're all dandelions:-) Good job.
Thanks, Stephen.  Look forward to comments.  It is version 00, so I know there is work to be done.
Nalini

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 16 Dec 2015 09:49:00 -0500

As other people have said, this appears to be a useful document.
I will be re-reading it, and hope to comment on the mentoring discussion 
list.

Yours,
Joel

On 12/15/15 1:29 PM, [email-masked] wrote:
> I feel that having something like this will be of quite a bit of help to
> new people at the IETF, in particular, the mentees in the IETF mentoring
> program.
>
> In the interests of not clogging up the IETF main list, if you would
> like to discuss, please register and comment on the mentoring email
> list.  Love to have your thoughts!
>
> This is the list for mentoring discussions:
> https://www.ietf.org/mailman/listinfo/ietf-mentoring-discuss
>
>
> The intent of this document is to speed up the process by which someone
> new to the IETF, can understand the objectives, fathom the environment,
> comprehend the culture, learn to navigate the problems, overcome the
> obstacles, and become a more productive IETF participant, in a shorter
> amount of time. Further, this document is intended to pass along the
> learning and experiences of people who have absorbed these values,
> perhaps in a much longer amount of time and with much greater effort and
> even hardship.
>
> Thanks,
>
> Nalini Elkins
> IETF Mentoring Program
>
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360

---

From: <[email-masked]>
Date: Wed, 16 Dec 2015 14:49:21 +0000 (UTC)

>Yes, I read few parts, and looks good. >Now, being new here, I really can't judge on the accuracy of the claims and IETF values, but looks good. 
Thanks, Alexey.  On behalf of the IETF Mentoring program, if you would like a mentor, as you are new here, please contact me on my email above and I will see what I can do.
Nalini

randy

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Wed, 16 Dec 2015 15:05:02 +0000

Hi:

Very nice work. It should be very useful to newcomers (and even to long time attendees to refresh their view of the IETF and process).

- Bernie

From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 16, 2015 at 9:41 AM
To: Randy Bush <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: I-D "Unwritten Rules and Values of the IETF" (Mentoring)

Nalini

---

From: Theodore V Faber <[email-masked]>
Date: Wed, 16 Dec 2015 15:28:00 +0000

On 12/15/15, 21:23, "ietf on behalf of Randy Bush" <[email-masked]

>documents.  this one may actually be quite helpful.  thank you.

I was planning to have a look, but now I’ve bumped it up my priority list.

Thanks for piping up, Randy.

-- 
Ted Faber <[email-masked]>
Engineering Specialist
Computer Systems Research Department
310-336-7373

---

From: Vinayak Hegde <[email-masked]>
Date: Wed, 16 Dec 2015 21:08:34 +0530

On Tue, Dec 15, 2015 at 11:59 PM,  <[email-masked]> wrote:
> I feel that having something like this will be of quite a bit of help to new
> people at the IETF, in particular, the mentees in the IETF mentoring
> program.
>
> In the interests of not clogging up the IETF main list, if you would like to
> discuss, please register and comment on the mentoring email list.  Love to
> have your thoughts!
>
> The intent of this document is to speed up the process by which someone new
> to the IETF, can understand the objectives, fathom the environment,
> learning and experiences of people who have absorbed these values, perhaps
> in a much longer amount of time and with much greater effort and even
> hardship.
>
> Thanks,
>
> Nalini Elkins
> IETF Mentoring Program

This is a good first draft. I have already sent some comments
privately. I will continue the discussion on the mentoring mailing
list.

-- Vinayak

---

From: [email-masked]
Date: Wed, 16 Dec 2015 07:36:55 -0800 (PST)

> I will be re-reading it, and hope to comment on the mentoring discussion

I concur with what Joel and everyone else has said: This is very good piece of
work. I wish I had time to contribute substantially to its further development,
but sadly, I really don't. I will try and review and comment on it in detail
once it's further along though.

				Ned

---

From: <[email-masked]>
Date: Wed, 16 Dec 2015 15:55:15 +0000 (UTC)

Thanks, Ned!
      From: Ned Freed <[email-masked]>

                Ned

---

From: Thiago Marinello <[email-masked]>
Date: Wed, 16 Dec 2015 17:34:27 +0000

> I have just posted an I-D "Unwritten Rules and Values of the IETF".

Initially I thought that the TAO of IETF has already addressed all
typical questions for a newcomer, but reading the draft I realized
that this idea is great. This kind of information will be very helpful
for new IETF participants.

I suggest publish the final version of this document in other
languages (like Portuguese, Spanish and others) the same way did with
TAO. I'd like to help with this.

__
 Thiago Marinello

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 Dec 2015 09:13:54 +1300

> for new IETF participants.

Which brings up a question I was meaning to ask anyway: once this is done,
should we actually incorporate it in the Tao? (The Tao is a community
document that happens to be maintained as a web page instead of an RFC,
so we could certainly decide to do this.)

Glancing at the Tao, it needs an update anyway (obsolete references etc.)

> TAO. I'd like to help with this.

Good idea.

   Brian

---

From: <[email-masked]>
Date: Wed, 16 Dec 2015 20:30:17 +0000 (UTC)

>Good idea.

Thanks, Brian & Thiago for your support!

Another thing that has come up is if people in different regions want to do presentations (PPTs) using this material either for outreach or for boot camps to get people started in IETF activities.   After we get consensus on a final document, then maybe we can create a PPT & have it translated for people to use in their regions.

Nalini

---

From: Rich Kulawiec <[email-masked]>
Date: Thu, 17 Dec 2015 05:52:24 -0500

On Wed, Dec 16, 2015 at 08:30:17PM +0000, [email-masked] wrote:
> 
> Another thing that has come up is if people in different regions want to do presentations (PPTs) [snip]

Please do not destroy the potential of a promising document by rendering
it in an obsolete, proprietary, utterly worthless format that should
never be used by anyone, ever.

---rsk

---

From: Eliot Lear <[email-masked]>
Date: Thu, 17 Dec 2015 14:08:43 +0100

Nice job.

I'd say, however, that this paints a very rosy picture of the IETF. 
Maybe that's aspirational.  Understanding why one is in the room in the
first place, and why others are in the room is an important success
factor.  I think the draft actually does a pretty good job of explaining
why without actually stating it as such ;-)

Eliot

On 12/15/15 7:29 PM, [email-masked] wrote:
> I feel that having something like this will be of quite a bit of help
> to new people at the IETF, in particular, the mentees in the IETF
> mentoring program.
>
> This is the list for mentoring
> discussions: https://www.ietf.org/mailman/listinfo/ietf-mentoring-discuss 
>
>
> The intent of this document is to speed up the process by which
> someone new to the IETF, can understand the objectives, fathom the
> environment, comprehend the culture, learn to navigate the problems,
> overcome the obstacles, and become a more productive IETF participant,
> in a shorter amount of time. Further, this document is intended to
> pass along the learning and experiences of people who have absorbed
> these values, perhaps in a much longer amount of time and with much
> greater effort and even hardship.  
>
> Thanks,
>
> Nalini Elkins
> IETF Mentoring Program
>
> Inside Products, Inc.
> www.insidethestack.com
> (831) 659-8360

---

From: <[email-masked]>
Date: Thu, 17 Dec 2015 13:48:57 +0000 (UTC)

From: Eliot Lear <[email-masked]>

>Nice job. 
Thank you.
 
>I'd say, however, that this paints a very rosy picture of the IETF.  Maybe that's aspirational.  Understanding why one is in the room in the first place, and why others are in the room is an >important success factor.  I think the draft actually does a pretty good job of explaining why without actually stating it as such ;-)
 
 Yes, I know that sometimes things go sadly astray.  But, I think it is important to try to follow these values - so I suppose it is aspirational.  A positive vision to reach for that IMHO we reach many times.

Thanks,
Nalini

---

From: <[email-masked]>
Date: Thu, 17 Dec 2015 13:50:05 +0000 (UTC)

From: Rich Kulawiec <[email-masked]>

>never be used by anyone, ever.
Thanks for your comments, Rich!
Nalini