Subject: Response to Jari's blog

From: "Olle E. Johansson" <[email-masked]>
Date: Wed, 30 Dec 2015 21:26:22 +0100

Hi!

Thank you Jari, for a great summary of 2015. 

One thing I’m missing is a continued focus on IPv6. I think there has to be some pressure and ways to handle IPv6 bugs in current RFCs outside of the normal process.

We have submitted several drafts to the dispatch and sipcore working groups, all died because of a lack of interest and discussion in the group. The bugs we found in the SIP protocol still remains and needs to be fixed in order for SIP implementations to handle dual stacks properly - but I can’t find a way to get this published following the normal process.

So we have bugs related to IPv6, we have a group of authors and the documents still are not going anywhere because a lack of interest.

I know that we have several bugs related to TLS handling in the SIP protocol as well. The handling of IPv6 issues doesn’t make me very positive about even bothering with writing any drafts about them.

Yes, I am pessimistic. Yes, I am pretty sure there are other protocols that have bugs related to both IPv6 and TLS handling. I think the IETF needs to find a way to handle these even in low-energy working groups like the SIPcore group.

Happy New Year!

/O

---

From: Jari Arkko <[email-masked]>
Date: Thu, 31 Dec 2015 00:06:22 +0200

Hi Olle,

> One thing I’m missing is a continued focus on IPv6.

If you were referring to the blog, I had to choose a set of issues to highlight. But I think you are referring to actual IETF or industry focus, so lets talk...

> I think there has to be some pressure and ways to handle IPv6 bugs in current RFCs outside of the normal process.
> 

This sounds familiar from many contexts, in standards, products, and open source :-)

Everybody is focused on adding new features, and making sure the thing actually works under all circumstances gets sadly less attention.

> Yes, I am pessimistic. Yes, I am pretty sure there are other protocols that have bugs related to both IPv6 and TLS handling. I think the IETF needs to find a way to handle these even in low-energy…

I don’t think we can entirely ignore our normal process. And by “normal process” I don’t necessarily mean the formal part of our process, but rather the fact that the core function of standards is that you have multiple people that agree on something. One or even a couple of people can’t be the only ones looking at something if we want to have a standard. That being said, the existence of a bug is a bad thing. It says something about the state or deployment of that particular part of the standard.

However, I am not pessimistic. We often highlight issues in the IETF and ensure that chairs and participants understand the importance, and then we pull through. Let me talk to my fellow ADs about what we could about this case. Do you have a list of drafts that you would like to move forward?

Jari

---

From: "Olle E. Johansson" <[email-masked]>
Date: Wed, 30 Dec 2015 23:18:43 +0100

> On 30 Dec 2015, at 23:06, Jari Arkko <[email-masked]> wrote:
> 
> Hi Olle,
> 
> If you were referring to the blog, I had to choose a set of issues to highlight. But I think you are referring to actual IETF or industry focus, so lets talk…
I know, it’s hard writing a blog and I do understand that you couldn’t cover all. But since you asked for feedback :-)

> Everybody is focused on adding new features, and making sure the thing actually works under all circumstances gets sadly less attention.
Don’t I know it from the Open Source projects I’m involved in :-)

> However, I am not pessimistic. We often highlight issues in the IETF and ensure that chairs and participants understand the importance, and then we pull through. Let me talk to my fellow ADs about…

I will forward the list separately - but in general, I think there has to be some issues that ADs need some pressure to move on and help generate momentum. Security is one, IPv6 is another that spans a lot of working groups. Maybe we need ambassadors that help these ADs and groups to focus on these issues. To me, it feels wrong that the IETF doesn’t have focus and energy to fix IPv6 issues - what message does it give to the implementors?

Happy New Year!

/O

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 31 Dec 2015 12:59:10 +1300

On 31/12/2015 09:26, Olle E. Johansson wrote:
...
> So we have bugs related to IPv6, we have a group of authors and the documents still are not going anywhere because a lack of interest.

Interest is usually generated by unhappy users, and there isn't quite enough of
the world depending on IPv6 yet to create the necessary unhappiness. I'm not
pessimistic though: we just have to be patient, and eventually the pointy-haired
bosses will start to insist on fixing IPv6 bugs.

And it isn't just the IETF. Just to take a random example that bit me recently,
why doesn't the Python socket module define IPPROTO_IPV6? A tiny thing that is
easy to work around, but I gather it's been like that for years.

   Brian