Subject: Re: Call for Comment: RFC Format Drafts

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 11 Feb 2016 20:02:38 -0500

Is there an example of the proposed format in use anywhere?

On Thu, Feb 11, 2016 at 12:39 PM, IAB Executive Administrative Manager
<[email-masked]> wrote:
> This is an announcement of an IETF-wide Call for Comment on
> the RFC Format Drafts. These documents are being considered for
> publication as Informational RFCs within the IAB stream.  The suggested
> reading order is:
>
> 1. The big picture
>
> - - - Flanagan, H., "RFC Format Framework",
>    http://datatracker.ietf.org/doc/draft-iab-rfc-framework/
>
> 2. The underlying vocabulary
>
> - - - Hoffman, P., "The 'XML2RFC' version 3 Vocabulary",
>     https://datatracker.ietf.org/doc/draft-iab-xml2rfc/
>
> 3. The outputs
>
> - - - Hildebrand, J. and P. Hoffman, "HyperText Markup
>    Language Request For Comments Format”,
>    https://datatracker.ietf.org/doc/draft-iab-html-rfc/
>
> - - - Flanagan, H., "Requirements for Plain Text RFCs",
>    https://datatracker.ietf.org/doc/draft-iab-rfc-plaintext/
>
> - - - Hansen, T., Masinter, L., and M. Hardy, "PDF for
>    an RFC Series Output Document Format”,
>    https://datatracker.ietf.org/doc/draft-iab-rfc-use-of-pdf/
>
> - - - Brownlee, N., "SVG Drawings for RFCs: SVG 1.2 RFC",
>    https://datatracker.ietf.org/doc/draft-iab-svg-rfc/
>
> 4. Generalized requirements
>
> - - - Flanagan, H., "The Use of Non-ASCII Characters in RFCs",
>    https://www.ietf.org/id/draft-iab-rfc-nonascii-00.pdf
>
> - - - Flanagan, H., “CSS Requirements for RFCs”,
>    https://datatracker.ietf.org/doc/draft-iab-rfc-css/
>
> 5. Workflow and tools (note that the examples draft will
>    not become an RFC, but is necessary for the project)
>
> - - - Hildebrand, J. and P. Hoffman, "RFC v3 Prep Tool Description",
>    https://datatracker.ietf.org/doc/draft-iab-rfcv3-preptool/
>
> - - - Hoffman, P. and T. Hansen, "Examples of the ‘XML2RFC'
>    Version 2 and 3 Vocabularies”,
>    http://datatracker.ietf.org/doc/draft-hoffman-rfcexamples/
>
> 6. The Statements of Work
>
> - - - http://www.nostrum.com/~rjsparks/rfced/
>
> The Call for Comment will last until 2016-03-10. Please send comments to
> [email-masked]. For comments on individual drafts, please include the
> relevant document filename in the subject line.
>

---

From: "Heather Flanagan (RFC Series Editor)" <[email-masked]>
Date: Fri, 12 Feb 2016 07:58:20 -0800

Hello Philip,

In production or as a prototype? In production, no. As a prototype,
yes. You can find v3 XML and associated HTML here:

http://hildjj.github.io/draft-iab-html-rfc/

Is that what you're looking for?

- -Heather

On 2/11/16 5:02 PM, Phillip Hallam-Baker wrote:
> On Thu, Feb 11, 2016 at 12:39 PM, IAB Executive Administrative
> Manager <[email-masked]> wrote:
>> This is an announcement of an IETF-wide Call for Comment on the
>> RFC Format Drafts. These documents are being considered for 
>> publication as Informational RFCs within the IAB stream.  The
>> suggested reading order is:
>> 
>> 1. The big picture
>> 
>> - - - Hildebrand, J. and P. Hoffman, "HyperText Markup Language
>> Request For Comments Format”, 
>> - - - Hansen, T., Masinter, L., and M. Hardy, "PDF for an RFC
>> Series Output Document Format”, 
>> 5. Workflow and tools (note that the examples draft will not
>> become an RFC, but is necessary for the project)
>> 
>> The Call for Comment will last until 2016-03-10. Please send
>> comments to [email-masked]. For comments on individual drafts,
>> please include the relevant document filename in the subject
>> line.
>> 
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 12 Feb 2016 11:23:07 -0500

Thanks,

I'll try to get round to updating my tools to support the new formats then.

On Fri, Feb 12, 2016 at 10:58 AM, Heather Flanagan (RFC Series Editor)
<[email-masked]> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> Hello Philip,
>
> -----BEGIN PGP SIGNATURE-----
> Comment: GPGTools - http://gpgtools.org
>
> iQIcBAEBCAAGBQJWvgEcAAoJEJlIWQlAXuk2Y9MQANSsSV1SL2M85F1rnw6dafOn
> vzM9rs9nAz3BehX+ilDY9aGcRr1rWyZbt2jm73LmXXZAyS2amLtUEBuK/RoYDjj1
> jBWrzbSVwZoxnoUwT0Q1ckYurni7jzTczwKyOFu4ymgjqfe3HZl3lkvJL3cG8y++
> 6z2kcHLS27blnCmgd6UguTjad6+wK5yXqkHHy92viPSkGDz3RRWngxustvjPxlCj
> AHMtAY/OjWyh1ExqT4ENJIw1jc80CkwzU8LdiYX65DRBvNOTeq9M/BBvJ3R8DLdn
> lR/9v8w8y0+yAEglJAvyqgYKt3c49qPUdZQ2spn83QFbd1KvBPLqJGLqVJNt36RF
> r8BkYO/irbNVt3iNrmlGlIL86l/wtAl+jBANKD2SO1rkXZJkewk4a6dsKgxmtX0S
> 9abpoPeMChLqa7l6Die0Mqpid7ryvaITU4ySsJtY7KMnCsGAYRxowm87KYvvzX7l
> 3a51B6QaNuiPsk/AKsmRKrTb+XENC/UTxyIDgu5hK2zU0FMSx6m8odtQUAgUcqsi
> H1QFY1jThtQ0AmVm2AXGER142uL28XS0Mgsc4BaWPfoA7xRu+JNfgM/Qa8+UZUba
> SPrnTKcvNW3JTZT/jhYjLK4Vfigyr1RobLS38nM4pVv4JtTp2Vz19cVJKP4cqTHZ
> lZZanFqYn2nxhhFqPnQd
> =eB+m
> -----END PGP SIGNATURE-----

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Fri, 12 Feb 2016 17:06:40 +0000

Please let me know if you find any issues in the prototype, in addition to issues you find in the specs.  Also, since the prototype is using... "esoteric" tooling, anyone who is interested in how it works should contact me directly with questions.

-- 
Joe Hildebrand

---

From: Julian Reschke <[email-masked]>
Date: Fri, 12 Feb 2016 18:14:00 +0100

On 2016-02-11 18:39, IAB Executive Administrative Manager wrote:
> ...

I strongly recommend to cc: all feedback to the public mailing list 
rfc-interest (<https://www.rfc-editor.org/mailman/listinfo/rfc-interest>).

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 12 Feb 2016 18:19:30 +0100

> Is there an example of the proposed format in use anywhere?

FWIW, rfc2629.xslt implements a subset of the new vocabulary, see 
<http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#v3> -- 
feedback appreciated.

Best regards, Julian