Subject: wrt quic, plus, and taps?

From: [email-masked]
Date: Wed, 20 Jul 2016 04:22:05 -0600

perhaps someone can explain at some point what the salient  
intersection(s) and difference(s) are between:  quic, plus, and taps ?

thanks,

=JeffH

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 20 Jul 2016 11:34:27 +0100

Is this one of those games?

I can manage
plus
paus
pads
tads
taps

But I have a problem with quic

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jul 2016 00:48:43 +1200

quic
quit
suit
suet
sues
suds
sups
saps
taps

Regards
   Brian

---

From: Brian Trammell <[email-masked]>
Date: Wed, 20 Jul 2016 23:32:25 +0200

hi Jeff,

Thanks for the question. I'll try to answer it succinctly.

QUIC is a transport protocol that runs over UDP, that encrypts almost all of its headers and all of its payload. It does this for privacy and security for the applications running over it, and to separate what the path needs to see from what the endpoints need to see, in order to enable relatively rapid evolution of the protocol. It is presently focused on supporting HTTP/2 as an application, but should be usable for many other applications with broadly similar requirements.

PLUS is a mechanism for building transport protocols with encrypted headers and payload over UDP, to separate what the path needs to see from what the endpoints need to see, in order enable the relatively rapid deployment of multiple transport protocols with a common surface exposed to devices on path. It also supports (optional) facilities for explicit cooperation between applications or transports and devices on path. You'll note these descriptions are quite similar: if PLUS had been built two years ago, it would probably make sense to build QUIC over PLUS. Because QUIC is designed to be easily versionable, future versions of QUIC could run over PLUS. Since QUIC will have to deal with many of the same issues PLUS aims to solve with respect to broadly deployable transports over UDP, deployment and implementation experience with QUIC will definitely inform the detailed design of PLUS.

These are two separate working groups because the focus of PLUS really is on explicit cooperation with on-path devices (under endpoint control) as an architectural pattern, and QUIC on a specific transport protocol.

TAPS is an effort to define a set of "transport services" and the properties thereof, and to support runtime selection of transport protocols based on application requirements in terms of these transport services and on-path support for these protocols. It generalizes the fallback mechanism QUIC uses to select among multiple protocols. QUIC provides another protocol to the set for TAPS to select from. PLUS provides a way to deploy other, future protocols for TAPS to select from.

Hope this helps, cheers,

Brian (no hats)

> On 20 Jul 2016, at 12:22, [email-masked] wrote:
> 
> perhaps someone can explain at some point what the salient intersection(s) and difference(s) are between:  quic, plus, and taps ?
> 
> thanks,
> 
> =JeffH
> 
>