Subject: Re: Correction: Request for Proposal: RFC Format CSS Design

From: Ted Lemon <[email-masked]>
Date: Fri, 22 Jul 2016 13:01:06 +0200

How can it be responsive if the PDF and HTML are to look the same?  On a
phone screen that would be to small to read!

On Jul 22, 2016 12:06, "IETF Administrative Director" <[email-masked]> wrote:

> Correction
> The previous announcement contained an error in the list of
> Deliverables.  Below is the corrected list.
>
> +++++++++++++++++++++++++++++++++++++++++++++
> The IETF Administrative Oversight Committee (IAOC), on behalf of the
> IETF, announces this Request for Proposals for the development of a
> RFC Format CSS Design.  The successful bidder will enter into a
> contract with the Internet Society.
>
> The RFC Editor plans to produce a canonical RFC document in XML
> using the xml2rfc v3 grammar, and to publish the RFC in several
> Publication Formats as defined in RFC6949.  In particular, there
> will be an HTML and PDF output that will support many new features
> within the documents, including SVG line art.  This project will
> result in a CSS file that will reflect visually pleasing,
> accessible, and responsive design.
>
> Deliverables
>
> •       Provide a responsive design CSS for future RFCs following the
> guidance in draft-iab-rfc-css
>
> •       The PDF and HTML output must look as similar as possible
>
> •       All of the HTML features  that have been called out in
> draft-iab-html-rfc need to be in place in the CSS
>
> The RFP can be found at: <https://iaoc.ietf.org/rfps.html>.
>
> Proposals must be received via email at [email-masked] no later
> than September 9, 2016.  All questions, inquiries must be submitted
> by August 8, 2016.  Responses to questions and inquiries shall be
> posted online at:  <https://iaoc.ietf.org/rfps.html> by August 15,
> 2016.
>
> The point of contact regarding this RFP is the IETF Administrative
> Director, Ray Pelletier, [email-masked].
>
> Ray Pelletier
> IAD
>
>

---

From: "John Levine" <[email-masked]>
Date: 22 Jul 2016 11:55:59 -0000

In article <[email-masked]> you write:
>-=-=-=-=-=-

I'm guessing that "as similar as possible" is not a synonym for "the same".

Reformatting stuff to be legible at different sizes and in different
media doesn't strike me as a new or unsolved problem.

>> •       The PDF and HTML output must look as similar as possible

R's,
John

---

From: Yoav Nir <[email-masked]>
Date: Fri, 22 Jul 2016 19:40:52 +0200

Perhaps the same as (or similar to) an A4-sized browser window. Or is it US Letter?

> On 22 Jul 2016, at 1:01 PM, Ted Lemon <[email-masked]> wrote:
> 
> How can it be responsive if the PDF and HTML are to look the same?  On a phone screen that would be to small to read!
> 
> 
> On Jul 22, 2016 12:06, "IETF Administrative Director" <[email-masked] <mailto:[email-masked]>> wrote:
> Correction
> The RFP can be found at: <https://iaoc.ietf.org/rfps.html <https://iaoc.ietf.org/rfps.html>>.
> 
> Proposals must be received via email at [email-masked] <mailto:[email-masked]> no later
> posted online at:  <https://iaoc.ietf.org/rfps.html <https://iaoc.ietf.org/rfps.html>> by August 15,
> 2016.
> 
> Director, Ray Pelletier, [email-masked] <mailto:[email-masked]>.
> 
> Ray Pelletier
> IAD
>

---

From: IETF Administrative Director <[email-masked]>
Date: Fri, 22 Jul 2016 03:06:16 -0700

Correction

Deliverables

Ray Pelletier
IAD

---

From: Joe Hildebrand <[email-masked]>
Date: Fri, 22 Jul 2016 21:33:57 +0200

The intent is that the HTML will be responsive. The PDF will look like the HTML, responsive to an A4 page size with margins set such that it will print adequately on US Letter page size as well.

If you want to read on your phone, and don't have some sort of fancy PDF reader there, use the HTML.

> On Jul 22, 2016, at 1:01 PM, Ted Lemon <[email-masked]> wrote:
> 

-- 
Joe Hildebrand