Subject: RE: [GROW] Last Call: <draft-ietf-grow-blackholing-00.txt> (BLACKHOLE BGP Community for Blackholing) to Proposed Standard

From: Michel Py <[email-masked]>
Date: Sat, 2 Jul 2016 02:20:32 +0000

> Thomas Mangin wrote :
> A long time ago, working for another employer, my team wrote a software called ’CleanFeed’ (it was trademarked - a
> trademark now owned by BT) and then demo’ed to BT, which code named a similar project with the same name. Today,
> the whole UK industry has to contend with ‘ISP level filtering’. You do NOT want to open any pandora’s box.

I strongly agree.

Michel.

---

From: Marco Marzetti <[email-masked]>
Date: Sat, 02 Jul 2016 19:42:44 +0200

On 2016-06-29 14:30, Nick Hilliard wrote:
> Job Snijders wrote:
>> I believe this update addresses the concerns raised in this phase of 
>> the
>> document.
> 
> yes, thanks, it addresses these concerns, and the document is a lot
> better as a result.
> 
> The second major area of concern I have about this proposal is the
> transitive nature of the bgp community.  The issue is that the draft
> specifies a mechanism to cause traffic to be dropped on the floor, that
> the signaling mechanism is globally transitive in scope, and the
> specific intent is that prefixes tagged in this way are exported to
> other ASNs. In other words, the draft specifies behaviour that is risky
> by default.
> 
> Prefix hijacking rates suggest that adding a new compromise vector is
> something that should be considered carefully in the context of
> standardisation.
> 

Nick (and all the others that have already discussed the topic in the 
later posts),

I can't see why blackholing someone else's traffic can be more 
dangerous/undesirable than sending it to the hijackers.
I think that chapter #5 addresses the issue as it should.

Also i think that there could be corner cases in which a the receiving 
network may not want to add NO_EXPORT (there is at least one large 
network that is using a different ASN for each region in which it 
operates).
So forcing NO_EXPORT is not advisable.

Regards

-- 
Marco