Subject: IETF Website Status Update

From: Russ Housley <[email-masked]>
Date: Fri, 15 Dec 2017 16:09:24 -0500

Hello,

Thanks to everyone who provided further input about the revamped www.ietf.org website around IETF 100. This was the third round of IETF community input this year.  In addition, we gathered input from people for whom the IETF is important but don’t necessarily participate in the IETF. This input has led to a better revamped website in a variety of ways, such as organizing the content to make it more intuitive to access for people new to the IETF, improving accessibility, and making it work better on mobile devices.

The latest round of input from IETF participants raised a few additional points to be addressed:

Some feedback noted that the “Quick Links” page accessible via 1-click (via the “Tools” top-menu item) from anywhere in the www.ietf.org website was difficult to parse. In response, the layout for displaying the items/links has been updated.  See https://beta.ietf.org/links/.  And, of course, this can be further refined.

It was also suggested that the meeting pages on the new site follow the current practice of making all the links immediately visible. The content management system template for those pages will be updated to make all meeting pages are displayed that way by default.

There were a few additional comments about things such as the crispness of font display, vertical padding, and font sizes but it was not clear to what extent these are general issues or what action might be taken at this point to address them. Feedback to improve the website is encouraged and can be submitted via [email-masked].

Based on the input received, the current plan is to move the revamped website to production on 11 January 2018. This plan has been shared with the Community Review Committee established by the IETF website revamp project’s Scope of Work [1], with IETF Tools team, and with the IAOC and the IESG.

While the goal is to anticipate and implement measures needed to ensure a smooth transition, the IETF Secretariat and the web development vendor are prepared to pay extra attention to fixing quickly any issues that arise in the weeks after the cut over to production.

URL continuity will be an area of focus during the transition. Based on the experience of previous IETF website transitions, there will likely be some URLs that end up resolving differently after the new website goes into production. Specific plans for maintaining continuity for all the URLs specified the SOW, as well as others identified in the process of the website development, will be documented and, to the extent possible, tested before the move to production takes place.

For the past few months, in preparation for the cut over, we have been maintaining two parallel websites. That work needs to stop are soon as possible.The existing website will continue to exist in its current state, and will accessible in some manner, just as the *previous* website does at https://www.ietf.org/old/2009/.  The URL for that has not yet been decided, but will be determined before the new website goes live.

Sincerely,
Russ Housley
IETF Website Revamp Project Manager

[1] https://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf

---

From: Tim Chown <[email-masked]>
Date: Mon, 18 Dec 2017 16:09:58 +0000

Hi,

> On 15 Dec 2017, at 21:09, Russ Housley <[email-masked]> wrote:
> 
> Hello,
> 

This is an improvement, thanks.  The heading and description that the page is full of links is probably superfluous; I’d suggest using the screen real estate for the real content.

> It was also suggested that the meeting pages on the new site follow the current practice of making all the links immediately visible. The content management system template for those pages will be…

That would be great; currently https://beta.ietf.org/how/meetings/101/ is far less navigable than https://www.ietf.org/meeting/101/index.html. 

> There were a few additional comments about things such as the crispness of font display, vertical padding, and font sizes but it was not clear to what extent these are general issues or what action…

What accessibility standards have been applied to the site?  The old site uses black / dark blue text on white, while the new is a lighter blue on white, and a thinner font, reducing contrast.

> For the past few months, in preparation for the cut over, we have been maintaining two parallel websites. That work needs to stop are soon as possible.The existing website will continue to exist in…

Appreciated, and a cutover in January seems a good time to do it.

Tim.

---

From: Greg Wood <[email-masked]>
Date: Mon, 18 Dec 2017 16:01:12 -0500

Hi Tim,

Thank you for taking time to provide feedback.

> On Dec 18, 2017, at 11:09 AM, Tim Chown <[email-masked]> wrote:
> 
> Hi,
> 

I’ve added this suggestion to the issue tracker.

> What accessibility standards have been applied to the site?  The old site uses black / dark blue text on white, while the new is a lighter blue on white, and a thinner font, reducing contrast.

A Russ mentioned in his October update we worked with the website developer on WCAG 2.0 compliance. However, ongoing editorial practices are required to ensure accessibility, so this will continue to be an area of focus.

> Appreciated, and a cutover in January seems a good time to do it.

Thanks for the feedback on these points, too.

Sincerely,

-Greg

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 19 Dec 2017 08:49:01 +0000

Hi,

On 2017-12-15, at 22:09, Russ Housley <[email-masked]> wrote:
> Based on the input received, the current plan is to move the revamped website to production on 11 January 2018.

agree that the new site is ready to take live, and that remaining (or new) issues can be addressed in production.

Lars