Subject: Opsdir last call review of draft-ietf-tokbind-negotiation-10

From: Will LIU <[email-masked]>
Date: Mon, 04 Dec 2017 05:19:14 -0800

Reviewer: Will LIU
Review result: Ready

I have reviewed draft-ietf-tokbind-negotiation-10 as part of the Operational
directorate's ongoing effort to review all IETF documents being processed by
the IESG.  These comments were written with the intent of improving the
operational aspects of the IETF drafts. Comments that are not addressed in last
call may be included in AD reviews during the IESG review.  Document editors
and WG chairs should treat these comments just like any other last call
comments.

“ This document specifies a Transport Layer Security (TLS) extension for the
negotiation of Token Binding protocol version and key
   parameters.”

My overall view of the document is 'Ready with Nits' for publication.

Section 3
>   "token_binding_version" contains the lower of:
>  o  the Token Binding protocol version offered by the client in the
>      "token_binding" extension and
>   o  the highest version supported by the server.

"The highest version" means  the highest *Token Binding protocol* version? If
yes, please indicate directly to eliminate confusion.

Section 8
>   [I-D.ietf-tokbind-protocol]
>             Popov, A., Nystrom, M., Balfanz, D., Langley, A., and J.
>             Hodges, "The Token Binding Protocol Version 1.0", draft-
>             ietf-tokbind-protocol-15 (work in progress), July 2017.

A later version (-16) should be put here.

---

From: Andrei Popov <[email-masked]>
Date: Mon, 4 Dec 2017 18:37:19 +0000

Thanks for the review; will use correct reference.

Cheers,

Andrei

-----Original Message-----
From: Will LIU [mailto:[email-masked]] 
Sent: Monday, December 4, 2017 5:19 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Opsdir last call review of draft-ietf-tokbind-negotiation-10

Reviewer: Will LIU
Review result: Ready

I have reviewed draft-ietf-tokbind-negotiation-10 as part of the Operational directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written with the intent of improving the operational aspects of the IETF drafts. Comments that are not addressed in last call may be included in AD reviews during the IESG review.  Document editors and WG chairs should treat these comments just like any other last call comments.

“ This document specifies a Transport Layer Security (TLS) extension for the negotiation of Token Binding protocol version and key
   parameters.”

Section 3
>   o  the highest version supported by the server.

"The highest version" means  the highest *Token Binding protocol* version? If yes, please indicate directly to eliminate confusion.

Section 8