Subject: Genart last call review of draft-ietf-teas-network-assigned-upstream-label-10

From: Stewart Bryant <[email-masked]>
Date: Thu, 28 Dec 2017 01:30:26 -0800

Reviewer: Stewart Bryant
Review result: Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-teas-network-assigned-upstream-label-10
Reviewer: Stewart Bryant
Review Date: 2017-12-28
IETF LC End Date: 2017-12-29
IESG Telechat date: 2018-01-11

Summary: A clear will written document. Ready for publication.

Major issues: None

Minor issues: Not an issue with the design per se, but there is a school of
thought that says do not use all zeros or all ones in a protocol without good
reason since these are common uninitialized variable values. If the designers
have scope to do so they might consider picking another value.

Nits/editorial comments:

Slightly strange order of final sections. Most readers will want to look at
IANA and Security rather than worrying about the contributors.

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Fri, 29 Dec 2017 10:41:26 -0500

Stewart, Hi!

Thanks for the review!

Please see inline (prefixed VPB).

Regards,
-Pavan

> have scope to do so they might consider picking another value.
[VPB] The authors did discuss this during the individual-draft stage. The
"all-ones" pattern was chosen because it was unlikely to conflict with any
of the labels that are already in use (the section on "backwards
compatibility" discusses this). Since there hasn't been any strong
resistance to the use of this value, the authors would like to retain the
current value.

> IANA and Security rather than worrying about the contributors.

[VPB] This order of sections is based on the template that is currently
being used. We will fix it in the next revision.

>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Sat, 30 Dec 2017 06:08:52 -0500

https://tools.ietf.org/rfcdiff?url2=draft-ietf-teas-network-assigned-upstream-label-11.txt

Rev-11 takes care of the "final sections - ordering" nit.

Regards,
-Pavan

On Fri, Dec 29, 2017 at 10:41 AM, Vishnu Pavan Beeram <[email-masked]