Subject: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 26 Jan 2018 12:00:51 +0200

Hello Khaled, and to all new comers,

I am sorry I did not see your question until yesterday, but your
question/draft is important for new comers and some times for old
participants. I really feel that the management some times may be not
serious for some slot of time and may have excuses because it is
volunteering. If our management are paid we can be more guided and
directed. So the new question, do we need more guidance or more friends?

The Answer to your question is: IETF is serious about adapted drafts only,
or new drafts that have support from the internet community. IMO, you need
to find 4 or 5 people that are willing to work with you/your-draft, maybe
it is easier to find them within your country or region. Then you contact
the area director that is related to your draft to get feedback. The IETF
provides some coaching so use that.

So the real answer to your question: is that you need more guidance and
directions, who doesn't. You are smart and all us in IETF are, but the
smarter who work within the guidance of WGs and ADs. All IETF experts,
authors and IETF WG chairs and ADs, all are getting guidance and they are
continuously guided by asking for comments/feedback from the communities.
So as many answered you to follow the reasonable engineering comments.

The other issue related to your question, the problem that we all are
bussy, so we IETF are serious but bussy. We need to be serious about our
time and others.

Finally, we in IETF must follow IETF procedures RFC2418, we always
follow/read it and its updates available. So that is important to be
guiding our management and our participants. We also have fun while we
participate and we make friends, so we should not get angry being more
serious, but we be mercy with more friends and guidance.

Take care,

AB

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 11:16:12 +0000

Hi Abdussalam,

> The Answer to your question is: IETF is serious about adapted drafts only, or new drafts that have support from the internet community.

I see many people in the community talking and dicussing the IPv10 I-D, I feel it is strange that people within the IETF do the opposite and not taking it seriously.

Best regards,

Khaled

-------- Original Message --------
Subject: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?
From: Abdussalam Baryun
To: Khaled Omar
CC: ietf

I am sorry I did not see your question until yesterday, but your question/draft is important for new comers and some times for old participants. I really feel that the management some times may be not serious for some slot of time and may have excuses because it is volunteering. If our management are paid we can be more guided and directed. So the new question, do we need more guidance or more friends?

The Answer to your question is: IETF is serious about adapted drafts only, or new drafts that have support from the internet community. IMO, you need to find 4 or 5 people that are willing to work with you/your-draft, maybe it is easier to find them within your country or region. Then you contact the area director that is related to your draft to get feedback. The IETF provides some coaching so use that.

So the real answer to your question: is that you need more guidance and directions, who doesn't. You are smart and all us in IETF are, but the smarter who work within the guidance of WGs and ADs. All IETF experts, authors and IETF WG chairs and ADs, all are getting guidance and they are continuously guided by asking for comments/feedback from the communities. So as many answered you to follow the reasonable engineering comments.

The other issue related to your question, the problem that we all are bussy, so we IETF are serious but bussy. We need to be serious about our time and others.

Finally, we in IETF must follow IETF procedures RFC2418, we always follow/read it and its updates available. So that is important to be guiding our management and our participants. We also have fun while we participate and we make friends, so we should not get angry being more serious, but we be mercy with more friends and guidance.

Take care,

AB

---

From: Keith Moore <[email-masked]>
Date: Fri, 26 Jan 2018 06:43:22 -0500

IETF does try to be open to new ideas.  But people bring new ideas to IETF all the time, and statistically speaking, most of those new ideas are bad ideas because they are coming from people without enough exposure to enough  experience that would let them realize that they are bad ideas.   So experienced IETF participants tend to reject bad or dubious ideas in ways that may seem impolite or rude.   This is (mostly) not because they are rude people overall, it is simply because there are so many bad ideas presented here, as a consequence of IETF's openness.

The people who succeed in getting IETF to adopt their ideas are those who are willing to listen to feedback, take it seriously, understand its relevance, and adapt their ideas in light of the feedback.   People who expect to be taken seriously without being willing to do those things tend to not succeed here.   Even good ideas need refinement, and IETF makes decisions by rough consensus.   Someone who isn't willing to listen to feedback will have a difficult time building consensus.   And even when a relatively good idea is presented, community members are less likely to try to help people refine their ideas, if those people seem unwilling to accept constructive feedback and consider compromises.

Also: IETF makes it relatively easy to post an internet-draft.   But posting an internet-draft doesn't do anything but make the draft available for download and send out an announcement to a mailing list.   It doesn't schedule any discussion on the draft, it doesn't refer the draft to any working group, and it doesn't mean that anybody will take it seriously or even read it - whether it's good or not.   That's just how the process works here.   It's how it has to work.  There aren't enough active participants in IETF for every internet-draft to be taken seriously.   We'd never get any work done at all if we undertook an obligation to try to make every proposal successful.

Keith

---

From: "Kevin A. McGrail" <[email-masked]>
Date: Fri, 26 Jan 2018 06:55:35 -0500

On 1/26/2018 6:43 AM, Keith Moore wrote:
> IETF does try to be open to new ideas.  But people bring new ideas to 
> IETF all the time, and statistically speaking, most of those new ideas 
> are bad ideas because they are coming from people without enough 
> exposure to enough  experience that would let them realize that they 
> are bad ideas.   So experienced IETF participants tend to reject bad 
> or dubious ideas in ways that may seem impolite or rude.   This is 
> (mostly) not because they are rude people overall, it is simply 
> because there are so many bad ideas presented here, as a consequence 
> of IETF's openness.
Hi Keith,

As another perspective from a lurker trying to help, there is also the 
daunting task of having to come up to speed on certain things that are 
collective knowledge of decades.  I've got one idea I've been honing 
that was actually mentioned obliquely literally 20+ years ago.

I appreciated the guidance I was given of "have you seen this RFC" 
rather than something more harsh.  It helped me find a direction where 
my idea might be added and a working group where it can be best debated.

Regards,
KAM

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 12:11:28 +0000

> I appreciated the guidance I was given of "have you seen this RFC" rather than something more harsh.  It helped me find a direction where my idea might be added and a working group where it can be best debated.

I've got good comments from some participants regarding the 1st ID IPv10 and most of the other comments were to change the draft name, I read so many RFCs suggested by some few people, and they were related to the IETF sequence of work, and I was waiting for actions to be taken to make a WG or to discuss it within a WG but nothing happened.

Even for the 2nd and 3rd drafts, no reviews happened.

I'm waiting for an action from the people who are responsible for certain areas to make a decision or assign a reviewer or even delete the drafts :-)

Khales

-------- Original Message --------
Subject: Re: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?
From: "Kevin A. McGrail"
To: Keith Moore ,Khaled Omar
CC: ietf ,Abdussalam Baryun

Hi Keith,

Regards,
KAM

---

From: Keith Moore <[email-masked]>
Date: Fri, 26 Jan 2018 07:22:48 -0500

On 01/26/2018 07:11 AM, Khaled Omar wrote:

> I'm waiting for an action from the people who are responsible for 
> certain areas to make a decision or assign a reviewer or even delete 
> the drafts :-)

Nobody has the time to decide which drafts should be deleted. That's why 
all drafts are automatically deleted from the download servers six 
months after publication.

Keith

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 12:29:03 +0000

I meant "if" the drafts does not brings new ideas, action should be taken. I didn't mean to delete them seriously.

-------- Original Message --------
Subject: Re: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?
From: Keith Moore
To: Khaled Omar ,"Kevin A. McGrail"
CC: ietf ,Abdussalam Baryun

Keith

---

From: Keith Moore <[email-masked]>
Date: Fri, 26 Jan 2018 07:33:37 -0500

On 01/26/2018 07:29 AM, Khaled Omar wrote:

> I meant "if" the drafts does not brings new ideas, action should be 
> taken. I didn't mean to delete them seriously.

I get the impression that you think that just because you posted a 
draft, somebody should take some action on it.  I've already explained 
that this is not how things work, and why things cannot work this way 
for an organization that accepts drafts from anybody regardless of how 
much or little knowledge and experience they have.

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 12:36:41 +0000

So in your opinion, what should I do after asking for uploading an ID?

---

From: Yoav Nir <[email-masked]>
Date: Fri, 26 Jan 2018 14:45:14 +0200

> On 26 Jan 2018, at 14:22, Keith Moore <[email-masked]> wrote:
> 
> Nobody has the time to decide which drafts should be deleted. That's why all drafts are automatically deleted from the download servers six months after publication.
> 
> Keith
> 

Sorry, that is not correct. Draft are never ever deleted from the download servers. The only thing that changes is that the datatracker shows them as expired rather than current.

Here’s a link to one of the download servers with the very first draft I have ever submitted:

https://tools.ietf.org/html/draft-nir-ikev2-auth-lt-00 <https://tools.ietf.org/html/draft-nir-ikev2-auth-lt-00>

---

From: Keith Moore <[email-masked]>
Date: Fri, 26 Jan 2018 07:45:27 -0500

> So in your opinion, what should I do after asking for uploading an ID?
Pay close attention to the feedback you've already received.  And if you 
intend to work in the addressing/routing area, invest several years 
learning why things are the way they are now.

I've been involved in IETF since 1990 or so and implementing Internet 
protocols since the mid 1980s.  And yet I seriously doubt that I could 
write a proposal for a new kind of IP that would be (a) enough of an 
improvement over what we have already that it would be interesting, and 
(b) obviously safe to deploy without significant risk of disruption.   
(And I have tried.)    And I tend to regard all such proposals - even 
those authored by people with decades of experience - in that area with 
extreme skepticism because I have some (not enough) understanding of 
just how much inertia there is (and should be) in that area.

Keith

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 12:58:59 +0000

So that means to ask for uploading a draft and wait until it is expired !!!

-------- Original Message --------
Subject: Re: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?
From: Yoav Nir
To: Keith Moore
CC: "Kevin A. McGrail" ,Khaled Omar ,ietf ,Abdussalam Baryun

On 26 Jan 2018, at 14:22, Keith Moore <[email-masked]<mailto:[email-masked]>> wrote:

Keith

https://tools.ietf.org/html/draft-nir-ikev2-auth-lt-00

---

From: Michael StJohns <[email-masked]>
Date: Fri, 26 Jan 2018 13:59:20 -0500

In my (very long) time working with the IETF, I have never heard the 
IETF deliberative process described quite as well as Keith has done 
below.   I would strongly urge the IESG to memorialize this verbatim in 
at least two places - the newcomer's entry page, and (for the last 
paragraph), the ID submission page.  There may be other places where 
this text will serve as a warning post against unrealistic expectations.

Note my "verbatim" recommendation - I would avoid the urge to tweak.

Mike

On 1/26/2018 6:43 AM, Keith Moore wrote:
> The people who succeed in getting IETF to adopt their ideas are those 
> who are willing to listen to feedback, take it seriously, understand 
> its relevance, and adapt their ideas in light of the feedback.   
> People who expect to be taken seriously without being willing to do 
> those things tend to not succeed here.   Even good ideas need 
> refinement, and IETF makes decisions by rough consensus.   Someone who 
> isn't willing to listen to feedback will have a difficult time 
> building consensus.   And even when a relatively good idea is 
> presented, community members are less likely to try to help people 
> refine their ideas, if those people seem unwilling to accept 
> constructive feedback and consider compromises.
>
> Also: IETF makes it relatively easy to post an internet-draft.   But 
> posting an internet-draft doesn't do anything but make the draft 
> available for download and send out an announcement to a mailing list. 
>   It doesn't schedule any discussion on the draft, it doesn't refer 
> the draft to any working group, and it doesn't mean that anybody will 
> take it seriously or even read it - whether it's good or not.   That's 
> just how the process works here.   It's how it has to work.  There 
> aren't enough active participants in IETF for every internet-draft to 
> be taken seriously.   We'd never get any work done at all if we 
> undertook an obligation to try to make every proposal successful.
>
> Keith
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Jan 2018 08:03:16 +1300

> my idea might be added and a working group where it can be best debated.

That's how things should work, indeed. As the Internet becomes ever bigger
and more complex, it is now a daunting task to design any change or
addition, even a relatively minor one. It's far beyond the capacity of
any individual working alone. The great thing about the IETF is that it
allows individuals to work with others, across organizational and national
boundaries.

Regards
   Brian Carpenter

---

From: Khaled Omar <[email-masked]>
Date: Fri, 26 Jan 2018 19:21:43 +0000

> The great thing about the IETF is that it

This is what i'm looking for at the IETF, more co-authors and more participants.

Best Regards,

Khaled

-------- Original Message --------
From: Brian E Carpenter
To: "Kevin A. McGrail"
CC: ietf

Regards
Brian Carpenter

---

From: "John Levine" <[email-masked]>
Date: 26 Jan 2018 16:29:48 -0500

>> So in your opinion, what should I do after asking for uploading an ID?

The IETF has a bias toward running code.  If you have actually
implemented something, and can provide reports about how it works, how
it deals with traffic spikes, routing problems, hostile traffic, and
all the stuff systems connected to the Internet have to deal with,
people will be more likely to take the time to look at it.

As has already been pointed out, anyone can write up a paper design and
send in an I-D, and many people do.

R's,
John