Subject: www.ietf.org

From: Leif Johansson <[email-masked]>
Date: Fri, 12 Jan 2018 17:49:54 +0100

Could somebody point me to the "I didn't mind what it looked
like before so I don't know why I should start caring now" corner?

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 12 Jan 2018 17:02:43 +0000

> like before so I don't know why I should start caring now" corner?

can we set up a bof for this?  count me in.

Nick

---

From: Christopher Morrow <[email-masked]>
Date: Fri, 12 Jan 2018 13:01:29 -0500

the larger question maybe: "why is there a picture of some not-ietf
meeting" on the ietf webpage? (looks like something in geneva, and much
more formal... what with the swiss shopping bag and the suits)

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 12 Jan 2018 10:44:31 -0800 (PST)

Because the picture is taken from the blog from IGF which was
indeed in Geneva. I suspect the picture changes from time to
time, you know sort of like what's on the front of Apple.com :-)

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Docomo: +81 090 3337-9311
E-mail: [email-masked]
Skype: organdemo

---

From: Russ Housley <[email-masked]>
Date: Fri, 12 Jan 2018 14:24:54 -0500

Leif:

You might want to bookmark this page: https://www.ietf.org/links/

Russ

> On Jan 12, 2018, at 11:49 AM, Leif Johansson <[email-masked]> wrote:
>

---

From: Mary B <[email-masked]>
Date: Fri, 12 Jan 2018 13:28:21 -0600

But, if the whole point of updating the homepage was to increase awareness
of IETF, it's not at all clear to me why it looks to be all about IGF.  I'm
gonna guess that there's a lot of IETFers that aren't all that familiar
with IGF.

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 12 Jan 2018 14:36:41 -0500

On Fri, Jan 12, 2018 at 01:28:21PM -0600, Mary B wrote:
> of IETF, it's not at all clear to me why it looks to be all about IGF.

I am sort of surprised that the people who were apparently satisfied
with the previous, text-heavy web site seem not to be reading the text
in GIANT TYPE right there on top of the very image people are
commenting on:

    Internet user communities, businesses, technical folk, and
    government coming together

    At the recent Internet Governance Forum, some IETF folk were
    present to listen to the larger community and to occasionally
    speak about the issues which touched on our technical work.

    Read the summary from the IETF and IAB chairs

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Ole Jacobsen <[email-masked]>
Date: Fri, 12 Jan 2018 11:38:24 -0800 (PST)

> gonna guess that there's a lot of IETFers that aren't all that familiar

Mary: I am not defending the use of that particular picture, just 
pointing out that it is (probably, hopefully) something DYNAMIC rather 
than static, reflecting the "latest news" or in the example case of 
Apple, "latest product" or promotion. I am going to guess that this is 
just some "feature" of the new design (for good or bad) and certainly
something that can be changed and locked to something more 
appropriate. The blog entry in question was posted last week.

ole

---

From: Mary B <[email-masked]>
Date: Fri, 12 Jan 2018 13:44:57 -0600

I did read the text but if someone doesn't know about IETF I'm not sure how
meaningful it is to them that IETF was at IGF.

---

From: "Patrik Fältström" <[email-masked]>
Date: Fri, 12 Jan 2018 20:45:06 +0100

The IETF site was historically very confused between either helping IETF participants that know about IETF already and people not knowing (much) about the IETF.

A choice was made that the new IETF site was to be targeted audiences that do not know so much about IETF.

I think that goal has been reached.

Thanks!

And yes, I really mean it!

Very well done!

For people that do know about IETF it is a step backward though, by definition, of course.

Those people should instead directly go to <https://datatracker.ietf.org/>.

   Patrik

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 12 Jan 2018 14:47:51 -0500

>     Read the summary from the IETF and IAB chairs

I read the words.

As someone who's been peripherally involved in IETF work for quite some time, 
but who's never been to a meeting, my reaction to the picture was "Wow.  IETF 
meetings are a lot fancier than I thought".  It wasn't at all clear to me that 
the main photo on the IETF web page would be about something other than the 
IETF.

Frankly, once I realized https://datatracker.ietf.org/ wasn't affected by the 
redesign, I quit worrying about the redesign.  It seems to be more about 
marketing the IETF than doing the work, so it doesn't affect me.

Scott K

---

From: Mary B <[email-masked]>
Date: Fri, 12 Jan 2018 13:50:42 -0600

My perspective would be that a photo from an IETF plenary and perhaps a
pointer to the writeup that IETF chair does with highlights from IETF
meeting might be a better front page since it is about IETF.

On Fri, Jan 12, 2018 at 1:44 PM, Mary B <[email-masked]> wrote:

> I did read the text but if someone doesn't know about IETF I'm not sure
> how meaningful it is to them that IETF was at IGF.
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 12 Jan 2018 15:14:13 -0500

I agree with Mary, a photo from the Singapore plenary and a pointer to Alissa’s
highlights would be much more appropriate.

Cheers,
Andy

---

From: Christian Huitema <[email-masked]>
Date: Fri, 12 Jan 2018 10:33:08 -1000

On 1/12/2018 9:50 AM, Mary B wrote:
> My perspective would be that a photo from an IETF plenary and perhaps
> a pointer to the writeup that IETF chair does with highlights from
> IETF meeting might be a better front page since it is about IETF.  

+1. Unless we intend to carry the message that the IETF is just an
activity of the UN, somewhere in Geneva. Which is a weird way to attract
newcomers.

-- Christian Huitema

---

From: Leif Johansson <[email-masked]>
Date: Fri, 12 Jan 2018 21:33:50 +0100

Actually I care & like that I can now read the thing on my phone wo sideways scrolling! Well done.

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 12 Jan 2018 22:02:08 +0100

Any way we can move this whole new IETF web page discussion to a more
appropriate mailing list ? I am sure more IETF participants would like
to try their luck at being webdesigners, and are only afraid
to do so because of Thomas' weekly nastygrams for this mailing lists
top posters.

Thanks
    Toerless

-- 
---
[email-masked]

---

From: John Leslie <[email-masked]>
Date: Fri, 12 Jan 2018 16:11:41 -0500

> You might want to bookmark this page: https://www.ietf.org/links/

   I tried it: alas, the page is not usable from my ancient Mac Mini.

   I ran validator.w3.org, and got 27 errors and warnings before the
validator gave up.

   Perhaps I am being too picky...

   But IMHO, IETF needs to appeal to third-world people who are running
computers even more ancient than mine.

   And I still try to make sure anything I put on IETF pages passes
validator.w3.org. (I realize olmost no professional web-designers agree
this is a valid goal; but ISTM to be the easiest way to make sure the
page will display reasonably on a variety of platforms.)

   And your page _doesn't_ display reasonably on my platform. It comes
up a a window-within-a-window with no left-right scroll-bar: so there's
no way to see the right-hand portion of the main window.

   I don't know how my difficulties compare to others'...

   I won't ask to revert to a previous version...

   but I will be looking carefully at the WaybackMachine for hints as to
where I might find things.

   It _would_ be nice if old links continued to work, or link to
workalike replacements. IMHO, a strong majority of pages maintained
by volunteers are sufficiently useful that they should be preserved.

   (A "Useful Links" page off a new website is _almost_never_ a good
tool for this purpose!)

--
John Leslie <[email-masked]>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Jan 2018 13:46:54 +1300

> to do so because of Thomas' weekly nastygrams for this mailing lists

As has been mentioned, specific nits should go to [email-masked]
(I tried it and it works). But I think the discussion of principles really
belongs here. Be proud of your place in the narten list ;-).

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 13 Jan 2018 13:49:45 +1300

> in GIANT TYPE right there on top of the very image people are

That's the whole point. People here mainly (not everybody) dislike or
passionately hate that sort of look and feel. (I hate it. And usually
I simply don't see THE BIG SHOUTING LETTERS because that's never the
useful part of any web site. Literally, it's the small print that
matters - for example, only yesterday I had to register on a new
commercial site and it took me 5 minutes of ignoring BIG FONTS to
find the privacy statement in a well-hidden 8-pt PDF file.)

For me at least, https://www.ietf.org/links/ is just about acceptable,
except for 5cm of wasted BIG LETTERS at the top. But the home page
is... just... pointless. If we want it to impress aspiring particpants,
don't hide the "Participate" link under "About"; headline it. If we want
it to impress potential sponsors, hide the IGF and other politics like
the plague; focus on our cheap, efficient, productive meetings.

Do not allow the same people to judge what is right for the IETF home
page that do it for the ISOC home page. The goals are different.

On 13/01/2018 08:45, Patrik Fältström wrote:
...
> Those people should instead directly go to <https://datatracker.ietf.org/>.

The problem is that a lot of the information is not in the tracker. Of the links
at https://www.ietf.org/links/, I counted more than 30 that are in www.ietf.org,
and others in tools.ietf.org.

Regards
     Brian

---

From: Loa Andersson <[email-masked]>
Date: Sat, 13 Jan 2018 09:45:23 +0800

All, Brian,

> find the privacy statement in a well-hidden 8-pt PDF file.)

While I'm not passionate enough to hate this, I can understand your
sentiment.

I have one other that I find a bit odd. We often say that the most
important of the IETF are the working groups, and from a "new people"
perspective I guess it is as common that they are initially interested
a particular working group, as in the IETF as whole. Yet the WG's are
at least one layer deeper buried on the web page than the were before.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 12 Jan 2018 22:42:53 -0500

A couple of notes for those who plan to continue to thumb through the IETF web site over the weekend:

As a few folks have noted, the [email-masked] alias is indeed the place to file bugs. Every bug I’ve filed has garnered a personal response and a fix or an explanation for why not within hours and I suspect others who have made use of it have had similar experiences.

The team behind the site is looking into a way to make the filed bugs visible. No promises but stay tuned for an update.

There is an effort underway to highlight a different photo in the landing page banner, or possibly a different blog post altogether. The other photos I took at the IGF would not have rendered well here. 

Cheers,
Alissa

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 13 Jan 2018 11:50:50 -0800

> computers even more ancient than mine.

May I ask what *browser* version you are using? While I agree that the IETF
Web site ought to work for people with old computers, but generally, one
needs to be using a reasonably modern browser or you are going to have
problems a lot bigger than the IETF Web site not rendering. FWIW, I just
tested the site with modern Firefox, Chrome, and Safari, and it renders fine

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 14 Jan 2018 10:05:10 +1300

...
>> computers even more ancient than mine.

Yes. Those are people we need to attract, but we also need to attract
senior managers in potential sponsors, who have different expectations.
So there's a tussle.

> tested the site with modern Firefox, Chrome, and Safari, and it renders fine

It does. But people with simpler tastes might prefer something like
the attachment as a start page. No CSS. YMMV.

    Brian

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 15 Jan 2018 10:26:32 +0100

On Fri, Jan 12, 2018 at 10:42:53PM -0500,
 Alissa Cooper <[email-masked]> wrote 
 a message of 17 lines which said:

> As a few folks have noted, the [email-masked] alias is indeed
> the place to file bugs. Every bug I’ve filed has garnered a personal
> response and a fix or an explanation for why not within hours and I
> suspect others who have made use of it have had similar experiences.

Not for me: at least one ticket ([www.ietf.org/rt #201081]) was closed
without the problem fixed and without explanations.

Also, we expect that some things will be done without users having to
file a ticket. Chasing old links that are broken could and should be
done by checking 404 in the log, without asking participants to do
this themselves.

---

From: Tim Chown <[email-masked]>
Date: Mon, 15 Jan 2018 10:50:06 +0000

> On 12 Jan 2018, at 19:36, Andrew Sullivan <[email-masked]> wrote:
> 

As it stands, it looks like the BIG TEXT "Internet user communities, businesses, technical folk, and government coming together" is the mission of the IETF, as it's being shouted from the front page, which of course is very different to what is stated at https://www.ietf.org/about/mission/.

As a more minor nit, I hope future headline writers can avoid words like "folk" that are very US-centric. Something like "participants" or "attendees" would work just as well.

Tim

---

From: John C Klensin <[email-masked]>
Date: Mon, 15 Jan 2018 10:27:38 -0500

>> May I ask what *browser* version you are using? While I agree
>> that the IETF Web site ought to work for people with old
>> computers, but generally, one needs to be using a reasonably
>> modern browser or you are going to have problems a lot bigger
>> than the IETF Web site not rendering. FWIW, I just tested the
>> site with modern Firefox, Chrome, and Safari, and it renders
>> fine
 
> It does. But people with simpler tastes might prefer something
> like the attachment as a start page. No CSS. YMMV.

And, independent of other issues, that example shows why
designing this sort of thing is not a simple issue.  I think
that, for the audience we have historically thought was most
important (active IETF participants trying find information or
do work) and quibbles aside, the content is about right.
However, even on a large screen, I can't read the screen without
glasses or magnification.  If I resort to magnification. I end
up either with horizontal scrolling or overlap onto a second
monitor, depending on how I'm set up, and either introduces the
sort of distraction that I think we agree such a page should
avoid.   The layout doesn't get on well with with a screen
reader either.  

To me, the example illustrates that there is a role for some
careful, and user- and usage-sensitive graphic design even for a
page of links optimized to be a quick-access index.  That
doesn't imply a need for picture from the meetings of other
organizations, animation, more than four colors, or decorative
framing.  It doesn't imply CSS or JavaScript either.  But I
think good design is still useful and important.  

On the other hand, I don't think the new pages demonstrate good
graphic design either, even for their rather different intended
audience, whether that design reflects common current practice
or not.  More on that in a separate note

   john

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 15 Jan 2018 19:55:00 +0100

Tim: Lordy, you blokes in the kingdom don't feel so folksy ?
I thought it refers to the folksy costumes (t-shirts) worn at the IETF.
(come to the IETF, wear a t-shirt and be part of the LARP). 

Kidding aside:

+1.  The word immediately catched my attention when reading the text.

I suggest that RFC editors (or someone with similar qualifications) are asked
to review IETF web page text. They can be very good weeding out "folksy" language.

"technologists" ?

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Stephanie McCammon <[email-masked]>
Date: Tue, 16 Jan 2018 14:00:13 -0800

Hi Stephane, 

I’m sorry you feel that your ticket was not properly addressed. From our logs it appears that the ticket you referenced (201081) was responded to within 24 hours and the specific example you raised was fixed at that time. 

Unfortunately, there are other missing redirects that still need to be repaired; thank you for bringing several more of those to our attention. I know there are people working hard to repair them, and the Secretariat is assisting with that effort as much as time permits. Please note that this will take some time to complete.

Thank you,

Stephanie McCammon
IETF Senior Project Manager
5177 Brandin Court
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning
www.amsl.com

On Jan 15, 2018, at 01:26 , Stephane Bortzmeyer <[email-masked]> wrote:

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 16 Jan 2018 16:46:55 -0600

Hi all,

Recently I visited the new IETF web site.

I found one thing that is missing, there was on the left upper side a
search box that I heavily used.
That is gone.
I would like to see that back, otherwise the other content added I don't
mind.

Regards,
Behcet

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 17 Jan 2018 09:45:11 +0100

On Tue, Jan 16, 2018 at 02:00:13PM -0800,
 Stephanie McCammon <[email-masked]> wrote 
 a message of 51 lines which said:

> From our logs it appears that the ticket you referenced (201081) was
> responded to within 24 hours and the specific example you raised was
> fixed at that time.

The specific URLs I mentioned were fixed. But there were many
others. Fixing broken links by waiting for someone to submit a ticket
one by one is not efficient. For instance, all meeting pages were
broken. I reported for IETF 92 and it was originally fixed for IETF
92, not for the other meetings.

The proper way to track 404 is to grep the logs. This way, you can
find, not only missing pages, but also for instance, that some pages
load CSS and/or JS which no longer exists (look at the
anti-harrassment policy
<https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html>)

> I know there are people working hard to repair them

Please leave "We are working very hard on this" to politicians. Here,
the problem is not a lack of work, I know you work, the problem is a
bad method (waiting for reports instead of analyzing the access logs).

---

From: Jari Arkko <[email-masked]>
Date: Wed, 17 Jan 2018 15:27:30 +0200

I wanted to comment on the discussion of the IGF text and picture on the web page. One potentially valuable piece of information on a web page like this is the dynamically changing information. It just happened to be Alissa’s and Ted’s post from IGF, but I think the idea is that it should change as some other relevant piece of information comes along. Another blog post, or, say, registration opened for IETF-nnn or that hotels are now bookable for the next half a day :-) I don’t think we should throw away the dynamic content… although I understand why people were confused. Had the word “news” or “blog” for instance appeared in the text somewhere, it might have been clearer what’s going on.

I as a consumer of this information would actually like to see this kind of thing on the web page, and would check back on the web page now and then to look for that.

Otherwise on this topic — lots of comments, long thread, and many very valid points. And I wish — as this was my project not long ago -- that we could have provided a web page that people are happier with from the start. Clearly, work remains! FWIW, I’m with what Andrew, Eliot, and John on the analysis of issues and way forward. I did want to say many thanks to Russ, Greg, AMS, and everyone else who I know are working very hard on this, addressing the points that have been made. Thank you. I also wanted to say that the new web page is a marked improvement for instance on my ability to browse the web site on a smartphone.

Finally, I wanted to say a word on the IETFer webpage being data tracker and the other people webpage being ietf.org.  I think that is true, to an extent, but not entirely. As an IETFer you’ll remember where to go, have bookmarks or your browser remembers. For instance, I know how to get to a working group’s documents, charter, etc and for me that address has usually been the tools page for the WG. If I need to look at the tracker or submit a draft, I know that I need to go to the data tracker. And my browser remembers the URL for list of WGs, which turns out is something that often have to browse to, as I don’t remember that new WG’s name so I can’t directly go to it.

However, there are tons of other things I would need more rarely: registration page for next meeting, IPR search, list of noncom members this year, tutorials, hackathon page, ombudsteam webpage, IESG statements, list of people serving as ADs, … that I don’t necessarily remember or use daily. For most of those cases, I would have clicked on the IETF web page and ultimately find my way to the right place. Retaining that sort of “ultimate directory of everything under the IETF” functionality is I think still important, and much of the information here could be needed by either newcomers, old-timers, or completely external people. I think for that role, the main IETF web page still needs to be the starting point.

Jari

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Jan 2018 07:48:07 +1300

Hi Jari,
On 18/01/2018 02:27, Jari Arkko wrote:
...
> Retaining that sort of “ultimate directory of everything under the IETF” functionality is I think still important, and much of the information here could be needed by either newcomers, old-timers, or completely external people. I think for that role, the main IETF web page still needs to be the starting point.

This really isn't an aspect of web sites (in general) that has improved over the years; it's got progressively worse. The old home page (www6.ietf.org) was IMHO inferior for that purpose to the *old* old home page, which lives on as www6.ietf.org/content. Yes, modern site design provides good eye candy and hopefully supports accessibility, but for just finding stuff, plain and simple is better.

Hence https://www.ietf.org/links/

    Brian

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 17 Jan 2018 13:47:44 -0600

On Wed, Jan 17, 2018 at 12:48 PM, Brian E Carpenter <
[email-masked]> wrote:

> > Retaining that sort of “ultimate directory of everything under the IETF”
> functionality is I think still important, and much of the information here
> could be needed by either newcomers, old-timers, or completely external
> people. I think for that role, the main IETF web page still needs to be the
> starting point.
>
> This really isn't an aspect of web sites (in general) that has improved
> over the years; it's got progressively worse. The old home page (
> www6.ietf.org)

Wow. This link does have the search box I have been looking for, thanks
Brian.

Behcet

> was IMHO inferior for that purpose to the *old* old home page, which lives
> on as www6.ietf.org/content. Yes, modern site design provides good eye
> candy and hopefully supports accessibility, but for just finding stuff,
> plain and simple is better.
>

---

From: Russ Housley <[email-masked]>
Date: Wed, 17 Jan 2018 17:23:02 -0500

Stephane:
> one by one is not efficient.

As I said in my message yesterday, the Secretariat is reviewing the logs at least once a day for 404 and other errors.  The things that are found are being added to the list of things to fix.  If there is a ticket, then that page will have a higher priority than a log entry without a ticket.

Russ

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 17 Jan 2018 23:58:24 +0100

Inline

On Wed, Jan 17, 2018 at 03:27:30PM +0200, Jari Arkko wrote:
> I wanted to comment on the discussion of the IGF text and picture on the web page. One potentially valuable piece of information on a web page like this is the dynamically changing information. It just happened to be Alissa???s and Ted???s post from IGF, but I think the idea is that it should change as some other relevant piece of information comes along. Another blog post, or, say, registration opened for IETF-nnn or that hotels are now bookable for the next half a day :-) I don???t think we should throw away the dynamic content??? although I understand why people were confused. Had the word ???news??? or ???blog??? for instance appeared in the text somewhere, it might have been clearer what???s going on.

Please make sure that there is tracking of history for dynamic content. Aka: associated with any dynamic piece of content should be a link to show the history (like a blog). Not to say that an RSS feed should be available.

> I as a consumer of this information would actually like to see this kind of thing on the web page, and would check back on the web page now and then to look for that.

And i want to be able to find and point people to stuff i remember from a week, a month or a year ago ;-)

> However, there are tons of other things I would need more rarely: registration page for next meeting, IPR search, list of noncom members this year, tutorials, hackathon page, ombudsteam webpage, IESG statements, list of people serving as ADs, ??? that I don???t necessarily remember or use daily. For most of those cases, I would have clicked on the IETF web page and ultimately find my way to the right place. Retaining that sort of ???ultimate directory of everything under the IETF??? functionality is I think still important, and much of the information here could be needed by either newcomers, old-timers, or completely external people. I think for that role, the main IETF web page still needs to be the starting point.

It is quite frustrating that you feel you have to say this. But indeed
it seems that the list of goals for the new IETF web page doesn't
include "IETF web page is a core tool for professionals
working for the IETF to do their (often (part-)voluntary) job"

And alas, this is IMHO still a core problem: I have yet to see any wb page that
strikes a good balance supporting vastly different communities. For example,
compare web-page where you are shopping with those of the phone
support people working at the companies selling the good (train, plane
automobiles, vacations,  whatever good & services). Hint: The pages with professionals
in front of them whose time is a cost factor look a lot more like the old IETF
web page and the customer pages a lot more (bloated,stylish) like the new IETF web page.

This goes fairly deep. For example: just look at how the fonts on the old IETF web page
where selected to be readable at the smallest size while the look & feel
of the new web page is made to impress but requires larger font size to be
readable. And i bet that the new web page designers are not capable or willing
to provide a different basic look & feel for pages directd more at professionals:
"Oh, the common look & feel is so much more important". This is a problem i havde
seen over and over again. Consumerization of professional web pages.

To completely put myself into the dog house: The old IETF web page could have
come from Microsoft. The new one from Apple. I rest my case.

Cheers
    Toerless

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 18 Jan 2018 16:24:58 +1300

> As I said in my message yesterday, the Secretariat is reviewing the logs at least once a day for 404 and other errors.  The things that are found are being added to the list of things to fix.  If t…

What is a little hard to understand is that the site was apparently launched containing *internal* 404s.
(where "internal" includes datatracker and tools).

Try running http://www.brokenlinkcheck.com.

    Brian