Subject: Update on www.ietf.org

From: Russ Housley <[email-masked]>
Date: Tue, 16 Jan 2018 19:13:55 -0500

Hello.

This note provides an update on the transition to the new www.ietf.org website, including:
  -  a specific update on some of the issues that have been discussed on this list;
  -  a general update on addressing issues going forward; and 
  -  a recap of the website project process.

Several site-wide issues raised on this list have been addressed in an update applied today.  These include removing the reference to externally hosted javascript and issues with how the site is displayed on smaller viewports such as phones.  Some updates have aimed to address accessibility issues raised, and accessibility remains an ongoing focus of the website’s development and editorial processes.

Content issues are also being addressed. Tickets already filed via the [email-masked] mailing list are being resolved as quickly as possible.  A publicly viewable version of the queue is available here: 

	https://www.ietf.org/tools/website.html

The details of each ticket require a login, but anyone can see the subject line for each open ticket.

A site-wide direct link to specific guidance about submitting website feedback has been added here:

	https://www.ietf.org/contact/website/

Server logs were reviewed after the site went into production.  The logs have helped us identify and fix broken links.  We will continue to review the logs daily.

Since it has been four several years, a review of the new website development process might be useful.  There were many opportunities for the community to comment at each stage of the development process.  The statement of work [1] for the project was informed by several rounds of IETF community input, including feedback received on this list.  Direction for the project was approved by the IESG after consultation with the community.  The IAOC received multiple bids, selected Torchbox, and made the announcement to the community at the end of 2014 [2].

The website design was developed based on initial research and feedback sessions conducted with key audiences identified in the statement of work. [3, 4].  Torchbox was onsite at IETF 93 in 2015 to gather in person feedback on the initial design concepts. Screenshots of the initial design were published to the IETF Blog in mid-2016.  Further feedback on the new website (online and in person) was gathered from each of the three audiences identified in the statement of work over the course of the past year. Office hours were held at IETF 98 to provide participants a face-to-face opportunity to preview the website and offer feedback [5]. The public beta site was made available https://beta.ietf.org starting in July 2017, and announced on this list [6].  Office hours were held at IETF 99 and IETF 100 to provide participants a face-to-face opportunity to provide feedback.

The website site will continue to be updated as feedback is received.  One area of focus will be refining and improving search capabilities.  This could include being able to search documents in the IETF Datatracker directly from the page at https://www.ietf.org and including more fine-grain search options for IETF participants at https://www.ietf.org/links.

In addition, the plan includes reaching out to the other key audiences identified in the statement of work to understand how the site might be further refined to address them.

Sincerely,
Russ Housley
IETF Website Revamp Project Manager

[1] Statement of work:
http://iaoc.ietf.org/documents/IETF-Website-SOW-20140604-Final.pdf

[2] IAOC meeting minutes (See Section 4):
https://iaoc.ietf.org/documents/IAOC-minutes-2014-11-12-public.pdf

[3] User research:
https://iaoc.ietf.org/documents/Torchbox_ETFUserresearch.pdf

[4] Design brief based on user research:
https://iaoc.ietf.org/documents/Torchbox_IETFDesignBrief.pdf

[5] Website revamp project update:
https://mailarchive.ietf.org/arch/msg/ietf-announce/uGXQbMzNQjSYgnVIke11XeyrIoo

[6] Revamp of the www.ietf.org website:
https://mailarchive.ietf.org/arch/msg/ietf/bWB2xpxT-WbcuhBBl6Hbrg2juoY

---

From: Randy Bush <[email-masked]>
Date: Tue, 16 Jan 2018 17:33:32 -0800

> removing the reference to externally hosted javascript

thanks to all involved

randy

---

From: Alissa Cooper <[email-masked]>
Date: Tue, 16 Jan 2018 21:52:11 -0500

I’d like to say a big thank you to everyone who has been working to respond to the feedback on the site as it has been rolling in. Greg, who has many responsibilities both for the IETF and ISOC in addition to supporting the new site, has been working at a breakneck pace to address the feedback. The secretariat staff at AMS has been all hands on deck, going way above and beyond what we’ve contracted for them to do. Russ continues to provide project management on a voluntary basis and Torchbox, the site vendor, continues to respond to requests as they receive them. Many thanks to all of you.

I have one short addendum to Russ’s note below, and a longer musing in response to the questions some people have raised about the lessons to be learned here.

> On Jan 16, 2018, at 7:13 PM, Russ Housley <[email-masked]> wrote:
> 
> Hello.
> 

Note that AMS is working on providing a way to make the ticket content visible without a login. Please be aware of this when submitting new tickets. They are also going to look into the possibility of publishing resolved tickets.

Because the ticket queue is generated from an email alias that has been advertised publicly on our site and on this list, it receives a lot of spam. AMS cleans this out on a regular basis but you are likely to see spam tickets pile up in the queue.

> The website design was developed based on initial research and feedback sessions conducted with key audiences identified in the statement of work. [3, 4].  Torchbox was onsite at IETF 93 in 2015 to…

Now, about the lessons learned.

As Russ notes above, this project was started nearly four years ago. It was started so long ago that people can’t remember the feedback they gave in the early rounds of community comment — or that community comment was sought at all. It was started so long ago that the entire IAOC, except the ISOC CEO, is different now than when it started. When I think about the big picture, the fact that it could take four years to re-do our web site is what really stands out. We do not have a viable structure for carrying out this sort of externally facing function, which is a necessary function for an organization that exists in the world. Within our administrative structure this function is at once many people’s responsibility and nobody’s responsibility.    

And I think it would be hard to argue that designing the site by rough consensus or with additional community input (beyond the six calls for community feedback listed above) would have gotten us to a more efficient conclusion, or perhaps even a more satisfactory one. In fact, the previous web site design was designed more in that vein. My understanding (although I was not involved) is that AMS spent the better part of 18 months building the previous site by piling feature upon feature as individual requests came in from the community. And in addition to that being suboptimal from a functional perspective, it also remained no one’s responsibility in particular to strategically manage the site content thereafter, which is why some bug reports over the last week have been met with the response “this was a bug in the old site too.”

So to me the underlying lesson here comes back to the IASA 2.0 discussions we’ve been having about the need to refactor our administrative structure. We need clearer lines of responsibility for this kind of function and we need the people assuming the responsibility to be bought in. This won’t give us a web site that everybody likes — nothing can do that — but it will give us a better chance of being able to adapt to the world around us on something less than a four-year time scale, whether that means adapting to the changing norms of web design or changes in the networking industry or changes in the tools people use to get work done. 

Alissa

---

From: Tim Chown <[email-masked]>
Date: Thu, 18 Jan 2018 10:03:33 +0000

Hi,

> On 17 Jan 2018, at 00:13, Russ Housley <[email-masked]> wrote:
> 
> <snip>
> 
> <snip>

These are both excellent additions, many thanks.

Tim

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 18 Jan 2018 18:31:36 +0100

Thank you so much, Russ & team.

Nits in https://www.ietf.org/tools/ticketview/ticketview.py?ticket=202007

Cheers
   Toerless

On Tue, Jan 16, 2018 at 07:13:55PM -0500, Russ Housley wrote:
> Several site-wide issues raised on this list have been addressed in an update applied today.  These include removing the reference to externally hosted javascript and issues with how the site is displayed on smaller viewports such as phones.  Some updates have aimed to address accessibility issues raised, and accessibility remains an ongoing focus of the website???s development and editorial processes.
>

---

From: S Moonesamy <[email-masked]>
Date: Wed, 31 Jan 2018 11:58:15 -0800

Hello,
At 06:52 PM 16-01-2018, Alissa Cooper wrote:
>As Russ notes above, this project was started 
>nearly four years ago. It was started so long 
>ago that people can't remember the feedback they 
>gave in the early rounds of community comment — 
>or that community comment was sought at all. It 
>was started so long ago that the entire IAOC, 
>except the ISOC CEO, is different now than when 
>it started. When I think about the big picture, 
>the fact that it could take four years to re-do 
>our web site is what really stands out. We do 
>not have a viable structure for carrying out 
>this sort of externally facing function, which 
>is a necessary function for an organization that 
>exists in the world. Within our administrative 
>structure this function is at once many people's 
>responsibility and nobody's responsibility.

I'll highlight the following: "many people's 
responsibility and nobody's responsibility".  If 
a person is on a committee, is he/she responsible 
for the decisions taken by the previous 
committee?  If the project was viewed as a 
success, who would take credit for that?

I don't see anything in the various BCPs which 
says that nobody is responsible.  There are 
actually statements about "responsibility" in the 
documents.  If there is anything to learn, I'd 
say that what is written about the administrative 
structure does not work in practice.

Regards,
S. Moonesamy

---

From: Doug Royer <[email-masked]>
Date: Wed, 31 Jan 2018 14:10:31 -0700

On 01/31/2018 12:58 PM, S Moonesamy wrote:

> I don't see anything in the various BCPs which says that nobody is 
> responsible.  There are actually statements about "responsibility" in 
> the documents.  If there is anything to learn, I'd say that what is 
> written about the administrative structure does not work in practice.

Sometimes we think it could have been done better. The Internet exists 
today because things got done. Perfection should be secondary to 
achievement.

I have always been impressed with the IETF staff and volunteers. I think 
they have done a great job. We owe all IETF-ers for the success our 
Internet.The IETF web page is not like it was before. I had issues with 
the old pages. I have issues with the current pages. Okay, now I will 
get back to life as I appreciate the hard work done.

-- 

Doug Royer - (http://DougRoyer.US  http://goo.gl/yrxJTu )
[email-masked]
714-989-6135