Subject: Not a simple question

From: S Moonesamy <[email-masked]>
Date: Thu, 04 Jan 2018 11:37:51 -0800

Hi Pete,

I read RFC 7282.  Does "rough consensus" have the same meaning as "consensus"?

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Thu, 4 Jan 2018 15:00:35 -0500

> I read RFC 7282.  Does "rough consensus" have the same meaning as "consensus"?

Do you mean in the IETF context, or in the dictionary?

---

From: S Moonesamy <[email-masked]>
Date: Thu, 04 Jan 2018 12:19:47 -0800

Hi Ted,
>Do you mean in the IETF context, or in the dictionary?

It is within the IETF context.

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Thu, 4 Jan 2018 15:22:07 -0500

> It is within the IETF context.

In the IETF context, there's only ever rough consensus, so the distinction doesn't matter.   Consensus means complete agreement of all participants.   I doubt that's ever happened in the IETF.

There can be debate on what "rough consensus" is, but I think that Pete's document does a good job of capturing it.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Thu, 4 Jan 2018 15:58:51 -0500

the editor of RFC 2026 thinks that Pete went a bit too far in describing process 

but the basic point is that not everyone needs to agree to progress a document
but a lot of people do (just what % was specifically not defined)

Scott

> On Jan 4, 2018, at 3:22 PM, Ted Lemon <[email-masked]> wrote:
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 4 Jan 2018 16:05:30 -0500

> but a lot of people do (just what % was specifically not defined)

The problem with this is that then it's just voting.   That's the problem that Pete was trying to address in the document—there's too much of a culture of voting at the IETF, and this has some bad consequences, as we've seen.   The working groups that (IMHO) do the best work tend more in the direction of doing things Pete's way.

---

From: Tim Bray <[email-masked]>
Date: Thu, 4 Jan 2018 13:10:39 -0800

In practice it means that the chair(s) declared rough consensus and nobody
dissented violently enough to informally move the needle or formally launch
an appeal.

I think that definition enjoys consensus support 😁

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 5 Jan 2018 10:17:14 +1300

> The problem with this is that then it's just voting.   That's the problem that Pete was trying to address in the document—there's too much of a culture of voting at the IETF, and this has some bad…

I think the point has always been that all technical objections, whether from
a minority or even from a single person, have been discussed and that there
is general agreement either to fix them or to let them slide. Which is of
course a judgment call by the WG chairs; Pete's RFC offers a way to ensure
that this judgment call is generally accepted by the community.

You can't get away from words like "general" or "judgment".

   Brian

---

From: Melinda Shore <[email-masked]>
Date: Thu, 4 Jan 2018 12:22:29 -0900

> that this judgment call is generally accepted by the community.

Right, exactly.  Also, in consensus there's this notion of a process
through which the group comes to agreement and that that process
matters a lot.  It's how buy-in is generated, etc.  Unfortunately
there's just a ton of voting being done in practice, and while a lot
of that is the result of suboptimal chairing it's also the case
that the unwillingness of some participants to say "I don't agree but
I can live with it" tends to gum up the process.

Consensus is actually pretty complicated and it's difficult to do
at IETF scale, which is how we end up at "rough consensus" rather than
consensus.

Melinda

---

From: "John Levine" <[email-masked]>
Date: 4 Jan 2018 22:55:21 -0000

In article <[email-masked]>,
>dissented violently enough to informally move the needle or formally launch

Agreed.  In my experience, ordinary consensus means that a group
reached agreement without dissent.  That doesn't mean that everyone
supported the conclusion, but nobody disagreed enough to stop it.
Quakers, who do not describe their process as consensus although
everyone else does, refer to that as "standing aside" as a decision is
agreed.

Our consensus is different in that WG chairs or other
quasi-authorities declare that we're close enough, and people who
disagree are considered to be standing aside unless they disagree
loudly and persuasively.*  Personally, I've had lots of situations in
the IETF where I was in the rough, I thought a decision was not the
best but I wasn't so certain that I was willing to derail it.

R's,
John

* - just loudly isn't enough, although I know a few people who think it is
-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: S Moonesamy <[email-masked]>
Date: Fri, 05 Jan 2018 06:32:07 -0800

Hi Tim,
At 01:10 PM 04-01-2018, Tim Bray wrote:
>In practice it means that the chair(s) declared rough consensus and 
>nobody dissented violently enough to informally move the needle or 
>formally launch an appeal.
>
>I think that definition enjoys consensus support

I am not disagreeing with what you wrote above.  There is, for 
example, the following in the RFC: "Consensus is when everyone is 
sufficiently satisfied with the chosen solution, such that they no 
longer have specific objections to it".  The RFC also mentions 
allowing some dissent as "rough consensus".  For what it is worth, 
the last informative reference is about "sense of the meeting".

Regards,
S. Moonesamy

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 9 Jan 2018 00:42:49 +0000 (UTC)

There can only ever be rough consensus on what 'rough consensus' means.
 
Lloyd Wood [email-masked] http://about.me/lloydwood 

________________________________
From: Ted Lemon <[email-masked]>
To: S Moonesamy <[email-masked]> 
Cc: Pete Resnick <[email-masked]>; [email-masked]
Sent: Friday, 5 January 2018, 7:22
Subject: Re: Not a simple question