Subject: Yangdoctors early review of draft-ietf-lime-yang-connection-oriented-oam-model-03

From: Carl Moberg <[email-masked]>
Date: Mon, 22 Jan 2018 14:59:42 -0800

Reviewer: Carl Moberg
Review result: On the Right Track

This is my review of draft-ietf-lime-yang-connection-oriented-oam-model-03 and
the included YANG module.

Overall, the document is in reasonable shape but needs more attention around
one fundamental aspect, and a short list of minor issues.

My understanding is that this module is intended to be implemented as a network
service model, per the module classification RFC (RFC8199). But e.g. the ‘mip'
list has a key 'interface' of type 'if:interface-ref'. That type is defined in
ietf-interfaces to be a leafref with path "/if:interfaces/if:interface/if:name”
assuming that the module context is a single network element. This seems
self-contradicting and needs to be resolved. 

I would suggest running the YANG module through 'pyang -f yang' to provide
consistent formatting of the module. I think it would also be worth considering
putting the content in the canonical order. E.g. the location of the description
statement in the mip-address grouping makes it hard to read.

The 'session' list is 'ordered-by user', but does not provide any description or
explanation to the meaning of the order.

The content of the description strings are in need of language fixes.

---

From: wangzitao <[email-masked]>
Date: Tue, 23 Jan 2018 03:17:05 +0000

Hi Carl,
Thank you for these good comments!
Please find my reply in-line.

Best Regards!
-Michael

-----邮件原件-----
发件人: Carl Moberg [mailto:[email-masked]] 
发送时间: 2018年1月23日 7:00
收件人: [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]
主题: Yangdoctors early review of draft-ietf-lime-yang-connection-oriented-oam-model-03

Reviewer: Carl Moberg

This is my review of draft-ietf-lime-yang-connection-oriented-oam-model-03 and the included YANG module.

Overall, the document is in reasonable shape but needs more attention around one fundamental aspect, and a short list of minor issues.

My understanding is that this module is intended to be implemented as a network service model, per the module classification RFC (RFC8199). But e.g. the ‘mip'
list has a key 'interface' of type 'if:interface-ref'. That type is defined in ietf-interfaces to be a leafref with path "/if:interfaces/if:interface/if:name”
assuming that the module context is a single network element. This seems self-contradicting and needs to be resolved. 

+++Michael: agree. The 'interface' may not enough to distinguish different MIPs. We will fix it in next version, and may be define an "id" as the key. 

I would suggest running the YANG module through 'pyang -f yang' to provide consistent formatting of the module. I think it would also be worth considering putting the content in the canonical order. E.g. the location of the description statement in the mip-address grouping makes it hard to read.

+++Michael: OK. Will improve it.

The 'session' list is 'ordered-by user', but does not provide any description or explanation to the meaning of the order.

+++Michael: agree. Will remove it in next version. 

+++Michael: OK. Will improve it.