Subject: Re: IPv6-only IETF web server for publishing an Internet Draft?

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 14:13:37 +0200

Hi John,

Le 14/05/2018 à 12:47, John C Klensin a écrit :
> 
> 
> --On Monday, May 14, 2018 11:19 +0200 Alexandre Petrescu
> <[email-masked]> wrote:
> 
>> John,
>>
>> Thank you for the reply.
>>
>> I understand the need of universal reachability, separation of
>> experiments, and avoid of appeals.
>>
>> Allow me to wonder though whether the non-IETF XML format went
>> through such experimenting before being enforced at IETF scale.
> 
> While I'm not sure what the two have to do with each other or
> exactly what you are referring to, if you are referring to what
> is known as the xml2rfc format,
> 
> (1) It is not "being enforced" (in either version).   You are
> free to prepare and submit I-Ds, or even final pre-publication
> RFC drafts in plain ASCII text format without getting anywhere
> near XML.
> 
> (2) And, yes, there has been extensive experimentation and
> discussion.  Some of us are fairly unhappy with the new version
> and its documentation, but that doesn't change the history of
> discussion, documentation, and, apparently, rough consensus.

At this time, the submission system will not accept only the xml, it 
wants the txt too.  Otherwise it complains about draft name and/or title.

(yes, I was wrong about many other things I said earlier; yes, the 
submission system works ok if accessed with a client that does only IPv6 
and that is connected on a network that does only IPv6; I just checked 
from a car network by submitting an Internet Draft).

Alex
> 
>     john
> 
>>
>> Alex
>>
>> Le 04/05/2018 à 13:48, John C Klensin a écrit :
>>> Personal opinion only...
>>>
>>> A key part of the intent of Internet Drafts is that they be
>>> generally available to anyone interested on the Internet.  I
>>> understand the motivations for experiments and demonstrations
>>> but, if something is posted that is deliberately inaccessible
>>> to someone who cannot not or will not use IPv6, it
>>> invalidates the function of the document as a
>>> generally-accessible I-D and presumably could result in a
>>> process problem (or appeal) if there were any attempt to move
>>> it into an IETF consensus process.
>>>
>>> Please do demonstrations and experiments in another way.
> 
> 
> 
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 13 Jun 2018 11:27:20 -0400

> wants the txt too.  Otherwise it complains about draft name and/or

Not the case for me.  I submit via the API and I upload only the XML that way.
I'm pretty sure that I've submitted only XML via the web interface too.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Russ Housley <[email-masked]>
Date: Wed, 13 Jun 2018 11:46:04 -0400

Alexandre:
> 
> At this time, the submission system will not accept only the xml, it wants the txt too.

That is not correct.  If you post just the XML, the server will produce the plaintext file for you.

Russ

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 13 Jun 2018 19:43:54 +0200

I have just tried again: if I submit just the xml then the web page
complains in red about title and draft name.  If I submit both the xml
and the txt then it accepts it.

The complain in red is this:
> Could not extract a valid draft revision from the upload. To fix this
> in a text upload, please make sure that the full draft name including
> revision number appears centered on its own line below the document
> title on the first page. In an xml upload, please make sure that the
> top-level <rfc/> element has a docName attribute which provides the
> full draft name including revision number.

This is the xml excerpt that may cause issue?:
> <rfc category="std"
>      docName="draft-ietf-ipwave-ipv6-over-80211ocb-24.txt"
>      ipr="trust200902">

Attached the full xml file for what it's worth.

Alex

---

From: Warren Kumari <[email-masked]>
Date: Wed, 13 Jun 2018 14:02:04 -0400

I'm assuming you tried it with the docName attribute as "
draft-ietf-ipwave-ipv6-over-80211ocb-24" ?
W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Russ Housley <[email-masked]>
Date: Wed, 13 Jun 2018 14:32:14 -0400

>> full draft name including revision number.

Others have had success submitting just the .xml file.

Looking at your .xml file, you need to remove the ".txt" from the docName as follows:

OLD:

<rfc category="std"
    docName="draft-ietf-ipwave-ipv6-over-80211ocb-23.txt"
    ipr="trust200902">

NEW:

<rfc category="std"
    docName="draft-ietf-ipwave-ipv6-over-80211ocb-23"
    ipr="trust200902">

Russ

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 14 Jun 2018 07:44:10 +0200

Le 13/06/2018 à 20:02, Warren Kumari a écrit :
> I'm assuming you tried it with the docName attribute as 
> "draft-ietf-ipwave-ipv6-over-80211ocb-24" ?

That is not the full draft name.

The full draft name is draft-ietf-ipwave-ipv6-over-80211ocb-24.txt

Right?

Alex

> W
> 
> On Wed, Jun 13, 2018 at 1:44 PM Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> I don't think the execution is relevant when it was obviously a bad idea 
> in the first place.

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 14 Jun 2018 07:45:00 +0200

>      docName="draft-ietf-ipwave-ipv6-over-80211ocb-23"

I will try that.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 14 Jun 2018 18:29:43 +0200

>>      docName="draft-ietf-ipwave-ipv6-over-80211ocb-23"

I have tried to not use the .txt extension in the docName.

The submission was accepted, without asking the txt file.

I think the question is in my interpretation of that 'full draft name' 
in the error message above.  It means to me a file name with txt extension.

Maybe 'full draft name' means just the name of draft but without the txt 
extension.

Alex

---

From: Mark Andrews <[email-masked]>
Date: Fri, 15 Jun 2018 09:30:07 +1000

> On 15 Jun 2018, at 2:29 am, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
> I think the question is in my interpretation of that 'full draft name' in the error message above.  It means to me a file name with txt extension.
> 
> Maybe 'full draft name' means just the name of draft but without the txt extension.

.txt, .xml, .html, .pdf etc. are the format of the document encoded into the filename.
You have "<name>.<format>”.

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 11:01:34 +0200

> You have "<name>.<format>”.

Yes, from an abstract layer.

But from a mundane point of view:

Among 'draft-person.txt' and 'draft-person'
which one is a 'full draft name'?

Alex

---

From: Mark Andrews <[email-masked]>
Date: Fri, 15 Jun 2018 19:46:07 +1000

> On 15 Jun 2018, at 7:01 pm, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> 
> which one is a 'full draft name’?

draft-person

---

From: Julian Reschke <[email-masked]>
Date: Fri, 15 Jun 2018 11:48:16 +0200

On 2018-06-15 11:01, Alexandre Petrescu wrote:
> ...
> ...

See 
<https://greenbytes.de/tech/webdav/rfc7749.html#element.rfc.attribute.docName>.

Best regards, Julian

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 14:17:47 +0200

>> which one is a 'full draft name’?

and 'draft-person.txt' is then 'full full draft name'?

Sorry, I cant parse.

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 14:23:24 +0200

> <https://greenbytes.de/tech/webdav/rfc7749.html#element.rfc.attribute.docName>. 

Please, if you want feedback from me, do not point me to URLs.  URLs 
take time to click, and are invisible after some time whereas the 
message is still visible.

Better - paste the content here, so I can reply to it.

Of course, you are free to walk me back and forth between all sites of 
the Internet and wikipedia, and I will take advantage of that walking 
back and forth to maybe check whether it is secure, or whether it is 
IPv6 or just IPv4, or others.

But if we want to stay to the point, and if we are open to remarks and 
difficulties, and if we want to be kind to the humble submitter, then we 
listen.

That website says:
> 2.33.3. "docName" Attribute
> 
> For Internet-Drafts, this specifies the draft name (which appears below the title).
> 
> A processor should give an error if both the "docName" and "number" attributes are given in the <rfc> element.
> 
> Note that the file extension is not part of the draft

How comes a file extension is not part of the draft?

Maybe it is not part of the draft _name_?

Nobody expects a file extension to be part of the draft (contents of 
that draft.)

Alex

, so in general it should end with the current draft number ("-", plus 
two digits).
> 
> Furthermore, it is good practice to disambiguate current editor copies from submitted drafts (for instance, by replacing the draft number with the string "latest").
> 
> See Section 7 of [IDGUIDE] for further information.

---

From: John C Klensin <[email-masked]>
Date: Fri, 15 Jun 2018 09:41:12 -0400

Julian,

I understand the reasoning and those of us who use the
submission system (and XML2RFC, etc.) frequently have long ago
gotten used to the conventions.   However, it seems to me that
having xml2rfc enforce those conventions (e.g., by generating a
warning message when "draft-foo-bar.txt" appears rather than
"draft-foo-bar-00" would be rather easy.   Compared to that and
while I'm sure it is unintentional, the present situation
somewhat resembles a hazing process of torturing newcomers until
they eventually figure things out, get enough advice and/or
abuse, and thread their way through sufficient documents to be
considered worthy to join the club.  

I think we should be able to do at least a little bit better,
don't you?

best,
    john

--On Friday, June 15, 2018 14:23 +0200 Alexandre Petrescu
<[email-masked]> wrote:

> Please, if you want feedback from me, do not point me to URLs.
> URLs take time to click, and are invisible after some time
> whereas the message is still visible.
> 
> Of course, you are free to walk me back and forth between all
> sites of the Internet and wikipedia, and I will take advantage
> of that walking back and forth to maybe check whether it is
> secure, or whether it is IPv6 or just IPv4, or others.
> 
> But if we want to stay to the point, and if we are open to
> remarks and difficulties, and if we want to be kind to the
> humble submitter, then we listen.
> 
> That website says:
>> A processor should give an error if both the "docName" and
>> "number" attributes are given in the <rfc> element.
>> 
> Nobody expects a file extension to be part of the draft
> (contents of that draft.)
> 
> Alex
> 
> , so in general it should end with the current draft number
> ("-", plus two digits).
>> 
>> Furthermore, it is good practice to disambiguate current
>> editor copies from submitted drafts (for instance, by
>> replacing the draft number with the string "latest").
>>

---

From: Julian Reschke <[email-masked]>
Date: Fri, 15 Jun 2018 17:00:23 +0200

> "draft-foo-bar-00" would be rather easy.   Compared to that and

rfc2629.xslt does that (and that's the only xml2rfc related code base I 
am working on).

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Fri, 15 Jun 2018 17:47:40 +0200

On 2018-06-15 14:23, Alexandre Petrescu wrote:
> That website...

...containing the IAB-approved RFC that defines the xml2rfc v2 format.

>> A processor should give an error if both the "docName" and "number" 
>> attributes are given in the <rfc> element.
>>

Congratulations, you found an editorial problem in the spec.

Best regards, Julian

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 15 Jun 2018 17:53:53 +0200

> ...containing the IAB-approved RFC that defines the xml2rfc v2 format.

You mean that that website has text that is in an RFC?

> Congratulations, you found an editorial problem in the spec.

You mean the RFC has some nit?  I could submit an errata.

Alex

---

From: Christian Huitema <[email-masked]>
Date: Fri, 15 Jun 2018 09:16:34 -0700

> The full draft name is draft-ietf-ipwave-ipv6-over-80211ocb-24.txt

Sort of. The TXT version is indeed the reference version of the draft,
but there are also HTML and PDF versions, and XML source. I assume that
this is why we have a conflict between the popular belief that the draft
name is "draft-example-07.txt", and the tool's developers conviction
that the draft name is "draft-example-07", which can produce
"sraft-example-07.{txt|xml|html|pdf}". But as JCK noted, "the present
situation somewhat resembles a hazing process of torturing newcomers".
Not just newcomers, in fact. I fell for that bug quite a few times
recently, then slapped my forehead and remembered to go remove the
".txt" from the doc name. Repeat that too often and you end up with a
bruised forehead.

What is even more irritating is that our tools are inconsistent. I
usually verify that my draft is correct by passing the XML text through
the xml2rfc tool, conveniently provided at xml2rfc.ietf.org. That's a
nice tool. It will catch various kinds of nits of nits, and will let me
check that the draft prints nicely. But guess what? It will accept a
draft name ending in ".txt" just fine. No nit, nothing. That special
trap is left for the submission stage.

So, one way or another, we need to fix it.

-- Christian Huitema

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 15 Jun 2018 20:46:38 +0200

>     docName="draft-ietf-ipwave-ipv6-over-80211ocb-23"

Right.  I've just released xml2rfc 2.9.7 where I've added warnings for
added file extension and missing document revision.

Best regards,

	Henrik

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 20 Jun 2018 19:54:34 +0200

Henrik,

Thanks for the improvement.

I have submitted a new xml to the Draft Submission webpage at 
tools.ietf.org.

The xml was sufficient.  In case of (intended) error the explanation was 
much better than before.

Alex

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Jun 2018 21:50:55 +0200

Hi Alexandre,

> Thanks for the improvement.

You're welcome :-)

> The xml was sufficient.  In case of (intended) error the explanation was

Splendid!

	Henrik