Subject: Re: Enabling DMARC workaround code for all IETF/IRTF mailing lists

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 28 Jun 2018 07:39:57 -0400

I just wanted to follow up to note that since this was put into place, I
haven’t seen any false spam positives for email from IETF lists, where
before i was seeing them almost daily. Great job!

Thanks,
Andy

On Fri, May 11, 2018 at 8:00 AM, Alexey Melnikov <[email-masked]>
wrote:

> Hi,
> Many of you have seen several long discussions thread about DMARC and how
> it affects use of IETF/IRTF mailing lists.
>
> After testing DMARC workaround code written by Henrik Levkowetz on several
> high volume IETF and IRTF mailing lists (e.g. CFRG, WebRTC, DMARC, QUIC),
> the tools team and the IESG decided that Henrik's code should be deployed
> for all IETF and IRTF mailing lists. In particular the workaround allows
> people from DMARC p=reject domains to participate in IETF mailing lists, as
> well as to avoid the problem of recipients being unsubscribed from mailing
> lists. These 2 issues were the main reasons for developing the DMARC
> workaround code..
>
> The workaround will be deployed today, May 11th.
>
>
> Below are some technical details on how the email address rewriting
> workaround is going to work:
>
> Emails from domains that don't have a p=reject DMARC setting are not going
> to be affected in any way.
>
> For emails from p=reject domains:
>
> - The From header field of such emails will be rewritten to be under @
> dmarc.ietf.org domain (which will have a p=none policy). For example, "
> [email-masked]" email address would become "alexey=
> [email-masked]". The original From header field will be
> preserved in the X-Original-From header field, which can be used for
> automatic message processing by Sieve and Mail User Agents.
>
> Note that the mapping is reversible, so it is possible to send replies or
> new messages to an original sender by sending them to the corresponding
> mapped @dmarc.ietf.org email address.
>
> Best Regards,
> Alexey
>
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 28 Jun 2018 10:53:30 -0400

Andy:

My guess is that the DMARC change was not the reason for the improvement.

See https://mailarchive.ietf.org/arch/msg/wgchairs/VMjHSHYvmCoxuTA4VChp-RwTsHk

Russ

> On Jun 28, 2018, at 7:39 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> I just wanted to follow up to note that since this was put into place, I haven’t seen any false spam positives for email from IETF lists, where before i was seeing them almost daily. Great job!
> 
> Thanks,
> Andy
> 
> 
> On Fri, May 11, 2018 at 8:00 AM, Alexey Melnikov <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> Many of you have seen several long discussions thread about DMARC and how it affects use of IETF/IRTF mailing lists.
> 
> After testing DMARC workaround code written by Henrik Levkowetz on several high volume IETF and IRTF mailing lists (e.g. CFRG, WebRTC, DMARC, QUIC), the tools team and the IESG decided that Henrik's code should be deployed for all IETF and IRTF mailing lists. In particular the workaround allows people from DMARC p=reject domains to participate in IETF mailing lists, as well as to avoid the problem of recipients being unsubscribed from mailing lists. These 2 issues were the main reasons for developing the DMARC workaround code..
> 
> Below are some technical details on how the email address rewriting workaround is going to work:
> 
> Emails from domains that don't have a p=reject DMARC setting are not going to be affected in any way.
> 
> - The From header field of such emails will be rewritten to be under @dmarc.ietf.org <http://dmarc.ietf.org/> domain (which will have a p=none policy). For example, "[email-masked] <mailto:[email-masked]>" email address would become "alexey=[email-masked] <mailto:[email-masked]>". The original From header field will be preserved in the X-Original-From header field, which can be used for automatic message processing by Sieve and Mail User Agents.
> 
> Note that the mapping is reversible, so it is possible to send replies or new messages to an original sender by sending them to the corresponding mapped @dmarc.ietf.org <http://dmarc.ietf.org/> email address.
> 
> Best Regards,
> Alexey
> 
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 28 Jun 2018 13:36:16 -0400

Russ,

No, DMARC was the cause of the false positives. Gmail would put legitimate
IETF emails from p=reject domains into my spam box. Since the change, that
has no longer happened.

Cheers,
Andy

On Thu, Jun 28, 2018 at 10:53 AM, Russ Housley <[email-masked]> wrote:

>> After testing DMARC workaround code written by Henrik Levkowetz on
>> several high volume IETF and IRTF mailing lists (e.g. CFRG, WebRTC, DMARC,
>> QUIC), the tools team and the IESG decided that Henrik's code should be
>> deployed for all IETF and IRTF mailing lists. In particular the workaround
>> allows people from DMARC p=reject domains to participate in IETF mailing
>> lists, as well as to avoid the problem of recipients being unsubscribed
>> from mailing lists. These 2 issues were the main reasons for developing the
>> DMARC workaround code..
>>