Subject: Re: Last Call: <draft-ietf-bfd-yang-13.txt> (YANG Data Model for Bidirectional Forwarding Detection (BFD)) to Proposed Standard

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 1 Jun 2018 16:56:27 +0000

Hi,

We just uploaded rev14 which (I believe) addresses your comments: we added the missing reference statements and also fixed an incorrect reference. The diffs also include some small tree diagram changes (I upgraded from pyang 1.7.3 to 1.7.5).

Regards,
Reshad.

On 2018-05-26, 11:10 AM, "Reshad Rahman (rrahman)" <[email-masked]> wrote:

    Hi Tom,
    
    Thanks for the review. I will add the missing reference statements, I believe this was just an oversight because there are/were no RFC numbers for these imported modules (there is now for ietf-routing).  So I will add the usual RFC XXX with a note for the RFC Editor.
    
    Regards,
    Reshad.

    On 2018-05-26, 7:31 AM, "tom p." <[email-masked]> wrote:
    
        This I-D has a number of import statements from other YANG modules for
        which there is no Reference statement where I believe that there should
        be, statements such as .
        
          import iana-bfd-types
          import ietf-bfd
          import ietf-bfd-mpls
          import ietf-te
          import ietf-routing
        
        In the first three cases, it may be that the editors of this I-D
        consider that such a reference is not needed because the relevant
        modules are in the same I-D but such thinking is erroneous.  These are
        separate modules which will lead independent existences in the wild so
        that there will be nothing to tell a user of e.g.  module
        ietf-bfd-mpls-te
        where to look for
        ietf-bfd-types, ietf-bfd,  ietf-bfd-mpls
        
        These need  reference statement such as
        
          reference "RFC XXXX:   YANG Data Model for BFD";
        
        Tom Petch
        
        ----- Original Message -----
        From: "The IESG" <[email-masked]>
        To: "IETF-Announce" <[email-masked]>
        Cc: <[email-masked]>; <[email-masked]>;
        <[email-masked]>
        Sent: Friday, May 25, 2018 2:26 PM
        
        > The IESG has received a request from the Bidirectional Forwarding
        Detection
        > WG (bfd) to consider the following document: - 'YANG Data Model for
        > Bidirectional Forwarding Detection (BFD)'
        >   <draft-ietf-bfd-yang-13.txt> as Proposed Standard
        >
        > The IESG plans to make a decision in the next few weeks, and solicits
        final
        > comments on this action. Please send substantive comments to the
        > [email-masked] mailing lists by 2018-06-08. Exceptionally, comments may
        be
        > sent to [email-masked] instead. In either case, please retain the
        beginning of
        > the Subject line to allow automated sorting.
        >
        > Abstract
        >
        >
        >    This document defines a YANG data model that can be used to
        configure
        >    and manage Bidirectional Forwarding Detection (BFD).
        >
        >    The YANG modules in this document conform to the Network Management
        >    Datastore Architecture (NMDA).
        >
        >
        >
        >
        > The file can be obtained via
        > https://datatracker.ietf.org/doc/draft-ietf-bfd-yang/
        >
        > IESG discussion can be tracked via
        > https://datatracker.ietf.org/doc/draft-ietf-bfd-yang/ballot/
        >
        >
        > No IPR declarations have been submitted directly on this I-D.
        >
        >
        > The document contains these normative downward references.
        > See RFC 3967 for additional information:
        >     draft-ietf-teas-yang-te: A YANG Data Model for Traffic Engineering
        Tunnels and Interfaces (None - IETF stream)
        >     draft-ietf-mpls-base-yang: A YANG Data Model for MPLS Base (None -
        IETF stream)

Subject: I-D Action: draft-ietf-bfd-yang-14.txt
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Date: Fri, 1 Jun 2018 09:36:05 -0700
List-Id: "RTG Area: Bidirectional Forwarding Detection DT" <rtg-bfd.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Bidirectional Forwarding Detection WG of the IETF.

        Title           : YANG Data Model for Bidirectional Forwarding Detection (BFD)
        Authors         : Reshad Rahman
                          Lianshu Zheng
                          Mahesh Jethanandani
                          Santosh Pallagatti
                          Greg Mirsky
	Filename        : draft-ietf-bfd-yang-14.txt
	Pages           : 74
	Date            : 2018-06-01

Abstract:
   This document defines a YANG data model that can be used to configure
   and manage Bidirectional Forwarding Detection (BFD).

   The YANG modules in this document conform to the Network Management
   Datastore Architecture (NMDA).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-bfd-yang/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-bfd-yang-14
https://datatracker.ietf.org/doc/html/draft-ietf-bfd-yang-14

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-yang-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "tom p." <[email-masked]>
Date: Tue, 5 Jun 2018 17:07:41 +0100

The newly published -14 addresses these comments I made, below.

Tom Petch

> From: "tom p." <[email-masked]>
> Sent: Saturday, May 26, 2018 12:19 PM
>