Subject: Re: [Netconf] Last Call: <draft-ietf-netconf-rfc7895bis-06.txt> (YANG Library) to Proposed Standard

From: Lou Berger <[email-masked]>
Date: Mon, 30 Jul 2018 13:01:15 -0400

Hi,

     I have a late comment on this document that I discovered while 
reviewing draft-ietf-netconf-nmda-netconf.  Sorry about the timing, but 
better to make the comment now rather then as an errata...

This document says:
    All NETCONF servers supporting YANG 1.1 [RFC7950] are required to
    support YANG Library (see Section 5.6.4 of RFC 7950).  NETCONF
    servers implementing the NETCONF extensions to support the NMDA
    [I-D.ietf-netconf-nmda-netconf] MUST implement at least the version
    of the YANG library defined in this document.  Similarly, all
    RESTCONF servers are required to support YANG Library (see Section 10
    of RFC 8040).  RESTCONF servers implementing the RESTCONF extensions
    to support the NMDA [I-D.ietf-netconf-nmda-restconf] MUST implement
    at least the version of the YANG library defined in this document.

I read this as an  update to RFC7950 and this should be noted in the 
document header, the abstract and Intro.

Lou

On 6/14/2018 12:22 PM, The IESG wrote:
> The IESG has received a request from the Network Configuration WG (netconf)
> to consider the following document: - 'YANG Library'
>    <draft-ietf-netconf-rfc7895bis-06.txt> as Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2018-06-28. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the beginning of
> the Subject line to allow automated sorting.
>
> Abstract
>
>
>     This document describes a YANG library that provides information
>     about the YANG modules, datastores, and datastore schemas used by a
>     network management server.  Simple caching mechanisms are provided to
>     allow clients to minimize retrieval of this information.  This
>     version of the YANG library supports the Network Management Datastore
>     Architecture by listing all datastores supported by a network
>     management server and the schema that is used by each of these
>     datastores.
>
>     This document obsoletes RFC 7895.
>
>
>
>
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-netconf-rfc7895bis/
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/doc/draft-ietf-netconf-rfc7895bis/ballot/
>
>
> No IPR declarations have been submitted directly on this I-D.
>
>
>
>
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 30 Jul 2018 13:10:35 -0700

Hi Lou,

> On Jul 30, 2018, at 10:01 AM, Lou Berger <[email-masked]> wrote:
> 
> Hi,
> 
>     I have a late comment on this document that I discovered while reviewing draft-ietf-netconf-nmda-netconf.  Sorry about the timing, but better to make the comment now rather then as an errata...
> 
> This document says:
> I read this as an  update to RFC7950 and this should be noted in the document header, the abstract and Intro.

Your read of the update to RFC7950 is that it should now reference rfc7895bis in Section 5.6.4. Is that correct? How is that different from 7895bis obsoleting 7895, and thus all references to 7895 should now be to 7895bis?

>> No IPR declarations have been submitted directly on this I-D.

Mahesh Jethanandani
[email-masked]

---

From: Lou Berger <[email-masked]>
Date: Mon, 30 Jul 2018 16:19:41 -0400

Hi,

> Your read of the update to RFC7950 is that it should now reference rfc7895bis in Section 5.6.4. Is that correct? How is that different from 7895bis obsoleting 7895, and thus all references to 7895…
All this means is that  draft-ietf-netconf-rfc7895bis should note it 
updates RFC 7950 in the header and abstract...

Lou