Subject: IETF103 Hackathon --- the weekend after?

From: Michael Richardson <[email-masked]>
Date: Sat, 21 Jul 2018 18:30:48 -0400

I understand that the IEEE meeting will be located in the same
hotel/conference center as IETF103, the week afterwards.
There is a desire to foster more collaboration between IEEE and IETF.

I want to suggest that we consider moving the Hackathon from the
Saturday/Sunday before IETF103, to the Saturday/Sunday afterwards,
such that it is now sandwiched between IETF and IEEE meetings.

I recognize that perhaps it's too late to rejig this, and there are issues
relating to the network infrastructure, hotel bookings, and the like.

I suggest the following points:
  a) We might attract IEEE-types to the Hackathon.

  b) We will give a reason for IETF-types to remain in Bangkok after IETF,
     in order to mix with IEEE-types.

  c) The Hackathon has now made the week 7 days for sure: arrive Friday
     morning, stay until Friday afternoon.  Few who come for the Hackathon
     are going to stay another weekend and attend IEEE, unless they already
     do stay.
     Moving the Hackthon means people could arrive Sunday and depart on
     the following Sunday or Monday.  Same number of hotel nights, but more
     overlap.

  d) Without something on the weekend between IETF and IEEE, there are likely
     to be no additional interactions,

  e) the Friday unstructured time experiment might actually work.

One might also contemplate starting the Hackathon on Friday or Friday
afternoon, possibly finishing earlier on Sunday.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Nick Feamster <[email-masked]>
Date: Sat, 21 Jul 2018 18:58:40 -0400

I thought the current scheduling worked very well, as a practical matter.

As a first-time hackathon goer and relative newcomer to IETF, placing the hackathon before the WG meetings was very useful for us, in that it allowed us to meet up with folks and get stuff done—design and otherwise—which we could talk about in the WG meeting itself.

In the sense that the hackathon serves as an informal pre-WG working meeting, I found it very useful. It also nicely sequenced with ANRW on Monday.

-Nick

> On Jul 21, 2018, at 6:30 PM, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
>

---

From: Randy Bush <[email-masked]>
Date: Sat, 21 Jul 2018 17:45:15 -0700

> hotel/conference center as IETF103, the week afterwards.

AINTEC 2018, an academic conference, will be the week after as well.
see https://interlab.ait.ac.th/aintec2018/.  but in a different venue.

randy

---

From: Tim Wicinski <[email-masked]>
Date: Sat, 21 Jul 2018 21:57:52 -0400

What Nick said.  Shane Kerr did a hackathon project on a draft that was
appearing in DNSOP later in the week, found problems with the spec, and was
able to work out the details before the meeting and show multiple
implementations.  It was double plus excellent.

We gave Shane some DNS cookies, but there was vendor interoperability
issues with him consuming them.   We're addressing that issue.

Tim

---

From: Eric Rescorla <[email-masked]>
Date: Sat, 21 Jul 2018 20:33:07 -0700

I agree with Nick here. We use the hackathon as a pre-meeting interop,
helping us flesh out issues for the WG meetings during the week. Having the
hackathon afterwards would not serve the same purpose.

An additional concern here is that people are pretty wiped out after an
IETF meeting. This was true even before we started having the hackathon the
weekend before and I think it would be difficult for people to be effective
at the hackathon afterwards.

-Ekr

On Sat, Jul 21, 2018 at 3:58 PM, Nick Feamster <[email-masked]>
wrote:

> As a first-time hackathon goer and relative newcomer to IETF, placing the
> hackathon before the WG meetings was very useful for us, in that it allowed
> us to meet up with folks and get stuff done—design and otherwise—which we
> could talk about in the WG meeting itself.
>
> In the sense that the hackathon serves as an informal pre-WG working
> meeting, I found it very useful. It also nicely sequenced with ANRW on
> Monday.
>
> -Nick
>
> _______________________________________________
> hackathon mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/hackathon
>
>

---

From: Antoni Przygienda <[email-masked]>
Date: Mon, 23 Jul 2018 05:17:01 +0000

All +1 …

--- tony

Thus spake <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>>:

I agree with Nick here. We use the hackathon as a pre-meeting interop, helping us flesh out issues for the WG meetings during the week. Having the hackathon afterwards would not serve the same purpose.

An additional concern here is that people are pretty wiped out after an IETF meeting. This was true even before we started having the hackathon the weekend before and I think it would be difficult for people to be effective at the hackathon afterwards.

-Ekr

On Sat, Jul 21, 2018 at 3:58 PM, Nick Feamster <[email-masked]<mailto:[email-masked]>> wrote:
I thought the current scheduling worked very well, as a practical matter.

-Nick

> On Jul 21, 2018, at 6:30 PM, Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:
>
> Signed PGP part
>
> Michael Richardson <[email-masked]<mailto:[email-masked]>>, Sandelman Software Works

_______________________________________________
hackathon mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/hackathon<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_hackathon&d=DwMFaQ&c=HAkYuh63rsuhr6Scbfh0UjBXeMK-ndb3voDTXcWzoCI&r=maKXfKzgRTpiLitqHnJiww&m=GLJemhK6gLDHJ4U3z4jLG0ejsWc-VXe-3isPdfh9Pjg&s=giBP9FyxKv8TFnBP3c814Vp4kK3pyuj8dFToJYf6dhY&e=>

---

From: OndÅej SurÃ½ <[email-masked]>
Date: Mon, 23 Jul 2018 07:26:51 +0200

+1 here, I am certainly sure that I won’t attend Hackathon after the IETF. I just want to be back home after the full week. The current timing works best.

Ondřej
--
Ondřej Surý <[email-masked]>

> On 22 Jul 2018, at 05:33, Eric Rescorla <[email-masked]> wrote:
> 
>> On Sat, Jul 21, 2018 at 3:58 PM, Nick Feamster <[email-masked]> wrote:

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 23 Jul 2018 13:09:02 +0000

Another consideration is that from a space and network perspective, running the hackathon the weekend before the week of meetings works better than after the week of meetings. Plus, at IETF 103, the schedule is such that meetings end Thursday, so having the hackathon the weekend after would require 3 extra days on the tail end, Friday, Saturday, and Sunday.
At IETF 102, we teamed up with the Netdev community (https://www.netdevconf.org/0x12/index.html), which ran its conference the week before IETF. We plan to do the same for IETF 104 in Prague. Perhaps we should look for a similar opportunity with IEEE in which an IEEE event is the week before IETF. More collaboration with IEEE, especially in the context of a future IETF hackathon, would be great.

Cheers,
Charles

From: ietf <[email-masked]> on behalf of OndÅ™ej SurÃ½ <[email-masked]>
Date: Monday, July 23, 2018 at 12:27 AM
To: Eric Rescorla <[email-masked]>
Cc: Michael Richardson <[email-masked]>, Nick Feamster <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [hackathon] IETF103 Hackathon --- the weekend after?

Ondřej
--
Ondřej Surý <[email-masked]<mailto:[email-masked]>>

On 22 Jul 2018, at 05:33, Eric Rescorla <[email-masked]<mailto:[email-masked]>> wrote:
I agree with Nick here. We use the hackathon as a pre-meeting interop, helping us flesh out issues for the WG meetings during the week. Having the hackathon afterwards would not serve the same purpose.

-Ekr

-Nick