Subject: Re: what to do about missing cites and encouraging better citing

From: Denis Ovsienko <[email-masked]>
Date: Sun, 01 Jul 2018 13:49:42 +0100

---- On Sun, 24 Jun 2018 23:29:35 +0100 Randy Bush <[email-masked]> wrote ---- 
 > [ we need a new rat-hole as relief from pico-managing the selection of a 
 >   board on which no one sane would want to be ] 
 >  
 > this is meant to raise consciousness, not cause process-creation or 
 > other complexity. 
 >   
 > over in the research universe, (most; hi dan) folk are careful about 
 > citing prior work in the area, especially if it is seminal.  we seem to 
 > be somewhat sloppy over here in standards wonk land; and i am not 
 > entirely comfortable with this. 

Your ideal of the research universe is nice. Your experience of the real research universe may be not as nice. It is not the opposite, but it is populated with real people, who are not ideal.

However, aiming to be as close to the ideal as possible is important to influence what IETF leaves in the world after itself. I personally find this matter more relevant than food, photography and the likes.

 > but can we do anything when we find a missing cite? 
 >  
 > to have an example, and not meaning to pick on anyone, rfc 7747 uses the 
 > methods of, but does not cite, the 2001 seminal work in the area of 
 > routing convergence measurement by shaikh and greenberg, 
 > http://citeseer.ist.psu.edu/viewdoc/summary?doi=10.1.1.910.8379 
 >  
 > yes, it is somewhat painful when the cite would be to a non-rfc, as our 
 > external citing mechanisms are clumsy. 

The effort the original author(s) had put into producing the referenced work in the first place is worth the 5-10 minutes spent spelling an exotic reference in an I-D. I had done the latter, it was not dramatic at all.

 > i assume a missing cite is not an erratum.  so maybe nothing can be done 
 > other than to encourage authors to be more careful.  in general, the 
 > ietf has a weak culture of good citing.  and i guess i could/should have 
 > flagged this particular example in a last call <blush>. 

Editorial errata seem to be the most reasonable first step, and whatever problems remain afterwards can be addressed as the next step.

-- 
    Denis Ovsienko

---

From: Denis Ovsienko <[email-masked]>
Date: Sun, 01 Jul 2018 14:41:59 +0100

---- On Mon, 25 Jun 2018 00:16:52 +0100 Brian E Carpenter <[email-masked]> wrote ---- 
 > On 25/06/2018 10:29, Randy Bush wrote: 
 > ....> i assume a missing cite is not an erratum.  so maybe nothing can be done 
 > > ietf has a weak culture of good citing.  
 >  
 > Yes. I mentioned this briefly in 
 > https://tools.ietf.org/html/draft-carpenter-whats-an-author-02#section-2 
 > but didn't detect great enthusiasm in the community for dealing with 
 > authorship ethics in general. 

>From my own experience, documents like this are very useful out-of-ordinary references, in that you do not need them for document production, but when (not if) normal work derails, structured thinking like this makes it more doable to talk sense back into people (or to confirm to yourself you are doing a right thing).

There is a certain art (which I do not master) in striking the balance between a single normative BCP saying "participants MUST NOT be evil" and total irresponsibility.

The lack of enthusiasm should not demotivate you as it is not rooted in the merits of this document.

-- 
    Denis Ovsienko

---

From: Jari Arkko <[email-masked]>
Date: Mon, 2 Jul 2018 16:34:35 +0300

I agree that there are many cases where improvements in
references and flagging prior work would be useful in IETF
documents.

I don’t think this is a something where we should be looking
for new process or a dramatic difference to current practice.
IETF documents tend to do the right thing in many cases,
but often focus on the standards issues (e.g., referencing
other documents for the sake of interoperability issues or
need to understand them for implementation reasons).

However, I do think referencing prior work, setting context
to how present work differs from other work, attribution,
and (generous) acknowledgment of contributions are
important. And in some of these cases we could do a
better job. Although that’s hard work and requires
those LC comments and maybe a bit of a shift
in thinking how one is supposed to write RFCs.

Some improvements in tooling might actually
be quite helpful here as well… struggling today
with some references in XML2RFC...

Jari

---

From: Randy Bush <[email-masked]>
Date: Mon, 02 Jul 2018 06:52:52 -0700

> for new process

great ghu save us!

> or a dramatic difference to current practice.

well, not in written practice.

> However, I do think referencing prior work, setting context to how
> present work differs from other work, attribution, and (generous)
> acknowledgment of contributions are important.

strongly agree on ensuring attribution those on whose shoulders, as
opposed to toes, we stand.

my model is also arming a new hire with no foo experience, or a grad
student who needs to come up to speed on foo for their research.  both,
but the latter especially, is used to following rabbit tunnels; but not
if they're not present.

randy, who is trying to get xml2rfc to do a cite to cacm this morning