Subject: Secdir last call review of draft-ietf-6lo-nfc-13

From: Leif Johansson via Datatracker <[email-masked]>
Date: Thu, 07 Mar 2019 08:34:40 -0800

Reviewer: Leif Johansson
Review result: Has Issues

 I have reviewed this document as part of the security directorate's 
ongoing effort to review all IETF documents being processed by the 
IESG.  These comments were written primarily for the benefit of the 
security area directors.  Document editors and WG chairs should treat 
these comments just like any other last call comments.

I am not a subject matter expert but overall I find the document well 
written and readable. 

The issue I have is in the security considerations section where I 
really think there should be normative language around the use 
of permanent identifiers. In particular:

"Thus, every single touch connection can use a different short address of NFC
link with an extremely short-lived link.  This can mitigate address scanning 
as well as location tracking and device-specific vulnerability exploitation."

This is imo too weak. I suggest reformulating this and related text to 
normative language. Given the possible consequences of NFC correlation
attacks I would have thought that a mandatory requirement on generating
different short addresses for every link would be a good idea.

---

From: 최영환 <[email-masked]>
Date: Fri, 8 Mar 2019 01:02:48 +0000

Dear Leif Johansson.

Thanks for your comments.
Please find the answer inline bellows:

BRs,
Younghwan Choi

-----Original Message-----
From: Leif Johansson via Datatracker <[email-masked]> 
Sent: Friday, March 8, 2019 1:35 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-6lo-nfc-13

Reviewer: Leif Johansson

 I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comments.

I am not a subject matter expert but overall I find the document well written and readable. 

YH>> Thanks a lot.

The issue I have is in the security considerations section where I really think there should be normative language around the use of permanent identifiers. In particular:

"Thus, every single touch connection can use a different short address of NFC link with an extremely short-lived link.  This can mitigate address scanning as well as location tracking and device-specific vulnerability exploitation."

This is imo too weak. I suggest reformulating this and related text to normative language. Given the possible consequences of NFC correlation attacks I would have thought that a mandatory requirement on generating different short addresses for every link would be a good idea.

YH>> I agree with your comment, so I would like to reformulate the sentences like followings:

YH>> "Thus, connections with every single touch between NFC-enabled devices MUST use different short addresses with extremely short-lived links. This also SHOULD mitigate the NFC correlation attacks, such as address scanning, location tracking, and device-specific vulnerability exploitation."

YH>> I will update the draft (-13) with the new sentences if it's ok.
YH>> Thanks again.