Subject: Finding the appropriate work stream for draft-nottingham-for-the-users

From: Ted Hardie <[email-masked]>
Date: Mon, 18 Mar 2019 14:58:06 -0700

Greetings,

The IAB is considering adopting this document onto the IAB stream as
Informational:

https://datatracker.ietf.org/doc/draft-nottingham-for-the-users/

with a focus on explaining why decisions in the IETF often are or should
be  user-focused.

However, in discussion some felt that there might be interest in adopting
this document into the IETF stream as a BCP (most likely in the General
Area), with a stronger focus on setting guidelines for working groups when
they face these sorts of issues.

The IAB is seeking input from the community about the level of interest (or
disinterest) in the latter approach. Please do so on this list, by sending
mail to [email-masked] (our public discussion list) or to
[email-masked] (to reach just the IAB). You can also discuss with individual
IAB members in Prague.

Thanks,

Ted Hardie
for the IAB

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 18 Mar 2019 23:22:41 +0100

Hi Ted,

Was not aware of this document, I just read it, and I agree with the content.

Furthermore, I fully agree, that unless there is a better fit, the General Area will be just right.

Regards,

Jordi

De: ietf <[email-masked]> en nombre de Ted Hardie <[email-masked]>
Fecha: lunes, 18 de marzo de 2019, 22:59
Para: IETF <[email-masked]>
Asunto: Finding the appropriate work stream for draft-nottingham-for-the-users

Greetings,

The IAB is considering adopting this document onto the IAB stream as Informational:

https://datatracker..ietf.org/doc/draft-nottingham-for-the-users/

with a focus on explaining why decisions in the IETF often are or should be  user-focused.

However, in discussion some felt that there might be interest in adopting this document into the IETF stream as a BCP (most likely in the General Area), with a stronger focus on setting guidelines for working groups when they face these sorts of issues. 

The IAB is seeking input from the community about the level of interest (or disinterest) in the latter approach. Please do so on this list, by sending mail to [email-masked] (our public discussion list) or to iab@iab..org (to reach just the IAB). You can also discuss with individual IAB members in Prague.

Thanks,

Ted Hardie

for the IAB

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 03:04:47 -0400

If IETF is serious about considering [the needs of] end users as its 
primary concern, it needs to be wider in scope than just informing 
technical decisions by working groups.  For instance, IETF has a 
decades-long history of holding meetings, and making appointments, in 
such a way as to favor those with large travel budgets.   Those who fund 
such individuals (which tend to be large corporations and sometimes 
governments) cannot be said to represent the interests of users first 
and foremost.  And even if the individuals who participate have often 
made a considerable good-faith effort to do that, I've also seen 
exceptions to that.

I'm not saying that this is an easy problem to address, or that efforts 
to address this problem have not been made.   There are indeed ways of 
participating in IETF on the cheap, sometimes effectively.   But anytime 
you hear anyone in a privileged position claim to represent the 
interests of ordinary people, your BS meter should register a 
significant deflection.  If we really wanted to conduct our 
deliberations in such a way as to consider the interests of end users as 
our primary concern (as opposed to just telling ourselves that), we'd 
have to make fairly drastic changes in how we operate.   Offhand I have 
a hard time imagining what that would look like.  And I wouldn't expect 
to reverse ~25 years of inertia overnight.   But we could probably do 
better than we are doing.

Anyway, you asked about which stream.   To me it seems clear that, for 
any result of such discussion to carry weight and actually affect how we 
operate, it needs to be an IETF consensus document - thus BCP and not 
IAB stream.

Keith

On 3/18/19 5:58 PM, Ted Hardie wrote:
> <https://datatracker.ietf.org/doc/draft-nottingham-for-the-users/>
>
> However, in discussion some felt that there might be interest in 
> adopting this document into the IETF stream as a BCP (most likely in 
> the General Area), with a stronger focus on setting guidelines for 
> working groups when they face these sorts of issues.
>
> The IAB is seeking input from the community about the level of 
> interest (or disinterest) in the latter approach. Please do so on this 
> list, by sending mail to [email-masked] 
> <mailto:[email-masked]> (our public discussion list) or 
> to iab@iab..org <mailto:[email-masked]> (to reach just the IAB). You can 
> also discuss with individual IAB members in Prague.
> Thanks,
> Ted Hardie
> for the IAB

---

From: Jari Arkko <[email-masked]>
Date: Tue, 19 Mar 2019 10:06:22 +0200

My personal opinion is that it would be useful for the IETF to state its preference to benefit the users, and to begin with, consider the impacts its technology may have on the various relationships among users, and various other players. Of course, in many cases we are already doing this (and debating it!), but there’s obviously always room for improvement.

I do think though that if the document goes forward, it would be beneficial to rethink the examples. “Network operators and equipment vendors” as the threat picture… doesn’t sound to me like 2019 at all, with all the technology and deployment changes we’ve had in the last few years. How about “large content and application providers”? This seems like a major issue in today’s Internet.

Jari

(No hats)

---

From: Eliot Lear <[email-masked]>
Date: Tue, 19 Mar 2019 11:21:48 +0100

Hi Jari,

First, thanks to Mark for writing a provocative draft worthy of his role on the IAB.

TL;DR I do not believe this document asks the right question, and further believe that there may be a better approach to take.

> On 19 Mar 2019, at 09:06, Jari Arkko <[email-masked]> wrote:
> 

You raise an important point.  More broadly, I would find it strange that someone participating here believes that he or she is not acting in the interests of the end users.
Network operators believe they are acting in the interests of end users  by intercepting threats to them.
Browser developers believe they are operating in the interests of end users when they protect the privacy of communications.
Social network providers believe they are operating in the interests of end users by providing them fora in which to congregate.
Content providers believe they are operating in the interests of end users by providing them meaningful and sometimes entertaining content.
Cloud providers believe they are operating in the interests of end users by supporting applications.
Firewall vendors believe they are operating in the interests of end users even by eavesdropping on corporate communications to prevent embezzlement.
Some civil society organizations believe they are operating in the interests of end users by preventing unwarranted and undetected surveillance by governments.
Governments believe they are operating in the interests of end users by identifying risks to their citizens.
The document, however, is framed as though only a handful of these groups are operating in the interest of end users.  And that is problematic, because it will lead to incessant argument over just who represents 7 billion people (did I mention the UN above?) with unpredictable and potentially perverse consequences.

This leads to a question: what behavior do we actively want to change?  What outcome went wrong that we would want to correct?  Like you, Jari, I am hard pressed to find an applicable example, which is why I suspect the Examples section is so paltry.  Put another way, what would be the practical ramifications of adopting this work as a BCP?

Having a food fight over who best represents the user isn’t productive.  We all think we do.  And we all want to leave the world better than we found it.  I would, therefore, propose that we frame our purpose accordingly, borrowing from the work of others, such as Hippocrates and Maimonides.  Practitioners of all sorts have ethics policies, including  ISOC and the IEEE.  Maybe what we really want is a promise from participants that they work for the betterment of society, however they understand that to mean, and that the higher they rise in leadership at the IETF, the more we will expect them to demonstrate having met that goal.

If we are to take this up at all, and I am not opposed to doing so, I would suggest that we first be able to agree on the goal, that we have some understanding of what mechanism we want to use to achieve that goal, and that we understand the ramifications of our choices.

The worst possible world is one in which we short circuit difficult decisions because we have enacted a policy that favors one view of users over another without regard to the consequences.  Applying a normative imprimatur to this work that an IETF BCP carries would therefore be premature.

Eliot

---

From: Ole Troan <[email-masked]>
Date: Tue, 19 Mar 2019 11:51:27 +0100

> The IAB is seeking input from the community about the level of interest (or disinterest) in the latter approach. Please do so on this list, by sending mail to [email-masked] (our public discussion…

In 6man we have a discussion triggered by a draft (slaac-renum) where “for-the-users” is very relevant (thank you for publishing).
The discussion is exposing the tussle between network operators wanting operational freedom of being able to instantly renumber end-user networks against the end-user’s expectation of stable addressing (and planned renumbering).

The stronger the IETF consensus behind this document, the easier it will be to use it to guide working group discussion and decisions.

Cheers,
Ole

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Mar 2019 12:05:31 +0000

I think we should focus on technology and be neutral on politics.

As an organization we are fully qualified to express a technical opinion 
on Internet technology, but we are amateurs when it comes to 
understanding the political consequences of our decisions.

The more we let politics impinge on out technical decisions, the greater 
the risks that the various governments that support our position as the 
Internet design authority will move that support to the ITU which is the 
UN (i.e. government run) telecommunications standards body, and is 
geared up to consider the political implications of their work.

Rather than consider this aspect of our work, we should put more focus 
on putting in place the telecommunications technology we need to have in 
place in the 10 to 20 year time-frame. By then we will need bandwidths 
in the 1TB class to the users, power consumptions per bit that is minute 
compared to the current level, and latencies where the laws of physics 
are the only significant factor. It is unclear whether the current 
Internet architecture will satisfy those needs without change, and in my 
view that is the area that the IAB should attend to, rather than to work 
described in this draft.

- Stewart

On 18/03/2019 21:58, Ted Hardie wrote:
> adopting this document into the IETF stream as a BCP (most likely in the 
> General Area), with a stronger focus on setting guidelines for working 
> groups when they face these sorts of issues.
> 
> The IAB is seeking input from the community about the level of interest 
> (or disinterest) in the latter approach. Please do so on this list, by 
> sending mail to [email-masked] 
> <mailto:[email-masked]> (our public discussion list) or to 
> iab@iab..org <mailto:[email-masked]> (to reach just the IAB). You can also 
> discuss with individual IAB members in Prague.
> 
> Thanks,
> 
> Ted Hardie
> for the IAB

---

From: Ted Lemon <[email-masked]>
Date: Tue, 19 Mar 2019 09:08:16 -0400

On Mar 19, 2019, at 8:05 AM, Stewart Bryant <[email-masked]> wrote:
> Rather than consider this aspect of our work, we should put more focus on putting in place the telecommunications technology we need to have in place in the 10 to 20 year time-frame. By then we will need bandwidths in the 1TB class to the users, power consumptions per bit that is minute compared to the current level, and latencies where the laws of physics are the only significant factor. It is unclear whether the current Internet architecture will satisfy those needs without change, and in my view that is the area that the IAB should attend to, rather than to work described in this draft.

This is certainly an exciting picture of the future that you are painting at layer 2 and layer 3, but I notice that you didn’t respond to Ole’s point, which I think is a great example of the problem.   Like it or not, the participants in the IETF have expertise that is relevant to things that you call “political,” and to suggest that we should not factor that into our decisions is unrealistic.   We are going to factor these considerations into our decisions whether we admit it or not.

But where IETF discourse goes badly wrong is when we have discussions where we haven’t agreed first on what we are talking about.   Then you see these hundred- or thousand-message streams of people talking past each other and never reaching completion, because nobody feels heard, because we didn’t take the time to figure out what questions we were trying to answer.

If you think about it, what you have proposed is actually just as political as anything else.   You believe that users should have maximally fast, minimally latent connectivity.   I think that’s a good goal, but it’s only a meaningful goal if the users want it.   Otherwise it’s just some shiny tech you’re working on.   And let’s be clear about this: it’s not at all clear that users want that.   What I mean is that users aren’t making purchasing decisions on the basis of whether they maximize throughput and minimize latency.   If they were, we wouldn’t still be seeing bufferbloat everywhere.

Understanding what users need and trying to address their needs is in a sense the core function of the IETF.   It’s not a side issue that we can ignore in the pursuit of technical excellence.

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 09:45:09 -0400

And for nearly every single one of those parties, it's easy to identify 
cases in which those parties act significantly against users' 
interests.  (Not sure if you intended this, but...)

Nearly everybody wants to believe they're doing good, even when they're 
not.    But it's easy to believe you're acting on behalf of Internet 
users when you're working in an environment that most users aren't aware 
of, and which imposes significant barriers to participation by ordinary 
users.

On 3/19/19 6:21 AM, Eliot Lear wrote:
>
>   * Network operators believe they are acting in the interests of end
>     users  by intercepting threats to them.
>   * Browser developers believe they are operating in the interests of
>     end users when they protect the privacy of communications.
>   * Social network providers believe they are operating in the
>     interests of end users by providing them fora in which to congregate.
>   * Content providers believe they are operating in the interests of
>     end users by providing them meaningful and sometimes entertaining
>     content.
>   * Cloud providers believe they are operating in the interests of end
>     users by supporting applications.
>   * Firewall vendors believe they are operating in the interests of
>     end users even by eavesdropping on corporate communications to
>     prevent embezzlement.
>   * Some civil society organizations believe they are operating in the
>     interests of end users by preventing unwarranted and undetected
>     surveillance by governments.
>   * Governments believe they are operating in the interests of end
>     users by identifying risks to their citizens.
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Mar 2019 14:31:59 +0000

On 19/03/2019 13:08, Ted Lemon wrote:
> On Mar 19, 2019, at 8:05 AM, Stewart Bryant <[email-masked] 
> <mailto:[email-masked]>> wrote:
>> on putting in place the telecommunications technology we need to have 
>> in place in the 10 to 20 year time-frame. By then we will need 
>> bandwidths in the 1TB class to the users, power consumptions per bit 
>> that is minute compared to the current level, and latencies where the 
>> laws of physics are the only significant factor. It is unclear whether 
>> the current Internet architecture will satisfy those needs without 
>> change, and in my view that is the area that the IAB should attend to, 
>> rather than to work described in this draft.
> 
> This is certainly an exciting picture of the future that you are 
> painting at layer 2 and layer 3, but I notice that you didn’t respond to 
> Ole’s point, which I think is a great example of the problem.   Like it 
> or not, the participants in the IETF have expertise that is relevant to 
> things that you call “political,” and to suggest that we should not 
> factor that into our decisions is unrealistic.   We are going to factor 
> these considerations into our decisions whether we admit it or not.
> 
> But where IETF discourse goes badly wrong is when we have discussions 
> where we haven’t agreed first on what we are talking about.   Then you 
> see these hundred- or thousand-message streams of people talking past 
> each other and never reaching completion, because nobody feels heard, 
> because we didn’t take the time to figure out what questions we were 
> trying to answer.
> 
> If you think about it, what you have proposed is actually just as 
> political as anything else.   You believe that users should have 
> maximally fast, minimally latent connectivity.   I think that’s a good 
> goal, but it’s only a meaningful goal if the users want it.   Otherwise 
> it’s just some shiny tech you’re working on.   And let’s be clear about 
> this: it’s not at all clear that users want that.   What I mean is that 
> users aren’t making purchasing decisions on the basis of whether they 
> maximize throughput and minimize latency.   If they were, we wouldn’t 
> still be seeing bufferbloat everywhere.
> 
> Understanding what users need and trying to address their needs is in a 
> sense the core function of the IETF.   It’s not a side issue that we can 
> ignore in the pursuit of technical excellence.
> 

Just to be clear, those are not numbers I plucked out of the air.

1TB/s is needed to do holographic teleconferencing. I would argue that 
being able to have a fully immersive experience including shaking the 
hand of your business contact, or hugging a parent or child without 
burning carbon must be a good thing that many people will want to do. 
The haptic component of the experience requires surprisingly low latency.

Then there are many other low latency demands such as people packets, 
i.e. driverless cars.

Obviously you can do no better than the physics, but the latency and b/w 
applies all the way up the stack.

Of course we have to do all of the above without switching the global 
energy demand from transport and heating/cooling to networking and 
computing.

Then it is clear that the sensor needs are only going in one direction
when it comes to quantity, energy, material, and silicon area in a post 
Moore's Law world.

The above is the clear direction we need to be pushing, and yet it is
by no means the IETF priority.

If you want more information look at the work that 3GPP and ITU are
doing on 5G and on Future networks respectively.

There seems to be a good case that many things need to change in the 
Internet, and it is really up to us whether we want to be part of the 
solution or an extinct part of the problem.

Meanwhile, I really think we should focus on technology and let 
governments worry about the highly complex politics of the Internet.

- Stewart

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 11:15:54 -0400

> The stronger the IETF consensus behind this document, the easier it will be to use it to guide working group discussion and decisions.

In this case I might frame the discussion differently.   Users clearly 
have an interest in having associations between (some) application 
instances maintained indefinitely.   It's not the network's job (nor 
IETF's) to decide when this is in users' interests.

The question can therefore be reframed as an engineering tradeoff 
/between layers/ - e.g. at what point should higher-layer protocols have 
to be responsible for maintaining such associations when needed?

This "point" could be expressed in terms of minimum address-to-interface 
binding lifetime, how much advance notice should be provided to 
endpoints before renumbering occurs, and what's the minimum overlap time 
between old and new addresses. (*)   Too short a lifetime, or too little 
notice, or too little overlap, puts a huge burden on the higher layers, 
makes it very difficult for them to recover, and results in traffic 
storms. Too long a lifetime and/or too much notice puts pressure on the 
network routing system, and the routers, to accommodate the instant 
renumberings that are sometimes unavoidable.

I suspect that this tussle is entirely unavoidable.  IETF's problem is 
that not that it hasn't made the tussle magically disappear, but rather 
that nobody's in charge of the architecture.

The reason we haven't picked a general-purpose higher-layer mechanism 
for adapting to renumbering by now, is that we've been too busy 
pretending that it's not necessary.    So none of the pieces necessary 
to make it work are in place.   We don't even have a mechanism to allow 
an endpoint to discover a peer's application endpoint's current 
address/port (**).

Keith

(*) I'll put stakes in the ground just for discussion purposes: minimum 
address-to-interface binding lifetime should be at least seven days, and 
minimum advance notice should be at least 24 hours, minimum overlap time 
should be at least 24 hours.   But these are not questions that a group 
discussing SLAAC should be having to try to answer.

(**) someone will surely claim that DNS can do this, but not without (at 
a minimum) additional profiling for exactly how it's to be used.  DNS 
doesn't make any distinction between address used for initial connection 
attempt and address/port used for reconnects, and there's no good way 
for individual endpoints or networks to update the RRs that application 
endpoints would need to use to make such a discovery.  Also, DNS assumes 
that query results can be cached, and that a fixed TTL makes sense.   
There may also be security issues with publicly disclosing application 
endpoint information - seems like such advertisement would greatly aid 
DoS attacks.

---

From: Ole Troan <[email-masked]>
Date: Tue, 19 Mar 2019 16:35:00 +0100

> This "point" could be expressed in terms of minimum address-to-interface binding lifetime, how much advance notice should be provided to endpoints before renumbering occurs, and what's the minimum overlap time between old and new addresses. (*)   Too short a lifetime, or too little notice, or too little overlap, puts a huge burden on the higher layers, makes it very difficult for them to recover, and results in traffic storms.   Too long a lifetime and/or too much notice puts pressure on the network routing system, and the routers, to accommodate the instant renumberings that are sometimes unavoidable.

In this particular case, it turns out the network was “lying” about the promised lifetime, and instantly renumbered the network with a overlap time of 0.
The discussion then fluctuates between: is this a misconfiguration? how could hosts possible deal with this situation? is there anything in standards that could improve? if we made “client-only” hosts deal well with this, are we doing the end-users a disservice? (as opposed to making sure the hosts break so badly that it results in a support call. ;-))

Cheers,
Ole

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 19 Mar 2019 15:48:26 +0000

From: ietf <[email-masked]> on behalf of Ted Lemon <[email-masked]>
> This is certainly an exciting picture of the future that you are painting at layer 2 and layer 3, but I notice that you didn’t respond to Ole’s point, which I think is a great example of the proble…

[JL] I agree, Ted. New IETF standards are not introduced in a vacuum.  Rather, IETF standards have real-world impacts on technologies, markets, and societies (and of course the people in those societies).

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 19 Mar 2019 12:09:39 -0400

I had asked this question on an earlier version of this draft and want to
poke at it again.  Is the focus on end users the best and most effective
way to achieve the same objective?  Could the focus of this work be shifted
to privacy and providing anonymity in protocols instead?

If you take the TLS 1.3 case, if the goal is to maintain PFS, a statement
on privacy and human rights plus anonymity could achieve that objective.

Thinking about the points Eliot and Stewart made, the entire Internet
ecosystem could be accounted for with this theme as well as how the
Internet is evolving.  Sensor data and edge computing is a major focus of
work for many now and the IETF will want to do work in those spaces.
Considering how we frame this could be very important to future work items
as the Internet evolves.  There's also a push for user ownership of data
that may upend the consolidation trends, while this is in support of the
end user, it could be framed as privacy focused and helping toward human
right objectives.

I think the examples should be varied as not to favor any communities as to
Eliot's points as well.

Best regards,
Kathleen

On Tue, Mar 19, 2019 at 11:48 AM Livingood, Jason <
[email-masked]> wrote:

> Ole’s point, which I think is a great example of the problem.   Like it or
> not, the participants in the IETF have expertise that is relevant to things
> that you call “political,” and to suggest that we should not factor that
> into our decisions is unrealistic.   We are going to factor these
> considerations into our decisions whether we admit it or not.
>
> [JL] I agree, Ted. New IETF standards are not introduced in a vacuum.
> Rather, IETF standards have real-world impacts on technologies, markets,
> and societies (and of course the people in those societies).
>
>

-- 

Best regards,
Kathleen

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 12:58:31 -0400

On 3/19/19 12:09 PM, Kathleen Moriarty wrote:

> I had asked this question on an earlier version of this draft and want 
> to poke at it again.  Is the focus on end users the best and most 
> effective way to achieve the same objective?  Could the focus of this 
> work be shifted to privacy and providing anonymity in protocols instead?

I don't think I understand.   Why would we emphasize privacy and 
anonymity if not for the benefit of end users?   Also, this kind of 
direction wouldn't tell us how to deal with tussles between privacy or 
anonymity, and other needs of end users.

I claim that, fundamentally, the Internet exists to benefit end users - 
much more than, say, to benefit network operators, merchants, equipment 
manufacturers, Big Brother, etc.   Failing to recognize that only makes 
IETF less relevant.

Keith

---

From: "Paul Hoffman" <[email-masked]>
Date: Tue, 19 Mar 2019 10:24:58 -0700

If this document is to be published other than in the ISE stream, it 
should be published with IETF consensus. The IETF as a whole could 
easily have greater expertise in how to prioritize decisions for end 
users than the IAB does. As has been seen on this thread already, we 
certainly have strong and diverging views on that topic.

Having said that, even though we have expertise in listing the 
conflicting things the set of end users might need to weigh for 
particular choices, I doubt we have expertise in understanding how the 
individuals in the this very large and diverse set would weigh them. 
Even if we understand our own individual methods for weighing multiple 
divergent views about things that affect us, we are unlikely to 
understand how others do so.

Section 4 of the draft talks about how we should prioritize, but it 
doesn't say why we think we can do so. If we prioritize for the set of 
end users without understanding how the individuals in that set 
prioritize for themselves, this document is not valuable. Worse, if we 
ignore that individuals in that set will prioritize quite differently, 
then this document can be actively harmful because we will solidify our 
decision process around ideas that dump very divergent end users into 
one bucket.

--Paul Hoffman

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 19 Mar 2019 10:55:00 -0700

Without responding to Eliot's point in detail, one comparison point would
be the HTML Priority of Constituencies:

https://dev.w3.org/html5/html-design-principles/#priority-of-constituencies

"In case of conflict, consider users over authors over implementors over
specifiers over theoretical purity. In other words costs or difficulties to
the user should be given more weight than costs to authors; which in turn
should be given more weight than costs to implementors; which should be
given more weight than costs to authors of the spec itself, which should be
given more weight than those proposing changes for theoretical reasons
alone. Of course, it is preferred to make things better for multiple
constituencies at once."

I've certainly found this to be a useful framing of design principles that
helps one reason about alternative designs. Perhaps that's one direction to
take this document.

-Ekr

On Tue, Mar 19, 2019 at 3:22 AM Eliot Lear <[email-masked]> wrote:

> TL;DR I do not believe this document asks the right question, and further
> believe that there may be a better approach to take.
>
> My personal opinion is that it would be useful for the IETF to state its
> preference to benefit the users, and to begin with, consider the impacts
> its technology may have on the various relationships among users, and
> various other players. Of course, in many cases we are already doing this
> (and debating it!), but there’s obviously always room for improvement.
>
> I do think though that if the document goes forward, it would be
> beneficial to rethink the examples. “Network operators and equipment
> vendors” as the threat picture… doesn’t sound to me like 2019 at all, with
> all the technology and deployment changes we’ve had in the last few years.
> How about “large content and application providers”? This seems like a
> major issue in today’s Internet.
>
>
>
> You raise an important point.  More broadly, I would find it strange that
> someone participating here believes that he or she is *not* acting in the
> interests of the end users.
>
>    - Network operators believe they are acting in the interests of end
>    - Browser developers believe they are operating in the interests of
>    - Social network providers believe they are operating in the interests
>    of end users by providing them fora in which to congregate.
>    - Content providers believe they are operating in the interests of end
>    users by providing them meaningful and sometimes entertaining content.
>    - Cloud providers believe they are operating in the interests of end
>    - Firewall vendors believe they are operating in the interests of end
>    users even by eavesdropping on corporate communications to prevent
>    embezzlement.
>    - Some civil society organizations believe they are operating in the
>    - Governments believe they are operating in the interests of end users
>    by identifying risks to their citizens.
>
> The document, however, is framed as though only a handful of these groups
> are operating in the interest of end users.  And *that* is problematic,
> because it will lead to incessant argument over just who represents 7
> billion people (did I mention the UN above?) with unpredictable and
> potentially perverse consequences.
>
> This leads to a question: what behavior do we actively want to change?
> What outcome went wrong that we would want to correct?  Like you, Jari, I
> am hard pressed to find an applicable example, which is why I suspect the
> Examples section is so paltry.  Put another way, what would be the
> practical ramifications of adopting this work as a BCP?
>
> Having a food fight over who best represents the user isn’t productive.
> We all think we do.  And we all want to leave the world better than we
> found it.  I would, therefore, propose that we frame our purpose
> accordingly, borrowing from the work of others, such as Hippocrates and
> Maimonides.  Practitioners of all sorts have ethics policies, including
>  ISOC and the IEEE.  Maybe what we really want is a promise from
> participants that they work for the betterment of society, however they
> understand that to mean, and that the higher they rise in leadership at the
> IETF, the more we will expect them to demonstrate having met that goal.
>
> If we are to take this up at all, and I am not opposed to doing so, I
> would suggest that we first be able to agree on the goal, that we have some
> understanding of what mechanism we want to use to achieve that goal, and
> that we understand the ramifications of our choices.
>
> The worst possible world is one in which we short circuit difficult
> decisions because we have enacted a policy that favors one view of users
> over another without regard to the consequences.  Applying a normative
> imprimatur to this work that an IETF BCP carries would therefore be
> premature.
>
> Eliot
>
>

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 19 Mar 2019 18:15:03 +0000

> manufacturers, Big Brother, etc.   Failing to recognize that only makes 

It needs to benefit the whole eco-system. Using the end user as a proxy 
for all of the other partners will lead to sub-optimal solutions.

As for Big Brother (presumably not the TV show), I hold a view that is 
controversial in the IETF, that as a tax payer I pay various agencies to 
protect me and my family, and if they need to see Internet data to do 
their job, then they should have access to it.

- Stewart

---

From: Eliot Lear <[email-masked]>
Date: Tue, 19 Mar 2019 19:28:15 +0100

Hi Eric,

> On 19 Mar 2019, at 18:55, Eric Rescorla <[email-masked]> wrote:
> 
> Without responding to Eliot's point in detail, one comparison point would be the HTML Priority of Constituencies:
> 
>     https://dev.w3.org/html5/html-design-principles/#priority-of-constituencies <https://dev.w3.org/html5/html-design-principles/#priority-of-constituencies>
> 
> "In case of conflict, consider users over authors over implementors over specifiers over theoretical purity. In other words costs or difficulties to the user should be given more weight than costs to authors; which in turn should be given more weight than costs to implementors; which should be given more weight than costs to authors of the spec itself, which should be given more weight than those proposing changes for theoretical reasons alone. Of course, it is preferred to make things better for multiple constituencies at once.”

I agree with all of the above, but have a far more succinct way of putting it (for a change): our works should be produced BY geniuses not FOR geniuses.

> 
> I've certainly found this to be a useful framing of design principles that helps one reason about alternative designs. Perhaps that's one direction to take this document.

And I would have no objection to taking that path.

Eliot

---

From: Vittorio Bertola <[email-masked]>
Date: Tue, 19 Mar 2019 19:57:21 +0100 (CET)

> Il 19 marzo 2019 alle 19.15 Stewart Bryant <[email-masked]> ha scritto:
> 

As someone who almost 20 years ago campaigned for the creation of the "end user constituency" at ICANN and then had to implement it for real, I think that the draft is potentially laudable but overly simplistic. Everyone agrees that you should act "for the users", but when you try to do it in practice, all sorts of other interests stand up and claim to speak for the users, or to know what's best for the users; you need someone to represent them, since you cannot ask several billion Internet users what they think of each new protocol and they would not be able to have informed opinions anyway, but many representatives end up being self-interested or captured by other interests that are more directly involved. 

So the difficult part is not in stating the principle, but in how to make it work fairly in the real world, and that's where the focus of any effort should be.

Also, it is very rare that anything goes in the interest of "the users"; more often, there will be some users that gain and others that lose. It is unclear in the document how the IETF would deal with that kind of tradeoff, which is generally managed via representative democracy and voting. There is a generic reference to "interacting with the greater Internet community", and yet the IETF is the less diverse and less multi-stakeholder of the I* organizations; not well equipped to make calls on what is the global public interest.

Strikingly, throughout the document there is basically just one example for "not end users": network operators (plus their hardware vendors). That's the example on top of page 3, but it is also implicit in the fourth paragraph of section 2 (if anyone at an endpoint is an end user, the only people that are not end users are those who sit in the network), and again is the only example of a "not end user" in section 4. 

One would expect the big Internet platforms also not to be "end users", but since according to the definition in section 2 anyone at an endpoint is an "end user", explicitly including those "producing content, selling goods or providing a service", even the most pervasive and dominant Internet platforms are "end users" and the IETF will design standards prioritizing their interests. I cannot see how this can be purported to be "for the people".

Regards,
-- 

Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked]
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 15:30:15 -0400

On 3/19/19 2:15 PM, Stewart Bryant wrote:

> It needs to benefit the whole eco-system. Using the end user as a 
> proxy for all of the other partners will lead to sub-optimal solutions.

Disagree.   When the eco-system ceases to benefit end users 
significantly more than it harms them, the eco-system needs to either 
change - or cease to exist.

> controversial in the IETF, that as a tax payer I pay various agencies 
> to protect me and my family, and if they need to see Internet data to 
> do their job, then they should have access to it. 

By "Big Brother" I was not intending to refer to any specific 
government.   But if you're talking about the US, the framers of the US 
Constitution disagreed with you.

Keith

---

From: Michael Richardson <[email-masked]>
Date: Tue, 19 Mar 2019 16:52:28 -0400

Kathleen Moriarty <[email-masked]> wrote:
    > poke at it again. Is the focus on end users the best and most effective way
    > to achieve the same objective? Could the focus of this work be shifted to
    > privacy and providing anonymity in protocols instead?

You have actually jumped to a conclusion that the end users want privacy and
anonymity.  I'm not saying you are wrong, but that you have just made
a value judgement indicating which constituency that represents.

As Eliot's list indicates, that's not always the desire of all users!

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 19 Mar 2019 17:10:00 -0400

Sent from my mobile device

> On Mar 19, 2019, at 4:52 PM, Michael Richardson <[email-masked]> wrote:
> 
> 

Fair point!  I was trying to reframe this into something that might stand the test of time better.  My thinking was that we have thought about security, privacy, and somewhat on human rights, but have not broken out the latter clearly enough and was going at that angle.  Perhaps there’s a better way to do this?

Thank you,
Kathleen

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 20 Mar 2019 01:10:58 +0100

> It needs to benefit the whole eco-system. Using the end user as a proxy for all of the other partners will lead to sub-optimal solutions.

Well, it’s the other way around.  The ecosystem is there to benefit the humans.  Technical decisions that benefit some parts of the ecosystem while damaging the users are not something I want to be part of.  (Neither of technical decisions that damage the ecosystem in such a way that it no longer works well for the users, of course.)

> As for Big Brother (presumably not the TV show), I hold a view that is controversial in the IETF, that as a tax payer I pay various agencies to protect me and my family, and if they need to see Internet data to do their job, then they should have access to it.

You will find there is less opposition in the IETF than you think to what you just said.
The question we are running into is how do we find out what they need.
Asking them is surprisingly ineffective in finding out.
They rarely understand the consequences of what they are demanding, and it is mostly informed by what has been and not what will be.

As a general rule, we have to skate to where the puck will be, not where it was.

Neither end users nor those government agencies really understand where that is, so asking 
them is less useful than one would wish.  Ask Steve Jobs about asking users what they want…

We need to invest in understanding the consequences of what we are building, and make choices that are good for humanity.  In the very real world that we are living in.  And get paid for that, and help get others paid for that, so our ecosystem stays sustainable.

Grüße, Carsten

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 20 Mar 2019 00:20:28 +0000

On 20/03/2019 00:10, Carsten Bormann wrote:
>> As for Big Brother (presumably not the TV show), I hold a view that
>> is controversial in the IETF, that as a tax payer I pay various
>> agencies to protect me and my family, and if they need to see
>> Internet data to do their job, then they should have access to it.

> You will find there is less opposition in the IETF than you think to
Not sure about that. There are O(200) entities (at the country
level) to which one could have the chance to pay tax. In most
cases, people I've asked are not at all happy with the idea
that any significant percentage of all of those would have such
access. I'm always puzzled that that aspect gets forgotten so
often.

That however seems like a side issue.

S.

---

From: Joe Touch <[email-masked]>
Date: Tue, 19 Mar 2019 19:33:54 -0700

> On Mar 19, 2019, at 7:31 AM, Stewart Bryant <[email-masked]> wrote:
> 
> 1TB/s is needed to do holographic teleconferencing. I would argue that being able to have a fully immersive experience including shaking the hand of your business contact, or hugging a parent or child without burning carbon must be a good thing that many people will want to do. The haptic component of the experience requires surprisingly low latency.

I’ll take bets against those numbers - with a caveat. You can’t deliberately break the system in the wrong place just to kick the numbers up.

The following is a chart from the early 1990s that shows the BW needed for a variety of ways of interacting. The latency budget is 100ms, i.e., intended to provide “realtime” haptic latency, some of which is consumed by propagation delay (depending on the distance between endpoints). 
https://www.strayalpha.com/interactive-web/ <https://www.strayalpha.com/interactive-web/>

When the chart was developed, we were shifting from HTML to icons and ISDN-ish speeds were enough. Now, nearly 30 years later, we’re pushing 300dpi displays and everyone is happy enough with 100M-ish speeds, as predicted, but only if you actually need to send the whole screen within the latency+reaction time.

If you push to 3D, you’re still just a factor of 2 above those numbers. 

But we basically stopped paying for 3D movies (http://collider.com/3d-movies-are-dead-again/ <http://collider.com/3d-movies-are-dead-again/>), so I have doubts about anyone caring about remote holography.

Instead, I’ll bet that in about 15-20 years, when our screens are 1000dpi, we’ll actually start to want 40G speeds.

Tb, not so much.

Joe

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 20 Mar 2019 03:13:34 +0000 (UTC)

A comment combining haptics and latency, based on a real-world example.
Bear with me here while I go through it.

Microsoft introduced a gliding text cursor animation that leverages graphics
cards, and Looks Cool. Problem is, it completely messes up touch typists
by adding lag to their internal feedback loops, as the drawing of typed
characters now lags behind what is typed. Disabling this animation can be done
on a per-Office app basis or systemwide, but keeping it disabled (along
with other animations as side-effects), and that it's on by default or
even exists in the first place, are issues if you can type fast.

Usual user interface features-that-shouldn't-be morass, and it's
quite amazing how word processing continues to get worse thanks to teams
of dedicated developers, none of whom can apparently type.

https://superuser.com/questions/989951/is-it-possible-to-disable-smooth-movement-of-the-cursor-in-office-2013-windows-1
https://support.office.com/en-ie/article/turn-off-office-animations-9ee5c4d2-d144-4fd2-b670-22cef9fa025a
etc.

you get the idea.

Now, in taking this up with Microsoft, I got to go through multiple
levels of support who wanted to 'see the problem' and I had to explain,
again and again, that no, screen sharing wasn't good enough to
see the problem, because the network and refresh rate was simply
incapable of being fast enough to even show the animation, never
mind how I reacted to it as a touchtypist, and did they know any
touchtypists they could try it out on on a local copy of the apps
and operating system?

"you actually need to send the whole screen within the latency+reaction time."

and that clearly can't be done in this case. Current technology
simply isn't good enough.

"latencies where the laws of physics are the only significant factor"

and this is a deliberate design counterexample, sitting on your
desktop right now.

L.

(I think the nottingham draft should be informational. It sounds
more like a W3C aspirational text. And the grammar in the first para
of section 2 is terrible.)

Lloyd Wood [email-masked] http://about.me/lloydwood

________________________________
From: Joe Touch <[email-masked]>
To: Stewart Bryant <[email-masked]> 
Cc: IETF <[email-masked]>
Sent: Wednesday, 20 March 2019, 13:34
Subject: Re: Finding the appropriate work stream for draft-nottingham-for-the-users

The following is a chart from the early 1990s that shows the BW needed for a variety of ways of interacting. The latency budget is 100ms, i.e., intended to provide “realtime” haptic latency, some of which is consumed by propagation delay (depending on the distance between endpoints). 
https://www.strayalpha.com/interactive-web/

But we basically stopped paying for 3D movies (http://collider.com/3d-movies-are-dead-again/), so I have doubts about anyone caring about remote holography.

Tb, not so much.

Joe

---

From: Lloyd Wood <[email-masked]>
Date: Wed, 20 Mar 2019 03:20:21 +0000 (UTC)

"we are amateurs when it comes to understanding the

political consequences of our decisions."

Well, so is everyone else, including the 'professionals'.
(Um, Brexit? How's that professional activity going?)

the question is whether the IETF should abdicate its
agency in this regard.

Being more like the ITU so that the IETF gets to continue
being an alternative to the ITU doesn't strike me as
much of a life.

Publish as (plausibly deniable) informational, and be damned.

L.

________________________________
From: Stewart Bryant <[email-masked]>
To: Ted Hardie <[email-masked]>; IETF <[email-masked]> 
Sent: Tuesday, 19 March 2019, 23:06
Subject: Re: Finding the appropriate work stream for draft-nottingham-for-the-users

- Stewart

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 20 Mar 2019 12:32:53 +0000

Hiya,

(Quoting ekr, but not really replying directly to him...)

> helps one reason about alternative designs. Perhaps that's one direction to

Some of the mails on this seem miss to the point that
the draft, as written, is about handling conflicting
needs, along the lines ekr describes above.

So it may be worth re-iterating that the abstract of the
draft [1] says:

  "This document explains why, when a conflict cannot be avoided, the
   IETF considers end users as its highest priority concern."

The "when a conflict cannot be avoided" bit seems to be a
bit lost in some mails.

Personally, I fully agree that we(*) can't only consider
the humans/users, (stuff has to actually work in the real
world too), so a draft that said something so absolute
along those lines would be likely to founder as some folks
have (I think) been saying. But the text in Mark's draft
isn't saying that, at least as I interpret it.

Cheers,
S.

(*) The "we" there I think works regardless of what path
to publication this draft might or might not take.

[1] https://tools.ietf.org/html/draft-nottingham-for-the-users-07