Subject: Adi Shamir denied entry to the US

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 6 Mar 2019 19:59:42 -0500

Looks like it might be a while before we can hold meetings in the US again.
If Adi can't get a visa, who can?

https://en.globes.co.il/en/article-israeli-cryptographer-prof-adi-shamir-denied-us-visa-1001277019?fbclid=IwAR28nkopYHUB_Q3FQ2MSJVaXAMfYf0Bq6DE6J2161OMLYZ3QvEJDvftCx94

---

From: Michael Richardson <[email-masked]>
Date: Wed, 06 Mar 2019 20:29:43 -0500

> If Adi can't get a visa, who can?

We have two meetings coming up:
   IETF 111, Summer 2021.

We also have a credit for the same hotel from having moved IETF101,
but we have to commit by summer 2020.   I really would have liked
IETF 111 to be moved (or never booked).

but, in the end, will the RSA Conference move?

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 6 Mar 2019 20:59:34 -0500

> but, in the end, will the RSA Conference move?
does it matter a whit to any of the people which are making the decisions
that end with this angst that ietf/rsa/etc come/go to US venues?
no, it does not.

easiest action for all involved: "have conferences elsewhere"

---

From: Richard Barnes <[email-masked]>
Date: Wed, 6 Mar 2019 23:30:05 -0500

If we're going to be making decisions on this basis, I hope we're keeping
track of visa denials for other candidate countries (see, e.g., [1]).

--Richard

[1]
https://www.sciencemag.org/news/2018/12/canada-denied-visas-dozens-africans-big-artificial-intelligence-conference

---

From: Eliot Lear <[email-masked]>
Date: Thu, 7 Mar 2019 09:03:39 +0100

[&TL;DR- Keep your powder dry.]

Dear colleagues,

As a reminder, we spent a fair amount of time developing criteria to provide to the IAOC and now the LLC for venue selection, and we came to consensus on a number of criteria.  These are broken out in draft-ietf-mtgvenue-iaoc-venue-selection-process-16.txt <https://datatracker.ietf.org/doc/draft-ietf-mtgvenue-iaoc-venue-selection-process/>.  We as a community address the sorts of problems that Adi Shamir ran into in two places in that document.  First, in the introductory material, we state as a part of a core value:

      Every country has limits on who it will permit within its borders.
      However the IETF seeks to:

      1.  Minimize situations in which onerous entry regulations
          inhibit, discourage, or prevent participants from attending
          meetings, or failing that to distribute meeting locations such
          that onerous entry regulations are not always experienced by
          the same attendees; […]

Later, we lay out mandatory criteria, important criteria, and other considerations.  The policy that implements the goal is found in important criteria:

   o  Travel barriers to entry, including visa requirements, are likely
      to be such that an overwhelming majority of participants who wish
      to do so can attend.  The term "travel barriers" is to be read
      broadly by the IASA in the context of whether a successful meeting
      can be had.

[emphasis added]

It is possible for the IASA to book a locale that does not meet important criterion.  If they do so, they must explain this to the community at the time a contract is made.  Members of the community have expressed concern about the U.S. in particular about the United States.  As someone who sits on the venue review committee as a community representative, I have reflected those concerns, and I will continue to reflect the community view until my term expires later this year.

However…

This criterion can and has come into conflict with other criteria, such as ease of travel to the locale, cost, and even safety and health issues.  Michael is correct that we could lose a credit for the moved meeting, and Richard is correct that Canada has refused entry to people as well.  Indeed a dear colleague on the IAB from China was refused entry at one point. In addition, it is often hard for some immigrants who leave a country to reenter.  The IASA has to take all of this into account.

As to community fears and concerns, if we don’t go to the U.S. at all, then we will have no data on just how we are affected.  While there are other conferences from whose experience we can and do benefit, the demographic of each community is slightly different.  It’s important to know how many people were denied access to a country.  I encourage the community to reflect on the numbers as and when they become available from the 2021 San Francisco meeting, not to mention all the other meetings in other countries in between.  And yes, a lot can and will change between now and 2021.

Eliot

> On 7 Mar 2019, at 05:30, Richard Barnes <[email-masked]> wrote:
> 
> If we're going to be making decisions on this basis, I hope we're keeping track of visa denials for other candidate countries (see, e.g., [1]).
> 
> --Richard
> 
> [1] https://www.sciencemag.org/news/2018/12/canada-denied-visas-dozens-africans-big-artificial-intelligence-conference <https://www.sciencemag.org/news/2018/12/canada-denied-visas-dozens-africans-big-artificial-intelligence-conference>
> 
> On Wed, Mar 6, 2019 at 9:00 PM Christopher Morrow <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> On Wed, Mar 6, 2019 at 8:30 PM Michael Richardson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> does it matter a whit to any of the people which are making the decisions that end with this angst that ietf/rsa/etc come/go to US venues?
> no, it does not.
>

---

From: Paul Wouters <[email-masked]>
Date: Thu, 7 Mar 2019 10:31:55 -0500 (EST)

On Thu, 7 Mar 2019, Eliot Lear wrote:

> However…
> 
> This criterion can and has come into conflict with other criteria, such as ease of travel to the locale, cost, and even safety and health issues.  Michael is
> correct that we could lose a credit for the moved meeting, and Richard is correct that Canada has refused entry to people as well.  Indeed a dear colleague on the
> IAB from China was refused entry at one point. In addition, it is often hard for some immigrants who leave a country to reenter.  The IASA has to take all of this
> into account.
> 
> As to community fears and concerns, if we don’t go to the U.S. at all, then we will have no data on just how we are affected.  While there are other conferences
> from whose experience we can and do benefit, the demographic of each community is slightly different.  It’s important to know how many people were denied access
> to a country.  I encourage the community to reflect on the numbers as and when they become available from the 2021 San Francisco meeting, not to mention all the
> other meetings in other countries in between.  And yes, a lot can and will change between now and 2021.

Indeed. Look at how suddenly there is this Canada - China issue, which
might strongly affect our meetings scheduled in Canada.

Paul

---

From: Stephan Wenger <[email-masked]>
Date: Thu, 7 Mar 2019 15:39:14 +0000

.... and in China.  (Perhaps even more so, considering what's happening to certain Canadian citizens there.)
Stephan

On 3/7/19, 07:32, "ietf on behalf of Paul Wouters" <[email-masked] on behalf of [email-masked]> wrote:

    
    
    Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 7 Mar 2019 15:42:48 +0000

Berlin. 

On 07/03/2019, 17.40, "ietf on behalf of Stephan Wenger" <[email-masked] on behalf of [email-masked]> wrote:

    

        
        Paul

---

From: John C Klensin <[email-masked]>
Date: Thu, 07 Mar 2019 12:01:39 -0500

You assume, of course, that, sometime after 29 March, UK
citizens are not required to go through a visa application
process involving appearing in person at a consulate in order to
visit Germany or the EU more generally.  Of course, I think the
odds of that are extremely small, but I would have given almost
as poor odds to Shamir being denied permission to come to the US
(or several other visa denials or timeouts I know about).

As several people have pointed out, things can change and change
quickly.   Even if we could predict such changes, for any
country or situation requiring that visas be issued before the
traveler gets on a plane, I know of no way to prevent or predict
when some arbitrary junior consular official will have a bad day
and decide to prove that he (or she or it) is powerful enough to
come up with an excuse (if that is even needed) to deny a visa
or lose the application for someone, possibly someone important.

That is the one thing I would have added to Eliot's excellent
and very helpful note:  Until we figure out a way to keep people
who are stupid and/or petty out of consular jobs (or government
jobs generally), some visa processing timeouts (and maybe even a
few rejections) are going to happen and happen nearly at random.
A decision to block a country as a meeting site had best be done
on the basis of patterns rather than isolated incidents, no
matter how much publicity those incidents draw or how irrational
they appear.  FWIW, the Canada-Chine behavior looks like a
pattern to me.  Trump's travel ban on a list of countries is
definitely not just a pattern but a matter of stated policy as
are, e.g., the rules several countries have adopted toward
Israeli passports and visa applications.  This thing with
Shamir?  Silly bordering on stupid, definitely.  But no evidence
of a pattern on which it would be sensible to start moving
meetings around, at least yet.  

best,
   john

> Berlin. 
伀渀 　㜀⼀　㌀⼀㈀　㄀㤀Ⰰ ㄀㜀⸀㐀　Ⰰ ∀椀攀琀昀 漀渀 戀攀栀愀氀昀 漀昀 匀琀攀瀀栀愀渀 圀攀渀最攀爀∀ഀ਀㸀 㰀椀攀琀昀ⴀ戀漀甀渀挀攀猀䀀椀攀琀昀⸀漀爀最 漀渀 戀攀栀愀氀昀 漀昀 猀琀攀眀攀䀀猀琀攀眀攀⸀漀爀最㸀 眀爀漀琀攀㨀ഀ਀㸀 ഀ਀㸀     ⸀⸀⸀⸀ 愀渀搀 椀渀 䌀栀椀渀愀⸀  ⠀倀攀爀栀愀瀀猀 攀瘀攀渀 �
�漀爀攀 猀漀Ⰰ 挀漀渀猀椀搀攀爀椀渀最ഀ਀㸀 眀栀愀琀✀猀 栀愀瀀瀀攀渀椀渀最 琀漀 挀攀爀琀愀椀渀 䌀愀渀愀搀椀愀渀 挀椀琀椀稀攀渀猀 琀栀攀爀攀⸀⤀ഀ਀㸀 匀琀攀瀀栀愀渀ഀ਀㸀     ഀ਀㸀     ഀ਀㸀     伀渀 ㌀⼀㜀⼀㄀㤀Ⰰ 　㜀㨀㌀㈀Ⰰ ∀椀攀琀昀 漀渀 戀攀栀愀氀昀 漀昀 倀愀甀氀 圀漀甀琀攀爀猀∀ഀ਀㸀 㰀�
��攀琀昀ⴀ戀漀甀渀挀攀猀䀀椀攀琀昀⸀漀爀最 漀渀 戀攀栀愀氀昀 漀昀 瀀愀甀氀䀀渀漀栀愀琀猀⸀挀愀㸀 眀爀漀琀攀㨀     ഀ਀㸀         伀渀 吀栀甀Ⰰ 㜀 䴀愀爀 ㈀　㄀㤀Ⰰ 䔀氀椀漀琀 䰀攀愀爀 眀爀漀琀攀㨀ഀ਀㸀         ഀ਀㸀         㸀 䠀漀眀攀瘀攀爀☠ഀ਀㸀         㸀 ഀ਀㸀     
    㸀 吀栀椀猀 挀爀椀琀攀爀椀漀渀 挀愀渀 愀渀搀 栀愀猀 挀漀洀攀 椀渀琀漀 挀漀渀昀氀椀挀琀 眀椀琀栀ഀ਀㸀 漀琀栀攀爀 挀爀椀琀攀爀椀愀Ⰰ 猀甀挀栀 愀猀 攀愀猀攀 漀昀 琀爀愀瘀攀氀 琀漀 琀栀攀 氀漀挀愀氀攀Ⰰ 挀漀猀琀Ⰰഀ਀㸀 愀渀搀 攀瘀攀渀 猀愀昀攀琀礀 愀渀搀 栀攀愀氀琀栀 椀猀猀甀攀猀⸀  䴀椀挀栀愀攀氀�
�椀猀         㸀ഀ਀㸀 挀漀爀爀攀挀琀 琀栀愀琀 眀攀 挀漀甀氀搀 氀漀猀攀 愀 挀爀攀搀椀琀 昀漀爀 琀栀攀 洀漀瘀攀搀 洀攀攀琀椀渀最Ⰰ 愀渀搀ഀ਀㸀 刀椀挀栀愀爀搀 椀猀 挀漀爀爀攀挀琀 琀栀愀琀 䌀愀渀愀搀愀 栀愀猀 爀攀昀甀猀攀搀 攀渀琀爀礀 琀漀 瀀攀漀瀀氀攀 愀猀ഀ਀㸀 眀攀氀氀⸀  䤀渀搀攀攀搀 愀 搀攀愀�
�� 挀漀氀氀攀愀最甀攀 漀渀 琀栀攀         㸀 䤀䄀䈀 昀爀漀洀 䌀栀椀渀愀ഀ਀㸀 眀愀猀 爀攀昀甀猀攀搀 攀渀琀爀礀 愀琀 漀渀攀 瀀漀椀渀琀⸀ 䤀渀 愀搀搀椀琀椀漀渀Ⰰ 椀琀 椀猀 漀昀琀攀渀 栀愀爀搀ഀ਀㸀 昀漀爀 猀漀洀攀 椀洀洀椀最爀愀渀琀猀 眀栀漀 氀攀愀瘀攀 愀 挀漀甀渀琀爀礀 琀漀 爀攀攀渀琀攀爀⸀  吀栀
攀 䤀䄀匀䄀ഀ਀㸀 栀愀猀 琀漀 琀愀欀攀 愀氀氀 漀昀 琀栀椀猀         㸀 椀渀琀漀 愀挀挀漀甀渀琀⸀ഀ਀㸀         㸀 ഀ਀㸀         㸀 䄀猀 琀漀 挀漀洀洀甀渀椀琀礀 昀攀愀爀猀 愀渀搀 挀漀渀挀攀爀渀猀Ⰰ 椀昀 眀攀 搀漀渀✀琀 最漀ഀ਀㸀 琀漀 琀栀攀 唀⸀匀⸀ 愀琀 愀氀氀Ⰰ 琀栀攀渀 眀攀�
�眀椀氀氀 栀愀瘀攀 渀漀 搀愀琀愀 漀渀 樀甀猀琀 栀漀眀 眀攀ഀ਀㸀 愀爀攀 愀昀昀攀挀琀攀搀⸀  圀栀椀氀攀 琀栀攀爀攀 愀爀攀 漀琀栀攀爀 挀漀渀昀攀爀攀渀挀攀猀         㸀ഀ਀㸀 昀爀漀洀 眀栀漀猀攀 攀砀瀀攀爀椀攀渀挀攀 眀攀 挀愀渀 愀渀搀 搀漀 戀攀渀攀昀椀琀Ⰰ 琀栀攀 搀攀洀漀最爀愀瀀栀椀挀ഀ਀㸀 漀昀 攀�
��挀栀 挀漀洀洀甀渀椀琀礀 椀猀 猀氀椀最栀琀氀礀 搀椀昀昀攀爀攀渀琀⸀  䤀琀✀猀 椀洀瀀漀爀琀愀渀琀 琀漀ഀ਀㸀 欀渀漀眀 栀漀眀 洀愀渀礀 瀀攀漀瀀氀攀 眀攀爀攀 搀攀渀椀攀搀 愀挀挀攀猀猀         㸀 琀漀 愀ഀ਀㸀 挀漀甀渀琀爀礀⸀  䤀 攀渀挀漀甀爀愀最攀 琀栀攀 挀漀洀洀甀渀椀琀礀 琀漀 爀攀昀氀攀挀琀 漀渀 
琀栀攀 渀甀洀戀攀爀猀ഀ਀㸀 愀猀 愀渀搀 眀栀攀渀 琀栀攀礀 戀攀挀漀洀攀 愀瘀愀椀氀愀戀氀攀 昀爀漀洀 琀栀攀 ㈀　㈀㄀ 匀愀渀 䘀爀愀渀挀椀猀挀漀ഀ਀㸀 洀攀攀琀椀渀最Ⰰ 渀漀琀 琀漀 洀攀渀琀椀漀渀 愀氀氀 琀栀攀         㸀 漀琀栀攀爀 洀攀攀琀椀渀最猀 椀渀ഀ਀㸀 漀琀栀攀爀 挀漀甀渀琀爀椀攀猀 椀渀 戀攀琀眀�
�攀渀⸀  䄀渀搀 礀攀猀Ⰰ 愀 氀漀琀 挀愀渀 愀渀搀 眀椀氀氀ഀ਀㸀 挀栀愀渀最攀 戀攀琀眀攀攀渀 渀漀眀 愀渀搀 ㈀　㈀㄀⸀         ഀ਀㸀         䤀渀搀攀攀搀⸀ 䰀漀漀欀 愀琀 栀漀眀 猀甀搀搀攀渀氀礀 琀栀攀爀攀 椀猀 琀栀椀猀 䌀愀渀愀搀愀 ⴀഀ਀㸀 䌀栀椀渀愀 椀猀猀甀攀Ⰰ 眀栀椀挀栀        �
��洀椀最栀琀 猀琀爀漀渀最氀礀 愀昀昀攀挀琀 漀甀爀 洀攀攀琀椀渀最猀ഀ਀㸀 猀挀栀攀搀甀氀攀搀 椀渀 䌀愀渀愀搀愀⸀         ഀ਀㸀         倀愀甀氀ഀ਀㸀         ഀ਀㸀         ഀ਀㸀     ഀ਀㸀     ഀ਀㸀 ഀ਀ഀ਀ഀ਀ഀ਀

---

From: Kent Watsen <[email-masked]>
Date: Thu, 7 Mar 2019 18:06:48 +0000

We do the best we can.  MeetEcho works well enough for exceptions.  

Maybe someday we'll do pure-virtual meetings, sidestepping some 
issues while introducing others.  Where in the balance of things are
we now?

As a thought experiment, what if there were only one physical meeting
per year, mostly just so folks can shake hands, but then *scheduled* 
(and completely deconflicted) per WG virtual meetings throughout the
year?  Would there be balance in that?

Just an idle thought.  No need to reply.

Kent

> On Mar 7, 2019, at 12:01 PM, John C Klensin <[email-masked]> wrote:
> 
> �攀琀昀ⴀ戀漀甀渀挀攀猀䀀椀攀琀昀⸀漀爀最 漀渀 戀攀栀愀氀昀 漀昀 瀀愀甀氀䀀渀漀栀愀琀猀⸀挀愀㸀 眀爀漀琀攀㨀     ഀ਀㸀         伀渀 吀栀甀Ⰰ 㜀 䴀愀爀 ㈀　㄀㤀Ⰰ 䔀氀椀漀琀 䰀攀愀爀 眀爀漀琀攀㨀ഀ਀㸀         ഀ਀㸀         㸀 䠀漀眀攀瘀攀爀☠ഀ਀㸀         㸀 ഀ਀㸀     
> � 挀漀氀氀攀愀最甀攀 漀渀 琀栀攀         㸀 䤀䄀䈀 昀爀漀洀 䌀栀椀渀愀ഀ਀㸀 眀愀猀 爀攀昀甀猀攀搀 攀渀琀爀礀 愀琀 漀渀攀 瀀漀椀渀琀⸀ 䤀渀 愀搀搀椀琀椀漀渀Ⰰ 椀琀 椀猀 漀昀琀攀渀 栀愀爀搀ഀ਀㸀 昀漀爀 猀漀洀攀 椀洀洀椀最爀愀渀琀猀 眀栀漀 氀攀愀瘀攀 愀 挀漀甀渀琀爀礀 琀漀 爀攀攀渀琀攀爀⸀  吀栀
> �挀栀 挀漀洀洀甀渀椀琀礀 椀猀 猀氀椀最栀琀氀礀 搀椀昀昀攀爀攀渀琀⸀  䤀琀✀猀 椀洀瀀漀爀琀愀渀琀 琀漀ഀ਀㸀 欀渀漀眀 栀漀眀 洀愀渀礀 瀀攀漀瀀氀攀 眀攀爀攀 搀攀渀椀攀搀 愀挀挀攀猀猀         㸀 琀漀 愀ഀ਀㸀 挀漀甀渀琀爀礀⸀  䤀 攀渀挀漀甀爀愀最攀 琀栀攀 挀漀洀洀甀渀椀琀礀 琀漀 爀攀昀氀攀挀琀 漀渀 
> �洀椀最栀琀 猀琀爀漀渀最氀礀 愀昀昀攀挀琀 漀甀爀 洀攀攀琀椀渀最猀ഀ਀㸀 猀挀栀攀搀甀氀攀搀 椀渀 䌀愀渀愀搀愀⸀         ഀ਀㸀         倀愀甀氀ഀ਀㸀         ഀ਀㸀         ഀ਀㸀     ഀ਀㸀     ഀ਀㸀 ഀ਀ഀ਀ഀ਀ഀ਀
>

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 7 Mar 2019 20:09:22 +0000

>    (or several other visa denials or timeouts I know about).
  
As UK has not been part of the Schengen area while being a EU member, my assumption is that not much is going to change..

But, of course, nobody knows. We don't even know whether UK will actually leave EU to begin with __

Regards,

Christer

---

From: "John Levine" <[email-masked]>
Date: 8 Mar 2019 15:20:57 +0900

In article <CAMm+LwiUGd4WjmSJDFG6HmwC5kw=[email-masked]> you write:
>-=-=-=-=-=-

During a government shutdown, probably nobody.

In other press reports it's utterly unclear whether he was
specifically refused or he was just in a pile of applications that
didn't get processed in time to go to the conference.  I would want to 
learn more details before leaping to conclusions.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 8 Mar 2019 07:35:18 +0100

> During a government shutdown, probably nobody.

But that’s the point: We don’t want to choose venues in countries that are unstable.

(Re the Brexit comment: Unfortunately, the UK is now also entering an unstable phase.)

Grüße, Carsten

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 8 Mar 2019 08:50:15 +0100 (CET)

On Thu, 7 Mar 2019, Eliot Lear wrote:

> As to community fears and concerns, if we don’t go to the U.S. at all, 
> then we will have no data on just how we are affected.  While there are 
> other conferences from whose experience we can and do benefit, the 
> demographic of each community is slightly different.  It’s important to 
> know how many people were denied access to a country.  I encourage the 
> community to reflect on the numbers as and when they become available 
> from the 2021 San Francisco meeting, not to mention all the other 
> meetings in other countries in between.  And yes, a lot can and will 
> change between now and 2021.

I'd like to point out that Daniel Stenberg (curl main developer) seems to 
be unable to make it to USA as well:

https://daniel.haxx.se/blog/2018/07/28/administrative-purgatory/

I don't know how often he attends IETF meetings in person though.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Fri, 8 Mar 2019 10:14:34 +0200

On 2019-3-8, at 9:50, Mikael Abrahamsson <[email-masked]> wrote:
> I'd like to point out that Daniel Stenberg (curl main developer) seems to be unable to make it to USA as well:
> 
> https://daniel.haxx.se/blog/2018/07/28/administrative-purgatory/ <https://daniel.haxx.se/blog/2018/07/28/administrative-purgatory/>
> 

He's certainly participating in QUIC. We run the locations of our interim meetings by the list for exactly that reason.

Lars

---

From: Eliot Lear <[email-masked]>
Date: Fri, 8 Mar 2019 09:26:55 +0100

Hi Lars and Mikael,

> On 8 Mar 2019, at 09:14, Lars Eggert <[email-masked]> wrote:
> 
> On 2019-3-8, at 9:50, Mikael Abrahamsson <[email-masked] <mailto:[email-masked]>> wrote:

That’s not good, clearly.  We also have some text in the mtgvenue document that states the following:

   Furthermore, it may be appropriate for the IASA to assist those who,
   as a result, have been inconvenienced in some way.

We have had government officials offer consular guidance and assistance in the past.  What I would suggest is that anyone who believes they are going to have entry problems for one of our meetings let Portia know.

Eliot

---

From: Fernando Gont <[email-masked]>
Date: Fri, 8 Mar 2019 08:54:39 -0300

On 8/3/19 05:26, Eliot Lear wrote:
> Hi Lars and Mikael,
> 
>> On 8 Mar 2019, at 09:14, Lars Eggert <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>> I'd like to point out that Daniel Stenberg (curl main developer)
>>> seems to be unable to make it to USA as well:
>>>
>> He's certainly participating in QUIC. We run the locations of our
>> interim meetings by the list for exactly that reason.
>>
> 
> 
> That’s not good, clearly.  We *also* have some text in the mtgvenue
> document that states the following:
> 
> We have had government officials offer consular guidance and assistance
> in the past.  What I would suggest is that anyone who believes they are
> going to have entry problems for one of our meetings let Portia know.

That's hard to know much in advance: if you need a visa, you may face
"preliminar" problems at that stage.. and, at least strictly speaking,
no matter the visa, it all depends on the officer at border control.

While this same logic applies to all places, when there are evident
problems even at the visa stage, I'm not sure that there are many
options other than avoiding problematic locations, unfortunately.

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Ted Lemon <[email-masked]>
Date: Fri, 8 Mar 2019 09:44:22 -0500

> We have had government officials offer consular guidance and assistance in the past.  What I would suggest is that anyone who believes they are going to have entry problems for one of our meetings…

We’ve also seen cases in the U.S. of people being denied entry capriciously, at the last minute.   The way in which entry is denied should probably also be taken into account: a country that denies entry after approving it, at the last minute, is not a great candidate for an international meeting.

---

From: Eliot Lear <[email-masked]>
Date: Fri, 8 Mar 2019 15:51:25 +0100

> On 8 Mar 2019, at 15:44, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 8, 2019, at 3:26 AM, Eliot Lear <[email-masked] <mailto:[email-masked]>> wrote:

Again, while I am certain of this having happened, I am equally certain it has happened in a great many countries, and I am quite uncertain as to how it has impacted the IETF.  It’s important for Portia to know when someone has been turned away.

Eliot

---

From: tom petch <[email-masked]>
Date: Fri, 8 Mar 2019 17:14:30 +0000

----- Original Message -----
From: "Carsten Bormann" <[email-masked]>
Sent: Friday, March 08, 2019 6:35 AM

> During a government shutdown, probably nobody.

But that’s the point: We don’t want to choose venues in countries that
are unstable.

(Re the Brexit comment: Unfortunately, the UK is now also entering an
unstable phase.)

<tp>

An interesting report in the papers today was that going from an EU
country to another can require a passport valid only until date of
departure whereas coming from outside the EU the requirement can be to
have several months validity remaining after the expected date of
departure; which has just entered the collective consciousness which in
turn has caused a sharp rise in applications for passport renewals which
caused the passsport renewal server to crash.  Yes, unstable (if
entirely foreseable).

More generally, things happen and we can never be sure that everyone who
wants to will be able to attend an IETF meeting; it is a question of
best efforts, keeping track of the failures that occur and making
informed decisions..

Tom Petch

Grüße, Carsten

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Fri, 8 Mar 2019 18:21:54 +0000

Lars,

It might be of interest if you could share the list of places QUIC has met since it’s been meeting regularly outside of the regular IETF meetings.

-glenn

On 3/8/19, 12:15 AM, "ietf on behalf of Lars Eggert" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

On 2019-3-8, at 9:50, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>> wrote:
I'd like to point out that Daniel Stenberg (curl main developer) seems to be unable to make it to USA as well:

Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 8 Mar 2019 20:57:59 +0200

> It might be of interest if you could share the list of places QUIC has met since it’s been meeting regularly outside of the regular IETF meetings.

https://github.com/quicwg/wg-materials

2x Tokyo
1x Paris
1x Seattle
1x Melbourne
1x Stockholm
1x NYC

Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 8 Mar 2019 21:02:01 +0200

> 1x NYC

And we did poll the WG list before the US meetings to check if anyone that was interested in attending in person would have difficulties doing so; for the two US meetings, that was not the case.

Lars

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Fri, 8 Mar 2019 19:28:47 +0000

Lars.

This is great data since it involves actual IETFers and it’s pretty current.

Did the QUIC meetings run into any issues at the other places you’ve met ?    No need to mention individuals and their situations – high level info is fine.

-glenn

On 3/8/19, 11:03 AM, "Lars Eggert" <[email-masked]<mailto:[email-masked]>> wrote:

On 2019-3-8, at 20:57, Lars Eggert <[email-masked]<mailto:[email-masked]>> wrote:
2x Tokyo
1x Paris
1x Seattle
1x Melbourne
1x Stockholm
1x NYC

Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 8 Mar 2019 14:14:36 -0600

On Fri, Mar 8, 2019, 13:03 Lars Eggert <[email-masked]> wrote:

> And we did poll the WG list before the US meetings to check if anyone that
> was interested in attending in person would have difficulties doing so; for
> the two US meetings, that was not the case.
>

... and coordinated with the responsible AD, who was satisfied that the
chairs had done what was necessary to run productive and open meetings.

My thanks to them for that.

Spencer

Lars

---

From: Keith Moore <[email-masked]>
Date: Sat, 9 Mar 2019 09:39:29 -0500

> But that’s the point: We don’t want to choose venues in countries that

Not that I disagree.   But in an era in which instability is apparently 
viewed as a virtue by many parties around the world, which countries are 
still stable?

---

From: Ted Lemon <[email-masked]>
Date: Sat, 9 Mar 2019 11:51:17 -0500

On Mar 9, 2019, at 9:39 AM, Keith Moore <[email-masked]> wrote:
> Not that I disagree.   But in an era in which instability is apparently viewed as a virtue by many parties around the world, which countries are still stable?

Finland.

:)

---

From: "Roni Even (A)" <[email-masked]>
Date: Sun, 10 Mar 2019 06:53:24 +0000

Hi,
I think that the attendance at the QUIC interim do not provide a good representation of  the general participants in terms of country of origin.
BTW: getting a visa to Australia was a bit of a challenge.

Roni

From: ietf [mailto:[email-masked]] On Behalf Of Deen, Glenn (NBCUniversal)
Sent: Friday, March 08, 2019 9:29 PM
To: Lars Eggert
Cc: IETF Discussion Mailing List
Subject: Re: [EXTERNAL] Adi Shamir denied entry to the US

Lars.

-glenn

Lars

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 11 Mar 2019 03:33:19 -0500

Hi, Roni,

On Sun, Mar 10, 2019, 00:54 Roni Even (A) <[email-masked]> wrote:

> Hi,
>
> I think that the attendance at the QUIC interim do not provide a good
> representation of  the general participants in terms of country of origin.
>
I understand the point, and agree that the QUIC participants, especially
in-person interim participants, aren't a random sample that reflects the
overall IETF, in a number of ways.

We really are making it up as we go along, because the definition of
"stable" is in flux. We're working from the data we have, and I'm not sure
what we can do beyond saying what we're planning, and asking for concerns -
whether at the working group level for interims, or the IETF level for our
three-meetings-per-year.

Any reported experiences like this are valuable.

Spencer, as QUIC AD for less than a month to go

>
>
> Roni
>
>
>
> *From:* ietf [mailto:[email-masked]] *On Behalf Of *Deen, Glenn
> (NBCUniversal)
> *Sent:* Friday, March 08, 2019 9:29 PM
> *To:* Lars Eggert
> *Cc:* IETF Discussion Mailing List
> *Subject:* Re: [EXTERNAL] Adi Shamir denied entry to the US
>
>
>
> Lars.
>
>
>
> Did the QUIC meetings run into any issues at the other places you’ve met
> ?    No need to mention individuals and their situations – high level info
> is fine.
>
>
>
> -glenn
>
>
>
> On 3/8/19, 11:03 AM, "Lars Eggert" <[email-masked]> wrote:
>
>
>

---

From: Vinayak Hegde <[email-masked]>
Date: Tue, 12 Mar 2019 12:33:40 +0530

> As to community fears and concerns, if we don’t go to the U.S. at all, then we will have no data on just how we are affected.  While there are other conferences from whose experience we can and do…

Hi Eliot,

Thank you and others for your work on the mtgvenue group. A couple of
data points that we can harness for collecting data about our
demographic of attendees (especially those at a disadvantage) are
1. ISOC Fellows to the IETF (technical and Policy Folks). There have
been many instances where people selected as fellows were not able to
attend due to visa denials.

2. IETF refunds the meeting fees for those attendees who cannot get
the visa (or get the visa in time) for the meetings.I am guessing the
tech team and the secretariat should already have this data.

We can track both these data qualitatively and quantitatively.

Regards
Vinayak