Subject: Re: Finding the appropriate work stream for draft-nottingham-for-the-users

From: S Moonesamy <[email-masked]>
Date: Tue, 19 Mar 2019 14:36:55 -0700

Hello,
At 02:58 PM 18-03-2019, Ted Hardie wrote:
>However, in discussion some felt that there might be interest in 
>adopting this document into the IETF stream as a BCP (most likely in 
>the General Area), with a stronger focus on setting guidelines for 
>working groups when they face these sorts of issues.

This draft was previously discussed in an IRTF RG.  It is now being 
discussed within the IETF and the IAB.  There is at least one 
statement in the draft which is too political.

Are the guidelines (to be set) about the issues which IETF working 
groups are facing from an architectural perspective or is it only 
about the "market"?  One of the outputs of the IETF is standards 
[1].  That in turn sometimes ends up in products which people use.  I 
assume that a few people on this mailing list are aware of some of 
those products "frustrate the user".  Is anyone considering telling 
[2] those users that "code is law"?

The Internet, as seen from an IETF perspective, is about "end points" 
instead of "end users".  The draft, as currently written, redefines 
the meaning of "user".  That is like saying that the Internet is for 
web browsers and mobile phones.

As a comment about the appropriate work stream, I see it as being 
about where one would get the level of review required to turn the 
draft into a RFC.  It could also be about wide-spread agreement [3] 
if that is one of the objectives of the author.

Regards,
S. Moonesamy

1. I was unable to locate the old discussion about that which ended 
up with an "updates" to BCP 9 with a well-known search engine.  I 
recall that an ex-IAB Chair commented about that during a plenary.

2. It is up to that person to determine whether that it a good or bad idea.

3. That is not easy.

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 20 Mar 2019 09:19:04 +1100

Hi SM,

> On 20 Mar 2019, at 8:36 am, S Moonesamy <[email-masked]> wrote:
> 
> Hello,
>> However, in discussion some felt that there might be interest in adopting this document into the IETF stream as a BCP (most likely in the General Area), with a stronger focus on setting guidelines for working groups when they face these sorts of issues.
> 
> This draft was previously discussed in an IRTF RG.  It is now being discussed within the IETF and the IAB.  There is at least one statement in the draft which is too political.

Which statement is that?

> Are the guidelines (to be set) about the issues which IETF working groups are facing from an architectural perspective or is it only about the "market"?  One of the outputs of the IETF is standards [1].  That in turn sometimes ends up in products which people use.  I assume that a few people on this mailing list are aware of some of those products "frustrate the user".  Is anyone considering telling [2] those users that "code is law"?

I'm not sure what you're getting at here.

> The Internet, as seen from an IETF perspective, is about "end points" instead of "end users".  The draft, as currently written, redefines the meaning of "user".  That is like saying that the Internet is for web browsers and mobile phones.

I don't agree with this characterisation; it's missing the point of the draft, which is that the people behind the computers are the point, not the programs running on them.

> As a comment about the appropriate work stream, I see it as being about where one would get the level of review required to turn the draft into a RFC.  It could also be about wide-spread agreement [3] if that is one of the objectives of the author.

I agree with you on [3].

Cheers,

> 
> Regards,
> S. Moonesamy
> 
> 1. I was unable to locate the old discussion about that which ended up with an "updates" to BCP 9 with a well-known search engine.  I recall that an ex-IAB Chair commented about that during a plenary.
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 18:42:49 -0400

> web browsers and mobile phones.

I don't read the draft that way, but perhaps it could be still 
clearer.   I suggest "The Internet Is For Humans".

Keith

---

From: S Moonesamy <[email-masked]>
Date: Tue, 19 Mar 2019 15:55:44 -0700

Hi Mark,
>Which statement is that?

There is the following: "As the Internet increasingly mediates key 
functions in societies, it has unavoidably become profoundly 
political; it has helped people overthrow governments ..."

>I'm not sure what you're getting at here.

In simple terms, it is about how the IETF operates.  It may be better 
to skip that discussion for now; it may be irrelevant as the draft progresses.

>I don't agree with this characterisation; it's missing the point of 
>the draft, which is that the people behind the computers are the 
>point, not the programs running on them.

Ok.

Regards,
S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Tue, 19 Mar 2019 17:56:49 -0700

Hi Keith,
>clearer.   I suggest "The Internet Is For Humans".

I am not disagreeing with your suggestion.  I am probably reading 
things the wrong way.  I prefer not to make a statement about users 
or humans if the reality is the opposite of that.

Regards,
S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Tue, 19 Mar 2019 21:21:40 -0400

> On Mar 19, 2019, at 8:56 PM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Keith,
>> I don't read the draft that way, but perhaps it could be still clearer.   I suggest "The Internet Is For Humans".
> 
> I am not disagreeing with your suggestion.  I am probably reading things the wrong way.  I prefer not to make a statement about users or humans if the reality is the opposite of that.

It will be interesting to find out what reality is. 

Keith

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 19 Mar 2019 20:20:23 -0700

> political; it has helped people overthrow governments ..."

In what way is this political? It seems merely factual.

-Ekr

---

From: S Moonesamy <[email-masked]>
Date: Tue, 19 Mar 2019 21:38:13 -0700

Dear Mr Rescorla,
>In what way is this political? It seems merely factual.

If that is indeed a fact, it is unlikely that any sovereign entity 
would allow such communication to be used to for unfettered 
interference in its internal affairs.  An entity which has a 
significant interest in the Internet might have to consider the risks 
of "technical fragmentation".

Regards,
S. Moonesamy

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 20 Mar 2019 11:01:52 +0000

On 20/03/2019 04:38, S Moonesamy wrote:
> If that is indeed a fact, it is unlikely that any sovereign entity would 
> allow such communication to be used to for unfettered interference in 
> its internal affairs.  An entity which has a significant interest in the 
> Internet might have to consider the risks of "technical fragmentation".
> 
> Regards,
> S. Moonesamy

The writing is on both or those walls already.

To the latter, Geoff Huston's paper "The Death of Transit" suggests that 
we are already seeing fragmentation, something we can consider both a 
threat and an interesting opportunity.

- Stewart

---

From: S Moonesamy <[email-masked]>
Date: Wed, 20 Mar 2019 12:37:23 -0700

Hi Stewart,
At 04:01 AM 20-03-2019, Stewart Bryant wrote:
>To the latter, Geoff Huston's paper "The Death of Transit" suggests 
>that we are already seeing fragmentation, something we can consider 
>both a threat and an interesting opportunity.

I agree with what the "interesting opportunity" in the above.

There are interesting points in that paper, e.g. overarching control 
of the digital service.  The paper does not discuss about whether 
internet-related policies are linked to some foreign policy(ies) 
which promote the overthrow of governments through external actors.

Regards,
S. Moonesamy