Subject: New tool: Using Emacs Org Mode for writing RFCs

From: Christian Hopps <[email-masked]>
Date: Mon, 04 Mar 2019 18:19:20 -0500

Check it out: https://github.com/choppsv1/org-rfc-export

If you are an Emacs user, especially one who is familiar with/uses Org Mode, I think you'll like this.

I've been working on an org mode exporter for writing RFCs. As it's now in MELPA (package: ox-rfc) I figured it was a good time to announce it's availability. Basically you write your RFC in Org Mode and export it to XML. The back-end supports exporting to XML (for manual xml2rfc), but also supports exporting to text, HTML, or PDF, including directly into a buffer for easy previewing.

Highlights:
- Powerful Org Mode
- Simple Citations/References.
- Lists (Numbered, Unnumbered)
- Definition Lists (term + definition)
- Tables
- Embedded Code (Literate Programming e.g., embed yang model, trees, examples)

In particular YANG embedding is pretty neat. There's no need for separate files and tree generation (and example validation) can be automated from the embedded text.

Check out the README and the examples (currently in the ert-tests directory).

Thanks,
Chris.

---

From: Wes Hardaker <[email-masked]>
Date: Wed, 06 Mar 2019 14:37:03 -0800

> Check it out: https://github.com/choppsv1/org-rfc-export

Holy cow.  That would make writing RFCs so much simpler and prettier.
I'll definitely take a look and thank you for putting in the effort.
-- 
Wes Hardaker
USC/ISI

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 6 Mar 2019 17:57:57 -0600

To echo Wes faintly,

> I'll definitely take a look and thank you for putting in the effort.

I don't imagine I'm going to use this anytime soon, but having hacked my
way through a couple of Kramdown docs that didn't quite follow the usual
trail through the process forest, the documentation for how to produce an
Internet Draft using this tool looks really complete. Since you probably
know how this stuff works, thank you for spending so much effort for people
who don't know that.

Spencer, who just finished flogging his Chromebook Linux environment until
I could use it for an IRTF RG draft ...

---

From: Christian Hopps <[email-masked]>
Date: Mon, 11 Mar 2019 07:24:09 -0400

> know how this stuff works, thank you for spending so much effort for people

Thanks for this! It does in fact help with motivation to keep writing those docs :)

Chris.