Subject: RFC Series Editor Resignation

From: Sarah B <[email-masked]>
Date: Tue, 18 Jun 2019 15:55:56 -0700

Hello,
	The RSOC, as required every two years, recently undertook a review of the RFC Series Editor contract, the base term of which is scheduled to end this year.   Although the RSOC had recommended renewing the RFC Series Editor (RSE) contract for another two years, and then put the contract back out to bid in 2021 expressly for the purposes of refining our RFP process, Heather Flanagan, the current RFC Series Editor (RSE), has informed the RSOC, IAB, and IETF LLC that she does not intend to renew the RSE contract, which is set to conclude at the end of this calendar year. She has indicated that she is willing to work through a transition period in the first months of next year, to support a smooth hand-over of duties to a new RSE.
	The RSOC and IAB are grateful for that courtesy and for Heather's many years of service as RSE.  We look forward to working with her during the transition process, which will result in a Request For Proposals, as has been the case during other contract awards. We hope that the community joins us in expressing their appreciation of her work on behalf of the community and in working to ensure a smooth transition.

Kind regards,
Sarah Banks
For the RSOC, in coordination with the IAB

---

From: "Aaron Falk" <[email-masked]>
Date: Tue, 18 Jun 2019 22:52:26 -0400

I’m not sure whether my question below should be addressed to the 
RSOC, IAB, IETF Exec Dir, or IETF LLC, so maybe one of them will 
enlighten me.

Regarding

> Although the RSOC had recommended renewing the RFC Series Editor (RSE) 
> contract for another two years, and then put the contract back out to 
> bid in 2021 expressly for the purposes of  refining our RFP process

I’m wondering what exactly it means to put a contract out to bid “to 
refine the RFP process”.  For example, is someone bidding on the RSE 
contract supposed to assume they are just providing information and not 
actually going to be a candidate for the award? (Is that even legal?)  
Or, should we presume that this is an actual competition for the RSE 
work?  I can’t understand how you can solicit bids for the RSE but say 
is is just to refine the process.   Can someone explain this curious 
wording?

If the goal is to replace the current RSE, perhaps someone can explain 
why.

--aaron

---

From: Terry Manderson <[email-masked]>
Date: Wed, 19 Jun 2019 13:52:43 +1000

Hi,

Perhaps you can clarify something.

> 	[...] back out to bid in 2021 expressly for the purposes of refining our RFP process, Heather Flanagan, the current RFC Series Editor (RSE), has informed the RSOC, IAB, and IETF LLC that she does not intend to renew the RSE contract, 

So, paraphrasing, originally the RSOC recommendation was to extend the contract, and during that period place it out to bid to refine the process.

My logic suggests that the RSOC (& IAB) believes that process needs refining before running the big "for real". 

Now you (we, the IETF) don't have that option. How are you going to refine the process prior to issuing the RFP? What community oversight and engagement will you be providing?

Cheers
Terry

---

From: Alexander Neilson <[email-masked]>
Date: Wed, 19 Jun 2019 15:55:12 +1200

I may be wrong but I read it as meaning a renewal of the current contract to allow time to refine the process and that new process would be the structure the RFP for a new contractor went out under. 

Regards
Alexander

Alexander Neilson
Neilson Productions Limited
021 329 681
[email-masked]

> On 19/06/2019, at 14:52, Aaron Falk <[email-masked]> wrote:
> 
> I’m not sure whether my question below should be addressed to the RSOC, IAB, IETF Exec Dir, or IETF LLC, so maybe one of them will enlighten me.
> 
> Regarding
> 
> Although the RSOC had recommended renewing the RFC Series Editor (RSE) contract for another two years, and then put the contract back out to bid in 2021 expressly for the purposes of refining our RFP process
> 
> I’m wondering what exactly it means to put a contract out to bid “to refine the RFP process”. For example, is someone bidding on the RSE contract supposed to assume they are just providing information and not actually going to be a candidate for the award? (Is that even legal?) Or, should we presume that this is an actual competition for the RSE work? I can’t understand how you can solicit bids for the RSE but say is is just to refine the process. Can someone explain this curious wording?
> 
> If the goal is to replace the current RSE, perhaps someone can explain why.
> 
> --aaron

---

From: Terry Manderson <[email-masked]>
Date: Wed, 19 Jun 2019 14:10:50 +1000

On the back of what Aaron asks, was this plan shared with the RSE Contractor?

If you did share it, what signal do you think that sends to the holder of a current contract?

"just refine the process"?? Really?

Cheers
Terry

> On 19 Jun 2019, at 12:52 pm, Aaron Falk <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Jun 2019 16:46:06 +1200

Well, I'm confused too. It's not as if the house was burning down, except that now it is.

What Sarah's message didn't make quite clear is that the 2021 re-bid would be two years early, given that the full term of the current contract ends 6 years from 1/1/2018. (https://iaoc.ietf.org/documents/RSE-2018-Independent-Contractor-24Oct17-Public.pdf,
Clause 3 "TERM"). In other words the RSOC and/or IAB had already decided to truncate the contract. This makes us (legally personified as IETF LLC) look like an unreliable business partner.

So what precipitated this disruption? From my point of view, everything was running well, even if occasionally some nominal target numbers were missed; it's great to have a series editor who actually has appropriate professional knowledge and experience, unlike all her predecessors. So the decision to prematurely run a bidding process seems to have been a really bad idea. Something about ain't broke, don't fix. The attempted fix has apparently caused serious breakage. This deserves a transparent explanation to the community.

The phrase "expressly for the purposes of refining our RFP process" literally makes no sense to me as an explanation for breaking off a satisfactory contract. If there's something wrong with our RFP process, we seem to have thrown away almost all the time available to improve it, given that the normal date for the rebid would be sometime in 2023. That seems like the exact opposite of what the community needed from the RSOC and the IAB.

Regards
   Brian Carpenter

On 19-Jun-19 15:55, Alexander Neilson wrote:
> [email-masked] <mailto:[email-masked]>
> 
> On 19/06/2019, at 14:52, Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: Alexander Neilson <[email-masked]>
Date: Wed, 19 Jun 2019 17:19:10 +1200

Hi Brian

Just to quibble on one point. 

The term is for two years with two possibly extensions if mutually agreed. 

So in this case it sounds like the intention was signalled to take up one renewal option by one party and the other decided not to take a renewal. 

I don’t think it is any signal of unreliability. The term itself is almost at its conclusion. The contract considered an option to extend which has not been taken up. 

Regards
Alexander

Alexander Neilson

> On 19/06/2019, at 16:46, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 19 Jun 2019 17:24:49 +1200

They seem to have pre-announced there would be no second renewal. That is not a normal way of doing business, to my mind.

Regards
   Brian Carpenter

---

From: Alexander Neilson <[email-masked]>
Date: Wed, 19 Jun 2019 19:59:58 +1200

If that is the decision made then one partner to a business relationship telling the other their intentions is not unusual for business people. 

Business thrives on certainty and holding back on telling the other party so they can plan with plenty of notice seems likely to cause more damage to the relationship. 

Especially if the next stage was to publish the terms of reference for the review including what they think needs to be looked at particularly and their proposed plan (including timeline for concluding the review, implementing the changes - which may have included putting the contract out to tender anew). Then this next step would be very negative having not told the other person the plan before they find out from third parties. 

Regards
Alexander

Alexander Neilson

> On 19/06/2019, at 17:24, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 19 Jun 2019 15:15:50 +0200

Hi Sarah,

> 	The RSOC, as required every two years, recently undertook a
> review of the RFC Series Editor contract, the base term of which is
> scheduled to end this year.   Although the RSOC had recommended
> renewing the RFC Series Editor (RSE) contract for another two years,
> and then put the contract back out to bid in 2021 expressly for the
> purposes of refining our RFP process, Heather Flanagan, the current
> RFC Series Editor (RSE), has informed the RSOC, IAB, and IETF LLC
> that she does not intend to renew the RSE contract, which is set to
> conclude at the end of this calendar year. She has indicated that she
> is willing to work through a transition period in the first months of
> next year, to support a smooth hand-over of duties to a new RSE.

Did the RSE indicate that she did not intend to renew before you informed
her that you were going to put the contract out for bid in 2021, or
as a result of you informing her about the early re-bid?

Regards,

	Henrik

> 	The RSOC and IAB are grateful for that courtesy and for Heather's
> many years of service as RSE.  We look forward to working with her
> during the transition process, which will result in a Request For
> Proposals, as has been the case during other contract awards. We hope
> that the community joins us in expressing their appreciation of her
> work on behalf of the community and in working to ensure a smooth
> transition.
> 
> Kind regards, Sarah Banks For the RSOC, in coordination with the IAB
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 19 Jun 2019 15:26:16 +0100

I really do not think that this is a discussion that should take place 
in a public forum like this.

There is much that both parties may legitimately wish to keep private in 
situations such as this.

- Stewart

---

From: Kyle Rose <[email-masked]>
Date: Wed, 19 Jun 2019 10:34:21 -0400

> There is much that both parties may legitimately wish to keep private in

The involved parties are not required to comment, but as this is an event
that impacts everyone at the IETF, this is 100% appropriate for discussion
on this forum. I further guarantee that this will be raised at the next
meeting plenary if adequate explanation for "refining [the] RFP process" is
not offered beforehand.

---

From: Michael StJohns <[email-masked]>
Date: Wed, 19 Jun 2019 10:45:31 -0400

> They seem to have pre-announced there would be no second renewal. That is not a normal way of doing business, to my mind.

Especially doing so 2.5 years in advance.   That seems to be a bad 
business practice to lock yourself (or your successors actually) into a 
set of actions 2 years into the future.    And seriously, I've done 
dozens of RFP like actions over the years during my time with the US DOD 
- there's not a lot of "refining" that needs to be done, or that can't 
be done during the process of the RFP (clarifications and precisions 
process).

Hmm.  What do the LLC minutes say about this?  Where would we look?

And nominally, the IAB gave themselves oversight over the RFC process 
with their original charter, but we've since gone through the IAOC and 
LLC processes.  Given that neither the IAB nor the RSOC is a contracting 
entity, I'm unclear why they are making the decision on renewal without 
community input to the LLC?

Later, Mike

---

From: Eliot Lear <[email-masked]>
Date: Wed, 19 Jun 2019 16:57:07 +0200

I think we might want to pause for a moment, just long enough to say this:

Thank you very much, Heather.

Eliot

---

From: Richard Barnes <[email-masked]>
Date: Wed, 19 Jun 2019 11:00:33 -0400

People are entitled to comment, but it might be nice not to create
unnecessary drama by micromanaging the RSOC and LLC's contracting process.
The point of delegating administrative support to these groups is to let
them worry about these details.

For my part, this seems like totally normal business.  The parties are
exercising the rights they're entitled to under the contract, to extend /
re-bid or to terminate.  That's why these provisions are in the contract.

It would be more productive to focus on the future, and provide the RSOC
with input on their selection of the next RSE.

--Richard

---

From: Ted Hardie <[email-masked]>
Date: Wed, 19 Jun 2019 08:01:52 -0700

Hi Mike,

> LLC processes.

The functions of the RSOC are set out here:

https://tools.ietf.org/html/rfc6635#page-14

It normally acts with authority delegated from the IAB.  In the case of
decisions that affect the RSE individually, such as contract extensions, it
recommends action to the IAB.  This language is substantially the same in
the update in preparation:

https://datatracker.ietf.org/doc/draft-ietf-iasa2-rfc6635bis/?include_text=1

The difference between the two is that the first describes the relation to
IASA and the second specifies that it be the IETF LLC. In this case, the
recommendation to renew the contract for the next 2-year term and Heather's
announcement to the IAB, RSOC, and LLC that she did not intend to renew
were received on the same day, so none of the rest of that process went
forward.  Instead, the RFP process will go forward, with coordination among
the IAB, RSOC, and LLC and with Heather's assistance.

There were a couple of threads on the IASA2 mailing list on the topic of
the update which you may wish to review.

> Given that neither the IAB nor the RSOC is a contracting
The only thing that has changed here is that the contracting party moved
from ISOC to the IETF LLC.  The rest of the process, including the role of
the RSOC in making this recommendation is the same.

regards,

Ted Hardie

> >> So in this case it sounds like the intention was signalled to take up
> one renewal option by one party and the other decided not to take a renewal.
> >>
> >> I don’t think it is any signal of unreliability. The term itself is
> almost at its conclusion. The contract considered an option to extend which
> has not been taken up.
> >>
> >> Regards
> >> Alexander
> >>
> >> Alexander Neilson
> >>> What Sarah's message didn't make quite clear is that the 2021 re-bid
> would be two years early, given that the full term of the current contract
> ends 6 years from 1/1/2018. (
> https://iaoc.ietf.org/documents/RSE-2018-Independent-Contractor-24Oct17-Public.pdf
> ,
> >>> Clause 3 "TERM"). In other words the RSOC and/or IAB had already
> decided to truncate the contract. This makes us (legally personified as
> IETF LLC) look like an unreliable business partner.
> >>>
> >>> So what precipitated this disruption? From my point of view,
> everything was running well, even if occasionally some nominal target
> numbers were missed; it's great to have a series editor who actually has
> appropriate professional knowledge and experience, unlike all her
> predecessors. So the decision to prematurely run a bidding process seems to
> have been a really bad idea. Something about ain't broke, don't fix. The
> attempted fix has apparently caused serious breakage. This deserves a
> transparent explanation to the community.
> >>>
> >>> The phrase "expressly for the purposes of refining our RFP process"
> literally makes no sense to me as an explanation for breaking off a
> satisfactory contract. If there's something wrong with our RFP process, we
> seem to have thrown away almost all the time available to improve it, given
> that the normal date for the rebid would be sometime in 2023. That seems
> like the exact opposite of what the community needed from the RSOC and the
> IAB.
> >>>
> >>> Regards
> >>>    Brian Carpenter
> >>>
> >>>> I may be wrong but I read it as meaning a renewal of the current
> contract to allow time to refine the process and that new process would be
> the structure the RFP for a new contractor went out under.
> >>>>
> >>>> Regards
> >>>> Alexander
> >>>>
> >>>> Alexander Neilson
> RSOC, IAB, IETF Exec Dir, or IETF LLC, so maybe one of them will enlighten
> me.
> >>>>>
> >>>>> Regarding
> >>>>>
> >>>>>     Although the RSOC had recommended renewing the RFC Series Editor
> (RSE) contract for another two years, and then put the contract back out to
> actually going to be a candidate for the award? (Is that even legal?) Or,
> should we presume that this is an actual competition for the RSE work? I
> can’t understand how you can solicit bids for the RSE but say is is just to
> refine the process. Can someone explain this curious wording?
> >>>>>

---

From: Ted Hardie <[email-masked]>
Date: Wed, 19 Jun 2019 08:13:16 -0700

On Tue, Jun 18, 2019 at 9:46 PM Brian E Carpenter <
[email-masked]> wrote:

> What Sarah's message didn't make quite clear is that the 2021 re-bid would
> be two years early, given that the full term of the current contract ends 6
> years from 1/1/2018. (
> Clause 3 "TERM").

First, you should note that this contract, like the others ISOC held on
behalf of the IETF was assigned to the IETF LLC.

This is the text from the section you cite.

3.TERM: ISOC, at the request of the IAOC which is acting on behalf of the
IAB and RFCSeries Oversight Committee (RSOC), desires to engage the
Contractor to fulfill the responsibilities of the RSE.
a. Term: The term of this Agreement is two years (the “Term”) beginning on
the Effective Date.
b. Extensions: This Agreement may be extended twice by mutual written
agreement of the parties (the “Extensions”), with each Extension being for
a period of up to two years.

As Alexander noted, the base term is two years, and it may be extended.
The RSOC review Sarah referenced is the review which takes place every two
years to consider these extension or, if no further extensions are
permitted, to create an RFP.  In this case the RSOC recommended an
extension, but Heather did not "mutually agree".

regards,

Ted Hardie

---

From: "John Levine" <[email-masked]>
Date: 19 Jun 2019 11:17:46 -0400

In article <[email-masked]> you write:
>-=-=-=-=-=-

Indeed.  She has shepherded the RFC series though some of the largest
changes in its history with intellgence and considerable charm.

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jun 2019 11:47:58 -0400

Stewart,

I disagree, but only partially.   I think there are actually at
least three or four separate questions involved with this.  One
is a strategy question or set of them having to do with how the
RFC Editor Function is managed and overseen.  Questions of
contract lengths, who has responsibility for what, and even the
question the Mike St Johns raised about whether, with the IASA
and then IASA2 transitions and other changes, the IAB's having
exclusive control is still right for the community are all part
of that.  So are other questions, e.g., whether,  there should
be people on the RSOC who are selected by the Nomcom for those
roles or appointed by other community bodies.   Those are issues
that affect the whole community (including many
none-participants in the IETF) and should be about to be
discussed broadly.   If a public discussion of them is not
possible, I think we are in very big trouble indeed.

Second, there are questions surrounding whether some of the
decisions that seem to have been made here --notably taking an
action that would have a high likelihood of constraining options
2.5 years out--  represent good business and/or management
practices.  With one exception that I trust is not the case and
that would raise other issues, I cannot imagine why the
community should not be able to discuss whether or not the
process of overseeing the RSE (and the RFC Editor Function
generally) is applying good practices.   If Heather was not
consulted (I don't think we know whether she was or not and she
is certainly not the person who should be obligated to tell us)
before the decision was made about the tradeoffs involved, how
difficult she thought it would be a find a replacement, etc.,
that is, to me, another management process issue for which there
should be some accountability. (I know such a conversation might
have been awkward but, noting that the nomcom handles equally
awkward conversations every year, if we cannot have expectations
about Heather's professionalism and that of the RSOC that are at
least that high, we are in big trobule.) If none of that can
discussed in public, then, AFAICT, we are essentially deciding
that the RSOC (or the RSOC and the IAB together) are not
accountable to the community around issues that clearly involve
management decisions and not just handing out architectural
advice.

Third, there is the question of Heather's performance. Taking an
action that, at least IMO, would have a high likelihood of
resulting in her saying "I don't need any more of this" (even
from someone of Heather's normal cheery temperament, especially
as compared to the hotheads among us) and doing so without
community input, even if that input had been requested to be
sent to the RSOC rather than this list, seems inappropriate ...
or is part of the management and accountability issues mentioned
above.

None of the above interacts with the details of particular
contracts with individuals, cost negotiations, etc., which
should clearly not be on this list.

best,
  john

--On Wednesday, June 19, 2019 15:26 +0100 Stewart Bryant
<[email-masked]> wrote:

> I really do not think that this is a discussion that should
> take place in a public forum like this.
> 
> There is much that both parties may legitimately wish to keep
> private in situations such as this.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 19 Jun 2019 11:55:02 -0400

The amount of speculation going on here is impressive. FWIW, my main reaction to this is that I’m really sorry to hear that Heather is going. She’s been wonderful.

I don’t know if there is any debugging required here, but I do know that no part of the debugging process can happen on this mailing list. I won’t ask you to stop, because you won’t.

So perhaps we can have a drinking game. One shot of espresso every time someone speculates wildly. Two shots every time someone gets the length of the term wrong. Every time you post you have to drink a shot. 

Sent from my iPhone

> On Jun 19, 2019, at 11:47 AM, John C Klensin <[email-masked]> wrote:
> 
> Stewart,
>

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jun 2019 12:12:20 -0400

--On Wednesday, June 19, 2019 11:55 -0400 Ted Lemon
<[email-masked]> wrote:

> The amount of speculation going on here is impressive. FWIW,
> my main reaction to this is that I'm really sorry to hear
> that Heather is going. She's been wonderful.

Agreed.  And I find her departure very upsetting.  I am
concerned about, but not speculating about, what led to that and
arguing that it is reasonable for the community to ask questions
rather than simply trusting that some combination of the RSOC,
IAB, and IETF LLC will sort things out, especially if they plan
to do that in secret.  I have no idea whether they plan to do
that in secret (or at all) but felt a need to respond to
Stewart's note that I took as suggesting that the community
should stay out of this.  I also find the 2.5 year story -- not
speculation, but something I believe both Sarah and Christian
have been explicit about -- to be troubling and believe that the
community is entitled to inquire about it even if the only
result is to improve how things are handled in tee future..

> I don't know if there is any debugging required here, but I
> do know that no part of the debugging process can happen on
> this mailing list. I won't ask you to stop, because you
> won't.

Well, my plan had been to make that one commend and then shut
up, at least until we heard from from the RSOC or IAB.  So I am
responding to your note, just as I responded to Stewart's, and
not the substantive issue.  And, again, no speculation there.
If I have misunderstood either your comments of Stewart's,
please correct me (on-list or off, as you prefer).

Both my earlier note and this one are about questions of
accountability and transparency, especially wrt management
practices, not speculation about what happened or why.   So,
while your complaint may be legitimate (and, from reading parts
of the thread, I think it probably is), please go pick on
someone else.

> So perhaps we can have a drinking game. One shot of espresso
> every time someone speculates wildly. Two shots every time
> someone gets the length of the term wrong. Every time you post
> you have to drink a shot. 

No comment.

best,
   john

---

From: Mike StJohns <[email-masked]>
Date: Wed, 19 Jun 2019 12:18:00 -0400

Tell me if I have to drink.  The current contract was for 2 years with the possibility of 2 2year extensions for a possible total of 6 years.  The contract started 1 Jan 2018 making the initial end date 31 Dec 2019.   From what Sarah’s note said, the IAB and RSOC decided to exercise the first extension option which if accepted would place the contract end at 31 Dec 2021 (2.5 years from now).  The IAB RSOC at the same time is indicated that they would never exercise the second extension, instead indicating they would put the RSE back out for a new contract with an award date by 1Jan 2022.

Did I miss anything or does Sarah’s note allow for a different set of conclusions?

Mike

Sent from my iPad

> On Jun 19, 2019, at 11:55, Ted Lemon <[email-masked]> wrote:
>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 19 Jun 2019 09:27:05 -0700

Preparing for a re-bid after the first extension doesn't necessarily mean
that the second extension won't be exercised.  Plans are just plans and
circumstances could change.

I think we both have to drink.  ☕️☕️

--Richard

On Wed, Jun 19, 2019 at 9:19 AM Mike StJohns <[email-masked]> wrote:

> Tell me if I have to drink.  The current contract was for 2 years with the
> possibility of 2 2year extensions for a possible total of 6 years.  The
> contract started 1 Jan 2018 making the initial end date 31 Dec 2019.   From
> what Sarah’s note said, the IAB and RSOC decided to exercise the first
> extension option which if accepted would place the contract end at 31 Dec
> 2021 (2.5 years from now).  The IAB RSOC at the same time is indicated that
> they would never exercise the second extension, instead indicating they
> would put the RSE back out for a new contract with an award date by 1Jan
> 2022.
>
> > The amount of speculation going on here is impressive. FWIW, my main
> reaction to this is that I’m really sorry to hear that Heather is going.
> She’s been wonderful.
> >
> > I don’t know if there is any debugging required here, but I do know that
> no part of the debugging process can happen on this mailing list. I won’t
> ask you to stop, because you won’t.
> >
> > So perhaps we can have a drinking game. One shot of espresso every time
> someone speculates wildly. Two shots every time someone gets the length of
> the term wrong. Every time you post you have to drink a shot.
> >
> > Sent from my iPhone
> >

---

From: Allison Mankin <[email-masked]>
Date: Wed, 19 Jun 2019 12:28:17 -0400

I want to add to what Eliot and JohnL wrote:  I can see why this could be a
time to decide to move on, with large accomplishments completed.

Heather accomplished all the large organizational changes, brought us to
the v3 format (yay!!) in the most careful way, and celebrated and promoted
the 50th anniversary of the RFCs in an excellent manner.  Just to mention
high points.  We in IETF, IRTF, and ISE have been very lucky to work with
her.

Allison

On Wed, 19 Jun 2019 at 11:21, John Levine <[email-masked]> wrote:

> Elliot Lear wrote:

---

From: Jared Mauch <[email-masked]>
Date: Wed, 19 Jun 2019 12:52:44 -0400

> On Jun 19, 2019, at 10:57 AM, Eliot Lear <[email-masked]> wrote:
> 

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

This.

Standards process stuff is sometimes a bit of a meat grinder that can eat people that are unprepared for it.  A great thank-you to the contractors, staff, etc.. that make the day-to-day things happen that we all take for granted is a good way to start these conversations.

This is also why virtual (and permanent record) participation is hard and so many people have f2f conversations at the IETF.

That being said, I was once party to a contract that didn’t have a mutual termination clause.  When this was discovered, it was problematic as it meant you couldn’t stop taking services even if you were unhappy or decided to end the product it was servicing.  

I don’t know the reason for the termination/transition, it could be for personal/family/health reasons or they’re relocating to Antarctica for the next 6 months.  The reason I think isn’t relevant unless it was performance related and the way to address that would be via a pathway that doesn’t appear to be happening here.

I’m grateful for all the staff/volunteers/wg chairs/corporations that support our efforts.  Keep that in mind even as we each want to nitpick the 1’s and 0’s.

- Jared

---

From: Randy Bush <[email-masked]>
Date: Wed, 19 Jun 2019 09:54:11 -0700

> Thank you very much, Heather.

indded.  deeply.  and for keeping the internet, the rfc series, and the
culture in front of contracts and who micro-manages what/whom.

another step on the path of becoming what we claim to dislike.

randy

---

From: Michael StJohns <[email-masked]>
Date: Wed, 19 Jun 2019 14:34:12 -0400

On 6/19/2019 12:27 PM, Richard Barnes wrote:
> Preparing for a re-bid after the first extension doesn't necessarily 
> mean that the second extension won't be exercised.  Plans are just 
> plans and circumstances could change.

I don't think that passes the smell test.

Announcing a plan to re-bid at least 18 months and maybe more like 24 
months ahead of a re-bid beginning suggests to me that the exercise of 
the second extension would only happen if the re-bid didn't result in 
viable offers - including any other offers from the incumbent possibly 
bidding against themselves.

> I think we both have to drink.  ☕️☕️

No - I don't think so.  While its possible a later IAB or RSOC could 
change the conditions, I think what I said is a good representation of 
current reality.

Later, Mike

>
> --Richard
>
>
> On Wed, Jun 19, 2019 at 9:19 AM Mike StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Tell me if I have to drink.  The current contract was for 2 years
>     with the possibility of 2 2year extensions for a possible total of
>     6 years.  The contract started 1 Jan 2018 making the initial end
>     date 31 Dec 2019.   From what Sarah’s note said, the IAB and RSOC
>     decided to exercise the first extension option which if accepted
>     would place the contract end at 31 Dec 2021 (2.5 years from now). 
>     The IAB RSOC at the same time is indicated that they would never
>     exercise the second extension, instead indicating they would put
>     the RSE back out for a new contract with an award date by 1Jan 2022.
>
>     > On Jun 19, 2019, at 11:55, Ted Lemon <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     > The amount of speculation going on here is impressive. FWIW, my
>     main reaction to this is that I’m really sorry to hear that
>     Heather is going. She’s been wonderful.
>     >
>     > I don’t know if there is any debugging required here, but I do
>     know that no part of the debugging process can happen on this
>     mailing list. I won’t ask you to stop, because you won’t.
>     >
>     every time someone speculates wildly. Two shots every time someone
>     gets the length of the term wrong. Every time you post you have to
>     drink a shot.
>     >
>     > Sent from my iPhone
>     >
>     >> On Jun 19, 2019, at 11:47 AM, John C Klensin <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >>
>     >> Stewart,
>     >>
>     >> <[email-masked] <mailto:[email-masked]>> wrote:
>     >>

---

From: Richard Barnes <[email-masked]>
Date: Wed, 19 Jun 2019 11:49:07 -0700

On Wed, Jun 19, 2019 at 11:34 AM Michael StJohns <[email-masked]>
wrote:

> months ahead of a re-bid beginning suggests to me that the exercise of the
> second extension would only happen if the re-bid didn't result in viable
> offers - including any other offers from the incumbent possibly bidding
> against themselves.
>
Lot of assumptions in here.  "Suggests to me" doesn't mean "necessarily
follows".

> No - I don't think so.
> "Every time you post you have to drink a shot. "

☕️🐝

--RLB

While its possible a later IAB or RSOC could change the conditions, I think
> what I said is a good representation of current reality.
>
> Later, Mike
>
>
>
> --Richard
>
>
>> Tell me if I have to drink.  The current contract was for 2 years with
>> the possibility of 2 2year extensions for a possible total of 6 years.  The
>> > I don’t know if there is any debugging required here, but I do know
>> that no part of the debugging process can happen on this mailing list. I
>> won’t ask you to stop, because you won’t.
>> >

---

From: Ted Hardie <[email-masked]>
Date: Wed, 19 Jun 2019 11:51:32 -0700

On Wed, Jun 19, 2019 at 11:35 AM Michael StJohns <[email-masked]>
wrote:

> suggests to me that the exercise of the second extension would only happen
> if the re-bid didn't result in viable offers - including any other offers
> from the incumbent possibly bidding against themselves.
>
>
As a process clarification, it is my understanding that either the
extension occurs or a re-bid occurs, and that the recommendations on that
point come early in order to allow for either one to occur.  Extending the
existing contract after bids have been received is not one of the described
possibilities, so any bid by the incumbent would be based on a new RFP.
As a former contracting officer, I am sure you understand that an incumbent
bidding for a contract after a new RFP is extremely common.

regards,

Ted

---

From: Michael StJohns <[email-masked]>
Date: Wed, 19 Jun 2019 15:45:34 -0400

On 6/19/2019 2:51 PM, Ted Hardie wrote:
> On Wed, Jun 19, 2019 at 11:35 AM Michael StJohns <[email-masked] 
>     suggests to me that the exercise of the second extension would
>     only happen if the re-bid didn't result in viable offers -
>     including any other offers from the incumbent possibly bidding
>     against themselves.
>
>
> extension occurs or a re-bid occurs, and that the recommendations on 
> that point come early in order to allow for either one to occur.  
> Extending the existing contract after bids have been received is not 
> one of the described possibilities, so any bid by the incumbent would 
> be based on a new RFP.   As a former contracting officer, I am sure 
> you understand that an incumbent bidding for a contract after a new 
> RFP is extremely common.

That's my understanding as well - it's what made sense from the released 
information - that the current contract would be terminated after this 
next renewal period in favor of issuing a new RFP.   Richard seems 
unconvinced.

I'm not sure what you mean by "described possibilities" - we'd have to 
wait until the RFP came out to find out the terms or so I would think. 
That said, it is *legally* possible to keep the current contract in the 
back pocket in the event of a bidding failure - but again - doesn't 
really pass the smell test.  I think when the the IAB/RSOC sent the 
notice to the RSE, they constructively gave notice of contract termination.

Note that while I'm extremely unhappy with losing Heather, I'm at least 
as unhappy with deciding 18-24 months out that the current contract 
needed to be terminated.  It makes absolutely NO business sense to do so 
in the given circumstances.    Stretches the definition of "early" by 
quite a bit.

Mike

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 19 Jun 2019 20:45:48 +0100

It may be cultural, but I find this “every time you post you have to drink a shot” to be inappropriate suppression of discussion. It does not add to the debate in anyway, but serves to shut down participation in the topic. 

I should be grateful if we were able to discuss what is clearly an emotionally charged topic focusing on the issues and concerns without resorting to this sort of rhetorical technique.

Thanks,

Adrian

From: ietf <[email-masked]> On Behalf Of Richard Barnes
Sent: 19 June 2019 19:49
To: Michael StJohns <[email-masked]>
Cc: John C Klensin <[email-masked]>; IETF Discussion <[email-masked]>
Subject: Re: RFC Series Editor Resignation

On Wed, Jun 19, 2019 at 11:34 AM Michael StJohns <[email-masked] <mailto:[email-masked]> > wrote:

Preparing for a re-bid after the first extension doesn't necessarily mean that the second extension won't be exercised.  Plans are just plans and circumstances could change.

Announcing a plan to re-bid at least 18 months and maybe more like 24 months ahead of a re-bid beginning suggests to me that the exercise of the second extension would only happen if the re-bid didn't result in viable offers - including any other offers from the incumbent possibly bidding against themselves.  

Lot of assumptions in here.  "Suggests to me" doesn't mean "necessarily follows".  

No - I don't think so. 

☕️🐝

--RLB

While its possible a later IAB or RSOC could change the conditions, I think what I said is a good representation of current reality.

Later, Mike

--Richard

On Wed, Jun 19, 2019 at 9:19 AM Mike StJohns <[email-masked] <mailto:[email-masked]> > wrote:

Mike

Sent from my iPad

> On Jun 19, 2019, at 11:55, Ted Lemon <[email-masked] <mailto:[email-masked]> > wrote:
> 
>> On Jun 19, 2019, at 11:47 AM, John C Klensin <[email-masked] <mailto:[email-masked]> > wrote:
>> 
>> Stewart,
>> 
>> <[email-masked] <mailto:[email-masked]> > wrote:
>>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 19 Jun 2019 23:17:11 +0200

On Wed, Jun 19, 2019 at 11:55:02AM -0400, Ted Lemon wrote:
> The amount of speculation going on here is impressive.

Yes. I feel like i am watching "Lost" or any other TV series based on
the premise that you keep the audience enticed by causing
speculations that never get resolved.

> FWIW, my main reaction to this is that I???m really sorry to hear that Heather is going. She???s been wonderful.

Yes, for me the RFC editor process has worked !!excellent!!, and it
seems thats also the comments from others on the list.

Then again, i wouldn't expect to learn about any actual issues
from public IETF mailing lists about any of the involved parties
RSOC, IAB, RSE and whoever else  is involved until much later
some strange new policy is published by someone more in the know
and all the IETF participants who are lost like me have to reverse
engineer why this new policy was proposed. IETF photography
policy comes to mind where i am still meeting at every IETF
people disagreeing on the actual causes why it came into place.

> I don???t know if there is any debugging required here, but I do know that no part of the debugging process can happen on this mailing list. I won???t ask you to stop, because you won???t.

Yes, speculation is is not helpfull. Transparency is. While there
may be questions obviously not to ask, there are a lot questions
where you may get a helpfull answer or you may have to
respect to not get an answer. These question should still be
fair to ask.

My question is simply whether there was anything negative
in the process that could be avoid in the future by better
policies and/or or execution. And if so, what.

> So perhaps we can have a drinking game. One shot of espresso every time someone speculates wildly. Two shots every time someone gets the length of the term wrong. Every time you post you have to dr…

Thank you, but i once fell into a cauldron of espresso in Milan,
so i am already hyperactive enough.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 20 Jun 2019 12:06:55 +1200

Mike,

> I'm unclear why they are making the decision on renewal without 
> community input

I think this is a key issue. I completely agree that the community
should not micro-manage either RSOC or IETF LLC in this matter. However,
community input on how the RFC Series is working and what needs to
be adjusted would be the obligatory first step, IMNSHO.

Regards
   Brian Carpenter

On 20-Jun-19 02:45, Michael StJohns wrote:
> .

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 20 Jun 2019 12:11:43 +1200

Hi Ted,
On 20-Jun-19 03:13, Ted Hardie wrote:
> On Tue, Jun 18, 2019 at 9:46 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
> First, you should note that this contract, like the others ISOC held on behalf of the IETF was assigned to the IETF LLC. 
> 
> 3.TERM:ISOC, at the request of the IAOC which is acting on behalf of the IAB and RFCSeries Oversight Committee (RSOC), desires to engage the Contractor to fulfill theresponsibilities of the RSE.
> a. Term: The term of this Agreement is two years (the “Term”) beginning on the Effective Date.
> b. Extensions: This Agreement may be extended twice by mutual written agreementof the parties (the “Extensions”), with each Extension being for a period of up to two years.
>  

Yes, but as Sarah said
 "The difference here is that the RSOC decided proactively to recommend to put the contract out to bid again" after the first (not the final) extension to the 2018 contract. That decision was two years ahead of the normal course of events, and that is what has surprised many of us.

   Brian

> The RSOC review Sarah referenced is the review which takes place every two years to consider these extension or, if no further extensions are permitted, to create an RFP.  In this case the RSOC recommended an extension, but Heather did not "mutually agree".
> 
> regards,
> 
> Ted Hardie

---

From: Leif Johansson <[email-masked]>
Date: Thu, 20 Jun 2019 17:36:40 +0200

On 2019-06-19 20:51, Ted Hardie wrote:
>     suggests to me that the exercise of the second extension would only
>     happen if the re-bid didn't result in viable offers - including any
>     other offers from the incumbent possibly bidding against themselves. 
> 
> 
> Extending the existing contract after bids have been received is not one
> of the described possibilities, so any bid by the incumbent would be
> based on a new RFP.   As a former contracting officer, I am sure you
> understand that an incumbent bidding for a contract after a new RFP is
> extremely common. 

As someone who has been responsible for several govt procurements and
contracts I offer this advise:

1. process is the means to the end, not the end in itself.
2. you never "exercise" a process without having a good sense of
the outcome.
3. never test in production - especially something as complex as a
tender/RFP process. If you don't know what you're doing, ask someone
with more experience.

Maybe we'll do better the next time we have the oportunity to work
with someone of Heather's caliber.

	Best of luck
	Leif

---

From: Leif Johansson <[email-masked]>
Date: Thu, 20 Jun 2019 17:36:46 +0200

Best of luck
	Leif

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 27 Jun 2019 06:06:08 +0000

I tried to follow the long email threads that followed this announcement. I do not think we need to figure out who is right and what we should have done, maybe only as a lesson learned . 
In my view, this is a case of not being right but being smart and I hope that RSOC took into consideration that the result of this decision will be the resignation of the RSE and has a plan.
I also hope that RSOC/IAB/... and whoever is involved in the processing of getting a new RSE will do it in a timely manner since having an RSE is important for us.

Having said that I would like to thank Heather for the work she has done as an authors of a couple of RFC.

Roni Even 

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Sarah B
Sent: Wednesday, June 19, 2019 1:56 AM
To: IETF Discussion
Subject: RFC Series Editor Resignation

Hello,

Kind regards,
Sarah Banks

---

From: Leif Johansson <[email-masked]>
Date: Thu, 27 Jun 2019 08:30:31 +0200

Skickat från min iPhone

> 27 juni 2019 kl. 08:06 skrev Roni Even (A) <[email-masked]>:

>  do not think we need to figure out who is right and what we should have done, maybe only as a lesson learned . 

Oh really?

Personally I think accountability has value.

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 27 Jun 2019 06:39:07 +0000

I think it should be as a lesson learned about the process and not who is to blame
Roni

-----Original Message-----
From: Leif Johansson [mailto:[email-masked]] 
Sent: Thursday, June 27, 2019 9:31 AM
To: Roni Even (A)
Cc: Sarah B; IETF Discussion
Subject: Re: RFC Series Editor Resignation

Skickat från min iPhone

Oh really?

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 27 Jun 2019 11:48:12 +0200

> Personally I think accountability has value.

There is a difference between backward accountability (blame assignment) and forward accountability (making sure the mistake is not made again, which implies understanding the mistake and why it was made in the first place).  I agree the latter has value.

Grüße, Carsten

---

From: "Stan Kalisch" <[email-masked]>
Date: Thu, 27 Jun 2019 12:58:59 -0400

> There is a difference between backward accountability (blame assignment) and forward accountability (making sure the mistake is not made again, which implies understanding the mistake and why it wa…

Not speaking to the specifics of this case, I would argue that sometimes the former done without animus (or with as little as humanly possible) can help foster the latter.

All people make mistakes. Sometimes, we can make "blame" less pejorative a word and still use it.

Thanks,
Stan

---

From: Randy Bush <[email-masked]>
Date: Thu, 27 Jun 2019 10:45:32 -0700

carsten,

> There is a difference between backward accountability (blame
> assignment) and forward accountability (making sure the mistake is
> not made again, which implies understanding the mistake and why it
> was made in the first place).  I agree the latter has value.

we have had an operational failure.  at least in the ops world, post
morta are usual in failure cases so that we can learn from the failure
and perhaps not set ourselves up to repeat history.  or worse. [0]

we are about to do a rushed patch to the entire network.  perhaps we
should have some confidence that the processes and plan will have a good
result.  if it is the process which broke, maybe not following it would
be wise, especially in in rush mode.  if it was (partially) the
processors, then maybe some change needs to be there.

and a good first look at the goal might not be a bad idea as well,
before we run toward it.  though maybe the result of the rfc++ bof in
bkk was a good goal check.

the belgians did shockingly well for 2.5 years without an elected
government; the civil service kept turning the wheels.  maybe the rfc
streams (pl) can still be processed for a bit while we try to design a
more failure resistant relationship with the rse process.

gedanken experiment: should the rse even be directly part of the
ietf/iab/... process, or be much more independent, e.g. a la the iana?

randy

---

0 - a lot of us are waiting to learn from vz for last week's exciting
    routing experiment

---

From: Ted Lemon <[email-masked]>
Date: Thu, 27 Jun 2019 13:52:25 -0400

> ietf/iab/... process, or be much more independent, e.g. a la the iana?

Is the IANA really independent in the sense that you mean?

---

From: Randy Bush <[email-masked]>
Date: Thu, 27 Jun 2019 10:57:33 -0700

> Is the IANA really independent in the sense that you mean?

to be honest, i do not know.  could be my perception.  but good
question.

they run multiple streams: protocols, names, numbers; only one of
which is 'ours'.

but we're down in the details.  i was just trying to jog us out of
assuming that we should follow the same path which has led to a clear
failure.

randy

---

From: Keith Moore <[email-masked]>
Date: Thu, 27 Jun 2019 15:32:35 -0400

> ietf/iab/... process, or be much more independent, e.g. a la the iana?

IMO, it's worth conducting that experiment  leaving out the "even" (and 
not implying an answer).

I frankly don't know what the answer is.   I see now, and have seen for 
as long as I've been associated with IETF, some advantages in having the 
RSE be independent.   But I also suspect that, in the long term, the 
more we fragment the I* community into different areas, supporting 
organizations, authorities, boards, and whatnot, the greater the 
tendency will be for those different groups to see different interests 
and, potentially, to work against one another in ways that are not 
constructive.    This is, I believe, a natural human tendency.

The processes and fragmentation we have in place now date from a time 
when pretty much everyone involved in Internet standards development 
shared a large set of common goals.  It's not clear that this is the 
case any longer.   Really, the division was becoming apparent by the 
mid-to-late 1990s though there was (and still is) some inertia.

If nothing else, if this fragmentation is going to continue, I think we 
should be looking for ways for the various interests to contribute to, 
agree on, maintain/evolve, and promote a shared vision of the 
Internet.   And also look for and maintain/evolve ways to resolve 
conflicts between different interests, with a minimum of disruption.

Regarding the RSE specifically, we have been extremely fortunate in the 
past and present to have excellent people filling those rather large 
shoes.   But I wonder if we should expect such good fortune to continue.

Keith

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 28 Jun 2019 15:28:53 +0000

On 6/27/19, 5:48 AM, "ietf on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

>    There is a difference between backward accountability (blame assignment) and forward accountability (making sure the mistake is not made again, which implies understanding the mistake and why it…

+1 to that. In my day job I've personally made mistakes that led to customer-impacting outages, as have my teams, and it is often natural for folks to fear being blamed (and fired/sanctioned). Few good ideas or discussion arise when everyone is in a defensive and/or attacking state of mind. And so I always liked to say *** "let's fix the problem, not the blame" ***. I have found that to be a constructive way re-frame a discussion, and thus to look ahead and ask how we can prevent this from occurring in the future. Usually a situation developed because some process was flawed or due to a lack alignment between responsibility & accountability, etc. This also means granting a bit of trust in colleagues and acknowledging that everyone is doing their best to achieve what they think will best serve the situation/platform/org/etc. This can be hard to do, but it is a healthy step that can make an org stronger.

Jason

---

From: Michael StJohns <[email-masked]>
Date: Fri, 28 Jun 2019 13:38:21 -0400

On 6/28/2019 11:28 AM, Livingood, Jason wrote:
> Usually a situation developed because some process was flawed or due to a lack alignment between responsibility & accountability, etc. This also means granting a bit of trust in colleagues and acknowledging that everyone is doing their best to achieve what they think will best serve the situation/platform/org/etc. This can be hard to do, but it is a healthy step that can make an org stronger.

Hi Jason -

The problem is that whatever trust I (we?) might want to grant in this 
case is diminished by past actions such as the rfcplusplus bof, and in 
the current instance, an explanation of behavior by the RSOC that 
doesn't meet the smell test.

This also begs the question of what were they actually trying to achieve 
and whether we the community believe those to be worthy goals.

A few of the other questions that should be asked in the post-mortem of 
this stupidity* is "Why did the RSOC find it necessary to take the 
actions it took without any community input whatsoever?" and "Did the 
IAB have any pre-knowledge of the actions that were about to be taken?"

Mike

* With respect to the term "stupidity", this was the least offensive 
term I was able to come up with that had the appropriate impact in the 
above statement. This is not an "unfortunate event" or a "well meaning 
action" or even a "mistake". "Stupidity" at least leaves the question of 
malign intent open.    Feel free to come up with your own terms.

---

From: Leif Johansson <[email-masked]>
Date: Fri, 28 Jun 2019 20:21:00 +0200

Skickat från min iPhone

> 28 juni 2019 kl. 19:38 skrev Michael StJohns <[email-masked]>:
> 
> The problem is that whatever trust I (we?) might want to grant in this case is diminished by past actions such as the rfcplusplus bof, and in the current instance, an explanation of behavior by the RSOC that doesn't meet the smell test.
> 
> This also begs the question of what were they actually trying to achieve and whether we the community believe those to be worthy goals.
> 
> A few of the other questions that should be asked in the post-mortem of this stupidity* is "Why did the RSOC find it necessary to take the actions it took without any community input whatsoever?" and "Did the IAB have any pre-knowledge of the actions that were about to be taken?"
> 
> Mike

Really looking forward to clear & concise answers to those two questions too. Should not be hard to do.

> 
> 
> * With respect to the term "stupidity", this was the least offensive term I was able to come up with that had the appropriate impact in the above statement. This is not an "unfortunate event" or a "well meaning action" or even a "mistake". "Stupidity" at least leaves the question of malign intent open.    Feel free to come up with your own terms.
> 

I have a catalogue of terms of my very own.

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 28 Jun 2019 16:45:04 -0500

Hi Mike,

> malign intent open.    Feel free to come up with your own terms.

I appreciate that you have put thought into your phrasing.  However, this
term nonetheless fails to meet the bar for professional conduct required
by RFC 3005.  We must treat each other with courtesy, even when we find
events to be disconcerting.  Making observations about the situation is
reasonable; attacking community members is out of bounds.

Thanks,

Ben
for the Sergeant-at-Arms

---

From: "Theodore Ts'o" <[email-masked]>
Date: Fri, 28 Jun 2019 17:55:52 -0400

> reasonable; attacking community members is out of bounds.

Ben,

I interpreted Mike's statement as saying the *decision* was stupid,
and not that an individual had a low IQ.  "This stupidity" doesn't
appear to be an attack on an individual.

Do you disagree?

					- Ted

---

From: Michael StJohns <[email-masked]>
Date: Fri, 28 Jun 2019 17:58:52 -0400

> reasonable; attacking community members is out of bounds.

With respect  - no.   Please read above more closely.   The situation is 
stupid.  "post-mortem of this stupidity".  If you choose to attribute 
stupidity to a community member so be it.

In any event, the general model is to first have a private discussion 
with the prospective offendee describing what you found offensive and 
why before public sanction.  Please try and do all of us that courtesy 
the next time.

Mike

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 28 Jun 2019 18:22:06 -0500

> stupidity to a community member so be it.

With respect, I have a hard time seeing how there can be stupidity without
some*one* being stupid -- inanimate objects don't have motive or
intelligence.  Especially so when seen alongside talk of "intent", which to
me at least seems clearly tied to one or more individuals' actions.
Feel free to tell me more about how I'm wrong (but that's probably better
off-list -- I don't anticipate an IETF working group that handles the
subtleties of the English language).

> why before public sanction.  Please try and do all of us that courtesy 

That is the general model, yes, and one that is followed most of the time.
There is a countervailing force, though, in the form of the risk that
observers will see silence as tacit approval.  As Sergeant-at-Arms, I'm
tasked with keeping the discussion forum a professional environment for all
participants, and sometimes that involves sending a public signal about
what behavior is expected.
I sympathsize with your frustration and I want the same answers that you
do, but this is a hard conversation for the community to be having, and
adding into the mix remarks that come off as personal attacks will just
make it harder.

-Ben

---

From: Keith Moore <[email-masked]>
Date: Fri, 28 Jun 2019 19:45:19 -0400

On 6/28/19 7:22 PM, Benjamin Kaduk wrote:

> some*one* being stupid

As far as I can tell, exactly this happens all the time. Well-meaning, 
intelligent people often produce "stupid" results, especially in 
collaboration with one another, which were difficult for the 
collaborators to anticipate, without any person or people actually 
exhibiting lack of intelligence or malice.

(This is NOT a statement on the specific nature of the conditions 
leading to the current disappointment about the RSE situation. I'm too 
distant from that to tell what happened there.)

Keith

---

From: "Theodore Ts'o" <[email-masked]>
Date: Fri, 28 Jun 2019 20:15:46 -0400

On Fri, Jun 28, 2019 at 07:45:19PM -0400, Keith Moore wrote:
> collaboration with one another, which were difficult for the collaborators
> to anticipate, without any person or people actually exhibiting lack of
> intelligence or malice.

Indeed:

https://thriveglobal.com/stories/why-smart-individuals-make-dumb-group-decisions/

						- Ted

---

From: Michael StJohns <[email-masked]>
Date: Sat, 29 Jun 2019 18:23:22 -0400

Hi -

I'm going to top post because replying to this line by line isn't really 
the best way to dispose of this part of the thread.  And as someone 
noted, if I remained silent it might be taken as implicit approval of 
what I consider a unsupportable take on "stupidity" as described below.

As other's have noted, its possible for smart people to do stupid 
things.  It's even possible to get a stupid result (or " this 
stupidity") with many smart people doing perfectly reasonable things.  
Note that I'm not claiming this is the current case.

In the instant case, this was a stupidity because it was a _completely 
foreseeable result_ that was _completely avoidable_, but the result had 
many many parents:

1) The community for not more carefully constraining the IAB's assertion 
of authority over the RFC process.
2) The IAB for delegation of said authority to the RSOC without 
carefully constraining its exercise.
3) The IAB for not paying attention to the result of the RFC++ bof
4) The IAB for replacing the majority of the RSOC post the RFC++ bof 
without input from the RSE, and in apparent violation of one of the 
guiding principles of the RSOC - that of maintaining continuity from 
year to year.
5) The community for not yelling a lot louder and longer when (4) happened.
6) The community, IAB and RSOC for not appreciating the value of a world 
class professional editor/publisher to the continued excellence of the 
RFC series, and for not expressing that appreciation in the form of 
professional deference and independence rather than what appears to have 
been more of a "you contractor, me boss"* model.
7) The RSOC for ... well - you know.
8) The LLC for not paying better attention to the relationship between 
contractor and contractee.

I'm sure there are others.

To finish up - I appreciate that the Sargent at Arms has to walk a fine 
line here, but I don't think this is even close.  Again, I'd appreciate 
it if in the future we follow the general contract and first have 
private conversations.   You'll  have plenty of time afterward to make 
your explicit disapproval clear if necessary.

Also I'd really appreciate it if you don't attribute a particular 
emotion to my persistence with this set of discussions - it's yet 
another form of demeaning behavior. You attributed "frustration", and 
another I* attributed "upset" to me.  What I actually am is "sad" at the 
state of affairs and "disappointed" in the various folk that caused this 
stupidity to occur somewhat including myself.  Feel free to use either 
of those words in future correspondence.

Mike

*About a year ago, shortly after the RFC++ bof, I had a conversation 
with one of the I* who I will not name about the disconnect between what 
I though the RFC editor job was and what I was seeing the I* push.  The 
phrase "she's just a contractor" is a direct quote from that conversation.

---

From: Nick Hilliard <[email-masked]>
Date: Sun, 30 Jun 2019 00:37:13 +0100

> contractor and contractee.

also:

- not soliciting input from / listening to / acting on what the RSE says

Heather's resignation was deeply unfortunate and almost certainly 
completely avoidable, but having been the RSE, the various oversight 
committees need to understand that she will have insights into the 
position and function of the RSE that they will never have.

If her viewpoints and wisdom are not taken into account now, the 
likelihood is that all the mistakes which have led to this situation 
will be repeated in future.  This would be tragically unnecessary.

This goes well beyond the mantra of "oh, let's reform stuff".  It means 
frank and open discussion, a willingness to accept constructive 
criticism, taking Heather's viewpoints on board and actually doing 
something about them.  This is not easy, but it is necessary.

A good starting point would be: "can you identify and if so, how would 
you fix the problems which ultimately led to your resignation"?

Nick