Subject: RSE Independence

From: Michael StJohns <[email-masked]>
Date: Fri, 28 Jun 2019 17:16:40 -0400

Hi -

In one of the threads relating to the RSE resignation, someone (I think 
Richard Barnes) asked the existential (and probably misquoted by me) 
question of "why does the RSE need independence?".  I thought I'd 
provide my thoughts on that.  There are actually two different 
independence discussions - one of the RSE as a contractor, and another 
of the RSE as a editor/publisher.   Both are important.

Practical/RSE as a contractor: 
https://www.quotemaster.org/Dilbert#&gid=1&pid=7

There are two types of individual contractor I want to talk about: One 
that is plug-compatible for functions where you might need more or less 
effort over time.  That's the "body shop" model where you hire HR folks 
or IT or janitorial services, security guards, or even programming 
services in a common field of endeavor (current example is IOT).  The 
second is the subject matter expert who provides niche or hard to find 
skills.  From a hiring point of view, you're might use the same job 
description to hire 100s of the same type of body-shop contractor, but 
you're rarely going to hire more than 1 or 2 people on a subject matter 
job description.

Hiring managers sometimes confuse the two.  For the the former, the 
hiring manager generally understands the job, and can bring a value-add 
to the discussions of how to make the job more efficient (cost and 
time).  For the latter, the hiring manager rarely understands the 
nuances of the field being contracted, and needs to restrain their 
impulses to give direction or advice to the contractor in how to perform 
the job due to the real risk of wasting or diluting the investment in 
the SME.    An SME should be a "fire and forget" asset that you tell 
what you want as the end game and then you get the hell out of the way 
and let them do it.

In the current incumbent RSE we have an SME in the arcane field of 
standards publication - a subset of technical editing and publication.  
I mostly don't know what that entails, except that it gets us 
well-edited RFCs and lots of them, a new RFC format, DOI's and probably 
other nuances.  I'm fine with that because "I am not a technical writer 
or a publisher" and other than saying "I think being able to put 
pictures and diagrams in the RFC is a good thing", I mostly wouldn't 
presume to try and out expert this expert.

What I'm trying to say a bit obliquely is that it's unclear whether the 
extent of "oversight" that the IAB has given itself and the RSOC over 
the RSE is more beneficial to the mechanics of publishing RFCs or has 
had an adverse or nil effect.  Does the cost vs benefit meet general 
business practices and community needs?   Should the RSOC restrain 
itself to simply monitoring compliance with the SOW or is there a bigger 
role for it on a day to day basis with the RSE?  My general view is 
hands off, but I'm willing the be persuaded if there's a clear benefit  
for the community, RSE and series to some other approach.

Lastly, the contract now resides with the LLC.  That makes three 
organizations within the I* structure that claim some authority over the 
RSE.  From a legal point of view, that can be problematic. If you've 
been involved in contracting on either side, you'll probably 
understand.  For the rest of you, go talk to a lawyer as there are 
nuances and rat holes galore.  My recommendation at this point given 
that the LLC legally owns the contract would be to have the LLC figure 
things out a bit more and comes up with an MOA of some sort (similar to 
the US Gov't concept of a Contracting Officer's technical 
representative) for the appropriate group to advise them.

Aspirational:  RSE/ISE independence as a editor/publisher

 From 1969 until the AMS transition of publication services in 2009 and 
the RSE contract in 2012 the RFC Editor was an independent organization 
providing publication services to the I* community.   In 2007 the 
community, not wishing to lose one of Jon's legacies, formalized the 
Independent stream and submission process.  The related documents 
described the history of independent submissions, the importance of such 
submissions, and the path forward.

Snippet from the abstract for RFC 4846:

>     There is a long-standing tradition in the Internet community,
>     predating the Internet Engineering Task Force (IETF) by many years,
>     of use of the RFC Series to publish materials that are not rooted in
>     the IETF standards process and its review and approval mechanisms.
>     These documents, known as "Independent Submissions", serve a number
>     of important functions for the Internet community, both inside and
>     outside of the community of active IETF participants.

I'm not going to repeat the high points of this document here, but 
suffice it to say that the independent stream provides a place for 
"other voices" - for dissent, for humor, for continuing discussion on 
what we are as a community, for cross publication of important technical 
knowledge, for radical proposals, for history, for remembrances - to 
speak without veto of the I* leadership and the I* participants.  I 
believe that principle to be as important as any of the RFC's we've 
published over the years and is an important part of what differentiates 
the I* from other technical communities.

I mention the ISE because of the timeline.  The I* of the time found the 
concept of independent submissions so important and was nervous about 
the eventual transfer of the RFC series from ISI and the stewardship of 
Bob and Joyce that they institutionalized it in a separate person almost 
5 years from that final transition.   I suspect had we done things in 
slightly different order - RSE first - AND written in the independent 
stream as part of that process, that we wouldn't have a separate ISE, 
instead incorporating that independent stream under the RSE.

Continuing on - we as a community benefit from a thoughtful and 
independent publication process.  Doing it the way we have tends to 
prevent capture of the process by one or another groups of more limited 
interest or focus.  Under the general rubric of "Internet" we publish 
things today (e.g., IoT, web services) that weren't contemplated when 
the series started.  It's evolved as we have, and more importantly as 
the wider community of internet related users have.

We've gotten lucky to have had professional, thoughtful and dedicated 
editors such as Jon, Bob & Joyce, and Heather.  All of these are/were 
more than "just contractor"s and made us look good in spite of 
ourselves.  If we're not careful we'll get just what some folks are 
asking for - a non-independent editor who has no incentive to rise above 
our diminished expectations.

Mike

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 29 Jun 2019 11:06:56 +1200

I'd like to pick out two of Mike's sentences for additional comment:

> What I'm trying to say a bit obliquely is that it's unclear whether the extent of "oversight" that the IAB has given itself and the RSOC over the RSE is more beneficial to the mechanics of publishing RFCs or has had an adverse or nil effect.  

BCP39, the IAB Charter (of which I was the document editor of record), doesn't as far as I can see give the IAB a duty of "oversight" of the RFC Editor.

> That makes three organizations within the I* structure that claim some authority over the RSE.  From a legal point of view, that can be problematic.

In fairness, one of the three (RSOC) presumably claims authority delegated by another (IAB). Of course, a delegator should never interfere with the authority of the delegatee. In any case, more than one authority over an entity is a *managerial* recipe for problems, as well as a legal one.

    Brian

On 29-Jun-19 09:16, Michael StJohns wrote:
> Hi -
> 
> In one of the threads relating to the RSE resignation, someone (I think Richard Barnes) asked the existential (and probably misquoted by me) question of "why does the RSE need independence?".  I thought I'd provide my thoughts on that.  There are actually two different independence discussions - one of the RSE as a contractor, and another of the RSE as a editor/publisher.   Both are important.
> 
> 
> Practical/RSE as a contractor:   https://www.quotemaster.org/Dilbert#&gid=1&pid=7 
> 
> There are two types of individual contractor I want to talk about: One that is plug-compatible for functions where you might need more or less effort over time.  That's the "body shop" model where you hire HR folks or IT or janitorial services, security guards, or even programming services in a common field of endeavor (current example is IOT).  The second is the subject matter expert who provides niche or hard to find skills.  From a hiring point of view, you're might use the same job description to hire 100s of the same type of body-shop contractor, but you're rarely going to hire more than 1 or 2 people on a subject matter job description.
> 
> Hiring managers sometimes confuse the two.  For the the former, the hiring manager generally understands the job, and can bring a value-add to the discussions of how to make the job more efficient (cost and time).  For the latter, the hiring manager rarely understands the nuances of the field being contracted, and needs to restrain their impulses to give direction or advice to the contractor in how to perform the job due to the real risk of wasting or diluting the investment in the SME.    An SME should be a "fire and forget" asset that you tell what you want as the end game and then you get the hell out of the way and let them do it. 
> 
> In the current incumbent RSE we have an SME in the arcane field of standards publication - a subset of technical editing and publication.  I mostly don't know what that entails, except that it gets us well-edited RFCs and lots of them, a new RFC format, DOI's and probably other nuances.  I'm fine with that because "I am not a technical writer or a publisher" and other than saying "I think being able to put pictures and diagrams in the RFC is a good thing", I mostly wouldn't presume to try and out expert this expert.
> 
> What I'm trying to say a bit obliquely is that it's unclear whether the extent of "oversight" that the IAB has given itself and the RSOC over the RSE is more beneficial to the mechanics of publishing RFCs or has had an adverse or nil effect.  Does the cost vs benefit meet general business practices and community needs?   Should the RSOC restrain itself to simply monitoring compliance with the SOW or is there a bigger role for it on a day to day basis with the RSE?  My general view is hands off, but I'm willing the be persuaded if there's a clear benefit  for the community, RSE and series to some other approach.
> 
> Lastly, the contract now resides with the LLC.  That makes three organizations within the I* structure that claim some authority over the RSE.  From a legal point of view, that can be problematic. If you've been involved in contracting on either side, you'll probably understand.  For the rest of you, go talk to a lawyer as there are nuances and rat holes galore.  My recommendation at this point given that the LLC legally owns the contract would be to have the LLC figure things out a bit more and comes up with an MOA of some sort (similar to the US Gov't concept of a Contracting Officer's technical representative) for the appropriate group to advise them.
> 
> 
> From 1969 until the AMS transition of publication services in 2009 and the RSE contract in 2012 the RFC Editor was an independent organization providing publication services to the I* community.   In 2007 the community, not wishing to lose one of Jon's legacies, formalized the Independent stream and submission process.  The related documents described the history of independent submissions, the importance of such submissions, and the path forward.
> 
> I'm not going to repeat the high points of this document here, but suffice it to say that the independent stream provides a place for "other voices" - for dissent, for humor, for continuing discussion on what we are as a community, for cross publication of important technical knowledge, for radical proposals, for history, for remembrances - to speak without veto of the I* leadership and the I* participants.  I believe that principle to be as important as any of the RFC's we've published over the years and is an important part of what differentiates the I* from other technical communities.
> 
> I mention the ISE because of the timeline.  The I* of the time found the concept of independent submissions so important and was nervous about the eventual transfer of the RFC series from ISI and the stewardship of Bob and Joyce that they institutionalized it in a separate person almost 5 years from that final transition.   I suspect had we done things in slightly different order - RSE first - AND written in the independent stream as part of that process, that we wouldn't have a separate ISE, instead incorporating that independent stream under the RSE.
> 
> Continuing on - we as a community benefit from a thoughtful and independent publication process.  Doing it the way we have tends to prevent capture of the process by one or another groups of more limited interest or focus.  Under the general rubric of "Internet" we publish things today (e.g., IoT, web services) that weren't contemplated when the series started.  It's evolved as we have, and more importantly as the wider community of internet related users have. 
> 
> We've gotten lucky to have had professional, thoughtful and dedicated editors such as Jon, Bob & Joyce, and Heather.  All of these are/were more than "just contractor"s and made us look good in spite of ourselves.  If we're not careful we'll get just what some folks are asking for - a non-independent editor who has no incentive to rise above our diminished expectations.
> 
> Mike
> 
>