Subject: Re: baffled Re: Energy saving as an IETF goal (mostly, I hope. off topic)

From: Toerless Eckert <[email-masked]>
Date: Thu, 1 Aug 2019 22:02:55 +0200

Indeed. My examples of why Internet technologies have been a big
reducer of energy consumption primarily also was focussed on
non-meeting/collab examples like telecommuting, tele-services,
e-transportation instead of physcial transportation and the like.
And this was all just directed at Eliots question of
how to explain to kids what the overall benefit is of what we do,
which should be IMHO a question simple to answer for us.

I have been frustrated for decades now about the lacking adoption
of our own tele-collaboration dog-food, i just think while the
energy-saving discussion is also very interesting in its own
right, we probably make more progress on both of them if we start
by not mixing them up. Because for example, we are doing the enery
saving subject a bad service when we limit it to the conferencing
use-case and vice versa.

Cheers
   Toerless

On Sat, Jul 27, 2019 at 11:37:47AM -0400, John C Klensin wrote:
> Noting Melinda's comment about what we actually do -- with while
> I strongly agree, I've been intermittently following the
> question of how improved two-way or multiway international
> communication changes travel patterns.  The story goes back to
> the realization that, with email and (even) first-generation
> list management and Usenet systems, communication and working
> with someone halfway around the world could be as inexpensive,
> and often as efficient, as working with someone who lived next
> door.  The number of international collaborations increased.
> Because of the value of f2f conversations identified in a
> different thread in the last few days,  so did travel to
> meetings that previously would have involved mostly or entirely
> people from a rather small region.
> 
> At least in retrospect (but there were scholars in the 80s and
> earlier who predicted it), what would we expect?
> 
> We tend to praise the increase in international collaborations
> and other interactions and curse the increased travel, but they
> may go together.
> 
>    john
> 
> 
> 
> 
> --On Friday, 26 July, 2019 13:37 -0700 Jacob Hoffman-Andrews
> <[email-masked]> wrote:
> 
> >  > In 2018, passenger activity increased by 6.1% to 8.2
> > trillion revenue passenger kilometres, and the number of total
> > air passengers reached a record 4.3 billion (ICAO, 2019a).
> > This activity growth is a slowdown from the 7.9% increase
> > registered in 2017, however, with regional growth rates in
> > 2018 ranging between 4.7% and 7.3%.
> > 
> > I agree that online collaboration has the *potential* to
> > reduce emissions. However, it is not fulfilling that
> > potential. That's why we need to walk the talk and demonstrate
> > how to collaborate effectively online, so other industries can
> > adopt our methods and tools.
> 
> 
> 

-- 
---
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Thu, 1 Aug 2019 16:25:34 -0400

I pretty much agree with this. I think we should really work on our telecollaboration fu  regardless of what we think about agw and flying because our failure to do so is holding us back and making us less effective. 

Sent from my iPhone

> On Aug 1, 2019, at 4:02 PM, Toerless Eckert <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 1 Aug 2019 22:51:05 +0200

Is there any existing mailing list where the topic of virtual IETF
meeting can be moved to ?

I checked the manycouches archive and the last post was from me in
april. If thats the only place where the discussion was supposed to
happen until now, i can only conclude that there is not enough energy
in the community itself to come up with proposals.

Then again, manycouches is not listed on the non-wg mailing page, so
i don't even have an idea how that list could have been created, but
if it was done so hush-hush, maybe thats a reason why there isn't much
traffic on it.

I can see how you want to push the ask to people who should do it
as part of their job responsibility (LLC), but hasn't past experience
shown that that the community is mostly not happy with stuff where
its not involved in the process ?

Aka: Instead of trying to only ask to outsource to LLC or the like
and come up with baked solutions, maybe it would be better to ask
someone with a job responsibility to take a lead with at least an
experiment first.

Eg: Lets have one AD coordinate a virtual interim for just one area. Maybe
two..three days. Maybe two tracks in parallel. One doing educational
presentations to attract audience to WGs (PPTX highly welcome, please
also post questions upfront to presenters), and one doing actual work
on documents (PPTX mostly despised ?), and the webex for the work
meetings could be independent of each other, so people can stay on
the channels and work overtime if they don't have conflict (its not
as if the rooms cost real money).

Aka: experimentation shouldn't only save travel pains but also attempt
to improve on other shortcomings of our physical meeting structure (such as
in my example the conflict between finishing draft and educating
interested candidate participants as well as physical limits on number
of rooms).

Cheers
    Toerless

On Fri, Jul 26, 2019 at 08:27:00AM -0400, Eliot Lear wrote:
> Don, others who think three meetings are the right number,
> 
> > On 25 Jul 2019, at 10:46, Donald Eastlake <[email-masked]> wrote:
> > 
> > I am also in favor of keeping three meetings a year.
> 
> 
> Why three?  Why not four, two, five?
> 
> Here is my claim: we can fly less and be more effective.  I am asking simply that the LLC in consultation with the IESG test that statement by finding the right questions, collecting and analyzing data, and then bring the results of their analysis with recommendations to the community for our consideration.
> 
> I take seriously the need for hallway conversations, hackathons, ad hocs, in addition to our formal meeting time.  That has to be taken into account.
> 
> But it has been some 28 years since we went to three meetings per year.  Let???s please do the work to understand what options we have.  That???s my request.  Do you disagree?
> 
> Eliot

---

From: Ted Lemon <[email-masked]>
Date: Thu, 1 Aug 2019 17:01:55 -0400

I don’t see any point in asking an ad to take this on unless one wants to. I think any couches is a great place to take this conversation. I tried to start a conversation about this there in Prague but then didn’t have time to actually work on it between then and Montreal. I think what happened there would be useful to talk about. 

But the bottom line for me at the moment is that this has to be done incrementally in ways that help me to be more effective in the IETF, not as a forklift upgrade. 

Sent from my iPhone

> On Aug 1, 2019, at 4:51 PM, Toerless Eckert <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 1 Aug 2019 23:17:08 +0200

On Thu, Aug 01, 2019 at 05:01:55PM -0400, Ted Lemon wrote:
> I don???t see any point in asking an ad to take this on unless one wants to.

My thinking is that if we want a WG to do something we need WG chair
sponsorship. If we want to have an area do something we need AD
sponsorship. If the scope of the experimeent would go beyond area,
sponsorship becomes even more convoluted. Hence scope area seems
a good experiement.

Yes, the AD would not have to be running the show, but needed beyond
sponsoring also to click all the right buttons in all the right
tools. If we had volunteers to take care of the logistics/plan the
experiment, even better.

[ Shall i dare to say that networking folks have volunteered for
decades, its called the Noc. So where are the application/conferencing
layer volunteers ? Wheren't the application layer folks supposed to
take over the IETF anyhow ? (yes, i know, its a lame attempt at public
shaming to improve things, i am not Greta ;-) ]

> I think any couches is a great place to take this conversation. I tried to start a conversation about this there in Prague but then didn???t have time to actually work on it between then and Montreal. I think what happened there would be useful to talk about. 

So, move this discuss to [email-masked] ? and ask
the other folks on this thread who would like to be part of the
solution to join too ?

> But the bottom line for me at the moment is that this has to be done incrementally in ways that help me to be more effective in the IETF, not as a forklift upgrade. 

Sure, please communicate your best idea of a meaningfull experiment
(unless you already did earlier on manycouches before i joined, then
i'll have to dig it up).

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Thu, 1 Aug 2019 17:19:08 -0400

Nope, that’s where I dropped the ball. I will try to post something, but don’t wait for me. 

Sent from my iPhone

> On Aug 1, 2019, at 5:17 PM, Toerless Eckert <[email-masked]> wrote:
>

---

From: George Michaelson <[email-masked]>
Date: Fri, 2 Aug 2019 08:35:09 +1000

I asked my partner if she'd support a move to twice yearly F2F at hubs
(less flying overall, less flights per trip since hub-based) and
teleconference even given the timezone consequences and she said
emphatically yes.

>From a personal perspective, I think we could reduce net carbon cost
on our process and impact on family, if we went to two, stopped
demanding multi-hop segment flight, and used remote processes more
effectively.

I hate to say it, but in the light of Christian Huitema's excellent
research work on impact/delay I think its possible we'd actually be
more productive, if we constrained our interminable wordsmithing, and
avoided microphone queues.

-George

---

From: Alissa Cooper <[email-masked]>
Date: Fri, 2 Aug 2019 14:21:00 -0400

Hi Eliot,

Thanks for writing this up. You can see that the LLC Board has an agenda item to start discuss it on our next call on August 7 [1]. We had some initial discussion some months back about whether to work on an environmental impact policy as part of our initial set of organizational policies and did not end up prioritizing it given the rest of the bootstrapping effort, but it’s certainly worth coming back to. 

Some of the concerns you raise are more about what the community wants and needs as far as meeting cadence, which puts them less in the purview of the LLC and more in the purview of the IESG as far as synthesizing what the community is looking for. Therefore I’ve started a discussion within the IESG about this.

Of course any changes we make need to account for existing policies (draft-ietf-mtgvenue-meeting-policy in particular), the fact that we have venues booked several years in advance already, the fact that we have pre-announced our meeting dates to the Internet community even more years in advance, ongoing discussions with potential future meeting hosts and venues about specific dates and locations, etc. In short, immediate change here is unlikely to be feasible, so hopefully no one is expecting that.

Thanks again,
Alissa

[1] https://www.ietf.org/media/documents/2019-08-07_-_Agenda_-_LLC_Board_Meeting.pdf

> On Jul 22, 2019, at 6:09 PM, Eliot Lear <[email-masked]> wrote:
> 
> Hi everyone,
> 
> From time to time we talk about changing our meeting modalities, and we certainly have done so a bit.  Not so much the plenary, face to face meetings.  For the last 28 years or so, we’ve been meeting three times per year (previously it was four!), and we will continue to do so for a while.  But it’s at least possible that we could meet more effectively and maybe even with fewer plenaries.
> 
> Many of us travel great distances just to attend a handful of working groups, especially if we are specialized.  And those working groups meet for an hour or two, and then modulo the hallway conversations, were done.  Being perfectly frank about my own motivations, my daughter wants to know why I generate so much CO2, in what is all too fast becoming her generation’s greatest challenge, and our generation’s greatest shame.
> 
> Even so, I am not prepared to propose any particular recommendation, but rather find a way to get to that point through a concerted professional effort that is not performed on the ietf mailing list ;-)
> 
> And so draft-lear-we-gotta-stop-meeting-like-this asks the LLC *not* to change our meeting structure, but to bring in the right people to study it in consultation with the IESG, and then to come back with some recommendations for the community’s consideration.  There are no timetables in the draft.  That’s because this might take some time.  And yes there are some financial impacts to be considered, not to mention human impact, not just on standards making, but on the valuable work being done at the Hackathon, and in other activities that colocate with us.
> 
> Anyway, have a read.  See what you think.  I’ll be mentioning this at a mic comment in the plenary.
> 
> Eliot

---

From: Eliot Lear <[email-masked]>
Date: Fri, 2 Aug 2019 21:21:09 +0200

Hi Alissa,

> On 2 Aug 2019, at 20:21, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Eliot,
> 

Thanks for taking this up on the agenda, and to all those who chimed in during the discussion who shared views.

> Some of the concerns you raise are more about what the community wants and needs as far as meeting cadence, which puts them less in the purview of the LLC and more in the purview of the IESG as far…

An even busier lot!  And again, I appreciate your (collective) time and consideration.

> Of course any changes we make need to account for existing policies (draft-ietf-mtgvenue-meeting-policy in particular), the fact that we have venues booked several years in advance already, the fac…

Precisely so.  Again, the purpose of all of this is simply for leadership to have a good think about what sort of options the community might have or want some years down the road.

Eliot

---

From: Fernando Gont <[email-masked]>
Date: Mon, 5 Aug 2019 14:02:53 +0300

On 25/7/19 18:41, S. Moonesamy wrote:
> Dear Fernando,
> At 05:28 AM 24-07-2019, Fernando Gont wrote:
>> I can tell you that it is extremely difficult (if at all possible) to
>> have your employer support your IETF work in regions such as Latin
>> America and the Caribbean.
> 
> One of the questions which I have received from a few
> participants/potential participants  residing in a few countries in
> Africa was about how to get employer support for IETF activities.  In my
> opinion, those persons may have encountered situations similar to the
> one mentioned above.

Not surprised. I would be quite surprised the other way around: if they
have encountered support. Same applies for the LAC region (modulo
exceptions such as e.g. NICs)

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Fernando Gont <[email-masked]>
Date: Mon, 5 Aug 2019 14:10:00 +0300

On 23/7/19 21:44, Keith Moore wrote:
> On 7/23/19 2:10 PM, Fernando Gont wrote:
> 
>> On 23/7/19 16:18, Eric Gray wrote:
>>> Look at the impact of near-zero cost mailing (in the form of E-Mail)
>>> on the tremendous volume of trash we all receive, even after
>>> filtering, and extend that to zero cost participation in the IETF.
>>>
>>> There is value in having to pass some form of "is it worth it" test -
>>> no matter who will be actually paying for it.
>> That may as well keep valuable people out, and making meetings be the
>> turf of big companies that can afford it.
> 
> even worse than it already is.   (yes, I agree)

Indeed.

---

From: Erik Nygren <[email-masked]>
Date: Wed, 7 Aug 2019 21:53:57 -0400

I'd also agree that this is an interesting and important topic.
In talking with some colleagues, it also has the potential to bring
in people to the IETF who have otherwise not yet been motivated to
participate.

There are likely a wide range of avenues to explore.  On the server and
network
device side, I suspect a common theme will be looking at ways to reduce
server utilization and/or to be able to power down network devices.
(eg, see this paper from a few years back:
https://arxiv.org/pdf/1109.5641.pdf)

Design choices being made in QUIC or other protocols that result in
measurably
higher CPU usage on servers and/or network devices and/or clients has
a direct impact on their energy consumption.  There may be conversations to
be
had as to whether a few percent performance improvement, or some small
privacy improvement, is always worth the added power utilization.

If U.S. data centers are projected to consume 73 billion kWh in 2020 [1],
then a change in a widespread protocol that increases average CPU resource
usage by 0.1%
across the board has a 73 million kWh impact in the U.S. alone.

For people interested in this topic, it was pointed out to me that
the ACM now has an emerging interest group EIG-ENERGY (
https://energy.acm.org/)
and its next conference has a paper-submission deadline for February:
   https://energy.acm.org/conferences/eenergy/2020/index.php

Best,

  Erik

[1] https://eta.lbl.gov/publications/united-states-data-center-energy

On Wed, Jul 24, 2019 at 2:54 PM Jari Arkko <[email-masked]> wrote:

> I think it is an interesting topic and very much on topic for us to think
> about. And a topic where potential savings could be significant. IT is a
> huge energy consumer (as well as a producer of short-lived gadgets). IT
> also has the potential to help optimise many non-IT processes, and
> therefore directly reduce energy consumption and waste.
>
> But of course this is also complex topic and not one where only IETF or
> only standards help. And a topic where continuous improvements in compute
> and comms are often offset by more high res videos and ever growing
> software packages (as well as auto-play and zillions of adverts, placed on
> my screen after way too much ML analysis).
>
> I’d be eager to work on this, assuming we can come up with proposals that
> can have an impact.
>
> Jari
>
>

---

From: Keith Moore <[email-masked]>
Date: Wed, 7 Aug 2019 22:13:04 -0400

On 8/7/19 9:53 PM, Erik Nygren wrote:

> a direct impact on their energy consumption.  There may be 
> conversations to be

Is there any ongoing effort in or near IETF to compare the energy 
consumption of implementation of new protocols with that of existing 
protocols?

Maybe some RFCs need an Energy Considerations section?   This isn't 
solely related to consumption from the grid, as mobile devices also have 
tight energy budgets.

Keith

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 8 Aug 2019 19:58:05 -0500

> consumption of implementation of new protocols with that of existing 

I don't think there's an ongoing effort, but we have seen localized
efforts.  (For example, power consumption was a topic at the LAKE BoF in
Montreal, and in general shows up more often for discussions involving
constrained devices than feature-ful devices, at present.)

-Ben