Subject: why is it still mandatary to have Jabber scribing for WG session given Etherpad can allow anyone to post questions?

From: Linda Dunbar <[email-masked]>
Date: Tue, 6 Aug 2019 23:19:10 +0000

Installing Jabber is not easy. You have to find specific servers to download, and very often you are not really sure which one is legitimate.
Many people don't have Jabber installed on their device, especially for people using mobile devices.

Given Etherpad allows anyone with any devices to post questions. Why is it still mandatary for WG session to have Jabber scribe before it can start?

Puzzled

Linda

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 6 Aug 2019 17:22:57 -0600

As described (informationally) in RFC 7649, the role of the Jabber
scribe is to relay questions from remote participants, not to take notes.

https://www.rfc-editor.org/rfc/rfc7649.txt

Peter

On 8/6/19 5:19 PM, Linda Dunbar wrote:
> Installing Jabber is not easy. You have to find specific servers to
> download, and very often you are not really sure which one is legitimate.
> 
> Many people don’t have Jabber installed on their device, especially for
> people using mobile devices.
> 
>  
> 
> Given Etherpad allows anyone with any devices to post questions. Why is
> it still mandatary for WG session to have Jabber scribe before it can
> start?
> 
>  
> 
> Puzzled
> 
>  
> 
> Linda  
> 
>  
> 
>  
>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 6 Aug 2019 23:37:54 +0000

Pete, 
Thanks for the pointer. 
There are so many very easy messaging Apps, Slack, Wire, etc. why it is mandatary to have Jabber? 
Besides, remote people who want to post questions should register with the Remote Participation, and can raise their hands if they want to ask questions (i.e. posting their questions to the Etherpad). 

If there are no remote participants, can WG go on without Jabber scriber? 

Remote people can also access Etherpad. It is kind of nice to have questions captured in the Etherpad. 

My two cents. 

Linda

-----Original Message-----
From: Peter Saint-Andre <[email-masked]> 
Sent: Tuesday, August 06, 2019 6:23 PM
To: Linda Dunbar <[email-masked]>; [email-masked]
Subject: Re: why is it still mandatary to have Jabber scribing for WG session given Etherpad can allow anyone to post questions?

As described (informationally) in RFC 7649, the role of the Jabber scribe is to relay questions from remote participants, not to take notes.

https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Frfc%2Frfc7649.txt&amp;data=02%7C01%7Clinda.dunbar%40futurewei.com%7C9256765b45d0474051d908d71ac50522%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637007305832539585&amp;sdata=HsAe%2F15LRIYXPyrI2iDQPVhYEeJHzBuhjXa2P%2F%2BTg%2Fo%3D&amp;reserved=0

Peter

On 8/6/19 5:19 PM, Linda Dunbar wrote:
> Given Etherpad allows anyone with any devices to post questions. Why 
> is it still mandatary for WG session to have Jabber scribe before it 
> can start?
> 
>  
> 
> Puzzled
> 
>  
> 
> Linda
> 
>  
> 
>  
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 7 Aug 2019 12:00:06 +1200

> If there are no remote participants, can WG go on without Jabber scriber?

Jabber is integrated with Meetecho, so I don't think we can drop it unless...
 
> Remote people can also access Etherpad. It is kind of nice to have questions captured in the Etherpad. 

...Etherpad could also in some way be integrated with Meetecho. But I don't see how that would work, whereas instant messaging fits in quite naturally.

(BTW, I've found Jabber very reliable using Gajim on Windows, with an account @jabber.org. But apart from IETF weeks, very few people seem to use it now.)

    Brian

---

From: Keith Moore <[email-masked]>
Date: Tue, 6 Aug 2019 20:05:40 -0400

> There are so many very easy messaging Apps, Slack, Wire, etc. why it is mandatary to have Jabber?

Why should people have to a proprietary app, or have an account with a 
proprietary service (with all of the attendant risks associated with 
either) to be able to participate remotely?

I understand that Jabber use has declined.    Some other non-proprietary 
chat facility might be fine.   But as a standards-making organization, 
IMO we should not be promoting use of technologies that aren't open 
standards or at least open source.

> Besides, remote people who want to post questions should register with the Remote Participation, and can raise their hands if they want to ask questions (i.e. posting their questions to the Etherpa…

Having tried to use both when participating remotely at the recent IETF, 
I can attest that Jabber works better for this.

> If there are no remote participants, can WG go on without Jabber scriber?

Remote participants can join at any time, so I would say the Jabber 
scribe is still needed.   But it may be that people think that by 
serving as Jabber scribe, they need to take notes.   If all they are 
expected to do is relay questions, chairs could make that clear, and it 
might be easier to recruit them.   And the Jabber scribe can use 
Meetecho to post to the chat room, so they don't need to install 
software other than a browser.

> Remote people can also access Etherpad. It is kind of nice to have questions captured in the Etherpad.

I find it confusing to have questions in the Etherpad because of the way 
it works.   An append-only medium is better for questions.

Keith

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 Aug 2019 10:06:06 +1000

FWIW -
  https://github.com/42wim/matterbridge

I've used this to bridge Slack and Jabber with some success; it's a bit fiddly to set up, and the process needs to be kicked once in a while, but it does work. 

It supports lots of other messaging services too... personally, I'm looking forward to participating in an IETF meeting through Minecraft chat.

> On 7 Aug 2019, at 10:00 am, Brian E Carpenter <[email-masked]> wrote:
> 
> ....Etherpad could also in some way be integrated with Meetecho. But I don't see how that would work, whereas instant messaging fits in quite naturally.
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 7 Aug 2019 00:27:50 +0000

> personally, I'm looking forward to participating in an IETF meeting through Minecraft chat.
 
Brings the concept of bikeshedding to an interesting level.

---

From: "John Levine" <[email-masked]>
Date: 6 Aug 2019 20:34:34 -0400

>There are so many very easy messaging Apps, Slack, Wire, etc. why it is mandatary to have Jabber? 

It's an open IETF standard and there are in fact a lot of clients such
as Pidgin, Adium, and Jitsi.

I agree that it's a pain that Google now uses mutant XMPP so you can't use
Google Hangouts any more.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 7 Aug 2019 07:55:11 +0300

The jabber room also works as a back-channel for both remote and local participants.  Sometimes the conversation there is at least as useful as the one in the room.

---

From: Nico Williams <[email-masked]>
Date: Wed, 7 Aug 2019 00:26:32 -0500

On Wed, Aug 07, 2019 at 07:55:11AM +0300, Yoav Nir wrote:
> The jabber room also works as a back-channel for both remote and local
> participants.  Sometimes the conversation there is at least as useful
> as the one in the room.

I'm all for keeping jabber.

I'm not sure we need a scribe at all now that we have meetecho and
decent sound, except perhaps when there are hard-of-hearing participants
in the room.

Nico
--

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 7 Aug 2019 07:34:50 +0200 (CEST)

> Installing Jabber is not easy. You have to find specific servers to download, and very often you are not really sure which one is legitimate.

You do not need a Jabber client. You can use the WebRTC enabled Meetecho 
webpage for the session and chat there. It's "the jabber room". It nicely 
combines the jabber room (the chat window in Meetecho), the video feed and 
the notes. It works in any modern browser/OS on a desktop OS.

I haven't used a jabber client to participate in IETF jabber room for 3-5 
years now. I only use Meetecho. I've jabber-scribed probably 30 sessions 
this way.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Tim Chown <[email-masked]>
Date: Wed, 7 Aug 2019 08:09:57 +0000

> On 7 Aug 2019, at 06:34, Mikael Abrahamsson <[email-masked]> wrote:
> 
> You do not need a Jabber client. You can use the WebRTC enabled Meetecho webpage for the session and chat there. It's "the jabber room". It nicely combines the jabber room (the chat window in Meetecho), the video feed and the notes. It works in any modern browser/OS on a desktop OS.

Exactly; you can use MeetEcho to be "on Jabber".

> I haven't used a jabber client to participate in IETF jabber room for 3-5 years now. I only use Meetecho. I've jabber-scribed probably 30 sessions this way.

Same, though not so much scribing as professionals such as you :)

Tim

---

From: Tim Wicinski <[email-masked]>
Date: Wed, 7 Aug 2019 07:44:36 -0400

If we want to keep the Jabber going, could we not set up our own Jabber
server? perhaps tied to the datatracker or something
more ephemeral ?

( I've lost more than a few jabber accounts in my days, and I did use
Hangouts until the googles switched to mutant XMPP.)

(Meetecho is very useful also, just saying).

On Wed, Aug 7, 2019 at 4:10 AM Tim Chown <[email-masked]> wrote:

> > I haven't used a jabber client to participate in IETF jabber room for
> 3-5 years now. I only use Meetecho. I've jabber-scribed probably 30
> sessions this way.
>

---

From: [email-masked]
Date: Wed, 07 Aug 2019 06:32:40 -0700 (PDT)

> > the notes. It works in any modern browser/OS on a desktop OS.

FWIW, I had some issues with it in Brave on MacOS: The room video worked but
the presentation video did not. Probably a security setting I had wrong...
OTOH, it's not exactly a major hardship to fire up a different browser (Chrome
in my case) and that worked fine.

> > years now. I only use Meetecho. I've jabber-scribed probably 30 sessions this
> > way.

> Same, though not so much scribing as professionals such as you :)

Meetecho is what makes remote attendance possible for me. If I had to mess
around with finding the latest working Jabber client/account/whatever in order
to participate, TBH I likely wouldn't bother.

This is not broken; let's please not try and fix it, and most definitely not
with Slack. Slack is almoat as bad as Jabber, but for completely different
reasons.

				Ned

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 7 Aug 2019 15:30:08 +0000

I like Tim’s idea of having IETF Jabber server.

How to use meetecho to do Jabber scribe?

Linda

From: Tim Wicinski <[email-masked]>
Sent: Wednesday, August 07, 2019 6:45 AM
To: Tim Chown <[email-masked]>
Cc: Mikael Abrahamsson <[email-masked]>; Linda Dunbar <[email-masked]>; [email-masked]
Subject: Re: why is it still mandatary to have Jabber scribing for WG session given Etherpad can allow anyone to post questions?

If we want to keep the Jabber going, could we not set up our own Jabber server? perhaps tied to the datatracker or something
more ephemeral ?

( I've lost more than a few jabber accounts in my days, and I did use Hangouts until the googles switched to mutant XMPP.)

On Wed, Aug 7, 2019 at 4:10 AM Tim Chown <[email-masked]<mailto:[email-masked]>> wrote:
> On 7 Aug 2019, at 06:34, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>> wrote:
>

Tim

---

From: Tim Chown <[email-masked]>
Date: Wed, 7 Aug 2019 17:07:16 +0000

On 7 Aug 2019, at 16:30, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:

The meetecho chat is the jabber chat.

Tim

Linda

From: Tim Wicinski <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, August 07, 2019 6:45 AM
To: Tim Chown <[email-masked]<mailto:[email-masked]>>
Cc: Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>>; Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: why is it still mandatary to have Jabber scribing for WG session given Etherpad can allow anyone to post questions?

Tim

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 7 Aug 2019 11:13:14 -0600

On 8/6/19 11:26 PM, Nico Williams wrote:
> decent sound, 

How do remote participants get their questions asked at the mic line?

> except perhaps when there are hard-of-hearing participants
> in the room.

Accessibility is a thing. :-)

Peter

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 13:13:24 -0400

Linda,

When you use Meetecho, the pane to the left of the video is the Jabber chat
window. So you just need to open Meetecho for the WG in question and not
allow it access to your camera or microphone when it starts up.

Cheers,
Andy

On Wed, Aug 7, 2019 at 11:30 AM Linda Dunbar <[email-masked]>
wrote:

> *From:* Tim Wicinski <[email-masked]>
> *Sent:* Wednesday, August 07, 2019 6:45 AM
> *To:* Tim Chown <[email-masked]>
> *Cc:* Mikael Abrahamsson <[email-masked]>; Linda Dunbar <
> [email-masked]>; [email-masked]
> *Subject:* Re: why is it still mandatary to have Jabber scribing for WG
> session given Etherpad can allow anyone to post questions?
>
>
>
>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 13:15:35 -0400

I was remote for the Montreal meeting and found Jabber much more convenient
for questions than raising my virtual hand, waiting to be recognized, and
then speaking my question.

Cheers,
Andy

---

From: Tim Chown <[email-masked]>
Date: Wed, 7 Aug 2019 17:15:46 +0000

> On 7 Aug 2019, at 18:13, Peter Saint-Andre <[email-masked]> wrote:
> 

Indeed, the jabber scribe is now to all intents and purposes a jabber relay.

> Accessibility is a thing. :-)

Indeed!

Tim

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 7 Aug 2019 11:18:38 -0600

> Indeed, the jabber scribe is now to all intents and purposes a jabber relay.

I think it always was. We tried to change that terminology in RFC 7649
but the terminology was already set in stone.

Peter

---

From: Warren Kumari <[email-masked]>
Date: Wed, 7 Aug 2019 13:25:05 -0400

> Exactly; you can use MeetEcho to be "on Jabber".

Just a meta-note:
There are a large number of things where the answer is Meetecho -- I
think that we are at risk of forgetting just how much they have
improved our process / experience...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 7 Aug 2019 13:30:24 -0400

On Wed, Aug 7, 2019 at 1:26 PM Warren Kumari <[email-masked]> wrote:

> > > You do not need a Jabber client. You can use the WebRTC enabled
> Meetecho webpage for the session and chat there. It's "the jabber room". It
> nicely combines the jabber room (the chat window in Meetecho), the video
> feed and the notes. It works in any modern browser/OS on a desktop OS.
> >

Would the network be impacted if signing onto meetecho became the norm in
the room?

Honest question.

Thanks,
Kathleen

-- 

Best regards,
Kathleen

---

From: Michael StJohns <[email-masked]>
Date: Wed, 7 Aug 2019 13:39:41 -0400

> Accessibility is a thing. :-)
On the "accessibility" item, I'm wondering if plugging in something like 
"Live Transcribe" into a jabber room (not the question asking one, but 
another secondary one) might make sense. Vint showed me the app and I 
was blown away with its speed (probably can transcribe Ekr or KC) and 
accuracy.  Unfortunately, only available on a subset of Android devices.

Mike

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Aug 2019 19:48:06 +0200

> but the terminology was already set in stone.

Yes, and Internet standards are called Proposed Standards unless they are called Internet Standards.

We are pretty good at using (and actually defending) terminology that is consistently confusing new people, unless each use of the terminology is combined with an explanation and an apology.

Why are we doing that?

Grüße, Carsten

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 13:48:13 -0400

Just a meta-note:

+1

Cheers,
Andy

---

From: Nico Williams <[email-masked]>
Date: Wed, 7 Aug 2019 13:39:13 -0500

> How do remote participants get their questions asked at the mic line?

That doesn't require scribing as it used to be.  It's just someone (yes,
we can call them scribes, but maybe the WG chairs can do this
themselves) to mediate mic access.

> Accessibility is a thing. :-)

Which is why I called it out :)

Now, if we want to support hard-of-hearing participants even when they
are not known to be in the room -- well, that's kinda like close-
captioning a video recording of the meeting, and that's the sort of
thing you want to pay for rather than rely on volunteers.  I for one
would love to see quality close-captioning of video recordings of IETF
meetings, though it's almost certainly cost prohibitive.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Wed, 7 Aug 2019 13:40:23 -0500

> then speaking my question.

Me too, sure, but those questions may not get answered at the mic, just
maybe in the chat room.  Then again, following the chat room and the
real room at the same time can be difficult and distracting.

---

From: Linda Dunbar <[email-masked]>
Date: Wed, 7 Aug 2019 18:40:28 +0000

Andy,

Thanks for the note. Do I need to download the Jabber agent to see the chat in Jabber room?

When I enter the Meetecho room for IDR, I only saw:

Linda

From: Andrew G. Malis <[email-masked]>
Sent: Wednesday, August 07, 2019 12:13 PM
To: Linda Dunbar <[email-masked]>
Cc: Tim Wicinski <[email-masked]>; Tim Chown <[email-masked]>; [email-masked]
Subject: Re: why is it still mandatary to have Jabber scribing for WG session given Etherpad can allow anyone to post questions?

Linda,

When you use Meetecho, the pane to the left of the video is the Jabber chat window. So you just need to open Meetecho for the WG in question and not allow it access to your camera or microphone when it starts up.

Cheers,
Andy

On Wed, Aug 7, 2019 at 11:30 AM Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
I like Tim’s idea of having IETF Jabber server.

Linda

Tim

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 7 Aug 2019 14:49:24 -0400

Linda,

I believe that you have to be in the Meetecho room during the meeting to
see the chat.

Cheers,
Andy

On Wed, Aug 7, 2019 at 2:40 PM Linda Dunbar <[email-masked]>
wrote:

> *From:* Andrew G. Malis <[email-masked]>
> *Sent:* Wednesday, August 07, 2019 12:13 PM
> *To:* Linda Dunbar <[email-masked]>
> *Cc:* Tim Wicinski <[email-masked]>; Tim Chown <[email-masked]>;
> [email-masked]
> When you use Meetecho, the pane to the left of the video is the Jabber
> chat window. So you just need to open Meetecho for the WG in question and
> not allow it access to your camera or microphone when it starts up.
>
>
>
> Cheers,
>
> Andy
>
>
>

---

From: Warren Kumari <[email-masked]>
Date: Wed, 7 Aug 2019 14:49:32 -0400

> When I enter the Meetecho room for IDR, I only saw:
For some reason you are looking at the IDR logs for Saturday July 27th --
the IDR meeting happened on Wednesday the 24th - if you look there you will
see the content - https://www.ietf.org/jabber/logs/idr/2019-07-24.html

W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Eliot Lear <[email-masked]>
Date: Wed, 7 Aug 2019 21:05:53 +0200

And we thought Github brought stickiness...

> On 7 Aug 2019, at 02:27, Salz, Rich <[email-masked]> wrote:
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 8 Aug 2019 07:55:13 +0200 (CEST)

> improved our process / experience...

Agreed, and I've several times written about this.

https://mailarchive.ietf.org/arch/msg/ietf/XRAe4hsKHTocAJ4Rc-kT5b2KZx0

I miss that the meetecho recordings seem to be no longer available. They 
are superior to the Youtube videos in that they have also the jabber room, 
all in one. The youtube videos are a lot less flexible.

I think the IETF should do a lot more "marketing" around Meetecho.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 8 Aug 2019 07:57:47 +0200 (CEST)

> themselves) to mediate mic access.

I find it useful to have the jabber scribe relay the names of the people 
speaking in the mic line. This records the name and spelling of the person 
in the meetecho recording for easier understanding of who is speaking. The 
minute taker can also have the meetecho page up and see the jabber scribe 
typing in the name of the person speaking at the mic line.

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 8 Aug 2019 08:04:36 +0200 (CEST)

On Thu, 8 Aug 2019, Benjamin Kaduk wrote:

> https://mailarchive.ietf.org/arch/msg/wgchairs/QVQYvAwzLatK_v2oPxTpctu8l9A 
> seems to indicate that the recordings still exist, though not how to 
> navigate to them.

That still seems to incorporate something that looks like the youtube 
video, but with transcript. What I am referring to was a functionality 
where it was possible to look at the meetecho recording in an identical 
fashion as in real-time, with two separate video feeds plus the jabber 
room all playing the recording as it would have been in realtime, with 
chat messages popping up as the meeting progressed.

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 8 Aug 2019 11:36:30 +0200

> ....Etherpad could also in some way be integrated with Meetecho. But I don't see how that would work, whereas instant messaging fits in quite naturally.

Etherpad is already integrated with Meetecho: 
http://ietf105.conf.meetecho.com/index.php/Remote_Participation#GUI

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 8 Aug 2019 11:46:16 +0200

Il 07/08/19 19:30, Kathleen Moriarty ha scritto:
> 
> 
> On Wed, Aug 7, 2019 at 1:26 PM Warren Kumari <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>      > >> Installing Jabber is not easy. You have to find specific
>     servers to download, and very often you are not really sure which
>     one is legitimate.
>      > >
>     Meetecho webpage for the session and chat there. It's "the jabber
>     room". It nicely combines the jabber room (the chat window in
>     Meetecho), the video feed and the notes. It works in any modern
>     browser/OS on a desktop OS.
>      >
> Would the network be impacted if signing onto meetecho became the norm 
> in the room?

Meetecho allows you to close all video feeds individually. So if you're 
sitting in the room you can just close the slides and speaker feeds and 
only use the integrated Jabber chat. The impact on the network would be 
close to zero in this case.

> Honest question.
> 
> Thanks,
> Kathleen
> 
> 
>     W
> 
>      > > I haven't used a jabber client to participate in IETF jabber
>     room for 3-5 years now. I only use Meetecho. I've jabber-scribed
>     probably 30 sessions this way.
>      >

---

From: Meetecho IETF support <[email-masked]>
Date: Thu, 8 Aug 2019 12:03:43 +0200

> chat messages popping up as the meeting progressed.
The "Meetecho recordings", i.e., the once accessible from the agenda 
site by clicking on the M-shaped icon 
(https://datatracker.ietf.org/meeting/105/agenda/) do pop up chat 
messages as they happened during the session. The only thing missing is 
the two separate video feeds, as the IETF chose to rely on YouTube for 
that as they didn't want to host all videos and serve them to people 
from IETF servers. YouTube is great at that, and also gives us some 
useful additional features, e.g.,:

- transcripts are automatically generated, which can be very useful for 
preparing minutes;

- uploaded videos are automatically scaled to different sizes in order 
to accommodate different clients bandwidth (if you have less bandwidth 
you get a smaller video).

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 8 Aug 2019 13:11:47 +0200 (CEST)

On Thu, 8 Aug 2019, Meetecho IETF support wrote:

> The "Meetecho recordings", i.e., the once accessible from the agenda site by 
> clicking on the M-shaped icon 
> (https://datatracker.ietf.org/meeting/105/agenda/) do pop up chat messages as 
> they happened during the session. The only thing missing is the two separate 
> video feeds, as the IETF chose to rely on YouTube for that as they didn't 
> want to host all videos and serve them to people from IETF servers. YouTube 
> is great at that, and also gives us some useful additional features, e.g.,:

Ah, great, thanks! The few times I checked this the right-side window was 
empty, didn't realise this was the jabber room. Tested it again, and 
indeed it is.

Thanks again!

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 8 Aug 2019 12:11:27 +0000

Perhaps an "insider's guide to meetecho" should be written. :)  Or at least circulated among the WG chairs.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 9 Aug 2019 08:32:05 +1200

> http://ietf105.conf.meetecho.com/index.php/Remote_Participation#GUI

Ah, good. 

fwiw, my opinion is that a separate instant messaging channel is better for
remote participants; anything useful in the jabber log can be inserted into
the minutes later. It's not as if raw Etherpad generally satisfies the
RFC2418 requirement that "minutes should include the agenda for the session,
an account of the discussion including any decisions made..." without
some manual editing.

   Brian

> .

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 9 Aug 2019 14:04:02 -0400

I have looked at this thread, trying to figure out the best place to 
interject my experience last November, and figure that this last will 
work as good as any place...

Last November I was in a hospital bed trying to get Meetecho to work.

Between the challenges of the hospital firewall rules for patients, 
being out of data on my cellular wifi account and on slow mode, besides 
pecking left-handed, I did not get in.

I would have been happy with an audio feed, the slides, and jabber. But 
probably jabber would not work through the hospital firewall either.  
Realtime, interactive web apps like the etherpad probably would have 
been miserable on that hospital wifi.  At simple web form that shows the 
conversation up to now and the ability to add some to the conversation 
in a RESTFUL mode (hint, hint).

We have become so use to big bandwidths and lots of data in the pipe 
(see the energy saving thread here) that we have forgotten those that 
want to connect with bad connectivity.

In my case, it was probably better that I went to sleep rather than 
connect in when the hospital expected me to be asleep.  But still...

Perhaps remote participation instructions for those with low bandwidth 
or unruly firewalls would be important to add.

Bob

As a totally side note about RESTFUL, I recently tried to explain to one 
youth what I did back in '83 on the American Motors (AMC) Honeywell 
mainframe with DMIV-TP online transaction processor and CODASYL database 
backend, and realize that I created a RESTFUL environment (actually 
forced in on the programmers) back then.  Each screenful was a separate 
event and there was 'cookie' support through hidden fields on the 
screen.  All code was fully reenterent, with no carry-over state.  This 
was very unusual approach back then.  Considerable resistance from the 
programmers.

Couching things in web terms understandable to today's youth almost made 
it a ho-hum talk.  ;)

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 9 Aug 2019 13:58:42 -0500

Hi Bob,

> or unruly firewalls would be important to add.

The audio stream link already has a dedicated button on the agenda, next to
the etherpad link, meeting materials, etc.  So it sounds like maybe you are
just asking for instructions for low-bandwidth/constrained-access jabber
and putting the pieces together?

What I do for jabber is to run a persistent TUI client in a screen session
on a machine with good connectivity, then ssh to it from wherever I happen
to be.  Granted, the TUI client is not super great, but it is definitely
low-bandwidth for my local access!  Sometimes I am even crazy enough to be
sitting in one session and following the audio stream of another via one
earphone, and monitoring the jabber rooms for both, though this takes quite
a bit of concentration to get much value from (definitely no peeking at
email).  Unfortunately, the audio stream tends to cut out when I try to
walk from the room I'm in to the room I'm listening to; presumably my TCP
connection doesn't survive switching APs...

-Ben

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 9 Aug 2019 15:21:29 -0400

> and putting the pieces together?

Things are a bit foggy about that time.  I was on pain meds...

I did not get the audio feed working.  I tried working with the hospital 
IT helpdesk, but they were not equiped to help patients, only 
employees.  This should work simply through a firewall.

I did not try Jabber.  After all these years, I really should give it a 
go so I have it when I am retired and sitting out in the backyard.

And try and be on the same slide as the presenter when you only have 
audio.  There should be some way to indicate which slide is current.  Of 
course most of us do not number our slides, so it is especially hard to 
tell a remote audio listener which slide # is current.

> connection doesn't survive switching APs...

Perhaps something to work more on.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 9 Aug 2019 21:41:45 +0200

I think there should be a Datatracker feature to reject unnumbered slides. Lacking that, the chairs can do that. 

Sent from mobile, sorry for terse

> On 9. Aug 2019, at 21:21, Robert Moskowitz <[email-masked]> wrote:
> 
> most of us do not number our slides,

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 9 Aug 2019 15:53:20 -0400

Thus another reason for the Jabber scribe:

Move to slide #4.

Oh back to slide #3.

:)

On 8/9/19 3:41 PM, Carsten Bormann wrote:
> I think there should be a Datatracker feature to reject unnumbered 
> slides. Lacking that, the chairs can do that.
>
> On 9. Aug 2019, at 21:21, Robert Moskowitz <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: tjw ietf <[email-masked]>
Date: Fri, 9 Aug 2019 15:53:44 -0400

I’d vote for a data tracker feature to add numbers to all slides 

From my high tech gadget

> On Aug 9, 2019, at 15:41, Carsten Bormann <[email-masked]> wrote:
>

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 9 Aug 2019 15:56:12 -0400

Considering how busy some slides are, this could be very tough to automate.

Including slide # was once something I aways did.  I realize that 
recently I have stopped.  I will commit to including slides #. Perhaps 
this is something for the Tao?

On 8/9/19 3:53 PM, tjw ietf wrote:
> On Aug 9, 2019, at 15:41, Carsten Bormann <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 10 Aug 2019 01:19:27 +0200

(Slide numbers:)

> On Aug 9, 2019, at 21:56, Robert Moskowitz <[email-masked]> wrote:
> 
> Perhaps this is something for the Tao?

Maybe, but maybe it’s also time for a few specific pages with instructions (help) for various activities such as slide making etc.

Grüße, Carsten

---

From: John C Klensin <[email-masked]>
Date: Sat, 10 Aug 2019 08:27:53 -0400

Hi.

Since this has, by last count, gone on for four days and 45
messages, some quick comments from someone who was in Montreal
(and didn't touch Jabber or Meetecho) but who is usually remote
these days (in no particular order):

(1) Using the Meetecho remote queue would be a better substitute
for the Jabber "scribe" if those who are leading meetings
consistently followed the associated notification, paid
attention to them, and treated such requests fairly wrt in-room
participants.  In practice, while I think it is gradually
getting better, it often doesn't happen: many times that queue
is either ignored completely or gotten to only when all in-room
queues have drained.  Sometimes the latter is after the "mic
line" is closed, which means that the remote comments or
questions are either locked out entirely or simply aren't
injected into the discussion until after they cease to be
timely.  This is a meeting chair training, management, and focus
problem, not something that can be done with technology, unless
we want to modify the interfaces to be _really_ intrusive.  A
Jabber scribe coming to the microphone is often still not as
timely as it should be for remote people to participate actively
in a controversial discussion, but it works much better than a
Meetecho remote queue that is being ignored.  And, fwiw, the
problem is not just a rogue or careless WG chair or two -- in
the last few years, one of the "pay no attention to remote queue
requests" offenders has often been the plenaries.

(2) As someone else mentioned, following a live session and a
chat room simultaneously can be rather difficult.  That is as
much a matter of the attention and skills of the remote
participant than it is a matter of technology.  Meetecho's (IMO,
very clever and useful) mode-switching arrangements may pose
difficult choices for the remote participant in terms of what to
look at.  It may be impossible to optimize simultaneously across
tradeoffs: some people with excess bandwidth, some with a
shortage; some in private spaces and some in busy rooms; some on
small laptops, some on desktops with large screens (plural).
One thing that makes it possible to follow Jabber under those
circumstances is that it is serial -- the most recent activity
is always at the bottom/end of the transaction list.  (Alternate
IM applications would be no better but would probably be harder
to get, and say, used to before they keep being "improved".)
Etherpad (and equivalent) have many advantages and useful
features, but asking someone who is already challenged by
keeping up with the Jabber feed and the meeting in real time to,
instead, keep track on a pad that is being regularly modified in
different places... well, others may be much better at that sort
of thing than I am but I'd think it would be a major setback.

(3) Another of the issues with accommodating different types of
remote setups is that, even if bandwidth is adequate and there
are no firewall problems or other blockages is that someone may
be in a situation in which listening and watching work fine but
speaking (whether on video or not) may be impossible or
inappropriate.   If there is an alternative to typing a question
under those circumstances, I don't know what it is.

(4) There would be an advantage to everyone in the room being
logged into Meetecho, particularly because it would allow using
Meetecho to manage those who want to speak in a single,
coherent, queue rather than relying on chairs to manage a remote
queue and multiple mic lines and have their actions/ decisions
be fair and perceived as fair.  However, even if there are no
bandwidth or performance issues, there is value in knowing (even
crudely) who is f2f in the room and who isn't.  There are also
real advantages to using a real mic line for in-room
participants even if Meetecho (or something else automated) is
managing the queues.   So, if we want to go down the path of
many or most in-room participants running Meetecho, we may need
to rethink the sign-in process and interfaces a bit.

(5) To turn around something that has been mentioned, the
requirement that someone in the mic line clearly identify
themselves seems to be violated more often that not.  It isn't
just the people who don't mention their names, or don't mention
them after the first interaction in a back-and-forth exchange
(I'm sensitive to the issue and have still been guilty), but the
ones who mumble their names or speak them too quickly,  The
latter, may be worse, and the definition of "quickly", may be
more difficult if the speaking style or accent of the speaker
differences from that of the listener.  For experienced IETF
participants, being able to see the speaker in combination with
hearing whatever is said may help, but that does relative
newcomers no good at all and doesn't help remote participants
more generally if the camera is not pointed at the speaker.
Having someone on Jabber recording who is speaking can be of
huge help with this, at least unless they can't figure out who
is speaking either.  We have experimented with badge readers and
other ways to make the speaker identification process more
automatic and more reliable, but gave up on it, at least
partially out of privacy concerns.  Unless we can all get a lot
better at identifying ourselves and doing so slowly, carefully,
and clearly, maybe we need to review those decisions as
tradeoffs between privacy and requirements for openness and
transparency about who is making Contributions and influencing
decisions.

There is probably more, but I just reached my self-imposed
length limit for this note :-(

thanks,
  john