Subject: GitHub blockage in Spain

From: Jim Fenton <[email-masked]>
Date: Fri, 1 Nov 2019 10:01:14 -0700

I'm hearing that Spain is blocking GitHub:

https://reclaimthenet.org/github-spain-blocked-catalan-protests/

If that were to continue, how would we handle that for IETF 108 (next
July in Madrid)?

-Jim

---

From: Jared Mauch <[email-masked]>
Date: Fri, 1 Nov 2019 13:04:00 -0400

> On Nov 1, 2019, at 1:01 PM, Jim Fenton <[email-masked]> wrote:
> 

Relevance?

Often these blocks are either done in local DNS or at the local ISP level.  When IETF rolls in, the network is often not part of this.  You’ve seen this work well in countries where the local blocking might have been an issue, the most prominent of them being IETF in China.

I get that some people don’t like GitHub and if you want to ask IETF to run a gitlab instance or similar it would likely mitigate the issue as well.

- jared

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 1 Nov 2019 18:09:51 +0100

Jared,

I think Jim's last worry was about IETF network :) The way I read and
understand it that having IETF in Madrid indirectly support such Spain gov
actions.

I suggest we move it to Barcelona.

Thx,
R.

On Fri, Nov 1, 2019 at 6:04 PM Jared Mauch <[email-masked]> wrote:

> Often these blocks are either done in local DNS or at the local ISP
> level.  When IETF rolls in, the network is often not part of this.  You’ve
> seen this work well in countries where the local blocking might have been
> an issue, the most prominent of them being IETF in China.
>
> I get that some people don’t like GitHub and if you want to ask IETF to
> run a gitlab instance or similar it would likely mitigate the issue as well.
>
> - jared
>

---

From: Jim Fenton <[email-masked]>
Date: Fri, 1 Nov 2019 10:20:36 -0700

While I think that blocking something like GitHub is a bad thing to do,
I'm not suggesting we step into another's country's politics.

My question is mostly about the practicalities of how attendees will be
able to use GitHub if the block is still in place then. We are doing an
increasing amount of IETF work in GitHub, and attendees need access to
it to do other work as well. If we can negotiate an arrangement that
will exempt the IETF network from the block, that would (IMO) be a
minimally acceptable solution. Of course, attendees staying offsite
would still need to use a VPN or something to access GitHub from their
hotel, AirBNB, etc. and that's still a bad situation.

On 11/1/19 10:09 AM, Robert Raszuk wrote:
> understand it that having IETF in Madrid indirectly support such Spain
> gov actions. 
>
> On Fri, Nov 1, 2019 at 6:04 PM Jared Mauch <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>
>
>     > On Nov 1, 2019, at 1:01 PM, Jim Fenton <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     Often these blocks are either done in local DNS or at the local
>     ISP level.  When IETF rolls in, the network is often not part of
>     this.  You’ve seen this work well in countries where the local
>     blocking might have been an issue, the most prominent of them
>     being IETF in China.
>
>     I get that some people don’t like GitHub and if you want to ask
>     IETF to run a gitlab instance or similar it would likely mitigate
>     the issue as well.
>
>     - jared
>

---

From: "Diego R. Lopez" <[email-masked]>
Date: Fri, 1 Nov 2019 17:31:46 +0000

Hi,

Just a quick comment: The request from the Spanish police was about blocking a few repositories in Github being used for purposes related to violent protests, not by any means to GitHub at large.

We can discuss about politics, fake news, and deliberate exaggerations in front of a beer next time we meet (Singapore?)

Be goode,

--
Likely to be brief and not very
elaborate as sent from my mobile
Diego R. Lopez
Telefonica I+D

On 1 Nov 2019, at 18:21, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:

While I think that blocking something like GitHub is a bad thing to do, I'm not suggesting we step into another's country's politics.

My question is mostly about the practicalities of how attendees will be able to use GitHub if the block is still in place then. We are doing an increasing amount of IETF work in GitHub, and attendees need access to it to do other work as well. If we can negotiate an arrangement that will exempt the IETF network from the block, that would (IMO) be a minimally acceptable solution. Of course, attendees staying offsite would still need to use a VPN or something to access GitHub from their hotel, AirBNB, etc. and that's still a bad situation.

I think Jim's last worry was about IETF network :) The way I read and understand it that having IETF in Madrid indirectly support such Spain gov actions.

Thx,
R.

On Fri, Nov 1, 2019 at 6:04 PM Jared Mauch <[email-masked]<mailto:[email-masked]>> wrote:

> On Nov 1, 2019, at 1:01 PM, Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:
>

Relevance?

- jared

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: MARCELO GABRIEL BAGNULO BRAUN <[email-masked]>
Date: Fri, 1 Nov 2019 18:36:15 +0100

mmm, I am currently in spain and I have been able to access
https://github.com/google/proto-quic without any problem. Is there any
specific URL or repo that you think it is relevant for the IETF and
blocked? I can check it for you if you want.

-- 
MARCELO GABRIEL BAGNULO BRAUN
Universidad Carlos III de Madrid

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 1 Nov 2019 18:37:31 +0100

I wrote before:

> One problem with an independent court system is that it sometimes acts out of a position that is not very well informed about reality.  Maybe our friends at ISOC can reach out, again?  (They had to do that before.)

Maybe not just the court system :-)

Grüße, Carsten

---

From: MARCELO GABRIEL BAGNULO BRAUN <[email-masked]>
Date: Fri, 1 Nov 2019 18:37:57 +0100

I meant https://github.com/quicwg (I can also access the google quic
one, but this is most the relvant for the IETF)

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 01 Nov 2019 19:05:31 +0100

I think you should get well informed *before* spreading such false information.

A Spanish court has ordered to block a specific app that is being hosted by github.

This app has been developed as part of a criminal activity by criminal groups trying to break Spain and circumvent our laws.

If you disagree with a court taking all the possible measures to block criminal activities, do you mean that you will also disagree with a court asking any hosting provider to block access too child pornography or any other criminal activity?

By the way, I've been the one supporting the IETF secretariat in order to organize the IETF in Spain, and among other reasons (cost and venue related), I strongly suggested not hosting the IETF in Barcelona in 2020, because I know that this situation will take some time to clean up.

Note that I was born in Barcelona, but I don't support any kind of criminal activities, including breaking apart a country.

Regards,
Jordi
@jordipalet

El 1/11/19 18:02, "ietf en nombre de Jim Fenton" <[email-masked] en nombre de [email-masked]> escribió:

    
    
    -Jim

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 01 Nov 2019 19:17:53 +0100

Actually not!

I hope the people from ISOC in Belgium doesn't create a trouble again.

Last time something similar happened with court orders for blocking some web sites doing criminal activities, the ISOC report faked it 100%, and they indicated that the courts orders to block the complete .cat.

I'd access to the court order and clearly was saying something different. I informed ISOC about that and asked them to correct the article.

They NEVER agreed to correct such misinformation.

Very SAD that ISOC acted in such way that promoted fake information and consequently promoted criminals.

Regards,
Jordi
@jordipalet

El 1/11/19 18:38, "ietf en nombre de Carsten Bormann" <[email-masked] en nombre de [email-masked]> escribió:

    

    Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 2 Nov 2019 08:02:21 +1300

Hi,

IMHO we should not discuss here any aspect except the narrow technical one whether a successful IETF meeting in Madrid in July 2020 is possible. In fact it seems to be the responsibility of IASA, and the meeting planners in particular, to check this and let us know if there are any risks.

I certainly don't want to enter into political debates here, on matters where most of us are ill-informed and not personally affected.

Regards
   Brian Carpenter

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Nov 2019 19:36:39 -0400

--On Saturday, November 2, 2019 08:02 +1300 Brian E Carpenter
<[email-masked]> wrote:

> IMHO we should not discuss here any aspect except the narrow
> technical one whether a successful IETF meeting in Madrid in
> July 2020 is possible. In fact it seems to be the
> responsibility of IASA, and the meeting planners in
> particular, to check this and let us know if there are any
> risks.
> 
> I certainly don't want to enter into political debates here,
> on matters where most of us are ill-informed and not
> personally affected.

Brian,

While I almost entirely agree, I note that we've had discussions
on this list about IETF participants being harassed or arrested
because of personal behavior or various "preferences" (aspects
of their lives that may not be discretionary choices, and hence
not preferences in the usual sense at all).  If there were
significant risk of IETF participants being harassed or arrested
because of their views on the relationship between Catalonia and
the rest of Spain (I note Jordi's description used the terms
"criminal activities" and "trying to break Spain and circumvent
our laws" ... and, before this turns into precisely the debate
you want to avoid, also note that I said "rest of Spain").

I also agree with Diego, and presumably you, that this list is
not a good place for discussions of "politics, fake news, and
deliberate exaggerations" and not just because most of us are
ill-informed.

I wouldn't expect us to avoid holding a meeting in California
because some of our participants might believe the state should
be divided in two or to avoid a meeting in Montreal because
there are people there and further to the north and east who
believe Quebec should withdraw from Canada.  And, of course, the
US and Scotland were, historically, both involved in rather
nasty wars over who has the right to secede from a country and
under what terms (including whether such beliefs or actions
taken to support them were appropriately classified as criminal
acts).  One might draw some analogies to the former Soviet Union
as well.  There are obviously differences among those examples
and between them and the Spanish case.  Your last paragraph
clearly would apply to debates about those situations or the
distinctions on this list.

At the same time, it is not clear to me whether the meeting
planners consider it part of their mandate to evaluate the
relevant tensions and any possible resulting interference with
the ability to hold a successful meeting and for any active IETF
participant to attend without having significant concerns about
what they would define as mistreatment (remember that we have
set interesting precedents about meeting in the US that might or
might not be relevant).  It would be useful to get a statement
from them --sooner rather than later-- about where they think
their responsibilities begin and end.   If they end before they
would get to evaluations of local tensions (including whatever
might be classified as criminal by relevant authorities) and
whether they might pose a threat to however we (and affected
participants) might define as a successful meeting, then I think
that boundary, and who or what does have responsibility for
those discussions, are probably an appropriate topic for this
list.  So is who is accountable to the community for whatever
decisions are made and how they are accountable.

Obviously not an easy line, or set of lines, to draw.  But
dismissing the need to do so by making inflammatory statements
(such as a few in this thread.. but nothing in your note) is
probably not a helpful way forward.

best,
   john

---

From: Rob Sayre <[email-masked]>
Date: Fri, 1 Nov 2019 17:28:31 -0700

On Fri, Nov 1, 2019 at 4:37 PM John C Klensin <[email-masked]> wrote:

> > technical one...
> I wouldn't expect us to avoid holding a meeting in California...
>

This issue has been discussed before:

https://www.ietf.org/blog/barriers-entry/

thanks,
Rob

---

From: John C Klensin <[email-masked]>
Date: Sat, 02 Nov 2019 01:59:47 -0400

> https://www.ietf.org/blog/barriers-entry/

Of course it has and, IIR, that discussion was what led us to
cut back on meetings in the US until and unless things got
better.  The questions in this case are 

(1) Whether there might be any issues in Madrid at the time of
the meeting that would require the kind of examination suggested
in that discussion.  I don't have nearly enough knowledge to
have an opinion on it.  At the same time, while I think we need
to be very careful about hyperbole, exaggerated conditions, or
"fake news", I think it is important to ask the question.

(2) It is not clear to me whether the (rather new) meeting site
determination and meeting planning process and team consider it
part of their responsibility to examine such questions, rather
than, e.g., meeting room facilities and network connectivity.
Whether they do or not, I think it is reasonable to ask that
their view of their responsibilities be made clear to the IETF
community.  And, if they do not, I think it is reasonable to ask
where and how such questions are to be addressed, keeping in
mind the risks of out-of-control discussions with a surplus of
ignorance and excitement and a shortage of facts.

best,
   john

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sat, 02 Nov 2019 09:01:05 +0100

Hi John,

I can confirm that *nothing* is happening in Madrid, and we are 610 Km away from Barcelona. The criminal activities are happening only in Catalonia. There is no chance that they extend their violent activities to Madrid: There has not been any signs about any planning on that.

I said criminal activates, because they have been convicted for those activities. The people supporting them in the protests, is not just protesting, is damaging private and public properties, which is a criminal act. Some of them were detained while preparing bombs and other terrorist activities, but all those were being planned only against the law enforcement authorities in Catalonia.

You can complain against a court decision to convict anyone if you believe is wrong. That's fair and I support it, but I don't support violence and damage to properties and against other people, as a way to sustaining that protest.

Regards,
Jordi
@jordipalet

El 2/11/19 7:00, "ietf en nombre de John C Klensin" <[email-masked] en nombre de [email-masked]> escribió:

    

    
    
    best,
       john

---

From: Bob Hinden <[email-masked]>
Date: Sat, 2 Nov 2019 08:31:12 -0700

Brian,

> On Nov 1, 2019, at 12:02 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

The requirements for an IETF network clearly state that it should be unfiltered.   Specifically from https://www.ietf.org/how/meetings/admin/meeting-network-requirements/ :

     The transit provided in support of the IETF MUST be capable of providing access
     to the IPv4 and IPv6 default free zones without the imposition of content
     filtering (e.g., URL, Site, application, port, or DPI based filtering).”

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 3 Nov 2019 08:42:45 +1300

John,
> than, e.g., meeting room facilities and network connectivity.

The criteria in draft-ietf-mtgvenue-iaoc-venue-selection-process
include:

"Economic, safety, and health risks associated with this Venue are
 acceptable."

That draft is approved and in the RFC Editor queue waiting for missing
references (the IASA2 drafts), so I assume and hope it's being applied by
IASA already.

> community.  

Isn't that exactly why we did the mtgvenue work?

> And, if they do not, I think it is reasonable to ask

In general, it would be nice to be assured that the two approved
mtgvenue drafts are already being applied.

Regards,
   Brian

---

From: S Moonesamy <[email-masked]>
Date: Sun, 03 Nov 2019 01:11:37 -0700

Hi Jim,
At 10:20 AM 01-11-2019, Jim Fenton wrote:
>My question is mostly about the practicalities of how attendees will 
>be able to use GitHub if the block is still in place then. We are 
>doing an increasing amount of IETF work in GitHub, and attendees 
>need access to it to do other work as well. If we can negotiate an 
>arrangement that will exempt the IETF network from the block, that 
>would (IMO) be a minimally acceptable solution. Of course, attendees 
>staying offsite would still need to use a VPN or something to access 
>GitHub from their hotel, AirBNB, etc. and that's still a bad situation.

I took a quick look at the IETF soon-to-be-published policy on the 
matter.  It only provides guidance about meeting rotation.  The 
document which might be of use would be the one about the selection 
criteria.  From a technical perspective, the Internet service for the 
IETF would likely be unmodified and unfiltered.  There was a takedown 
notice [1] which was published a few days ago.  That notice is in 
line with the IAB considerations about how to perform 
filtering.  Furthermore, a person from the country where the meeting 
will be hosted confirmed that access to a working group repository is 
working correctly.

Does the IETF LLC have any grounds to negotiate an arrangement?

Regards,
S. Moonesamy

1. http://r.elandsys.com/r/69452

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 3 Nov 2019 11:43:52 +0100

Hi SM,

I think the discussion here was less about the specific takedown notice but about the collateral damage caused by ISPs by interpreting the prohibitions too broadly, blocking entire sites that we need or maybe even larger regions.

It would be good to get some information from the ground about whether that is likely to be an ongoing concern in Spain or whether the police/the ISPs have learned from this occurrence.  I don’t know where to get that; maybe some people with the appropriate government and community contacts can find out and report.

Grüße, Carsten

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Sun, 03 Nov 2019 11:56:35 +0100

Hi Carsten,

I think in general ISPs (and LEAs) in Spain, know how to do this "specific" blocking, and in fact, they haven't blocked GitHub, or in the previous occasion they didn't blocked .cat, but only blocked specific and very concrete web sites.

>From the link provided by SM, this is very obvious:

https://github.com/github/gov-takedowns/blob/master/Spain/2019/2019-10-23-GuardiaCivil.md

and even more looking at specific details from the court order:

https://github.com/github/gov-takedowns/blob/master/Spain/2019/2019-10-26-GuardiaCivil.md

Furthermore, the IETF network is not using a "standard" connection, we use our own routers, BGP, addressing space and ASN, and at least, from my side, what I'm asking to the possible sponsors for the links (when negotiating its sponsorship), is "unfiltered" service.

In my opinion, that means that in case of a "different" court order, the responsibility will fall in the IETF itself, not the transit provider (which in fact, can pass us that responsibility if that's the case).

I fully understand that criminals are publishing false information, as ISOC did previously (despite having been informed by ISOC Spain), that looks like the "Spanish Government" (not the Courts), are closing down the "access to github" or ".cat", or whatever. But this is not the case.

Regards,
Jordi
@jordipalet

El 3/11/19 11:44, "ietf en nombre de Carsten Bormann" <[email-masked] en nombre de [email-masked]> escribió:

    Hi SM,

    
    Grüße, Carsten