Subject: Re: Quality of Directorate reviews

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 29 Nov 2019 20:30:04 +0200

Hi Alex and Ralph,

The quality will never increase if authors are not answering positively to
discussions in their WG, however, I always blame first WG-authors and
second WG chair and then thirdly the AD, for low quality of
discussions/drafts/works.

> From: ietf <[email-masked]> <[email-masked]&gt>; On Behalf
Of Ralph Droms
> Sent: 06 November 2019 11:03
> To: Alexey Melnikov <[email-masked]>
<[email-masked]&gt>;
> Cc: Michael Richardson <[email-masked]> <[email-masked]&gt>;;
ietf <[email-masked]> <[email-masked]&gt>;
> Subject: Re: Quality of Directorate reviews
>
>
>
> > On Nov 6, 2019, at 5:34 AM, Alexey Melnikov <[email-masked]>
<[email-masked]&gt>;
> wrote:
> >
> > Hi Michael,
> >
> > On 05/11/2019 21:50, Michael Richardson wrote:
> >>
> >> Brian E Carpenter <[email-masked]>
<[email-masked]&gt>; wrote:
> >>> If we want the IESG job to be more reasonably sized, we have to take
> >>> work away from the ADs.

I agree

>>>>As far as I can see, that means taking away
> >>> their duty of acting as final reviewers. I don't want to name names
> >>> because I don't think the ADs are to be blamed individually, but
> >>> some of them spend *enormous* effort on detailed reviews.

The WG Chair/manager is blamed, they need to encourage discussions/works
and deep investigation before submitting drafts to AD. The WG Chair should
push WG and authors for best reviews and cooperation.

> >>
> >> +1
> >>
> >> I think that there is a lack of trust by ADs of the various
> directorates.
> >
> > Other ADs have commented on this, but I think I need to repeat what
> > they said and expand on it.
> >
> > Results are vary varied. Some are quite good (e.g. Gen-Art) and others
> > really depend on reviewer. ADs responsible for Directorates are faces
> > with the choice of firing half of their Directorates (which has some
> > rather unfortunate consequences) and/or raise the bar on who should be
> > allowed to join. We already struggle to recruit people at all levels
> > of our organization.

It is easy to know when the draft is ready, YOU just check if there was
many discussions on the WG list, if non then send it back to WG to work.

> >
> > Best Regards,
> > Alexey
>
> We shouldn't be depending on last-minute quality checks to maintain the
> quality of our output.

Agree

>Working groups should be producing documents that
> are ready to publish, and develop trust that their documents are high
> quality.

Agree, the authors need to answer all questions on the list as if all
participants are ADs. WG authors reply differently with AD than with WG
participant, this needs to change.

AB

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 30 Nov 2019 08:54:14 +1100

There is a lot of evidence that a culture of blame leads to bad engineering outcomes. 

John Allspaw wrote something about this a while back:
  https://codeascraft.com/2012/05/22/blameless-postmortems/

I think it’d be better for this community to be  focused less on blame and more on becoming what John refers to as a just culture. 

Cheers,

Sent from my iPhone

> On 30 Nov 2019, at 5:30 am, Abdussalam Baryun <[email-masked]> wrote:
> 
> 
> Hi Alex and Ralph,
> 
> The quality will never increase if authors are not answering positively to discussions in their WG, however, I always blame first WG-authors and second WG chair and then thirdly the AD, for low quality of discussions/drafts/works.
> 
> > From: ietf <[email-masked]>; On Behalf Of Ralph Droms
> > To: Alexey Melnikov <[email-masked]>;
> > Cc: Michael Richardson <[email-masked]>;; ietf <[email-masked]>;
> > > On Nov 6, 2019, at 5:34 AM, Alexey Melnikov <[email-masked]>;
> > wrote:
> > >
> > > Hi Michael,
> > >
> > >> Brian E Carpenter <[email-masked]>; wrote:
> The WG Chair/manager is blamed, they need to encourage discussions/works and deep investigation before submitting drafts to AD. The WG Chair should push WG and authors for best reviews and cooperation.
> 
> 
> > >>
> > >> +1
> > >>
> It is easy to know when the draft is ready, YOU just check if there was many discussions on the WG list, if non then send it back to WG to work.
> 
> > >
> > > Best Regards,
> > > Alexey
> > 
> Agree, the authors need to answer all questions on the list as if all participants are ADs. WG authors reply differently with AD than with WG participant, this needs to change.
> 
> AB