Subject: Fwd: Introducing the Meetecho Virtual Hum tool

From: Martin Duke <[email-masked]>
Date: Thu, 9 Jul 2020 11:00:56 -0700

---------- Forwarded message ---------
From: Martin Duke <[email-masked]>
Date: Wed, Jul 8, 2020 at 4:59 PM
Subject: Introducing the Meetecho Virtual Hum tool
To: <[email-masked]>

The IESG and IETF LLC are working with the Meetecho team to add the
capability to conduct “virtual hums” in fully remote meetings. A software
model model that shows the output for given numbers of people humming is
available for experimentation [TEST_SITE].

Working Group chairs seeking “a sense of the room” are invited to use this
tool to help obtain it. As always, consensus ultimately requires
confirmation on the email list.

The current implementation is based on a specification the IESG developed
[I-D.duke]. Briefly, the workflow is as follows:

   -

   A chair begins the hum in meetecho
   -

   Participants have 20 seconds to hum loudly, softly, or not all
   -

   At the conclusion of the hum, Meetecho will report the approximate
   loudness of the hum, on the following increasing scale: niente,
   pianissimo, piano, forte, fortissimo.

As there is no IETF consensus that offline hums have specific flaws, the
current specification seeks to reproduce the offline version as faithfully
as possible. The SHMOO working group [SHMOO] might reach consensus on a
different set of requirements in the future, and update or replace this
document.

The community will have an opportunity to try out this tool at participant
[PARTICIPANTS] and session chair [CHAIRS] training sessions beginning 15
July. Feedback is welcome on the manycouches mailing list. In particular,
practical operational issues (e.g. bug reports, usability concerns,
security weaknesses) and strong, unambiguous consensus for feature changes
might be actionable prior to IETF 108. More contentious philosophical
concerns are best left for long-term consideration by SHMOO.

Regards,

Martin Duke

On behalf of the IESG

[CHAIRS] https://ietf.org/how/meetings/108/session-chair-guide/

[I-D.duke] https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/

[PARTICIPANTS] https://ietf.org/how/meetings/108/session-participant-guide/

[SHMOO] https://datatracker.ietf.org/wg/shmoo/documents/

[TEST_SITE] https://jsfiddle.net/Jay_Daley/yqgr9pnb/

---

From: "Scott O. Bradner" <[email-masked]>
Date: Thu, 9 Jul 2020 15:02:10 -0400

cute!

Scott

> On Jul 9, 2020, at 2:00 PM, Martin Duke <[email-masked]> wrote:
> 
> 
> 
> The IESG and IETF LLC are working with the Meetecho team to add the capability to conduct “virtual hums” in fully remote meetings. A software model model that shows the output for given numbers of people humming is available for experimentation [TEST_SITE].
> 
> Working Group chairs seeking “a sense of the room” are invited to use this tool to help obtain it. As always, consensus ultimately requires confirmation on the email list.
> 
> The current implementation is based on a specification the IESG developed [I-D.duke]. Briefly, the workflow is as follows:
> 	• A chair begins the hum in meetecho
> 	• Participants have 20 seconds to hum loudly, softly, or not all
> 	• At the conclusion of the hum, Meetecho will report the approximate loudness of the hum, on the following increasing scale: niente, pianissimo, piano, forte, fortissimo.
> 
> As there is no IETF consensus that offline hums have specific flaws, the current specification seeks to reproduce the offline version as faithfully as possible. The SHMOO working group [SHMOO] might reach consensus on a different set of requirements in the future, and update or replace this document.
> 
> The community will have an opportunity to try out this tool at participant [PARTICIPANTS] and session chair [CHAIRS] training sessions beginning 15 July. Feedback is welcome on the manycouches mailing list. In particular, practical operational issues (e.g. bug reports, usability concerns, security weaknesses) and strong, unambiguous consensus for feature changes might be actionable prior to IETF 108. More contentious philosophical concerns are best left for long-term consideration by SHMOO.
> 
> Regards,
> Martin Duke
> On behalf of the IESG
>

---

From: Fred Baker <[email-masked]>
Date: Thu, 9 Jul 2020 12:02:40 -0700

Thanks for this note. Let me put on my “co-chair RSSAC” hat and get your opinion?

ICANN has been going through the same issues with virtual meetings that IETF has. ICANN 67, 68, and 69 - at least - are virtual, and even after that we expect an increased amount of ICANN attendance to be remote. Historically, that has been listen-only, and we are thinking we may have to rethink our remote access tools. I copy David Olive as he and his group are important in that discussion.

ICANN has been using zoom and its “hand raise” feature. What that has meant is that the chair of a discussion, or his/her deputy, watches the “participants” pane, and invites remote commentary from folks who “raise their hand”. It can also be used as a voting tool - “everyone who <takes a stated position>, raise your hand” - allowing the deputy to count.

That is a little different than the IETF “hum”, which is intentionally inexact - a “sense of the room”. Who in the IETF would you recommend that I encourage David to discuss requirements and tools with?

Sent from my iPad

> On Jul 9, 2020, at 11:01 AM, Martin Duke <[email-masked]> wrote:
> 
> 
> 
> 
> At the conclusion of the hum, Meetecho will report the approximate loudness of the hum, on the following increasing scale: niente, pianissimo, piano, forte, fortissimo.
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Thu, 9 Jul 2020 15:35:27 -0400

btw - I assume that this, like a hum, is is anonymous - all you get is aggregate volume and not, as Fred asks, vote totals or have any 
way to find out who hummed and who did not  - I also assume that if 1/10th of the people on the call (for lack of a better word) 
hummed loudly and no one else hummed at all the result would be very low volume (i.e. the volume is based on the total
# of people that could hum rather than on just those that did)

Scott

---

From: Paul Wouters <[email-masked]>
Date: Thu, 9 Jul 2020 21:23:28 -0400 (EDT)

> # of people that could hum rather than on just those that did)

I find humming at times have been wildely differently interpreted than
what I heard. In physical meetings we dont have easy tools to vote
anonymously. But when we are meeting virtually, I would have expected
us to improve the humming system - not implement its real flaws, in this
case potentially literally amplified and send looping back.

Why not a flag or button to set, with the results anonymized and rounded
up/down based on the size of the meeting. So we get answers like "25% of
the room" or "just a few people" or "the vast majority".

Seeing as a lot of the times, the humming questions are confusing, a
place for the WG chair to write down the question and possible answers
would also have added clarification to our current virtualized emulated
humming system.

Paul

---

From: Martin Duke <[email-masked]>
Date: Thu, 9 Jul 2020 18:49:41 -0700

Paul, I believe my original email answers your questions.

On Thu, Jul 9, 2020, 18:23 Paul Wouters <[email-masked]> wrote:

> > btw - I assume that this, like a hum, is is anonymous - all you get is
> aggregate volume and not, as Fred asks, vote totals or have any
> > way to find out who hummed and who did not  - I also assume that if
> 1/10th of the people on the call (for lack of a better word)
> > hummed loudly and no one else hummed at all the result would be very low
> volume (i.e. the volume is based on the total

---

From: Christian Hopps <[email-masked]>
Date: Fri, 10 Jul 2020 06:08:47 -0400

Will there be a function that captures a non-anonymous raising of hands (like the email list or the in-person meeting)? Not all WGs use hums.

Thanks,
Chris.

---

From: Martin Duke <[email-masked]>
Date: Fri, 10 Jul 2020 06:48:01 -0700

IIUC the best way to do this is via jabber.

On Fri, Jul 10, 2020 at 3:08 AM Christian Hopps <[email-masked]> wrote:

> Will there be a function that captures a non-anonymous raising of hands
> (like the email list or the in-person meeting)? Not all WGs use hums.
>
> Thanks,
> Chris.
>
> > Working Group chairs seeking “a sense of the room” are invited to use
> this tool to help obtain it. As always, consensus ultimately requires
> > The current implementation is based on a specification the IESG
> developed [I-D.duke]. Briefly, the workflow is as follows:
> >       • At the conclusion of the hum, Meetecho will report the
> approximate loudness of the hum, on the following increasing scale: niente,
> > The community will have an opportunity to try out this tool at
> participant [PARTICIPANTS] and session chair [CHAIRS] training sessions
> beginning 15 July. Feedback is welcome on the manycouches mailing list. In
> particular, practical operational issues (e.g. bug reports, usability
> concerns, security weaknesses) and strong, unambiguous consensus for
> feature changes might be actionable prior to IETF 108. More contentious
> philosophical concerns are best left for long-term consideration by SHMOO.
> >
> > Regards,
> > Martin Duke
> > On behalf of the IESG
> >
> > [I-D.duke]
> https://datatracker.ietf.org/doc/draft-duke-shmoo-virtual-hum/
> > [PARTICIPANTS]
> https://ietf.org/how/meetings/108/session-participant-guide/

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 10 Jul 2020 10:30:16 -0400

My first reaction is that a recordable list of hands is useful for a 
different problem that WGs also have.  When the chairs asks "who commits 
to reviewing and contributing to this" it is useful to be easily able to 
note the hands.  If a WG does not want to use humms, it is free not to. 
Different process pieces.  (In terms of judging support rather than 
active work for a draft, I don't see much value in taking names at the 
virtual meeting, since it still needs to be confirmed on the list.  I 
may be missing the case you are considering Chris.)

Yours,
Joel

---

From: Andrew Campling <[email-masked]>
Date: Fri, 10 Jul 2020 15:02:56 +0000

Does this also present an opportunity to provide a method for those with hearing problems to participate? I'm told that the traditional, in-room humming can be problematic, could a second method be used alongside actual humming for those that might otherwise feel excluded?  

Andrew 

-----Original Message-----

--
108attendees mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/108attendees