Subject: IESG Statement On Oppressive or Exclusionary Language

From: The IESG <[email-masked]>
Date: Thu, 23 Jul 2020 09:35:45 -0700

The IESG believes the use of oppressive or exclusionary language is 
harmful.  Such terminology is present in some IETF documents, including 
standards-track RFCs, and has been for many years. It is at odds with 
our objective of creating an inclusive and respectful environment in the 
IETF, and among readers of our documents.

The IESG realizes that the views of the community about this topic are 
not uniform. Determining an actionable policy regarding problematic 
language is an ongoing process. We wanted to highlight that initial 
discussions about this topic are taking place in the general area (a 
draft [1] is slated for discussion in GENDISPATCH [2] at IETF 108).  
Updating terminology in previously published RFCs is a complex endeavor, 
while making adjustments in the language used in our documents in the 
future should be more straightforward. 

The IESG looks forward to hearing more from the community, engaging in 
those discussions, and helping to develop a framework for handling this 
issue going forward.

[1] https://datatracker.ietf.org/doc/draft-knodel-terminology/
[2] https://www.ietf.org/proceedings/108/agenda/agenda-108-gendispatch-03

---

From: Michael StJohns <[email-masked]>
Date: Thu, 23 Jul 2020 13:34:38 -0400

Hi -

I support the general goals you've stated below, but I have a few 
problems with how you're (IESG) suggesting we approach them.  Two in 
particular:

1) The onus for implementing whatever we end up deciding will be on the 
RFC Editor and the RPC - that argues that the primary driver of the 
language effort should be rooted over on the rfc-interest mailing list, 
and driven by the RSE (or the temporary equivalent) and not as part of 
the general area.  I'm not sure why this even needs to run past Dispatch?

2) I'm not enamored of the document [1] for a number of reasons:

  * At least three of the sources  (BrodieGravesGraves, Burgest, Eglash)
    are  behind paywalls making it difficult for anyone besides the
    authors to do a meaningful review
  * other sources appear to be paper only - at least there are no
    on-line references
  * there are few peer-reviewed scholarly papers referenced - it would
    be helpful to have more to strengthen any arguments rather than
    depending on popular press opinion pieces (Grewal, Jansens, McClelland)
  * because X, Y and Z did it isn't a great set of arguments for why we
    should do it (e.g, Drupal, Github, etc)
  * If we're going to get into this, we need to also address "master" as
    a stand-alone term, not simply in the context of "master/slave" -
    e.g. "master copy", "mastering a recording", "zone master file",
    "mastering a skill", "master controller". I'd *really* like to not
    have to do this multiple times because we lacked imagination or
    completeness.
  * the list of master/slave alternatives within the document doesn't
    really deal with the "controlling entity/controlled entity" pattern.

Later, Mike

On 7/23/2020 12:35 PM, The IESG wrote:
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Eliot Lear <[email-masked]>
Date: Thu, 23 Jul 2020 19:45:39 +0200

Hi,

I support this draft being adopted as a starting point, but I would like to see some substantial changes.  I have said this in other contexts, and I will say it here: what is needed is not a dictate on specific words, but rather a well-understood framework by which we decide these sorts of things.  I suggest that we do what we can to attract appropriate expertise into a working group to participate.

Eliot

> On 23 Jul 2020, at 18:35, The IESG <[email-masked]> wrote:
>

---

From: Richard Barnes <[email-masked]>
Date: Thu, 23 Jul 2020 13:53:15 -0400

Hi Mike,

I think you're taking the wrong approach here.  I would suggest approaching
this from a frame of compassion / honest effort instead of one of
engineering.  What matters here is making a good-faith effort at
inclusiveness, not nailing down every corner case.

Looking at your points in that frame:

1. Let's not sweat the procedural details here.  It doesn't matter if the
RFC Editor / RPC has the specific right set of instructions, what matters
is that we the IETF request that they keep certain things in mind with
regard to our documents.  As a way to help us keep ourselves honest.

2. While I respect your commitment to academic rigor, the quality of the
citations is not the most important thing here.  There are several clear,
well-known examples cited in the paper and acted on in several other places
across the industry, which illustrate the general path we should be on.
Again, where exactly we land on "master boot record" is kind of secondary;
the point is that we make the meta commitment to looking out for situations
like this and trying to work through them.

Cheers,
--Richard

On Thu, Jul 23, 2020 at 1:36 PM Michael StJohns <[email-masked]>
wrote:

> Hi -
>
> I support the general goals you've stated below, but I have a few problems
> with how you're (IESG) suggesting we approach them.  Two in particular:
>
> language effort should be rooted over on the rfc-interest mailing list, and
> driven by the RSE (or the temporary equivalent) and not as part of the
> general area.  I'm not sure why this even needs to run past Dispatch?
>
>    - At least three of the sources  (BrodieGravesGraves, Burgest, Eglash)
>    are  behind paywalls making it difficult for anyone besides the authors to
>    do a meaningful review
>    - other sources appear to be paper only - at least there are no
>    on-line references
>    - there are few peer-reviewed scholarly papers referenced - it would
>    be helpful to have more to strengthen any arguments rather than depending
>    on popular press opinion pieces (Grewal, Jansens, McClelland)
>    - because X, Y and Z did it isn't a great set of arguments for why we
>    - If we're going to get into this, we need to also address "master" as
>    a stand-alone term, not simply in the context of "master/slave" - e.g.
>    "master copy", "mastering a recording", "zone master file", "mastering a
>    skill", "master controller".  I'd *really* like to not have to do this
>    multiple times because we lacked imagination or completeness.
>    - the list of master/slave alternatives within the document doesn't
> IETF-Announce mailing [email-masked]://www.ietf.org/mailman/listinfo/ietf-announce
>
>
>

---

From: Ted Hardie <[email-masked]>
Date: Thu, 23 Jul 2020 10:54:46 -0700

Howdy,

> general area.  I'm not sure why this even needs to run past Dispatch?
For what it's worth, I disagree with this.  The primary mode of
implementation here for new work will be a change in community practice,
not a set of changes implemented at the end of the process by the RSE or
RPC.  It also seems to clear to me that it would be valuable for the other
streams to consider the same issues, but I don't believe that changing the
IETF's practice requires the consensus of the other streams to change.

To put this in a slightly different way, we're better off if alternatives
to terms like master/slave are considered and adopted by the working groups
who are building the technologies than if the alternatives are brought
forward only after the work is done.

As a result, I believe BCP and IETF processing is appropriate here, even if
the other streams adopt similar conventions.  It may still happen that
there are issues flagged late, but I'm guessing it would be at IESG review
rather than at the RPC exceptional circumstances.

regards,

Ted Hardie

---

From: Michael StJohns <[email-masked]>
Date: Thu, 23 Jul 2020 14:07:26 -0400

On 7/23/2020 1:54 PM, Ted Hardie wrote:
> Howdy,
>
> On Thu, Jul 23, 2020 at 10:36 AM Michael StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi -
>
>     problems with how you're (IESG) suggesting we approach them.  Two
>     in particular:
>
>     1) The onus for implementing whatever we end up deciding will be
>     on the RFC Editor and the RPC - that argues that the primary
>     driver of the language effort should be rooted over on the
>     rfc-interest mailing list, and driven by the RSE (or the temporary
>     equivalent) and not as part of the general area.  I'm not sure why
>     this even needs to run past Dispatch?
>
>
> implementation here for new work will be a change in community 
> practice, not a set of changes implemented at the end of the process 
> by the RSE or RPC.  It also seems to clear to me that it would be 
> valuable for the other streams to consider the same issues, but I 
> don't believe that changing the IETF's practice requires the consensus 
> of the other streams to change.

Hi -

I'm actually surprised that you think its a good idea to do this on a 
stream basis rather than on a community basis.   Regardless, the draft 
cited is pretty clear that it wants to add constraints to the RFC process:

>   RFC Editor MUST: * Offer alternatives for excluding terminology as an
>     important act of correcting larger editorial issues and clarifying
>     technical concepts and * Maintain a style sheet that collects all
>     terms that have been considered and indicate wheter they are deemed
>     acceptable, and if not what terms Authors should consider instead *
>     Suggest to Authors that even when referencing other specifications
>     that have not replaced offensive terminology, the Authors could use
>     another term in their document and include a note to say that they
>     have used the new term as a replacement for the term used in the
>     referenced document.
That puts the scope of the effort completely within the RFC model.   Or 
to put it another way, no one has any control about what goes into the 
IDs except the person that writes the ID.  The RFCs are from start to 
finish a product of the community and must meet the community standards.

>
> To put this in a slightly different way, we're better off if 
> alternatives to terms like master/slave are considered and adopted by 
> the working groups who are building the technologies than if the 
> alternatives are brought forward only after the work is done.
>
> As a result, I believe BCP and IETF processing is appropriate here, 
> even if the other streams adopt similar conventions.  It may still 
> happen that there are issues flagged late, but I'm guessing it would 
> be at IESG review rather than at the RPC exceptional circumstances.

I think I'm about to get into an argument about tail wagging and dogs, 
so I'm not going to do that. Suffice it to say, that you've got folks 
that submit to multiple streams and will have to follow different 
guidance on what's acceptable content for those streams.  Sounds 
confusing to me.   I think this is a community issue, not a IETF 
stream's issue and I think treating as an only an IETF stream's issue is 
just going to make more work for us and lead to less progress.

Later, Mike

>       * At least three of the sources (BrodieGravesGraves, Burgest,
>         Eglash) are  behind paywalls making it difficult for anyone
>         besides the authors to do a meaningful review
>       * there are few peer-reviewed scholarly papers referenced - it
>         would be helpful to have more to strengthen any arguments
>         rather than depending on popular press opinion pieces (Grewal,
>         Jansens, McClelland)
>       * because X, Y and Z did it isn't a great set of arguments for
>         why we should do it (e.g, Drupal, Github, etc)
>       * If we're going to get into this, we need to also address
>         "master" as a stand-alone term, not simply in the context of
>         "master/slave" - e.g. "master copy", "mastering a recording",
>         "zone master file", "mastering a skill", "master controller". 
>         I'd *really* like to not have to do this multiple times
>         because we lacked imagination or completeness.
>       * the list of master/slave alternatives within the document
>         doesn't really deal with the "controlling entity/controlled
>         entity" pattern.
>
>     Later, Mike
>
>>     [1]https://datatracker.ietf.org/doc/draft-knodel-terminology/
>>     [2]https://www.ietf.org/proceedings/108/agenda/agenda-108-gendispatch-03
>>
>>     [email-masked]  <mailto:[email-masked]>

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 23 Jul 2020 14:09:59 -0400

I was hoping the various "nits" tools would be updated to help authors.

tim

On Thu, Jul 23, 2020 at 2:09 PM Michael StJohns <[email-masked]>
wrote:

> That puts the scope of the effort completely within the RFC model.   Or to
> put it another way, no one has any control about what goes into the IDs
> except the person that writes the ID.  The RFCs are from start to finish a
> product of the community and must meet the community standards.
>
>
>
> As a result, I believe BCP and IETF processing is appropriate here, even
> if the other streams adopt similar conventions.  It may still happen that
> I think I'm about to get into an argument about tail wagging and dogs, so
> I'm not going to do that. Suffice it to say, that you've got folks that
> submit to multiple streams and will have to follow different guidance on
> what's acceptable content for those streams.  Sounds confusing to me.   I
> think this is a community issue, not a IETF stream's issue and I think
> treating as an only an IETF stream's issue is just going to make more work
> for us and lead to less progress.
>
> Later, Mike
>
>
>
>
> regards,
>
> Ted Hardie
>
>
>>    - At least three of the sources  (BrodieGravesGraves, Burgest,
>>    Eglash) are  behind paywalls making it difficult for anyone besides the
>>    - If we're going to get into this, we need to also address "master"
>>    as a stand-alone term, not simply in the context of "master/slave" - e.g.

---

From: Ted Hardie <[email-masked]>
Date: Thu, 23 Jul 2020 11:20:24 -0700

> cited is pretty clear that it wants to add constraints to the RFC process:
Just above the text you cite is this:

Authors SHOULD: * Replace the excluding term "master-slave" with more
   accurate alternatives, for instance from the list of Section 3.1.  *
   Replace the excluding term "blacklist-whitelist" with more accurate
   alternative, for instance from the list of suggested alternatives at
   Section 3.2.  * Reflect on their use of metaphors generally * Use the
   neutral "they" as the singular pronoun, and * Consider changing
   existing exclusive language in current (reference) implementations
   [socketwench] * Consult the style sheet maintained by the RFC editor.

Getting the cultural shift to this reflection on the consideration means
that it will be rare that the RFC editor will need to offer alternatives.
It also means the language in I-Ds and working group discussion will avoid
the terms early, rather than expecting a post-facto adjustment by an
expert.  A BCP covering the IETF practice here seems to me a useful thing
to do, even if all the other streams come to very similar practices.

Adjustment of the language of the draft to reflect that targeting would, of
course, be fine by me.

regards,

Ted Hardie

---

From: Michael StJohns <[email-masked]>
Date: Thu, 23 Jul 2020 14:31:22 -0400

On 7/23/2020 2:20 PM, Ted Hardie wrote:
> On Thu, Jul 23, 2020 at 11:08 AM Michael StJohns <[email-masked] 
>>     On Thu, Jul 23, 2020 at 10:36 AM Michael StJohns
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         Hi -
>>
>>         I support the general goals you've stated below, but I have a
>>         few problems with how you're (IESG) suggesting we approach
>>         them. Two in particular:
>>
>>         1) The onus for implementing whatever we end up deciding will
>>         be on the RFC Editor and the RPC - that argues that the
>>         primary driver of the language effort should be rooted over
>>         on the rfc-interest mailing list, and driven by the RSE (or
>>         the temporary equivalent) and not as part of the general
>>         area.  I'm not sure why this even needs to run past Dispatch?
>>
>>
>>     practice, not a set of changes implemented at the end of the
>>     process by the RSE or RPC.  It also seems to clear to me that it
>>     would be valuable for the other streams to consider the same
>>     issues, but I don't believe that changing the IETF's practice
>>     requires the consensus of the other streams to change.
>
>     Hi -
>
>     I'm actually surprised that you think its a good idea to do this
>     on a stream basis rather than on a community basis.   Regardless,
>     the draft cited is pretty clear that it wants to add constraints
>     to the RFC process:
>

Note the above does not say "IETF Stream Authors SHOULD".

>
> Getting the cultural shift to this reflection on the consideration 
> means that it will be rare that the RFC editor will need to offer 
> alternatives. It also means the language in I-Ds and working group 
> discussion will avoid the terms early, rather than expecting a 
> post-facto adjustment by an expert.  A BCP covering the IETF practice 
> here seems to me a useful thing to do, even if all the other streams 
> come to very similar practices.

I don't disagree with the first or second sentence, but this is not an 
IETF Stream nor an IAB Stream nor an IRTF Stream nor an Independent 
Stream issue, but a community issue directly related to the publication 
of RFCs.  If you set requirements for the RFCs, they flow back into the 
submissions from the streams.

This is not a IETF BCP issue - except as the RFC style guide might be 
adopted as a BCP.  E.g an update to RFC7322.

Later, Mike

>
> Adjustment of the language of the draft to reflect that targeting 
> would, of course, be fine by me.
>
> regards,
>
> Ted Hardie
>
>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 23 Jul 2020 14:37:57 -0400

It seems to me that the first place to do this is in I-Ds, even if we do 
not have strict enforcement mechanisms.  And if it is to be done in 
I-Ds, it is up to the individual streams to do so.  Having the IETF 
discuss doing this for IETF i_Ds seems a really effective and sensible 
starting point.

Yours,
Joel

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 23 Jul 2020 20:40:12 +0200

I think this document should become an indificual submission draft/RFC. It is a
good socio-linguistic research/position paper, but if we wold run it through a work
group process we would excude a lot of community members that are not interested
or fear getting into this type of socially critical discussions and we could get
 arbitrary ratholing about details from other community members. 

IMHO The actual work to be done to suggest a process for us would best be in a new
document that really only needs to be scoped on two simple questions: 

Abstract:

This document discussses:

  I)  How can we make new work product (RFC) use words that are not gratuitous
      metaphores without so significanty improving readability as to outweigh
      possible negative connotations of the metaphores ?

  II) How can we agree to as few a possible, consistent replacements for words falling into I)

For examples and justification see <individual-submission-doc>

/Abstract

Example for I): We should have a process that would also be able to cope with
words accepted to be problematic enough even if from different contexts:
   "kill" command in unix comes to mind
   "red" and "black" in accounting comes to mind

For I): I am mostly worried about as few as possible == consistent replacement words.

For something like blacklist/whitelist i think its eay to randomnly select a single
replacement. My random choice would be denylist/permitlist

For master/slave it seems more difficult:

In 2018, Python replaced uses of the term "master" variously with "main", "parent", and "server"; and "slave" with "worker", "child", and "helper", depending on the context.

Aka: these type of replacements are where the real problem will lie.

I would propose our process includes to capture/summarize all replacments/choices
we make on some page (like RFC editor abbreviations page). Maybe a wiki: 
outlining reasons for specific replacement word choices and also pointing which
older RFCs (which we can't change anymore) these should be equivalent...

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Michael StJohns <[email-masked]>
Date: Thu, 23 Jul 2020 14:52:38 -0400

On 7/23/2020 2:37 PM, Joel M. Halpern wrote:
> It seems to me that the first place to do this is in I-Ds, even if we 
> do not have strict enforcement mechanisms.  And if it is to be done in 

Do you expect the IAB and IRSG and the ISE to also do an evolution like 
this?   For example: Should the use of "master key"be banned in CFRG 
documents?  Isn't that a lot of redundant work?

When you say "IETF discuss", I'm assuming you have a WG in mind to do 
this work?  Or are we going to stand up yet another WG?  Or is the IESG 
going to decide on its own perhaps with some community input?

Why would you not let the RSE or the Temp (John) manage the process of 
updating the acceptable phrasings in the RFC series? Isn't that directly 
in their job description?

Later, Mike

---

From: "John Levine" <[email-masked]>
Date: 23 Jul 2020 14:56:23 -0400

In article <[email-masked]> you write:
>I support this draft being adopted as a starting point, but I would like to see some substantial changes.  I have said this in other contexts, and I will
>say it here: what is needed is not a dictate on specific words, but rather a well-understood framework by which we decide these sorts of things.  I suggest
>that we do what we can to attract appropriate expertise into a working group to participate.

Yes, exactly. I already sent a note to gendispatch saying that while I
concur with the general goals of draft-knodel-terminology I disgree
with pretty much all of the details.

With respect to whose responsibility this is, it absolutely has to be
the entire community, and definitely *not* something that waits until
a document gets to the RFC Editor. I have no interest in a job that
will be perceived by some authors as Language Policeman, and it is not
something I would ask our contractors at the RPC to do.

I would also not underestimate the mental effort involved in keeping
our documents clear and readable while also avoiding undesirable
metaphors. It is not somthing that mechanical tools can do -- while
there are certainly some words that shouldn't ever appear in RFCs, I
doubt many of them appear anyway. There are lot of words which are
entirely defined by context such as "master" where the authors need
to think about what they're trying to say.  No tool can do that for us.

R's,
John

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 23 Jul 2020 20:15:56 +0100

What approach should be used when the terms master/slave are used in third party specifications?

For example when referring to the IEEE 1588 Best Master Clock Algorithm?

- Stewart

---

From: Joseph Touch <[email-masked]>
Date: Thu, 23 Jul 2020 13:50:26 -0700

Hi, all

I think this doc could be more useful if it leaves the discussion and debate of context to a single background section with at most one paragraph each on a few examples. Instead, it should spend more time providing groups of suggested alternatives with explanations as to when each might be more accurate, e.g.:
	
	primary-secondary	when limited to two instances, one of which is privileged
	primary-replica	when more than two instances are possible, one of which is privileged

I agree that none of this doc should mandate when to use any particular alternate, but it should say that documents SHOULD NOT use the exclusionary language except in direct reference to legacy uses. Leave it to the community and RSE to help clean things up - and yes, tools help here too.

(i.e., I can’t see how we can get around pointing out the correspondence between current and legacy terms in future docs or external standards, not just here).

FWIW: alternates for primary-replica when one is in control could be:

	leader-follower
	commander-subordinate

Recognizing that this doc can never be complete, we should scrub the current RFCs for terms that we think should - or could - be used. Below are a few I found that we either need to provide alternatives for or explain are not currently known as problematic (i.e., a more complete ‘accept/deny’ list). It would also help to point out that the list should include other areas, such as:

	ageist terms
	sexist terms
	disability terms

Joe

--------

Additional “deny” list (note that most of these I either found in RFCs are other tech literature):

	grandfather(ed)
		legacy/legacied

	whitewash
		(none - euphemism that may be better phrased directly)

	black and white (referring to binary decisions with clearly desirable outcomes)
		(none - euphemism that may be better phrased directly)

	gyp (as in to short-change or cheat)
		cheat/swindle

	greybeard (as senior member of a community)
		senior member

	greylist (because it is derived from white/blacklist)
		partial accept/admit

	minon
		follower/subordinate

	dummy
		placeholder

	sanity check / reality check
		validity check / correctness check / confidence check / quick check

	bitch
		complain

	hobbled
		undermined / made less effective by 

	there’s also the question of whether we can avoid gendered terms for people (he/she/guys/dude, his/her)

“Accept” list (or at least I think they are; please point out if otherwise):

	black/red as network security levels

	black and white referring to images (i.e., binary greyscale)

	dark web/net

	grey web/net (as in partially dark)
		FWIW, I prefer “dim” to grey as being more clear, but that’s me

	white pages / yellow pages (refers to historical use of paper of those colors to publish phone directories)

	white paper (a brief though-piece)

	black hole

	black box

	red/green, red/yellow/green

	red (as a warning or error)

Joe

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 24 Jul 2020 10:41:36 +1000

My personal .02 -

This is a worthwhile topic for the community to consider, and past due.

However, it may be best to defer discussion of a Series-wide policy until we have a "full" RFC Series Editor (or the replacement for that role). Such a policy would inevitably place requirements on the RFC Editor, and may involve updating existing documents -- both contentious topics in the rfced-future program. And, while John is (IMO) a good candidate for owning such a discussion, the Temporary RFC Series Project Manager role explicitly excludes strategic ownership.

In the meantime, I think we should encourage individual streams to define policies on the terminology they use in drafts. For example, the IESG could formulate a (shorter) statement, circulate it in the community for discussion, and then post it. The IAB, IRTF and Independent streams could adopt that policy if they wished, or define their own.

This would also allow us to gain some operational experience with such a policy before nailing it down in an RFC.

Cheers,

P.S. I'm seeing 'main' used as a replacement for 'master' in a few places; e.g., `git checkout main` is easier, because you can type `ma` and then tab complete.

> On 24 Jul 2020, at 2:35 am, The IESG <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Joseph Touch <[email-masked]>
Date: Thu, 23 Jul 2020 19:01:05 -0700

FYI - in case it wasn’t clear:

a) I’m serious (this isn’t reductio ad absurdum) 
b) writing more professionally/collegially is more than just addressing two sets of terms

Joe

> On Jul 23, 2020, at 1:50 PM, Joseph Touch <[email-masked]> wrote:
> 
> Hi, all
>

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Jul 2020 14:34:18 +1200

> For example when referring to the IEEE 1588 Best Master Clock Algorithm?

Since you ask, the answer seems obvious: its name is "Master Clock" so there's nothing else you can call it. "Master" on its own is here to stay, anyway; in some contexts the proposed alternatives (like "main") simply don't work. That's why most of the advice to authors cannot be binary; we can't resolve this just with a blocklist approach.

While I'm here: it will be very unfortunate if the same guidelines are not followed by all the RFC Streams. Either this debate moves to an rfc-editor.org list as Mike suggests, or we handle it like IPR rules: the other streams watch the IETF's debate and then adopt and adapt the IETF's eventual guidelines.

    Brian

---

From: Joe Touch <[email-masked]>
Date: Thu, 23 Jul 2020 20:45:12 -0700

> On Jul 23, 2020, at 7:34 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> "Master" on its own is here to stay, anyway; in some contexts the proposed alternatives (like "main") simply don't work.

I have no idea why you could claim one works and the other does not.  

Master of what?

There may be better alternatives, such as canonical. But “master” isn’t a unicorn word. 

Joe

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Jul 2020 16:13:29 +1200

On 24-Jul-20 15:45, Joe Touch wrote:
> There may be better alternatives, such as canonical. 

"Canonical" applies in some circumstances but not always. You can sometimes use a
complicated formulation like "Authoritative server". But if you need to convey that
the entity in question gives instructions to other entities, any word you choose
will be synonymous with "master".

> But “master” isn’t a unicorn word. 

It's very common word with multiple meanings and applications.

    Brian

---

From: Joseph Touch <[email-masked]>
Date: Thu, 23 Jul 2020 21:33:07 -0700

> On Jul 23, 2020, at 9:13 PM, Brian E Carpenter <[email-masked]> wrote:
> 

Not in all senses; it is a few senses we’re trying to avoid.

Commander, leader, etc. all work - and don’t have the same problems.

Either we - as a community - care about using such words or we don’t. 

> It's very common word with multiple meanings and applications.

Although I agree we can’t avoid using the quoted term “IEEE 1588 Best Master Clock Algorithm”, we don’t need to use the term master beyond that sort of direct quote. “Master” on its own need not be here to stay. Words come and words go. It’s OK for us to choose to use other words except when citing legacy or external names.

In this case, it’s actually a poor choice anyway. Leader/follower is more accurate in this example anyway for many reasons (better aligns to multiple levels of the relation, better aligns to the sense in which each party participates, etc.).

But then this is what the doc could help with - providing useful and often more accurate alternatives.

Joe

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 24 Jul 2020 15:03:31 +0900

> [1] https://datatracker.ietf.org/doc/draft-knodel-terminology/

US centric view of the draft as if only blacks were slaves
is totally wrong only to make people in other part of the
world or with knowledge on world history upset or angry.

For example, Christianity was banned in medieval Japan
because Christians exported many Japanese as slaves.

For another example, in ancient Greece, many white people
were enslaved.

As "slave" has long established meaning having nothing
to do especially with blacks in recent (that is, for
these 100 or 200 years) US, it is stupid to ban it.

Or, should we avoid talking on ancient Greece, because
slavery was common?

						Masataka Ohta

---

From: Carrick Bartle <[email-masked]>
Date: Thu, 23 Jul 2020 23:12:12 -0700

I think we can all agree that slavery is bad, right? So why should we even allude to it in technical documents?

> 
> On Jul 23, 2020, at 11:09 PM, Masataka Ohta <[email-masked]> wrote:
> 
> The IESG wrote:
>

---

From: Lars Eggert <[email-masked]>
Date: Fri, 24 Jul 2020 09:14:34 +0300

> I was hoping the various "nits" tools would be updated to help authors.

https://github.com/codespell-project/codespell flags these things already. You need to run it manually, but that's not too much of a burden.

Lars

---

From: Lars Eggert <[email-masked]>
Date: Fri, 24 Jul 2020 09:17:17 +0300

I agree that this is a worthwhile effort. And:

> I agree that none of this doc should mandate when to use any particular alternate, but it should say that documents SHOULD NOT use the exclusionary language except in direct reference to legacy use…

+1

Lars

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 24 Jul 2020 15:54:48 +0900

Carrick Bartle wrote:

> I think we can all agree that slavery is bad, right?
> So why should we even allude to it in technical documents?

That is not a valid argument against some terminology,
especially because it should have been agreed so at
the time when the term of "master slave" was originally
coined.

That is, we have long established agreement to use words
to be considered bad by many for technical terms.

					Masataka Ohta

---

From: Eliot Lear <[email-masked]>
Date: Fri, 24 Jul 2020 09:24:42 +0200

Hi,

> It's very common word with multiple meanings and applications.

Herein lies the problem.  “Master” itself may not be a horrible word either. As we discussed on this list some two years ago, the entire basis of removing master/slave involves one anonymously reported incident and an essay by one person in a journal, who himself did an informal survey amongst a small number of friends and colleagues.  In that essay, Dr. Eglash did not claim his work to be dispositive, and so we should be careful about making such claims as well.

And it leaves us in a place where we truly do not know how to handle the next set of words.  And so some questions:

When is it reasonable to be offended by some language?
Have some number of people been offended by particular terms?
How do we test for this in some reasonable way?
What are the tradeoffs involving changes to language?  Remember, the point of language is to provide a stable means of communication.  That’s not to say it shouldn’t evolve, but we would be foolish to not examine the costs.
What other changes should we be making as an organization? (Not that this should block language changes, but if we only change language I fear we may fall short of any sort of goal toward inclusiveness we might have.)

Some phrases are obviously worse than others.

And I would point out that none of us involved in this discussion are experts on any of this (that includes the draft authors).  One aspect of taking on this work is that we really need to go get those people to participate.

Eliot

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 24 Jul 2020 10:06:12 +0200

On Thu, Jul 23, 2020 at 11:12:12PM -0700,
 Carrick Bartle <cbartle891=[email-masked]> wrote 
 a message of 33 lines which said:

> I think we can all agree that slavery is bad, right? So why should
> we even allude to it in technical documents?

It is bad for humans but, in RFCs, we are talking about network
entities, software. To take another example, we all agree that killing
humans is bad, yet we don't hesitate to kill a runaway program, for
instance. That's because human rights apply... to humans only, not to
processes.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 24 Jul 2020 10:16:24 +0200

On Fri, Jul 24, 2020 at 02:34:18PM +1200,
 Brian E Carpenter <[email-masked]> wrote 
 a message of 10 lines which said:

> Since you ask, the answer seems obvious: its name is "Master Clock"
> so there's nothing else you can call it. "Master" on its own is here
> to stay, anyway; in some contexts the proposed alternatives (like
> "main") simply don't work. That's why most of the advice to authors
> cannot be binary; we can't resolve this just with a blocklist
> approach.

And this is also why it cannot be implemented in tools. Even the best
AI cannot know if the use of a word like master is oppressive or not.

---

From: Christian Hopps <[email-masked]>
Date: Fri, 24 Jul 2020 04:51:37 -0400

It is bad b/c it has an actual and real impact on people today, it get's in the way of them being able to work/create most efficiently, it contributes to people not even going into technical fields.

The document actually talks to these points with some references.

Just b/c we have done things one way in the past does not mean we shouldn't strive to do better in the future.

Thanks,
Chris.

> On Jul 24, 2020, at 2:54 AM, Masataka Ohta <[email-masked]> wrote:
> 
> Carrick Bartle wrote:
>

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 24 Jul 2020 18:11:37 +0900

> The document actually talks to these points with some references.

I'm saying the document and the references are all too
much US centric ignoring both the original and established
meaning of "slave".

As

	https://www.etymonline.com/word/slave

	originally "Slav"

	Grose's dictionary (1785) has under Negroe "A
	black-a-moor; figuratively used for a slave,"
	without regard to race.

it should be OK to stop using "Negroe", but not "slave",
which are originally for Slav, whites.

					Masataka Ohta

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 24 Jul 2020 11:44:18 +0200

>     https://www.etymonline.com/word/slave

So maybe users of Slavonic languages (like me) should feel offended in
the first place. :-) It is worth pointing out that Czech equivalents of
master and slave are never used in a technical context - instead we
already use some neutral terms (or, sometimes the English terms without
any connotations). So, all this is basically a non-issue for the Czech
language.

It is perhaps also interesting that the Italian greeting "ciao" means
also the same as "schiavo" (in a Venetian dialect, I believe).

So I would also suggest not to over-react regarding master and slave.

Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Vittorio Bertola <[email-masked]>
Date: Fri, 24 Jul 2020 11:50:12 +0200 (CEST)

> Il 23/07/2020 18:35 The IESG <[email-masked]> ha scritto:
> 

While I share the basic motivations, and I have no problems with the wording changes that are proposed in the draft if the community wants them, I have a few comments on the approach.

First of all, we need principles and a method well before we start building lists of proscribed words. The referenced draft only seems to address what is offensive to a single ethnic group in a single country, i.e. African-Americans. However, a proper policy on this would address language that is offensive to any ethnicity, gender, culture, geographical origin and social background.

For example, quite a few Italian software developers feel offended by the widespread use of the expression "spaghetti code" - even if it purportedly refers to the structure of the code, it is not uncommon to see any code written by an Italian pejoratively defined like that, even when it is actually good code. I don't know if this expression is ever used in any RFC, but it is just to illustrate that the discussion should be about much more than "master/slave".

I am also a bit wary of attaching inherent negative and positive meaning to colours. Again, I have no problem in getting rid of "blacklist" if it makes other people happy, but statements such as "Blacklist-whitelist is not a metaphor for lightness or darkness, it is a good-evil metaphor" are unsourced or sourced with single references to militant scholars (e.g. Frantz Fanon). Colours are widely used in technical interfaces and specifications, but most of them can be attached to specific ethnicities (or political opinions and more), and it could be a problem if we had to get rid of them completely.

But more importantly, I think that any kind of word policing and cleaning up of text is hypocritical if the problem of the actual inclusiveness and diversity of participation in the IETF is not addressed. Actually, I dislike word policing because it too often becomes a way for organizations to whitewash(*) themselves while perpetuating their imbalances of representation and power.

To be practical: the draft was proposed two years ago on HRPC and even there it could not reach consensus. Given how sensitive the subject is, I would suggest that we would dispatch it to a specific working group with the task of working out a general mechanism that can apply to any past and future case of offensive language. The specific terms to avoid, and how to deal with them, should then emerge as an initial application of that mechanism. 

It would however be much better if the group were also tasked with developing a strategy to increase the overall diversity of participation in the IETF and in its leadership roles.

(*) used in the primary British English meaning of https://dictionary.cambridge.org/dictionary/english/whitewashing #1, and also as an example of a word associating white with something negative

-- 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Vittorio Bertola <[email-masked]>
Date: Fri, 24 Jul 2020 12:13:32 +0200 (CEST)

> Il 24/07/2020 11:44 Ladislav Lhotka <[email-masked]> ha scritto:
> 
> > As
> > 
> the first place. :-)

Though the most likely etymology goes the opposite way: "Slav[[on]ic]" seems to be an autochtonous term that was then imported into medieval Latin as "sclavus", with the meaning of slave, in the second half of the first millennium, when the Byzantine and Holy Roman empires used to get their slaves from those peoples. So slavery was named after Slavonic peoples, not the opposite. But it looks like those peoples have long overcome the trauma :-)
 
> also the same as "schiavo" (in a Venetian dialect, I believe).

Sure, from Venice via Lombardy, with the same meaning as the Bavarian-Austro-Hungarian "servus".

(Perhaps we do need an IETF list for language curiosities after all)

---

From: tom petch <[email-masked]>
Date: Fri, 24 Jul 2020 12:53:06 +0100

> instance. That's because human rights apply... to humans only, not to

Where will it end?  I see the widespread use in technology of male and 
female, as in plug and socket, which will be exclusionary to non-binary; 
as is perhaps the use of 'binary' in technical documents.

This statement has a very narrow focus and one that seems to me, as a 
European, to be US-centric, perhaps exlusionary to other countries.  How 
relevant is it to China or Brazil or   ..?

I wish I was joking but I see this as the thin end of a wedge that will 
disrupt the work of the IETF.

Tom Petch

> .

---

From: Lars Eggert <[email-masked]>
Date: Fri, 24 Jul 2020 15:32:41 +0300

Hi,

I've been reading this thread, and don't understand how this IESG statement is controversial.

Many of us learned in recent years that some terminology and language that's been used in the past alienates or is otherwise objectionable to a part of our community. Alternative terms readily exist, sometimes even offering a more precise meaning. How is it not the right thing to simply start using these alternative terms when we can?

Sure, an occasional change in terminology is only a small step. But it's still moving us in the right direction, and costs us practically nothing.

Lars

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 24 Jul 2020 13:47:52 +0100

Lars Eggert wrote on 24/07/2020 13:32:
> Sure, an occasional change in terminology is only a small step.
as a general observation, languages and customs evolve continuously, and 
things that were written 100 or even 50 years ago often strike us as 
discriminatory or use terms which are now considered offensive to one 
degree or another.  It would be unusual not to change aspects of 
terminology over time.

Nick

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 24 Jul 2020 23:23:42 +1000

> I think we can all agree that slavery is bad, right? So why should we even allude to it in technical documents?

We can all agree that slavery of humans is bad, but I own my cat and when I say he's not allowed on the table he's damn well not allowed on the table (at least when I'm in the room, I'm pretty sure he parties on there when I'm out).

Is he my slave?  I'm certainly the boss of him and can put him in a little cage against his will and take him to the vet to get his balls chopped off.

So yep, I'm against the slavery of humans (while acknowledging that there's equipment right here on the desk in front of me, and clothing on my body, which was almost certainly made by people who live as slaves for all intents and purposes).

Language evolves, and I'm happy to evolve along with it, but let's not go conflating "the sale and bondage of human beings is bad" with "the concept of non-human entities having complete control over other non-human entities is bad".

Cheers,

Bron.

(and I never call my cat a slave, but I do call him other unsavoury things that don't belong in an RFC when he shoves his smelly butt at my face while I'm trying to focus on a call)

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Christian Hopps <[email-masked]>
Date: Fri, 24 Jul 2020 09:36:19 -0400

The impact of simply reading the terms master and slave over and over, is perhaps proportional to the impact slavery has had directly on a persons life (e.g., the racism that continues to exist today). So it's not surprising that some of us might not have recognized the impact those terms had on others who have had different life experiences.

Thanks,
Chris.

> On Jul 24, 2020, at 9:23 AM, Bron Gondwana <[email-masked]> wrote:
> 
>   [email-masked] <mailto:[email-masked]>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 14:05:18 +0000

To say "this only covers part of the problem" is reasonable.  To add "therefore we should do nothing" is not reasonable.  A better approach is to say "this covers part of the problem, here are other areas to address"

Yes, it is probably a US-dominated view of things, and yes it refers to relatively recent history.  The IETF was US-dominated and needs to fix some of the things (such as implicit bias) it brough to the table, in order to make room for more seats at the table.

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 14:08:44 +0000

So why not use other words that many do not consider bad or hurtful?

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 24 Jul 2020 23:19:43 +0900

Salz, Rich wrote:

 > Yes, it is probably a US-dominated view of things

And, I feel offended if US people insist on distorting the
meaning of "slave" only mean black slaves ignoring sad history
of enslavement of yellows (and whites).

> The IETF was US-dominated

It was but isn't.

							Masataka Ohta

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 14:22:01 +0000

Okay, I understand that. If things like the Knodel draft move forward, will you bring that viewpoint into discussion of it?  If not, then that viewpoint might not get represented.

>    It was but isn't.

Yes, and I was explaining why we should address some mistakes of the past.  That doesn't mean ignoring other mistakes; sorry if I gave that impression.

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 16:39:13 +0200

> > The IETF was US-dominated

Check out what percentage of people in any role other than individual contributor
are neither US citizens, live in the US or do not draw money from a US company/organization.

If that iss not a good definition for IETF being a US-dominated organization, then please tell me yours.

Toerless

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 24 Jul 2020 16:12:34 +0100

> On 24 Jul 2020, at 09:16, Stephane Bortzmeyer <[email-masked]> wrote:
> 

.. and of course why it cannot be properly  litigated against in an RFC.

The OED defines it as 
†a.  gen. A person (predominantly, a man) having authority, direction or control over the action of another or others; a director, leader, chief, commander; a ruler, governor. Obsolete(archaic in later use).

And when we use it technically we are using it in the same sense but applied between automatons that feel no slight.

The word goes back to old English but the first quotes use in the OED in the modern spellings is in the King James Bible (1611), so I imagine that it unlikely to be expunged from common English any time soon.

The first use in conjunction with slavery seems to be 1833 so it is a much more recent definition.

If you look overall with the OED entry the context in which the authors of the draft raise the term is relatively infrequent, with most associations seemingly relatively benign.

FWIW the first technical reference to master-slave seems to be in 1952 and in reference to the a system for the manipulation of irradiated items rather than computers.

The first technical introduction of master-slave I had was the context of a J-K flip-flop where it describes the relationship extremely well. The master takes arbitrary action and the slave has no choice but to follow or very occasionally rebel (metastability is is a big problem in flip-flops) so in many ways the term is a perfect fit. What is the new standard term in that context?

- Stewart

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 17:14:59 +0200

> P.S. I'm seeing 'main' used as a replacement for 'master' in a few places; e.g., `git checkout main` is easier, because you can type `ma` and then tab complete.

I like main too.

One problem we have not discussed in the thread is that of the euphemism treadmill:

So now we use maybe "main" instead of "master" and "secondary" instead of slave,
and a new round of the treadmill starts, and not in our industry, but in the
culture of the USA people start to diss each other as "main" and "sec"'s,
and 20 years from now we're sitting on exactly the same mail thread and argue
about replacing min and sec.

So question: Would we nail down that we will stick to perpetuity in new work
to terms we once choose before they had negative connotations, or will we
commit ourselves to willingly follow the need to periodically follow 
euphemism treadmill cycles ?

One could of course try to always pick words so obscure that the chance of getting
abused into a euphemism cycle is low. E.g.: i feel pretty confident that
permitlist/denylist will be safe for perpetuity.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 24 Jul 2020 16:18:06 +0100

> On 24 Jul 2020, at 10:11, Masataka Ohta <[email-masked]> wrote:
> 
> Christian Hopps wrote:
> 

The earliest OED entry is 
a. One who is the property of, and entirely subject to, another person, whether by capture, purchase, or birth; a servant completely divested of freedom and personal rights.

c1290    S. Eng. Leg. <> I. 106   He was sone i-nome, Ase a sclaue forth i-lad and i-don in prisone.

- Stewart

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 15:24:10 +0000

That's fine.  Language evolves.  As do standards.  Nobody will ever need more than 640Kb.  Nobody will ever need more than 32bits of IP address.  Why should a document be different?

---

From: "John Levine" <[email-masked]>
Date: 24 Jul 2020 11:26:37 -0400

In article <[email-masked]> you write:
>"Canonical" applies in some circumstances but not always.

The historical meaning of "Canonical" is that something is part of the
canon of Christian scripture. It by implication excludes people from
other cultural backgrounds.

I'm not sure whether I believe that, but we're sitting on a whole lot
of turtles here.

R's,
John

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 17:31:26 +0200

Stewart:

The word master even by itself is still a metaphore for a type of roles
by humans. Hence it is exposed to negative connotations that apply
to its use in humans. 

Thats why i was suggesting our rule could be:

E.g.: forget existing use for a moment, and try to figure out what the
best word in new work could be. Difficult of course, because at the time
of putting the new work together, metaphores from past work will most likely
most easily be comprehended, but not necessarily so when thinking about readers
10 yers in the future.

Funnily enough, in my observation its only engineering work product where
metaphores are so dominant to ease understanding. In patents and research
papers, it seems a lot more common to create new words for concepts just
to make the work product look more novel. I was always cynical about this
"re-branding" (*) but maybe in the context of this discussion it actually helps.

And i think readability is core to escape as much as possible the
euphemism treadmill problem.

Cheers
    Toerless

(*) I have already sent a letter of self incrimination to PETA for the use of the word branding.

On Fri, Jul 24, 2020 at 04:12:34PM +0100, Stewart Bryant wrote:
> ... and of course why it cannot be properly  litigated against in an RFC.
> 
> The OED defines it as 
> ???a.  gen. A person (predominantly, a man) having authority, direction or control over the action of another or others; a director, leader, chief, commander; a ruler, governor. Obsolete(archaic in later use).
> 

-- 
---
[email-masked]

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 09:00:14 -0700

+1

> On Jul 24, 2020, at 5:32 AM, Lars Eggert <[email-masked]> wrote:
> 
> Sure, an occasional change in terminology is only a small step. But it's still moving us in the right direction, and costs us practically nothing

We follow grammar and punctuation rules, with exceptions.

I don’t think anyone is claiming we won’t have exceptions here or that tools will be perfect (the current tools aren’t either).

The point is to:
- highlight the concern (from a *variety* of perspectives - race, oppression, sex, gender, ethnicity, national identity, age, etc.) 
- provide some other terms that are often more precise anyway
- provide / evolve tools to help identify uses to be considered more closely

Let’s be clear that this community generates a lot more position statements that are of less utility. IMO, let this one proceed.

Joe

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 24 Jul 2020 11:05:29 -0500

On 24 Jul 2020, at 4:50, Vittorio Bertola wrote:

> To be practical: the draft was proposed two years ago on HRPC and even 
> there it could not reach consensus. Given how sensitive the subject 
> is, I would suggest that we would dispatch it to a specific working 
> group with the task of working out a general mechanism that can apply 
> to any past and future case of offensive language. The specific terms 
> to avoid, and how to deal with them, should then emerge as an initial 
> application of that mechanism.
>
> It would however be much better if the group were also tasked with 
> developing a strategy to increase the overall diversity of 
> participation in the IETF and in its leadership roles.

This is good input into the gendispatch discussion that is going to 
happen next week. If other think that this work should go to a working 
group, or to a different sort of group (the RFC Editor; the IAB), or not 
be worked on at all, your presence at the gendispatch meeting next week, 
or input to the gendispatch list, would be greatly appreciated.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 18:12:37 +0200

> That's fine.  Language evolves.  As do standards.  Nobody will ever need more than 640Kb.  Nobody will ever need more than 32bits of IP address.  Why should a document be different?

But that's different. The problem is to recurringly changing the words for
the same subject because a prior word was abused AFTER it was choosen to
address the subject.

There is a good amountd of justice for this euphemism treadmill when a new
word is picked as a euphemism without the problematic nature of the underlying
subject to be resolved. But in our case the situation is different. Our
subjects are never the ones with problematic subject matter. Its only that
our words are typically metaphors for subjects where either the original subject
is problematic, or the use of the word for the original subject has attained
_some_ negative connotations.

Cheers
---
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 16:26:30 +0000

Thou varlet, I am woefully sorry that you feel that way.

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 24 Jul 2020 16:32:28 +0000

+1

On 7/24/20, 8:33 AM, "ietf on behalf of Lars Eggert" <[email-masked] on behalf of [email-masked]> wrote:

    Hi,

    Lars

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 25 Jul 2020 01:50:28 +0900

Salz, Rich wrote:

>> meaning of "slave" only mean black slaves ignoring sad history of
>> enslavement of yellows (and whites).

> Okay, I understand that. If things like the Knodel draft move
> forward, will you bring that viewpoint into discussion of it?  If
> not, then that viewpoint might not get represented.

As I already expressed my viewpoint here in IETF list where the
draft is now under discussion, how can you say the viewpoint be
brought to discussion of the draft?

> Yes,

No, it isn't.

> and I was explaining why we should address some mistakes of the
> past. That doesn't mean ignoring other mistakes;

I can see no mistakes. Could you elaborate what "some" and "other"
mistakes are?

							Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 25 Jul 2020 02:00:12 +0900

Salz, Rich wrote:

> Language evolves.  As do standards.

Evolution needs time.

> Nobody will ever need more than 32bits of IP address.

See what happened to poor IPv6 for these 15 years.

No, I don't think IPv6 necessary especially because properly
architected NAT can enjoy the full end to end transparency.

						Masataka Ohta

---

From: Bob Hinden <[email-masked]>
Date: Fri, 24 Jul 2020 10:07:35 -0700

Lars,

> Sure, an occasional change in terminology is only a small step. But it's still moving us in the right direction, and costs us practically nothing.

Well said.   We can’t fix the world, but we can fix the part we have control over.

Bob

---

From: Victor Kuarsingh <[email-masked]>
Date: Fri, 24 Jul 2020 13:08:44 -0400

On Fri, Jul 24, 2020 at 12:33 PM Livingood, Jason <
[email-masked]> wrote:

> +1
>
> On 7/24/20, 8:33 AM, "ietf on behalf of Lars Eggert" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Hi,
>
>     Many of us learned in recent years that some terminology and language
> that's been used in the past alienates or is otherwise objectionable to a
> part of our community. Alternative terms readily exist, sometimes even
> offering a more precise meaning. How is it not the right thing to simply
> start using these alternative terms when we can?
>
>     Sure, an occasional change in terminology is only a small step. But
> it's still moving us in the right direction, and costs us practically
> nothing.
>

This may be true.  Have we assessed the full impact of doing so, and what
issues it may raise to the contrary?    Some of the challenges I see
(forgive me if I have missed substantive discussion points on this matter
to date) include:

- Language evolves (especially english), so the meaning of words are not
constant
- Often terms (or words) have more than one meaning, and how do we provide
consistency in approach to terms/words we should avoid?
- in Reading "draft-knodel-terminology-03.pdf", I see a number of good
points noted, but I did not see much in the way of describing the counter
argument (or at least impacts of such)
- The IETFs work often intersects work from other organizations/communities
outside of those listed in the draft above (e.g. . Have we assessed the
impacts of potentially changing things such that it is not not consistent
with works that are produced outside the IETF but also intersect with the
IETFs?
- In the draft noted above, I would argue that some of the suggested terms
may not actually be more technically accurate (it depends).   Often the
words/terms most meaningful are those recognized by the audience in
addition to the author (where the audience may be a very large extended
group)
- if alternative terms can be used in some instances, but perhaps less
appropriate in others (based on technical accuracy or consistency), does
the divergence of terms across intersecting technologies,
implementations or documents matter?

I am certainly not advocating to not go down this path, but would think
understanding the impacts of doing so are important.

regards,

Victor K

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 17:12:55 +0000

Well, one can hope that if the document is adopted somewhere, that the people in the WG/RG/Program/whatever will recall all the IETF talks.  Or, one can participate.  Trade-offs and limitations in each approach, as is usual.

>    I can see no mistakes. Could you elaborate what "some" and "other"

I believe that it is still a mistake to use terms like blacklist/whitelist and master/slave in technology documentation.  I am not the only one who thinks so. There are some who believe this is not a mistake.  Oh well, that's why we have "rough consensus" here.  There are probably other terms and mindsets which have resulted in off-putting or even exclusionary behavior. I will not propose a list here (easy one: why our 1-1-1 policy doesn't include other continents?), but I would consider anything in that category to be a mistake. Likewise, treating slavery as purely a black/white issue through the lens of US history is also a mistake.

Hope this helps.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 24 Jul 2020 09:41:00 -0800

Thanks for the thoughtful questions, Victor.

I think the set of terms under consideration here is quite
limited, and the remediation being proposed is similarly
limited, so I'm not that concerned about potential impacts.
I do think it would be a terrible idea to try to develop an
exhaustive list of alternatives but a few examples might not
be a terrible idea.

One thing I think we need to be clear about is that we can
only change what we do, not what others do, and if a reference
from an older document or from another body contains language
we no longer use we can add a few clarifying sentences.

Having recently been through this in non-IETF contexts (including
some truly hairball build/CI environments), the _decision_ to
try to avoid exclusionary language can feel burdensome but the
_implementation_ effort is really pretty trivial.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 11:57:13 -0700

Based on the evolution of this discussion, I have concluded that the only useful way forward for me is:

- *I* plan on keeping a list of my own of terms to avoid
- *I* plan to avoid using them
- *I* plan to complain when others use them in docs I review

The IESG and IETF can do as it wants, but ultimately this comes down to what we, as individuals, believe and do.

Joe

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 24 Jul 2020 21:15:11 +0200

> - *I* plan on keeping a list of my own of terms to avoid

Can you put it in a place where we can find it for reference?

We don’t need consensus on these lists, but we do need to be reminded.

Grüße, Carsten

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 12:48:47 -0700

Hi, John,

> On Jul 24, 2020, at 8:26 AM, John Levine <[email-masked]> wrote:
> 

It originates from a word that meant “rod” (as a measuring device). As with many of these words, it has many meanings and inferences that evolved since; the use of the term as generic “standard of measure” goes back to the 1400s; the most recent new meaning is “from the approved list of authors” of a body of work.

But the question is not just the origin or even how many current meanings a term has; it’s whether others consider its use exclusionary. 

So far, I am not aware that the term “canonical” has that exclusionary sense. To date, the only examples I’ve seen actually use the terms canon and canonical in discussions about the ways in which sets of documents (canon) or exemplars (canonical) are themselves exclusionary.

HOWEVER, if we hear “social consensus” (i.e., not just those having this discussion, but examples outside the IETF) where this term is considered problematic, I will add it to my list of terms to avoid happily.

Joe

---

From: Ole Troan <[email-masked]>
Date: Fri, 24 Jul 2020 22:20:43 +0200

And you think this discussion isn’t exclusionary?

O. 

> On 24 Jul 2020, at 21:49, Joseph Touch <[email-masked]> wrote:
> 
> Hi, John,
>

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 13:35:37 -0700

> And you think this discussion isn’t exclusionary?

Just as “free speech” cannot include “speech” that restricts the speech of others, avoiding exclusionary language cannot avoid excluding those who consider that language appropriate.

If that’s what you mean. If not, it would be useful to explain.

Joe

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 24 Jul 2020 23:15:17 +0200

> Thou varlet, I am woefully sorry that you feel that way.

Not sure i understand what you mean:

You think it is not only unavoidable, but also fine if over time we have to periodically
change the word we use for the same subject because word N-1 has accumulated to much
negative connotations ?

If not that, then pls. rephrase.

Thanks!
    Toerless

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 21:52:00 +0000

Yup.

---

From: Randy Presuhn <[email-masked]>
Date: Fri, 24 Jul 2020 14:56:50 -0700

Hi -

On 7/24/2020 2:15 PM, Toerless Eckert wrote:
....
> change the word we use for the same subject because word N-1 has accumulated to much

It's not unheard of for languages to do that.  An obvious example
is the German word "Frau".  The Middle-high German equivalent in
meaning is "wîp".  "Wîp" (which has since become "Weib") had accumulated
too many negative connotations, so usage appropriated "vrouwe" 
("noblewoman",
modern orthography "Frau") to serve the more general purpose.

Randy

---

From: Melinda Shore <[email-masked]>
Date: Fri, 24 Jul 2020 13:58:35 -0800

> change the word we use for the same subject because word N-1 has accumulated to much

I'm old enough to have seen these sorts of acceptability shifts happen
in English a few times, and my sense is that it happens roughly once or
twice per generation.  I think that argument is a red herring.

Melinda

-- 
Melinda Shore
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Fri, 24 Jul 2020 14:59:25 -0700

Surely we could reference someone else's list of terms and suggested
alternatives, as it is otherwise susceptible to bikeshedding, where everyone
has uncountable opinions.

<bikeshed>
Mastery. Masterpiece. Concertmaster. Master class. Maestro. 
MA, Master of Arts; MS, Master of Science; MBA, Master of Business
Administration.
 To master a subject. Masterscope (called Scope in my thesis). 
</bikeshed>

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 00:56:54 +0200

Joe, *:

Here is how i think this whole effort is exclusionary: 

For the mayority of writers and even more so readers of IETF documents,
english is not the first language. Even for any non-american native english
speaker, i wonder how much they feel that there is a need to update the language
used by the IETF for what arguably is primarily a US social problem: Dealing with 
a still seemingly not well enough handled history of afro-american racism and slavery. 

This effort of language change if it is then adopted officially in IETF or RFC
editor will undoubtedly reconfirm the perception if not reality that the IETF
is a strongly USA dominated institution:

- IETF chair lives in USA works for USA company
- 12 of 14 IESG members live in the USA and/or work for USA companies.
- 10 out of 13 IAB members live in the USA and/or work for USA companies.
- Anybody want to take a bet what percentage of WG chairs live in the
  USA and/or work for a USA company ?
- Any of the other leadership roles ?

While in the past USA leadership was seen as very positive, unfortunately this
has changed around the world, and this effort has good chances to also be
seen in that light:

In this case, we have a situation where (if i analyze it correctly) not even 
the long-term IETF community, but one from outside the IETF brings this USA centric
social issue into the IETF, and the USA centric active IETF community is directly
jumping on this boat because they confuse whatever might be good for their
countries community to be equally good for the supposedly much larger 
and supposedly much more diverse and inclusive global IETF community. To me, this
is a sign of even stronger USA influence than anything technical we had so far.

IMHO this is NOT going to be perceived well in the worldwide IETF community,
instead, this will create more ridicule about bullish USA centric influence
and  control of the IETF. 

I for once learned a lot of network/software terminology from german language 
books using american terms. For all intent and purpose the mayority of the
worldwide IETF community  and even moree so the readers of IETF products (RFCs)
uses english ONLY as a technical language in a similar fashion. Why would
that community have to care about social issues in the USA in their
technical language ? Change english originated technical terms in maybe
a hundred foreign language books to match latest IETF documents ?
Retrain students all over the world about technical networking terms
and having to explain USA history in its wake ? And that going to play positive ??

How about we create an RFC-editor language advisory board: 10 people
selected at random from the active community, at most 2 first-language english
speakers, at most 2 first-language chinese speaker, at most one first-language
speaker for any other language. That would be a good starting point
to decide what does and what does not qualify as IETF community relevant
RFC language problems.

Otherwise, we could simply replace any english term we do not like as
americans with a french term for use in the IETF. They have a long history 
of trying to keep their own language freee of english influence, and AFAIK
they even have a government oversight board for such terminology, so i am
sure they will have a technical terms for anything we need and those
terms have been vetted professionally. Might even get lower hotel rates
next time in Quebec if we do this ;-)

Cheers
    Toerless

On Fri, Jul 24, 2020 at 01:35:37PM -0700, Joseph Touch wrote:
> > And you think this discussion isn???t exclusionary?
> > 
> > O. 
> 
> Just as ???free speech??? cannot include ???speech??? that restricts the speech of others, avoiding exclusionary language cannot avoid excluding those who consider that language appropriate.
> 
> If that???s what you mean. If not, it would be useful to explain.
> 
> Joe

-- 
---
[email-masked]

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 15:58:46 -0700

> On Jul 24, 2020, at 2:59 PM, Larry Masinter <[email-masked]> wrote:
> 

I’m sure there are such lists that take into consideration the kinds of terms and usages typical in Internet technology.

I wonder where someone might look to find that sort of thing.

Oh, right. Here.

Joe

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 16:04:41 -0700

> On Jul 24, 2020, at 3:56 PM, Toerless Eckert <[email-masked]> wrote:
> 
> Joe, *:
> 

I tried to point out in my examples that this goes far beyond a US problem or the specific problem of slavery.

It might also be useful to keep in mind that slavery had existed for thousands of years before there ever was a US.

Yes, because we write our docs in English, many terms are particular to the English language, but not just US-English either.

If the worldwide community thinks that being respectful of others is a bad thing, then so be it.

Joe

---

From: Viktor Dukhovni <[email-masked]>
Date: Fri, 24 Jul 2020 21:11:51 -0200

> AI cannot know if the use of a word like master is oppressive or not.

And we also know that language policing can be an oppressive and
exclusionary tool, and a great deal of caution and discretion is
required to avoid that outcome.

   http://paulgraham.com/orth.html

Indeed at the IETF what is probably most oppressive and exclusionary is
clubbiness and group-think by the established cliques in working groups,
that makes outsiders unwelcome because of their outsider perspective.

Policing of language may well reinforce that dynamic, and make the IETF
even more of an exclusive club than it already is.  Policing of language
creates a climate of fear and empowers politically strident voices at
both ends of the spectrum.  It can turn all speech political, and can
backfire by amplifying conciousness of ethnic/racial/gender distinctions
and by stoking resentment.

The cited evidence that technical terms play a meaningful role in
deterring participation by under-represented groups looks rather anecdotal.
For more credible deterrents look at lack of educational opportunities,
cultural attitudes to interests technology (popular terms such as nerds,
geeks, ...), perceived employment prospects, absence of role models etc.

To see the inefficacy of language policing, contrast the historical
official discourse of soviet-block countries, with its purported
internationalism, denunciation of racism, etc. with the reality that
xenophobia was and still is much more prevalent in eastern Europe than
in liberal democracies to the west.

Of course wide disconnects between official ideology and reality are not
limited to the Soviet block, they are rather a fundamental feature of
totalitarian systems.  The more removed the ideals from actual practice,
the more power to arbitrarily impose penalties when convenient.

Mere good intentions don't always produce good outcomes.  I do not
impute ill motives to those who are trying to make the world a more
just place, but I am rather sceptical that the proposal at hand does
more good than harm.  I am quite sure that it is exclusionary to those
who see the tradeoffs in a different light, and are justly afraid to
speak up given the current political climate.  At the same time, the
bad words to be banned are only speculatively and tenuously exclusionary
for the under-represented groups the proposal is intended to support.

A great deal of caution is therefore appropriate in moving forward in
the proposed direction.  Where the existing terms of art are unclear,
and alternatives are better and/or more widely understood, working
groups can and often will encourage authors to choose clearer terms.

Otherwise, absent manifestly provocative or hostile intent (we'll
generally only know it when we see it), it is likely best to not police
language merely on the grounds that it uses words that out of context
are tenuously connected to (might remind one of) a present or historical
injustice.

-- 
   Viktor.

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 01:17:05 +0200

Thanks, Rich,...Melinda

I probably agree on this, for how languages are used in the human culture, and i
think i only do not like this when it happens as part of a euphemism treadmill, but this is
not i think what is proposed here, although we still might fall into future traps.

Instead, the problem with the suggested process is really more about the inclusiveness
re. the actual IETF community and the target RFC reader community. See the "USA dominion" thread.

Cheers
   Toerless

---

From: Rob Evans <[email-masked]>
Date: Sat, 25 Jul 2020 00:18:52 +0100

> Even for any non-american native english

FWIW, I am not from the US, my native language is en-GB (with a little
bit of "cy"), and I disagree with this characterisation of the problem
to solve within the IETF.

Cheers,
Rob

---

From: Mary B <[email-masked]>
Date: Fri, 24 Jul 2020 18:22:32 -0500

You might also want to consider that it isn't just a US majority, it's a
white male US majority, which is also an issue IMHO.   The same applies for
WG chairs etc.  Indeed, I would posit that the lack of diversity when it
comes to gender is also a huge issue with the organization.

Regards,
Mary.

On Fri, Jul 24, 2020 at 5:57 PM Toerless Eckert <[email-masked]> wrote:

> > Just as ???free speech??? cannot include ???speech??? that restricts the
> speech of others, avoiding exclusionary language cannot avoid excluding
> those who consider that language appropriate.
> >

---

From: Jacob Uecker <[email-masked]>
Date: Fri, 24 Jul 2020 16:30:31 -0700

+1  

> On Jul 24, 2020, at 4:24 PM, Mary B <[email-masked]>
> 
> You might also want to consider that it isn't just a US majority, it's a white male US majority, which is also an issue IMHO.   The same applies for WG chairs etc.  Indeed, I would posit that the lack of diversity when it comes to gender is also a huge issue with the organization.
> 
> Regards,
> Mary. 
>

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 24 Jul 2020 23:25:37 +0000

*     Indeed, I would posit that the lack of diversity when it comes to gender is also a huge issue with the organization.

Strongly agree.

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 02:01:48 +0200

> I tried to point out in my examples that this goes far beyond a US problem or the specific problem of slavery.

If the process is being let run by the people who started it, then it
will not result in any word change outside of their their area of interest.

Ho about my proposal for a language steering group constituted from members
from all type of language backgrounds. you did not comment about that.

> It might also be useful to keep in mind that slavery had existed for thousands of years before there ever was a US.

Sure.  Whats your point ?

> If the worldwide community thinks that being respectful of others is a bad thing, then so be it.

Software components are not humans. Giving role names to technical constructs that
are considered to have negative connotations when applied to humans imho in
no way means to endorse or even trivialize the human application IMHO.

And i am not saying we should use such terms, i am just rejecting your claim
that its use implies respectlessness to others.

Of course, the wider the audience is you want to reach and the younger it may be
be the more difficult it is to use word where you need to make such distinctions
between human and other situations.  I personally do not think this is an
actual issue for IETF output.

If we had a steering group with really diverse backgrounds (as i proposed),
such as also from africa and parts of asia, where there is real slavery, and
such a steering group would suggest such language  changes in the IETF, i think that
would carry a lot more weight for the IETF community than the USA centric effort
that we see happening now.

Cheers
    Toerless

---

From: Christian Huitema <[email-masked]>
Date: Fri, 24 Jul 2020 17:11:16 -0700

> are tenuously connected to (might remind one of) a present or historical

Viktor,

There is a significant difference between policing speech and being
careful of the way we write technical specifications. What we seem to be
debating here is the narrow issue of metaphors used in technical
specifications. And I do agree with the statement that metaphors like
"master/slave" or "white list/black list" are best avoided. I also don't
think this a huge burden. I speak from practice here. My former
employer, Microsoft, has been avoiding these terms in technical
specifications for years. That language restriction never prevented me
from writing technical specifications or contributing to technical
discussions.

-- Christian Huitema

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 02:14:54 +0200

> comes to gender is also a huge issue with the organization.

Lets stay on topic (or open another thread): 

What specifically do you think we should do to have
sufficient diversity for deciding on IETF document language evolution ?

How much is this ok. to be a primarily USA lead initiative ? 
What does it say about the self proclaimed inclusiveness goal of the
IETF if it does imvolve 70% or more USA centric contributors ?

Same question to the others who +1 your post.

Cheers
   Toerless

-- 
---
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 00:52:43 +0000

We don't have to "solve" all the problems.  We should address known issues.  And then, when language changes, or another group comes up and says "this is hurtful/eclusionary" we should continue the process.

Based on your postings, I have come to the conclusion that you seem to think that, ideally, this is a one-time thing:  We fix a few words and then we're done.  I don't see it that way.  We start a process, and address those terms we know about.

I don't know, but that's kind of a leading question. I'll answer similarly: if the first part of the process is done by mostly US contributors, that's could be okay because it is mostly US contributors that have used words we now want to avoid, and who seem to be in the most civil unrest over it. Put another way, "look those folks over there are getting rid of problematic terminology, maybe I can mention some words that hurt"  It is up to the privilege to provide a "safe space" for others.  I speak from experience on that.

---

From: Joseph Touch <[email-masked]>
Date: Fri, 24 Jul 2020 17:57:26 -0700

> On Jul 24, 2020, at 5:01 PM, Toerless Eckert <[email-masked]> wrote:
> ...

I have more faith that those interested can step outside of their own experiences. Or at least try.

> from all type of language backgrounds. you did not comment about that.

Nobody is stopping anyone from participating. We don’t need a steering group. The IETF enforces nothing (not even protocol requirements), certainly not this.

> ...
> Software components are not humans.

Yes, but we anthropomorphize them all the time. I appreciate that you are not offended by the way that is done, but this is about what others have raised THIS EXACT ISSUE as their concern.

> such as also from africa and parts of asia, where there is real slavery,

Surely you’re aware that slavery has occurred on nearly every continent (perhaps less so in Antarctica), in nearly every time period...

> and

This is about what we do AFTER the doc is published, not the doc itself. The “weight” is what we do, not what we state we will do.

Joe

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 04:34:49 +0200

> We don't have to "solve" all the problems.  We should address known issues.  And then, when language changes, or another group comes up and says "this is hurtful/eclusionary" we should continue the…

The question i have is more about who makes the decision. From
what you are saying it sounds as if its fine if just the interested
small set of people who are vocal enough chiming into the issue
should be the ones making the decision. My argument is that that
group has not enough diversity to represent the diversity of the
target audience of RFCs across the globe. I gave examples
of pain points in my prior email.

> Based on your postings, I have come to the conclusion that you seem to think that, ideally, this is a one-time thing:  We fix a few words and then we're done.  I don't see it that way.  We start a…

I don't know how you think this is what i said. I meant that i
see the risk of this happening because i see the initiative being
brought up by a specific, quite focussed social issue originating
from a single country. As i proposed, i would be happy if we
first agreed on what the goal is, and i proposed one (no feedback
received for that), and i don't think that a predominant USA
group should decide how to make such determinations for the IETF.

> I don't know, but that's kind of a leading question. I'll answer similarly: if the first part of the process is done by mostly US contributors, that's could be okay because it is mostly US contribu…

I am sure that in this climate the IETF mailing lists are a safe
space for others to chime in in the way you describe it, but
a real safe space would have to be one equally safe for all
reasonable opinions. And then there is the question how
to even best determine the best outcome for the target audience.

Cheers
    toerless

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 06:20:37 +0200

> I have more faith that those interested can step outside of their own experiences. Or at least try.

We could let the folks who claim they will do a good job
outside their own experience prove that for 18 months by having them
only work on words not related to black live matter and then vet
the results and decide if they should continue to work on the
words they came for originally.

> Nobody is stopping anyone from participating. We don???t need a steering group. The IETF enforces nothing (not even protocol requirements), certainly not this.

If "this" is meant to ultimately go to RFC editor as rules,
i think  it would be meant to be enforce,

If anything coming out of the process are suggestions that authors can
chose to ignore without penalties, that would actually be a good way to
start the process (independent of my concerns about who is running the process).

> Yes, but we anthropomorphize them all the time. I appreciate that you are not offended by the way that is done, but this is about what others have raised THIS EXACT ISSUE as their concern.

I understand that, and i do agree that this is something to consider, but
it very much depends on the target audience of our documents:

(a) On one end there is the wish of social justice activists to change language in all
places even where irrelevantor detrimental  to raise awareness of a social issue. Thats
a great and simple partisan position to fight for.

(b) There are people, IMHO primarily children or young adults that do anthropomorphize
without being able to distinguish.

(c) There are adult technical readers of RFC around the world that likely may
not even know and certainly don't care about the non metaphorical meaning
or history of our technical terms, and for whom as i outlined in the prior email
three may be real downsides for a change of text.

(a) always uses (b) as an argument for their initiative, and i do agree
with them.  But i think our readers are (c), not (b).

I am sure there is also (d) adult rascist engineers that explicitly use technical
terms to live their racism and have fun in making it sound as if they could blame
some RFC for it. Changing our language in recognition of those (d)
people is about the worst defeat i can imagine. Trying to do that also just
restarts the euphemism treadmill. Instead of telling the non-white engineering co-worker
"hey you slave, who is your master", they would simply say "hey you secondary,
who is your main". And that poor co-worker probably has even more problems with
the HR department to prove the racism of that guy because the HR department is not on top
of all the newest RFC language.

Maybe i am missing important cases, if o, then i would love to hear simple
example workflows where the change in RFC language would really help.
Short of that i would only worry about whether or not (b) applies to RFCs,
and so far i have not been presented with good evidence for that.

> Surely you???re aware that slavery has occurred on nearly every continent (perhaps less so in Antarctica), in nearly every time period...

I was saying "is",  i was not referring to the past.

[rant]

IMHO the biggest issue today is non-state sanctioned, often international
slavery typically called human traficking (slavery ~= state sanctioned).

I have a real hard time imagining how RFC word changes could have any
positive impact on worldwide human traficking.

On the other hand i can very well imagine how commoditizing end-to-end
encryption through TLS is very much helping worldwide organized crime
especially all the startup, small business organized crime.

How can we even argue about slavery in the context of IETF by
talking about RFC words without ever having had even a discussion
(in my memory) about these impacts of our actual technical work ? 

Where is the IETF working or research group to brainstorm IETF technologies
to help law enforcment fight organized crime such as human traficking,
child pornography, racism and terrorism ?

[/rant]

> This is about what we do AFTER the doc is published, not the doc itself. The ???weight??? is what we do, not what we state we will do.

sorry... can't parse. rephrase ?

Cheers
    Toerless

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 25 Jul 2020 16:48:08 +0900

Salz, Rich wrote:

> Well, one can hope that if the document is adopted somewhere,

I hope not.

> I believe that it is still a mistake to use terms like
> blacklist/whitelist and master/slave in technology documentation.

Distorting meaning of "blacklist" is even more impossible,
because in almost all, if not all, culture (including
that of Japan, where all native Japanese are yellow
and those of blacks), black is somewhat evil and white is
somewhat good, which is a natural result from a biological
fact that human beings are diurnal and nocturnal beasts
are the evil monsters.

US (and UK) culture is no exception, fundamental changes
on which are simply impossible.

So, before working on "blacklist", tell me how you can
rephrase the following in Thriller:

	It's close to midnight and something evel's
	lurking in the dark

And, tell me how you feel about the following:

	https://en.wikipedia.org/wiki/Gandalf
	Midway through The Lord of the Rings, Gandalf becomes
	the head of the order of Wizards, and is renamed Gandalf
	the White. This change in status (and clothing)
	introduces another name for the wizard: the White Rider.

	After the war, Gandalf crowns Aragorn as King Elessar,
	and helps him find a sapling of the White Tree of Gondor.

	https://en.wikipedia.org/wiki/Morgoth
	The name Morgoth is Sindarin (one of Tolkien's invented
	languages) and means "Dark Enemy", "Black Foe", or "Black
	Foe of the World".

	Morgoth, the diminished being that styled itself Dark
	Lord of Arda.

If you think "black" and "white" are improperly used in the
Lord of the Rings, feel free to modify it or ban it from US
market along with all the current and *future* fantasies
and FRPGs doing so.

Only after that, we can start working on less important
fields of technical terms such as "blacklist".

					Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 25 Jul 2020 16:57:40 +0900

> a bad thing, then so be it.

Be respectful of non-black slaves.

						Masataka Ohta

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 10:27:00 +0200

Toerless,

as a fellow with a German background, let me just say this:

It’s their language.

We are witnessing a change in what is polite to say in English.
Many of us would simply ignore that — engineers are not often connoisseurs of finer points of English, and we value clarity over politeness.
The suggestion is to follow the change(*).

I have already made my point that some of the well-meaning changes that have previously occurred didn’t stick.  That (and the cost of change) argues for caution, not for ignoring the change.

And to bring in the (Northern, in my case) German perspective:
We generally have a rather robust relationship to language, even if some people are chipping away at that.
But then, we also have words that we no longer use (it took me a couple of years to call a name server  ns.tzi.org  — 25 years ago that choice was still nearly unthinkable, even if that sounds ridiculous now).
It also would *never* have occurred to a German to call a technical concept a “slave” (**), or to “kill” processes (***), etc., so the German speaker in me is not too unhappy if some of those horrible usages finally get fixed.

Grüße, Carsten

(*) I don’t think anybody is suggesting to lead it, although I may simply have ignored those who do.
(**) the German equivalents of “master” are mostly innocuous, including great ones like “Herrchen” and the analogous “Frauchen” (of an animal).  We also have completely non-charged variants, such as “Meister”.  So the German in me doesn’t understand the urge to replace “master”, but then again, it’s their language.
(***) insert account of IBM’s somewhat comical choice to replace “kill” by “force” in CP/CMS.

---

From: Tim Chown <[email-masked]>
Date: Sat, 25 Jul 2020 10:02:27 +0100

> On 23 Jul 2020, at 18:45, Eliot Lear <lear=[email-masked]> wrote:
> 
> Hi,
> 

+1 to working on this topic, it’s long overdue, and not just about the US, or slavery.

+1 to the above, though I suspect some words will be “on a list” regardless.

Tim

---

From: [email-masked]
Date: Sat, 25 Jul 2020 10:50:46 +0000 (UTC)

Well, to start this: this thread has used “folks” repeatedly.
As I’ve stated previously on this list, I view “folks” as a trigger, as it imposes passive-aggressive patronising distancing, and it’s certainly not as inclusionary as you might think. A word best avoided, in my view.
RFC7282 and other documents use this word, which is certainly not technical language. We can all do better, and the proposed ad-hoc committee for censoring words can begin with that divisive word.

L.
wondering if the people who came to the IETF to work on IPv6 should only have been allowed to work on NAT for eighteen months. Wouldn’t the world have been a far better place?

---

From: [email-masked]
Date: Sat, 25 Jul 2020 12:08:59 +0000 (UTC)

A while back, I was tasked with reviewing an academic paper that used the technical terminology of ‘master/slave’ to describe a process.
I found myself writing in my review that that terminology was no longer considered acceptable, and would just have to be replaced. And I was very aware, while typing out my friends-of-the-offended-and-oppressed piece, that I was was concocting this explanation to be read by the authors of the paper, who all had African heritage, and who attended a US educational institution in a US state considered remarkable for its previous use of slavery.
Those authors would clearly have far better and more nuanced perspectives on the mechanisms and oppression of racism and slavery than I ever will, not least from lived experiences. They had simply used technical terminology, they were clearly in agreement that that use was fine, and their paper was otherwise excellent.
So, once my review had explained to them that Black Lives Matter, and just how appalliing those terms were and how triggering and insensitive they were inadvertently being, I had fulfilled my solemn academic duty, and my head exploded from the irony of it all. 
I now believe that double-blind reviewing has its advantages, while continuing to distrust the intentions of those willing to censor language. It’s so Owellian ++ungood;

Lloyd [email-masked],uk
have we cancelled Star Wars because of its slaves yet?

Hope this helps.

---

From: "Bron Gondwana" <[email-masked]>
Date: Sat, 25 Jul 2020 22:42:14 +1000

> As I’ve stated previously on this list, I view “folks” as a trigger, as it imposes passive-aggressive patronising distancing, and it’s certainly not as inclusionary as you might think. A word best…

I'm not "triggered" by it, but the word that I naturally put before it is "old" as in "old folks home" or "you'll have to ask the folks" - aka, one's parents.

It's definitely not a word that I've seen young people use to refer to other young people (yet - though I see a cultural effort in my circles to bless is as the one true plural for humans).

My teenage kids, neither of whom are cis male, never say "folks", and regularly use "guys" to refer to their schoolmates of any gender.  When I asked them about whether it has any gendered connotations to them recently, they said it does not.

Personally I'm holding out for "all y'all" or "youse" to make a comeback.

Bron.

---

From: Joseph Potvin <[email-masked]>
Date: Sat, 25 Jul 2020 09:25:47 -0400

Conductor | Musician ?

Joseph Potvin

---

From: Paul Wouters <[email-masked]>
Date: Sat, 25 Jul 2020 10:00:22 -0400

> especially all the startup, small business organized crime.

It’s interesting to see that the example you picked here implies that citizens end to end communication without the government able to read it is something that you personally don’t even need to consider as a danger to your person. That this might be a positive trade-of, compared to facilitating a regime that vanishes people in unmarked vans while they communicate in full protection themselves.

This is why the IETF can always use more diversity. There are small things we can do, like avoid using certain language, and big things we can do, like ensuring TLS 1.3 does not have MITM properties. We should so do all of these. And by doing the small things immediately, we help those for who these thousands of small things in their lives have accumulated to structural discrimination.

Paul

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 14:04:48 +0000

Reductio ad abursdium arguments -- commenting on Thriller or Tolkien's writings -- isn't useful to have a productive conversation, and I won't be enticed there.

Take care.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 14:05:29 +0000

>    Be respectful of non-black slaves.

Sure.  Who has said otherwise?  Perhaps it's a language barrier issue?

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 14:08:44 +0000

*   As I’ve stated previously on this list, I view “folks” as a trigger, as it imposes passive-aggressive patronising distancing, and it’s certainly not as inclusionary as you might think. A word best avoided, in my view.

This is an honest question: are you serious?  Are there others who feel this way?

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 14:15:50 +0000

what you are saying it sounds as if its fine if just the interested
    small set of people who are vocal enough chiming into the issue
    should be the ones making the decision.

I am sorry if I was not clear, but I do not see that I said anything about who makes the decision.  I thought it was obvious, given the context, that we follow normal IETF decision-making procedures.

>  My argument is that that
    group has not enough diversity to represent the diversity of the
    target audience of RFCs across the globe.

We have that problem overall, don't we?  (Rhetorical question: yes we do.)  We can address what we think is problematic, and as more communities tell us of more things, we can address them too (or not, as the IETF decides to do).

> As i proposed, i would be happy if we
    first agreed on what the goal is

Okay.  I like the IESG statement.  I have no useful feedback on what you proposed.

---

From: [email-masked]
Date: Sat, 25 Jul 2020 14:28:51 +0000 (UTC)

Rich
I’m quite serious. I have stated this before, on this list, to an audience that you would think would care about this.
I cannot speak for others here.

On Sunday, July 26, 2020, 00:09, Salz, Rich <rsalz=[email-masked]> wrote:

#yiv6246083418 #yiv6246083418 -- _filtered {} _filtered {} _filtered {}#yiv6246083418 #yiv6246083418 p.yiv6246083418MsoNormal, #yiv6246083418 li.yiv6246083418MsoNormal, #yiv6246083418 div.yiv6246083418MsoNormal {margin:0in;margin-bottom:.0001pt;font-size:11.0pt;font-family:sans-serif;}#yiv6246083418 p.yiv6246083418MsoListParagraph, #yiv6246083418 li.yiv6246083418MsoListParagraph, #yiv6246083418 div.yiv6246083418MsoListParagraph {margin-top:0in;margin-right:0in;margin-bottom:0in;margin-left:.5in;margin-bottom:.0001pt;font-size:11.0pt;font-family:sans-serif;}#yiv6246083418 span.yiv6246083418EmailStyle18 {font-family:sans-serif;color:windowtext;}#yiv6246083418 .yiv6246083418MsoChpDefault {font-size:10.0pt;} _filtered {}#yiv6246083418 div.yiv6246083418WordSection1 {}#yiv6246083418 _filtered {} _filtered {} _filtered {} _filtered {} _filtered {} _filtered {} _filtered {} _filtered {} _filtered {} _filtered {}#yiv6246083418 ol {margin-bottom:0in;}#yiv6246083418 ul {margin-bottom:0in;}#yiv6246083418    
   - As I’ve stated previously on this list, I view “folks” as a trigger, as it imposes passive-aggressive patronising distancing, and it’s certainly not as inclusionary as you might think. A word best avoided, in my view.

---

From: Victor Kuarsingh <[email-masked]>
Date: Sat, 25 Jul 2020 10:35:00 -0400

On Sat, Jul 25, 2020 at 10:09 AM Salz, Rich <rsalz=
[email-masked]> wrote:

>
>    - As I’ve stated previously on this list, I view “folks” as a trigger,
>    as it imposes passive-aggressive patronizing distancing, and it’s certainly
>    not as exclusionary as you might think. A word best avoided, in my view.
>
>
>

I suspect that we will wind up having discussions which cover so many
words/terms across too many domains with varying levels of acceptance by
people who may (or may not) be triggered.  This is my largest concern (that
we may not be able to contain the limits of the conversation).

My thoughts are - we will all do our best to consider others, and we should
be considerate of others if we don't agree with them (as
their experience and disposition may differ from ours).   Jon Postel comes
to mind.

regards,

Victor K

---

From: Kyle Rose <[email-masked]>
Date: Sat, 25 Jul 2020 10:58:54 -0400

The IETF does have an inclusion problem, but I suspect it has very little
to do with problematic technical jargon and a lot more to do with the
all-too-frequent bullying, mocking, and dismissal that seem to be standard
operating procedure for a small but vocal minority of the community. This
statement feels like a way for the IETF leadership to pay feel-good lip
service to inclusion while not adequately addressing the behaviors that
have actually driven away participants.

Kyle

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 00:16:05 +0900

Salz, Rich wrote:

> Reductio ad abursdium arguments

Is a powerful tool to prove something and it seems to me that
I have used it so successfully.

> -- commenting on Thriller or Tolkien's writings -- isn't useful to have
> a productive conversation, and I won't be enticed there.

If you ignore deep cultural nature of the issue that black is
considered somewhat evil by almost all culture including
that of blacks and have no intention to change it, surely,
it is not productive to discuss whether "blacklist" should
be banned or not.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 00:17:07 +0900

Salz, Rich wrote:

> Sure.  Who has said otherwise?

Many.

> Perhaps it's a language barrier issue?

Of you?

						Masataka Ohta

---

From: "John R Levine" <[email-masked]>
Date: 25 Jul 2020 11:41:25 -0400

> I cannot speak for others here.

I'm also honestly surprised.  Here in the US the term seems perhaps 
faux-informal but not offensive.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "John R Levine" <[email-masked]>
Date: 25 Jul 2020 11:42:32 -0400

> have actually driven away participants.

Finally, a comment with which I can completely agree, particularly being 
aware that my own interactions have sometimes been a bit dismissive.

Regards,

---

From: Jared Mauch <[email-masked]>
Date: Sat, 25 Jul 2020 11:43:11 -0400

I think it's clear we can do better here. This doesn't mean we can resolve it all at once, but we can improve the quality of the products we produce. WG docs, WG last call and IETF last call provide many venues for us to audit our work and improve it. 

Let's focus on that, and as other said allow the IESG and RSE perform their roles to ensure the quality we aspire to. 

Sent from my iCar

> On Jul 24, 2020, at 12:33 PM, Livingood, Jason <[email-masked]> wrote:
> 
> +1
>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 15:47:57 +0000

*   I’m quite serious. I have stated this before, on this list, to an audience that you would think would care about this.

Okay, thanks.

  *   I cannot speak for others here.

I was asking if you know of anyone else (anywhere) who feels similarly.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 15:48:54 +0000

We disagree, and I guess I'll leave it at that.

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 15:52:35 +0000

>    Many.

I don't recall any such postings.  I *do* recall people saying that the US history is the most egregious, but I don't recall anyone saying non-black slave history should not be considered.  Do you have any links?

 > Of you?

It could well be.  If you thought I was implying that you had a problem with the language, I apologize. A barrier is between two parties, so either party could be having an issue.

---

From: Paul Wouters <[email-masked]>
Date: Sat, 25 Jul 2020 12:16:29 -0400

> This is an honest question: are you serious?  Are there others who feel this way?

I do.

In Canada “folks” is a term used by conservatives only to appeal / addres a
 the “common people”.

In Dutch, it reminds of volk, which reeks of nationalism.

Using the term to me feels like talking down to a group that you have power or control over.

That said, I understand a lot of people do not see or use it that way, and I can ignore it.

Paul

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 25 Jul 2020 16:24:53 +0000

Paul,

Thanks for the info and the history lesson.

I will learn how to spell “Colleagues” :)

---

From: Miles Fidelman <[email-masked]>
Date: Sat, 25 Jul 2020 12:33:17 -0400

> I will learn how to spell “Colleagues” :)
Of course "colleague" has it's own problems - it implies that one 
assumes that all of one's addressees have opinions of equal worth.  For 
some, that's an expression of respect.  For others, it's kowtowing to 
Dunning-Kruger syndrome.  And some might take "Dear Colleague" as a 
sarcastic insult.

You really can't win with this stuff.  Someone will always object to 
something.  Personally, I'm still good with old-fashioned knock-down, 
drag-out, technical exchange - the hell with the language & people's 
feelings.  Good engineering is good engineering, bad engineering is bad 
engineering.  All the rest is navel-gazing.

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

Theory is when you know everything but nothing works.
Practice is when everything works but no one knows why.
In our lab, theory and practice are combined:
nothing works and no one knows why.  ... unknown

---

From: Leif Johansson <[email-masked]>
Date: Sat, 25 Jul 2020 18:36:17 +0200

Skickat från min iPhone

> 25 juli 2020 kl. 17:00 skrev Kyle Rose <[email-masked]>:
> 
> 
> The IETF does have an inclusion problem, but I suspect it has very little to do with problematic technical jargon and a lot more to do with the all-too-frequent bullying, mocking, and dismissal that seem to be standard operating procedure for a small but vocal minority of the community. This statement feels like a way for the IETF leadership to pay feel-good lip service to inclusion while not adequately addressing the behaviors that have actually driven away participants.
> 
> Kyle
> 

+1

---

From: Mary B <[email-masked]>
Date: Sat, 25 Jul 2020 12:20:57 -0500

I absolutely don't see it that way.  I use it all the time and use it
really in the following context based on this definition:
https://www.dictionary.com/browse/folks

(used with a plural verb) people as the carriers of culture, especially as
representing the composite of social mores, customs, forms of behavior,
etc., in a society

with IETF being the society.   So, I actually consider it a more inclusive
term than "people".  I actually use the latter often in a much more
negative context.

Some of this is probably also regional within the US.

Mary.

On Sat, Jul 25, 2020 at 11:17 AM Paul Wouters <[email-masked]> wrote:

>    as it imposes passive-aggressive patronising distancing, and it’s certainly
>    not as inclusionary as you might think. A word best avoided, in my view.
>
>
>

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 22:40:52 +0200

> I am sorry if I was not clear, but I do not see that I said anything about who makes the decision.  I thought it was obvious, given the context, that we follow normal IETF decision-making procedure…

And i was implying tht the normal process may not be a good choice, because
it's basically built around benefitting those who show up, whereas in this
case we should figure out how to achieve the best results for those who read
RFCs, and i don't think that tht is taken enough into consideration.

For example, one could create a questionaire about language used in RFCs
and pass that to all ISOC chapters for feedback, and then analyze that feedback.

Just saying...

> We have that problem overall, don't we?  (Rhetorical question: yes we do.)  We can address what we think is problematic, and as more communities tell us of more things, we can address them too (or…

Most what comes out of IETF can be ignored by those who don't care.
When like in this case it impacts everybody, and when as i claim
there may even be fear to speak out against it, and when furthermore
it would be prudent to show diversity was observed in decision making,
then business as usual may not be the right approach.
> 
> > As i proposed, i would be happy if we first agreed on what the goal is
> 

Which IESG statement ?

Cheers
    Toerless

---

From: Joseph Touch <[email-masked]>
Date: Sat, 25 Jul 2020 13:45:44 -0700

> On Jul 25, 2020, at 1:40 PM, Toerless Eckert <[email-masked]> wrote:
> 

ISOC chapters have little to nothing to do with RFCs. They serve a different purpose, as described here:
https://www.internetsociety.org/chapters/ <https://www.internetsociety.org/chapters/>

Joe

---

From: Joseph Touch <[email-masked]>
Date: Sat, 25 Jul 2020 13:55:56 -0700

A few points in summary:

- nobody has proposed a penalty for using these terms
	the typical RFC document review and editing process already allows for flexibility in many ways

- nobody has set restrictions on who can participate
	including the need for a ‘license’ for having participated in these issues elsewhere

- although our target is RFCs, every bit helps when trying to address these sorts of biases
	this isn’t about raising awareness; it’s about avoiding marginalization

- nobody has asserted that these terms are being used deliberately or maliciously
	the point is to be aware of their impact

- everyone is free to raise dimensions of this issue that they believe should be included
	I raised ageism, sexism, genderism, nationalism, etc., in addition to racism

- yes, the IETF routinely works on technologies that impact sociological issues
	that’s what the security considerations sections are often about, 
	including (but not limited to) privacy preservation

	but that isn’t the purpose of this doc.

> sorry... can't parse. rephrase ?

The point of this thread is that we should DO something; not merely document or talk about it.

Joe

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 23:04:57 +0200

On Sat, Jul 25, 2020 at 10:27:00AM +0200, Carsten Bormann wrote:
> It???s their language.

Well, we do use US english, true, but we are talking about technical terms.
I think we have a lot of freedom as a communty to decide what to pick and how.

> We are witnessing a change in what is polite to say in English.

That was very politely said!

[...]

> It also would *never* have occurred to a German to call a technical concept a ???slave??? (**), or to ???kill??? processes (***), etc., so the German speaker in me is not too unhappy if some of those horrible usages finally get fixed.

Sure, anything that helps readability is great IMHO (first thing i wrote
in this thread). I have just a lot of concern about process especially
how this becomes a one-off for just the words in the draft that
started this.

For exmple i have to observe a real bad execution on evolving the
RFC abbreviations list, and every time i pointed to problems,
they where not fixed, and ADs did not bother to pick up the problem.

Cheers
    Toerless
> 
> Grüße, Carsten
> 
> 
> (*) I don???t think anybody is suggesting to lead it, although I may simply have ignored those who do.
> (**) the German equivalents of ???master??? are mostly innocuous, including great ones like ???Herrchen??? and the analogous ???Frauchen??? (of an animal).  We also have completely non-charged variants, such as ???Meister???.  So the German in me doesn???t understand the urge to replace ???master???, but then again, it???s their language.
> (***) insert account of IBM???s somewhat comical choice to replace ???kill??? by ???force??? in CP/CMS.

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Sat, 25 Jul 2020 23:11:41 +0200

On Sat, Jul 25, 2020 at 01:45:44PM -0700, Joseph Touch wrote:
> ISOC chapters have little to nothing to do with RFCs.

What do you mean ? If i join an ISOC chapter, i am not allowed anymore to read RFCs ?

Or have no opinions about what technical words would most likely be desirable
for network engineers in my country (RFC text terms matching other educational material
for example) ? Or whether avoiding specific words isin RFC would be seen as culturally
benefical in my country ?

The IETF community is not the customer (readers of RFCs), even though we are a subset
of it. All i am saying is that if you change the product you should be interested
to understand what the customer thinks. How would you propose to do that ?

Cheers
   Toerless

> They serve a different purpose, as described here:

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 25 Jul 2020 23:34:43 +0200

> they where not fixed, and ADs did not bother to pick up the problem.

True.  One of these “medium importance” issues…  Hard to get attention for them.

I think we need a calendar to attend to them once a year or so.

Grüße, Carsten

---

From: S Moonesamy <[email-masked]>
Date: Sat, 25 Jul 2020 14:55:16 -0700

Hi Toerless, Joe,
>is a sign of even stronger USA influence than anything technical we 

The Spanish words for the concept which was discussed in several 
venues is similar to the English words.  I would have to spend more 
time on that topic to understand it.

The main part of Toerless' message is about whether the U.S. social 
issues which have influenced the debate about some words.  It is 
difficult to determine whether the fact that 85% of IESG members have 
U.S. ties has anything to do with the IESG Statement.

It is strange that the traditional Thursday censorship index was 
discontinued. The majority of persons posting to this mailing list 
have U.S. ties.  The reality is that it is that majority which 
influences the decision(s).  It is probably similar for the related 
debate {1] on the Human Rights Protocol Considerations mailing list.

One of the points made was whether a solution which Country X 
considers as good is equality good for other countries.  Do all those 
countries have the same culture?  Would Country X be putting the 
interests of the other country ahead of its own interests?

Regards,
S. Moonesamy

1. https://mailarchive.ietf.org/arch/msg/hrpc/9E7uZeAD53eQ2qOPgJfSY3LHnDE/

---

From: "John Levine" <[email-masked]>
Date: 25 Jul 2020 18:06:25 -0400

>benefical in my country ?

I would be surprised if 5% of chapter members had ever read an RFC.
They are predominantly Internet users, not Internet engineers. ISOC
has chapters all over the world and many chapter members don't speak
English.

-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Joe Touch <[email-masked]>
Date: Sat, 25 Jul 2020 15:12:31 -0700

> On Jul 25, 2020, at 2:11 PM, Toerless Eckert <[email-masked]> wrote:
> 
>> 

No, but reading, implementing, or discussing RFCs isn’t the point of ISOC chapters.

I.e., they’re not really representative of the community of people who read or use RFCs any more than LEGO robot club members.

Joe

---

From: Christopher Morrow <[email-masked]>
Date: Sat, 25 Jul 2020 22:14:08 +0000

(I've intentionally not been reading the several threads about the
potential wording/vocabulary changes.. but I did read some of the
thread, this particular jumped out at me)

> Lets stay on topic (or open another thread):

I feel like this came off in a manner that Toerless didn't mean for it
to... Like
asking Mary to 'be quiet' (or some other similar version of that). I'm hopeful
that this was not the aim of the remark.

I think Mary's point actually is on topic? Whether the part of
'diversity' you all
are discussing is racial, gender or orientation. it's all the same
sort of problem,
the folk making decisions about the direction of the
community/organization should
be representative of both the local IETF community and the wider
Internet community
if possible. Taking measures to help ensure that seems like a reasonable action.

-chris

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 00:15:07 +0200

If we can put the most important new standards into RFC abbreviation list
even after i tell an AD twice, then i don't think we can deal with
new technical terms in the organization any better.

On Sat, Jul 25, 2020 at 11:34:43PM +0200, Carsten Bormann wrote:
> True.  One of these ???medium importance??? issues???  Hard to get attention for them.
>

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 00:19:47 +0200

> has chapters all over the world and many chapter members don't speak

Sure. 5% of chapter member input would be much more diversity than what we have now.
Also, this is more about asking about the desirable english langugage terms
even outside of RFCs. And i am sure there is a much larger amount will speak
english as a second language.

Are all ISOC pages available in spanish and chinese ? Just wondering as you
said many members do not speak english.. Ok. offtopic ;-)

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 00:25:24 +0200

On Sat, Jul 25, 2020 at 03:12:31PM -0700, Joe Touch wrote:
> No, but reading, implementing, or discussing RFCs isn???t the point of ISOC chapters.
> 
> I.e., they???re not really representative of the community of people who read or use RFCs any more than LEGO robot club members.
> 

Hahaha. You're good in snipe remarks today.

ISOC is even doing regular? teaching session for network operators,
i would be suprised if none of the IETF is ever read by operators.

Also remember that ISOC itself is somehow involved in financing the IETF,

And finally: if nobody reads RFCs, who the heck are we doing the more "polite"
words for ? Just ourselves ?

Cheers
    Toerless

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sat, 25 Jul 2020 18:30:08 -0400

The ADs do not own the RFC Editor list of abbreviations which do not 
need expansion.
As a first approximation, as long as an abbreviation is considered new, 
it is extremely unlikely to be added by the RSE (or equivalent person). 
The point of that list is to list things that are so well known even 
outside the narrow field of use that it is reasonable to expect people 
to know the abbreviation.

Personally, I wouldn't care if that list were reduced to zero.  Out goal 
is to write clear documents.  expanding abbreviations / acornyms on 
first use is a good idea.  I do understand that we do not bother with 
things like IP, TCP, HTTP.  So having a list is useful.  But if people 
complain about how hard it is to get anything on the list, I will push 
to remove it entirely.

Yours,
Joel

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 00:51:34 +0200

Christopher:

I did not mean or say for Mary to shut up! 

When i brought a new aspect into the discussion, i changed the subject to "USA dominion",
to structure the discussion.

I was just implying to Mary to do the same for her new aspect and
just wanted to stay on subject for sub thread i have opened.

I only did not want to do it myself
because i was already using up more than my fair share of bandwidth in this
thread as it is without opening yet another discuss point myself. 
I do agree wih what Mary and you are saying and i think it deserves
further considerations/discuss.

Maybe i am too anal on this subthreading by subject, but
a thread with hundreds of messages without any change in subject
(even though it covered several separate sub-topics) is just unnecessarily 
confusing to me. 

Of course, in the meantime i have just given up of expecting useful
structuring of the discuss into sub-topics after the one
i opened was primarily occupied by folks who wanted to
discuss the perfect use or prohibition of the use of "folk(s)".

That's all folks!
    Toerless

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 00:57:31 +0200

Well, i will invite you to the next discuss where an AD wants to educate
a WG as to the appropriate use of some abbreeviation for a new expansion
by referring to the RFC abbreviation list.

I for once don't think it is difficult to get things added. Indeed, i
have simply added to my drafts an RFC-editor note stating which new
abbreviations i would like to have added, something i think that
should bhave been done for other now ubiquouts abbreviations as
well.

Just as a reminder, why this thread came into place: I think we're
not doing a well structured job on the RFC abbreviations list and
i was just pointing that out as a bad example for how to not do things
for someting like a "recommended new replacement acronyms" list
that probably would ahve to evolve from that other folks thred we're
just having here on the list.

Cheers
    Toerless

On Sat, Jul 25, 2020 at 06:30:08PM -0400, Joel M. Halpern wrote:
> The ADs do not own the RFC Editor list of abbreviations which do not need
> expansion.
> As a first approximation, as long as an abbreviation is considered new, it
> is extremely unlikely to be added by the RSE (or equivalent person). The
> point of that list is to list things that are so well known even outside the
> narrow field of use that it is reasonable to expect people to know the
> abbreviation.
> 
> Personally, I wouldn't care if that list were reduced to zero.  Out goal is
> to write clear documents.  expanding abbreviations / acornyms on first use
> is a good idea.  I do understand that we do not bother with things like IP,
> TCP, HTTP.  So having a list is useful.  But if people complain about how
> hard it is to get anything on the list, I will push to remove it entirely.
> 
> Yours,
> Joel
> 

-- 
---
[email-masked]

---

From: Joel Halpern Direct <[email-masked]>
Date: Sat, 25 Jul 2020 19:00:29 -0400

It may be that we are not doing a good job adding terms to the RFC list 
of abbreviations which do not need expansion on first use.

However, in terms of what you state below, an RFC which introduces a new 
abbreviation can almost never meet the requirements for that 
abbreviation appearing in the RFC Editor list.  As almost by definition 
the new term is not yet in wide  use and widely recognized without 
expansion.  (There may be an exception or two where the RFC is 
recognizing a term that is already in use.  I said almost.)

Yours,
Joel

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 26 Jul 2020 01:46:06 +0200

On 2020-07-26, at 01:00, Joel Halpern Direct <[email-masked]> wrote:
> 
> It may be that we are not doing a good job adding terms to the RFC list of abbreviations which do not need expansion on first use.

There is a big difference between expansion on first use (in abstract and  document) and expansion in the title.

8778 Use of the HSS/LMS Hash-Based Signature Algorithm with CBOR Object
     Signing and Encryption (COSE). R. Housley. April 2020. (Format:
     HTML, TXT, PDF, XML) (Status: PROPOSED STANDARD) (DOI:
     10.17487/RFC8778) 

CBOR was ready to no longer be expanded here, but imagine we had expanded that and HSS/LMS in that title as well.  This one of several RFCs that no longer expands CBOR in the title, but CBOR is not starred in https://www.rfc-editor.org/materials/abbrev.expansion.txt — CDDL (*) isn’t even in there.

Oh, and RSA was never expanded in an RFC title.  MD5, SHA, ...

Looking at the way RSVP-TE was handled in RFC titles over the years makes me nauseous.

(Toerless’ original point was that, if you add contentiousness to that list — abbreviation expansions are rarely contentious, but the original subject of the thread this thread exited from was — such a list would not stay healthy.  But that is not my point, just that you need to clean the dust out of the fans once a year, and if you do not have a preventive maintenance schedule, that won’t happen.)

Grüße, Carsten

(*) CDDL was originally the CBOR Data Definition Language (CDDL), which I surmise would have become the Concise Binary Object Representation (CBOR) Data Definition Language (CDDL).  We shortened that to Concise Data Definition Language (CDDL), mainly because it was the right thing to do, but probably also motivated by the inevitable monster expansions.  Still…

8610 Concise Data Definition Language (CDDL): A Notational Convention to
     Express Concise Binary Object Representation (CBOR) and JSON Data
     Structures. H. Birkholz, C. Vigano, C. Bormann. June 2019. (Format:
     TXT, HTML) (Status: PROPOSED STANDARD) (DOI: 10.17487/RFC8610)

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 26 Jul 2020 10:47:20 +1000

> Of course "colleague" has it's own problems - it implies that one assumes that all of one's addressees have opinions of equal worth.  For some, that's an expression of respect.  For others, it's kowtowing to Dunning-Kruger syndrome.  And some might take "Dear Colleague" as a sarcastic insult.

> You really can't win with this stuff.  Someone will always object to something.  Personally, I'm still good with old-fashioned knock-down, drag-out, technical exchange - the hell with the language & people's feelings.  Good engineering is good engineering, bad engineering is bad engineering.  All the rest is navel-gazing.

We can't even use "bipeds" because it's insulting to people who have lost a leg or are otherwise incapable of bipedal motor function.  (reminds me of the joke about the hick loudly asserting that he ain't no homosapien, he's a hetrosapien)

"Dear bikeshedders,"

Thankfully, words like "folks" or "colleagues" are rarely going to make their way into RFC text itself, because there's almost always a more specific class of person or entity that will be referenced by their role in any protocol or interaction that the RFC describes.

Bron.

---

From: Randy Bush <[email-masked]>
Date: Sat, 25 Jul 2020 19:24:02 -0700

> You might also want to consider that it isn't just a US majority, it's
> a white male US majority, which is also an issue IMHO.  The same
> applies for WG chairs etc.  Indeed, I would posit that the lack of
> diversity when it comes to gender is also a huge issue with the
> organization.

agree as an old white person of pallor who even has a grey beard

from my narrow view, isoc's have been the only focused and long term
efforts.  not sure about metrics for progress.

it may be interesting to see how much diversity a well announced
online meeting brings.  again, not sure about metrics.

randy

---

From: John C Klensin <[email-masked]>
Date: Sat, 25 Jul 2020 22:32:02 -0400

Toerless,

--On Sunday, July 26, 2020 00:57 +0200 Toerless Eckert
<[email-masked]> wrote:

> Well, i will invite you to the next discuss where an AD wants
> to educate a WG as to the appropriate use of some
> abbreeviation for a new expansion by referring to the RFC
> abbreviation list.

Let me start where Joel left off: the criterion for the list
(and both the list and the criteria predate the IETF) is that
the abbreviation be well-known and immediately obvious to anyone
with a significant Internet technical or operational background
and experience.  Not just IETF participants, not just experts on
a particular topic or in a particular topic area (whether
matching IETF Areas or not).  That involves judgment calls, but
that is one of the reasons we've had (again, since before the
IETF) an RFC Editor who is either skilled in the technology and
its terminology or, in more recent years, an RFC Series Editor
who is skilled in technical publications and who can and will
reach out for advice as needed.

Because the list involves judgment calls, I'm quite confident
that, if any one or us were to go through the list, we would
find some things we would think don't belong there and others
that we would think are missing.  Whether those conclusions
would get IETF consensus if the conclusions were organized and
turn into a question is, IMO, doubtful although I'm quite
confident that debates over particular terms could and would
consume a huge amount of time.  Even if it did get IETF
consensus, that might not be relevant.  Not even readers of RFCs
because, for example, if someone reads relevant RFCs and writes
a book or tutorial that draws on them, many of us have assumed
over the years that the IETF and RFC user communities prefer
that any abbreviations that are used are used the way we use
them and that other abbreviations be carefully defined and
identified as not being widely used in the industry.

The IETF does have a way to affect the list and that is the
development of a standards track or BCP "terminology"
specification.  If one of those suggested a particular
abbreviation for a well-known term, I'd expect the RFC Editor to
take note, but, even then, "taking note" should not imply an
automatic addition to the list.

> I for once don't think it is difficult to get things added.
> Indeed, i have simply added to my drafts an RFC-editor note
> stating which new abbreviations i would like to have added,
> something i think that should bhave been done for other now
> ubiquouts abbreviations as well.

If the decision to add, or not add, an abbreviation is based on
whatever you (or Joel, or myself, or even the IESG) consider
ubiquitous rather than a broader assessment (for which our
beliefs might reasonably be input) then, IMO, something is
broken... and broke fairly recently.

I do disagree with Joel about discarding the list because it
serves another purpose, a purpose not unlike that of many IANA
registries.  To use an example that I hope is obviously silly
enough to avoid offending anyone, suppose you came up with a new
model for talking about control planes in conjunction with the
Internet or technology used for the Internet.  And suppose you
and your colleagues consistently referred to it as "Toerless's
Control Plane".  Regardless of how popular and important it
became, I think it should never be referred to, especially in
the RFC Series, as "TCP".  And I would expect the RFC Editor to
push back on that abbreviation, even if it were defined for use
within the specific defining specification and somehow got past
IETF Last Call and the IESG (or other Stream Manager).  From
that perspective, the list is not only a list of well-known
abbreviations but a list of reserved ones.
 
> Just as a reminder, why this thread came into place: I think
> we're not doing a well structured job on the RFC abbreviations
> list and i was just pointing that out as a bad example for how
> to not do things for someting like a "recommended new
> replacement acronyms" list that probably would ahve to evolve
> from that other folks thred we're just having here on the list.

I trust that the people who make up the RFC Editor function will
carefully consider your suggestion, presumably after a new RSE
is selected and on the job.

best,
   john

---

From: Dan Harkins <[email-masked]>
Date: Sat, 25 Jul 2020 20:25:28 -0700

> IETF, and among readers of our documents.

   Well then the IESG is confused. Language cannot be harmful. It can
hurt ones feelings but it cannot cause harm because feelings are just
that...feeling.

   This is a classic "First World Problem" where affluent people who lack
serious life problems create drama in order to provide meaning to their
lives. So now we are being told that words that cause harm? For whom? Well
these First World People are identifying other communities (by race, by
ethnicity) who they declare are harmed by their language.

   How arrogant! How patronizing! The Vision of the Anointed, indeed.

> [2] https://www.ietf.org/proceedings/108/agenda/agenda-108-gendispatch-03

   How about no? Just stop. No need for an "ongoing process" to determine
"actionable policy regarding problematic language". [1] is a horrible
document that engages in unprofessional personal attack and brings the
cancer of "cancel culture" to the IETF.

   Critical race theory is a pile of excrement and [1] builds an entire 
house
on top of the foundation of critical race theory. It should have no place in
the IETF.

   Dan.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sat, 25 Jul 2020 23:38:28 -0400

Dan,
     I have been trying to stay out of this debate, as it is being 
handled quite ably by the proponents.
    But I simply can not ignore your assertion that words can not cause 
harm, and that harm to emotions ("feelings:) is not harm.

You may be able to argue that the specific terms are not causing harm, 
although that contradicts my understanding and extrapolation from my own 
experiences.

But the flat statement that "language can not be harmful" is simply 
false.  And unacceptable.  It is itself a statement ignoring other 
people's experience, and likely to cause harm.  Stop.

Yours,
Joel

---

From: Dan Harkins <[email-masked]>
Date: Sat, 25 Jul 2020 21:10:10 -0700

Joel,

   I'd rather not play dueling assertions-- "it's not", "yes it is",
"no it's not", "it most certainly is".

   Words can be mean and they can make someone cry. And if someone is hurt
they may also cry. But the fact that both outcomes end up with someone
crying doesn't mean the two things that cause that result are the same,
it doesn't mean that words can hurt. Language is not violence. Anyone who
says differently has an agenda they're pushing.

   The idea that a metaphor can prevent someone from joining a STEM career
is ridiculous. Why is it that white people are primarily behind this drive
to identify "racist" language? There's something very patronizing and
frankly "otherizing" in the effort to identify certain words and how they
affect certain other groups (non-white, naturally). This observation holds
true for other groups who are declared as victims as well. Someone who is
part of a perceived dominant group (i.e. not the victim group) will declare
that some grammar or some tense or some word is violence against this
group and insist that everyone cease using that word or that tense. It's
arrogant and patronizing. Just stop!

   Let me end with an observation on how you close your email. You say that
my statement is "unacceptable", and you baselessly assert it is "likely to
cause harm." This is the real problem here. You want to prevent people from
saying certain things. You want to prevent thoughts from being expressed.

   Well NUTS TO THAT!

   Dan.

On 7/25/20 8:38 PM, Joel M. Halpern wrote:
> although that contradicts my understanding and extrapolation from my 
> own experiences.
>
>>> [2] 
>>> https://www.ietf.org/proceedings/108/agenda/agenda-108-gendispatch-03
>>
>>    Critical race theory is a pile of excrement and [1] builds an 
>> entire house

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 13:22:01 +0900

Salz, Rich wrote:

> I don't recall any such postings.

That should be because you failed to respect non-black slaves
properly.

If you did it properly, you could have understood that
there are a lot of non-black slaves and that saying "slave"
is by no means "Exclusionary" (see Subject:).

Obviously, you are not alone.

						Masataka Ohta

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 26 Jul 2020 06:26:00 +0200

On 2020-07-26, at 04:32, John C Klensin <[email-masked]> wrote:
> that
> and experience.  

Hmm, I think the intersection between people knowing what RSVP-TE is, what JSON is, and what RSASSA-PSS is may be smaller than you think.  That bar is a bit high.  I would expect this to be limited to the target group for the specific RFC (which by the way in some cases isn’t “anyone with a significant Internet technical or operational background and experience”).

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 26 Jul 2020 16:33:27 +1200

Dan,

I will probably regret responding other by simply saying +1 to Joel, but here goes.

> hurt ones feelings but it cannot cause harm because feelings are just

So emotional harm isn't "harm" in your book? I think you will find that
most people disagree.
 
> lives. 

A pretty amazing remark, when the developed world has been forced to all
but shut down for several months by a virus that is now starting to
run free in the developing world. No drama there, huh?

> So now we are being told that words that cause harm? For whom? Well

Whereas I suppose your vision is beyond dispute?

> cancer of "cancel culture" to the IETF.

I've read it, and I've felt no personal attack whatever, despite being an
elderly privileged white male who has certainly written documents in
the past using master/slave and blacklist/whitelist terminology. I've simply
decided to slightly adjust my detector of unprofessional writing as a result.
The draft certainly needs more work and critical review, but that's why
it's called a "draft", after all.

>    Critical race theory is a pile of excrement

Thanks for pointing me to this interesting topic. It appears to be a
purely American and principally legal theory. The only person who has
ever mentioned it in the IETF is you, as far as Google knows. Since the
IETF is international and neither writes nor interprets American laws,
it seems startlingly irrelevant, which is probably why...

> and [1] builds an entire 
> house
> on top of the foundation of critical race theory. 

... that is untrue. It doesn't mention or cite CRT. Neither do any of the
documents of the IRTF Human Rights Protocol Considerations Research Group.
Neither does Google find any direct association of Mallory Knodel or
Niels ten Oever with CRT. (That is to say, I found articles that refer
both to CRT and to Mallory's and Niels' work, but disjointly.)

> It should have no place in
> the IETF.

Assuming "it" means CRT, we completely agree on that, but it's irrelevant
to the discussion at hand.

Regards,
     Brian Carpenter

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 13:43:29 +0900

> We disagree, and I guess I'll leave it at that.

And I'm saying it's not very sincere or effective to ban
"blacklist" leaving such terms as "black magic" and cultural
framework that darkness of black is somewhat evil which has
produced both terminologies.

					Masataka Ohta

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 26 Jul 2020 00:55:11 -0400

It may be that we are discussing two different things.
I am not concerned with what abbreviations appear in the "these are 
abbreviations commonly used in the IETF" list.  I am concernwed with the 
subset of that list marked with a *, meaning that they usually do not 
require expansion.   Of the three examples you cite, two are marked with 
a *, the third (RSASSA-PSS) is not so marked.

If the question is how things get into the list at all, that is one 
question, and not something we have to be particularly limited about.
My reading of other notes was that the question was things marked with a 
"*".

Yours,
Joel

---

From: Rob Sayre <[email-masked]>
Date: Sat, 25 Jul 2020 21:59:33 -0700

> I will probably regret responding other by simply saying +1 to Joel, but

+1 to Joel as well. It's important to attempt to avoid sending messages
with unintended connotations.

There will always be mixups, but I find it's better to focus on what people
hear, rather than what I meant to say.

If I am writing about a technical matter, I want the recipient to focus on
the technical issue at hand.

thanks,
Rob

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Jul 2020 01:17:39 -0400

FWIW, yes, I was addressing the same list Joel was, i.e., the
abbreviations that are allowed to be used without (local)
expansion.  The rest, IMO, is little more than a way to avoid
conflicting abbreviations within the IETF.

best,
   john

--On Sunday, July 26, 2020 00:55 -0400 "Joel M. Halpern"
<[email-masked]> wrote:

> I am not concerned with what abbreviations appear in the
> "these are abbreviations commonly used in the IETF" list.  I
> am concernwed with the subset of that list marked with a *,
> meaning that they usually do not require expansion.   Of the
> three examples you cite, two are marked with a *, the third
> (RSASSA-PSS) is not so marked.
> 
> If the question is how things get into the list at all, that
> is one question, and not something we have to be particularly
> limited about.
> My reading of other notes was that the question was things
> marked with a "*".

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 26 Jul 2020 07:52:14 +0200

> with a significant Internet technical or operational background

… for getting starred is too high.  RSASSA-PSS is also an example how the “starred” list doesn’t really work that well (the RFC title doesn’t expand it although it is not starred), as are many other cases.

So the putative criteria is wrong, (partially as a result of that, and partially because the whole concept doesn’t quite work) the list is applied inconsistently, and it seems that there is no uniformity in the result.

Looks like something that needs work.

Maybe not urgently, but it is one of those pieces of technical debt that come up each time an RFC is published, the main damage being that their titles are often mangled beyond recognition, which makes them harder, not easier, to understand.

Giving some regular attention (*) to that list could ease the pain, which is what I was trying to point out.  
In the end we’ll also need a better policy to handle the expansion issue.

Maybe all stuff to do for the RSE-ng, but stuff to do it is.

Grüße, Carsten

(*) Randomly poking:

6CIO       - 6LoWPAN Capability Indication (6CIO) 
6CO        - 6LoWPAN Context Option (6CO)

(Both should say “Option”)

ARMv4     *- Advanced RISC Machine version 4 

(This surely shouldn’t be starred under the criteria above, but then it also doesn’t make sense to expand it.  It is used in a single RFC, 6366, in an example.  This is a mid-1990s technology...)

Because the > 2500 lines are in no way sourced or even dated, it does not lend itself to divvying up the work to clean this up.  Maybe some mining in the RFCs can help do that, e.g. assigning IETF areas to the abbrevs.  But we need to understand how this list is being used, how the list could be improved to help these use cases, and what the appropriate criteria might be for them.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 26 Jul 2020 02:11:34 -0400

The text above the list states that titles are a judgment call and that 
they will sometimes allow omission of expansions in titles if the 
alternative looks too ugly.  Using judgment does seem to be what we want.

Having said that, yes, some periodic housekeeping would seem to be useful.

My disagreement was with the apparent claim by others that the "*" list 
ought to be easily updatable by an RFC that issues a new abbreviation. 
It may be that the person proposing that meant inclusion in the general 
list, rather than the "*" subset.  Or I may have misudnerstood something 
even more basic.

Yours,
Joel

---

From: Dan Harkins <[email-masked]>
Date: Sat, 25 Jul 2020 23:16:29 -0700

Brian,

> So emotional harm isn't "harm" in your book? I think you will find that

   Not that caused by mere words, no. Emotional harm can come from 
witnessing
some traumatic event but just listening to someone else talk? Nope.

> run free in the developing world. No drama there, huh?

   That has nothing to do with the idea that words are violence. Really,
I don't know what you're trying to say here.

> Whereas I suppose your vision is beyond dispute?

   I'm not imposing my vision on anyone. So you don't actually know about my
vision because I'm not telling anyone how to behave. I'm not saying that
anyone's speech is out-of bounds. I'm not telling anyone how to think or
what to say. That's the whole point.

> it's called a "draft", after all.

   Well read it again. And look for the reference to [Jansens]. A most
unprofessional attack on a person for something said as a comment to
some random blog post 12 years ago. Not that I'm defending what he said,
just that personal attack for comments on random blogs in 2008 is
unprofessional and is a sign of cancerous "cancel culture."

   As I noted on gendispatch, in 2008 Barack Obama was saying that "marriage
is between a man and a woman", a statement that will get you pilloried, or
worse, today. So maybe we should not be scouring the bowels of the Internet
for comments made in 2008 to use as motivation for the "continued struggle
against racists amongst us."

> it seems startlingly irrelevant, which is probably why...

   Nope, not a legal theory at all. It's a post-modern take on race and
equality. It has absolutely nothing to do with American law.

> both to CRT and to Mallory's and Niels' work, but disjointly.)

   Well since you thought it's somehow part of American law then I'm
not surprised you missed it. If you're just doing a grep or a google
search then you're doing it wrong.

   Dan.

---

From: Dan Harkins <[email-masked]>
Date: Sat, 25 Jul 2020 23:25:57 -0700

On 7/25/20 9:16 AM, Paul Wouters wrote:
> On Jul 25, 2020, at 10:09, Salz, Rich 
> <rsalz=[email-masked]> wrote:
>>
>> 
>>
>>   * As I’ve stated previously on this list, I view “folks” as a
>>     trigger, as it imposes passive-aggressive patronising distancing,
>>     and it’s certainly not as inclusionary as you might think. A word
>>     best avoided, in my view.
>>

   "folks" being a trigger is a classic First World Problem!

   Do you run away in terror at the sight of a VW beatle? "Volkswagen it 
reeks of
nationalism! It's a Nazi car! Aaaaahhhhh!!!!"

   Dan.

---

From: Fernando Gont <[email-masked]>
Date: Sun, 26 Jul 2020 03:33:56 -0300

> those discussions, and helping to develop a framework for handling this

Since we are at it, may I ask that the following terms be added to the 
"discussion":
* balkanization
* third-world countries
?

I've seen instances of these in RFCs, IETF I-Ds, mailing-list postings, 
and meeting minutes...

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 21:11:09 +0900

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 21:23:02 +0900

Sorry to have sent an unedited mail.

[email-masked] wrote:

> Those authors would clearly have far
> better and more nuanced perspectives on the mechanisms and oppression
> of racism and slavery than I ever will, not least from lived
> experiences. They had simply used technical terminology they were > clearly in agreement that that use was fine,

That is the correct behavior you should have been instructed
from the Authors.

> and their paper was otherwise excellent.

I wonder how you can ignore the fact that your review is fatally
broken biased for whites seeking for easy but false solutions.

I'm afraid you are suffering from the "First World Problem".

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 21:35:56 +0900

> ethnicity) who they declare are harmed by their language.

It perfectly explains why so many white people attempt to ban
innocent terminologies such as "blacklist" while avoiding to work
on the impossible task to rephrase problematic (only for their
opinion) parts of Thriller and the Lord of the Rings only to
prove their attempts are meaningless.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Sun, 26 Jul 2020 21:57:20 +0900

S Moonesamy wrote:

> issues which have influenced the debate about some words.

A problem is that, even with US local wordings, "slave" does not
specifically mean black slaves unless otherwise mentioned from
the context, which should be the reason why US people, long
after the era of slavery of blacks, coined and accepted the
terminologies with "master/slave".

So, I think it's just temporal instability in US to be better
ignored.

						Masataka Ohta

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 26 Jul 2020 15:04:59 +0200

On 2020-07-26, at 08:11, Joel M. Halpern <[email-masked]> wrote:
> 
> The text above the list states that titles are a judgment call and that they will sometimes allow omission of expansions in titles if the alternative looks too ugly.  Using judgment does seem to be what we want.

Completely agree.  The question is what input is available to make that judgement.  I can’t imagine that the RFC editor is in a good position to judge whether RSASSA-PSS is "well-known and immediately obvious to anyone...”.

So the abbreviation list could serve a purpose recording some of that information.

> Having said that, yes, some periodic housekeeping would seem to be useful.

Indeed.

> My disagreement was with the apparent claim by others that the "*" list ought to be easily updatable by an RFC that issues a new abbreviation. It may be that the person proposing that meant inclusion in the general list, rather than the "*" subset.  Or I may have misudnerstood something even more basic.

I think that an RFC cannot by itself “update” that list.
But just as the RFC editor asks about “keywords” for an RFC, they could indicate/ask about abbreviations used and created.  This would create a conscious point where authors/ADs and RFC editor could interact about moving the list forward.

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 13:31:58 +0000

I am way more optimistic.

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 13:38:19 +0000

*   We can't even use "bipeds" because it's insulting to people who have lost a leg or are otherwise incapable of bipedal motor

  *   Of course "colleague" has it's own problems - it implies that one assumes that all of one's addressees have opinions of equal worth.
I do not know if you two are joking, just going to extremes to make a point, or are really sincere, but you are mistaking the effort.

The point is not to avoid *any* word that could offend someone.  It is about being open and adaptable, so that when a group comes forward we try to accommodate them.  And we make it clear, by our actions, that we are willing to listen and be inclusive.

---

From: Fernando Gont <[email-masked]>
Date: Sun, 26 Jul 2020 11:42:50 -0300

On 26/7/20 10:38, Salz, Rich wrote:
[...]
> 
> The point is not to avoid **any** word that could offend someone.  It is 
> about being open and adaptable, so that when a group comes forward we 
> try to accommodate them.  And we make it clear, by our actions, that we 
> are willing to listen and be inclusive.

FWIW, I find the effort worthwhile. That said, there's a long way from 
using more inclusive language to being inclusive.

It would seem to me that only specific aspects of inclusiveness, and 
only specific dimensions of diversity are considered.

For instance, whenever we have had discussions on e.g. where to hold 
meetings such that the IETF is more inclusive, the usual answer is that 
that's not necessarily a goal, and that meetings should happen where 
most of the attendees come from. -- which talks a lot about protecting 
the status quo rather than about being more inclusive.

It also puzzles me a bit when the actions that are meant to be more 
inclusive do not include the most affected folks in the decisions/actions.

Maybe if we need to "be willing to listen" (to the "outside"), it's 
probably because we're not being very inclusive in the first place?

Thanks,

---

From: Paul Wouters <[email-masked]>
Date: Sun, 26 Jul 2020 10:51:47 -0400

On Jul 26, 2020, at 02:38, Fernando Gont <[email-masked]> wrote:
> 
> Since we are at it, may I ask that the following terms be added to the "discussion":

> * balkanization

Balkanization is a good example of words that are commonly used without the users realizing how painful or offensive a word can be to some. I didn’t know its use was problematic to a large group of people until Vesna Manojlovic from RIPE-NCC explained this to me back in 2000.

An RFC is a proper way for our community to write down these things so that we can refer people to it who might not be aware of these.

And if I use other words that are problematic that I am not aware of, my personal goal is to generally be acting in a way that people around me feel comfortable enough to approach me - be it email or in person - to point this out to me.

Paul

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 15:49:20 +0000

>      The idea that a metaphor can prevent someone from joining a STEM career
    is ridiculous.

And how do you know this, strongly enough to say that those who feel otherwise are ridiculous?

---

From: Joseph Touch <[email-masked]>
Date: Sun, 26 Jul 2020 08:54:50 -0700

> On Jul 25, 2020, at 3:25 PM, Toerless Eckert <[email-masked]> wrote:
> 

ISOC > ISOC chapters

(I’d have implied “much greater than”, but “>>” means shift in most programming languages).

> words for ? Just ourselves ?

You used ISOC chapters as an example of how to poll the global technical community. That fails for the reasons I have given.

You also seem to be locked onto the idea that somehow we’re officially elevating a set of people to stand in judgement. We aren’t.

All we’re trying to do is gather info from anyone who is interested. That’s about all the IETF can do (or ever does).

Joe

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 16:05:16 +0000

Does that term appear in RFCs?  If so, then yes, we should neutralize it.

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 16:07:32 +0000

>  Do you run away in terror at the sight of a VW beatle? "Volkswagen it reeks of

Belittling folks who might disagree with you does not help advance the conversation.

Yes, I know several people who will not do business with VW, DeutscheBank, IBM.

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 16:17:19 +0000

I think we're going in circles here.

You said we need to be respectful of non-black slaves and I asked for specific places where we haven't been. You said, that fact that I can't think of it means that I am being disrespectful.  I disagree: Pointing out one thing doesn't mean ignoring any others.

I admire your use of English. If we were having this conversation in Japanese, I would not be able to say much beyond thank you. But I will not go along with your attempts at language tricks to halt the conversation.  If you that makes you feel that you won, so be it.

---

From: S Moonesamy <[email-masked]>
Date: Sun, 26 Jul 2020 09:32:27 -0700

Hello,
At 05:57 AM 26-07-2020, Masataka Ohta wrote:
>specifically mean [removed] slaves unless otherwise mentioned from
>after the era of slavery of [removed], coined and accepted the

RFC 1034 was written by Mr Mockapetris, ISI, and published in 
1987.  There isn't any occurrence of the word "slave" in that 
technical specification.  The word was introduced in technical 
specifications after that date.  I would not use the word in a 
technical specification as I would have to assess whether the word 
would be considered as derogatory (or injurious) in the jurisdiction 
where I reside.

I would not use the terminology as a figure of speech as there is a 
high probability that it could be considered as offensive nowadays.

The opinions expressed in 2018 were that the terminologies were 
acceptable.  My reading of the latest round of discussions is that 
the opinions have moved to not acceptable.  In my opinion, it was 
influenced by events in the United States [1].  Nowadays, those 
opinions spread quickly to other countries through Facebook or 
Twitter.  It is difficult to ignore that.

Regards,
S. Moonesamy

1. 
https://www.reuters.com/article/us-minneapolis-police-jp-morgan-race-exc/exclusive-jpmorgan-drops-terms-master-slave-from-internal-tech-code-and-materials-idUSKBN2433E4

---

From: Dan Harkins <[email-masked]>
Date: Sun, 26 Jul 2020 10:08:43 -0700

On 7/26/20 8:49 AM, Salz, Rich wrote:
> And how do you know this, strongly enough to say that those who feel otherwise are ridiculous

   I know this because I pursued a STEM career. It was an incredible
amount of work to get into an impacted major at university, elbowing
out other ambitious and smart kids. I made a great many sacrifices
to get what I wanted so the idea that a metaphor would cause me to
throw up my hands and say, "forget it" is ridiculous. It is
inconceivable that someone would be willing to sacrifice time,
friends, and fun, to do extra work in order to succeed but then would
decide a mere word was a bridge too far and give up.

   I also know its ridiculous because the people who assert otherwise
do so with a fallacy, the residual fallacy. It goes like this:

   1. find a statistical difference between 2 groups;
   2. demonstrate that a random selection would not produce that
      difference;
   3. "control" some arbitrary variable to eliminate it from the
      difference;
   4. attribute the remaining difference to whatever you want.

So people who want to find racism in RFCs will naturally determine
that the reason black people are not pursuing STEM degrees according
to their proportion in select countries, after eliminating racism in
university admissions, must be because the technical specifications
necessary to pursue that career use exclusionary language (like
"master-slave") that dissuades the black person from the STEM career.
That's the residual. Ta-da!

   It's completely unscientific and this process can be used to "prove"
both racism in technical specifications and also to "prove" genetic
inferiority among races. It can, in fact, "prove" anything you want
which is why this particular fallacy is so attractive.

   Does this answer your question?

   Dan.

---

From: Joseph Touch <[email-masked]>
Date: Sun, 26 Jul 2020 10:30:18 -0700

> On Jul 25, 2020, at 11:33 PM, Fernando Gont <[email-masked]> wrote:
> 

Yes - thanks. That does help. Other examples are welcome - at least to me directly off-list if not on-list.

Examples with suggested alternatives are helpful too.

Joe

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 26 Jul 2020 11:50:18 -0700

> Examples with suggested alternatives are helpful too.

grandfather/grandfathered is used in a few RFCs:  https://www.britannica.com/topic/grandfather-clause

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 26 Jul 2020 22:53:48 +0200

Words that where already used in RFCs would IMHO might get higher priority.

balkanization: 4 times, third world (not countries): 3 times.

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 26 Jul 2020 23:14:18 +0200

> grandfather/grandfathered is used in a few RFCs:  https://www.britannica.com/topic/grandfather-clause

Thank you — we should collect these explanatory snippets so people like me who are not experts on US history can readily find the explanation why we shouldn’t be using these idioms any more.

Grüße, Carsten

---

From: Jay Daley <[email-masked]>
Date: Mon, 27 Jul 2020 09:32:15 +1200

A question I can’t resolve by Googling - has anyone attempted to create entirely new words to represent the concepts that master or slave have been used to represent?  e.g. a word that means "authoritative source of data that has no dependency on another source" and has no other meaning?

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Joseph Touch <[email-masked]>
Date: Sun, 26 Jul 2020 14:49:58 -0700

> On Jul 26, 2020, at 2:32 PM, Jay Daley <[email-masked]> wrote:
> 

Why aren’t either primary or authoritative vs. copy/secondary/replica sufficient?

Joe

---

From: Jay Daley <[email-masked]>
Date: Mon, 27 Jul 2020 10:04:37 +1200

> On 27/07/2020, at 9:49 AM, Joseph Touch <[email-masked]> wrote:
> 
> 
> 

I don’t have an opinion on whether they are or not.  I was just interested in whether anyone is rethinking this from a different perspective.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 27 Jul 2020 00:05:18 +0200

> Why aren’t either primary or authoritative vs. copy/secondary/replica sufficient?

There’s also “original”.

A good way to coin words is to look into other languages (not just Latin and Greek).  E.g., in German, there is “Matrize” and “Mater” from the printing world (OK, these are Latin); “Cliché” in French (Klischee germanized) does have other meanings though.  You’ll have to ask an Indonesian whether “babon” would work…  Makes hens and eggs back in English.

Maybe calling them A and B is easier...

Grüße, Carsten

---

From: Joseph Touch <[email-masked]>
Date: Sun, 26 Jul 2020 15:06:13 -0700

> On Jul 26, 2020, at 3:04 PM, Jay Daley <[email-masked]> wrote:
> 
> 
> 
>> On 27/07/2020, at 9:49 AM, Joseph Touch <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 
>>> On Jul 26, 2020, at 2:32 PM, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>>> 

Oh, I don’t know if new terms have been coined for this issue.

However, in many cases these might not have been the best terms in the first place vs. other existing terms.

Joe

---

From: John C Klensin <[email-masked]>
Date: Sun, 26 Jul 2020 18:11:40 -0400

--On Monday, July 27, 2020 09:32 +1200 Jay Daley <[email-masked]>
wrote:

> A question I can't resolve by Googling - has anyone
> attempted to create entirely new words to represent the
> concepts that master or slave have been used to represent?
> e.g. a word that means "authoritative source of data that has
> no dependency on another source" and has no other meaning?

Jay,

At least in the DNS sense, some of us (despite being old white
guys with white beards) have objected to "master/slave" for
years, not just because the usage may be offensive but because
it is wrong technically.   In that context, the so-called slave
is actually fairly independent.  It (or its operators) decide
when check for and fetch relevant values (whether based on
timeouts or on server request) and can reject and not install
such updates.

Unfortunately, in the DNS context, "authoritative" means someone
else, but "primary" and "secondary" have been used for years.
Of course, someone could probably find those offensive too, but
then we get into problems with, e.g., "Director" ("Executive" or
otherwise).

    john

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 26 Jul 2020 22:15:24 +0000

Dan, it seems that your post says "I worked hard and nothing deterred me, therefore nobody else who really wants it should be deterred, therefore people who believe that it is possible must be using this theory of residual fallacy."  Your post only holds if your experience is applicable to everyone, and it's not, so no you didn't convince me.

---

From: Victor Kuarsingh <[email-masked]>
Date: Sun, 26 Jul 2020 18:26:24 -0400

John,

I am wondering if master/copy would be appropriate since that is what do we
in a number of cases.

As with things like recordings (e..g music, video, etc) , we have a master
of information and copies which operate quite independently.  This use of
the term - “master” -  is not connected with the historical issues with the
previous terms.

Not specifically advocating for this per se.

Regards,

Victor K

---

From: [email-masked]
Date: Sun, 26 Jul 2020 22:40:17 +0000 (UTC)

the sense of “obey without question” present in the original terms is missing

Joe

---

From: Donald Eastlake <[email-masked]>
Date: Sun, 26 Jul 2020 20:07:14 -0400

I agree with Joel. Standards document in all SDOs with which I am
familiar vastly overuse acronyms.

I never consult the RFC Editor abbreviations list. I just try to apply
common sense. I don't spell out things like IP, IETF, UDP, TCP, etc.
but quite frequently spell out things that turn out to be on the RFC
Editor abbreviations list. Occasionally the office of the RFC Editor
or an AD points this out to me and I just push back and say that I
think it is better to be clearer and more explicit. I have never been
forced to use an acronym in the IETF.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Dan Harkins <[email-masked]>
Date: Sun, 26 Jul 2020 18:14:52 -0700

On 7/26/20 3:15 PM, Salz, Rich wrote:
> Dan, it seems that your post says "I worked hard and nothing deterred me, therefore nobody else who really wants it should be deterred,

   In a word: no. That's not what it said. Everyone can be deterred but 
if they are
not deterred by hard work, sacrifice, and delayed gratification then 
they're not
going to be deferred by a mean word. That's the point. It beggars belief.

> therefore people who believe that it is possible must be using this theory of residual fallacy."  Your post only holds if your experience is applicable to everyone, and it's not, so no you didn't convince me.

   The thing is Rich, I'm not the one trying to tell anyone else what 
words they
cannot use. So the burden of convincing is not on me. You seem to think 
that there
are words that we must not use in RFCs anymore. So the burden is 
actually on you.
Go ahead, convince me. I'll wait.

   Dan.

---

From: Rob Sayre <[email-masked]>
Date: Sun, 26 Jul 2020 18:32:45 -0700

On Sun, Jul 26, 2020 at 6:15 PM Dan Harkins <[email-masked]> wrote:

> You seem to think that there are words that we must not use in RFCs
> anymore. So the burden is
> actually on you. Go ahead, convince me. I'll wait.
>

 I don't think this is a big deal. The specs that insist on using
controversial words are usually bad, anyway.

thanks,
Rob

---

From: Joseph Touch <[email-masked]>
Date: Sun, 26 Jul 2020 21:12:02 -0700

> On Jul 24, 2020, at 12:15 PM, Carsten Bormann <[email-masked]> wrote:
> 

https://www.strayalpha.com/tech-terms <https://www.strayalpha.com/tech-terms>

It’s a work in progress; I’m working particularly on formatting it so it can be scraped more easily for searching.

Joe

---

From: Fernando Gont <[email-masked]>
Date: Sun, 26 Jul 2020 13:05:28 -0300

On 25/7/20 19:25, Toerless Eckert wrote:
[...]
> words for ? Just ourselves ?

Well, unfortunately, unless there's a more comprehensive strategy for 
inclusiveness, I believe that, unfortunately, you've made a valid point.

(Although I still think the effort is worthwhile).

Thanks,

---

From: Fernando Gont <[email-masked]>
Date: Mon, 27 Jul 2020 01:02:41 -0300

On 26/7/20 14:30, Joseph Touch wrote:
> 
> 
>> On Jul 25, 2020, at 11:33 PM, Fernando Gont <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>

FWIW, this is what I'd probably suggest as alternatives:

* third-world countries / thirld world -> developing 
countries/developing economies

* balkanization -> segmentation / uncooperative segmentation / 
conflictive segmentation/separation

P.S.: One of the most useful things would be for the tools employed to 
create documents (e.g. xml2rfc or idnits and/or spellcheck) to issue 
warnings for these, and probably suggest the author to tweak the text 
and maybe suggest some of the alternatives we are discussing here..

Thanks!

Cheers,

---

From: Fernando Gont <[email-masked]>
Date: Mon, 27 Jul 2020 01:05:11 -0300

> balkanization: 4 times, third world (not countries): 3 times.

FWIW, Google also shows some instances  of "third world" in a recent 
IASA meeting and also on mailing-lists...

Thanks!

Cheers,

---

From: tom petch <[email-masked]>
Date: Mon, 27 Jul 2020 10:25:06 +0100

> Does that term appear in RFCs?  If so, then yes, we should neutralize it.

Yes, the title, no less, of RFC5782 is 'DNS Blacklists and Whitelists'. 
  You will find it in the RFC-index and via the datatracker.
The term was discussed on the list, with blocklist considered as an 
alternative, but that was rejected.  The potential connotations of the 
term were discussed and there was a clear consensus that it was the most 
suitable term for the context.
(I still get requests from organisations wanting my business asking me 
to ensure that their e-mail address is on my whitelist).
It is history, it is how we were and it would be wrong to rewrite 
history; rather the focus should be on accepting how we were and using 
it to illuminate how we are and see what we can learn from the comparison.

A quick search suggests that I have seen the term used in I-D from SACM, 
NETCONF, I2NSF, ANIMA, APPSAWG, HTTPAUTH, INTAREA, SIPPING, V6OPS, DTNRG 
and MANET, some more recent than others; it also appears in the minutes 
of IETF102.

Of the RFC I cache, I see it in nine of which the most recent is RFC6589.

Tom Petch

---

From: tom petch <[email-masked]>
Date: Mon, 27 Jul 2020 10:54:23 +0100

On 26/07/2020 05:10, Dan Harkins wrote:
>    Words can be mean and they can make someone cry.

And that is where I part company with you (and perhaps the starting 
point of this thread).  To me it is fundamental that I cannot 'make' you 
or anyone else feel an emotion by what I say or do.  What I say may 
engender sorrow in one, anger in another, fear in another and so no 
(although it would not have been my intention for any of this to 
happen).  Rather, what emotion results is, in a deep sense, a choice 
made by the individual, perhaps affected by their personality, state of 
mind, history and so on; they have a choice to feel differently even if 
the conscious mind struggles to escape its immediate reaction.

So when I see others declaring that an action is hurtful, then I may, at 
times, see that as a subjective response, one that might be different 
were they to reflect more on where this response is coming from.  We can 
agree that slavery is abhorent, in the past or in the present, but that 
does not mean we must eradicate the terminology from our discourse as if 
we could somehow eradicate such a practice or the emotions associated 
with it.

Tom Petch                                                         And if 
someone is hurt

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 11:00:12 +0000

>Everyone can be deterred but 
    if they are

There are more things in heaven and earth, Horatio, then are dreamt of in your philosophy.  You never know what will be the final straw for someone.

Walk a mile in someone else's shoes.  Accept that there are those who are deterred.  Oh well.

---

From: Dan Harkins <[email-masked]>
Date: Mon, 27 Jul 2020 04:40:31 -0700

> Walk a mile in someone else's shoes.  Accept that there are those who are deterred.  Oh well.

   I see. So actually any assertion is completely valid. Nothing can be 
contested
because "you'll never know" and "there are those".

   And based on this unfalsifiable assertion you are going to compel 
behavior?
No! That's not how it works.

   Dan.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 11:43:18 +0000

No Dan, I'm asking you to consider that your personal history might not be universal.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 27 Jul 2020 13:35:47 +0100

Joe

I see how that properly describes the relative authority of the two components.

I always prefer to use a h/w flip-flop to visualise the behaviour.

I am fine with moving to a new name provided we captures the actual behaviour.

Stewart

> On 26 Jul 2020, at 22:49, Joseph Touch <[email-masked]> wrote:
> 
> 
>

---

From: Dan Harkins <[email-masked]>
Date: Mon, 27 Jul 2020 05:44:43 -0700

On 7/27/20 4:43 AM, Salz, Rich wrote:
> No Dan, I'm asking you to consider that your personal history might not be universal

   And I'm telling you that if you that the bar to compel speech is 
considerably
higher than rank assertions and fallacies.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 12:50:01 +0000

considerably

Nobody is compelling anything, unless the IETF comes to consensus to not use language that some find problematic. I think you have made it clear that you are opposed to that consensus. Calling it compelled speech is clever and I salute your linguistic ability.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 27 Jul 2020 08:56:27 -0400

Dan, as far back as 2013, the IESG adopted, and the IETF accepted, a 
policy on anti-harrassment that recognizes that speech can be harmful.
It seems clear to me that the community disagrtees with your perspective 
on this.
And the community clearly has the right and responsibility to set 
behavioral standards for its members.

Yours,
Joel

---

From: Dan Harkins <[email-masked]>
Date: Mon, 27 Jul 2020 06:10:02 -0700

On 7/27/20 5:56 AM, Joel M. Halpern wrote:
> It seems clear to me that the community disagrtees with your 
> perspective on this.

https://www.ietf.org/about/groups/iesg/statements/anti-harassment-policy/

"harm" not found.

---

From: Paul Wouters <[email-masked]>
Date: Mon, 27 Jul 2020 10:02:21 -0400

> "harm" not found.

Unfortunately, this thread has already harmed the IETF community. Not only by showing a lack of empathy to try and be more inclusive when the costs are low, but also by showing how toxic discussions can get at IETF.

unfortunately, cultural change is very slow.

Paul

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 27 Jul 2020 16:08:09 +0200

On Sat, Jul 25, 2020 at 12:56:54AM +0200,
 Toerless Eckert <[email-masked]> wrote 
 a message of 81 lines which said:

> Otherwise, we could simply replace any english term we do not like
> as americans with a french term for use in the IETF.

I agree 100 %.

> They have a long history of trying to keep their own language freee
> of english influence,

Quite unsuccessful, in the technical environment (both in work and in
education). When I talk about IT-related stuff in french, I often have
to use the english word because listeners were baffled by the french
word I used.

> and AFAIK they even have a government oversight board for such
> terminology,

A lot of FUD have circulated about that so let's make things straight:

* The "Commission d'enrichissement de la langue française"
<http://www.culture.fr/franceterme> is indeed a government body but
its output is non-binding for ordinary citizens and organisations. (It
is mandatory for official text.)

* "Académie française" <http://www.académie-française.fr/> (hello to
RFC 5891), is not really a "governement body" and, anyway, whatever
they produce is also non-binding.

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 27 Jul 2020 23:25:21 +0900

> Does that term appear in RFCs?  If so, then yes, we should neutralize it.

Do you mean "cultural framework that darkness of black is somewhat
evil which has produced both terminologies" is a term?

I'm afraid I don't think so.

							Masataka Ohta

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 14:26:48 +0000

> Does that term appear in RFCs?  If so, then yes, we should neutralize it.

I meant the specific term "black magic"

Your response was, as I am sure you know, not a good representation of what I have been saying.

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 27 Jul 2020 23:30:11 +0900

> I think we're going in circles here.

That should be because you won't face the source of
the problem saying:

 > commenting on Thriller or Tolkien's writings -- isn't useful
 > to have a productive conversation, and I won't be enticed there.

						Masataka Ohta

---

From: Carrick Bartle <[email-masked]>
Date: Mon, 27 Jul 2020 07:33:47 -0700

I agree.

> On Jul 27, 2020, at 7:02 AM, Paul Wouters <[email-masked]> wrote:
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 14:35:24 +0000

We disagree on the relevance of discussing that.

    						Masataka Ohta

---

From: Richard Barnes <[email-masked]>
Date: Mon, 27 Jul 2020 10:42:05 -0400

+1

On Mon, Jul 27, 2020 at 10:41 AM Carrick Bartle <cbartle891=
[email-masked]> wrote:

> > Unfortunately, this thread has already harmed the IETF community. Not
> only by showing a lack of empathy to try and be more inclusive when the
> costs are low, but also by showing how toxic discussions can get at IETF.
> >

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 27 Jul 2020 23:45:49 +0900

S Moonesamy wrote:

> RFC 1034 was written by Mr Mockapetris, ISI, and published in 1987.  
> There isn't any occurrence of the word "slave" in that technical 
> specification.  The word was introduced in technical specifications 

I thank you to have proved my point that saying "slave" has never
been a problem in the then-US-dominant Internet community even
after 1987.

						Masataka Ohta

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 27 Jul 2020 15:46:18 +0100

OK, I'll be drawn...

I can quite believe that contributors to the IETF can have and express
opinions on the language used in a variety of published works that were not
produced in the IETF. I cannot believe that those opinions will have any
influence on those publications.

If we limit our discussions to those things we can control (i.e., the use of
language in future work produced within the IETF) we may have a more useful
discussion.

We might rephrase the question as (please note the wording carefully!):
If we have reason to believe that the use of a particular term might bring
the IETF into disrepute or might cause some people to feel excluded from
IETF participation, would we prefer to use a different term?

Note that question does not ask:
- is the reason to believe credible?
- is the reputational damage bothersome?
- is it sensible for people to feel excluded?

I am hoping that no one here assembled wishes to deliberately use a term
that they know will cause disrepute or make people feel excluded. 

So the debate collapses to a discussion of which terms are problematic. 
It is a classic problem that we find it hard to judge which things we say or
do are upsetting to others. Perhaps we can take advice from experts in the
field?

Best,
Adrian
-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Masataka Ohta
Sent: 27 July 2020 15:30
To: Salz, Rich <[email-masked]>; [email-masked]
Subject: Re: USA dominion: Re: IESG Statement On Oppressive or Exclusionary
Language

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 27 Jul 2020 23:57:14 +0900

> I think we're going in circles here.

when your disagreement results in the loops of unproductive
conversation?

>       > to have a productive conversation, and I won't be enticed there.

Face the true problem.

							Masataka Ohta

---

From: Joseph Touch <[email-masked]>
Date: Mon, 27 Jul 2020 08:30:38 -0700

Speaking of Lord of the Rings, I’ve realized this community seems to be inspired by the Ents (with liberties):

	“It takes a long time to say anything in IETFish. And we *NEVER* say anything unless it is worth taking a long time to say.:”

I take my inspiration from Yoda (and not should everyone?):

	“Do or do not. There is no try."

Joe

> On Jul 27, 2020, at 7:42 AM, Richard Barnes <[email-masked]> wrote:
> 
> +1
> 
> On Mon, Jul 27, 2020 at 10:41 AM Carrick Bartle <cbartle891=[email-masked] <mailto:[email-masked]>> wrote:
> I agree.
> 
> 
> 
> > On Jul 27, 2020, at 7:02 AM, Paul Wouters <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > On Jul 27, 2020, at 09:10, Dan Harkins <[email-masked] <mailto:[email-masked]>> wrote:
> >> 
> >> "harm" not found.
> >

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 15:33:45 +0000

You insist that I consider things like Tolkein and Thriller, and if I don't I am not facing the true problem.  I believe you are widening the scope beyond what is necessary to address the current issue.  Hence the circularity.  As I said a few messages ago, if you want to take that as "I win" go ahead.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 27 Jul 2020 11:51:09 -0400

Sorry if I'm misunderstanding your allusion here, Joe, but it sounds to me
like you're saying "if you can't keep up with the threads (only 'try'ing),
GTFO."

Assuming I'm reading you correctly, that is a big dimension the exclusion
that folks are noting here.

--Richard

On Mon, Jul 27, 2020 at 11:30 AM Joseph Touch <[email-masked]> wrote:

> “It takes a long time to say anything in IETFish. And we *NEVER* say
> anything unless it is worth taking a long time to say.:”
>

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 28 Jul 2020 00:55:51 +0900

Salz, Rich wrote:

> I believe you are widening the scope beyond what is necessary to
> address the current issue.

Though the original draft says:

: describes the problems introduced by some specific terms,

: The terms discussed in this document include "master-slave"
: and "whitelist-blacklist".any problem in

the draft does not discuss "blacklist".

Maybe because of that, we were (or, at least, I was) discussing
on "slave".

Then, as *YOU* mentioned "blacklist" to me, I explained why
there are no problems unless you think Thriller and the Lord
of the Rings were problematic.

For me, "blacklist" is an easier example than "slave" and,
as such, I welcomed your mentioning of "blacklist" widening
the scope.

						Masataka Ohta

---

From: Joe Touch <[email-masked]>
Date: Mon, 27 Jul 2020 08:56:29 -0700

I’m asking what actions are planned. Or has that been sidelined in favor of discussion?

> On Jul 27, 2020, at 8:51 AM, Richard Barnes <[email-masked]> wrote:
> 
> 
> Sorry if I'm misunderstanding your allusion here, Joe, but it sounds to me like you're saying "if you can't keep up with the threads (only 'try'ing), GTFO."
> 
> Assuming I'm reading you correctly, that is a big dimension the exclusion that folks are noting here.
> 
> --Richard
> 
>>>> On Mon, Jul 27, 2020 at 10:41 AM Carrick Bartle <cbartle891=[email-masked]> wrote:
>>>> I agree.
>>>> 
>>>> 
>>>>

---

From: Yoav Nir <[email-masked]>
Date: Mon, 27 Jul 2020 19:08:17 +0300

> On 27 Jul 2020, at 15:50, Salz, Rich <rsalz=[email-masked]> wrote:
> 

> Nobody is compelling anything,

The subject of this thread is “IESG Statement On Oppressive or Exclusionary Language”. Someone is definitely tryiing to compel people to not use what they consider to be oppressive and exclusionary language.

> unless the IETF comes to consensus to not use language that some find problematic.

This is empowering “some” to compel everyone to avoid what they consider problematic. As an example, I know I’m an outsider in the US, but to me words like “folks” and “y’all” in US English (no connection to German or Dutch origins) express the contempt that intellectual elites feel towards less educated people. The latter term is specifically a fake southern accent, while the former is always associated with a lack of education. Consider terms like “folksy” and “folk wisdom”.

> I think you have made it clear that you are opposed to that consensus. Calling it compelled speech is clever and I salute your linguistic ability.

IETF consensus is usually achieved by a small group of people who care about a particular subject. That works fine as long as the people who care about automated certificate issuance and renewal participate in ACME, and people who only participate in the IETF for routing protocols don’t ever read the drafts. We’re fine with saying that the documents have “IETF consensus”.  

This doesn’t work here. Like every other topic, only the people who care about word usage are going to participate in the discussion, and maybe Dan and two others will be the only voices there against it. The people who don’t care so much, or the people who think the whole thing is just silly are not going to participate.  Yet this will end up in an RFC that is binding on everyone.   

The potential for a small but motivated group to hijack the process and dictate policy is great, and the argument that the process was open to everyone is not convincing. We all have limited time, and arguing language policy at the IETF is not a good use of time for most of us.  

For me, the “master/slave” terminology is something that I believe should be phased out, because it was never a good metaphor: The interaction between human masters and human slaves is not one where the slave copies the master, so it was always a poor term. But “blacklist” and “whitelist” are terms that have been used widely for decades if not centuries, and nobody can really give a good reason as to why someone would consider it offensive.  Perhaps whitespace is also offensive? Red/Black trees?  You don’t have to walk in anyone’s shoes to consider that silly, and yet a working group would be very likely to add all of those to the list of prohibited speech, and that will affect us all.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 16:16:55 +0000

*   I’m asking what actions are planned. Or has that been sidelined in favor of discussion?

The IESG posted their statement four days ago. Since then about 200 messages with this subject have been posted, about 60 people commented and the top five are:
  29  "Salz, Rich" <[email-masked]>
  21  Masataka Ohta <[email-masked]>
  19  Toerless Eckert <[email-masked]>
  18  Joseph Touch <[email-masked]>
   9  Dan Harkins [email-masked]<mailto:[email-masked]>

More than half of all postings were people who posted one or two messages.

TL;DR:  Still early to plan actions I think.

---

From: Joseph Touch <[email-masked]>
Date: Mon, 27 Jul 2020 09:22:34 -0700

IMO, it would be useful for those who care to post a list of what they consider eligible and/or comment on lists others have posted.

Same with process.

So far we’ve been speaking in hypotheticals of what might result; I’d like to see what people have in mind beyond what’s written.

Joe

> On Jul 27, 2020, at 9:16 AM, Salz, Rich <[email-masked]> wrote:
> 
>   29  "Salz, Rich" <[email-masked] <mailto:[email-masked]>>
>   21  Masataka Ohta <[email-masked] <mailto:[email-masked]>>
>   19  Toerless Eckert <[email-masked] <mailto:[email-masked]>>
>   18  Joseph Touch <[email-masked] <mailto:[email-masked]>>
>    9  Dan Harkins [email-masked] <mailto:[email-masked]>
>

---

From: Mary B <[email-masked]>
Date: Mon, 27 Jul 2020 11:26:34 -0500

On Mon, Jul 27, 2020 at 11:14 AM Yoav Nir <[email-masked]> wrote:

> The subject of this thread is “IESG Statement On Oppressive or
> Exclusionary Language”. Someone is definitely tryiing to compel people to
> not use what they consider to be oppressive and exclusionary language.
>
> This is empowering “some” to compel everyone to avoid what they consider
> problematic. As an example, I know I’m an outsider in the US, but to me
> words like “folks” and “y’all” in US English (no connection to German or
> Dutch origins) express the contempt that intellectual elites feel towards
> less educated people. The latter term is specifically a fake southern
> accent, while the former is always associated with a lack of education.
> Consider terms like “folksy” and “folk wisdom”.
>
[MB] And, your interpretation is totally, totally off base.  I use both of
those words frequently and there are a lot of folks here in Texas with a
real southern accent that use those words. And, I've been around long
enough that I can also use a southern drawl and it's not even intentional
that I will often do so after spending time in places like East Texas (most
of Dallas are not native Texans).  I use "folks" all the time and I'm
absolutely not using it as an intellectual elite nor using it in any way
as condescending. And, yes, I use "y'all" frequently as well but not very
frequently in writing.   I have no idea where you got this impression or
why you've formed such a strong negative opinion of those terms.  You might
be watching too much American television if this is what you really
believe.   Of course, this might explain why I do find IETF to be a pretty
hostile place to get work done if people are interpreting my language in
that way.  [/MB]

>
> > I think you have made it clear that you are opposed to that consensus.
> Calling it compelled speech is clever and I salute your linguistic ability.
>
> IETF consensus is usually achieved by a small group of people who care
> about a particular subject. That works fine as long as the people who care
> about automated certificate issuance and renewal participate in ACME, and
> people who only participate in the IETF for routing protocols don’t ever
> read the drafts. We’re fine with saying that the documents have “IETF
> consensus”.
>
> This doesn’t work here. Like every other topic, only the people who care
> about word usage are going to participate in the discussion, and maybe Dan
> and two others will be the only voices there against it. The people who
> don’t care so much, or the people who think the whole thing is just silly
> are not going to participate.  Yet this will end up in an RFC that is
> binding on everyone.
>
> The potential for a small but motivated group to hijack the process and
> dictate policy is great, and the argument that the process was open to
> everyone is not convincing. We all have limited time, and arguing language
> policy at the IETF is not a good use of time for most of us.
>
> For me, the “master/slave” terminology is something that I believe should
> be phased out, because it was never a good metaphor: The interaction
> between human masters and human slaves is not one where the slave copies
> the master, so it was always a poor term. But “blacklist” and “whitelist”
> are terms that have been used widely for decades if not centuries, and
> nobody can really give a good reason as to why someone would consider it
> offensive.  Perhaps whitespace is also offensive? Red/Black trees?  You
> don’t have to walk in anyone’s shoes to consider that silly, and yet a
> working group would be very likely to add all of those to the list of
> prohibited speech, and that will affect us all.
>
>

---

From: Joseph Touch <[email-masked]>
Date: Mon, 27 Jul 2020 09:28:41 -0700

> On Jul 27, 2020, at 9:08 AM, Yoav Nir <[email-masked]> wrote:
> 
> 
> 

The doc says:

	Authors SHOULD … (avoid the following terms)
	RFC Editor MUST … (support this process by offering alternatives)

I.e., the only compelled party here is the RFC Editor - at best to provide suggested alternatives.

> ...
> IETF consensus is usually achieved by a small group of people who care about a particular subject.

That’s how the IETF works. If you want to change process, that’s a different doc.

> This doesn’t work here. Like every other topic, only the people who care about word usage are going to participate in the discussion, and maybe Dan and two others will be the only voices there agai…

That’s true of all IETF docs.

> The potential for a small but motivated group to hijack the process and dictate policy is great, and the argument that the process was open to everyone is not convincing. We all have limited time,…

You could say the same for the documents at the core of many current WGs. 

This is the process we have. If you want to change THAT, it would be a different proposal.

We’re not trying to ban words; we’re trying to help those who might not realize otherwise when certain words have current  connotations they might not have intended.

Joe

---

From: Joseph Touch <[email-masked]>
Date: Mon, 27 Jul 2020 09:31:21 -0700

FWIW, for flip-flops, leader/follower works too.

> On Jul 27, 2020, at 5:35 AM, Stewart Bryant <[email-masked]> wrote:
> 
> Joe
>

---

From: Eliot Lear <[email-masked]>
Date: Mon, 27 Jul 2020 18:31:26 +0200

In the department of meta-meta...

> On 27 Jul 2020, at 16:02, Paul Wouters <[email-masked]> wrote:
> 

On the one hand the IESG has asked for community feedback.  On the other hand, when someone provides a dissent, he is told that the discussion itself is toxic.  Maybe so, but the right response is research results that demonstrate that the language needs to be change, not just a statement from which it is to be inferred that it’s unreasonable to disagree with a proposed change.

Again, the fundamental here is that there is no stable norm of how we should choose technology terms and more to the point, when we should change them.  This is what causes much of the strife.  Let’s get some people to go fix that part.

Some resistance to change of terminology is probably a good thing because otherwise our language itself becomes unstable, and difficult to comprehend as the years go by.  We all know of terms that were in common use in the late 1800s and much of the 20th century that we would not dare use today, so some change is appropriate.

I might also point out that this toxicity you speak of only stopped in a number of other fora when package maintainers just decided to end the debate, and do what they wanted.  Not generally how we work, for better or worse.

Eliot

---

From: Vittorio Bertola <[email-masked]>
Date: Mon, 27 Jul 2020 18:41:11 +0200 (CEST)

> Il 27/07/2020 18:08 Yoav Nir <[email-masked]> ha scritto:
>  

Unfortunately, all these nuances are generally lost to non-native English speakers, who do not know the context behind these terms and how they could ever be offensive. Actually, given some of the comments earlier in the thread, even native English speakers of a dialect other than American English may miss these implications.

So can I point out that being easily offended by such complex nuances, or requiring all participants to master English so well that they can avoid using any term inappropriately, is also quite exclusionary? There is a difference between terms that are specifically connected to discrimination (such as "slave") and pretty general terms that could be construed as offensive only in some secondary meanings and specific contexts (such as "grandfather", to mention another example given here).

Also, the more the community becomes picky and aggressive on the use of "appropriate" English words, and the more the non-native speakers (and the newcomers) will be scared of opening their mouths. It is already quite scary today, given how openly aggressive the reactions are sometimes.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 27 Jul 2020 12:43:35 -0400

On Mon, Jul 27, 2020 at 12:33 PM Eliot Lear <lear=[email-masked]>
wrote:

> Unfortunately, this thread has already harmed the IETF community. Not only
> by showing a lack of empathy to try and be more inclusive when the costs
> are low, but also by showing how toxic discussions can get at IETF.
>
>
>
> On the one hand the IESG has asked for community feedback.  On the other
> hand, when someone provides a dissent, he is told that the discussion
> itself is toxic.
>

I would just like to push back on the idea of there being a dichotomy
here.  There is a lot of room for feedback and even dissent that is not
toxic.

For me where the "toxic" line is crossed is when folks start to invalidate
the experiences of others.  We've seen this in other venues, notably in the
RFC series discussion.  A newcomer says "This is hard for me" or "This
doesn't meet my needs" and hears back "It's not hard" or "It meets my needs
just fine".  Here, some folks are saying "This sort of language makes it
harder for me to participate" and some messages in this thread are saying
back "This isn't a concern".

So like I said in my very first message to this thread, if this discussion
could be had from a place of empathy for our fellow contributors here, I
think we would make a lot more progress.

--Richard

> Maybe so, but the right response is research results that demonstrate that
> the language needs to be change, not just a statement from which it is to
> be inferred that it’s unreasonable to disagree with a proposed change.
>
> Again, the fundamental here is that there is no stable norm of how we
> should choose technology terms and more to the point, when we should change
> them.  This is what causes much of the strife.  Let’s get some people to go
> fix that part.
>
> Some resistance to change of terminology is probably a *good* thing
> because otherwise our language itself becomes unstable, and difficult to
> comprehend as the years go by.  We all know of terms that were in common
> use in the late 1800s and much of the 20th century that we would not dare
> use today, so some change is appropriate.
>
> I might also point out that this toxicity you speak of only stopped in a
> number of other fora when package maintainers just decided to end the
> debate, and do what they wanted.  Not generally how we work, for better or
> worse.
>
> Eliot
>
>

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 28 Jul 2020 01:53:13 +0900

Eliot Lear wrote:

> but the right response is
> research results that demonstrate that the language needs to be
> change,

destroying Thriller, the Lord of the Rings and all the fantasies
and FRPGs in the future?

That's impossible.

Instead, you should accept that "black" is somewhat evil/bad
though it does not imply black skin or cloths are evil/bad.

For example, though rather a fantasy than reality, Ninja is
famous to have worn black cloths. So what?

						Masataka Ohta

---

From: Mary B <[email-masked]>
Date: Mon, 27 Jul 2020 12:04:36 -0500

On Mon, Jul 27, 2020 at 11:41 AM Vittorio Bertola <vittorio.bertola=
[email-masked]> wrote:

> Unfortunately, all these nuances are generally lost to non-native English
> speakers, who do not know the context behind these terms and how they could
> ever be offensive. Actually, given some of the comments earlier in the
> thread, even native English speakers of a dialect other than American
> English may miss these implications.
>
[MB] That nuance is also lost on me as a 50+ year old native English
speaker whose lived in a variety of regions in the US (and Newfoundland).
 I use the term "folks" with the same meaning as the German word "volk".
And, y'all is just how we abbreviate "you all" in the more Southern parts
of the US.  Often further North, the term "you guys" is used.  And,
actually when I use "You people" that's often in a much more negative
context.   I have no idea where Yoav got his interpretation of these terms
unless, like I said, he derived it from American TV or movies with
stereotypes of folks from those regions.   [/MB]

>
> So can I point out that being easily offended by such complex nuances, or
> requiring all participants to master English so well that they can avoid
> using any term inappropriately, is also quite exclusionary? There is a
> difference between terms that are specifically connected to discrimination
> (such as "slave") and pretty general terms that could be construed as
> offensive only in some secondary meanings and specific contexts (such as
> "grandfather", to mention another example given here).
>
> Also, the more the community becomes picky and aggressive on the use of
> "appropriate" English words, and the more the non-native speakers (and the
> newcomers) will be scared of opening their mouths. It is already quite
> scary today, given how openly aggressive the reactions are sometimes.
>
[MB] I totally agree per my comment that if people are interpreting my use
of these terms that way, that might partly explain why I find IETF to be a
pretty hostile place to get work done. [/MB]

---

From: Nico Williams <[email-masked]>
Date: Mon, 27 Jul 2020 12:29:27 -0500

> IETF, and among readers of our documents.

[I'll come back to the quoted text at the bottom.]

I long ago started using, e.g., primary/replica terminology in
proprietary code.  (In open source code projects where replacing the
traditional alternative to primary/replica terminology would require
making backwards-incompatible interface changes, I've left it as it
was.)  I didn't need a policy to tell me that this might be a good idea
-- no one even told me so, I just did it.

We are adults.  We do not need explicit language policies.  We can
easily have a soft policy that the RFC production center (RPC),
shepherds, ADs, reviewers, look for offensive language and suggest or
even require changing it.  Heck, we don't even need a soft policy, as
each of those can already of their own initiative make such suggestions.

What's nice about a soft policy is that we don't have to have bitter
self-DDoS debates on this list about the offensiveness of particular
terminology.  As long as the arbiter of offensiveness is the offended,
we can't avoid such debates except by just not having them in the first
place by not having an exact policy written down.  Instead we can have
localized debates about individual terms as they come up.

Explicit language policies and the policing that goes with them
infantilize everyone in all of at least these ways:

 - In today's cancel culture atmosphere politically-correct policies
   serve to identify the in-crowd and the out-crowd at the middle school
   cafeteria.  Hint: those who object are in the out-crowd.  Objecting
   to some details still marks you as a possible thought criminal.

 - We see unsubstantiated claims as above of language causing
   unspecified "harms".  It's like we're all 5 and the teacher has to
   tell us "it's thus because [I say so]".  No argument is or will be
   accepted because we're too infantile to understand.

   Indeed, no argument will be accepted.  The proposed policy will
   almost certainly be adopted without substantial changes.

   (That language policies themselves cause harm will not even be
   considered a valid proposition, let alone considered, while the
   proposition that some terms cause harm will be accepted at face
   value with no argument even considered.)

 - Victims are made victims even when they don't know it or agree to it.
   No choice is given them.

 - Stripping away of initiative and responsibility from authors/
   contributors.  We will now need only heed the policy as written and
   will be shielded from criticism until it is updated.

 - The rationales for some of the language choices in the policy will be
   infantile, supposing that someone somewhere will view a certain term
   as conveying meaning that authors cannot possibly have meant to
   convey.

The point of all of this (as perceived by some of us at the least) is
not even to have a functional policy.  The point is to signal to the
world that we will play by the PC rules of the day, and to identify the
rebels -- the out-crowd.

Some of the readers on this list, and some of the participants in this
massive thread are terrified of losing their jobs or being denied jobs
in the future if they do anything other than voice unconditional support
for the policy.  We know how this works.  We've been watching this
movie.  The particulars of the proposed policy are not as relevant as
that not agreeing to any of it can be expected to be ipso facto grounds
for exclusion.  Speaking of exclusion...

Nico
--

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 27 Jul 2020 18:38:11 +0100

“Followers" have a choice which does not apply here.

The second stage of a flip-flop has no choice.

The metaphor has to allow arbitrary behaviour of the first stage and zero choice to anything but obedience for the second stage.

- Stewart

> On 27 Jul 2020, at 17:31, Joseph Touch <[email-masked]> wrote:
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 27 Jul 2020 13:51:08 -0400

I don't see a need to litigate the phrase y'all absent a plausible reason
such a word would be used in an RFC or standards process document.
Colloquial language is best avoided regardless.

On the broader topic, I recall a very hotly contested issue that consumed
much time in Westminster and at cabinet level a few years back where the
absence of females serving in a particular role in a document was used to
argue that they must never be allowed to serve in that role: ordination of
women priests.

Now I recall that at the very same time the CoE was going through that
issue, the use of gender neutral language in specs was being dismissed by
some people (all men) on the basis it was 'nonsense'.

Language has consequences.

Nor are facts or history the relevant measure, the question should be
whether the terms are used to give offense. In the UK, to 'Welch' on a bet
means not paying after losing and the name goes back to a pair of bookies
called the Welch brothers who did a runner after taking a large number of
winning bets in the 1860s. But that is now a term that is avoided because
in speech it is easily mistaken for a slur on the Welsh.

There are numerous cases of this type where no ill intent might be intended
but might easily be taken. But why introduce unnecessary ambiguity? The
whole point of the IETF process is to produce clarity.

Whitelist and Blacklist are best avoided because they carry no semantic.
The association white=accept is purely cultural. Acceptlist and Blocklist
are preferable because they provide more clarity.

There is also a technical argument to be made against at least 80% of the
uses of master/slave: the terms simply do not reflect the technical
reality. The term is ambiguous in any case, the online dictionary I just
scanned has six separate meanings as a noun plus three adjectives and two
verbs. That is not a word to use in a spec.

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 28 Jul 2020 03:00:15 +0900

Unless you think discriminating people of black skin
is bad but discriminating people of dark skin is OK,
you might (though wrongly) think rfc8274 had been
problematic stating:

    The Internet of Things (IoT) malware test exchanged information that
    described a bad IP address of IoT malware and its scanned ports.
    This example information is extracted from alert messages of a
    darknet monitoring system referred to in [RFC8134].
    ^^^^

						Masataka Ohta

PS

May the light side force be with you.

---

From: Eliot Lear <[email-masked]>
Date: Mon, 27 Jul 2020 20:09:46 +0200

Hi Richard,

> I would just like to push back on the idea of there being a dichotomy here.  There is a lot of room for feedback and even dissent that is not toxic.

Yes.
 
> For me where the "toxic" line is crossed is when folks start to invalidate the experiences of others.  We've seen this in other venues, notably in the RFC series discussion.  A newcomer says "This is hard for me" or "This doesn't meet my needs" and hears back "It's not hard" or "It meets my needs just fine".. 

That’s well put, but we also tend to project what we think is hard, and end up in endless debates about that.  We need to allow for some of that but we also need to allow for pushback in those circumstances.  And even when there is a person who is offended, we have to ask whether that offense is reasonable.  We have seen that as well over the years.  This may seem invalidating but that is why we don’t make decisions based on the views of single individuals.  Having that discussion respectfully and courteously of course is always in order.

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 27 Jul 2020 18:46:52 +0000

>    The metaphor has to allow arbitrary behaviour of the first stage and zero choice to anything but obedience for the second stage.

It can be explained in the prose, the words themselves needn't convey that.  To me, and I have no knowledge if that is your intent, this is a way of setting up the discussion so that changing the terms is impossible.

---

From: Viktor Dukhovni <[email-masked]>
Date: Mon, 27 Jul 2020 15:11:09 -0400

> think we would make a lot more progress.

Empathy is an excellent guide in personal relationships, and should not
be neglected in broader social contexts, and yet there is both much
truth in:

    https://en.wikipedia.org/wiki/Hard_cases_make_bad_law

and opportunity to downplay injustice.  In the current context we're
better off dealing with each case on its merits, than litigating overly
broad prescriptions.

Authors already have plenty of incentives to avoid controversial
language, there's no need to explicitly enshrine specific taboos, such
lists are always both too broad and too narrow.  Let each document be
reviewed on the merits.  We'll pretty much get the same outcome, without
the exclusionary over-policing.

> RFC series discussion.

The expeperience of a single person is anecdote, it is not
"invalidating" to suggest that such anecdotes need to be balanced
against the potential harms of over-correcting.  It is not possible to
avoid all possible misunderstandings and someone taking offense.  We are
not denying the offense when we choose to not institute (often
ultimately futile) preemptive measures.

> A newcomer says "This is hard for me" or "This doesn't meet my needs"
> and hears back "It's not hard" or "It meets my needs just fine".

Only in a dystopia can there be uniform justice, when almost all are
equally oppressed (except for those doling out said equal justice).

We need to be careful to not strive for that outcome.  We can expect
authors to avoid inflamatory language, and to generally avoid colourful
metaphors that might be misconstrued.

To transgress for a moment, to make a more emphatic point, none of that
requires a blacklist of verbotten words or phrases, slavishly followed
by all authors, lest they be sentenced to exile for reeducation.  The
anecdotes presented to support the proposed policies don't look
sufficient to justify a remedy, the harms of policing an explicit list
of taboos look greater on balance.

> Here, some folks are saying "This sort of language makes it harder for
> me to participate" and some messages in this thread are saying back
> "This isn't a concern".

No, they're saying that the concern has not been credibly demonstrated
to be sufficient to warrant the proposed remedy, and perhaps that the
"harder" != "too hard", and that "too hard" is neither demonstrated nor
perhaps even plausible.  There is no perfect justice, only perfect
tyranny.

-- 
    Viktor.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 27 Jul 2020 20:11:32 +0100

> On 27 Jul 2020, at 19:46, Salz, Rich <[email-masked]> wrote:
> 
> 

No, I am describing the behaviour of one of the most fundamental hardware components in a computer.

3.3.2 Master–slave edge-triggered D flip-flop <https://en.wikipedia.org/wiki/Flip-flop_(electronics)#Master%E2%80%93slave_edge-triggered_D_flip-flop>

It is the primary technique for crossing synchronisation boundaries.

Interestingly when someone pointed out that slaves occasionally mutinied that aligned the metaphor with greater precision because occasionally the data changes exactly on a clock edge and the flip flop cannot decide which state to adopt in which case it sometimes oscillates for an indeterminate time with catastrophic consequences for the logic. Flip-flop metastability is mitigated by some techniques such as multiple ranking.

The historic term is master-slave, and whilst I condemn this behaviour in humans, it is an accurate metaphor for this electronic construct and the electronics is not offended by this required behaviour.

Stewart

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 27 Jul 2020 15:20:09 -0400

Ohta-san, please stop.
 From where I sit, we are only discussing I-Ds and RFCs here.  Not works  
of literature.  And we are only discussing future I-Ds and RFCs.  The  
question of whether works of literature should  
/could/would/shouldn't/couldn't be rewritten is not relevant.

Yours,
Joel

---

From: Joseph Touch <[email-masked]>
Date: Mon, 27 Jul 2020 13:24:24 -0700

Leader/follower is equally - if not more - accurate for this type of system.

Joe

> On Jul 27, 2020, at 12:11 PM, Stewart Bryant <[email-masked]> wrote:
>

---

From: "John Levine" <[email-masked]>
Date: 27 Jul 2020 16:28:48 -0400

In article <[email-masked]>,
Stewart Bryant  <[email-masked]> wrote:
>3.3.2 Master–slave edge-triggered D flip-flop
><https://en.wikipedia.org/wiki/Flip-flop_(electronics)#Master%E2%80%93slave_edge-triggered_D_flip-flop>
>

>The historic term is master-slave, and whilst I condemn this behaviour in humans, it is an accurate metaphor for
>this electronic construct and the electronics is not offended by this required behaviour.

The master stage can sell the slave stage?  Still seems like a poor metaphor to me.

I suggest we call the two stages Eccles and Jordan.

Historically,
John

---

From: Evan Hunt <[email-masked]>
Date: Mon, 27 Jul 2020 21:01:32 +0000

> destroying Thriller, the Lord of the Rings and all the fantasies

A clear and binding statement from the IESG that it does not intend to
begin editing and publishing epic fantasy novels in the future would go a
long way toward ameliorating these concerns.

-- 
Evan Hunt -- [email-masked]
Internet Systems Consortium, Inc.

---

From: Erik Nygren <[email-masked]>
Date: Mon, 27 Jul 2020 17:47:33 -0400

+1 to Phillip here

I feel there is value in publishing a best-practice guide here to avoid the
need to keep
litigating this conversation over and over.  One major value will be in
helping
give some "style-guide" recommendations to non-English speakers
as well as to help bridge between our varying cultural backgrounds.
I can see why people outside the U.S. may not have a local history
with systemic racism against people who are black and thus may
not see the importance of shifting the language here.

For example, I didn't understand the controversy about
whitehat/blackhat until I talked to some coworkers who
pointed out the concern that associating "black" with "illegal"
furthers a long history of injustice within the US justice system
and furthers racial stereotypes in an American context.
I agree with Richard's comment above that we should not
be trying to invalidate the experience of others
and should be listening to them.

It is important for us to recognize that the people who introduced
master/slave and whitelist/blacklist into our technical lexicon did
not have ill intent, and going forwards we generally should be
forgiving of accidental use.  The goal here shouldn't be to forbid
speech, but to help provide guidance towards a technical
lexicon which is more inclusive.

It will also be valuable to have some new standard recommendations.
As companies and software projects change terminology, having
consistency may help with interoperability of both technology
and human communications.

The cultural context matters, and with the IETF as a diverse
organization with people from around the world, standardized
guidance can help us be more sensitive to others.
For example, I would hope that we'd all agree that we
should be avoiding slurs against genders and ethnic groups
in IETF documents? If we were to discover that some technical
term was a ethnic slur (perhaps not even in American English),
I'd also hope that we'd have guidance to help authors avoid
using it and provide recommendations for a new term to use instead.

I agree with some others earlier in this long thread that it would
be good to have guidance/recommendations to draft authors, with RFC Editor
actually providing a final check prior to publication.

That doesn't mean we necessarily need to go back and change existing
documents, although
there may be cases where we want to do so over time (and in some
cases may be prevented from easily doing so).  As an example, rfc1760
and rfc2289 have word lists that contains quite a few words that I really
hope would not be included if such
a word list were to be compiled today.  That doesn't mean it's possible to
change
given how they are baked into the protocol, but I might hope that if we
were
creating a new version today that some more thought would be given
to avoiding words that are offensive to some users (especially given that
some other words do seem to have been excluded from those word lists)
or finding a better approach that didn't involve needing to pick a list
of only "good" words.

On Mon, Jul 27, 2020 at 1:51 PM Phillip Hallam-Baker <[email-masked]>
wrote:

> There are numerous cases of this type where no ill intent might be
> intended but might easily be taken. But why introduce unnecessary
> ambiguity? The whole point of the IETF process is to produce clarity.
>

---

From: [email-masked]
Date: Mon, 27 Jul 2020 23:07:42 +0000 (UTC)

“  I have no idea where you got this impression or why you've formed such a strong negative opinion of those terms.  You might be watching too much American television if this is what you really believe.”
Being exposed to aspects of American culture leads to holding views on aspects of American culture, which are expressed when one engages with Americans about American culture.
Who knew?

On Tuesday, July 28, 2020, 02:27, Mary B <[email-masked]> wrote:

[MB] And, your interpretation is totally, totally off base.  I use both of those words frequently and there are a lot of folks here in Texas with a real southern accent that use those words. And, I've been around long enough that I can also use a southern drawl and it's not even intentional that I will often do so after spending time in places like East Texas (most of Dallas are not native Texans).  I use "folks" all the time and I'm absolutely not using it as an intellectual elite nor using it in any way as condescending. And, yes, I use "y'all" frequently as well but not very frequently in writing.   I have no idea where you got this impression or why you've formed such a strong negative opinion of those terms.  You might be watching too much American television if this is what you really believe.   Of course, this might explain why I do find IETF to be a pretty hostile place to get work done if people are interpreting my language in that way.  [/MB]

> I think you have made it clear that you are opposed to that consensus. Calling it compelled speech is clever and I salute your linguistic ability..

---

From: Mary B <[email-masked]>
Date: Mon, 27 Jul 2020 18:40:52 -0500

As I said in another email, I use the term "folk" in an identical way in
which one might use the German word "volk".  I actually don't watch much
American television because it is pretty idiotic and I'm guessing some
folks miss the parody aspect where those terms might be being used.  That's
the only logical thing I can think of as to why one might get that
impression of those words.    Again, I'm not sure what "aspects of American
culture" would lead one to interpret the words in the way that Yoav does.
And, believe it or not, we are not a homogenous population with a single
mindset so y'all's interpretation of what we mean when we use these words
carries quite a bias without giving people the benefit of the doubt - of
course, that is the IETF way.

Mary.

On Mon, Jul 27, 2020 at 6:08 PM <[email-masked]> wrote:

> “  I have no idea where you got this impression or why you've formed such
> a strong negative opinion of those terms.  You might be watching too much
> American television if this is what you really believe.”
>
> Being exposed to aspects of American culture leads to holding views on
> aspects of American culture, which are expressed when one engages with
> Americans about American culture.
>
> Who knew?
>
>
> Lloyd Wood
> [email-masked],uk
>
> Calling it compelled speech is clever and I salute your linguistic ability..
>

---

From: Joe Touch <[email-masked]>
Date: Mon, 27 Jul 2020 19:43:07 -0700

> On Jul 27, 2020, at 10:38 AM, Stewart Bryant <[email-masked]> wrote:
> 

Slaves can revolt. 

The first stage is not unconstrained either. 

It issues a trigger with a response, that’s all.  Actor/reactor thus would cover your desired connotation. 

Joe

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Jul 2020 00:59:36 -0400

Hi.

I have been trying to follow this discussion but have had
difficulty doing so -- far too many postings, many of them
repetitive, especially when it was initiated only two or three
days before the start of IETF.  I'm in agreement with the basic
principles, including the idea that it is time for the IETF to
start thinking about its vocabulary, but concerned about the
document, the details, and how this has been and is being
handled.  A brief summary of my impressions after doing
something I would definitely not recommend --reaching through
the entire thread at one sitting -- is:

(1) For many reasons, some of them not even mentioned in the
I-D, it would be a good idea for the IETF community to pay more
attention its vocabulary -- especially vocabulary that could be
construed as oppressive or exclusionary (and I'd add
"dismissive", "insulting of groups or individuals" and maybe a
few other categories to that list), both in documents it
develops or produces and in day-to-day discussions and
presentations.

(2) Creation of a dictionary of bad words (even to the extent
that the I-D does it) is unlikely to be satisfactory, especially
if, in practice, it devolves into "anything not forbidden by the
list is allowed".  Encouraging some group of people to
participate in the IETF by playing enforcers of cultural norms
(whether as "language police" or otherwise) or in the form of a
WG is unlikely to work out well for either the IETF or the
portions of the Internet that we are supposedly trying to make
better... and the people who depend on our work.

(3) We are an international community with aspirations to be
even more so.   That may imply that a term or acronym that is
neutral or otherwise acceptable in English may be offensive,
oppressive, or exclusionary when translated or transliterated
into another language.  We should probably be aware of that too.

(4) The good news is that the IETF has very good ways of dealing
with such issues even if they are not the remedy recommended by
the I-D.  That is that we try to educate the community to these
issues (in a way, these discussion threads are a good start but
one can imagine EDU team and other IESG efforts).  Then we use,
and encourage the use of, our existing WG, IETF Last Call, and
IESG review mechanisms, mechanisms that include people who are
not first-language speakers of English and, as we work on other
problems, an increasingly diverse IETF community, to identify
problematic language and handle it the same way we handle other
problematic text in documents.

And three more observations:

(5) Some of the subthreads on the list have shown a level of
acrimony, dismissiveness of the perspectives of others, and
absence of willingness to listen, much less demonstrate any
empathy, that are, IMO, as likely, perhaps more likely than any
particular choice of language, to convince newcomers (especially
newcomers from disadvantaged groups) that the IETF is not a
place in which they want to do work.  If we really want
diversity, we may need to expand our definition of bullying to
move well beyond recent interpretations and apply it to behavior
on our mailing lists.

(6) If we need a document to describe what we are trying to do
and why we are trying to do it (I'm not convinced we do) the
current iteration of draft-knodel-terminology is almost
certainly not it.  I think the issues have been identified
adequately by others and I won't repeat them, but it needs work,
ideally work that includes generally-accessible references and
[more] people with in-depth professional expertise on the
relevant topics.

(7) Finally, I would encourage the IESG to examine what was done
here and its (IMO, predictable) outcome.  An IESG statement was
posted three days before the IETF meetings started referring to
version -03 of an I-D (posted 8 July) whose -02 version dates
from mid-June and whose -00 version was posted in October 2018.
The community was asked to look at it (essentially for the first
time, since it was not developed as an IETF document) and told
it would be on the agenda for the GENDISPATCH meeting Thursday,
a week after the announcement was posted.  It generated close to
200 messages on the IETF list, a flow that was more than
adequate to suppress any more technical discussions that might
have been come up on that list in the days before IETF and
possibly to distract people from doing pre-meeting technical
work, getting meeting materials posted in a timely fashion, etc.
If this subject matter is important --and I think it is-- then
it was important a month or six weeks ago, an only slightly
different version of the draft was around, and a more leisurely
discussion could have been held without the risk of impairing
the message or the use of a last-minute announcement.  I also
note that the IESG has pushed less complex discussions off onto
dedicated mailing lists rather than encouraging even smaller
volumes of discussion on the IETF list.  I'm sure the IESG had
its collective reasons for this particular case but I hope it
does not become bad precedent for how we do things in the future
and, for the future, I hope we can avoid similar sequences and
timing.

best,
    john

--On Thursday, July 23, 2020 09:35 -0700 The IESG
<[email-masked]> wrote:

> The IESG believes the use of oppressive or exclusionary
> language is  harmful.  Such terminology is present in some
> IETF documents, including  standards-track RFCs, and has been
> for many years. It is at odds with  our objective of creating
> an inclusive and respectful environment in the  IETF, and
> among readers of our documents.
> 
> The IESG realizes that the views of the community about this
> topic are  not uniform. Determining an actionable policy
> regarding problematic  language is an ongoing process. We
> wanted to highlight that initial  discussions about this topic
>...

---

From: Yoav Nir <[email-masked]>
Date: Tue, 28 Jul 2020 08:47:20 +0300

It’s not unique to American culture, but I should have clarified that I’m talking about using imitation of accents and improper contractions *in writing*

Even Shakespeare and Dickens have the educated characters speaking proper English, while the uneducated ones will have contractions. This is still used in writing today. The uneducated people will use y’all, readin’ and ain’t.  So when someone uses such words in written communications, they’re either having characters who talk in a, well, folksy way, or they’re trying to themselves appear folksy.  

> On 28 Jul 2020, at 2:07, lloyd.wood=[email-masked] wrote:
> 
> On Mon, Jul 27, 2020 at 11:14 AM Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On 27 Jul 2020, at 15:50, Salz, Rich <rsalz=[email-masked] <mailto:[email-masked]>> wrote:
> > 
> > I think you have made it clear that you are opposed to that consensus. Calling it compelled speech is clever and I salute your linguistic ability...
>

---

From: Masataka Ohta <[email-masked]>
Date: Tue, 28 Jul 2020 16:54:58 +0900

Joel M. Halpern wrote:

> of literature.

As I wrote:

: If you think "black" and "white" are improperly used in the
: Lord of the Rings, feel free to modify it or ban it from US
: market along with all the current and *future* fantasies
: and FRPGs doing so.
:
: Only after that, we can start working on less important
: fields of technical terms such as "blacklist".

if literature, in general, is free to use black/dark with
negative meaning, there is no reason to ban use of
black/dark only for technical terms.

That is, you should stop and wait.

Same for "slave".

I expect even US people (not all of them, I hope) will soon
recognize they are pursuing something impossible and
meaningless.

						Masataka Ohta

---

From: [email-masked]
Date: Tue, 28 Jul 2020 10:25:39 +0000 (UTC)

More to the point, educated people will use the slang and contractions when they are attempting to convince and win over people they believe to be uneducated or inferior.
When you hear “folks” you’re about to be patronised by an American.
The word has no place in technical documentation.

Lloyd [email-masked]

On Tuesday, July 28, 2020, 15:48, Yoav Nir <[email-masked]> wrote:

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Jul 2020 12:11:52 +0000

*   More to the point, educated people will use the slang and contractions when they are attempting to convince and win over people they believe to be uneducated or inferior.

Not all.  Sometimes we are trying to establish a rapport by using informal language.  Trying to add a little informality to a fairly rigid communications system.  Not unlike an IETF bar conversation.  HOWEVER, I’ve since learned that the term is offensive to some and I am going to try to find other words.

Perhaps we can assume good intentions all around?

  *   The word has no place in technical documentation.

Agreed.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Jul 2020 12:18:53 +0000

They're not the same.  Literature is often TRYING to evoke emotional responses and technical documents try to NOT do that. I mean, you don't want all RFC's to be written in Haiku format and its nature allusions.  (Although that is tempting at times.)

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Jul 2020 10:54:50 -0500

> better... and the people who depend on our work.

Yes.  The way to enforce reasonable language is to review for it as
empathetic adults rather than with a list of verboten words, and to
raise and discuss any issues with document authors.  This would be (is)
much broader and effective than a list of verboten words.  And the group
involved in enforcing this rule is the entire community (rather than a
special group of "enforcers"), starting with editors/co-authors, WG/RG
participants, shepherds, responsible ADs, the IETF/IRTF (e.g., during
IETF LC), the I* leadership, the RPC, and the RFC-Editor.

BTW, regarding {color}lists, we generally refer to "local policy" in
RFCs, not to specific implementation designs for local policy.  I've
checked my cache of RFCs I frequently check and there are many many more
hits for 'local policy' than '(white|black)(-| |)?list', and many more
hits for 'master' than 'slave' (only NTP and DNS in my cache refer to
'slave').  There are also more instances of 'primary' than 'master', and
'replica' than 'slave'.  I can happily say that none of my RFCs (unless
I've somehow failed to cache some of them) use offensive language.  My
cache is fairly small though.  A more complete analysis of Internet
RFCs' use of problematic language would be useful.

Speaking of which, I don't see in draft-knodel-terminology anything like
a survey or performed a survey of RFCs, current I-Ds, and maybe even
expired I-Ds, of how many instances of offensive language appears in
them, and even the frequency of offensive language as a function of
publication/submission year.

It would seem that evidence in this matter is important.  Evidence of
our having a problem would help drive faster adoption of better
solutions.  Conversely, lack of evidence, or even evidence that we don't
have a problem, would help us quickly dispose of solutions to non-
problems.

> into another language.  We should probably be aware of that too.

There are limits to how sensitive we can be to issues we're not aware
of.  I.e., we depend on reviewers to tell us about the issues they are
aware of.  Which brings us back to your point about banned word lists
not possibly being sufficient.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Jul 2020 11:00:35 -0500

> [1] https://datatracker.ietf.org/doc/draft-knodel-terminology/

I'm surprised not to find there anything like a survey of RFCs, current
I-Ds, and maybe even expired I-Ds, of problematic language.  Or any
analysis of the prevalence of problematic language and trends in its
use.  Did we use to have a problem that we now no longer have?  Do we
still have a problem?  Is it getting better or worse?

Can we ask the author, and/or maybe the RPC, to perform such a survey?

(The RPC presumably would only survey RFCs, not I-Ds.)

It would be quite useful to have such a survey.

Nico
--

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Tue, 28 Jul 2020 13:31:33 -0300

Not every society needs to confront the same issues or troubling 
legacies.

I live in a country where painting your face black is perfectly 
acceptable. It’s done by thousands of people every February and blacks 
and “lubolos” (whites in black face) perform all together in 
ensembles called “Comparsas”. It’s been going on since the 1870s.

See 
[https://carnavaldelfuturo.uy/2006/12/15/la-historia-de-los-negros-y-lubolos/] 
in Spanish, Google translate can be your friend.

We do have a troubling past when it comes to our land’s native 
inhabitants.

If we are to re-engineer all language, then it would only make sense to 
aim for the “lowest common denominator”, that language that offends 
no one and triggers no one. I believe this subset of language to be the 
empty set or very close to it, but that’s just IMO.

/Carlos

---

From: Joseph Touch <[email-masked]>
Date: Tue, 28 Jul 2020 09:35:13 -0700

> On Jul 28, 2020, at 9:00 AM, Nico Williams <[email-masked]> wrote:
> 

I checked and the list I have online shows both items found in RFCs and those not found in RFCs but potentially useful (including providing the regexp I used to find the term).

I didn’t do a count for each example; it’s easy to find a single example but hard to verify a count against possible false positives.

Joe

---

From: tom petch <[email-masked]>
Date: Tue, 28 Jul 2020 17:45:03 +0100

Nico

Uplist you will find an e-mail from me about blacklist which showed that 
in my own local (statistically unsound) filestore of RFC and I-D the use 
has much declined compared to 10 years ago.  I think that that is one 
term that we have informally recognised as unsuitable and acted upon 
without any need for an IESG statement.  (I was responding erroneously 
to a post that was about black magic that I thought was about blacklist 
from Rich Salz).

At a tangent, I keep looking to see if my posts have got through the 
rules imposed by my ESP; if I ever refer to the LSR routing protocol 
that is not OSPF by its usual abbreviation, then my post is .. well, 
disappears without trace.  You can guess what word I was about to use:-)

Tom Petch

---

From: Fernando Gont <[email-masked]>
Date: Tue, 28 Jul 2020 13:49:01 -0300

On 28/7/20 13:00, Nico Williams wrote:
> I-Ds, and maybe even expired I-Ds, of problematic language.  

Well, for the time being, my understanding is that the list itself of 
what's considered "offensive language" is being produced.

> Or any
> use.

There's empirical evidence that such language has been used.

>  Did we use to have a problem that we now no longer have?

If the use of such language is considered a problem, then yes, that 
still happens. And since people come and go, whatever has happened in 
the past may be different from what happens in the future. So I'm not 
sure to what extent that would be relevant.

>  Do we still have a problem? 

Part of the problem, I guess, is the definition of "we". e.g., since the 
vast majority of IETF participants are white, probably the answer to "do 
we have a problem?" will, from that perspective, be "no".

Similarly, most folks will have no problems with the use of 
"balkanization", since the vast majority of participants are not from 
the balkans.

And most folks will be happy to use "third-world countries" or the like, 
since most participants are from what are typically considered 
"developed countries".

> Is it getting better or worse?
> 

IMO, that would be like overengineering the isue, but....

> (The RPC presumably would only survey RFCs, not I-Ds.)

Actually, if such survey were to be done, it should probably done on 
RFC, I-Ds, and mailing lists. Because, if such language is offensive, it 
doesn't matter the specific status of the document that uses it, or 
whether it's a mailing-list post as opposed to an actual document.

Just my two cents,

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 01:55:45 +0900

Just FYI.

https://www.merriam-webster.com/dictionary/servomotor

History and Etymology for servomotor

French servo-moteur, from Latin servus slave, servant + French
-o- + moteur motor, from Latin motor one that moves

						Masataka Ohta

---

From: Fernando Gont <[email-masked]>
Date: Tue, 28 Jul 2020 13:55:50 -0300

On 28/7/20 12:54, Nico Williams wrote:
[....]
> not possibly being sufficient.

Part of the issue is, I guess, that much needs to be second-guessed, 
because virtually all the communities that would find the aforementioned 
language to be offensive are under-represented here (if at all represented).

Maybe if one were to try to address the underlying problem 
(inclusiveness), any issues related to language would be solved as a 
side-effect?

Thanks,

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Jul 2020 12:30:46 -0500

On Tue, Jul 28, 2020 at 01:55:50PM -0300, Fernando Gont wrote:
> Part of the issue is, I guess, that much needs to be second-guessed, because
> virtually all the communities that would find the aforementioned language to
> be offensive are under-represented here (if at all represented).

Because we are such an international community, but also a very very
small and unrepresentative subset of the world's population, we're bound
to have under-represented communities.  There are a few things that are
particularly important when dealing with such a situation:

 - empathy
 - openness
 - intent

Intent, of course, is typically not-of-interest to many in these debates
for some reason.  But it is important.  If one unintentionally gives
offense and their lack of intent is insufficient to obtain forgiveness,
then we might as well stop having a functioning society.  I.e., we can
learn.

> Maybe if one were to try to address the underlying problem (inclusiveness),
> any issues related to language would be solved as a side-effect?

We're a very specialized, *self-selected* group.  No one ever said to me
"hey, you'd bring diversity to the IETF, so your next assignment is to
participate there".  Nor is that a recipe for the further success of the
IETF.  Many of us are not sponsored in any way by employers.  When I was
at Sun my IETF participation was never a principal aspect of my job, and
I participated entirely of my own initiative.  Ditto my employer
previous to Sun.  Ditto all my employment since.  I believe this is true
for most IETF participants.

Self-selection simply *cannot* produce uniform diversity.  For that
matter, how could a group of 1,000 to 2,000 people, no matter how they
be selected, possibly be reasonably representative of the world's
population??  If you want proportional representation of the world in
the IETF's participant population, you'd have to make the IETF an
expensive membership organization with participant ethnic/racial/
gender/etc. quotas to be met by member organization employers who have
the kind of resources to make that happen (as if rich high-tech
employers' employees are themselves representative of the world!).
That's not in the cards, so we'll have to make do with the diversity
that we have.

Perhaps you mean that we have barriers to entrance that produce an
exclusive club.  However, of all the SDOs, the IETF is by far the most
accessible by any and all measures: ease of access (mailing lists,
meetecho, etc.), cost ($0 for mailing list participation, which is the
only participation that is required to get RFCs published, i.e., work
done), discrimination (our rules for selecting a NomCom and I*
leadership are explicitly non-discriminatory using any plausible
protected classes).  All other SDOs are far far more costly and less
accessible at the very least: ISO and member nation SDOs, the ITU-T, the
UC, IEEE, OASIS, etc -- all expensive membership organizations and
inaccessible to non-members.

We've yet to hear a plausible proposal for increasing diversity at the
IETF.  In the meantime we have to operate with who we are.  Decrying our
lack of diversity will not help us.  Instead, we need (and have!)
mechanisms for identifying use of offensive language and correcting it
prior to publication -- mechanisms that work as well as can be expected
given an educated, empathetic, open-minded, self-selected, -yes, fairly
diverse considering- membership.  We have such a mechanism, and it is
the entirety of our publication proces, with its many opportunities for
review.

Nico
--

---

From: Barry Leiba <[email-masked]>
Date: Tue, 28 Jul 2020 13:48:12 -0400

Masataka-san, I understand what you're saying, but I'm trying to
understand the details of your objection and what you would like done
about it.  Please help me.

I understand and agree that whether certain words and phrases are or
aren't offensive is very much a cultural issue.  It's clear that any
plea that we stop using certain terms will necessarily be culturally
dependent, and, thus <somewhere>-centric.  When people from the U.S.
make such requests, they are bound to be U.S.-centric, and others in
this conversation have given examples of things that might be
bothersome to people from their cultures.

What I don't understand, and need to ask, are these:

- Do you think that, in general, it might be reasonable to avoid using
certain words and phrases because a significantly large group of
people find them offensive or exclusionary?  Or do you think that it
is not reasonable to ask people to do that?

- How does your answer to the above question lead you into a
recommendation about what to do with this situation in general?

- What would you want the IETF community to do with respect to the
Internet draft in question: To expand it to include other terms,
making it less U.S.-centric?  To change the explanation to make that
less U.S.-centric?  To abandon the draft because any version of it
would be too focused on one culture, and it can't be made inclusive
enough?  Something else?

Thanks,
Barry

---

From: John E Drake <[email-masked]>
Date: Tue, 28 Jul 2020 18:00:09 +0000

Hi,

This is the most sensible email on this thread.

Yours Irrespectively,

John

Juniper Business Use Only

> From: ietf <[email-masked]> On Behalf Of Nico Williams
> Sent: Tuesday, July 28, 2020 11:55 AM
> To: John C Klensin <[email-masked]>
> Cc: [email-masked]
> Subject: Re: IESG Statement On Oppressive or Exclusionary Language
> 
> [External Email. Be cautious of content]
> 
> 
> > (2) Creation of a dictionary of bad words (even to the extent that the
> > I-D does it) is unlikely to be satisfactory, especially if, in
> > practice, it devolves into "anything not forbidden by the list is
> > allowed".  Encouraging some group of people to participate in the IETF
> > by playing enforcers of cultural norms (whether as "language police"
> > or otherwise) or in the form of a WG is unlikely to work out well for
> > either the IETF or the portions of the Internet that we are supposedly
> > trying to make better... and the people who depend on our work.
> 
> Yes.  The way to enforce reasonable language is to review for it as empathetic
> adults rather than with a list of verboten words, and to raise and discuss any
> issues with document authors.  This would be (is) much broader and effective
> than a list of verboten words.  And the group involved in enforcing this rule is the
> entire community (rather than a special group of "enforcers"), starting with
> editors/co-authors, WG/RG participants, shepherds, responsible ADs, the
> IETF/IRTF (e.g., during IETF LC), the I* leadership, the RPC, and the RFC-Editor.
> 
> BTW, regarding {color}lists, we generally refer to "local policy" in RFCs, not to
> specific implementation designs for local policy.  I've checked my cache of RFCs
> I frequently check and there are many many more hits for 'local policy' than
> '(white|black)(-| |)?list', and many more hits for 'master' than 'slave' (only NTP
> and DNS in my cache refer to 'slave').  There are also more instances of 'primary'
> than 'master', and 'replica' than 'slave'.  I can happily say that none of my RFCs
> (unless I've somehow failed to cache some of them) use offensive language.  My
> cache is fairly small though.  A more complete analysis of Internet RFCs' use of
> problematic language would be useful.
> 
> Speaking of which, I don't see in draft-knodel-terminology anything like a survey
> or performed a survey of RFCs, current I-Ds, and maybe even expired I-Ds, of
> how many instances of offensive language appears in them, and even the
> frequency of offensive language as a function of publication/submission year.
> 
> It would seem that evidence in this matter is important.  Evidence of our having
> a problem would help drive faster adoption of better solutions.  Conversely, lack
> of evidence, or even evidence that we don't have a problem, would help us
> quickly dispose of solutions to non- problems.
> 
> > oppressive, or exclusionary when translated or transliterated into
> > another language.  We should probably be aware of that too.
> 
> There are limits to how sensitive we can be to issues we're not aware of.  I.e.,
> we depend on reviewers to tell us about the issues they are aware of.  Which
> brings us back to your point about banned word lists not possibly being
> sufficient.
> 
> Nico
> --

---

From: Fernando Gont <[email-masked]>
Date: Tue, 28 Jul 2020 14:54:04 -0300

Hi, Ted,

On 23/7/20 15:20, Ted Hardie wrote:
>>     <[email-masked] <mailto:mstjohns@comcast..net>> wrote:
>>
[....]
>     Hi -
> 
>     I'm actually surprised that you think its a good idea to do this on
>     a stream basis rather than on a community basis.   Regardless, the
>     draft cited is pretty clear that it wants to add constraints to the
>     RFC process:
> 
> that it will be rare that the RFC editor will need to offer 

If this is to be applied, why not apply it to all IETF contributions, 
rather than to some particular form of it?

Thanks,

---

From: Fernando Gont <[email-masked]>
Date: Tue, 28 Jul 2020 15:09:36 -0300

On 28/7/20 14:30, Nico Williams wrote:
> to have under-represented communities.

That sounds a bit like naturalizing non-inclusiveness -- in many 
different aspects.

I disagree that we're necessarily bond to that.

[....]
> for most IETF participants.

Are you suggesting that participants from, say, the top-10 or top-20 
affiliations are self-funded?

  [....]
> exclusive club. 

That's, sort of, what I meant. BUt not just "entrance".

> However, of all the SDOs, the IETF is by far the most
> accessible by any and all measures:

Fully agree on this one.

> ease of access (mailing lists,
> done),

This one is very debatable. Yes, "on paper", you only need maling-list 
participation.

> discrimination (our rules for selecting a NomCom and I*
> protected classes).

Well, the rules are that you need to have attended X recent meetings, 
which in turn requires funding of some sort.

> All other SDOs are far far more costly and less

Fully agree on this one.

> prior to publication 

As noted, I do support this effort. That said, the sad state of affairs 
is that, from a practical point of view, in most cases the potentially 
offensive words will not get to the folks that would most likely be 
offended by their usage.

That's the underlying issue that I think is being overlooked, or not 
considered to be an issue.

Thanks,

---

From: S Moonesamy <[email-masked]>
Date: Tue, 28 Jul 2020 10:19:59 -0700

Hello,

>>More to the point, educated people will use the slang and 
>>contractions when they are attempting to convince and win over 
>>people they believe to be uneducated or inferior.

At 05:11 AM 28-07-2020, Salz, Rich wrote:
>Not all.  Sometimes we are trying to establish a rapport by using 
>informal language.  Trying to add a little informality to a fairly 
>rigid communications system.  Not unlike an IETF bar 
>conversation.  HOWEVER, I've since learned that the term is 
>offensive to some and I am going to try to find other words.

It is difficult to determine which of the two opinions about slang 
and contractions is true.

>Perhaps we can assume good intentions all around?

The usual response, in the IETF, is that a complainant could assume 
that the action (or content of a message) was in good faith.  I asked 
someone else to review a few messages (unrelated to this 
thread).  The messages were described as condescending.

Regards,
S. Moonesamy

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Jul 2020 18:56:31 +0000

Let's compare the two.

    >>people they believe to be uneducated or inferior.

This says everyone.

    >Not all.  Sometimes we are trying to establish a rapport by using 

This  says some do not.

One person, with no knowledge of the context or authors?

Do you think I am condescending?

---

From: S Moonesamy <[email-masked]>
Date: Tue, 28 Jul 2020 12:22:53 -0700

Hi Rich,
>Let's compare the two.

On reading the two opinion I could not reach any conclusion.

>One person, with no knowledge of the context or authors?

The person does not know the authors.  The persons and the authors 
(of the messages) are from the same country.  I provided information 
about the context.

>Do you think I am condescending?

I don't think so.

Regards,
S. Moonesamy

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 28 Jul 2020 19:47:42 +0000

>   On reading the two opinion I could not reach any conclusion.

One says "they all do this"  One says "some do that."  So almost by definition, the one that says "some" has to be more correct. And in my view is more empathetic and assuming good intent.  Of course I am biased, because I wrote that one.

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Jul 2020 16:25:09 -0500

On Tue, Jul 28, 2020 at 10:19:59AM -0700, S Moonesamy wrote:
> > informal language.  Trying to add a little informality to a fairly rigid
> > communications system.  Not unlike an IETF bar conversation.  HOWEVER,
> > I've since learned that the term is offensive to some and I am going to
> > try to find other words.

In regards to "folks"?!

I'm from Argentina.  I spent 15 years in the NYC area.  I've since been
living in Texas.  I use Texas-isms all the time to demonstrate comfort.

Yes, I suppose I could use "y'all" and "folks" to talk-down-to, or sign
"Cheers," (an Ozzie-ism?) as in "bleep off", and perhaps I have, but I
also sign "Cheers," frequently out of habit, as a positive note.  Because:

> It is difficult to determine which of the two opinions about slang and
> contractions is true.

Well, context simply matters.  Much language is dual-use!  :)

Intent also matters.  Lack of intent to offend does not mean offense
won't be received, and it does not mean that the first person shouldn't
consider adapting their speech to avoid giving further offense when they
learn of it, nor does it mean that the second person shouldn't learn to
identify contexts that make the apparently-offensive speech not-quite-
so.  Lack of intent certainly means we should be open to forgiveness.

Empathy requires we make an effort to assume good faith, and that we be
open to learning and forgiving.

> The usual response, in the IETF, is that a complainant could assume that the
> action (or content of a message) was in good faith.  I asked someone else to
> review a few messages (unrelated to this thread).  The messages were
> described as condescending.

+1e6.

Plus, I know condescencion when I see it; I've seen plenty.  And, I
always know it when I sometimes even express it myself.  (Imagine that,
me being human.)

Nico
--

---

From: Fernando Gont <[email-masked]>
Date: Tue, 28 Jul 2020 18:57:08 -0300

>>> I've since learned that the term is offensive to some and I am going to

As an "English as a second" language speaker, I'm beginning to become 
concerned.

As far as I support of getting rid of words that may be seen as 
conveying an underlying message (e.g. blacklist vs whitelist), I'm 
beginning to think that words that I believed to be 100% friendly, can 
be seen as otherwise.

Re the word "folks", many of us non-native English speakers have had our 
first encounter with that word via "Looney Toons" cartoons (something 
ala "guys", "friends" or the like). And if "folks" is seen as offensive, 
I don't even want to think about "looney" (?)

[...]
> so.  Lack of intent certainly means we should be open to forgiveness.

I guess much of this issue would be solved by applying Postel's Principle?

Thanks,

---

From: John C Klensin <[email-masked]>
Date: Tue, 28 Jul 2020 20:12:13 -0400

Executive/ TL;DR Summary: Rather than looking for new mechanisms
or trying to see if we can build tools that are smarter than we
are, we will do far better for both the IETF community and the
Internet by expanding our existing document development and
review processes to include being as sensitive to inappropriate
vocabulary or presentation as we are to technical flaws.  The
issues are important and will often be difficult but, if we
cannot educate ourselves and each other to be able to deal with
them, any other attempted solutions are likely to cause worse
problems.

--On Tuesday, July 28, 2020 10:54 -0500 Nico Williams
<[email-masked]> wrote:

>...
> It would seem that evidence in this matter is important.
> Evidence of our having a problem would help drive faster
> adoption of better solutions.  Conversely, lack of evidence,
> or even evidence that we don't have a problem, would help us

And...

--On Tuesday, July 28, 2020 11:00 -0500 Nico Williams
<[email-masked]> wrote:

> I'm surprised not to find there anything like a survey of
> RFCs, current I-Ds, and maybe even expired I-Ds, of
> problematic language.  Or any analysis of the prevalence of
> problematic language and trends in its use.  Did we use to
> have a problem that we now no longer have?  Do we still have a
> problem?  Is it getting better or worse?
>...

I'm actually not sure about either of those assertions.  We know
that language -- and, more specifically, terminology-- has been
used in IETF documents and other Internet technical
specifications in the past that reasonable people can interpret
as having connotations that are problematic (including, but not
limited to, "Oppressive or Exclusionary").  Like Rich, I would
like to assume (and am convinced) that the vast majority of such
language was chosen out of ignorance or lack of sensitivity to
the possible issues and not out of some malicious intent or
explicit sense of superiority by the author toward other
populations.  

Should we do better at identifying such language in new
documents, bringing it to the attention of authors and, if
needed, the broader community?  I think so and I think that
would be true if we are talking about one incident a year or a
hundred incidents every week.   This is not one of those
subjects on which saying "well it doesn't happen often enough to
be a concern, so we should just move on" is reasonable, nor is
it one for which a larger volume of problematic language would
justify a radically different response.  And so I don't see what
more statistics would tell us that would be useful... other
than, maybe, promoting a large sense of outrage, something that,
IMO, is not useful if we are willing to engage with the problem
and that should not be needed for us to be willing to engage.

So, to repeat:  We should get better at encouraging people to
speak up when they spot problems of vocabulary or usage or even
tone that makes them uncomfortable (or other terms along that
scale).   Some explicit encouragement from the IESG and IAB
might be helpful in that regard; it almost certainly could not
hurt.   We should try to be sure that the community is as
supportive as possible when someone does raise such concerns,
possibly building on the ombudsteam mechanisms for dealing with
other types of inappropriate reactions in the community.  We
should try, as we should try with technical issues, quiet,
supportive, and educational private conversations with authors
and speakers rather than anything that amounts to public
shaming.  If that fails or is inappropriate, we should expect
WGs to detect and adjust the language of their drafts and, if
something slips through, to catch things on IETF Last Call.  If
documents with problematic language get through to the IESG, I
hope the IESG will catch those problems and push back but that
they will also examine why problems got through to them --how
things failed at earlier stages of the review process-- with an
eye toward looking at ways to preventing recurrences [1].

And I think we should be very careful to not create official
"bad vocabulary" lists or formal mechanisms to enforce them.  We
should also be careful that people don't set themselves up as
arbiters of what some other group would find offensive -- that
is ultimately either as demeaning of that other group and its
inability to speak up for itself or an indication that the IETF
has become toxic for that group in a way that discourages them
from speaking up.  The latter is not a problem about vocabulary
and, should it occur, our dealing with it effectively is
probably far more important than vocabulary issues.  That won't
solve the problem of vocabulary that might be offensive to
people from populations who have no presence in the IETF but, as
others have pointed out, the solutions to that lie in more
outreach and diversity rather than trying to narrow our language
to eliminate anything we think might be a problem for someone
else.

The other advantage of that approach -- simply expanding our
existing mechanisms for developing and reviewing documents
rather than inventing a new system or mechanism-- is that it is
also well-adapted to reasoned discussions about what to do about
language in older documents that we might object to today,
decisions that will certainly have to be made on a case by case
basis considering the disadvantages of trying to change
established usage. 

Of course, if we can't have reasoned and reasonable discussions
on these topics (again like technical ones) we either need to
educate people and fix that problem or we should consider
whether the IETF has outlived its usefulness.

Finally, I think we should thank the authors of the I-D and the
IESG for bringing the issue to our attention and stimulating
this discussion (regardless of what I think of the timing).  It
is just the solution to which the I-D seems to point that seems
entirely inappropriate for the IETF (and for any other body that
wants to be broadly and internationally sensitive to the broader
issues, not just a particular list of bad words.  If I am
misinterpreting the intent of either the authors (who have been
surprisingly quiet in this discussion) or the IESG, I apologize
and welcome corrections.

And now, having said that twice in different ways recently, I'm
going to retreat into trying to get other work, some of it
technical, done.

best regards and wishes to all,
   john

[1] Something we often (probably not often enough) tried to do
when I was on the IESG a quarter-century ago wrt technical
issues and that I think the IETF would be a better place if the
IESG were doing a lot more of now with technical issues as well
as choices of vocabulary or the like.  If we could view every
single issue that gets through IETF Last Call but is then
grounds for a DISCUSS in the IESG as a sign of a process failure
that the involved ADs are required to investigate and suggest
ways to prevent the next time, we'd see a more
smoothly-functioning IETF, fewer documents tied up for extended
periods after IETF Last Call, and probably even less generalized
rancor.

(Now we get to see who has read this far :-( )

---

From: S Moonesamy <[email-masked]>
Date: Tue, 28 Jul 2020 17:38:24 -0700

Hi Nico, Fernando,
>In regards to "folks"?!

Yes.  Please see 
https://mailarchive.ietf.org/arch/msg/ietf/kSG5GfCE5ozrD-mRiJ4lGu-E9zY/

>also sign "Cheers," frequently out of habit, as a positive note.  Because:

The words which you mentioned above would likely be used by people 
who have some affinity with a geographical area.

There are a few English sentences (unrelated to what you wrote) which 
I regarded as friendly.  I have a different opinion nowadays.

Yes.

>so.  Lack of intent certainly means we should be open to forgiveness.

Should previous complaints be taken into account?  Should the 
differences in culture be taken into account?

>open to learning and forgiving.

There is a message at 
https://mailarchive.ietf.org/arch/msg/eligibility-discuss/PJJ3GuNKOlcNrmu1ETZeTINFHwY/ 
If that is the principle which reflects reality, I doubt that anyone 
who falls outside it would be open to forgiveness.

>I guess much of this issue would be solved by applying Postel's Principle?

I don't think so as the principle was established for a different context.

Regards,
S. Moonesamy

---

From: Nico Williams <[email-masked]>
Date: Tue, 28 Jul 2020 22:26:28 -0500

> https://mailarchive.ietf.org/arch/msg/ietf/kSG5GfCE5ozrD-mRiJ4lGu-E9zY/

This is fun.  We can now agree that we can find no common language.
"Folks" is one of very few words we have that are gender-neutral for
plural second person.

> The words which you mentioned above would likely be used by people who have
> some affinity with a geographical area.

Perhaps more than very local.

> Should previous complaints be taken into account?  Should the differences in
> culture be taken into account?

Perhaps.  Without a counter-point to the complaint about "folks" one
might simply acquiesce to its non-use.  With counter-points perhaps the
right answer is to consider the context more fully.  That would be a
good outcome.

> There is a message at https://mailarchive.ietf.org/arch/msg/eligibility-discuss/PJJ3GuNKOlcNrmu1ETZeTINFHwY/
> If that is the principle which reflects reality, I doubt that anyone who
> falls outside it would be open to forgiveness.

[I'm not seeing enough context there to understand what you're referring
to, and I'm not going to read that thread just to see it.  Can you
summarize what's going on here.  I do understand about recall petitions,
but that entire subject is rather inside baseball compared to this
thread.  In particular I'm not seeing what forgiveness has to do with
Pete's post that you linked to.]

Note I'm not saying that we must assume good faith always.  At some
point one's patience with people who argue in bad faith runs out.

> I don't think so as the principle was established for a different context.

"Be conservative in what you do, be liberal in what you accept from
others" was meant for a different context, but it does capture the
concept of being forgiving.  In protocol implementations Postel's
principle nowadays is not viewed very kindly, is it, but in
interpersonal relationships, there might be something to it.  In this
context the idea is to be careful with the language you use, but not to
be quick to condemn others.  I like it.

Nico
--

---

From: Joseph Touch <[email-masked]>
Date: Tue, 28 Jul 2020 21:14:23 -0700

> On Jul 28, 2020, at 8:26 PM, Nico Williams <[email-masked]> wrote:
> 
> ...

“You” is second person plural, gender neutral. It’s also a pronoun.

“Folks” is a noun, not a pronoun. Nouns have no “person” in English.  It can be replaced with “people”, “parents”, or “family", depending on context - all of.which are also gender neutral nouns,

Joe

---

From: Keith Moore <[email-masked]>
Date: Wed, 29 Jul 2020 00:16:33 -0400

On 7/27/20 5:54 AM, tom petch wrote:

> point of this thread).  To me it is fundamental that I cannot 'make' 
> you or anyone else feel an emotion by what I say or do.  What I say 
> may engender sorrow in one, anger in another, fear in another and so 
> no (although it would not have been my intention for any of this to 
> made by the individual, perhaps affected by their personality, state 
> of mind, history and so on; they have a choice to feel differently 
> even if the conscious mind struggles to escape its immediate reaction.

I believe this is technically correct.   I also think that 
readers/listeners have a responsibility to try to avoid interpreting 
others' speech in an offensive, oppressive, etc., way unless there's a 
compelling reason to do so.

However I also observe that people can have a very hard time doing this, 
unless perhaps they've been trained in the practice of being 
non-reactive.   And a lot of cultures (including mine) reinforce the 
practice of being reactive.   For instance, not reacting to a perceived 
offense can result in loss of status.

So I basically think we should not expect people to be perfect. We 
should try to avoid causing offense when we can, without assuming that 
we can always be successful.   Successful communication often requires 
both the speaker and the listener to help build the bridge.

Keith

---

From: Viktor Dukhovni <[email-masked]>
Date: Wed, 29 Jul 2020 01:25:46 -0400

On Mon, Jul 27, 2020 at 09:28:41AM -0700, Joseph Touch wrote:

> > The potential for a small but motivated group to hijack the process
> > and dictate policy is great, and the argument that the process was
> > open to everyone is not convincing. We all have limited time, and
> > arguing language policy at the IETF is not a good use of time for
> > most of us.  
> 

But Yoav explained in detail why this case is different, by nature of
its scope and difficulty of achieving rough consensus from the community
large, and not just a few brave and/or foolhardy enough to take the bait
and spend time discussing a not terribly fun topic.

> We’re not trying to ban words; we’re trying to help those who might
> not realize otherwise when certain words have current connotations
> they might not have intended.

You say we, but I don't consider myself sufficiently elevated above the
hoi polloi to be quite so paternalistic.  The authors know what they
intended, and their peers in the WG, IETF LC, IEST and finally the RSE
will read the documents and will suggest clearer/better language where
that intent is liable to be misunderstood by others.

The documents will *organically* on average end up roughly reflecting
the values (biases) of the community of IETF participants.  Thus, for
example, we've collectively valued privacy over various operational
advantages of third-party access to cleartext, a bias that is not
necessarily representative of the world at large.  We're probably even
somewhat unwelcoming to those who don't share those values.  That's the
nature of rough consensus, the process achieving it can also sometimes
be noticeably rough.

Being an outlier in an IETF WG, when your particular use cases are not
the mainstream ones of the WG as a whole, can make for an especially
rough ride.  Your problems will be judged unimportant, and solutions
will be judged as unnecessary added complexity.  Of all the ways in
which the IETF is exclusionary, this is by far the most oppressive.

The language used in IETF documents will reflect the norms of the time
in which they were written, and so it should be.  No prior restraint is
needed or desirable.  Whatever words are justly or fashionably taboo at
a point in time will encounter enough friction that there's no point in
trying to compile lists, have the lists reviewed, ...

If, in a particular technical area, some potential taboo words have no
adequate replacement, or replacing them would require rewriting too many
textbooks, published papers, prior standards, ... it should be possible
for the WG and broader IETF community to accept them in light of the
historical and technical context in which they are used to convey their
narrow technical meaning.

No policing is needed to discourage the use of terms that become
culturally loaded.  The battle to keep using them is lost before the
first shots are fired.  What remains worth fighting for is not the lost
neutrality of now controversial words, but rather the right to be
treated as an adult human being, capable of expressing ideas in
context, and not be prejudged or attacked for using the clearest
reasonably concise language at one's disposal.

Noone should be afraid to use existing terms of art that were clear
enough last year, but if in the document review process alternative
terms find more support, they should be used instead.  Corrections for
clarity and style are a normal part of the document review process.

-- 
    Viktor.

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 17:50:22 +0900

Barry Leiba wrote:

> aren't offensive is very much a cultural issue.

Of course.

> When people from the U.S.
> make such requests, they are bound to be U.S.-centric,

No, even based on US culture, they should not make US centric
requests so strongly as if it were international common sense.

But, the worse problem is that there is no such culture in US now.

> people find them offensive or exclusionary?

"a significantly large group of people"???

There may be 1,000 or 1,000,000 such people in US.

But, considering that most other people, both blacks and whites,
in US are enjoying Thriller, the Lord of the Rings, Star Wars
and all the fantasies and FRPGs with such words of "dark lord",
"black magician" and "dark side of force", there is no such
culture in US to avoid saying black/dark with negative meaning.

As such, your "a significantly large group of people" is,
for people in US in general, just noisy minority having no
or little influence on US culture.

> Or do you think that it

People of noisy minority?

They may try to change culture, but, first, of US, not IETF.

Then, if most people in US stop saying "dark lord" or
"black magician" (note both "lord" and "magician" are
human (or demi-human such as elvish) beings), they
(people in US) may start considering to stop saying
black, dark or slave on non human and non living entities
such as "list" ("list" is a little sensitive as some list
may be a list of human beings), "flip flop" and "web".

> recommendation about what to do with this situation in general?

See above, though, as I repeatedly said, it should be impossible.

 > Internet draft in question:

Treat it as something written by noisy minority.

						Masataka Ohta

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 29 Jul 2020 11:11:53 +0200

On Tue, Jul 28, 2020 at 11:00:35AM -0500,
 Nico Williams <[email-masked]> wrote 
 a message of 17 lines which said:

> I'm surprised not to find there anything like a survey of RFCs,
> current I-Ds, and maybe even expired I-Ds, of problematic
> language. [...]  Can we ask the author, and/or maybe the RPC, to
> perform such a survey?

It would require a definition of "problematic language", something
that the discussion proved next to impossible. (I enjoyed the long
discussion about "folks", I learned a lot of things about the english
language and about the english-speaking societies, I didn't know that
this term was so polysemic).

My favorite example is RFC 6350 which uses the example "Chief vCard
Evangelist" since apparently chief is "Oppressive or Exclusionary
Language"
<https://www.theglobeandmail.com/business/article-why-i-decided-to-take-the-word-chief-out-of-my-ceo-title-to-respect/>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 29 Jul 2020 11:25:55 +0100

I would let authors express their thoughts as they think best, and leave the decision of what words to rephrase with the RFC Editors.

They are our specialist in the English language, they have good judgement on appropriateness, and they have a good understanding of internal and external continuity of expression.

As to this draft I would drop it as it is really unnecessary given that what I describe is what I think the RFC Editors would do anyway.

Stewart

> On 28 Jul 2020, at 18:48, Barry Leiba <[email-masked]> wrote:
>

---

From: Frode Kileng <[email-masked]>
Date: Wed, 29 Jul 2020 13:21:34 +0200

Sorry, but I it's time to speak up.

> Treat it as something written by noisy minority.

I strongly disagree. This is a real issue that needs to be addressed.

And this is definitively not only U.S.  centric, It's addressed in 
Norway and I guess many other "western countries" also. And the "white 
good/attractive" vs "dark  bad/attractive" is something that seems 
deeply rooted in Asian cultures also, both based on personal 
observation, media, avertismentss and others observers [1].

It's not up to you or me to define how others should interpret the "good 
intention" of the words we are using and instead MUST avoid using terms 
that don't need an explanation and cannot be misinterpreted.

Regards

Frode

{1] Some quick references

- White and Beautiful: An Examination of Skin Whitening Practices and 
Female Empowerment in China: 
https://onourterms.barnard.edu/article/white-and-beautiful/

. Where Does the Asian Obsession With White Skin Come From? 
https://thediplomat.com/2019/12/where-does-the-asian-obsession-with-white-skin-come-from/

- Brown and beautiful: the color-based beauty standards of Asian culture 
are grossly outdated 
https://www.highlandernews.org/36604/brown-and-beautiful-the-color-based-beauty-standards-of-asian-culture-are-grossly-outdated/

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Jul 2020 11:39:08 +0000

I think providing a clear indication that we are trying to be inclusive is important. Yes, some dismiss that as "virtue signaling." But being virtuous is a good thing :) Consider the upcoming publication draft-iab-for-the-users; how can we act on their behalf without being more represenatative and inclusive.

"Fix it in editing" is a negative message.

---

From: tom petch <[email-masked]>
Date: Wed, 29 Jul 2020 12:49:30 +0100

> As to this draft I would drop it as it is really unnecessary given that what I describe is what I think the RFC Editors would do anyway.

Yes.  This started with the IESG making a statement that they were 
looking for a framework going forward.

My message to the IESG is no, do not do that.  Leave it to the RFC Editor.

Tom Petch

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 21:06:45 +0900

> I strongly disagree. This is a real issue that needs to be addressed.

How can you disagree by not quoting my reasonings such as:

: But, considering that most other people, both blacks and whites,
: in US are enjoying Thriller, the Lord of the Rings, Star Wars
: and all the fantasies and FRPGs with such words of "dark lord",
: "black magician" and "dark side of force", there is no such
: culture in US to avoid saying black/dark with negative meaning.

without which, we can't have constructive discussion.

Or, do you agree with me on my points on US culture above?

Then, where is the "real issue"?

Note that, IMHO, most people in US, including blacks, are wise
enough to be able to enjoy terms of "dark lord", "black magician",
"dark side of force",without discriminating people with black skin
just as rest of us can do for people with black cloths.

If you might think they weren't so wise, that could be the worst
kind of discrimination of you.

Then, where is the point to ban "blacklist", "master/slave flip
flop" or "dark web"?

						Masataka Ohta

---

From: Yoav Nir <[email-masked]>
Date: Wed, 29 Jul 2020 15:12:36 +0300

> On 29 Jul 2020, at 13:25, Stewart Bryant <[email-masked]> wrote:
> 

I don’t think that is reasonable. The RFC editors may fix some sentence of explanatory text that is using some phrase that is loaded with baggage. 

But an importnat part of a document is the terminology that it defines. If a document defines something that is a “controller” or a “master” and something else that is a “function” or a “slave” or a “supplicant”, then this terminology is later going to be used in code, in product documentation, even in future university courses. it’s not reasonalbe to expect the editor to come up with a different terminology.

Drafts should arrive at the RFC editor being mostly ready for publication. Changing terminology should send a document back to the WG.

Yoav

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Jul 2020 12:14:55 +0000

I am responding to the last line of this.  It is factually incorrect. Others have asked you about this as well.  I am a native-born American.

"This is no such culture in the US to avoid saying black/dark with negative meaning"  This is factually wrong.  It is a generalization. There is a strong, and growing, culture within the US to avoid these terms in technical documentation.

Will you please stop trying to make this point now?  You are wrong.

---

From: Yoav Nir <[email-masked]>
Date: Wed, 29 Jul 2020 15:15:29 +0300

A white woman from California calling out the Vietnamese culture for being “grossly outdated” is among the most condescending things I’ve seen in a while.

> On 29 Jul 2020, at 14:21, Frode Kileng <[email-masked]> wrote:
> 
> 
> And this is definitively not only U.S.  centric, It's addressed in Norway and I guess many other "western countries" also. And the "white good/attractive" vs "dark  bad/attractive" is something that seems deeply rooted in Asian cultures also, both based on personal observation, media, avertismentss and others observers [1].
> 
> It's not up to you or me to define how others should interpret the "good intention" of the words we are using and instead MUST avoid using terms that don't need an explanation and cannot be misinterpreted.
> 
> 
> Regards
> 
> Frode
> 
> 
> - White and Beautiful: An Examination of Skin Whitening Practices and Female Empowerment in China: https://onourterms.barnard.edu/article/white-and-beautiful/
> 
> .. Where Does the Asian Obsession With White Skin Come From? https://thediplomat.com/2019/12/where-does-the-asian-obsession-with-white-skin-come-from/
> 
> - Brown and beautiful: the color-based beauty standards of Asian culture are grossly outdated https://www.highlandernews.org/36604/brown-and-beautiful-the-color-based-beauty-standards-of-asian-culture-are-grossly-outdated/
> 
> 
>

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 21:17:04 +0900

Stewart Bryant wrote:

> I would let authors express their thoughts as they think best, and
> leave the decision of what words to rephrase with the RFC Editors.

Never make the RFC editors the dictators.

The situation is already bad enough that employees of twitter
can not enjoy freedom of speech to say publicly that ban on
"blacklist" or "master/slave" is wrong without fear of losing
their job.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 21:34:24 +0900

> I am responding to the last line of this. It is factually incorrect.
> Others have asked you about this as well. I am a native-born
> American.

So?

As I said "most other people" and:

: There may be 1,000 or 1,000,000 such people in US.

I can't see your point that my points admitting noisy minority
can be "factually incorrect" by a single or thousands of
not-really-counter-examples of native-borns?

I believe most people in US, including blacks, are wise enough
to be able to enjoy saying "dark lord", "black magic", "blacklist",
"dark side of force", "blacklist", "master/slave flip flop" or
"dark web" without discriminating people with black skin of black
cloths, even though you might think they were less wise.

						Masataka Ohta

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Jul 2020 12:46:40 +0000

I am sorry that I am not making my point clearly enough.

I read your words as "since language is used in works like Thriller, there is no culture to avoid these words"  I am saying that is wrong because *context* is important.

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 29 Jul 2020 22:31:03 +0900

> I am sorry that I am not making my point clearly enough.

Instead, I am sorry in advance not to be able to resist saying
"Language barrier of you?" :-)

> I read your words as "since language is used in works like Thriller,
> there is no culture to avoid these words"  I am saying that is wrong
> because *context* is important.

Anyway, yes, context is important as I wrote:

 > (note both "lord" and "magician" are
 > human (or demi-human such as elvish) beings),

and

 > stop saying

So, some might be disturbed by "blacklist" of a list of human
beings, though most should still be indifferent to.

						Masataka Ohta

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 29 Jul 2020 23:32:00 +1000

On Wed, Jul 29, 2020, at 21:39, Salz, Rich wrote:
> Yes, some dismiss that as "virtue signaling." But being virtuous is a good thing :) 

Virtue signalling is not synonymous with being virtuous.  Being virtuous is supporting a charity (modulo the goodness of the charity of course), virtue signalling is posing outside a charity for the perfect Instagram photo and the associated street cred.

It's possible to be both virtuous and give off signals about it of course.  To bring it back to the specific here:

> I think providing a clear indication that we are trying to be inclusive is important.

It seems to be me that most of the debate in this thread boils down to: "is this effort is a clear signal that we're serious about trying to be inclusive rather than facile pandering to a particularly noisy political group?", and an associated "would publishing something like this be effective and attract people who want to make the Internet work better by producing high quality, relevant technical documents that influence the way people design, use, and manage the Internet?"

Regards,

Bron.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Jul 2020 13:33:23 +0000

Not quite.  Some might have no problem with "The Master of Flies and his Slaves" in a work of *fiction* but would see it as needlessly harmful when describing a relationship between replica's in a *technical document.*

---

From: Leif Johansson <[email-masked]>
Date: Wed, 29 Jul 2020 16:36:28 +0200

On 2020-07-29 15:32, Bron Gondwana wrote:
> Virtue signalling is not synonymous with being virtuous.  Being virtuous is supporting a charity (modulo the goodness of the charity of course), virtue signalling is posing outside a charity for the
> perfect Instagram photo and the associated street cred.
> 

often one gets in the way of the other tho

> 
>> I think providing a clear indication that we are trying to be inclusive is important..
> 
> It seems to be me that most of the debate in this thread boils down to: "is this effort is a clear signal that we're serious about trying to be inclusive rather than facile pandering to a particularly
> noisy political group?", and an associated "would publishing something like this be effective and attract people who want to make the Internet work better by producing high quality, relevant technical
> documents that influence the way people design, use, and manage the Internet?"

excellent summary of the whole thread

---

From: S Moonesamy <[email-masked]>
Date: Wed, 29 Jul 2020 06:33:32 -0700

Hi Nico,
>Pete's post that you linked to.]

I came across the following well before this thread was started: 
https://www.bloomberg.com/opinion/articles/2013-12-30/2013-offensive-cliche-winner-is-skin-in-the-game- 
It was argued that the phrase, which is found in the message I 
referenced, is an euphemism for "callous".  That is at odds with "empathic".

>point one's patience with people who argue in bad faith runs out.

Yes. [1]

Regards,
S. Moonesamy

1.  Sometimes it is better to keep things simple; hence the short response.

---

From: Nico Williams <[email-masked]>
Date: Wed, 29 Jul 2020 10:32:01 -0500

On Wed, Jul 29, 2020 at 06:33:32AM -0700, S Moonesamy wrote:
> I came across the following well before this thread was started: https://www.bloomberg.com/opinion/articles/2013-12-30/2013-offensive-cliche-winner-is-skin-in-the-game-
> It was argued that the phrase, which is found in the message I referenced,
> is an euphemism for "callous".  That is at odds with "empathic".

Time for Newspeak then.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Jul 2020 15:33:41 +0000

Not replying to any particular email, but to the general discussion...

It seems to me that IETF isn't in a good position to natively determine what words are "problematic". So what I think would be good would be to have a list of words and phrases that external communities (e.g., governments, universities, corporations) are either forbidding or recommending against. Include a reference to the external community's web page where they discuss this. RECOMMEND not using words in this list. Allow anyone to suggest having something added to the list; suggestion must include the reference. Have a small team that vets the request (makes sure the reference works and judges whether the referenced community reflects a community that IETF should consider reflecting -- which is still a judgment call, but I think identifying whether a community is (or should be) important to IETF members is easier than judging whether someone who doesn't share your experiences might be offended by a word or phrase) and decides whether or not to add it to the list. An existing team, like the Ombudsteam, might be tasked with this.

The RFC Editor doesn't need to police the use of these words. Allow for IETF community self-policing to decide whether a WG or independent stream author really want to use a word or phrase, given its presence on this list.

For example, consider Apple as a reasonable reference.
https://developer.apple.com/news/?id=1o9zxsxl

Specifically, for "master/slave" or "blacklist/whitelist", look at 
https://help.apple.com/applestyleguide/#/apsg72b28652 and go to master/slave or blacklist/whitelist in the alphabetical list

Apple participates actively in IETF and does good work here -- so it is important to IETF.

References don't have to all point to US entities -- any term/reference can be proposed to be added to the list from any geography/country.

If there is a good reference for RECOMMENDING against the use of "folks" or "people" in RFCs, propose adding those words it and point to the reference.
Barbara

---

From: Nico Williams <[email-masked]>
Date: Wed, 29 Jul 2020 10:36:07 -0500

On Wed, Jul 29, 2020 at 11:11:53AM +0200, Stephane Bortzmeyer wrote:
> that the discussion proved next to impossible. [...]

Sure, but Knodel clearly has an idea of what problematic language is and
made a proposal around it, therefore Knodel could have included (and yet
could include) a survey based on that idea.  I'm rather curious about
that.  By the the proposed definition, the one the IESG approves of, do
we even have a problem, has it been getting better naturally, or worse?

---

From: Dick Franks <[email-masked]>
Date: Wed, 29 Jul 2020 17:07:29 +0100

On Wed, 29 Jul 2020 at 13:15, Salz, Rich <rsalz=[email-masked]>
wrote:

> Others have asked you about this as well.  I am a native-born American.
>

But the real point lies in the first part of the sentence.

The substantial proportion of the US population that enjoy such fantasies
must have an expectation or acceptance that black/dark has a negative
meaning; otherwise the fantasy scenario makes no sense at all.

> "This is no such culture in the US to avoid saying black/dark with
> negative meaning"  This is factually wrong.  It is a generalization. There
> is a strong, and growing, culture within the US to avoid these terms in
> technical documentation.
>

i.e. currently fashionable
Merely a passing phase, like a teenager with blackheads.

---

From: Victor Kuarsingh <[email-masked]>
Date: Wed, 29 Jul 2020 12:11:06 -0400

Barbara,

On Wed, Jul 29, 2020 at 11:34 AM STARK, BARBARA H <[email-masked]> wrote:

> It seems to me that IETF isn't in a good position to natively determine
> what words are "problematic". So what I think would be good would be to
> have a list of words and phrases that external communities (e.g.,
> governments, universities, corporations) are either forbidding or
> recommending against. Include a reference to the external community's web
> page where they discuss this. RECOMMEND not using words in this list. Allow
> anyone to suggest having something added to the list; suggestion must
> include the reference. Have a small team that vets the request (makes sure
> the reference works and judges whether the referenced community reflects a
> community that IETF should consider reflecting -- which is still a judgment
> call, but I think identifying whether a community is (or should be)
> important to IETF members is easier than judging whether someone who
> doesn't share your experiences might be offended by a word or phrase) and
> decides whether or not to add it to the list. An existing team, like the
> Ombudsteam, might be tasked with this.
>
> The RFC Editor doesn't need to police the use of these words. Allow for
> IETF community self-policing to decide whether a WG or independent stream
> author really want to use a word or phrase, given its presence on this list.
>
> https://help.apple.com/applestyleguide/#/apsg72b28652 and go to
> master/slave or blacklist/whitelist in the alphabetical list
>

Since this is such a problematic topic, I was wondering if there is a more
subtle way to slowly address this with as little pain as possible.  People
may get upset that I am making this suggestion, however here it is.

1. WG Chairs (since we read the docs anyway), flag a doc for GenART review
if words are in it that may need to be scrutinized  (AD can also ask for
that review)
2. As part of that directorate  review (or we create a new directorate for
this? ) we flag / make recommendations on alterative words/phrases if needed

Seems like this would work without the need to pre-agree.  That team can
then look to key external references as input.  Over time, with some
experience behind us (from actual reviews and updates), we can then apply
our knowledge and experience to the problem to see if it makes sense to
create more fixed rules on this.  Perhaps this is too late in the process
to do such changes.  it would also incentive authors and WG chairs to
pre-vet for this in as part of normal document creation.  We have lots of
time to make this part of normal WG review anyway.

regards,

Victor K

> References don't have to all point to US entities -- any term/reference
> can be proposed to be added to the list from any geography/country.
>
> If there is a good reference for RECOMMENDING against the use of "folks"
> or "people" in RFCs, propose adding those words it and point to the
> reference.
> Barbara
>
>
>
>
>

---

From: Joseph Touch <[email-masked]>
Date: Wed, 29 Jul 2020 09:13:04 -0700

> On Jul 28, 2020, at 10:25 PM, Viktor Dukhovni <[email-masked]> wrote:
> 

Those are exactly the reasons this case is identical to other IETF docs.

> that intent is liable to be misunderstood by others.

And that’s all this document is intended to assist. As I mentioned before, it compels only the RSE to support the process. Authors are encouraged to help by participating too, but not compelled.
,,,
> in which they were written, and so it should be.

And what this doc is recognizing is that these norms now include addressing potentially unintended connotations of the terms it lists.

Further, it also can help us in encouraging consistent use of new terms. If we each choose different versions of replacements, the result could be confusing. Suggesting why “primary/secondary” is not a good choice for DNS (for which primary already has other meanings), e.g., could be very useful.

...
> terms find more support, they should be used instead.  …

The proposed document helps us have that discussion collectively now, rather than ad-hoc for each RFC published. That’s all it is intended to do.

Joe

---

From: Dan Harkins <[email-masked]>
Date: Wed, 29 Jul 2020 09:15:05 -0700

> It would be quite useful to have such a survey.

   It would also be useful if the draft could refer to research on
the subject that was not behind a paywall.

   We are being told that certain words are "exclusionary" and that
certain groups of people, when they read these words, feel excluded.
If this is not anecdotal and/or fallacious then let's see the work.
Is there any evidence that elimination of these words has any
impact on "inclusion"?

   We're being asked to swallow quite a number of assertions here,
the last of which being that if you don't swallow the other ones
you're not compassionate or empathetic. So call me names, that's
fine but I still want to see some justification for what people
are saying is a problem and what their proposed solution will do
(aside from giving some people the opportunity to describe
themselves as "empathetic and compassionate").

   regards,

   Dan.

---

From: Bob Hinden <[email-masked]>
Date: Wed, 29 Jul 2020 10:44:15 -0700

Barbara,

> On Jul 29, 2020, at 8:33 AM, STARK, BARBARA H <[email-masked]> wrote:
> 

Thanks for the pointers, these are quite good in my view.

Bob

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Wed, 29 Jul 2020 15:42:28 -0300

Hi all

> required to avoid that outcome.

I fully agree.

>    http://paulgraham.com/orth.html

A sobering read.

Language control has been for ages a preferred tool for societal/thought 
control. Just go over a bit of history and make a list of different 
organizations that tried to control language.

Without even googling:

- The Catholic Church during the Middle Ages
- Every fascist government in the first half of the 20th century
- Every military dictatorship during most of the 20th century
- Quite a few regimes currently in power. No need to name them, they are 
known to all

Language control creates a very powerful control tool that if it were to 
fall on the wrong hands. Even things created with the best intentions 
can do incredible harm if suddenly the wrong set of people are in 
charge.

As someone who grew up in a military dictatorship I have first hand 
experience on this. An uncle of mine spent a week in jail in 1974 just 
for uttering the word “communist” on the street. A word that had 
been banned.

The IETF has a lot of work to do in order to ensure an inclusive, open 
minded and welcoming environment, one that will lead to more and better 
technology being developed within its framework. Language control is not 
something that will help, and could be dangerous in the future.

/Carlos

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Jul 2020 19:35:16 +0000

Hi Victor,
I think I may not have described what I was suggesting clearly enough. I wasn’t proposing any fixed (i.e., MANDATORY or MUST) rules. I was trying to avoid problems caused by the perception that people inside IETF would be identifying what words were problematic (using their own subjective criteria, and where the decision makers are not members of the demographics perceived to be slighted by the words), and that use of these words would be strictly prohibited.

Let me make my suggestion more concretely:

There exists a list (not an IANA list, but maybe on tools or datatracker).
This list has 2 columns:
Word or Phrase  |  Reference(s)

The Reference(s) column has references to websites where entities IETF considers important are asking for the word or phrase not to be used in documentation or publications that they have some element of control over. It can be delimited (comma or semi-colon) so a word that is referenced by multiple entities can have multiple references.

The Word column could have a tool (like idnits) developed against it such that authors, shepherds, or anyone else can directly run the check and there is no need for WG chairs or GenArt reviewers to be held responsible for knowing all the words on the list or running the tool.

It is only RECOMMENDED that these words not be used. The authors are being asked to make a *conscious* decision to use the words, knowing some people somewhere may have issues in certain contexts. The authors are also provided references so they can know who it is who has issues and in what context. But it can also happen that a reviewer or RFC editor decides to run the check and asks the authors if use of the words was intentional. The authors can say “Yes”, and that’s the end of it (until the next person asks and they say “Yes” again). “Yes, use of these words is intentional” is valid; which means publication of a RFC isn’t denied just because it contains those words.

But lists like this don’t just magically spawn. There needs to be a process for creating/updating the list. I think anyone should be able to suggest adding a word or phrase. But they have to provide a reference where an entity describes how that entity deals with occurrences of that word or phrase. The suggester can also provide additional references for existing entries. Some people do need to look at the suggestion and make a decision as to whether the referenced website is sufficiently relevant to IETF and belongs on the list.

I think this is manageable with relatively low overhead, and it doesn’t censor use of the words. It merely asks people to make an informed and conscious decision to use the words. And the list of words to be careful about is explicit and known.
Barbara

From: Victor Kuarsingh <[email-masked]>
Sent: Wednesday, July 29, 2020 11:11 AM
To: STARK, BARBARA H <[email-masked]>
Cc: [email-masked]
Subject: Re: IESG Statement On Oppressive or Exclusionary Language

Barbara,

On Wed, Jul 29, 2020 at 11:34 AM STARK, BARBARA H <[email-masked]<mailto:[email-masked]>> wrote:
Not replying to any particular email, but to the general discussion...

For example, consider Apple as a reasonable reference.
https://developer.apple.com/news/?id=1o9zxsxl<https://urldefense.proofpoint.com/v2/url?u=https-3A__developer.apple.com_news_-3Fid-3D1o9zxsxl&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=KGQ1RQlq8czTXz492w-8fak_ka8kxLlHRSTeBzQXbLU&s=Eh4QhnAGng9GaqjLRoNUv_dscuCVaUSBQ2PvbDw3akM&e=>

Specifically, for "master/slave" or "blacklist/whitelist", look at
https://help.apple.com/applestyleguide/#/apsg72b28652<https://urldefense.proofpoint.com/v2/url?u=https-3A__help.apple.com_applestyleguide_-23_apsg72b28652&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=KGQ1RQlq8czTXz492w-8fak_ka8kxLlHRSTeBzQXbLU&s=N3_-r7Tw9dSLr5jiyEQXbLKL8arC4XWS7EMeGEiKNQM&e=> and go to master/slave or blacklist/whitelist in the alphabetical list

Since this is such a problematic topic, I was wondering if there is a more subtle way to slowly address this with as little pain as possible.  People may get upset that I am making this suggestion, however here it is.

1. WG Chairs (since we read the docs anyway), flag a doc for GenART review if words are in it that may need to be scrutinized  (AD can also ask for that review)
2. As part of that directorate  review (or we create a new directorate for this? ) we flag / make recommendations on alterative words/phrases if needed

Seems like this would work without the need to pre-agree.  That team can then look to key external references as input.  Over time, with some experience behind us (from actual reviews and updates), we can then apply our knowledge and experience to the problem to see if it makes sense to create more fixed rules on this.  Perhaps this is too late in the process to do such changes.  it would also incentive authors and WG chairs to pre-vet for this in as part of normal document creation.  We have lots of time to make this part of normal WG review anyway.

regards,

Victor K

---

From: Christian Huitema <[email-masked]>
Date: Wed, 29 Jul 2020 12:52:20 -0700

Maybe we want to run some kind of threat modeling before we put in place
a tool like that. I am concerned that "the road to hell is paved with
good intentions." For example, if there is a process like that, what is
the guarantee that some dictatorial regimes do not use it to enforce
party-line recommendations? And of course, no dictatorial regime will
ever admit that they are a dictature...

-- Christian Huitema

On 7/29/2020 12:35 PM, STARK, BARBARA H wrote:
>
> Hi Victor,
>
> I think I may not have described what I was suggesting clearly enough.
> I wasn’t proposing any fixed (i.e., MANDATORY or MUST) rules. I was
> trying to avoid problems caused by the perception that people inside
> IETF would be identifying what words were problematic (using their own
> subjective criteria, and where the decision makers are not members of
> the demographics perceived to be slighted by the words), and that use
> of these words would be strictly prohibited.
>
>  
>
> The Reference(s) column has references to websites where entities IETF
> considers important are asking for the word or phrase not to be used
> in documentation or publications that they have some element of
> control over. It can be delimited (comma or semi-colon) so a word that
> is referenced by multiple entities can have multiple references.
>
>  
>
> The Word column could have a tool (like idnits) developed against it
> such that authors, shepherds, or anyone else can directly run the
> check and there is no need for WG chairs or GenArt reviewers to be
> held responsible for knowing all the words on the list or running the
> tool.
>
>  
>
> It is only RECOMMENDED that these words not be used. The authors are
> being asked to make a **conscious** decision to use the words, knowing
> some people somewhere may have issues in certain contexts. The authors
> are also provided references so they can know who it is who has issues
> and in what context. But it can also happen that a reviewer or RFC
> editor decides to run the check and asks the authors if use of the
> words was intentional. The authors can say “Yes”, and that’s the end
> of it (until the next person asks and they say “Yes” again). “Yes, use
> of these words is intentional” is valid; which means publication of a
> RFC isn’t denied just because it contains those words.
>
>  
>
> But lists like this don’t just magically spawn. There needs to be a
> process for creating/updating the list. I think anyone should be able
> to suggest adding a word or phrase. But they have to provide a
> reference where an entity describes how that entity deals with
> occurrences of that word or phrase. The suggester can also provide
> additional references for existing entries. Some people do need to
> look at the suggestion and make a decision as to whether the
> referenced website is sufficiently relevant to IETF and belongs on the
> list.
>
>  
>
> I think this is manageable with relatively low overhead, and it
> doesn’t censor use of the words. It merely asks people to make an
> informed and conscious decision to use the words. And the list of
> words to be careful about is explicit and known.
>
> Barbara
>
>  
>
> *From:*Victor Kuarsingh <[email-masked]>
> *Sent:* Wednesday, July 29, 2020 11:11 AM
> *To:* STARK, BARBARA H <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: IESG Statement On Oppressive or Exclusionary Language
>
>  
>
> Barbara,
>
>  
>
>  
>
>  
>
>     It seems to me that IETF isn't in a good position to natively
>     determine what words are "problematic". So what I think would be
>     good would be to have a list of words and phrases that external
>     communities (e.g., governments, universities, corporations) are
>     either forbidding or recommending against. Include a reference to
>     the external community's web page where they discuss this.
>     RECOMMEND not using words in this list. Allow anyone to suggest
>     having something added to the list; suggestion must include the
>     reference. Have a small team that vets the request (makes sure the
>     reference works and judges whether the referenced community
>     reflects a community that IETF should consider reflecting -- which
>     is still a judgment call, but I think identifying whether a
>     community is (or should be) important to IETF members is easier
>     than judging whether someone who doesn't share your experiences
>     might be offended by a word or phrase) and decides whether or not
>     to add it to the list. An existing team, like the Ombudsteam,
>     might be tasked with this.
>
>     The RFC Editor doesn't need to police the use of these words.
>     Allow for IETF community self-policing to decide whether a WG or
>     independent stream author really want to use a word or phrase,
>     given its presence on this list.
>
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__developer.apple.com_news_-3Fid-3D1o9zxsxl&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=KGQ1RQlq8czTXz492w-8fak_ka8kxLlHRSTeBzQXbLU&s=Eh4QhnAGng9GaqjLRoNUv_dscuCVaUSBQ2PvbDw3akM&e=>
>
>     https://help.apple.com/applestyleguide/#/apsg72b28652
>     <https://urldefense.proofpoint.com/v2/url?u=https-3A__help.apple.com_applestyleguide_-23_apsg72b28652&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=KGQ1RQlq8czTXz492w-8fak_ka8kxLlHRSTeBzQXbLU&s=N3_-r7Tw9dSLr5jiyEQXbLKL8arC4XWS7EMeGEiKNQM&e=>
>     and go to master/slave or blacklist/whitelist in the alphabetical list
>
>  
>
> Since this is such a problematic topic, I was wondering if there is a
> more subtle way to slowly address this with as little pain as
> possible.  People may get upset that I am making this suggestion,
> however here it is.
>
>  
>
> 1. WG Chairs (since we read the docs anyway), flag a doc for GenART
> review if words are in it that may need to be scrutinized  (AD can
> also ask for that review)
>
> 2. As part of that directorate  review (or we create a new directorate
> for this? ) we flag / make recommendations on
> alterative words/phrases if needed
>
>  
>
> Seems like this would work without the need to pre-agree.  That team
> can then look to key external references as input.  Over time, with
> some experience behind us (from actual reviews and updates), we can
> then apply our knowledge and experience to the problem to see if it
> makes sense to create more fixed rules on this.  Perhaps this is too
> late in the process to do such changes.  it would also incentive
> authors and WG chairs to pre-vet for this in as part of normal
> document creation.  We have lots of time to make this part of normal
> WG review anyway.
>
>  
>
> regards,
>
>  
>
> Victor K
>
>  
>
>  
>
>
>     References don't have to all point to US entities -- any
>     term/reference can be proposed to be added to the list from any
>     geography/country.
>
>     If there is a good reference for RECOMMENDING against the use of
>     "folks" or "people" in RFCs, propose adding those words it and
>     point to the reference.
>     Barbara
>
>
>

---

From: "John Levine" <[email-masked]>
Date: 29 Jul 2020 16:58:13 -0400

In article <[email-masked]> you write:
>-=-=-=-=-=-
>Hi Victor,
>I think I may not have described what I was suggesting clearly enough. I wasn’t proposing any fixed (i.e.,
>MANDATORY or MUST) rules. I was trying to avoid problems caused by the perception that people inside IETF would
>be identifying what words were problematic (using their own subjective criteria, and where the decision makers
>are not members of the demographics perceived to be slighted by the words), and that use of these words would be
>strictly prohibited. ...

Unfortunately, that's much too simplistic. There are lots of words
where the context is crucial. To take a familiar example, Master is a
problem in the sense of someone who owns a slave, but not in the sense
of someone who knows all about a topic. My daughter got a Master of
Arts degree this year and I don't expect her to give it back.

Certainly some words we should never use at all, like **** and !*%&#
but we never use them in I-D's anyway.

R's,
John

PS: Then there's words like "niggardly."

---

From: Carlos Martinez-Cagnazzo <[email-masked]>
Date: Wed, 29 Jul 2020 18:09:16 -0300

Indeed. That is the point I tried to make.

On Wed, Jul 29, 2020 at 16:53 Christian Huitema <[email-masked]> wrote:

> Maybe we want to run some kind of threat modeling before we put in place a
> tool like that. I am concerned that "the road to hell is paved with good
> intentions." For example, if there is a process like that, what is the
> guarantee that some dictatorial regimes do not use it to enforce party-line
> recommendations? And of course, no dictatorial regime will ever admit that
> they are a dictature...
>
> -- Christian Huitema
> I think I may not have described what I was suggesting clearly enough. I
> wasn’t proposing any fixed (i.e., MANDATORY or MUST) rules. I was trying to
> avoid problems caused by the perception that people inside IETF would be
> identifying what words were problematic (using their own subjective
> criteria, and where the decision makers are not members of the demographics
> perceived to be slighted by the words), and that use of these words would
> be strictly prohibited.
>
>
>
> considers important are asking for the word or phrase not to be used in
> documentation or publications that they have some element of control over.
> It can be delimited (comma or semi-colon) so a word that is referenced by
> multiple entities can have multiple references.
>
>
>
> The Word column could have a tool (like idnits) developed against it such
> that authors, shepherds, or anyone else can directly run the check and
> there is no need for WG chairs or GenArt reviewers to be held responsible
> for knowing all the words on the list or running the tool.
>
>
>
> It is only RECOMMENDED that these words not be used. The authors are being
> asked to make a **conscious** decision to use the words, knowing some
> people somewhere may have issues in certain contexts. The authors are also
> provided references so they can know who it is who has issues and in what
> context. But it can also happen that a reviewer or RFC editor decides to
> run the check and asks the authors if use of the words was intentional. The
> authors can say “Yes”, and that’s the end of it (until the next person asks
> and they say “Yes” again). “Yes, use of these words is intentional” is
> valid; which means publication of a RFC isn’t denied just because it
> contains those words.
>
>
>
> process for creating/updating the list. I think anyone should be able to
> suggest adding a word or phrase. But they have to provide a reference where
> an entity describes how that entity deals with occurrences of that word or
> phrase. The suggester can also provide additional references for existing
> entries. Some people do need to look at the suggestion and make a decision
> as to whether the referenced website is sufficiently relevant to IETF and
> belongs on the list.
>
>
>
> I think this is manageable with relatively low overhead, and it doesn’t
> censor use of the words. It merely asks people to make an informed and
> conscious decision to use the words. And the list of words to be careful
> about is explicit and known.
>
> Barbara
>
>
>
> *From:* Victor Kuarsingh <[email-masked]> <[email-masked]>
> *To:* STARK, BARBARA H <[email-masked]> <[email-masked]>
> *Cc:* [email-masked]
--
=========================
Carlos M. Martinez-Cagnazzo
h <http://cagnazzo.name>ttp://cagnazzo.me
=========================

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 29 Jul 2020 21:09:41 +0000

The sort of “language policing” you describe is where the people in power prevented people not in power from expressing their views and opinions. It is not about the people in power policing their own language so as not to (intentionally?) oppress people not in power. The powerful regimes you reference were very effective at selecting words to maximize oppression – and they knew it.

IETF is powerful. The people who are able to get RFCs published are powerful. The suggestion being made in this thread is that the IETF proceed in a way to minimize oppression of marginalized communities that IETF’s words might cause. I don’t think outright bans are useful. I do think it’s a good idea to ask authors to make conscious decision to use words that we know communities of  marginalized people say harms them.

Language matters, as the debate over such things as Texas schoolbooks * shows us. It can be as insidious as the order in which things are presented, omission of select information, and use of passive vs. active tense (so no-one and nothing gets “blamed”). All over the world, women and societies are brainwashed by people in control of broadcast and print media that having dark skin is unattractive. I’ve seen reports about this from India, Ghana, South Africa, Japan, Korea, the United States, and elsewhere. They are sold skin bleaching products that cause cancer, kidney damage, fetal damage, etc. The message that “dark” is evil/bad/ugly/stupid has real consequences.

I think it’s past time that people who have the influence and prestige of IETF standing behind their published words were asked to at least be aware of any words they use that might be causing harm to marginalized populations around the world.

Barbara

* https://www.npr.org/sections/ed/2015/07/13/421744763/how-textbooks-can-teach-different-versions-of-history (and you can find many other articles if you search for “Texas State Board of Education history”

From: ietf <[email-masked]> On Behalf Of Carlos M. Martinez
Sent: Wednesday, July 29, 2020 1:42 PM
To: [email-masked]
Subject: Re: [Offlist] IESG Statement On Oppressive or Exclusionary Language

Hi all

I fully agree.

http://paulgraham.com/orth.html<https://urldefense.proofpoint.com/v2/url?u=http-3A__paulgraham.com_orth.html&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=5y-_0C2d770v07iq5xllNPU2mkVazNxHlsEAAlHx2cs&s=IQPYiadfx2TZyc0TVa3Fhl2fIRp6nrXiIEbhBMSoeFs&e=>

A sobering read.

Language control has been for ages a preferred tool for societal/thought control. Just go over a bit of history and make a list of different organizations that tried to control language.

Without even googling:

  *   The Catholic Church during the Middle Ages
  *   Every fascist government in the first half of the 20th century
  *   Every military dictatorship during most of the 20th century
  *   Quite a few regimes currently in power. No need to name them, they are known to all

Language control creates a very powerful control tool that if it were to fall on the wrong hands. Even things created with the best intentions can do incredible harm if suddenly the wrong set of people are in charge.

As someone who grew up in a military dictatorship I have first hand experience on this. An uncle of mine spent a week in jail in 1974 just for uttering the word “communist” on the street. A word that had been banned.

The IETF has a lot of work to do in order to ensure an inclusive, open minded and welcoming environment, one that will lead to more and better technology being developed within its framework. Language control is not something that will help, and could be dangerous in the future.

/Carlos

---

From: Keith Moore <[email-masked]>
Date: Wed, 29 Jul 2020 21:10:59 -0400

On 7/29/20 11:32 AM, Nico Williams wrote:

>> I came across the following well before this thread was started:https://www.bloomberg.com/opinion/articles/2013-12-30/2013-offensive-cliche-winner-is-skin-in-the-game-

doubleplus ungood!

Keith

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 30 Jul 2020 10:48:45 +0200

On 29. 07. 20 23:09, STARK, BARBARA H wrote:
> The sort of “language policing” you describe is where the people in
> power prevented people not in power from expressing their views and
> opinions. It is not about the people in power policing their own
> language so as not to (intentionally?) oppress people not in power. The
> powerful regimes you reference were very effective at selecting words to
> maximize oppression – and they knew it.
> 

It is perfectly OK if somebody applies such language policing (I would
rather say good taste) to herself or himself. It is somewhat more
problematic to enforce it, even gently, on others. In my own country,
the communist regime was not started by some Big Brother seizing power,
but by a relatively large part of the population that was even able to
win elections in 1946 (still relatively democratic). These folks
proclaimed themselves to be the progressive part of the society, and
started slowly oppressing others that didn't share their views,
including language policing.

I believe that free speech (within limits stated by law) is one of the
greatest virtues of the liberal society. Je suis Charlie.

>  
> 
> IETF is powerful. The people who are able to get RFCs published are
> powerful. The suggestion being made in this thread is that the IETF
> proceed in a way to minimize oppression of marginalized communities that
> IETF’s words might cause. I don’t think outright bans are useful. I do
> think it’s a good idea to ask authors to make conscious decision to use
> words that we know communities of  marginalized people say harms them.
>
It should be sufficient to explain mental clichés that many of us are
still using and their possible consequences, and suggest to be more
creative and, where possible, use terms that better express the actual
relationship at hand. Sensitive and caring people should get the message.

>  
> 
> Language matters, as the debate over such things as Texas schoolbooks *
> shows us. It can be as insidious as the order in which things are
> presented, omission of select information, and use of passive vs. active
> tense (so no-one and nothing gets “blamed”). All over the world, women
> and societies are brainwashed by people in control of broadcast and
> print media that having dark skin is unattractive. I’ve seen reports
> about this from India, Ghana, South Africa, Japan, Korea, the United
> States, and elsewhere. They are sold skin bleaching products that cause
> cancer, kidney damage, fetal damage, etc. The message that “dark” is
> evil/bad/ugly/stupid has real consequences.
> 

Well, many people in other parts of the world try to make their skin as
dark as possible by going to solar studios etc., even though it also
causes cancer. All this is a consequence of the global consumerist
culture and marketing rather than wrong speech.

Lada

>  
> 
> I think it’s past time that people who have the influence and prestige
> of IETF standing behind their published words were asked to at least be
> aware of any words they use that might be causing harm to marginalized
> populations around the world.
> 
>  
> 
> Barbara
> 
>  
> 
> *
> https://www.npr.org/sections/ed/2015/07/13/421744763/how-textbooks-can-teach-different-versions-of-history
> (and you can find many other articles if you search for “Texas State
> Board of Education history”
> 
>  
> 
> *From:*ietf <[email-masked]> *On Behalf Of *Carlos M. Martinez
> *Sent:* Wednesday, July 29, 2020 1:42 PM
> *To:* [email-masked]
> *Subject:* Re: [Offlist] IESG Statement On Oppressive or Exclusionary
> Language
> 
>  
> 
> Hi all
> 
>     <https://urldefense.proofpoint.com/v2/url?u=http-3A__paulgraham.com_orth.html&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=LoGzhC-8sc8SY8Tq4vrfog&m=5y-_0C2d770v07iq5xllNPU2mkVazNxHlsEAAlHx2cs&s=IQPYiadfx2TZyc0TVa3Fhl2fIRp6nrXiIEbhBMSoeFs&e=>
> 
> A sobering read.
> 
> can do incredible harm if suddenly the wrong set of people are in charge.
> 
> for uttering the word “communist” on the street. A word that had been
> banned.
>

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 30 Jul 2020 23:46:09 +0900

On 2020/07/29 22:33, Salz, Rich wrote:
> Not quite.  Some might have no problem with "The Master of Flies and
> his Slaves" in a work of *fiction* but would see it as needlessly
> harmful when describing a relationship between replica's in a
> *technical document.*

Needlessly harmful not because of "Master" or "Slaves" but of "Flies"?

I can't see your point.

						 Masataka Ohta

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 30 Jul 2020 15:12:48 +0000

>    I can't see your point.

I don't have the language skills to make it more clear, sorry.

---

From: Keith Moore <[email-masked]>
Date: Thu, 30 Jul 2020 22:47:16 -0400

On 7/25/20 10:58 AM, Kyle Rose wrote:

> The IETF does have an inclusion problem, but I suspect it has very 
> little to do with problematic technical jargon and a lot more to do 
> with the all-too-frequent bullying, mocking, and dismissal that seem 
> to be standard operating procedure for a small but vocal minority of 
> the community.

That statement could be credibly read in at least two ways:

1. the small but vocal minority of the community that claims the 
authority to bully people whom that small but vocal minority sees as 
being on the fringes

2. the small but vocal minority of the community that is on the fringes 
whom are seen as bullying others merely because they have different 
opinions (which they express even though they are different, and don't 
readily cave in to pressure from others)

Even in this particular discussion, which to me looks like it has been 
relatively respectful, there are signs that it really bothers some 
people that other people have different opinions, as if everyone should 
somehow agree with a vocal minority of people /merely because that 
minority believes it has good intentions/.

To me, part of what inclusion looks like is /respectful tolerance of 
differing views //even though some of those views make some people 
uncomfortable/.   I want to suggest that people being immediately 
comfortable isn't an appropriate goal, because it always makes some 
people uncomfortable that there are multiple valid perspectives on a 
subject.  Instead, the community needs to cultivate a willingness to be 
uncomfortable when it is done in the service of accommodating different 
views and building rough consensus.

Keith

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 30 Jul 2020 23:12:15 -0400

Hi,

> but we never use them in I-D's anyway.

Context always matters. There is an RFC containing the % decoding of
%66%75%63%6B%65%64. I know because I am the author. :)

Thanks,
Donald

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 06:03:34 +0200

On Wed, Jul 29, 2020 at 09:09:41PM +0000, STARK, BARBARA H wrote:
> All over the world, women and societies are brainwashed by people in control of broadcast and print media that having dark skin is unattractive. I???ve seen reports about this from India, Ghana, South Africa, Japan, Korea, the United States, and elsewhere. They are sold skin bleaching products that cause cancer, kidney damage, fetal damage, etc. The message that ???dark??? is evil/bad/ugly/stupid has real consequences.

And in "pinkskin" countries, people go to indoor tanning, take pills,
cremes or sprays to get darker skin, a lot of which i was told is
problematic or dangerous as well. I know a country that elected
a man president who is using some method of darkening his skin.

Not to speak of all the other bodily alterations and augmentations done
to gain more self confidence, and to have more success in job, relationship
or other social situations.

Are specific skin tanning products maybe a good next big thing to get fixed/prohibited by a public outcry as we've seen for many food, agricultural, beauty products ? Sure, it could be, but i don't think this is caused by a unique oppression of blackness. I think it is yet another example of self-oppression by perceptions of societal beauty norms, and there are so many examples other than just skin color (either ways).

Cheers
    Toerless

> * https://www.npr.org/sections/ed/2015/07/13/421744763/how-textbooks-can-teach-different-versions-of-history (and you can find many other articles if you search for ???Texas State Board of Education history???
> 
> As someone who grew up in a military dictatorship I have first hand experience on this. An uncle of mine spent a week in jail in 1974 just for uttering the word ???communist??? on the street. A word that had been banned.
> 

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 31 Jul 2020 06:25:36 +0200

I would hereby like to ask that the RIFT WG is renamed
because i feel personally oppressed by the fat shaming the name implies.
Trees are just like people, all their shapes are beautiful.

Fat shaming is causing many societal problems around the world.
France just had to create a new law to ban extremely thin models for
example. Many people around the world digest dangerous products or
exercise in health endangering ways to loose weight purely to meet
societal norms.  Even the medical profession is leading this oppression
charge by insisting to rely on old fashioned BMI regimes while new
medical evidence start to point into a different direction.

IETF  Attendees who do not meet societal norms are already discriminated
against by the IETFs sometimes limited quantity of N*XL t-shirts. Also,
every time IETF t-shirts are sourced from Asia, they tend to be at least one
X size smaller than they are supposed to be, further increasing the fat
shaming.

Cheers
   Toerless

-- 
---
[email-masked]

---

From: Masataka Ohta <[email-masked]>
Date: Fri, 31 Jul 2020 17:50:59 +0900

STARK, BARBARA H wrote:

> All over the
> world, women and societies are brainwashed by people in control of
> broadcast and print media that having dark skin is unattractive. I’ve
> seen reports about this from India, Ghana, South Africa, Japan,
> Korea, the United States, and elsewhere.

In Japan, whiter women has been considered better for these
1,000 years, even when there was no broadcast, not even
printing.

Be careful not to be fooled by deceptive reports.

						Masataka Ohta

---

From: Christian de Larrinaga <[email-masked]>
Date: Fri, 31 Jul 2020 11:11:14 +0100

Joseph Touch writes:

> https://www.internetsociety.org/chapters/
>
> Joe

True - Although firstly chapters are a good place for IETFrs to engage
(with) their local  communities. It is maybe  worth pointing out
that many chapters have lists and connections across the entire "stack"
and so can be a useful place to find things out about the
level of hum or even bemusement you might receive outside the narrow  
confines of a Working Group IETF list context.

-- 
Christian de Larrinaga 
https://firsthand.net
mu4e - still working on my config... !

---

From: Kyle Rose <[email-masked]>
Date: Fri, 31 Jul 2020 08:23:22 -0400

Congrats, Keith: you made me compose an email in vim.

To preface, I agree with what you're getting at, and will add my own
thoughts below. But first I would like to clarify that my earlier statement
obliquely referred to specific cases of people having withdrawn from IETF
participation because the technical problems they were trying to highlight
were not only not being taken seriously in official venues, but were
prompting ridicule and personal attacks from that vocal minority who could
not conceive of any legitimate position in opposition to IETF mantras. I'm
not going to get any more specific here because specific cases are not the
point of this thread, and there's already been too much drift.

Now, getting back to your reply:

The IETF classically expresses its values through its consensus process in
an emergent way: when a normative RFC is published in the IETF stream, it
(let's assume for the sake of argument) represents the consensus of the
participants at the time, and so whatever values are implied by the
normative language become part of the overall set of values that the IETF
expresses. The non-historic normative documents are effectively a codex
from which our shared values are drawn.

Position statements come at this from the other direction. They establish
an orthodox view within the IETF, effectively putting up a sign saying "If
you disagree, maybe you ought not come here." That is far more exclusionary
than any loaded technical jargon. By preemptively excluding those who
disagree with the prevailing orthodoxy, we create an echo chamber and
eventually come to assume that there are no reasonable divergent
viewpoints. For the IESG to arrogate to itself the power to set the bounds
of appropriate discourse on a non-technical matter on which many reasonable
people can and do disagree seems a dangerous precedent.

Fundamentally, what this comes down to is that the IETF is a bottom-up
organization. Not top-down. The IESG is there to serve the participants, as
a well of expertise and a means for shepherding consensus for a coherent
technical vision from a cacophony of voices, continuously changing and
often wildly out of tune with each other. The IETF is not simply a factory
for a vision chosen by the IESG.

Kyle

On Thu, Jul 30, 2020 at 10:47 PM Keith Moore <[email-masked]>
wrote:

> operating procedure for a small but vocal minority of the community.
>
> 1. the small but vocal minority of the community that claims the authority
> to bully people whom that small but vocal minority sees as being on the
> fringes
>
> relatively respectful, there are signs that it really bothers some people
> that other people have different opinions, as if everyone should somehow
> agree with a vocal minority of people *merely because that minority
> believes it has good intentions*.
>
> To me, part of what inclusion looks like is *respectful tolerance of
> differing views **even though some of those views make some people
> uncomfortable*.   I want to suggest that people being immediately
> comfortable isn't an appropriate goal, because it always makes some people
> uncomfortable that there are multiple valid perspectives on a subject.
> Instead, the community needs to cultivate a willingness to be uncomfortable
> when it is done in the service of accommodating different views and
> building rough consensus.
>
> Keith
>
>
>

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 31 Jul 2020 13:53:09 +0100

> 1,000 years, even when there was no broadcast, not even

Humans have been voluntarily changing their appearance since as long as
we've been knocking rocks together to make fire.  E.g. in some cultures
it's fashionable to have a tan, but things may differ in other cultures.

But all of that is beside the point.  This discussion resolves around
whether it's appropriate to use terms which have been historically
associated with discrimination based on colour / gender / ethnicity /
etc, and where those terms have recently changed to one degree or other
to make them less acceptable in common parlance due to the connotations
that those terms have.

All cultures have skeletons in this particular cupboard, bar none.
Words and phrases have subtleties and undertones, and sometimes these
connotations can cause offence.

It happens the other way too, incidentally: once upon a time, the word
"occupy" was considered to be crude and offensive, but over time it lost
those connotations and is once again entirely acceptable in polite
conversation.

Languages change and cultures morph over time to adapt to changing
circumstances.  The only thing that would be abnormal would be for
society not to recognise this and to fail to adapt.

Nick

---

From: Masataka Ohta <[email-masked]>
Date: Sat, 1 Aug 2020 01:22:11 +0900

> whether it's appropriate to use terms which have been historically

How long, do you think, should something last to be able to be
historically meaningfully long?

> etc, and where those terms have recently changed to one degree or other

How recent, do you mean, is "recently"?

							Masataka Ohta

---

From: Joseph Touch <[email-masked]>
Date: Fri, 31 Jul 2020 10:06:57 -0700

> On Jul 31, 2020, at 3:11 AM, Christian de Larrinaga <[email-masked]> wrote:
> 
> 
> Joseph Touch writes:
>> ...
> (with) their local  communities.

Please see https://www.internetsociety.org/chapters/ <https://www.internetsociety.org/chapters/>

AFAICT, chapters are largely about public education, community programs, and public policy - they’re not local outposts of the IETF or even technical people.

Joe

---

From: Christian de Larrinaga <[email-masked]>
Date: Fri, 31 Jul 2020 18:42:21 +0100

It depends on the chapter which depends on input from those who 
participate.  I have very much encouraged those with tech clue in chapter 
activities I've helped with.

C

--------------------------------------

Christian de Larrinaga

On 31 July 2020 18:07:42 Joseph Touch <[email-masked]> wrote:
> Please see https://www.internetsociety.org/chapters/
>
> AFAICT, chapters are largely about public education, community programs, 
> and public policy - they’re not local outposts of the IETF or even 
> technical people.
>
> Joe

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Jul 2020 17:49:40 +0000

We also have local IETF hubs, which are of course much less active now. Ietf-hub-boston and ietf-hub-bangalore are the email lists.
The effort to create more seems to have fizzled, but that could be covid-adjacent.

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Fri, 31 Jul 2020 16:29:04 -0300

Hi!

On 30 Jul 2020, at 23:47, Keith Moore wrote:

> To me, part of what inclusion looks like is  _respectful tolerance of 
> differing views  _ _even though some of those views make some people 
> uncomfortable_.    I want to suggest that people being immediately 
> subject.  Instead, the community needs to cultivate a willingness to 
> be uncomfortable when it is done in the service of accommodating 
> different views and building rough consensus.

Beautifully written. Couldn’t agree more.

/Carlos

---

From: Leif Johansson <[email-masked]>
Date: Fri, 31 Jul 2020 22:26:44 +0200

Skickat från min iPhone

> 31 juli 2020 kl. 21:30 skrev Carlos M. Martinez <[email-masked]>:
> 
> Hi!
> 
>> To me, part of what inclusion looks like is  _respectful tolerance of differing views  _ _even though some of those views make some people uncomfortable_.    I want to suggest that people being immediately comfortable isn't an appropriate goal, because it always makes some people uncomfortable that there are multiple valid perspectives on a subject.  Instead, the community needs to cultivate a willingness to be uncomfortable when it is done in the service of accommodating different views and building rough consensus.
> 
+1

---

From: S Moonesamy <[email-masked]>
Date: Fri, 31 Jul 2020 16:06:10 -0700

Hi Barbara,
At 02:09 PM 29-07-2020, STARK, BARBARA H wrote:
>The sort of "language policing" you describe is 
>where the people in power prevented people not 
>in power from expressing their views and 
>opinions. It is not about the people in power 
>policing their own language so as not to 
>(intentionally?) oppress people not in power. 
>The powerful regimes you reference were very 
>effective at selecting words to maximize oppression – and theyy knew it.

In my opinion, the two persons who commented 
about "language control" probably have a better 
understanding of how it was applied at their locations.

>IETF is powerful. The people who are able to get 
>RFCs published are powerful. The suggestion 
>being made in this thread is that the IETF 
>proceed in a way to minimize oppression of 
>marginalized communities that IETF's words might 
>cause. I don't think outright bans are useful. I 
>do think it's a good idea to ask authors to make 
>conscious decision to use words that we know 
>communities of  marginalized people say harms them.

I don't see being listed as an author of an IETF 
document which was published as a sign of 
power.  If that was the case, I would not be 
sending comments as a reviewer of a draft.

I would give Ms Knodel and Mr ten Oever credit 
for writing about a topic which some people might not like discuss openly.

People who are at the periphery of what is 
described as "community" are sometimes told that 
"we have a mailing list" if you are unable to get 
to a meeting.  Sometimes, the question is 
ignored; I guess that it is for "language control".

>Language matters, as the debate over such things 
>as Texas schoolbooks * shows us. It can be as 
>insidious as the order in which things are 
>presented, omission of select information, and 
>use of passive vs. active tense (so no-one and nothing gets

I am not familiar with the Texas schoolbooks 
debate; I vaguely recall reading about a 
schoolbooks issue which occurred in the United 
States several years or more ago.

Regards,
S. Moonesamy