Subject: RE: Spelling, Grammar and Style in Internet Drafts

From: "Voyer, Daniel" <[email-masked]>
Date: Fri, 31 Jul 2020 17:45:58 +0000

Oh, I thought Github was the way 😊

From: ietf <[email-masked]> on behalf of Ron Bonica <rbonica=[email-masked]>
Date: Friday, July 31, 2020 at 1:44 PM
To: IETF Rinse Repeat <[email-masked]>
Subject: [EXT]Spelling, Grammar and Style in Internet Drafts

Folks,
IETF workload might be reduced if presentation were addressed early in a document’s life cycle. To achieve this goal:

  *   Could the RFC editor recommend a few software tools that draft authors can use to check spelling, grammar, and style (e.g., Grammarly, Hemmingway, ProWritingAid)?
  *   Could authors use these tools before submitting Internet Drafts?
  *   Could WG chairs and document shepherds use these tools to evaluate documents before adopting or progressing them.
                                                               Ron

Juniper Business Use Only

________________________________
External Email: Please use caution when opening links and attachments / Courriel externe: Soyez prudent avec les liens et documents joints

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 31 Jul 2020 18:51:13 +0100

https://tools.ietf.org/tools/idspell/webservice may be of use as a starting point.

A

From: ietf <[email-masked] <mailto:[email-masked]> > on behalf of Ron Bonica <rbonica=[email-masked] <mailto:rbonica=[email-masked]> >
Date: Friday, July 31, 2020 at 1:44 PM
To: IETF Rinse Repeat <[email-masked] <mailto:[email-masked]> >
Subject: [EXT]Spelling, Grammar and Style in Internet Drafts

Folks,

                                                               Ron

  _____

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 31 Jul 2020 18:00:10 +0000

https://github.com/codespell-project/codespell also.
From: "[email-masked]" <[email-masked]>
Organization: Old Dog Consulting
Reply-To: "[email-masked]" <[email-masked]>
Date: Friday, July 31, 2020 at 1:53 PM
To: 'Ron Bonica' <rbonica=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: Spelling, Grammar and Style in Internet Drafts

https://tools.ietf.org/tools/idspell/webservice<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_tools_idspell_webservice&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=pX9o3_7X3QHAL1bAcYBO_6RRwlr3hIewHf3toVylWOg&s=azIqjqvU-L-_Ei7deiyHGBetUWeEesQARz4_S92dXQs&e=> may be of use as a starting point.
A

From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of Ron Bonica <rbonica=[email-masked]<mailto:rbonica=[email-masked]>>
Date: Friday, July 31, 2020 at 1:44 PM
To: IETF Rinse Repeat <[email-masked]<mailto:[email-masked]>>
Subject: [EXT]Spelling, Grammar and Style in Internet Drafts

Folks,

---

From: Mary B <[email-masked]>
Date: Fri, 31 Jul 2020 13:31:14 -0500

In general, I think this is a good idea.  But, I would not like to see this
as a hard requirement.  There are different writing styles and I am
generally very intentional about how I write certain things and some tools
can change that and it's possible that could be missed.  That's why we have
AUTH48 with the RFC editor model.  So, it's not without some cost to try to
keep everything pretty as time goes by.  So, maybe recommend these tools
before WGLC.  I don't think the effort is worthwhile any earlier as text
often changes, and again, it's not without a cost to double check that any
recommended changes are correct.  Personally, I'm not bothered with docs
that don't have perfect grammar (typos yes), as long as I know what
it means.  I left some lovely Italian English in some the XCON docs I
co-authored with my Meetecho friends, but alas RFC editor changed it to be
more grammatically correct.  And, then I had one co-author whose grammar I
would change and then they would change it back to what they perceived to
be correct.  In that case, it might have been handy if I could point to a
tool as the basis for my change.   But, again, I don't think we should get
overly prescriptive and I do think this is why we have an RFC editor.

Regards,
Mary.

On Fri, Jul 31, 2020 at 12:53 PM Adrian Farrel <[email-masked]> wrote:

> *From: *ietf <[email-masked]> on behalf of Ron Bonica <
> rbonica=[email-masked]>
> *Date: *Friday, July 31, 2020 at 1:44 PM
> *To: *IETF Rinse Repeat <[email-masked]>
> *Subject: *[EXT]Spelling, Grammar and Style in Internet Drafts
>
>
>
> Folks,
>
> IETF workload might be reduced if presentation were addressed early in a
> document’s life cycle. To achieve this goal:
>
>    - Could the RFC editor recommend a few software tools that draft
>    authors can use to check spelling, grammar, and style (e.g., Grammarly,
>    Hemmingway, ProWritingAid)?
>    - Could authors use these tools before submitting Internet Drafts?
>    - Could WG chairs and document shepherds use these tools to evaluate
>    documents before adopting or progressing them.
>
>                                                                Ron
>
>
>
>
>
> ------------------------------
>
> *External Email:** Please use caution when opening links and attachments
> / **Courriel externe:** Soyez prudent avec les liens et documents joints *
>