Subject: Re: Kudos to MeetEcho

From: Jay Daley <[email-masked]>
Date: Wed, 29 Jul 2020 16:08:41 +1200

> On 28/07/2020, at 2:16 AM, Richard Barnes <[email-masked]> wrote:
> 
> While there has been a lot of progress since 107, it is clear from the first couple of sessions that there are still a many rough edges that are wasting a lot of WG time.  We should take a serious look at whether it's worth investing more in refining this tool, or whether a more standard tool would be appropriate.

It’s worth remembering that the primary use case for Meetecho is to provide online support to an in-person meeting while its secondary us car is an entirely online meeting. The primary use case requires physical adaptations that are not easily found in systems designed for the second. It would of course be possible to have different systems for the two use cases but feedback from the community so far has been to use a single tool. 

Another complicating factor is the use of WebRTC, which, as we’ve seen. is not supported either well enough or consistently enough across even the main browser platforms. 

The final complicating factor is of course the complexity of IETF requirements - for example we require a system that dynamically recognises multiple roles via OIDC and grants permissions accordingly. 

That’s not to say these complications apply to all of our system choices. Instant messaging for example is very different. 

Jay
-- 
Jay Daley
IETF Executive Director
+64 21 678840
> 
>> On Mon, Jul 27, 2020 at 10:08 AM Chris Inacio <[email-masked]> wrote:
>> I just want to say that I finished chairing a WG this morning and to say kudos to MeetEcho. Since it seems all I do is spend time in (many different) video conferencing apps, I think the updates to MeetEcho for the full virtual meeting are VERY impressive in the time from “Vancouver” till now.
>> 
>> It went smoother than I would have thought. I think MeetEcho did an amazing job. Thanks to them and all the leadership making the tooling work for this meeting.
>> 
>> There is the human problem of people reading the Jabber chat continuously during the meeting, because it really is now multiple stream communications during the meeting. If I knew the human / UI fix to that, I would suggest it, I don’t. I chair a small working group, so we can multitask that way. Large working groups will like have to the use the queue more formally than we did - with the chairs possibly voicing the jabber room.
>> 
>> 
>> 
>> --
>> Chris Inacio
>> [email-masked]
>> 
>>

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 29 Jul 2020 14:25:10 +1000

> The final complicating factor is of course the complexity of IETF requirements - for example we require a system that dynamically recognises multiple roles via OIDC and grants permissions according…

I am not sure where this requirement is derived from.  I have been to physical meetings in which there is no security guard standing in the room enforcing sitting requirements, and yet somehow the chairs of each session find themselves sitting at the desk out the front where the controls for the meeting are.

Given that you need a valid datatracker login, a "don't do that again" for the first misbehaviour and a denial of access for repeat offense would be enough.

I'd be in favour of having a mode switch from "regular participant" to "admin mode" that mirrors the process of deliberately sitting in the chair seats rather than the participant seats - just so people don't make accidental UI mistakes with those admin controls. - but beyond that it appears that the dynamic role permissions system is a level of top-down control that we don't normally impose on our physical sessions.

Cheers,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Jay Daley <[email-masked]>
Date: Wed, 29 Jul 2020 21:59:02 +1200

> On 29/07/2020, at 4:25 PM, Bron Gondwana <[email-masked]> wrote:
> 
> 

I too prefer permissive systems but who would manage the denial of access, if anyone can choose to sit in the chair seat?

> I'd be in favour of having a mode switch from "regular participant" to "admin mode" that mirrors the process of deliberately sitting in the chair seats rather than the participant seats

I’m not sure if you’ve spotted the irony here - you’re suggesting a feature here that, as far as I know, is not provided by any off-the-shelf conferencing system and would need to be developed specifically for the IETF. 

> - just so people don't make accidental UI mistakes with those admin controls. - but beyond that it appears that the dynamic role permissions system is a level of top-down control that we don't normally impose on our physical sessions.

Physical sessions have microphones on stands, people queuing at them, chairs calling on the next person to speak (use the microphone), certain people able to cut in, big red buttons and so on.  As I understand it, these features of an in-person meeting have built up over time to manage multiple speakers as fairly and productively as possible. There’s no evidence to suggest that doing away with that would improve those goals but I do agree that there are different ways of implementing those in an online system and the best way may still be waiting to be found. 

If we are to accept Richard’s assertion that we should be using off-the-shelf systems with >1m DAU then that would by necessity mean accepting their interaction model rather than our own and adapting our practices to fit. As far as I can tell, and I would be very happy to be corrected, that would be a significant cultural change even the principle was ring-fenced to a small set of systems not all systems. 

Jay

-- 
Jay Daley
IETF Executive Director

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 29 Jul 2020 21:00:01 +1000

> I too prefer permissive systems but who would manage the denial of access, if anyone can choose to sit in the chair seat?

Social pressure, pretty much.  The same thing that would manage access if you went and sat in a chair seat in a regular physical meeting - along with secretariat and meetecho staff having the ability to boot somebody who refused to rehave and block their user from joining again (as with threats of force anywhere in the world, the existence of that capability would be enough to mean it would very rarely be needed - like the sergeant-at-arms on the mailing lists but even less so because the social expectation of "you don't sit in the chair's chair unless you're a working group chair" is much stronger than the expectation of any particular behaviour on the lists).

> I’m not sure if you’ve spotted the irony here - you’re suggesting a feature here that, as far as I know, is not provided by any off-the-shelf conferencing system and would need to be developed spec…

Yeah, good point!  I don't know of any systems which support it built in, though plenty of systems have a pretty rich API.  But then you're back with some level of bespoke again.

I don't have a problem with meetecho as a concept, though it could definitely do with some user testing on the chair workflows, based on the amount of mistakes I've seen chairs (and participants) make, as well as a better testing framework to allow users to confirm their setup and try the interface out before they need it.

Speaking of which - I attended 3 of the testing sessions in advance of the IETF to make sure my setup was robust, with a couple of different configurations.  We knew this was a new version of a tool many of us haven't used before, and a new style of running an IETF - and we could well be wasting hundreds of people's time trying to learn the interface on the fly during a session.  So I don't have massive sympathy for people discovering that their setup didn't work having done no testing in advance.

> Physical sessions have microphones on stands, people queuing at them, chairs calling on the next person to speak (use the microphone), certain people able to cut in, big red buttons and so on.  As…

Yes, and heckling from the floor!  Definitely having it clear what the queue is and where you are in the queue is valuable, and norms around waiting your turn work better when everyone else can also see the queue and see that you're cutting it.

> If we are to accept Richard’s assertion that we should be using off-the-shelf systems with >1m DAU then that would by necessity mean accepting their interaction model rather than our own and adapti…

This I would agree with.  There are pros and cons of a >1m DAU system.  I've found meetecho this time a better experience than WebEx last time.  There are definitely pros of having a non-browser, non-webrtc client which can give a more consistent experience - but I think I'd also be OK with saying "use Chrome for your meetecho session" (I'm using Firefox on Linux myself, but I'd switch if it wasn't working for me) and tell people to suck it up and install Chrome in whatever level of restricted profile they wanted on their computer / tablet / pet rock.  That's no more invasive than the stand-alone clients of any of the >1m DAU systems' clients.

Bron.