Subject: On diversity in the NomCom

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 13 Jul 2020 23:01:30 +1000

https://www.ietf.org/topics/areas/

We have 7 areas by my reading of that page, which are considered so significantly areas of differentiation within the IETF. I'm interested in topics from various areas but by far I would say my "primary affiliation" within the IETF is ART.

Areas are indeed so important that when you look at the agenda, you see:

1100-1240  Session I
Room 1          	ART 	dispatch    	Dispatch WG - Joint with ARTAREA
Room 2          	IRTF	pearg       	Privacy Enhancements and Assessments Research Group 
Room 3          	RTG 	spring      	Source Packet Routing in Networking WG
Room 4          	SEC 	sacm        	Security Automation and Continuous Monitoring WG
Room 5          	SEC 	teep        	Trusted Execution Environment Provisioning WG
Room 6          	TSV 	dtn         	Delay/Disruption Tolerant Networking WG
Room 8          	TSV 	tcpm        	TCP Maintenance and Minor Extensions WG

Right there as almost the most important part of each line is which area the meeting belongs to.

I'd say of the many types of diversity - geographic location, primary language, personal identity, age, length of time involved with IETF, etc... that primary area affiliation would be a valuable thing to have diversity of within the nomcom - particularly since it handles nominations for the directors of these areas - having experience within multiple areas on the committee is valuable.

So there's my two cents towards any rework of the criteria for nomcom eligibility filtration - we should ask people to nominate a primary area and allow no more than say 4 from each area. In the worst case we would have only 3 areas represented, but right now it could all be from one!

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 13 Jul 2020 14:37:43 +0100

That is an interesting point, though I am not sure of the specifics of the proposal.

The IETF is very tribal along area lines with too little interaction between the tribes. Some consideration of areas of interest would be useful in Nomcom so that the special issues that effect the areas are better understood by those taking the decisions. Now I know they can ask, but some background context helps a lot.

Stewart

> On 13 Jul 2020, at 14:01, Bron Gondwana <[email-masked]> wrote:
> 
> https://www..ietf.org/topics/areas/ <https://www.ietf.org/topics/areas/>
> 
>   [email-masked] <mailto:[email-masked]>

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 13 Jul 2020 17:19:28 +0200

Earlier on when i had started a thread about the max2 rule suggesting that
its unfair to single out one specific criteria as a limiter, most responses
seemed to go in the direction of "but we had to do it, or else big
companies had too much influence, and: doing more would be too much work".
Aka: any more diversity criteria will be met with a lot of resistance.

As well meaning as those additional criteria are (and i was suggesting
country as another one), this is not going to happen for this NomCom.

What i instead suggest to anyone interested in best NomCom selection output,
is to educate yourself about the candidates and bring your personal
analysis of facts at hand as feedback to NomCom. Look at candidates prior
document reviews, work as chair or other role, author, personal personal interactions
and other relevant background.

Hearsay and tribal marketing "i like candidate foo, because i share tribe
bar with her" is not very useful to NomCom and may easily lead to annoyance
when it is stacked by obvious tribes like company affiliation. Indeed,
this may even backfire for candidates. 

In my experience, the most important feedback for NomCom when i served was
about long held grudges, sometimes as far back as more than one or two decades.
To those who want to bring forward grudges about candidates, i would suggest
to first attempt to have a disccuss about them with the candidate, e.g.:
in PM, and then make up your mind.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Christian Huitema <[email-masked]>
Date: Mon, 13 Jul 2020 10:16:11 -0700

> On Jul 13, 2020, at 6:37 AM, Stewart Bryant <[email-masked]> wrote:
> 

I don't think we are that tribal. Look at the QUIC WG happily mixing contributions from application, transport and security experts, with management also debated. I am sure there are other examples.

-- Christian Huitema

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 13 Jul 2020 10:27:50 -0700

> On Jul 13, 2020, at 10:16 AM, Christian Huitema <[email-masked]> wrote:
> 
> 

> -- Christian Huitema 

+1

Lots of the best work we do is spread across the fuzzy boundaries between areas.

Areas have changed over the years, and I’d be reticent to see these areas institutionalized to the point that people choose “primary” affiliations. I certainly wouldn’t want to have to choose an affiliation.

The NomCom talks to the community of contributors in each area, and listens to that feedback as the way to determine who is best suited for each role.

Best,
Tommy

---

From: Victor Kuarsingh <[email-masked]>
Date: Mon, 13 Jul 2020 13:50:06 -0400

On Mon, Jul 13, 2020 at 13:29 Tommy Pauly <tpauly=[email-masked]>
wrote:

> >> The IETF is very tribal along area lines with too little interaction
> between the tribes. Some consideration of areas of interest would be useful
> in Nomcom so that the special issues that effect the areas are better
> understood by those taking the decisions. Now I know they can ask, but some
> background context helps a lot.
> >
> > I don't think we are that tribal. Look at the QUIC WG happily mixing
> contributions from application, transport and security experts, with
> management also debated. I am sure there are other examples.
>
> >
> > -- Christian Huitema
>
> +1
>
> Areas have changed over the years, and I’d be reticent to see these areas
> institutionalized to the point that people choose “primary” affiliations. I
> certainly wouldn’t want to have to choose an affiliation.
>
> The NomCom talks to the community of contributors in each area, and
> listens to that feedback as the way to determine who is best suited for
> each role.

I would also agree with this position in general.  Folks may clump together
at times - perhaps in ephemeral or long lasting tribes, but I see
significant cross area collaboration, input and work done in spite of all
of this.

In my personal experience on Nomcom, I would say cross area understanding,
over a body of 10 voting members persons, has not seemed to be a limitation
doing the work (speaking also both a chair and a voting member).

The key attribute was that the nomcom knew at least some of the people, and
understood how work gets done (both in person and on lists) to help
evaluate the needs of the roles (considering input from the bodies,
liaisons and the community at large through feedback).  If after all of
that, there is still an issue, the confirming bodies are present to affirm
selections are in line with the community needs.

I am not opposed to diversity in general, but attempting to engineer that
diversity (in a model where randomness is needed), and across N vectors,
seems like a challenge.

If this is the desire of the community, then I would like to know if we
understand the problem statement more fully before trying to engineer a
solution.   With primary affiliation, the problem statement (IMO) is well
understood and is easy to define and action against.  Attempting to group
folks in other categories, of which boundaries change constantly, may not
result in a better outcome.

Regards,

Victor K

---

From: "Pete Resnick" <[email-masked]>
Date: Mon, 13 Jul 2020 14:04:42 -0500

On 13 Jul 2020, at 8:01, Bron Gondwana wrote:

> I'd say of the many types of diversity - geographic location, primary 
> language, personal identity, age, length of time involved with IETF, 
> etc... that primary area affiliation would be a valuable thing to have 
> diversity of within the nomcom - particularly since it handles 
> nominations for the directors of these areas - having experience 
> within multiple areas on the committee is valuable.

Just a few quick reminders:

a) We have an email list that is discussing NomCom eligibility more 
broadly: [email-masked]. Right now, it's discussing the 
topic of pre-selection volunteer eligibility (because of the outstanding 
issue of who is eligible now that we're having online-only plenary 
meetings), but selection criteria might be an interesting future topic.

b) Brian Carpenter has a draft on possible criteria changes: 
https://datatracker.ietf.org/doc/draft-carpenter-eligibility-expand/ 
(the HTML version is most useful).

c) Brian's document is on the agenda for the gendispatch at IETF 108 
https://datatracker.ietf.org/meeting/108/session/gendispatch. If 
selection criteria is a plausible future topic, that might be 
interesting input on how to dispatch the work. (Or not: We might decide 
that Brian's document needs separate handling from other NomCom related 
topics, but it's worth knowing that other topics are floating around in 
the community.)

FWIW: I like the idea of area diversity among NomCom members, and while 
I think we do have quite a few "tribes", we also have quite a good 
amount of cross-area work too, and that's a good value for the NomCom to 
embody and be thinking about.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Rob Sayre <[email-masked]>
Date: Mon, 13 Jul 2020 23:41:21 -0700

On Mon, Jul 13, 2020 at 6:02 AM Bron Gondwana <[email-masked]>
wrote:

>
> So there's my two cents towards any rework of the criteria for nomcom
> eligibility filtration - we should ask people to nominate a primary area
> and allow no more than say 4 from each area.  In the worst case we would
> have only 3 areas represented, but right now it could all be from one!
>

I also see the problem. When I looked at the recent process, it seemed
pretty stuffed.

Without challenging the current round, I'd suggest moving the "affiliation"
test to the volunteer phase.

I was able to attribute at least 63 of 143 volunteers to just four
companies.

thanks,
Rob

14. Stewart Bryant, Futurewei
17. Italo Busi, Huawei
21. Mach CHEN, Beijing Huawei Digital Technologies Co., Ltd.
22. Huaimo Chen, Futurewei
23. Uma Chunduri, Futurewei Inc
25. Alexander (Alex) Clemm, Futurewei Technologies, Inc.
27. Dhruv Dhody, Huawei
28. Jie Dong, Huawei Technologies
29. Linda Dunbar, Futurewei
30. Donald E. Eastlake, 3rd, Futurewei Technologies, Inc.
32. Toerless Eckert, Futurewei USA
35. David (Dawei) Fan, Huawei
38. Xuesong Geng, Huawei
47. Susan Hares, Huawei
60. Yuanlong Jiang, Huawei Technologies Co., Ltd
63. Georgios Karagiannis, Huawei Technologies Dusseldorf GmbH
69. Cheng Li, Huawei
70. Guangpeng Li, Huawei
71. Yizhou Li, Huawei Technologies
73. Bing Liu (Remy), Huawei Technologies
75. Kiran Makhijani, Futurewei Technologies
85. Tal Mizrahi, Huawei
92. Wei Pan, Huawei
93. Shuping Peng, Huawei
95. Yingzhen Qu,  Futurewei Technologies
112. Haoyu Song, Futurewei Technologies
124. YUEHUA (Corona) WEI, ZTE CORPORATION
129. Bo Wu, Huawei Technologies
130. QIN WU, Huawei
132. Jingrong Xie, Huawei
134. GANG YAN, Huawei
135. Huaru Yang, Beijing Huawei Digital Technologies Co., Ltd
137. XIANG YU, Huawei
140. Haomian Zheng, Huawei Technologies Co., Ltd.
141. guangying zheng, huawei
142. Xingwang (Joe) Zhou, Huawei
143. Shunwan Zhuang, Huawei

2. Zafar Ali, Cisco Systems
15. Luc André Burdet, Cisco
18. Pablo Camarillo, Cisco Systems
31. Charles Eckel, Cisco Systems
67. Eliot Lear, Cisco Systems
83. Mankamana Mishra, Cisco Systems
96. Reshad Rahman, Cisco
114. Ketan Jivan Talaulikar, Cisco Systems, India
117. Pascal Thubert, Cisco Systems
120. Stig Venaas, Cisco

55. Daniel Huang, ZTE
82. Gregory (Greg) Mirsky, ZTE TX, Inc.
124. YUEHUA (Corona) WEI, ZTE CORPORATION
131. Min Xiao, ZTE
133. Quan Xiong, ZTE Corporation
139. Zheng Zhang, ZTE

1. Melchior Aelmans, Juniper Networks
6. Vishnu Pavan (Pavan) Beeram, Juniper Networks
12. Ronald Bonica, Juniper Networks
13. Chris Bowers, Juniper Networks
42. Jeffrey Haas, Juniper Networks
50. SHRADDHA HEGDE, Juniper Networks
94. Tony Przygienda, Juniper
106. John G. Scudder, Juniper Networks
109. Yimin Shen, Juniper Networks
138. Zhaohui (Jeffrey) Zhang, Juniper

---

From: Melinda Shore <[email-masked]>
Date: Mon, 13 Jul 2020 22:59:29 -0800

> I was able to attribute at least 63 of 143 volunteers to just four

Might be interesting to look at how well that reflects meeting
attendance.  My guess is that it's disproportionate (having over
500 people at a 1200-person meeting come from those 4 companies
"feels" incorrect) but that's just a guess.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Jul 2020 08:56:39 +1200

> "feels" incorrect) but that's just a guess.

That might be true, but big companies are more likely to support
sustained participation, making their employees more likely to
meet the 3/5 rule.

I'd also like to challenge the assumption that the result is
necessarily bad.

If the IETF was a more typical SDO, we'd be funded by membership
subscriptions and we might well have voting weighted by membership
categories. So big companies would have proportionate power. For
good reasons, we don't do that. Nevertheless, the fact is that big
companies can (and do) send more people, and provide more sponsorship
(such as hosting meetings, and funding Area Directors), than small
companies. If they didn't get something back for that, they would
complain, or simply withdraw their resources. The chance to have
two people in the NomCom is quite a small "something" IMHO.

   Brian

---

From: Andrew Campling <[email-masked]>
Date: Tue, 14 Jul 2020 22:54:57 +0000

On 14-Jul-20 21:57, Brian E Carpenter <[email-masked]> wrote:

> I'd also like to challenge the assumption that the result is necessarily bad.
> 
> If the IETF was a more typical SDO, we'd be funded by membership subscriptions and we might 
> well have voting weighted by membership categories. So big companies would have 
> proportionate power. For good reasons, we don't do that. Nevertheless, the fact is that big 
> companies can (and do) send more people, and provide more sponsorship (such as hosting 
> meetings, and funding Area Directors), than small companies. If they didn't get something 
> back for that, they would complain, or simply withdraw their resources. The chance to have 

I think that this is a very valid point.  I do wonder though whether there may be an opportunity to inject a little more diversity into the process by requiring the second NomCom member from any organisation to be based in a different continent than the first?  This shouldn't be too onerous for big companies as their operations will typically have multinational if not global scope.  It would be even better to have limits on the total number of NomCom members from a given country and/or continent but at least seeking some diversity from within companies would be a good start.

Andrew

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Jul 2020 00:50:47 -0400

--On Tuesday, July 14, 2020 22:54 +0000 Andrew Campling
<[email-masked]> wrote:

>> If the IETF was a more typical SDO, we'd be funded by
>> membership subscriptions and we might  well have voting
>> weighted by membership categories. So big companies would
>> have  proportionate power. For good reasons, we don't do
>> that. Nevertheless, the fact is that big  companies can (and
>> do) send more people, and provide more sponsorship (such as
>> hosting  meetings, and funding Area Directors), than small
>> companies. If they didn't get something  back for that, they
>> would complain, or simply withdraw their resources. The
>> chance to have  two people in the NomCom is quite a small
>> "something" IMHO.
> 
> I think that this is a very valid point.  I do wonder though
> whether there may be an opportunity to inject a little more
> diversity into the process by requiring the second NomCom
> member from any organisation to be based in a different
> continent than the first?  This shouldn't be too onerous for
> big companies as their operations will typically have
> multinational if not global scope.  It would be even better to
> have limits on the total number of NomCom members from a given
> country and/or continent but at least seeking some diversity
> from within companies would be a good start.

I'm not sure that is the right problem to solve.  First, some
big companies who have multinational operations may not have
technical Internet operations in as many countries as they have
operations of any type, so the effect of such a rule might
easily be to limit them to a single Nomcom member where the
randomization process would have given them too.  Those same
companies often move people around for either short or long
appointments in different facilities.  That can lead to the sort
of hairsplitting that I think we are best off avoiding rather
than trying to make rules to cover every case (or require us to
give the Chair sufficient discretion to make at least some of us
anxious).  For example, assume the first person selected from a
given company is in country A.  The second person is a citizen
of country B but is on a long-time assignment, perhaps nominally
a permanent one, in country A.  Eligible or not?   If that is a
short-term appointment for, say, less than a year, but they
normally work in country B, does that change the eligibility?
Conversely, suppose the second person is a citizen of country A
working in country B?   Are they eligible?  Or suppose they
normally work in country A but transfer to country B.   How long
before or after the first Nomcom list is drawn from the pool is
it ok for them make that move and be eligible because there is
already someone on the Nomcom list from that company and country
A?

I don't know the answer to any of those questions, but I'm
fairly sure that trying to lay out all of the cases (the above
is certainly not a complete list) and make rules for each would
be crazy-making and that we would still encounter an edge case.

So I don't think we should go there regardless of the advantages
of perceived demographic diversity unless we are really, really
sure that those advantages would be worth the pain.

Let me suggest something different, and a different kind of
diversity, that has come up before in other forms.  Assume that
we can agree that the current 6 of 10 situation is a problem.  I
think it could then actually be three rather different problems:

(1) Absent the kinds of geographical you suggest, it may reduce
geographical diversity.

(2) I recognize what Brian is saying and may have more to say
about it when I get my thoughts together, but the very fact that
a disproportionate fraction of the Nomcom puts us at risk of a
Nomcom with certain types of biases that typically go with such
companies.  For example, suppose there are two candidates for a
given slot on the IESG.  Both are qualified from the standpoint
of prior IETF participation and leadership at the WG level and
both are technical leaders in the relevant area.   One of them
believes quite passionately that the IETF has gotten too complex
and too expensive in which to participate and that it should be
an objective to reduce complexity, costs, time commitments
needed to participate in the leadership, and so on.   The other
has spent most of her or his career in large companies with
generous travel support and generous support for the IETF and
similar bodies.  All thing being equal, one would expect a
Nomcom most of whose members come out of those large (and
generous) company environments to be less sympathetic to the
problems the first person identifies with and hence less
sympathetic to that person than would be the case for a Nomcom
with more diversity of organization types, occupational
categories, etc.

(3) Typically, these bigger companies tend to have much of their
technical interests --at least as represented by the people they
support to participate in  the IETF-- in a relatively small
number of IETF areas.  To the extent that is true and their two
Nomcom members (or five or six of the group from that collection
of companies), that face may reduce the diversity of the Nomcom
with regard to Areas (both in the IETF sense and areas of work
more generally), reducing the range of perspectives about what
is important, where the Nomcom should spend its time getting
things just right, and what expertise is available in the Nomcom
for candidate evaluation.

It is not impossible to address the third and still stick to
objective criteria.  One could ask volunteers for the Nomcom to
identify, not just an employer but the not more than two IETF
Areas in which they most strongly identify and/or have done most
of their work.  One could then think about a rule much like the
one you suggested about geography: if a given company already
had one volunteer seated who was associated with a given Area,
any other candidates from that company who came to the top of
the queue would be disqualified unless they identified with a
different area.     If that information were made public --it
certainly should not be a secret -- it would be hard to game
(and much less complex than sorting out geography) because its
not passing a laugh test would be grounds for a challenge.  

I don't know whether having that sort of criterion would be a
good idea, but I believe that examining it would be, at least, a
useful thought experiment and that more diversity in the Nomcom
along those lines would be useful in practice.

best,
   john

---

From: Rob Sayre <[email-masked]>
Date: Wed, 15 Jul 2020 01:51:01 -0700

On Tue, Jul 14, 2020 at 1:57 PM Brian E Carpenter <
[email-masked]> wrote:

> Nevertheless, the fact is that big
> complain, or simply withdraw their resources.
>

This seems like one of those things that might not "return to normal".

IETF work seems to be proceeding fine without people flying long distances
to sit in a hotel conference room and look at their laptops.

thanks,
Rob

---

From: Eliot Lear <[email-masked]>
Date: Wed, 15 Jul 2020 11:38:47 +0200

Hi,

> On 13 Jul 2020, at 19:27, Tommy Pauly <tpauly=[email-masked]> wrote:
>> 

I agree with Stewart.  My experience is that the IETF is quite tribal.  That doesn’t mean that the tribes divide along the lines of WGs and areas, but more along technology.  That’s not to say that there is no intermingling, but on rare occasion the knives do come out.  Part of this is just due to specialization.

> Areas have changed over the years, and I’d be reticent to see these areas institutionalized to the point that people choose “primary” affiliations. I certainly wouldn’t want to have to choose an af…

I agree that hardcoding areas is a bad idea.  They are already hardcoded enough (the number of changes in 30 years can be counted on two hands at most).  In a way, I wish we could strip the labels entirely and just let the IESG self-organize around the work at hand, indicating to NOMCOM how many people they feel they need to cover the workload.

Eliot

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 15 Jul 2020 17:57:55 +0200

I disagree. The absence of in-person meeting is quite disruptive IMHO.

---

From: Victor Kuarsingh <[email-masked]>
Date: Wed, 15 Jul 2020 12:43:44 -0400

> to sit in a hotel conference room and look at their laptops.

Its quite possible this may wind up being true.  That said, at least for
me, we are also likely operating on momentum that has been built up over a
number of months / years.   Understanding what work look like, and what
changes we may need to expect, may not be manifest for some time.

Not to overly correlate this to "day-job", but I can certainly say there
are differences in a full remote model vs. hybrid model.  What we can get
done, and how work gets done is not the same IMO.   I am not suggesting we
can't operate fully remote, I am just unsure on what that means.

Where as many do "look at their laptops", there is considerable social
interaction which is not immaterial to how we work (after all, we are all
still human - for now).

regards,

Victor K

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Jul 2020 15:13:38 -0400

--On Wednesday, July 15, 2020 11:38 +0200 Eliot Lear
<lear=[email-masked]> wrote:

>> Areas have changed over the years, and I'd be reticent to
>> see these areas institutionalized to the point that people
>> choose "primary" affiliations. I certainly wouldn't
>> want to have to choose an affiliation.
> 
> I agree that hardcoding areas is a bad idea.  They are already
> hardcoded enough (the number of changes in 30 years can be
> counted on two hands at most).  In a way, I wish we could
> strip the labels entirely and just let the IESG self-organize
> around the work at hand, indicating to NOMCOM how many people
> they feel they need to cover the workload.

My earlier comments and strawman proposal notwithstanding, I
agree. I'm perhaps oversensitive due to speading too large a
fraction of my IETF time on fringe areas (you know, like email,
Internet-PSTN boundaries, and internationalization). However, in
the least couple of decades, I've sat in many WGs and listened
to people say "we don't want to understand that, we just want a
simple solution" (sometimes with WG Chairs agreeing), seen the
IAB push architectural issues that are important to the Internet
aside because no one in their membership both cared about and
understood them, and have seen multiple documents held up in the
IESG because no one understood the subject matter (but one or
more ADs acted as if they felt a need to have opinions anyway
without a willingness to spend the time to learn).   I'm also
seen reason to question the ability of a Nomcom with no, or
almost no, experience on the relevant topics to evaluate
candidates for the IAOC and LLC Board.  One certainly cannot
blame those problems (others may not even agree that they are
problems) entirely on Nomcoms and their composition but I can't
help feeling that, if Nomcoms had people on them who could
advocate for a broader set of perspectives and for consideration
of the importance of various technologies, we might be better
off.

best,
   john

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Jul 2020 09:10:20 +1200

On 15-Jul-20 20:51, Rob Sayre wrote:
> On Tue, Jul 14, 2020 at 1:57 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
> IETF work seems to be proceeding fine without people flying long distances to sit in a hotel conference room and look at their laptops.

That doesn't change my argument that big companies are more able than small companies to donate resources to the IETF. Whether those resources come out of the travel budget is a detail.

   Brian

---

From: Rob Sayre <[email-masked]>
Date: Wed, 15 Jul 2020 16:39:09 -0700

On Wed, Jul 15, 2020 at 2:10 PM Brian E Carpenter <
[email-masked]> wrote:

> [email-masked] <mailto:[email-masked]>> wrote:
> >
> > IETF work seems to be proceeding fine without people flying long
> distances to sit in a hotel conference room and look at their laptops.
>
> That doesn't change my argument that big companies are more able than
> small companies to donate resources to the IETF. Whether those resources
> come out of the travel budget is a detail.
>

Yes, the point was to consider whether the IETF needs the money. The number
of meetings is a sliding scale. Zero is probably not a good idea, but three
per year seems like too many. I attended a few IETF meetings long ago, and
I can understand why they must happen occasionally.

Area Director and WG chair time is a real cost, and I would advocate
reducing that commitment as well. Perhaps the IETF should no longer publish
Informational or Experimental RFCs. Internet-Drafts are good enough for
that.

thanks,
Rob

---

From: John C Klensin <[email-masked]>
Date: Wed, 15 Jul 2020 23:01:14 -0400

--On Wednesday, July 15, 2020 16:39 -0700 Rob Sayre
<[email-masked]> wrote:

> Area Director and WG chair time is a real cost, and I would
> advocate reducing that commitment as well. Perhaps the IETF
> should no longer publish Informational or Experimental RFCs.
> Internet-Drafts are good enough for that.

FWIW,...

Of course, the relatively new rules requiring IETF consensus for
Informational and Experimental documents in the IETF stream take
us in exactly the opposite direction.

I also note that many other SDOs publish informative,
non-standard, documents in the form of technical reports and
that things we would call Experimental (or our original
definition of Proposed Standard) show up as things "for trial
use".  So, again, fwiw, we are not the only, or even the first,
body to conclude that formal review, consensus, and publication
of such documents is a practical necessity.

It may be the the most effective way to reduce AD and WG Chair
workload and assorted overhead costs --if we really want to do
that-- would be to take a careful and critical look at how much
we can, and want to, actually get done, holding ourselves to a
higher standard about what work gets chartered/ authorized and
far more quickly killing off WGs that are not productive.  I
vaguely remember a proposal by a group of people including Dave
Crocker along those lines long ago and wonder if it would be
worth finding and giving another look.

But we are getting fairly far from the "diversity" topic and the
Nomcom.

    john

   john

---

From: Rob Sayre <[email-masked]>
Date: Thu, 16 Jul 2020 00:33:26 -0700

On Wed, Jul 15, 2020 at 8:01 PM John C Klensin <[email-masked]> wrote:

> non-standard, documents in the form of technical reports
>

Yes, and when I have to read anything that is not a Standards Track RFC, I
just groan.

The IETF is not perfect, but Internet Standard documents are generally
clear.

That said, Internet Draft links are now sufficiently stable, making many
kinds of RFCs unnecessary.

> Nomcom.

The argument was that stuffing the NomCom was ok, because of "resources"
that might be withdrawn.

My reaction was something like "ooh, promise?". I don't feel good about a
bunch of telecom companies bent on hobbling encryption.

thanks,
Rob

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 16 Jul 2020 15:04:34 +0000

If we were to do this, we need another term besides RFC.  After 20 years, everyone "knows" that RFC means an Internet standard.

(Yes, I exaggerate about what everyone knows)

---

From: Joel Halpern <[email-masked]>
Date: Thu, 16 Jul 2020 12:11:18 -0400

If we were to do what?  Publish IETF Stream (rough consensus) 
Informational and Experimental RFCs?  We already do that.  And have done 
so for many years.

If you are trying to argue that we should use a different form of 
publication, please make and justify that argument.  There is lots of 
disinformation and misinformation out there.  (I recently observed 
another SDO citing an expired individual draft as if it were an approved 
RFC.)

Yours,
Joel

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 16 Jul 2020 19:05:52 +0200

Hi Rich,

I hope you enjoy a bit of what i intend to be good humored ranting:

Where you at the infamous RFC bof where 20 people presented and
discussed 30 opinions about what should be in what (RFC variation)
name, without ever explaining their context upfront, leaving many
 observers in the dark as to what the heck anyone was talking about ?

If we ever where to poll for most bizarre IETF meeting, than that
RFC bof would get my vote. Really entertaining. As confusing as
westworld season 1+2.

If anybody wants to open the pandoras box of trying to make
RFC be anything but just the superset of all the documents
we publish, then i will chime in on the side of constitutional
originalists meaning an RFC is a document that is asking
for feedback. Nothing less, nothing more. The whole abuse
of putting never-to-be-touched normative specifications into RFC
is an abomination of what used to be an ad-hoc engineering 
discussion tool. Only "drafts" today are really in the spirit
and name of RFCs IMHO.

Maybe less of a rant:

The mayority of customers also are NOT clear about the distinction
between the different tracks and status options of RFCs we have, and
even when they are aware, it does not matter that much, because
the predominant use of RFCs in customers is to put their numbers
into RFP for product offers. And when a customer wants specific
functionality it is secondary whether this is an individual
submission, informational, experimental or standards track
RFC. Only customers who actaully follow IETF would know the
difference in "quality" of the specs based on status status.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Jul 2020 08:52:47 +1200

> another SDO citing an expired individual draft as if it were an approved 

I hope everyone realises that this conversation has been going on for
about 25 years. It actually doesn't matter, from this point of view, what
the document series is called or what the boilerplate says. It will still
be cited as "The IETF says..." sometimes.

Just look here for a recent example:
https://www.theregister.com/2020/06/08/developers_renew_push_to_get/

   Brian