Subject: remote camera protocols?

From: Michael Thomas <[email-masked]>
Date: Fri, 3 Jul 2020 11:02:15 -0700

I have a friend who is a theater person, who as everybody knows has been 
completely shut down. I remarked to him that it's probably time to start 
thinking about streaming plays. His counter is that it's expensive which 
I'm guessing is mainly in the production costs much more than the 
equipment. What occurs to me is that you don't *really* need camera 
people on site, or at least it's very plausible that they could do this 
remotely which would cut down quite a bit of the cost.

So the obvious question is whether there are existing standards for 
remote operation of cameras, sound equipment, lighting, etc? Is this 
something we've done?

Mike

---

From: John Scudder <[email-masked]>
Date: Sun, 5 Jul 2020 02:28:24 +0000

If I were looking for such things I’d probably start with SMPTE, not IETF.

Either way, best of luck.

--John

> On Jul 3, 2020, at 2:02 PM, Michael Thomas <[email-masked]> wrote:
> 
> [External Email. Be cautious of content]
> 
>

---

From: Gunnar Hellström <[email-masked]>
Date: Sun, 5 Jul 2020 20:08:02 +0200

There is one in RFC 4573.

Regards

Gunnar

---

From: Gene Hastings <[email-masked]>
Date: Sun, 5 Jul 2020 15:00:08 -0400

Let me also suggest the United States Institute for Theatre Technology <https://www.usitt.org/>. Their scope is wide, including Broadway tech and church streaming.

Also, the Entertainment Services and Technology Association <https://www.etsa.org>.

Of course, these folks will have a lot of material that’s not germane to your query, but they may have pointers to useful developments,

Gene

On Jul 4, 2020, at 10:28 PM, John Scudder <jgs=[email-masked]> wrote:

--John

Mike

---

From: Michael Thomas <[email-masked]>
Date: Sun, 5 Jul 2020 12:18:47 -0700

So it occurs to me that IETF has done something fairly similar for a 
different domain which is MGCP for telephony. Quite a bit of it would be 
directly useful since in the end cameras and  audio are literally media 
gateways. MGCP doesn't have the ability to, say, move a camera or zoom 
in/out, but it does know about hook switches keypads and other hardware 
related things so it's certainly in the spirit of the original. And MGCP 
certainly knows how to handle more than one kind of device, since it's 
not just about POTS termination, but PSTN gateways and maybe even IVR's? 
(it's been a long time).

Mike

On 7/5/20 12:00 PM, Gene Hastings wrote:
> Let me also suggest the United States Institute for Theatre Technology 
> <https://www.usitt.org/>. Their scope is wide, including Broadway tech 
> and church streaming.
>
> Of course, these folks will have a lot of material that’s not germane 
> to your query, but they may have pointers to useful developments,
>
> Gene
>
>
>> On Jul 4, 2020, at 10:28 PM, John Scudder 
>> <jgs=[email-masked]> wrote:
>>

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 5 Jul 2020 12:42:13 -0700

> On Jul 3, 2020, at 11:02, Michael Thomas <[email-masked]> wrote:
> 
> 
> I have a friend who is a theater person, who as everybody knows has been completely shut down. I remarked to him that it's probably time to start thinking about streaming plays. His counter is that it's expensive which I'm guessing is mainly in the production costs much more than the equipment. What occurs to me is that you don't *really* need camera people on site, or at least it's very plausible that they could do this remotely which would cut down quite a bit of the cost.
> 
> So the obvious question is whether there are existing standards for remote operation of cameras, sound equipment, lighting, etc? Is this something we've done?

Live broadcast television, sports, even cinema production make extensive use of remotely controlled cameras, lighting is essentially all remotely controlled, audio is mixed by computers etc.

While there exist camera specific control protocols such as AW which run over rs422  or IP, one should be aware that a ptz camera is simply a light duty industrial robot with three or more axises of freedom and some data acquisition grafted onto the side and that therefore modbus iccp or some other cnc protocol may well be the principle control protocol. dmx512 for lighting control was essentially an adaptation of pre-exisiting industrial control standards

The existence of standards while foundational to  building interoperable industrial control devices; doesn't seem entirely germain to the question of whether you can replace camera operators with robots where appropriate, or remote operators. You can, and productions do it all the time.

As cultural artifacts, go though, a recording once made for remote consumption is a good as the first time is was captured if not better due to post-acquisition editing or processing.  One can therefore ask whether recording it once and really well and as somewhat greater expense (including ongoing royalties for the contributors) is a more worthwhile effort then reducing your production costs by making the production less costly but retaining the most expensive part  (the labor).  The fact that we place value in the live, and repeated presentation of staged production is both anachronistic and the reason we go to the theater. I would hazard that while we can make do with the recording, attending in person cannot be replaced.

---

From: Stephan Wenger <[email-masked]>
Date: Mon, 6 Jul 2020 02:49:32 +0000

Right.  To elaborate a bit more:

IP/UDP/RTP as transport for far-end camera control
ITU-T Rec. H.323 Annex Q as the RTP payload format.
RFC 4573 as the media type specification when using SIP or other SDP-based signaling
Inside H.323 Annex Q, ITU-T Rec. H.224 for the framing, and in those frames H.281 for the far end camera control syntax.

This combination has been used in set-top-box, roll-about, and older H.323 and SIP based desktop video conferencing systems for the past 20 years or so.  It works.  There are a number of PTZ cameras out there that respond to the H.281 syntax, received over a serial link or its USB emulation.  I'm unaware of deployment in the current mostly closed systems (Zoom etc.), but note that at least some of those can drive PTZ cameras.

Stephan

On 7/5/20, 11:08 AM, "ietf on behalf of Gunnar Hellström" <[email-masked] on behalf of [email-masked]> wrote:

    Regards

    Gunnar

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 6 Jul 2020 08:32:04 -0600

Lots of stuff on FECC “Far End Camera Control” - the most widely used version are stuff the security cameras. Not sure the IETF version is used much. Much of theater lighting and other things are controlled with MIDI and there is lots of stuff implementing various forms of MIDI over IP including AppleMIDI.  For audio, look at some fo the stuff that supports Dante (proprietary de-facto standard)

> On Jul 3, 2020, at 12:02 PM, Michael Thomas <[email-masked]> wrote:
> 
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 7 Jul 2020 00:11:42 +0200

https://www.onvif.org/

E.g.:
https://www.amazon.co.uk/Tilt-Joystick-Controller-Monitor-Cameras/dp/B07N8FVMQV

Having embedded PTZ controllers available for a protocol is
IMHO a good indication of market penetration of the protocol.
Most people wouldn't use such a dedicated PTC controller but one
out of 1000 PC software based surveillance control software
options from vendors, and/or open source.

ONVIF is an interesting stew of IETF, Microsoft and W3 protocols,
i only worked with the discovery part (UPnP, WS-Discoevery/SSDP),
so no idea about the PTZ part, but if you look at the companies
in ONVIF you will see most, if not all of the big commercial
players. Penetration into low-end home surveillance cameras may
differ. I have not looked into this for years now.

There is also PSIA, but i can't remember anything interesting about it.

Remote theater/event should have more dedicated tooling beyond the
generic remote video surveillance infra. For example, when i first
installed stuff for remote teleteaching  in the 90th, we gave professors
red baseball caps, because thats all the PTZ cameras back then could track
automatically. Nowadays you would have a lot more tracking of individuals
on-stage to automatically derive atmos sound source 3D vectors AND
 camera tracking for example. But no idea about what good beginners
toolchains are.

Not sure if SMPTE actually got IP based PTZ into any of their specs.

Dr Google can certainly help more.

Cheers
    Toerles

On Fri, Jul 03, 2020 at 11:02:15AM -0700, Michael Thomas wrote:
> thinking about streaming plays. His counter is that it's expensive which I'm
> guessing is mainly in the production costs much more than the equipment.
> What occurs to me is that you don't *really* need camera people on site, or
> at least it's very plausible that they could do this remotely which would
> cut down quite a bit of the cost.
> 
> So the obvious question is whether there are existing standards for remote
> operation of cameras, sound equipment, lighting, etc? Is this something
> we've done?
> 
> Mike

-- 
---
[email-masked]