Subject: Thoughts about the IETF mailing list discussion

From: "[email-masked]" <[email-masked]>
Date: Wed, 19 Aug 2020 04:47:36 +0000 (UTC)

Well, I'm back from a five-day 'voluntary posting ban' imposed by the Sergeant-At-Arms (SAA) on August 12th, under direction of the IETF Chair, after being accused of being 'part of an emerging pattern of abuse' including but, presumably, not limited to, my recent emails related to the IESG's announcement:

https://mailarchive.ietf.org/arch/msg/ietf/UbhPgqdDNjqnL2c4LZzjWR28Q9I/

https://mailarchive.ietf.org/arch/msg/ietf/OdoiOlnKrHfHSl5dW2NxjfcEh6w/

https://mailarchive.ietf.org/arch/msg/ietf/-dNDiTeN_PFep1YZQkmvZpt6Fn4/

The SAA offered  me the option of posting its rebuke to me to the mailing list, having already quickly announced my ban a couple of times. I said yes to the option of them posting that rebuke text in full, but I haven't seen that posted.

I see that after I was banned, Ohta-san in Tokyo and M. Kobeissi in Paris (France, not Texas) were also promptly banned, and M. Kobeissi's ban was later reversed because he kicked up a fuss, and well, bullies are cowards. I do find M. Kobeissi's minority-viewpoint arguments quite persuasive. I feel that I'm in good company. (I'll note that this trend to replace 'bad' terms is very much in vogue in the United States, and that the three people banned for pointing out problems with the idea are not in the United States. Interesting, that. I'm reasonably sure that list policing should be part of mailing list administration, akin to giving a council car parking ticket in a civilized society, and should not be at the behest of the IETF Chair's personal direction. IETF mailing lists are for focused debate on topics, not just for me-too +1 agreement that avoids censure by the Sergeants.)

Unsurprisingly, I have some specific and some more general thoughts on this. No great realizations, alas; more a collection of pointers to stuff I hadn't been tracking closely that indicate a trend I hadn't paid much attention to but you, dear reader, have probably noticed.

The discouraging-bad-terminology draft discussion that kicked this off is very much a red herring testing the waters, and in my opinion is simply another play in pushing issues in terms of how speech is policed, how IETF mailing lists are run and how discussion is conducted, to be escalated slowly but ultimately to how the IETF itself is run and what goals are set for it. Change comes from within, an avalanche needs a first rock to fall, a journey starts with a single step, all that.

The IETF is set up on mailing lists to do its work, and, in these days of COVID and forced distanced working, needs them more than ever. Mailing lists are where the bulk of IETF work is done, directions are decided, drafts are discussed, and many decisions are taken.

Mailing-list etiquette is imo not difficult for an adult to master. Don't be an ass, argue the point, not the person, try to avoid ad hominem and bad rhetoric, make a point that is relevant and do try and write well; you're taking the attention of a lot of people, many who may disagree with you, some strongly. At least be polite (though expectations of what politeness entails and its customs do vary). If you're not, you'll get called on it. Be interesting, if you can. Being entertaining is a welcome, if rare, bonus.

And yet, it seems that we have been Doing Mailing Lists Wrong All This Time. Not inclusive enough? Toxic? That's not my experience; I find IETF-Discuss to be nowhere near as toxic as many other places can be, Twitter included, and there's a widely shared view of what the list is about and is for. Written down, codified.

I do find that automatic filtering of list mails into list mailboxes and threading of subjects provides useful distancing from topics and allows focusing my attention. I can come and go from IETF-Discuss or from various working group discussions without any undue emotional attachment, but then I'm not required to read or comment on everything. Or, because it's the IETF and I'm just a peon, anything. But that's just my experience.

I was struck by something Alissa Cooper, the current IETF chair, had minuted in the GENDISPATCH meeting on 30 July:

https://tools.ietf.org/wg/gendispatch/minutes

* **Alissa Cooper** : really interesting discussion.  Interesting noting
          dramatic difference in tone here vs tone on ietf@ietf.  Appreciate the
          desire to want a forum for discussion.  An IETF mailing list seems a
          really problematic way to talk about this subject.  Extremely painful
          to read through, and that dynamic pushes people out of the discussion
          who need to be there and are absent from it entirely in its current
          form. It's almost like having meetings like this is a better way.

Now, we've had IETF chairs who were criticized for paying too much attention to Cisco, and for not paying enough attention to Cisco (that was the same guy, at the same time). We've had chairs that had doubts about evolution or believed that all problems could be resolved by thinking about them on a cross-country ski trip. But as far as I know we've never before had a chair that didn't like reading IETF mailing lists because they were felt to be painful. The 'I can't read the mailing list now, because feelings' is now a trope that now seems to be recurring, even among people in senior roles. Emotions are not just being brought to the table, but are actually being expressed, with actual words.

These emotional responses and just-can't-deal-with-it statements are odd for me to see, especially from people posting about drafts they're invested in -- and receiving feedback on their drafts that they don't like to read, then calling foul. I do wonder what mail filtering and threading, if any, they're using, and what distancing that affords them mentally.

But mailing lists are how topics are debated in the IETF. One might wonder, if it can't be discussed on any mailing list, perhaps it is not a topic for the IETF or IETF contributors? Is an absent IETF contributor who doesn't contribute to mailing lists still a contributor? This is the kind of philosophy Wittgenstein's Tractatus 7 gets into.

Is someone who doesn't want to be there not there simply because they just don't want to be there? Or because they're not interested? Or feel oppressed? By a mailing list? Surely only the putative contributor can decide if they need to be there? And if they really need to be there, they'll be there? Despite the pain of reading the mailing list? Can they work through the pain of the mailing list and of having to listen to other people whose opinions are as valid as theirs are? And can they set up a separate mailbox for it? Is their presence on the list felt by their very absence? Does the list discussion call out for them? Is reading disagreement that painful? Do they feel as oppressed by reading journalism? Is hell other people, and their loud opinions?  Thanks, Sartre. Not easy questions to answer.

But if it's a matter of tone: the problem is apparently really Loud Men Talking Loudly on this list, which is what men are wont to do, and which is indeed exactly what I am doing right now.One can be loud, but also quite self-aware. And this male behaviour has, of course, already been called out As Wrong. Even though I'm engaging with the list and the subject matter.

https://hackcur.io/whats-wrong-with-loud-men-talking-loudly-the-ietfs-culture-wars/

(via the Oxford Internet Institute, which awarded Cooper's doctorate. It really is a small world. But there's a good simple rejoinder to much of that world: https://twitter.com/Nathabeer/status/1294353253463928835

"To be frank, one of the worst encounters I experienced in the IETF was with some women. I didn't experience sexism but bullying by other women because I didn't feel the need to join a women-only group.")

It's interesting how this sort of material moves quickly from anthropological analysis to prescriptive action. It's very much like 'Boys: They won't do what they are told and get distracted in class' or 'Men and Sportsball: What can we do about it?'

Well, we can always make Sportsball more inclusive. Remove violent tackles from rugby, change the rules, give everyone a ball. But at some point, it ceases to lose its activity and purpose, just as eventually, reasoned debate that is too watered down ceases to be useful debate; it degenerates into a series of unending "+1"s.

If you don't want to play sportsball to progress the state of the art, you shouldn't have to. Deliberately working to include people who really don't like sportsball and who stand on the sidelines saying that it's played all wrong, or try to play to their own rules and promptly take their ball home, is simply too difficult. (Those sidelines are Twitter commentary, these days. Many Twitter involved - ahem, IETF tweeps - remain _completely appalled_ by this mailing list. But I should also say that vast chunks of Twitter do remain completely devoted to Sportsball, showing that sometimes a metaphor is just a metaphor.)

I note that the IETF Chair is also the Area Director for GENDISPATCH (I would have thought that either in itself would be a fulltime role, as is staying woke), and that the GENDISPATCH terminology draft was written by Mallory Knodel, who, just as Cooper was, is at the Center for Democracy and Technology. That's a primarily-US lobbying organisation, pleased to be disrupting the IETF:

https://cdt.org/insights/pushing-internet-standards-governing-body-ietf-to-tackle-discriminatory-and-exclusionary-terminology/

You'd think a Center for Democracy and Technology would be more interested in spending time on the upcoming US election, on say, the democratic technology of voting machines and ensuring that a federal republic with mass disenfranchisement and a skewed voting college at least pretends to resemble a democracy to some degree, but here we are. Promoting US-style democracy is laudable, but fixing it is not. Anyway, probably too late for that. Pick the battles that you might win, in line with larger goals.

Knodel's also running the IRTF Human Rights Protocol Consideration group, which had a feminist take on how the IETF should be:

https://www.ietf.org/archive/id/draft-guerra-feminism-01.txt

https://www.apc.org/en/blog/can-we-make-internet-standards-feminist-discussion-internet-freedom-festival

Certainly new territory to be explored; I've certainly never given intersectionality its due when designing protocols or state machines.

Ultimately, beyond the IETF-discuss mailing list, this seems to be a growing trend in approaching IETF governance, and who gets to choose how things are run. Or, at least, an opening volleys of sorts in beginning that effort. It's less technical but far more political, and this particular politics has some external, well-funded, lobbyists.

The problem with discussing politics is that separating the person from the political viewpoint held is often far harder to do cleanly, and motives and purpose come into it more. It's more difficult to not go ad-hominem. Still, most IETF participants have external funding of some sort, and everyone has a viewpoint. But one rather wishes that the lobbying and politicking to set the direction of governance was a bit more transparent in stating its larger goals.

Speaking of governance, separation of powers is commonplace in democracies: the _trias politica_ of legislature; executive; and judiciary, though that and the rule of law are often under attack.

In the IETF, we have approximations in the IAB, the IESG, and the RFC-Editor, though we've been without a proper RFC-Editor for well over a year. Publishing judgement and technical gatekeeping has been weakened administratively over the years, if you like. It can be argued that the power of the RFC Editor has been considerably diminished since the glory days of Postel, and that remediating steps have not been enough. Discussions about language and discussions just distract from that. Rule of law? That's now who the Chair sets the SAA on. I sense a lack of balance in the force. But here I am, discussing the seemingly smaller issue tone on mailing lists.

Aspects of this problem are very much sourced from the American culture still dominant in the IETF. That prompts a fictive analogy also taken from American culture; George Lucas intended Star Wars to be commentary on the United States and its governance, shining city on a hill and all.

The Jedi, smug annoying superior mostly-male know-it-all jerks that they are, are completely surprised and upended by someone in a position of power, who starts a minor dispute as a pretext, then relies on a younger apprentice to spur growing conflict and eventually completely destroys the systems of governance, sweeping away the existing power structure and value system  to install a new one of people who think alike, but are programmed to think differently. But that canon was brought into being by an entire movie where there is only one significant woman in leadership, who is permanently annoyed by the actions of al the white men around her and their ongoing maleness. There are lessons in combining those. (Oh, spoiler alerts. sorry.)

Welcome to the Culture Wars. I have a bad feeling about this.  May the RFC Editor be with you.

L.

If you need me, I'll be in an Australian desert, under a single blazing sun.

Lloyd Wood [email-masked] http://about.me/lloydwood

---

From: Larry Masinter <[email-masked]>
Date: Tue, 18 Aug 2020 22:14:44 -0700

+1

> -----Original Message-----
> From: ietf <[email-masked]> On Behalf Of [email-masked]
> Sent: Tuesday, August 18, 2020 9:48 PM
> To: [email-masked]
> Subject: Thoughts about the IETF mailing list discussion
> 
> Well, I'm back from a five-day 'voluntary posting ban' imposed by the Sergeant-
> At-Arms (SAA) on August 12th, under direction of the IETF Chair, after being
> accused of being 'part of an emerging pattern of abuse' including but,
> presumably, not limited to, my recent emails related to the IESG's
> announcement:
> 
> 
> The SAA offered  me the option of posting its rebuke to me to the mailing list,
> having already quickly announced my ban a couple of times. I said yes to the
> option of them posting that rebuke text in full, but I haven't seen that posted.
> 
> 
> I see that after I was banned, Ohta-san in Tokyo and M. Kobeissi in Paris
> (France, not Texas) were also promptly banned, and M. Kobeissi's ban was later
> reversed because he kicked up a fuss, and well, bullies are cowards. I do find M.
> Kobeissi's minority-viewpoint arguments quite persuasive. I feel that I'm in
> good company. (I'll note that this trend to replace 'bad' terms is very much in
> vogue in the United States, and that the three people banned for pointing out
> problems with the idea are not in the United States. Interesting, that. I'm
> reasonably sure that list policing should be part of mailing list administration,
> akin to giving a council car parking ticket in a civilized society, and should not be
> at the behest of the IETF Chair's personal direction. IETF mailing lists are for
> focused debate on topics, not just for me-too +1 agreement that avoids censure
> by the Sergeants.)
> 
> 
> Unsurprisingly, I have some specific and some more general thoughts on this..
> No great realizations, alas; more a collection of pointers to stuff I hadn't been
> tracking closely that indicate a trend I hadn't paid much attention to but you,
> dear reader, have probably noticed.
> 
> 
> The discouraging-bad-terminology draft discussion that kicked this off is very
> much a red herring testing the waters, and in my opinion is simply another play
> in pushing issues in terms of how speech is policed, how IETF mailing lists are
> run and how discussion is conducted, to be escalated slowly but ultimately to
> how the IETF itself is run and what goals are set for it. Change comes from
> within, an avalanche needs a first rock to fall, a journey starts with a single step,
> all that.
> 
> 
> The IETF is set up on mailing lists to do its work, and, in these days of COVID
> and forced distanced working, needs them more than ever. Mailing lists are
> where the bulk of IETF work is done, directions are decided, drafts are
> discussed, and many decisions are taken.
> 
> 
> Mailing-list etiquette is imo not difficult for an adult to master. Don't be an ass,
> argue the point, not the person, try to avoid ad hominem and bad rhetoric,
> make a point that is relevant and do try and write well; you're taking the
> attention of a lot of people, many who may disagree with you, some strongly.
> At least be polite (though expectations of what politeness entails and its
> customs do vary). If you're not, you'll get called on it. Be interesting, if you can.
> Being entertaining is a welcome, if rare, bonus.
> 
> 
> And yet, it seems that we have been Doing Mailing Lists Wrong All This Time..
> Not inclusive enough? Toxic? That's not my experience; I find IETF-Discuss to be
> nowhere near as toxic as many other places can be, Twitter included, and
> there's a widely shared view of what the list is about and is for. Written down,
> codified.
> 
> 
> I do find that automatic filtering of list mails into list mailboxes and threading of
> subjects provides useful distancing from topics and allows focusing my
> attention. I can come and go from IETF-Discuss or from various working group
> discussions without any undue emotional attachment, but then I'm not
> required to read or comment on everything. Or, because it's the IETF and I'm
> just a peon, anything. But that's just my experience.
> 
> 
> Now, we've had IETF chairs who were criticized for paying too much attention
> to Cisco, and for not paying enough attention to Cisco (that was the same guy,
> at the same time). We've had chairs that had doubts about evolution or
> believed that all problems could be resolved by thinking about them on a cross-
> country ski trip. But as far as I know we've never before had a chair that didn't
> like reading IETF mailing lists because they were felt to be painful. The 'I can't
> read the mailing list now, because feelings' is now a trope that now seems to
> be recurring, even among people in senior roles. Emotions are not just being
> brought to the table, but are actually being expressed, with actual words.
> 
> 
> These emotional responses and just-can't-deal-with-it statements are odd for
> me to see, especially from people posting about drafts they're invested in -- and
> receiving feedback on their drafts that they don't like to read, then calling foul. I
> do wonder what mail filtering and threading, if any, they're using, and what
> distancing that affords them mentally.
> 
> 
> But mailing lists are how topics are debated in the IETF. One might wonder, if it
> can't be discussed on any mailing list, perhaps it is not a topic for the IETF or
> IETF contributors? Is an absent IETF contributor who doesn't contribute to
> mailing lists still a contributor? This is the kind of philosophy Wittgenstein's
> Tractatus 7 gets into.
> 
> 
> Is someone who doesn't want to be there not there simply because they just
> don't want to be there? Or because they're not interested? Or feel oppressed?
> By a mailing list? Surely only the putative contributor can decide if they need to
> be there? And if they really need to be there, they'll be there? Despite the pain
> of reading the mailing list? Can they work through the pain of the mailing list
> and of having to listen to other people whose opinions are as valid as theirs
> are? And can they set up a separate mailbox for it? Is their presence on the list
> felt by their very absence? Does the list discussion call out for them? Is reading
> disagreement that painful? Do they feel as oppressed by reading journalism? Is
> hell other people, and their loud opinions?  Thanks, Sartre. Not easy questions
> to answer.
> 
> 
> But if it's a matter of tone: the problem is apparently really Loud Men Talking
> Loudly on this list, which is what men are wont to do, and which is indeed
> exactly what I am doing right now.One can be loud, but also quite self-aware.
> And this male behaviour has, of course, already been called out As Wrong. Even
> though I'm engaging with the list and the subject matter.
> 
> 
> (via the Oxford Internet Institute, which awarded Cooper's doctorate. It really is
> a small world. But there's a good simple rejoinder to much of that world:
> https://twitter.com/Nathabeer/status/1294353253463928835
> 
> "To be frank, one of the worst encounters I experienced in the IETF was with
> some women. I didn't experience sexism but bullying by other women because
> I didn't feel the need to join a women-only group.")
> 
> 
> It's interesting how this sort of material moves quickly from anthropological
> analysis to prescriptive action. It's very much like 'Boys: They won't do what
> they are told and get distracted in class' or 'Men and Sportsball: What can we
> do about it?'
> 
> 
> Well, we can always make Sportsball more inclusive. Remove violent tackles
> from rugby, change the rules, give everyone a ball. But at some point, it ceases
> to lose its activity and purpose, just as eventually, reasoned debate that is too
> watered down ceases to be useful debate; it degenerates into a series of
> unending "+1"s.
> 
> 
> If you don't want to play sportsball to progress the state of the art, you
> shouldn't have to. Deliberately working to include people who really don't like
> sportsball and who stand on the sidelines saying that it's played all wrong, or
> try to play to their own rules and promptly take their ball home, is simply too
> difficult. (Those sidelines are Twitter commentary, these days. Many Twitter
> involved - ahem, IETF tweeps - remain _completely appalled_ by this mailing
> list. But I should also say that vast chunks of Twitter do remain completely
> devoted to Sportsball, showing that sometimes a metaphor is just a metaphor.)
> 
> 
> I note that the IETF Chair is also the Area Director for GENDISPATCH (I would
> have thought that either in itself would be a fulltime role, as is staying woke),
> and that the GENDISPATCH terminology draft was written by Mallory Knodel,
> who, just as Cooper was, is at the Center for Democracy and Technology. That's
> a primarily-US lobbying organisation, pleased to be disrupting the IETF:
> 
> 
> https://cdt.org/insights/pushing-internet-standards-governing-body-ietf-to-
> tackle-discriminatory-and-exclusionary-terminology/
> 
> 
> You'd think a Center for Democracy and Technology would be more interested
> in spending time on the upcoming US election, on say, the democratic
> technology of voting machines and ensuring that a federal republic with mass
> disenfranchisement and a skewed voting college at least pretends to resemble
> a democracy to some degree, but here we are. Promoting US-style democracy
> is laudable, but fixing it is not. Anyway, probably too late for that. Pick the
> battles that you might win, in line with larger goals.
> 
> 
> Knodel's also running the IRTF Human Rights Protocol Consideration group,
> which had a feminist take on how the IETF should be:
> 
> Certainly new territory to be explored; I've certainly never given
> intersectionality its due when designing protocols or state machines.
> 
> 
> Ultimately, beyond the IETF-discuss mailing list, this seems to be a growing
> trend in approaching IETF governance, and who gets to choose how things are
> run. Or, at least, an opening volleys of sorts in beginning that effort. It's less
> technical but far more political, and this particular politics has some external,
> well-funded, lobbyists.
> 
> 
> The problem with discussing politics is that separating the person from the
> political viewpoint held is often far harder to do cleanly, and motives and
> purpose come into it more. It's more difficult to not go ad-hominem. Still, most
> IETF participants have external funding of some sort, and everyone has a
> viewpoint. But one rather wishes that the lobbying and politicking to set the
> direction of governance was a bit more transparent in stating its larger goals.
> 
> 
> Speaking of governance, separation of powers is commonplace in democracies:
> the _trias politica_ of legislature; executive; and judiciary, though that and the
> rule of law are often under attack.
> 
> 
> In the IETF, we have approximations in the IAB, the IESG, and the RFC-Editor,
> though we've been without a proper RFC-Editor for well over a year. Publishing
> judgement and technical gatekeeping has been weakened administratively over
> the years, if you like. It can be argued that the power of the RFC Editor has been
> considerably diminished since the glory days of Postel, and that remediating
> steps have not been enough. Discussions about language and discussions just
> distract from that. Rule of law? That's now who the Chair sets the SAA on. I
> sense a lack of balance in the force. But here I am, discussing the seemingly
> smaller issue tone on mailing lists.
> 
> 
> Aspects of this problem are very much sourced from the American culture still
> dominant in the IETF. That prompts a fictive analogy also taken from American
> culture; George Lucas intended Star Wars to be commentary on the United
> States and its governance, shining city on a hill and all.
> 
> 
> The Jedi, smug annoying superior mostly-male know-it-all jerks that they are,
> are completely surprised and upended by someone in a position of power, who
> starts a minor dispute as a pretext, then relies on a younger apprentice to spur
> growing conflict and eventually completely destroys the systems of governance,
> sweeping away the existing power structure and value system  to install a new
> one of people who think alike, but are programmed to think differently. But
> that canon was brought into being by an entire movie where there is only one
> significant woman in leadership, who is permanently annoyed by the actions of
> al the white men around her and their ongoing maleness. There are lessons in
> combining those. (Oh, spoiler alerts. sorry..)
> 
> 
> If you need me, I'll be in an Australian desert, under a single blazing sun..
> 
> 

--
https://LarryMasinter.net https://interlisp.org