Subject: Pandemic Acronym Collisions

From: Michael Thomas <[email-masked]>
Date: Sat, 8 Aug 2020 11:53:59 -0700

SIP, PPP...If I see Inter-Entubation Tracheotomy Facilitator I'm going 
to die.

Mike

---

From: "John Levine" <[email-masked]>
Date: 8 Aug 2020 21:45:38 -0400

>SIP, PPP...If I see Inter-Entubation Tracheotomy Facilitator I'm going 

See https://essentialtremor.org/

R's,
John