Subject: Re: New Version Notification for draft-nottingham-discussion-recharter-00.txt

From: Dick Franks <[email-masked]>
Date: Mon, 17 Aug 2020 21:59:37 +0100

1.1. The IETF discussion list is not representative

>8

   As of writing, the IETF discussion list has 1,751 members who have
   made their e-mail address public; 29 members have not made their
   addresses public.

   Comparing its membership to a sample of other IETF mailing lists, we
   find that there are typically many members that are not taking part
   on the IETF discussion list:

           +-------------+---------+---------+----------------+
           | List        | Members | Overlap | % on IETF list |
           +-------------+---------+---------+----------------+
           | 6MAN        | 1,698   | 246     | 14.5%          |
           | DISPATCH    | 436     | 111     | 25.5%          |
           | DNSOP       | 1,041   | 204     | 19.6%          |
           | GENDISPATCH | 54      | 37      | 68.5%          |
           | OPSAWG      | 423     | 100     | 23.6%          |
           | QUIC        | 853     | 121     | 14.2%          |
           | RTGWG       | 610     | 119     | 19.5%          |
           | SECDISPATCH | 153     | 50      | 32.7%          |
           | TLS         | 1,257   | 134     | 10.7%          |
           | WEBTRANS    | 110     | 39      | 35.5%          |
           | WPACK       | 98      | 24      | 24.5%          |
           +-------------+---------+---------+----------------+

   When combined, the lists above have 5,355 unique addresses
   subscribed; only 628 (11.7%) of them are on the IETF discussion list.

Whether there are 628 or 1751 participants on the IETF list, it is still an
order of magnitude more representative than the miserable tally of 54
subscribers to the GENDISPATCH list.

As has been noted elsewhere, moving discussion of contentious issues off
the IETF list is a ruse by political axe-grinders and apparatchiks to avoid
challenge or proper scrutiny.

Dick Franks
________________________

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Aug 2020 10:23:50 +1200

On 18-Aug-20 08:59, Dick Franks wrote:
...
> Whether there are 628 or 1751 participants on the IETF list, it is still an order of magnitude more representative than the miserable tally of 54 subscribers to the GENDISPATCH list.
> 
> As has been noted elsewhere, moving discussion of contentious issues off the IETF list is a ruse by political axe-grinders and apparatchiks to avoid challenge or proper scrutiny.

These two polemic sentences deserve careful deconstruction.

1. There are about 1700 members of the IETF list. There is no "whether" about it.

2. In my experience over the last 10 or so years, a large proportion of IETF participants that I have encountered are absolutely not interested in IETF policies, process issues, or administrative matters. They are interested in the technical work of specific WGs. This is anecdotal, but the fact that only 54 people have bothered to subscribe to GenDispatch seems to confirm it. 

For more confirmation, let's look back at February 2009 in the data provided by Jay:

ietf-announce 3227  (presumptively, that counts everybody seriously interested)
i-d-announce  2492  (everybody who chose to track new drafts)
ietf          1834  (presumptively, everybody interested in plenary discussion)
ipr-wg         189
newtrk          97

The last two are the only process-related lists I noticed in the 2009 data. Again, this confirms my anecdotal input: 189/3227 is 6%, 189/1834 is 10%.

Most people *simply don't care*. I'd be happy to see more people on GenDispatch, but its participation is not out of line (after all, it's not even chartered to adopt and process drafts, only to recommend what should happen to them).

"miserable tally" is a tendentious misstatement.

3. Moving contentious issues to dedicated open lists does not suppress debate. It's been a standard method in the IETF for at least 25 years, because it encourages more structured debate among people who care, and reduces annoyance to people who don't care. Since, on the evidence, at most about 10% of people on the ietf list care about such things, moving a topic to a dedicated list is a kindness to the other 90%.

Calling it a "ruse" is a tendentious misstatement.

4. "political axe-grinders" is simply absurd. Firstly, I can't see where "political" comes in, except as the adjective derived from "policy". Yes, the IETF has policies. So what? Secondly "axe-grinders" is just a snarky way of referring to people who have a point of view that the writer doesn't like. So "political axe-grinders" is really just a way of saying "people I disagree with."

5. "apparatchiks" is just incorrect as well as insulting. The people in IETF leadership positions are put there by a community process called BCP10 for fixed terms. If you don't like what they do, see BCP10 for remedies.

6. "to avoid challenge or proper scrutiny" is just incorrect. GenDispatch is a WG with, of course, an open mailing list. If you don't like what they do, see BCP9 for remedies.

    Brian

---

From: Keith Moore <[email-masked]>
Date: Tue, 18 Aug 2020 04:49:08 -0400

On 8/17/20 6:23 PM, Brian E Carpenter wrote:

> 3. Moving contentious issues to dedicated open lists does not suppress debate.

I disagree somewhat, at least for issues that impinge on multiple areas 
of interest.  Every new list that a participant has to subscribe to in 
order to participate, is another impediment to broad participation.

I readily agree that the vast majority of IETF participants don't want 
to be bothered with administrative, policy, and process issues (and 
shouldn't need to be bothered by such things) - /unless/ they perhaps 
threaten fundamental or significant changes to how IETF works.   The 
question in my mind is: How to identify those issues, make the broader 
population aware of them, and make it easy to participate should they 
choose to do so (without bothering them if they don't)?

The low subscriber count to gendispatch is an indication that 
gendispatch isn't a great place to initially discuss, or dispatch, 
potentially controversial topics of widespread interest - precisely 
because its use in such instances would hide potentially controversial 
discussions from broad scrutiny.   And by the time a WG gets chartered, 
it's generally too late to fix its scope.

Sure, WG charters under consideration are posted to ietf-announce, but 
what percentage of participants really has time to read everything that 
gets posted to ietf-announce?  IMO that's another barrier to effective 
participation.

IMO the problem is _mostly_ a tools problem.   It seems like we could do 
a lot better at making it easy for participants to be aware of what's 
going on, without having to slog through enormous numbers of email 
messages.

Keith