Subject: We could learn from ISO

From: "Salz, Rich" <[email-masked]>
Date: Mon, 24 Aug 2020 14:50:30 +0000

Reading this document surprised me, particularly this section:  https://isocpp.org/std/standing-documents/sd-4-wg21-practices-and-procedures#consensus  What’s the difference between IETF “rough consensus” and ISO “consensus” ?  But there’s much good in the whole thing.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Aug 2020 17:19:53 +0200

Fixed the subject line for you.

(This is the group that elevates C++ to ever more surprising zeniths (*))

> On 2020-08-24, at 16:50, Salz, Rich <rsalz=[email-masked]> wrote:
> 

Well, there are pockets of wisdom in some ISO WGs, just like there is TC39 in ECMA.  We could learn (and adopt/adapt some process ideas, like TC39’s stages) from them.  But the useful processes usually have a very narrow scope and might not work 1-to-1 on our standardization projects.

Grüße, Carsten

(*) I briefly contributed to C++ standardization around the turn of the century, when this was still done via national body meetings.
Having worked in ISO for a large part of the 1980s, I almost fell off my chair reading the original subject line.

---

From: Michael StJohns <[email-masked]>
Date: Mon, 24 Aug 2020 11:40:46 -0400

On 8/24/2020 10:50 AM, Salz, Rich wrote:
> What’s the difference between IETF “rough consensus” and ISO “consensus” ?

Generically, its who has standing to be counted for consensus.

E.g.

> To have a say in approval polls, or for longer-term participation, 
> normally you would join your national body (NB); please consult your 
> nation’s body for specific information, as each NB has its own rules 
> and requirements. A second option is that it is also possible for 
> anyone to join the United States national body, which permits non-U.S. 
> members and accepts just about anyone who wants to pay US$1,950 a year 
> to be a member; a number of our international participants use this 
> option when it’s significantly cheaper than what their own national 
> body charges.

Also, that link was for defining consensus for one work group under one 
subcommittee of ISO and probably shouldn't be generalized to apply to 
more than that.

Later, Mike

---

From: "John Levine" <[email-masked]>
Date: 24 Aug 2020 13:51:27 -0400

In article <[email-masked]> you write:
>-=-=-=-=-=-
>Reading this document surprised me, particularly this section: 
>https://isocpp.org/std/standing-documents/sd-4-wg21-practices-and-procedures#consensus  What’s the difference between IETF
>“rough consensus” and ISO “consensus” ?  But there’s much good in the whole thing.

That definition of consensus is the one that most of the world uses.

A key part of it is that all of the participants need to respect the
process enough to be willing to "stand aside" when they disagree with
the result of the group, but believe a decision was made in good faith
for plausible reasons. Blocking objections and appeals are kept for
exceptional situations.

Unfortunately, you only need a few people willing to die on every
molehill to blow up a consensus process. IETF rough consensus more or
less appoints WG chairs and the IESG to decide when the molehillers
would have stood aside.

R's,
John

---

From: Sylvain Hellegouarch <[email-masked]>
Date: Mon, 24 Aug 2020 20:18:44 +0200

> for plausible reasons. Blocking objections and appeals are kept for
How does one decide when a fight is the good fight and who makes that call
though?

If we are still reflecting on the initial debate on language policy, some
folks felt this was worth arguing about. Who can decide if that was wrong
or not?
I can't recall the group even came to a result in that case (which again
I'm assuming is why there is such a debate about changing the way this
works, or maybe I'm missing something)
So could this process of standing aside have worked?

-- 
- Sylvain Hellegouarch

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Aug 2020 20:26:00 +0200

On 2020-08-24, at 20:18, Sylvain Hellegouarch <[email-masked]> wrote:
> 
> How does one decide when a fight is the good fight and who makes that call though?

Works better for technical than for non-technical questions.
Works worst for non-technical questions that are mistakenly approached like technical ones.
(Which some IETFers are very prone to, worse so if the question isn’t brought up properly in the first place.)

Grüße, Carsten

---

From: Miles Fidelman <[email-masked]>
Date: Mon, 24 Aug 2020 14:30:54 -0400

It occurs to me how useful this would have been in the Linux community - 
over the systemd issue.

On 8/24/20 10:50 AM, Salz, Rich wrote:
> https://isocpp.org/std/standing-documents/sd-4-wg21-practices-and-procedures#consensus 
> What’s the difference between IETF “rough consensus” and ISO 
> “consensus” ?  But there’s much good in the whole thing.
>
-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

Theory is when you know everything but nothing works.
Practice is when everything works but no one knows why.
In our lab, theory and practice are combined:
nothing works and no one knows why.  ... unknown

---

From: Nico Williams <[email-masked]>
Date: Mon, 24 Aug 2020 13:46:12 -0500

> less appoints WG chairs and the IESG to decide when the molehillers

Not so.  Rough consensus does not mean unanimity.  I've been on the
rough side of consensus even when I thought I had a winning technical
argument.  Rough consensus does mean that we need an authority to decide
it, and that is typically a WG chair for WG consensus, and so on.  And
consensus calls can be challenged via appeals.  That's the process.
Being willing to die on a hill cannot stop a document progressing as-is
if the IETF is intent on publishing it.

---

From: "John R Levine" <[email-masked]>
Date: 24 Aug 2020 15:02:45 -0400

> How does one decide when a fight is the good fight and who makes that call

Yes, that is the hard part.  I have found that a large part of successful 
consensus is trying to listen hard and understand other people's 
positions, rather than repeating one's own over and over.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Keith Moore <[email-masked]>
Date: Mon, 24 Aug 2020 15:24:53 -0400

On 8/24/20 3:02 PM, John R Levine wrote:

> I have found that a large part of successful consensus is trying to 
> listen hard and understand other people's positions, rather than 
> repeating one's own over and over. 

+1