Subject: Messages from the ietf list for the week ending Sun Aug 16 14:36:38 2020

From: "John Levine" <[email-masked]>
Date: 16 Aug 2020 18:36:16 -0000

9 | 142854 | Khaled Omar <[email-masked]>
 10 |  97462 | Salz, Rich <[email-masked]>
 10 |  65947 | Nico Williams <[email-masked]>
  6 |  51868 | Sergeant-at-Arms <[email-masked]>
  4 |  51788 | Richard Barnes <[email-masked]>
  9 |  47815 | Dan Harkins <[email-masked]>
  4 |  47684 | Lloyd Wood <[email-masked]>
  5 |  47582 | Nadim Kobeissi <[email-masked]>
  9 |  46902 | Toerless Eckert <[email-masked]>
  7 |  45534 | Joe Touch <[email-masked]>
  2 |  36733 | Kyle Rose <[email-masked]>
  3 |  32019 | Leif Johansson <[email-masked]>
  6 |  29843 | Benjamin Kaduk <[email-masked]>
  3 |  29838 | Michael StJohns <[email-masked]>
  6 |  29592 | S Moonesamy <[email-masked]>
  1 |  28228 | Eric Heflin <[email-masked]>
  1 |  24819 | Eric Vyncke (evyncke) <[email-masked]>
  6 |  23828 | Masataka Ohta <[email-masked]>
  4 |  21795 | Melinda Shore <[email-masked]>
  3 |  20891 | Brian E Carpenter <[email-masked]>
  5 |  20385 | Carsten Bormann <[email-masked]>
  3 |  20141 | John C Klensin <[email-masked]>
  2 |  20070 | Mary B <[email-masked]>
  2 |  18282 | Marc Petit-Huguenin <[email-masked]>
  3 |  17482 | Joel M. Halpern <[email-masked]>
  3 |  17267 | Keith Moore <[email-masked]>
  3 |  16417 | STARK, BARBARA H <[email-masked]>
  2 |  16280 | Scott O. Bradner <[email-masked]>
  3 |  16065 | Lars Eggert <[email-masked]>
  1 |  15629 | Martin Duke <[email-masked]>
  2 |  15497 | Larry Masinter <[email-masked]>
  1 |  15400 | Suresh Krishnan <[email-masked]>
  2 |  15251 | Timothy Mcsweeney <[email-masked]>
  2 |  14787 | IETF Chair <[email-masked]>
  2 |  14414 | Eric Rescorla <[email-masked]>
  1 |  14407 | Rob Wilton (rwilton) <[email-masked]>
  1 |  14037 | Charlie Perkins <[email-masked]>
  2 |  13067 | Yoav Nir <[email-masked]>
  1 |  12924 | Ted Hardie <[email-masked]>
  2 |  12643 | David Schinazi <[email-masked]>
  3 |  12567 | Viktor Dukhovni <[email-masked]>
  2 |  12349 | Warren Kumari <[email-masked]>
  1 |  12144 | Bron Gondwana <[email-masked]>
  1 |  11404 | tom petch <[email-masked]>
  1 |  11205 | Robert Raszuk <[email-masked]>
  1 |  10141 | Marc Petit-Huguenin <[email-masked]>
  1 |  10024 | Ladislav Lhotka <[email-masked]>
  2 |   9503 | John Levine <[email-masked]>
  1 |   9287 | Fred Baker <[email-masked]>
  2 |   9007 | Paul Wouters <[email-masked]>
  1 |   7751 | Vittorio Bertola <[email-masked]>
  1 |   7618 | Bob Hinden <[email-masked]>
  1 |   7038 | Joel Halpern Direct <[email-masked]>
  1 |   6909 | Alissa Cooper <[email-masked]>
  1 |   6716 | Rob Sayre <[email-masked]>
  1 |   6618 | Christian Huitema <[email-masked]>
  1 |   6612 | Wendy Seltzer <[email-masked]>
  1 |   6159 | Murray S. Kucherawy <[email-masked]>
  1 |   6049 | Theresa Enghardt <[email-masked]>
  2 |   5985 | Randy Bush <[email-masked]>
  2 |   5885 | Paul Hoffman <[email-masked]>
  1 |   5621 | Martin Thomson <[email-masked]>
  1 |   5575 | Stewart Bryant <[email-masked]>
  1 |   5553 | Miles Fidelman <[email-masked]>
  1 |   5444 | Christopher Morrow <[email-masked]>
  1 |   5431 | Jen Linkova <[email-masked]>
  1 |   5360 | Patrik =?utf-8?b?RsOkbHRzdHLDtm0=?= <[email-masked]>
  1 |   5201 | Pete Resnick <[email-masked]>
  1 |   5110 | Carlos M. Martinez <[email-masked]>
  1 |   4692 | Barry Leiba <[email-masked]>
  1 |   4030 | Dorian Kim <[email-masked]>
  1 |   3691 | Ross Finlayson <[email-masked]>
  1 |   3532 | Nick Hilliard <[email-masked]>
  1 |   3304 | Ofer Inbar <[email-masked]>
  1 |   3238 | Jared Mauch <[email-masked]>
  1 |   3014 | Wes Hardaker <[email-masked]>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 16 Aug 2020 14:58:46 -0400

>   1 |   3014 | Wes Hardaker <[email-masked]>

Is it HTML formatting, bottom quoting, or email header explosion (or some
combination of the above) that leads the smallest individual email on the
list this past week to be 3014 bytes in length? (I didn't bother to average
the email lengths from multi-posters).

For what it's worth, I'm trying to send this without formatting and with
minimal quoting to see how small I can get it. Now I have to try to refrain
from posting anything else on the list this week ... :-)

Cheers,
Andy

---

From: tom petch <[email-masked]>
Date: Mon, 17 Aug 2020 10:43:57 +0100

> from posting anything else on the list this week ... :-)

Andrew,

e-mail header explosion by the ESP in part, HTML in part.

The plain text announcement of an RFC on the announce list is 2kbyte to 
3kbyte.  In 2012, that was up to 6kbyte by the time I received it.  In 
2013 that jumped to 9kbyte and in 2015 to 12kbyte and in 2016 to 
16kbyte.  In 2019, it went down to 11kbyte.  The difference is mostly in 
the x- headers with X-Microsoft-Antispam-Message-Info
being enormous.

HTML varies a lot.  Your message reached me as 13423byte; removing HTML 
takes that down to 12193byte while removing the X- headers cuts that to 
6207byte.  At the MSA stage it was probably 1270byte if it were plain 
text only.

BUT this message is a very conservative use of HTML.  Some MUA like to 
include the Microsoft style sheet which can expand a message from 
10kbyte to over 100kbyte - yes, one hundred. As a rule of thumb I would 
say that a multipart alternative with HTML is about twice the size of a 
plain text message.

I select the MUA option of plain text and think that the security of the 
IETF system, and the usability of web mail, would be improved if that 
were mandatory:-)

HTH

Tom Petch

---

From: tom petch <[email-masked]>
Date: Mon, 17 Aug 2020 17:03:53 +0100

> IETF system, and the usability of web mail, would be improved if that

Just to add to my earlier figures what may, or may not, be obvious, 
John's figures come from IMAP with the data on the server whereas mine 
come after the e-mail has been downloaded with POP3, which means that it 
has passed through more MTA, every one of which adds a header or two, so 
John records me as posting one e-mail of 11404 byte but by the time I 
had downloaded it, that had grown to 18646 byte.  I think that John's 
figures include all the headers that it took to get the e-mail to the 
server.  I note that the addition of large anti-spam headers can occur 
prior to arrival on the server, in which case they would count toward 
the IMAP figure, during the download with POP3 or both; it depends on 
the policy of the ESP involved.

If, by  bottom posting, you mean keeping all the previous exchanges, 
then each addition is likely to be a few kbyte so it builds up and a 
single, plain text e-mail can grow to tens of kbyte, even 100 or more. 
Where the text goes, in plain text, has little or no impact.  Where my 
response includes the e-mail headers from previous posts, then I tend to 
edit the headers to just sender and date, which saves a few bytes but 
saves several lines of display so users have less to scroll down.

> .

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 17 Aug 2020 16:22:24 +0000

Does it matter about mail headers, etc.?  The point is to look at number of postings and relative size.  As long as all measurements are done at the same place, that's fine.

---

From: "John R. Levine" <[email-masked]>
Date: 17 Aug 2020 12:43:04 -0400

> Does it matter about mail headers, etc.?  The point is to look at number of postings and relative size.  As long as all measurements are done at the same place, that's fine.

Of course.

There is a long tradition of old-timers grousing about how bloated modern 
mail messages have become.  On the one hand they're right, turning 2K of 
text into 50K of bloat is silly.  On the other hand, people less set in 
their ways than we are find it normal and useful that they can format 
their mail the same way they can format any other document.  And on the 
third hand, in a world of streaming video, the total storage and bandwidth 
that mail uses, bloat and all, is a rounding error.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

PS: in response to several requests, next week's summary will be sorted 
by number of messages rather than size.

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 17 Aug 2020 18:48:31 +0200

On 2020-08-17, at 18:43, John R. Levine <[email-masked]> wrote:
> 
> And on the third hand, in a world of streaming video, the total storage and bandwidth that mail uses, bloat and all, is a rounding error.

I’m more concerned about human bandwidth (*).

So if we can find a closer proxy for how much human bandwidth a set of messages consumes, that would be useful.  Starting with not counting headers certainly is.

BTW, modern mail readers typically can “mute” a conversation, so in many cases, if the subject is *not* changed in a sudden logorrhea, the human bandwidth consumed can be 0.

Grüße, Carsten

(*) and, yes, I do recognize there is also emotional bandwidth.  
But that is very hard to measure.  Again, muting may help.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 17 Aug 2020 13:11:52 -0400

> Does it matter about mail headers, etc.?  The point is to look at number of postings and relative size.  As long as all measurements are done at the same place, that's fine.

Indeed -- I think we need to make sure we are not losing sight of the
*purpose* of this -- I had always understood it to be a signal to the
top posters that they may be dominating the conversation, and to
consider taking a step back / deep breath and let others speak as
well.

I think that 5 long and considered posting are much much more helpful
(and certainly less harmful) than 25 really short back and forths. I
personally think that the "length" metric should be dropped, or is
just a "meh, 'tis easy to report, why not?!" sort of thing...

W

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 17 Aug 2020 16:37:19 -0400

Warren and Rich,

Of course! My email was triggered by idle curiosity looking at the size of
the messages in the list.

Cheers,
Andy

On Mon, Aug 17, 2020 at 1:12 PM Warren Kumari <[email-masked]> wrote:

> > Does it matter about mail headers, etc.?  The point is to look at number
> of postings and relative size.  As long as all measurements are done at the
> same place, that's fine.
>