Subject: Triple Parentheses vs. Triple Braces

From: Carsten Bormann <[email-masked]>
Date: Tue, 11 Aug 2020 16:55:07 +0200

For those who don’t know what the subject line is talking about, please have a quick look at:

https://en.wikipedia.org/wiki/Triple_parentheses

ASCIIDOC uses (((term))) as the notation to put “term” into the index at its point  (“concealed index term”), a convention that kramdown-rfc copies for its markdown dialect.  
(I’m not planning to fix anything about this until ASCIIDOC offers a replacement that would fit well with markdown; in any case, I’d only add another convention.
Fortunately, the index functionality of RFCXML is rarely used in RFCs.)

With the rise of RFCXMLv3, now I need a more friendly notation for the construct 

	<contact fullName=“Nguyễn Ái Quốc”/>

Am I a complete idiot to think that {{{Nguyễn Ái Quốc}}} is a good way to express this in kramdown-rfc’s markdown dialect, the above notwithstanding?  
It would never be visible as such in published material, only in the markdown source code.

[Searching RFCs, RFC 6386 contains the line
           union mv          chroma_mv[4] = {{{0}}};
in some source code; triple braces are not used anywhere else that I can find.
For another random example, note that Trac's wiki syntax uses {{{…}}} for monospace/code; but there are usually no names of people in those braces.
Since the slur was only invented in 2014, these notations predate that.]

Alternative notations that avoid the obvious trap, are still as easy to read and type, and don’t create new backwards compatibility nightmares, are expressly solicited.  

Sorry for the cross-posting to ietf@; we don’t have a mailing list for this kind of subject yet.  (In case it wasn’t clear, I’m looking for serious opinions here.)

Grüße, Carsten

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Tue, 11 Aug 2020 08:18:28 -0700

Not directly answering, but in AsciiDoc I would suggest `[contact]#Nguyễn Ái Quốc#`, which is similar to the notation for <bcp14> (https://www.metanorma.com/author/ietf/topics/markup/#inline-formatting).

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug