Subject: A Public Option for the Core

From: Lars Eggert <[email-masked]>
Date: Tue, 11 Aug 2020 21:50:11 +0300

Hi,

Scott Shenker et al. just presented a pretty thought-provoking "public option" for the Internet's core backbone at SIGCOMM: https://dl.acm.org/doi/abs/10.1145/3387514.3405875

If you scroll down (or go to https://dl.acm.org/doi/abs/10.1145/3387514.3405875#sec-supp), his recorded talk video gives a high-level overview.

(PDF and video *should* be open access and work for me, but you never know with the ACM...)

Lars

---

From: Paul Wouters <[email-masked]>
Date: Tue, 11 Aug 2020 15:17:06 -0400

How is this different from a non-profit IX ?

How could you prevent ISPs from purposefully ignoring the poc?

Paul

Sent from my iPhone

> On Aug 11, 2020, at 14:50, Lars Eggert <[email-masked]> wrote:
> 
> Hi,
>

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 11 Aug 2020 15:41:50 -0400

> How is this different from a non-profit IX ?

it sounds like the proposal is effectively (to use your example) a
"global non-profit IX".

It sounds like the expectation is likely that:
  1) 'the core' operates globally as a neutral provider
  2) 'the core' offers 'transit' to end-networks (LMPs) at a cost
which is not ... usery
  3) all of the global areas have the same world view on 'Network Neutrality'

It seems ... like a pretty high lift to move from today to the utopia proposed.

---

From: Dorian Kim <[email-masked]>
Date: Tue, 11 Aug 2020 16:00:04 -0400

> On Aug 11, 2020, at 3:43 PM, Christopher Morrow <[email-masked]> wrote:
> 

3 is a high enough bar given the disparity of connectivity and content directives of all the countries in the world, but also this paper seems to be at least 10 years too late given the realities of the transit market globally, and aspirational net neutrality goals aside, seems to be rather inconsistent in its financial analysis.

Cost of building the backbone vs. last mile even by the paper’s own admission is heavily weighted towards the last mile and under such scenario one would think that the significant need for invest in last mile would be the barrier to entry vs. cost of building a backbone which has gotten orders of magnitudes cheaper and continues to do so to a point where non-transit private backbones dominate today’s Internet by traffic volume.

-dorian

---

From: Warren Kumari <[email-masked]>
Date: Tue, 11 Aug 2020 17:14:10 -0400

> It seems ... like a pretty high lift to move from today to the utopia proposed.

Yeah -- the word "utopia" in this is an important one -- if we lived
in a utopia, this proposal seems like it would work - "a rising tide"
and all that. But, in the current (and foreseeable future) the world
just doesn't work like this...

Warren "Cynical" Kumari.

> > > If you scroll down (or go to https://dl.acm.org/doi/abs/10.1145/3387514..3405875#sec-supp), his recorded talk video gives a high-level overview.
> > >

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Aug 2020 10:53:09 +1200

(Bcc to the IETF list and Cc to the architecture-discuss list)

Thanks for circulating this.

> Scott Shenker et al. just presented a pretty thought-provoking "public option" for the Internet's core backbone at SIGCOMM: https://dl.acm.org/doi/abs/10.1145/3387514.3405875

Hmm.

"The technical Internet community has long embraced the notion
that the Internet should be application-neutral; that notion later
became known as network neutrality (a term coined in [57])."

I dispute that assertion. "Network neutrality" is a slippery term,
but certainly there is antipathy between some interpretations of it
and RFC2474 and other QoS technologies.

"We choose instead to initially create the POC’s backbone network out
of a set of leased lines, and use the interconnections to one or more
ISPs as a fallback if the POC’s backbone does not have sufficient
connectivity."

That sounds like a fairly accurate description of the Internet in
about 1995, when ISPs had emerged but the de facto backbone was still
largely non-profit and/or settlement-free. And note that non-profit
transit networks existed then, and actively migrated to a for-profit
model after about 1998. See https://en.wikipedia.org/wiki/EBONE for
an example.

So I think history would likely repeat itself if this proposal was
adopted.

Maybe it's time to update https://tools.ietf.org/html/draft-carpenter-metrics
Reactions to that draft from the then major transit ISPs were interestingly
negative.

   Brian

---

From: Randy Bush <[email-masked]>
Date: Wed, 12 Aug 2020 15:49:32 -0700

> Scott Shenker et al. just presented a pretty thought-provoking "public
> option" for the Internet's core backbone at SIGCOMM:
> https://dl.acm.org/doi/abs/10.1145/3387514.3405875

1993 wants its NAPs back