Subject: IPv10 I-D Destiny.

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 01:48:26 +0000

Hi All,

As all of you now see the great contributions to developing the Internet it is not from the logic point of view to keep watching the division occurs between internet hosts.

As I proposed an I-D earlier that offers a solution to this pandemic that started to be distributed in the internet due to IPv4 address space exhaustion and the no migration to IPv6 occurred till now.

So please take one moment and evaluate the IPv10 I-D and make an accurate decision whether it can be promoted to a Standard or there is another solution that could solve this problem from its roots.

Here is the linky to the IPv10 I-D:

https://tools.ietf.org/html/draft-omar-ipv10-06

THANK YOU,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 04:27:31 +0000

It's really weird to hear the silence for my e-mails at the IETf main list, at the same time, to see insistence with consensus not take any decision or any official announcement to the internet community regarding the division problem, people are in need to get feedback for this issue as this problem affects all internet users, I can't keep making the problem clear more than that as it is obvious for all, time to act positively to get benefits for all.

I write here because I care about solving the problem and can't do more than proposing a solution, please let's put any hat or agenda aside and make an announcement regarding how the IETF is working on solving that problem and I'm sure they have full support from the community as they believe on you, otherwise, it will be a waste of time not to make any discussion regarding this issue to make people feel comfortable.

Khaled Omar

From: ietf <[email-masked]> On Behalf Of Khaled Omar
Sent: Wednesday, August 12, 2020 3:48 AM
To: IETF Discussion <[email-masked]>
Subject: IPv10 I-D Destiny.

Hi All,

THANK YOU,

Khaled Omar

---

From: Lars Eggert <[email-masked]>
Date: Wed, 12 Aug 2020 09:21:20 +0300

Hi,

On 2020-8-12, at 7:27, Khaled Omar <[email-masked]> wrote:
> It’s really weird to hear the silence for my e-mails at the IETf main list,

you gave it not even four hours since your earlier email, which you posted in the middle of the night (European/US time). I am sure you will get feedback shortly (incl. mine below).

> So please take one moment and evaluate the IPv10 I-D and make an accurate decision whether it can be promoted to a Standard or there is another solution that could solve this problem from its roots.

This is not how the IETF operates. Please review RFC2026.

Regarding your proposal, briefly:

(1) A networking architecture consist of much more than a header encoding scheme - that is the easy part.

(2) Simply pointing to IPsec is not a security analysis.

(3) The I-D says "there is no need to think about migration" when there clearly is such a need - the I-D expects all hosts and routers to understand and speak a new packet format.

(4) This paragraph IMO demonstrates best how far from deployment realities the proposal is:

    "IPv10 support on "all" Internet connected hosts can be deployed
     in a very short time by technology companies developing OSs
     (for hosts and networking devices, and there will be no
     dependence on enterprise users and it is just a software
     development process in the NIC cards of all hosts to allow
     encapsulating both IPv4 and IPv6 in the same IP packet header."

Sorry, but this is unpublishable.

Lars

---

From: IETF Sergeant at Arms <[email-masked]>
Date: Wed, 12 Aug 2020 17:55:39 +0530

Hi all,

We wanted to let the list know that the sergeant-at-arms (SAA) team 
(described in more detail at [1]) consider this thread [2] to be more 
appropriate for [email-masked] [3]. And as per the IETF discussion 
list charter [4], we suggest that the discussions should be moved to the 
more specific forum identified.

Thanks,
Dhruv Dhody on behalf of the SAA team

[1] https://www.ietf.org/how/lists/discussion/
[2] https://mailarchive.ietf.org/arch/msg/ietf/c8Un1c9wNrXUrzPOci_EdLEHBNY/
[3] https://www.ietf.org/mailman/listinfo/int-area
[4] https://tools.ietf.org/html/rfc3005

---

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 12 Aug 2020 14:34:11 +0200

> more specific forum identified.

Can this possibly ever help? Here is my message that I sent to this list
almost four years ago:

https://mailarchive.ietf.org/arch/msg/ietf/xIm0l6b24OGljNzZsKzLhGFGxMU/

Lada

>> you gave it not even four hours since your earlier email, which you
>> posted in the middle of the night (European/US time). I am sure you
>> will get feedback shortly (incl. mine below).
>>
>>> As I proposed an I-D earlier that offers a solution to this pandemic
>>> that started to be distributed in the internet due to IPv4 address
>>> space exhaustion and the no migration to IPv6 occurred till now.
>>>
>>> So please take one moment and evaluate the IPv10 I-D and make an
>>> accurate decision whether it can be promoted to a Standard or there
>>> is another solution that could solve this problem from its roots.
>>
>> (3) The I-D says "there is no need to think about migration" when
>> there clearly is such a need - the I-D expects all hosts and routers
>> to understand and speak a new packet format.
>>

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 13:25:57 +0000

Hi Liars,

>> you gave it not even four hours since your earlier email, which you posted in the middle of the night (European/US time). I am sure you will get feedback shortly (incl. mine below).

Last time before this time I got zero response that's why I send another e-mail regardless the different time zones.

>> This is not how the IETF operates. Please review RFC2026.

I don't know which way the IETF would like to work, I tried many ways and all are in vain, there should be a different approach specially for urgent problems that can harm all internet users.

>>> (1) A networking architecture consist of much more than a header encoding scheme - that is the easy part.

Yes, this is very easy.

>>> (2) Simply pointing to IPsec is not a security analysis.

There is no need to security analysis, just mixing the two versions on one header.

>>> (3) The I-D says "there is no need to think about migration" when there clearly is such a need - the I-D expects all hosts and routers to understand and speak a new packet format.

Again, this is not called migration, this is called updating.

Where is the problem.

Best Regards,

Khaled Omar

-----Original Message-----
From: Lars Eggert <[email-masked]> 
Sent: Wednesday, August 12, 2020 8:21 AM
To: Khaled Omar <[email-masked]>
Cc: IETF Discussion <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

Hi,

Lars

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 13:32:26 +0000

Hi,

>> [1]) consider this thread [2] to be more appropriate for [email-masked]

Ok, but I hope there will be a different evaluation that aims to the benefits of the internet.

>> we suggest that the discussions should be moved to the more specific forum identified.

Online discussions anywhere could help solve the problem, thinking about getting in touch in such situation means we are thinking about something else new.

Best Regards,

Khaled Omar 

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of IETF Sergeant at Arms
Sent: Wednesday, August 12, 2020 2:26 PM
To: [email-masked]
Subject: Re: IPv10 I-D Destiny.

Hi all,

We wanted to let the list know that the sergeant-at-arms (SAA) team (described in more detail at [1]) consider this thread [2] to be more appropriate for [email-masked] [3]. And as per the IETF discussion list charter [4], we suggest that the discussions should be moved to the more specific forum identified.

Thanks,

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 13:36:55 +0000

Hi IntArea WG,

Can we move the discussion to this appropriate WG and of course after the approval of the AD and the Chairs.

Best Regards,

Khaled Omar

From: Khaled Omar

Hi All,

THANK YOU,

Khaled Omar

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 12 Aug 2020 20:09:12 +0200

This topic has been discussed in RTGWG already. You got the feedback.

https://mailarchive.ietf.org/arch/msg/rtgwg/ZrXrtQ2IKM08oRhDxe-OxG4r364/

How much more time we need to spend on something which is not deployable in
practice ?

Thx,
R.

On Wed, Aug 12, 2020 at 6:27 AM Khaled Omar <[email-masked]>
wrote:

> It’s really weird to hear the silence for my e-mails at the IETf main
> list, at the same time, to see insistence with consensus not take any
> decision or any official announcement to the internet community regarding
> the division problem, people are in need to get feedback for this issue as
> this problem affects all internet users, I can’t keep making the problem
> clear more than that as it is obvious for all, time to act positively to
> get benefits for all.
>
>
>
> I write here because I care about solving the problem and can’t do more
> than proposing a solution, please let’s put any hat or agenda aside and
> make an announcement regarding how the IETF is working on solving that
> problem and I’m sure they have full support from the community as they
> believe on you, otherwise, it will be a waste of time not to make any
> discussion regarding this issue to make people feel comfortable.
>
>
>
> Khaled Omar
>
>
>
> *From:* ietf <[email-masked]> *On Behalf Of * Khaled Omar
> *Sent:* Wednesday, August 12, 2020 3:48 AM
> *To:* IETF Discussion <[email-masked]>
> *Subject:* IPv10 I-D Destiny.
>
>
>
> Hi All,
>
>
>
> As all of you now see the great contributions to developing the Internet
> it is not from the logic point of view to keep watching the division occurs
> between internet hosts.
>
>
>
> As I proposed an I-D earlier that offers a solution to this pandemic that
> started to be distributed in the internet due to IPv4 address space
> exhaustion and the no migration to IPv6 occurred till now.
>
>
>
> So please take one moment and evaluate the IPv10 I-D and make an accurate
> decision whether it can be promoted to a Standard or there is another
> solution that could solve this problem from its roots.
>
>
>

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 18:47:57 +0000

Hi Alllll,

Maybe there is confusion at the ietf, KRP is different than IPv10 I-D.

Khaled Omar

From: Robert Raszuk <[email-masked]>
Sent: Wednesday, August 12, 2020 8:09 PM
To: Khaled Omar <[email-masked]>
Cc: IETF Discussion <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

How much more time we need to spend on something which is not deployable in practice ?

Thx,
R.

On Wed, Aug 12, 2020 at 6:27 AM Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
It’s really weird to hear the silence for my e-mails at the IETf main list, at the same time, to see insistence with consensus not take any decision or any official announcement to the internet community regarding the division problem, people are in need to get feedback for this issue as this problem affects all internet users, I can’t keep making the problem clear more than that as it is obvious for all, time to act positively to get benefits for all.

I write here because I care about solving the problem and can’t do more than proposing a solution, please let’s put any hat or agenda aside and make an announcement regarding how the IETF is working on solving that problem and I’m sure they have full support from the community as they believe on you, otherwise, it will be a waste of time not to make any discussion regarding this issue to make people feel comfortable.

Khaled Omar

From: ietf <[email-masked]<mailto:[email-masked]>> On Behalf Of Khaled Omar
Sent: Wednesday, August 12, 2020 3:48 AM
To: IETF Discussion <[email-masked]<mailto:[email-masked]>>
Subject: IPv10 I-D Destiny.

Hi All,

THANK YOU,

Khaled Omar

---

From: Kyle Rose <[email-masked]>
Date: Wed, 12 Aug 2020 15:31:02 -0400

> Maybe there is confusion at the ietf, KRP is different than IPv10 I-D.

It seems clear there is no interest from IETF participants in pursuing this
work. Consider:

* More than 20 years have passed since IPv6 was published as a proposed
standard.
* IPv6 is in widespread use: for example, roughly 30% of Google's traffic
comes from IPv6 clients.
* There are already numerous v4/v6 transition and interoperability
technologies, and seemingly little appetite for developing any more.

Bringing potential work to the IETF carries the burden of convincing others
to work with you on it. You have not done this, and frankly you are
unlikely to do so as the internet engineering community has decided en
masse that the v4/v6 interoperability problem space has been sufficiently
covered by existing technologies and has moved on to other things.

Kyle

---

From: Joseph Touch <[email-masked]>
Date: Wed, 12 Aug 2020 12:35:36 -0700

> On Aug 11, 2020, at 9:27 PM, Khaled Omar <[email-masked]> wrote:
> 
> It’s really weird to hear the silence for my e-mails at the IETf main list,...

You were told in 2017 that this was not appropriate for this list and to take this topic to INTAREA.

You did and it was discussed and rejected for further discussion here:
https://mailarchive.ietf.org/arch/msg/int-area/cYhjioyneuGF-Y0LEHUiO_p91jo/ <https://mailarchive.ietf.org/arch/msg/int-area/cYhjioyneuGF-Y0LEHUiO_p91jo/>

If you want further consideration:
	a) *significantly* update your proposal, addressing the feedback you received 3 years ago
	b) post a request to evaluate that new proposal to INTAREA

Simply re-posting and re-asking a question isn’t going to change the answer.

PS - the link below is to -06; the most recent (and still expired) is -11.

Joe

>  
> From: ietf <[email-masked] <mailto:[email-masked]>> On Behalf Of Khaled Omar
> To: IETF Discussion <[email-masked] <mailto:[email-masked]>>
> ...
> https://tools.ietf.org/html/draft-omar-ipv10-06 <https://tools.ietf.org/html/draft-omar-ipv10-06>
>  
> THANK YOU,
>  
> Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 19:37:55 +0000

>> You have not done this, and frankly you are unlikely to do so as the internet engineering community has decided en masse that the v4/v6 interoperability problem space has been sufficiently covered by existing technologies and has moved on to other things.

Are people well trained to apply these technologies?

KHALED OMAR

From: Kyle Rose <[email-masked]>
Sent: Wednesday, August 12, 2020 9:31 PM
To: Khaled Omar <[email-masked]>
Cc: Robert Raszuk <[email-masked]>; IETF Discussion <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

On Wed, Aug 12, 2020 at 2:48 PM Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Maybe there is confusion at the ietf, KRP is different than IPv10 I-D.

It seems clear there is no interest from IETF participants in pursuing this work. Consider:

* More than 20 years have passed since IPv6 was published as a proposed standard.
* IPv6 is in widespread use: for example, roughly 30% of Google's traffic comes from IPv6 clients.
* There are already numerous v4/v6 transition and interoperability technologies, and seemingly little appetite for developing any more.

Bringing potential work to the IETF carries the burden of convincing others to work with you on it. You have not done this, and frankly you are unlikely to do so as the internet engineering community has decided en masse that the v4/v6 interoperability problem space has been sufficiently covered by existing technologies and has moved on to other things.

Kyle

---

From: Khaled Omar <[email-masked]>
Date: Wed, 12 Aug 2020 19:39:25 +0000

>> Simply re-posting and re-asking a question isn’t going to change the answer.

I keep asking from time to time as long as I still see the problem goes bigger and affects all, aiming to find some help after these talks.

From: Joseph Touch <[email-masked]>
Sent: Wednesday, August 12, 2020 9:36 PM
To: Khaled Omar <[email-masked]>
Cc: IETF Discussion <[email-masked]>; int-area <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

On Aug 11, 2020, at 9:27 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

You did and it was discussed and rejected for further discussion here:
https://mailarchive.ietf.org/arch/msg/int-area/cYhjioyneuGF-Y0LEHUiO_p91jo/

Joe

...

THANK YOU,

Khaled Omar

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Thu, 13 Aug 2020 12:36:55 +0000

With my INT Area Director hat on:

Thank you Joe for providing the pointer to the previous email exchange.

Khaled, all efforts to improve the Internet are always welcome, but, as Joe, I would like to understand what has changed since 2017 ?

IPv6, that solves the IPv4 issues, is being more and more deployed (actually doubled from January 2017 to August 2020 – even if not fast enough to my taste).

Did you vastly change your proposal ?

Best regards

-éric

From: ietf <[email-masked]> on behalf of Joseph Touch <[email-masked]>
Date: Wednesday, 12 August 2020 at 21:36
To: Khaled Omar <[email-masked]>
Cc: int-area <[email-masked]>, IETF Discussion <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

Joe

...

THANK YOU,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Thu, 13 Aug 2020 14:17:27 +0000

Hi Eric,

Yes, the proposal kept changing to take the best form, the two ID names idea was made to help to reach the final stage of being a standard.

Lets make the problem clear which may help us, the concept is that one size doesn’t fits all, so consensus with this low percentage is critical alarm, can’t fight for my idea in all directions, there are many haters from the community now to this division problem, they wanna do as much support as they can but not to be a factor in the solution, they are affected as all but not their problem.

Best regards,

Khaled Omar

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Eric Vyncke (evyncke) <[email-masked]>
Sent: Thursday, August 13, 2020 2:36:55 PM
To: Joseph Touch <[email-masked]>; Khaled Omar <[email-masked]>
Cc: int-area <[email-masked]>; IETF Discussion <[email-masked]>
Subject: Re: IPv10 I-D Destiny.

Best regards

-éric

Joe

...

THANK YOU,

Khaled Omar