Subject: Re: [Last-Call] Last Call: <draft-ietf-v6ops-cpe-slaac-renum-06.txt> (Improving the Reaction of Customer Edge Routers to Renumbering Events) to Best Current Practice

From: S Moonesamy <[email-masked]>
Date: Tue, 12 Jan 2021 16:35:49 -0800

Hi Fernando,

[I moved the thread to [email-masked]]

At 12:31 PM 01-01-2021, Fernando Gont wrote:
>There was an *error* in how the metadata for the document was set. 
>The track of the document had always been "Informational".

There is an assumption that the "verifications" [1] would catch such 
an error.

>I thought we had responded to all, but since we authors are mere 
>mortals, it could also be the case that we missed some. I will 
>review all received comments (and, in particular, any by Eric) and 
>respond if necessary.
>
>That said, the document is being IETF LC'ed (rather than published 
>by the RFC-Ed), so we're just in time to address anything that we 
>may have missed before.

Are the authors of the opinion that it is unnecessary to respond to 
the comments which were received?

Regards,
S. Moonesamy

1. 
https://www.ietf.org/chairs/document-writeups/document-writeup-working-group-documents/

---

From: Fernando Gont <[email-masked]>
Date: Wed, 13 Jan 2021 02:46:30 -0300

On 12/1/21 21:35, S Moonesamy wrote:
>> There was an *error* in how the metadata for the document was set. The 
>> track of the document had always been "Informational".
> 
> There is an assumption that the "verifications" [1] would catch such an 
> error.

I guess that at the end of the day, we are all mere mortals, and can 
always err/fail. Fortunately, when that happens, somebody else notices 
the problem, and we can fix it.

>> mortals, it could also be the case that we missed some. I will review 
>> all received comments (and, in particular, any by Eric) and respond if 
>> necessary.
>>
>> That said, the document is being IETF LC'ed (rather than published by 
>> the RFC-Ed), so we're just in time to address anything that we may 
>> have missed before.
> 
> Are the authors of the opinion that it is unnecessary to respond to the 
> comments which were received?

I'd have assumed that my comment above already answered this one, before 
you even asked.  (i.e., I noted "I thought we had responded to all...").

I normally respond to all comments, even if just to Ack. Again, we're 
all mere mortals. At times we can unintentionally err or fail. When/if 
we do, a short email is usually more than enough to trigger the fault 
recovery process (e.g., responding to an email that, for some reason, we 
failed to respond).

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: S Moonesamy <[email-masked]>
Date: Wed, 13 Jan 2021 01:15:02 -0800

Hi Fernando,
At 09:46 PM 12-01-2021, Fernando Gont wrote:
>I'd have assumed that my comment above already 
>answered this one, before you even 
>asked.  (i.e., I noted "I thought we had responded to all...").
>
>I normally respond to all comments, even if just 
>to Ack. Again, we're all mere mortals. At times 
>we can unintentionally err or fail. When/if we 
>do, a short email is usually more than enough to 
>trigger the fault recovery process (e.g., 
>responding to an email that, for some reason, we failed to respond).

I have my share of mistakes in the IETF and 
outside the IETF.  However, whether there was a 
mistake on your side or my side is not the main 
point of interest.  I was interested in reading 
the response of the working group on those points 
after going through the relevant RFCs and the 
draft.  My reading of your reply is that a 
response to the comments from Éric is 
unnecessary.  I suggest going for "Informational" 
so as to keep the effort to a minimum.

The following comment is unrelated to the 
draft.  RFC 7772 has two URIs in Section 3.  The 
first URI requires a Google account to access the 
content.  The second URI is redirected to a site about "

white-glove managed cloud services".  The 
guidance for RFCs are for URIs to be stable; that is not the case.

Regards,
S. Moonesamy

---

From: Fernando Gont <[email-masked]>
Date: Wed, 13 Jan 2021 07:17:18 -0300

Hi, SM,

On 13/1/21 06:15, S Moonesamy wrote:
[....]
>> recovery process (e.g., responding to an email that, for some reason, 
>> we failed to respond).
> 
> I have my share of mistakes in the IETF and outside the IETF.  However, 
> whether there was a mistake on your side or my side is not the main 
> point of interest.  I was interested in reading the response of the 
> working group on those points after going through the relevant RFCs and 
> the draft.  My reading of your reply is that a response to the comments 
> from Éric is unnecessary.

Certainly not. What I meant is that if I failed to respond, I will.

In fact, if I failed to respond, I'd expect Eric's comments to remain 
part of his IESG review, and hence discussing his comments would be part 
of the process, as usual.

> The following comment is unrelated to the draft.  RFC 7772 has two URIs 
> in Section 3.  The first URI requires a Google account to access the 
> white-glove managed cloud services".  The guidance for RFCs are for URIs 
> to be stable; that is not the case.

    Alice: How long is forever?
    White Rabbit:  Sometimes, just one second.

          -- Lewis Carroll, Alice in Wonderland

For one reason or another, URLs are seldomly stable. Organizations 
change their CMS (breaking URLs), etc., etc.,

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Warren Kumari <[email-masked]>
Date: Sun, 17 Jan 2021 13:46:37 -0500

> of the process, as usual.

I think that the majority of the major DISCUSS (Alissa, Eric, and Rob)
and general feedback/comments have been addressed by the change in
status/removal of the pseudo-2119 language. However, the document will
(of course) undergo another full IESG Eval, and so all of the ADs will
have another opportunity to review the document and
confirm/double-check that their comments and concerns have been fully
addressed...

In particular, Erik had a DISCUSSS unrelated to the Informational/BCP
question, and so I've asked him to work with the author to ensure that
his comments have been fully addressed -- it would be stupid to do
another IETF Eval which results in the same DISCUSS position...

I believe that this document is getting more review than most - it is
having 2 WGLCs, 2 IETF LCs, and 2 IESG Evals; if comments are not
addressed when I take to the the second eval, I expect my co-ADs to
point out (loudly!) that their comments are still open...

W

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra