Subject: [ifmib] FW: ifStackTable entries

From: "Ketan Talaulikar" <[email-masked]>
Date: Tue, 1 May 2001 12:34:38 +0530

Still looking forward to a response for my earlier query.

-----Original Message-----
From: Ketan Talaulikar [mailto:[email-masked]]
Sent: Friday, March 30, 2001 00:17
To: [email-masked]'
Subject: ifStackTable entries

Hi,

I was looking for some clarification about the ifStackTable description in
RFC 2863. To quote a line ...

For each ifIndex value, I, which identifies an active interface, there are
always at least two instantiated rows in this table associated with I.

What is implied by *active* interface in this description?
- an interface which is admin or oper UP
- an interface which has a media-specific MIB with RowStatus object and its
value being *active*
- interface for which an ifEntry has been instantiated (irrespective of
anything else)

TIA
Ketan

_______________________________________________
ifmib mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/ifmib

---

From: Mike MacFaden <[email-masked]>
Date: Tue, 01 May 2001 19:24:37 -0700

>What is implied by *active* interface in this description?

[snip]

>- interface for which an ifEntry has been instantiated (irrespective of

My interpretation has been for every ifEntry that has been instantiated
in a given implementation, there are at least two entries in the ifStackTable. 

The only time I've broken this rule is in an implementation where an 
ifEntry could have an ifOperStatus of notPresent(6)  either due
to removal of pre-provisioning such that what is might 
be glued to does not exist in which case these
rows are not found in the ifStackTable. These I have left out of
the ifStackTable.

Regards,
Mike MacFaden