Subject: [EAI] Fw: Observatoins on http://www.ietf.org/internet-drafts/draft-ietf-eai-smtpext-01.txt

From: "Yao Jiankang" <[email-masked]>
Date: Tue, 1 Aug 2006 08:43:42 +0800

forwarded is from [email-masked], who may send the message to wrong mail address ([email-masked]). should be [email-masked]

----- Original Message ----- 
From: George Jones 
To: [email-masked] ; [email-masked] 
Cc: [email-masked] 
Sent: Monday, July 31, 2006 8:52 PM
Subject: Observatoins on http://www.ietf.org/internet-drafts/draft-ietf-eai-smtpext-01.txt

> So internationalized email address SHOULD be solved in>   the mail transport-level using the negotiation mechanism, which is an>   architecturally desirable approach.Just an observation.   This assumes low latency end-to-end connectivity of the
mail tranport.  There are significant cases in the past (e.g. UUCP) and somepossibly significant future cases (see the DTNRG) where this may not be thecase (LONG round trip times, one way or unreliable links), etc.
These may be out of scope, but you might want to make the assumptoin explicit.---George Jones

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: John C Klensin <[email-masked]>
Date: Mon, 31 Jul 2006 20:53:38 -0400

--On Tuesday, 01 August, 2006 08:43 +0800 Yao Jiankang
<[email-masked]> wrote:

> forwarded is from [email-masked], who may send the message
> to wrong mail address ([email-masked]). should be [email-masked]
> 
> Subject: Observatoins on
> http://www.ietf.org/internet-drafts/draft-ietf-eai-smtpext-01.
> txt
> 
> 
>> So internationalized email address SHOULD be solved in>   the
>> mail transport-level using the negotiation mechanism, which
>> is an>   architecturally desirable approach.Just an
>> observation.   This assumes low latency end-to-end
>> connectivity of the
> mail tranport.  There are significant cases in the past (e.g.
> UUCP) and somepossibly significant future cases (see the
> DTNRG) where this may not be thecase (LONG round trip times,
> one way or unreliable links), etc. These may be out of scope,
> but you might want to make the assumptoin explicit.---George
> Jones

George,

As far as I know, we have made no such assumption.  Indeed,
things might be a bit easier if we made the assumption that the
sending (or submission) SMTP was directly connected to the
destination one, even with high latency.   But this is designed
to work in the classic, hop-by-hop relay model of email and as
robustly as anything else that model supports (including cases
of store and forward transport with per-hop connections being
made less often than daily... been there, done that, made the
systems work).

So, if you find someplace where we have made a low latency
end-to-end assumption, (i) I would be really surprised and (ii)
you should tell us so it can be fixed.

regards,
    john