Subject: [EAI] changing name of ATOMIC?

From: Tony Hansen <[email-masked]>
Date: Wed, 19 Jul 2006 16:45:51 -0400

This comment was made, sort of in passing, in a few other posts by other
people, but I think it's worth a thread of its own.

Can the concept ATOMIC be renamed to be something else, say
DOWNGRADEABLE? This question is irrespective of whether it's implemented
within the MUA or passed as an SMTP parameter.

The idea is that the i18n email address is allowed to be converted into
an ACE form.

Now consider the word "atomic". American Heritage defines it like this:

    1. Of or relating to an atom or atoms.
    2. Of or employing nuclear energy: an atomic submarine; atomic
       weapons.
    3. Very small; infinitesimal.

The closest definition seems to be 3, but it seems to be backward. If an
address *is* downgradeable, then it's not indivisible.

The name ATOMIC just doesn't grab me the same way or seem to imply the
same thing. Wouldn't DOWNGRADEABLE be a better name for this concept?

	Tony Hansen
	[email-masked]

_______________________________________________
IMA mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ima

---

From: John C Klensin <[email-masked]>
Date: Wed, 19 Jul 2006 18:56:51 -0400

--On Wednesday, 19 July, 2006 16:45 -0400 Tony Hansen
<[email-masked]> wrote:

> This comment was made, sort of in passing, in a few other
> posts by other people, but I think it's worth a thread of its
> own.
> 
> DOWNGRADEABLE? This question is irrespective of whether it's
> implemented within the MUA or passed as an SMTP parameter.
> 
> The idea is that the i18n email address is allowed to be
> converted into an ACE form.
> 
>     2. Of or employing nuclear energy: an atomic submarine;
> atomic        weapons.
> The closest definition seems to be 3, but it seems to be
> backward. If an address *is* downgradeable, then it's not
> indivisible.
> 
> The name ATOMIC just doesn't grab me the same way or seem to
> imply the same thing. Wouldn't DOWNGRADEABLE be a better name
> for this concept?

I still hope to get rid of it, but agree that DOWNGRADEABLE
might be a better choice.  

That said, "atomic" has a well-known definition in computer
science (and most good dictionaries), which is "indivisible"
(that is the derivation of at least the first of the definitions
you give, with the second presumably deriving from the first).
E.g., the Merriam-Webster Unabridged definition includes

		4 : being ultimate, logically simple, unanalyzable, or
		noncompound either actually or taken as such within a
		given universe of discourse **this is red* may be
		considered an atomic proposition*;  specifically   :
		without sentential connectives and variables —
		compare MONADIC

(Sorry, no time right now to key in the similar, but better, OED
definition.)

The term was chosen too quickly but precisely to convey the
flavor of having an address that did not contain subaddresses or
other sorts of components... hence one that could be subjected
to an ACE or similar encoding without risk of having internal
information that would be hidden at the wrong times.

    john

---

From: Tony Hansen <[email-masked]>
Date: Thu, 20 Jul 2006 00:32:55 -0400

Hmmm, from draft-ietf-eai-smtpext-00.txt:

	The "ATOMIC" has one of two values: y or n.  The parameter
	"ATOMIC" is designed to assert whether the address is atomic,
	which means that the primary address(IMA) can be safely
	transformed or converted to the respect ASCII email address via
	ACE (ASCII Compatible Encoding) if the value is 'y' or not if
	the value is 'n'.

I don't get what you describe below at all from there. That is, there
are some unstated assumptions that lie in the words "safely
transformed". One is the indivisibility you mention; another is that
there is going to be one true ACE conversion that can be applied. This
is all further evidence that the term ATOMIC would be better named
something else.

	Tony Hansen
	[email-masked]

John C Klensin wrote:
>> ...
> ...

---

From: John C Klensin <[email-masked]>
Date: Thu, 20 Jul 2006 03:00:28 -0400

As I tried to say, I was trying to explain the choice of term,
not to defend it -- the term was chosen very quickly and was not
expected to last even as long as it has.   A change seems
entirely in order.

    john

--On Thursday, 20 July, 2006 00:32 -0400 Tony Hansen
<[email-masked]> wrote:

> 	transformed or converted to the respect ASCII email address
> via 	ACE (ASCII Compatible Encoding) if the value is 'y' or
> not if 	the value is 'n'.
> 
> I don't get what you describe below at all from there. That
> is, there are some unstated assumptions that lie in the words
> "safely transformed". One is the indivisibility you mention;
> another is that there is going to be one true ACE conversion
> that can be applied. This is all further evidence that the
> term ATOMIC would be better named something else.
> 
> 	Tony Hansen
> 	[email-masked]
> 
> John C Klensin wrote:
>> 
>> flavor of having an address that did not contain subaddresses
>> or other sorts of components... hence one that could be
>> subjected to an ACE or similar encoding without risk of
>> having internal information that would be hidden at the wrong
>> times.
>

---

From: Tony Finch <[email-masked]>
Date: Thu, 20 Jul 2006 11:47:14 +0100

On Wed, 19 Jul 2006, Tony Hansen wrote:
> DOWNGRADEABLE?

+1

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
FITZROY SOLE: SOUTHERLY 3 OR 4, BUT WESTERLY AT FIRST IN WEST, INCREASING 5 TO
7 LATER IN WEST. SHOWERS. MODERATE OR GOOD, WITH FOG PATCHES AT FIRST.

---

From: "Charles Lindsey" <[email-masked]>
Date: Thu, 20 Jul 2006 12:03:54 +0100

> might be a better choice.

I agree, assuming we need to retain the concept (though, as a matter of  
spelling, I don't think it needs that "E" in it - but I haven't the time  
to consult Fowler just at the moment).

> information that would be hidden at the wrong times.

Yes, but that is not the right interpretation anyway. Even if it contains  
subaddresses and other forms of internal structure, that is not  
necessarily a bar to downgrading.

Essentially, a site whose addresses are permitted to include the keyword  
DOWNGRADABLE (with whatever notation we provide for expressing that) is  
saying, in effect

"Yes, even though we parse our incoming local-parts looking for all sorts  
of local structure, and we can recognize such structure in both ASCII and  
UTF8 local-parts, we have also set things up so that we can even figure  
out the structure of an ACEd UTF8 local-part."

[Upgrading is the obvious way to "figure it out", but the site is welcome  
to do it anyway it likes].

So I would expect that the only sites which might insist on  
"NON-DOWNGRADEABLE" in their addresses would be those whose  
implementations could not, as John suggested, easily be hacked to do the  
upgrading. Are there any other situations when "NON-DOWNGRADEABLE" might  
be required?

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131                       
   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Bill McQuillan <[email-masked]>
Date: Thu, 20 Jul 2006 09:15:52 -0700

> upgrading. Are there any other situations when "NON-DOWNGRADEABLE" might

A difficulty with using punycoding for our ACE is that a transformation
such as: "add -owner to a mailing list name to get to a human" is done by
senders rather than final delivery agents and I'm not sure what the effect
of punycode's sticking the "special" stuff on the end will do to this
ability. That is why the strawman ACE I threw out earlier maintained
character order throughout the transformation.

Unfortunately, now that I think about it, if a local part needs to be
modified by the sender and that makes it NON-DOWNGRADABLE, then an second
ALT-ADDR will be needed for the modified address as well as the one for the
unmodified one!

-- 
Bill McQuillan <[email-masked]>

---

From: Tony Finch <[email-masked]>
Date: Thu, 20 Jul 2006 17:22:24 +0100

On Thu, 20 Jul 2006, Bill McQuillan wrote:
> ability.

Downgrading will not happen in this situation because it's UTF8-to-UTF8.

The more interesting question is how an ASCII user could reach the owner
of a UTF8 mailing list given the list's downgraded submission address.

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
HUMBER THAMES DOVER: SOUTH OR SOUTHWEST 4 OR 5, BECOMING VARIABLE 3. SHOWERS
THEN FAIR. MODERATE OCCASIONALLY POOR, WITH FOG PATCHES IN DOVER.

---

From: John C Klensin <[email-masked]>
Date: Thu, 20 Jul 2006 12:37:48 -0400

--On Thursday, 20 July, 2006 09:15 -0700 Bill McQuillan
<[email-masked]> wrote:

> Unfortunately, now that I think about it, if a local part
> needs to be modified by the sender and that makes it
> NON-DOWNGRADABLE, then an second ALT-ADDR will be needed for
> the modified address as well as the one for the unmodified one!

I am not sure I understand this comment.

Unless we are getting confused about terminology, senders don't
modify addresses, they supply them. 

Since ALT-ADDRESSes are required to be all-ASCII, substitution
of one of them yields something that does not need further
downgrading.

What am I missing?

    john

---

From: Tony Finch <[email-masked]>
Date: Fri, 21 Jul 2006 00:03:01 +0100

> modify addresses, they supply them.

They do if they are expecting a standard convention for constructing
addresses, such as adding -owner to [email-masked] to get [email-masked].

Tony.
-- 
f.a.n.finch  <[email-masked]>  http://dotat.at/
THAMES DOVER WIGHT PORTLAND PLYMOUTH: SOUTHWESTERLY 3 OR 4, OCCASIONALLY 5 IN
THAMES AND DOVER, BECOMING VARIABLE 3. SHOWERS LATER. MODERATE OCCASIONALLY
POOR, WITH FOG PATCHES.

---

From: John C Klensin <[email-masked]>
Date: Thu, 20 Jul 2006 19:55:32 -0400

--On Friday, 21 July, 2006 00:03 +0100 Tony Finch <[email-masked]>
wrote:

>> Unless we are getting confused about terminology, senders
>> don't modify addresses, they supply them.
> 
> They do if they are expecting a standard convention for
> constructing addresses, such as adding -owner to [email-masked]
> to get [email-masked].

But there has never been a Standard (large "S") convention.
There have only been a series of conventions.  E.g., for the
role you are describing and list foo, I have seen, in the
local-part,
   owner-foo
   foo-owner
   foo-request
at least.

That problem is one of the reasons the list-xxx headers were
adopted.  They make the relevant addresses explicit, rather than
relying on conventions that are often not followed.

Let's not try to make this problem even more difficult than it
is.

    john

---

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 25 Jul 2006 12:08:51 +0100

> addresses, such as adding -owner to [email-masked] to get  

But I still do not see the problem. Surely the 'sender' is sufficiently  
close to the 'author@ (i.e. they are usually at the same site, and are  
dealing with the mail _before_ is has been submitted, i.e. _before_ is  
starts its first SMTP hop) that the 'author' and 'sender' can sort out  
between them whether the '-owner' is added to a UTF8 or ASCII version of  
the address, after which it may get downgraded when it is offered to the  
first MTA (or by some later MTA).

A more interesting question is the one raised regarding the ASCII man who  
has the downgraded address of the list, and wants to contact its owner. I  
usupect that is a problem for the mailing list administrator to worry  
about, and maybe it should receive some attention in out  
mailing-list-document, which I gather someone is writing.