Subject: [EAI] So what's the status of the drafts :)

From: Shawn Steele <[email-masked]>
Date: Wed, 9 Jun 2010 19:26:12 +0000

Now we've rechartered, what's the status of the new drafts?

:)

---

From: John C Klensin <[email-masked]>
Date: Wed, 09 Jun 2010 16:46:19 -0400

> Now we've rechartered, what's the status of the new drafts?

I've asked Jiankang and Joseph to start working on scheduling
and an agenda for Maastricht.  I expect to have a preliminary
draft of "framework" to YangWoo within the next week and posted
not long thereafter.  Per earlier notes, other editors should
start assessing their availability and schedules and should get
back to myself, Joseph, and Jiankang with either commitments or
suggestions about alternate approaches (I will ask Jiankang to
start harassing people if we don't hear from them, but it would
be better to hear from them).

And, fwiw, I interpret asking a lot of questions about status as
volunteering to take on roles that would otherwise block
progress :-)

     john

---

From: Timo Sirainen <[email-masked]>
Date: Thu, 10 Jun 2010 03:59:45 +0100

On 9.6.2010, at 21.46, John C Klensin wrote:

> not long thereafter.

I know I haven't been here for very long, but could someone give me some kind of an URL/thread pointer to what the new goal is supposed to be like? The main thing I gathered from the agenda update was:

> Work will therefore reflect a "no fallback" approach.  

From what I understand, it means if the message has been sent in UTF-8, it means that's the way it's going to show up for client as well is going to be UTF-8, or otherwise it wouldn't have been accepted at all. Is that correct? That seems quite unrealistic, given IMAP's possibility of retrieving contents for many different clients. And especially if you think of what the currently most commonly used IMAP clients are. Did I miss something?

Personally I'm mostly interested in the IMAP part, but I'm not opposed to other parts of the specification either. I just don't really see what the problem is here. Why do people want to change something that has worked quite well for a decade or two?

BTW. I'll most likely be in Maastricht.

---

From: Shawn Steele <[email-masked]>
Date: Thu, 10 Jun 2010 04:18:29 +0000

> Why do people want to change something that has worked quite well for a decade or two?

Unless you live in China or somewhere else you have to use a foreign script for your email address.  (Just think if you had to type your address in Cyrillic or Chinese.)

If the header's UTF-8, the rest of the body may as well be UTF-8, but most clients accept UTF-8 encoded mail now anyway?  (I think?)  So UTF-8 shouldn't be a barrier here.

-Shawn