Subject: Re: [EAI] rfc5336bis

From: "Jiankang YAO" <[email-masked]>
Date: Tue, 17 Aug 2010 16:40:13 +0800

you mean:

if the headers are in utf-8, the body can be ascii data or non-ascii data(utf-8) if there are no body parameters?

----- Original Message ----- 
  From: Shawn Steele 
  To: [email-masked] 
  Sent: Tuesday, August 17, 2010 3:24 AM
  Subject: [EAI] rfc5336bis

  Confused about 3.5 #1 – I know some of this has been discussed before.

  If the server’s supposed to support UTF8SMTP, and there’s no BODY parameter, I’m confused why we’d say the header is UTF-8 but the body is ASCII.  It seems like if the header has UTF-8 in it, then it would be safe to say the body is then UTF-8.  UTF-8 is a superset of ASCII for these purposes, so it doesn’t even matter in the case where there’re no 8-bit bytes in the body.  If the server is assuming 8-bit bytes in the header are UTF-8, it seems that making the same assumption in the body would be no riskier?

  - Shawn

   

  http://blogs.msdn.com/shawnste

  (Selfhost 7787)

------------------------------------------------------------------------------

  _______________________________________________
  IMA mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/ima

---

From: Shawn Steele <[email-masked]>
Date: Tue, 17 Aug 2010 21:37:49 +0000

Yes, that’s what I’d assume.  (Otherwise the headers shouldn’t be in UTF-8 either).

From: Jiankang YAO [mailto:[email-masked]]
Sent: Tuesday, August 17, 2010 1:40 AM
To: Shawn Steele; [email-masked]
Subject: Re: [EAI] rfc5336bis

you mean:

----- Original Message -----
From: Shawn Steele<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]>
Sent: Tuesday, August 17, 2010 3:24 AM
Subject: [EAI] rfc5336bis

- Shawn

 

________________________________
_______________________________________________
IMA mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ima

---

From: John C Klensin <[email-masked]>
Date: Tue, 17 Aug 2010 18:41:01 -0400

--On Tuesday, August 17, 2010 16:40 +0800 Jiankang YAO
<[email-masked]> wrote:

> you mean:
> 
> if the headers are in utf-8, the body can be ascii data or
> non-ascii data(utf-8) if there are no body parameters?

Nope.  If there are no body parameters --in particular, a
"charset" for text types or some sort of non-text type -- the
body can only be ASCII.  Anything else is invalid MIME.  And
that is completely independent of how the primary headers are
encoded.

    john

---

From: Shawn Steele <[email-masked]>
Date: Tue, 17 Aug 2010 22:43:47 +0000

That's sort of my point.  What I read is that "if headers are UTF-8, but there's no MIME, then BODY is ASCII".  If there's no MIME, headers shouldn't be in UTF-8, so we shouldn't even get here.  If there's no MIME, but headers are UTF-8 and we want to recognize that, then I'd think the only logical conclusion would be that the body is also UTF-8.

Maybe I completely misread what the original text meant.

-Shawn

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Tuesday, August 17, 2010 3:41 PM
To: Jiankang YAO; Shawn Steele; [email-masked]
Subject: Re: [EAI] rfc5336bis

--On Tuesday, August 17, 2010 16:40 +0800 Jiankang YAO <[email-masked]> wrote:

> you mean:
> 
> if the headers are in utf-8, the body can be ascii data or non-ascii 
> data(utf-8) if there are no body parameters?

Nope.  If there are no body parameters --in particular, a "charset" for text types or some sort of non-text type -- the body can only be ASCII.  Anything else is invalid MIME.  And that is completely independent of how the primary headers are encoded.

    john

---

From: John C Klensin <[email-masked]>
Date: Tue, 17 Aug 2010 19:37:32 -0400

--On Tuesday, August 17, 2010 22:43 +0000 Shawn Steele
<[email-masked]> wrote:

> That's sort of my point.  What I read is that "if headers are
> UTF-8, but there's no MIME, then BODY is ASCII".  If there's
> no MIME, headers shouldn't be in UTF-8, so we shouldn't even
> get here.  If there's no MIME, but headers are UTF-8 and we
> want to recognize that, then I'd think the only logical
> conclusion would be that the body is also UTF-8.
> 

I think we can't have UTF-8 headers (or any other piece of
UTF8SMTPbis) without MIME:

Reasons:

	(1) There is no reason for not requiring MIME in this
	day and age.
	
	(2) UTF8SMTP[bis] requires 8BITMIME in order to make the
	addresses and headers work.  And 8BITMIME absolutely
	requires MIME.
	
	(3) Absent MIME, we are back to RFC 822 (or 5322 if you
	prefer) and, for it, the only valid headers are ASCII.
	Absent MIME, there are no encoded words either.

Put differently, UTF-8 headers without MIME don't imply some
sort of default UTF-8 body.  That case implies "seriously broken
message" with no other options.

So I don't know what the original text meant either, but I'm
pretty sure it leads into a dead end.   Or worse.

   john

---

From: Shawn Steele <[email-masked]>
Date: Tue, 17 Aug 2010 23:41:20 +0000

That's sort of what I was concluding as well.  Either the message is MIME, so the headers are MIME and the BODY then should also be MIME.  (So the case can't ever happen), or the MIME requirement was ignored, so raw UTF-8 headers shouldn't be happening, so the rest is also irrelevant.  (I don't mind assuming UTF-8 for non-MIME and crossing my fingers, but I realize that isn't a popular opinion).

Can we just strike that reference then?  Since it sounds like it's just saying "use MIME like we said earlier?"

-Shawn

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Tuesday, August 17, 2010 4:38 PM
To: Shawn Steele; Jiankang YAO; [email-masked]
Subject: RE: [EAI] rfc5336bis

--On Tuesday, August 17, 2010 22:43 +0000 Shawn Steele <[email-masked]> wrote:

> That's sort of my point.  What I read is that "if headers are UTF-8, 
> but there's no MIME, then BODY is ASCII".  If there's no MIME, headers 
> shouldn't be in UTF-8, so we shouldn't even get here.  If there's no 
> MIME, but headers are UTF-8 and we want to recognize that, then I'd 
> think the only logical conclusion would be that the body is also 
> UTF-8.
> 

Reasons:

	

Put differently, UTF-8 headers without MIME don't imply some sort of default UTF-8 body.  That case implies "seriously broken message" with no other options.

   john

---

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 18 Aug 2010 11:55:44 +0800

I prefer that we still keep the current text.

besides the reason mentioned by John,  if we allow that the body can be 
non-ascii data(utf-8) if there are no body parameters,  it is possible that the body may be other 8bit encoding standard such as
chinese code standard GB2312.
many MUAs sends the message with the local encoding.

----- Original Message ----- 
From: "Shawn Steele" <[email-masked]>
To: "John C Klensin" <[email-masked]>; "Jiankang YAO" <[email-masked]>; <[email-masked]>
Sent: Wednesday, August 18, 2010 7:41 AM
Subject: RE: [EAI] rfc5336bis

-Shawn

-----Original Message-----
From: John C Klensin [mailto:[email-masked]] 
Sent: Tuesday, August 17, 2010 4:38 PM
To: Shawn Steele; Jiankang YAO; [email-masked]
Subject: RE: [EAI] rfc5336bis

Reasons:

   john

---

From: Shawn Steele <[email-masked]>
Date: Wed, 18 Aug 2010 08:41:21 +0000

The current text would forbid GB2312 or any other local code page.  (It says it has to be ASCII).

For those other clients the headers would also likely be a local code page & not UTF-8.

-Shawn

 

________________________________________
From: Jiankang YAO [[email-masked]]
Sent: Tuesday, August 17, 2010 8:55 PM
To: Shawn Steele; John C Klensin; [email-masked]
Subject: Re: [EAI] rfc5336bis

----- Original Message -----
From: "Shawn Steele" <[email-masked]>
To: "John C Klensin" <[email-masked]>; "Jiankang YAO" <[email-masked]>; <[email-masked]>
Sent: Wednesday, August 18, 2010 7:41 AM
Subject: RE: [EAI] rfc5336bis

-Shawn

-----Original Message-----
From: John C Klensin [mailto:[email-masked]]
Sent: Tuesday, August 17, 2010 4:38 PM
To: Shawn Steele; Jiankang YAO; [email-masked]
Subject: RE: [EAI] rfc5336bis

Reasons:

   john

---

From: "Jiankang YAO" <[email-masked]>
Date: Wed, 18 Aug 2010 17:08:13 +0800

my understanding is that headers are in utf-8,

the body part might still use mime(gb2312).