Subject: Re: [EAI] ulabel

From: "Jiankang YAO" <[email-masked]>
Date: Mon, 9 Aug 2010 16:19:28 +0800

I will point to 5335bis, I'd like to keep the uMailbox instead of utf-8mailbox.

just now, I try to chang it to utf-8mailbox,

the defintition will be too long.

for example:

utf-8Local-part = utf-8Dot-string / utf-8Quoted-string
  utf-8Quoted-string = DQUOTE *utf-8qcontent DQUOTE
utf-8Domain = (sub-utf-8domain 1*("." sub-utf-8domain)) / address-literal

----- Original Message ----- 
From: "Shawn Steele" <[email-masked]>
To: "Jiankang YAO" <[email-masked]>; "Ernie Dainow" <[email-masked]>; <[email-masked]>
Sent: Friday, July 16, 2010 1:01 PM
Subject: RE: [EAI] ulabel

> Whatever you'd like.  Consistency is good between docs.  I'm fine with umailbox.
> 
> I think the more interesting thing is to NOT redefine the terms in different ways in different places.  I think it'd be better? for 5336bis to point to the definitions of mailboxes in 5335bis?  Eg: 5335 should focus on headers & addresses, and 5336 should focus on how SMTP handles those changes?
> 
> -Shawn
> 
>  
> http://blogs.msdn.com/shawnste
> 
> 
> ________________________________________
> From: Jiankang YAO [[email-masked]]
> Sent: Thursday, July 15, 2010 8:02 PM
> To: Ernie Dainow; Shawn Steele; [email-masked]
> Subject: Re: [EAI] ulabel
> 
> ----- Original Message -----
> From: "Ernie Dainow" <[email-masked]>
> To: "YAO Jiankang" <[email-masked]>; "Shawn Steele" <[email-masked]>; <[email-masked]>
> Sent: Thursday, July 15, 2010 5:43 AM
> Subject: Re: [EAI] ulabel
> 
> 
>> On 7/14/2010 2:59 PM, Shawn Steele wrote:
>>> Whatever you think's best.  I can't get very excited about nomenclature :), I just have the one minor concern about what ulabel means to me, but I can't even get very worked up about that :)
>>>
>>> I have a very mild preference for utf-8 in contexts where UTF-8 is interesting.  (Internally, I expect most windows apps to store email addresses in UTF-16 WCHARS as that's what our native data/string types are, so u* as in "Unicode" could still be vague in some contexts.  Utf8* would be very clear that UTF-8 is expected and not some other form of Unicode).  IDNA didn't care about the encoding of the Unicode, so U-Label works for it.
>>>
>>> That said, I reiterate that I've said way more words on this topic than I really have the passion for, whatever's easy for the authors is fine with me.  I mildly agree that consistency between docs would be nice, but I can't even get worked up about that either.
>>>
>>
>> Consistency is important to support best software engineering practices.
> 
> yes.
> 
> so Shawn, and Abel, will we keep utf-8mailbox or umailbox?
> in next version, we may make it to be same in our drafts.
> 
> Jiankang  Yao

---

From: Yangwoo Ko <[email-masked]>
Date: Mon, 9 Aug 2010 17:30:34 +0900

+1

On Fri, Jul 16, 2010 at 10:14 PM, Tony Hansen <[email-masked]> wrote:
>
>
> +1 for referencing.
>
>    Tony Hansen
>    [email-masked]
>
> On 7/16/2010 3:23 AM, Shawn Steele wrote:
>>
>> Repeating is fine, so long as they're the exactly the same (which they
>> aren't right now).  So referencing seems safer to me.  The problem with
>> repeating is that if something's slightly different, then any ambiguity
>> becomes more confusing.
>>
>>
>> Sent: Friday, July 16, 2010 12:06 AM
>> To: Shawn Steele; Ernie Dainow; [email-masked]
>> the tradion is that rfc2821 and rfc28822, rfc5321 and rfc5322 has similar
>> definitions of mailbox.
>>
>> both headner and smtp documents need mailbox defintion, either you said
>> you reference it or repeat it is same.
>>
>> even rfc5336bis reference rfc5335bis'definiton, rfc5336bis should be still
>> repeat the mailbox'defintion.
>
> _______________________________________________
> IMA mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ima
>

-- 
a human / twitter as yangwooko / msn as [email-masked] / nate
as [email-masked]

---

From: Shawn Steele <[email-masked]>
Date: Mon, 9 Aug 2010 17:05:20 +0000

That's fine with me.

-----Original Message-----
From: Jiankang YAO [mailto:[email-masked]] 
Sent: Monday, August 09, 2010 1:19 AM
To: Shawn Steele; Ernie Dainow; [email-masked]
Subject: Re: [EAI] ulabel

for example:

utf-8Local-part = utf-8Dot-string / utf-8Quoted-string
  utf-8Quoted-string = DQUOTE *utf-8qcontent DQUOTE utf-8Domain = (sub-utf-8domain 1*("." sub-utf-8domain)) / address-literal

---

From: "Jiankang YAO" <[email-masked]>
Date: Tue, 10 Aug 2010 09:16:26 +0800

great.