Subject: [IMRG] Discovering alternate routes between two hosts & source routing?

From: Yeggy Easwaran <[email-masked]>
Date: Mon, 2 Jun 2003 19:13:46 -0700 (PDT)

I would like to know if there is any means to discover alternate routes on the internet between two hosts that are connected and maybe reroute the packets along an alternate route that is less lossy/congested or one that offers better bandwidth than the default route. How popular/feasible is source routing?  Thanks a bunch 

---------------------------------
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.

---

From: Augustin Soule <[email-masked]>
Date: Tue, 03 Jun 2003 08:50:51 +0200

I don't know any tools to discover alternate routes, but as far as  I know
source Routing is a very bad idea and normally a packet with such options
has to be drop by every routers.
"Source rooting is used in conjunction with a spoofed source address to
re-direct packets to a hackers machine, getting around the problem of being
unable to receive replies to packets with a forged source address when
outside the target network."
see http://www.zensecurity.co.uk/whatis/WhatIs.asp?URL=source%20rooting

So source Routing is not very popular...

        Augutin Soule

Le 3/06/03 4:13, « Yeggy Easwaran » <[email-masked]> a écrit :

> I would like to know if there is any means to discover alternate routes on the
> internet between two hosts that are connected and maybe reroute the packets
> along an alternate route that is less lossy/congested or one that offers
> better bandwidth than the default route. How popular/feasible is source
> routing?
> 
> Thanks a bunch 
> 
> 
> Do you Yahoo!?
> The New Yahoo! Search
> <http://us.rd.yahoo.com/search/mailsig/*http://search.yahoo.com>  - Faster.
> Easier. Bingo.

_______________________________________________
IMRG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imrg

---

From: Neil Spring <[email-masked]>
Date: Tue, 3 Jun 2003 00:51:02 -0700

For an idea of the feasibility of using source routing, see
http://www.isi.edu/scan/mercator/mercator.ps.gz , pages 4
and 8.

 Not all routers in the Internet are source-route capable. In
 fact, only a small fraction (about 8%, see Section IV)
 support source routing.

I'd copy more, but I'm lazy.  The detail in section IV is
worth reading.

End hosts that use IP addresses for authentication are
already on shaky ground; blocking source routed packets
seems like an incomplete solution to the wrong problem.

good luck,
-neil

On Tue, Jun 03, 2003 at 08:50:51AM +0200, Augustin Soule wrote:
> I don't know any tools to discover alternate routes, but
> as far as I know source Routing is a very bad idea and
> normally a packet with such options has to be drop by
> every routers.

> "Source rooting is used in conjunction with a spoofed
> source address to re-direct packets to a hackers machine,
> getting around the problem of being unable to receive
> replies to packets with a forged source address when
> outside the target network."  see
> http://www.zensecurity.co.uk/whatis/WhatIs.asp?URL=source%20rooting

> Le 3/06/03 4:13, ??Yeggy Easwaran?? <[email-masked]> a ?crit?: