Subject: RE: [IMRG] Discovering alternate routes between two hosts &source routing?

From: "Ayyasamy, Senthilkumar (UMKC-Student)" <[email-masked]>
Date: Tue, 3 Jun 2003 02:37:53 -0500

>far as  I know source Routing is a very bad idea and normally 
>a packet with such options has to be drop by every routers.
>
>So source Routing is not very popular...

not really... It depends on whether source routing is
done at router or domain level. Domain level source 
routing delegates the control to the customer. Customer
can choose the path depending on performance or whatever 
criteria. I can argue that traffic engineering is only 
beneficial for ISPs; whereas, domain level source 
routing provides a choice to customers (like multi homing)

Their are lot of issues in domain level source routing..
esp: 
  - incentive for ISP
  - route selection and discovery
  - addressing scheme. 

I am not telling something new. Their are bunch of old 
( NIMROD, IDPR, estrin et all idr arch -SIGCOMM 92) and 
new (NIRA, feedback based routing) proposals supporting 
domain level source routing. They differ depending on
route selection and addressing scheme. For example, NIRA
does DSR by placing the heuristics in the address 
selection procedure. 

>> I would like to know if there is any means to discover 
>> alternate routes on the internet between two hosts that  
>> are connected 

Check Detour project/ Lixin Gao paper on path inflation. 

>> and maybe reroute the packets along an
>> alternate route that is less lossy/congested or one 
>> that offers better bandwidth than the default route.

This is a form of selfish routing. Their are some 
commerical products which supports this kind of smart 
routing. But, it helps only to select the first hop of 
the best route. 

I guess, their is atleast two works in SIGCOMM 03 which
target the above two issues. 

_______________________________________________
IMRG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/imrg

---

From: Jennifer Rexford <[email-masked]>
Date: Tue, 3 Jun 2003 11:44:37 -0400 (EDT)

> It depends on whether source routing is done at router or domain
> level. Domain level source routing delegates the control to the
> customer. Customer can choose the path depending on performance or
> whatever criteria. I can argue that traffic engineering is only
> beneficial for ISPs; whereas, domain level source routing provides a
> choice to customers (like multi homing)

True, though I wouldn't call this "domain-level source routing" since
the customer can only pick the first AS hop -- which upstream provider
they use to carry the traffic.  As such, this is more of a load-balancing 
technique that controls which path (of a small set of paths, beyond
the customer's control) is used to carry the traffic.  The customer
can't control what the second, third, etc. AS is used along the path.

-- Jen