Subject: [Insipid] WGLC for draft-ietf-insipid-session-id-reqts-07

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 9 Jul 2013 00:09:46 +0000

(As WG co chair)

This document has been around for 3 or 4 weeks now and has attracted no comments to update it.

The chairs would therefore like to make a further one week WGLC to check that the document has been finished and ready to do a publication request.

So if you have any comments before we request IESG to approve this as an informational document, then please make them by close of business on 16th July.

Regards

Keith

	Title           : Requirements for an End-to-End Session Identification in IP-Based Multimedia Communication Networks
	Author(s)       : Paul E. Jones
                          Gonzalo Salgueiro
                          James Polk
                          Laura Liess
                          Hadriel Kaplan
	Filename        : draft-ietf-insipid-session-id-reqts-07.txt
	Pages           : 11
	Date            : 2013-06-12

Abstract:
   This document specifies the requirements for an end-to-end session
   identifier in IP-based multimedia communication networks.  This
   identifier would enable endpoints, intermediate devices, and
   management and monitoring systems to identify a session end-to-end
   across multiple SIP devices, hops, and administrative domains.

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 9 Jul 2013 12:42:22 +0000

(As WG cochair)

I've just been double checking, and having thought that we had already had a WGLC on it, I find that formally, this is the first. I will therefore extend this WGLC until 23rd July 2013 to give it the full 2 weeks.

I'd also remind you that there are a number of IPR declarations against this document

https://datatracker.ietf.org/ipr/search/?option=document_search&id_document_tag=draft-ietf-insipid-session-id-reqts 

I believe we have briefly discussed these in the past, but please raise any concerns you have with proceeding with the draft in the presence of these declarations.

Regards

Keith

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of DRAGE, Keith (Keith)
> Sent: 09 July 2013 01:10
> To: [email-masked]
> Subject: [Insipid] WGLC for draft-ietf-insipid-session-id-reqts-07
> 
> (As WG co chair)
> 
> The chairs would therefore like to make a further one week WGLC to check
> that the document has been finished and ready to do a publication request.
> 
> So if you have any comments before we request IESG to approve this as an
> informational document, then please make them by close of business on 16th
> July.
> 
> Regards
> 
> Keith
> 
> 
> 	Title           : Requirements for an End-to-End Session
> Identification in IP-Based Multimedia Communication Networks
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 16 Jul 2013 15:32:19 +0000

(As WG cochair)

A reminder of this working group last call, now you all have plenty of time following the draft deadline.

If you have read it and have no comments, then do send the chairs a short mail saying that.

Keith

> Sent: 09 July 2013 13:42
> Subject: Re: [Insipid] WGLC for draft-ietf-insipid-session-id-reqts-07
> 
> (As WG cochair)
> 
> I've just been double checking, and having thought that we had already had
> a WGLC on it, I find that formally, this is the first. I will therefore
> extend this WGLC until 23rd July 2013 to give it the full 2 weeks.
> 
> https://datatracker.ietf.org/ipr/search/?option=document_search&id_documen
> t_tag=draft-ietf-insipid-session-id-reqts
> 
> I believe we have briefly discussed these in the past, but please raise
> any concerns you have with proceeding with the draft in the presence of
> these declarations.
> 
> Regards
> 
> Keith
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 16 Jul 2013 12:00:16 -0400

I've read it. I'm done nit picking it.

	Thanks,
	Paul

---

From: Brett Tate <[email-masked]>
Date: Fri, 19 Jul 2013 16:44:16 +0000

> If you have read it and have no comments, then do 
> send the chairs a short mail saying that.

I have read the draft and have no comments.

As discussed within the following thread, it sounds like requirement 3 will not be fully met.  However, there likely isn't much reason to list the various exceptions or loosen the "must require".

http://www.ietf.org/mail-archive/web/insipid/current/msg00529.html

Thanks,
Brett

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 19 Jul 2013 15:05:57 -0400

Brett,

What you introduced in that flow has multiple ends.  Bp and Bc are two
different endpoints and the signaling is merged at the B2BUA.  Basically,
the B2BUA is acting like an MCU, but one that never gets involved in media
transcoding or mixing.

So from Alice to the B2BUA (MCU), there is one session ID.  From the B2BUA
to Bp and Bc, there are different session IDs, but we re-use the B2BUA's
UUID "M" since that's the procedures specified for MCU behavior.  The net
result is three session IDs that are related:
  {A,M}
  {M,Bp}
  {M,Bc}

That's exactly what we would have had three users called into an MCU.  The
common value here is "M".

So, one could argue that REQ3 is not met, but another way to look at it is
that the "end" is the B2BUA.  Arranging the signaling as you have it in that
flow is about like using MGCP or H.248 to control the video or audio device
associated with the B2BUA.

In any case, we cannot use a single identifier to identify a call from the
point of origin to the point of termination if there are actually multiple
simultaneous termination points.  The best we can do is associate them as we
do for an MCU.

Paul

> Of Brett Tate
> Sent: Friday, July 19, 2013 12:44 PM
> To: DRAGE, Keith (Keith); [email-masked]
> As discussed within the following thread, it sounds like requirement 3
> will not be fully met.  However, there likely isn't much reason to list
> the various exceptions or loosen the "must require".
>

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 20 Jul 2013 14:08:15 +0000

Hi,

I'm ok with the reqs document.

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: [email-masked] [mailto:[email-masked]] Puolesta Paul Kyzivat
Lähetetty: 16. heinäkuuta 2013 19:00
Vastaanottaja: [email-masked]
Aihe: Re: [Insipid] WGLC for draft-ietf-insipid-session-id-reqts-07

	Thanks,
	Paul

On 7/16/13 11:32 AM, DRAGE, Keith (Keith) wrote:
>> From: [email-masked] [mailto:[email-masked]] On 
>> Behalf Of DRAGE, Keith (Keith)
>> Sent: 09 July 2013 13:42
>> To: [email-masked]
>> I've just been double checking, and having thought that we had 
>> already had a WGLC on it, I find that formally, this is the first. I 
>> will therefore extend this WGLC until 23rd July 2013 to give it the full 2 weeks.
>>
>> https://datatracker.ietf.org/ipr/search/?option=document_search&id_do
>> cumen t_tag=draft-ietf-insipid-session-id-reqts
>>
>> I believe we have briefly discussed these in the past, but please 
>> raise any concerns you have with proceeding with the draft in the 
>> presence of these declarations.
>>
>> Regards
>>
>> Keith
>>
>>> The chairs would therefore like to make a further one week WGLC to 
>>> check that the document has been finished and ready to do a 
>>> publication
>> request.
>>>
>>> So if you have any comments before we request IESG to approve this 
>>> as an informational document, then please make them by close of 
>>> business on
>> 16th
>>> July.
>>>
>>> Regards
>>>
>>> Keith
>>>
>>>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Mon, 22 Jul 2013 20:24:38 +0000

I have read it and think it is ready to move forward.

Cheers,
Charles

> Sent: Tuesday, July 16, 2013 8:32 AM
> To: [email-masked]

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Wed, 24 Jul 2013 16:50:14 +0000

[As WGLC cochair]

The WGLC has completed. No comments have been submitted and a number of mails have been received from people indicating that they have read the document and are happy with it.

The next step is to submit the draft to the IESG, and that is currently in progress. I have identified a number of editorials for correction, and this will occur when the new version has been issued.

Regards

Keith

> Sent: 16 July 2013 16:32
> > > This document has been around for 3 or 4 weeks now and has attracted
> no
> > > comments to update it.
> > >
> check