Subject: [Insipid] Next version of the backwards compatibility proposal

From: James Polk <[email-masked]>
Date: Thu, 24 Oct 2013 17:26:02 -0500

INSIPID

Here is the next version of the proposal for backwards compatibility 
between the insipid and kaplan versions of the Session-ID header.

http://www.ietf.org/internet-drafts/draft-polk-insipid-bkwds-compatibility-proposal-03.txt

There is a new section dealing with alternative proposals for a 
'flag' to indicate which implementation an endpoint is, namely either 
a new option tag or a Contact header feature tag. I list the reasons 
why I don't think either will work.

I'd like to get this draft discussed, as well as the two alternative 
flags on the list before we have our face2face in Vancouver on Monday 
evening, Nov 4th.

James

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 25 Oct 2013 11:36:07 -0400

James,

This draft is a little hard to follow because the examples all use 
Alice, Bob, Carol, but sometimes they are Kaplan implementations and 
sometimes they are Jones implementations. It would be easier to read if 
a name always corresponded to the same type of implementation. (E.g., 
Katy, Jan, Jerry.)

But since its transient, it may not be worth changing.

Otherwise, I think you make your point that other indicators aren't needed.

	Thanks,
	Paul

On 10/24/13 6:26 PM, James Polk wrote:
> There is a new section dealing with alternative proposals for a 'flag'
> to indicate which implementation an endpoint is, namely either a new
> option tag or a Contact header feature tag. I list the reasons why I
> don't think either will work.
>
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid
>

---

From: James Polk <[email-masked]>
Date: Fri, 25 Oct 2013 13:51:08 -0500

Thanks for reviewing and commenting Paul

At 10:36 AM 10/25/2013, Paul Kyzivat wrote:
>sometimes they are Jones implementations. It would be easier to read 
>if a name always corresponded to the same type of implementation. 
>(E.g., Katy, Jan, Jerry.)

I thought about doing this (where one 'name', e.g., Alice) is always 
a certain version of implementation, but it didn't make it into this rev.

>Otherwise, I think you make your point that other indicators aren't needed.

Thanks for understanding (and agreeing  ;-) )

James

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 25 Oct 2013 18:58:13 +0000

Alice could have different family names, depending on what type of entity she represents: Alice Kaplan and Alice Jones :)

Regards,

Christer

________________________________
From: [email-masked] [[email-masked]] on behalf of James Polk [[email-masked]]
Sent: Friday, 25 October 2013 9:51 PM
To: Paul Kyzivat; [email-masked]
Subject: Re: [Insipid] Next version of the backwards compatibility proposal

James

---

From: James Polk <[email-masked]>
Date: Fri, 25 Oct 2013 14:47:22 -0500

That's an interesting suggestion. If others think this solves any 
confusion, and doesn't create more - I can use this in my slide deck in YVR...

-j

At 01:58 PM 10/25/2013, Christer Holmberg wrote:

>Alice could have different family names, depending on what type of 
>entity she represents: Alice Kaplan and Alice Jones :)
>
>
>
>Regards,
>
>
>
>Christer
>
>
>
>
>
>
>
>----------
> >><http://www.ietf.org/internet-drafts/draft-polk-insipid-bkwds-comp 
> atibility-proposal-03.txt>http://www.ietf.org/internet-drafts/draft-polk-insipid-bkwds-compatibility-proposal-03.txt
> >>
> >>
> >><https://www.ietf.org/mailman/listinfo/insipid>https://www.ietf.or 
> g/mailman/listinfo/insipid
> >
> ><https://www.ietf.org/mailman/listinfo/insipid>https://www.ietf.org 
> /mailman/listinfo/insipid
>
><https://www.ietf.org/mailman/listinfo/insipid>https://www.ietf.org/mailman/listinfo/insipid