Subject: [Insipid] Tweak to insipid ABNF

From: Paul Kyzivat <[email-masked]>
Date: Wed, 12 Nov 2014 18:38:55 -1000

Hi,

In siprec we have decided to make explicit provision to include 
session-ids in recording metadata. As part of that, we need to specify 
what the syntax is of the data we include. IMO the best way to do that 
is to directly reference the ABNF used in the session-id draft.

We can do that now. But it is a little messy, because we need to 
replicate syntax from your draft:

     local-uuid *(SEMI sess-id-param)

It would be helpful if we could reference just a rulename. Specifically, 
if your ABNF was:

      session-id = "Session-ID" HCOLON session-id-value

      session-id-value = "Session-ID" HCOLON local-uuid
                         *(SEMI sess-id-param)

then we could simply refer to 'session-id-value'.

	Thanks,
	Paul

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Thu, 13 Nov 2014 22:39:37 +0000

I agree with updating the ABNF for simplified referencing.  We'll plan to make that change in the next version.

Cheers,

Gonzalo

> On Nov 12, 2014, at 6:38 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> Hi,
> 
> In siprec we have decided to make explicit provision to include session-ids in recording metadata. As part of that, we need to specify what the syntax is of the data we include. IMO the best way to do that is to directly reference the ABNF used in the session-id draft.
> 
> We can do that now. But it is a little messy, because we need to replicate syntax from your draft:
> 
> It would be helpful if we could reference just a rulename. Specifically, if your ABNF was:
> 
> _______________________________________________
> insipid mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/insipid

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 13 Nov 2014 13:01:28 -1000

> I agree with updating the ABNF for simplified referencing.  We'll plan to make that change in the next version.

Thanks. Unfortunately I botched my proposed ABNF. Corrected below.

         session-id-value = local-uuid *(SEMI sess-id-param)

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Thu, 13 Nov 2014 23:16:11 +0000

Thanks.  We'll review before adding, anyway.

-G

> On Nov 13, 2014, at 1:01 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> 
>