Subject: Re: [Insipid] Working group last call for draft-ietf-insipid-session-id-10

From: Brett Tate <[email-masked]>
Date: Thu, 6 Nov 2014 15:39:59 -0500

Hi,

I'd actually like to see the draft be updated based upon the current WGLC
comments and the WGLC be continued.

As indicated within the following post and the following offline comment,
I currently don't think that the draft adequately addresses CANCEL.  This
includes when caller cancels a forking fan-out.

http://www.ietf.org/mail-archive/web/insipid/current/msg00962.html

"However, seeing the section 9.8.1 figure 10 modification highlights
additional interesting things concerning the CANCEL-while-forking call
flow such as the CANCEL's 200 response and INVITE's 487 response.

Some B2BUAs act like a proxy, you might want to white board exactly how
you expect compliant proxies (or proxy B2BUAs) to behave when the caller
cancels.

Similarly, some B2BUAs will send 487 immediately instead of waiting for a
final responses from the cancelled branches.  You might want to white
board exactly how you expect compliant B2BUAs (which behave this way) to
behave when the caller cancels.

Similarly, both of the above can occur after 100 response (no 101-199
responses).  You might want to white board exactly how you expect a
compliant proxy/B2BUA to behave."

Thanks,
Brett

-------

From: insipid [mailto:[email-masked]] On Behalf Of DRAGE, Keith
(Keith)
Sent: Thursday, November 06, 2014 2:57 PM
To: [email-masked]
Subject: [Insipid] Working group last call for
draft-ietf-insipid-session-id-10

(as WG cochair)

We have now passed the deadline for comments.

The chairs believe the document has been well reviewed and will now
proceed with the publication request writeup.

If you do still have comments out there that are yet to be submitted, then
please contact the chairs to at least indicate they are coming, and we
will make appropriate arrangements to handle them.

Regards

Keith

_______________________________________________
insipid mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/insipid

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 6 Nov 2014 20:43:07 +0000

Yes, I am expecting an update sometime after the window reopens on Monday. But I would like to get this closed off.

I would encourage others to join the discussion of this one open point.

Keith

> -----Original Message-----
> From: Brett Tate [mailto:[email-masked]] 
> Sent: 06 November 2014 20:40
> To: DRAGE, Keith (Keith); [email-masked]
> Subject: RE: [Insipid] Working group last call for 
> I'd actually like to see the draft be updated based upon the 
> current WGLC comments and the WGLC be continued.
> 
> As indicated within the following post and the following 
> offline comment, I currently don't think that the draft 
> adequately addresses CANCEL.  This includes when caller 
> cancels a forking fan-out.
> 
> "However, seeing the section 9.8.1 figure 10 modification 
> highlights additional interesting things concerning the 
> CANCEL-while-forking call flow such as the CANCEL's 200 
> response and INVITE's 487 response.
> 
> Some B2BUAs act like a proxy, you might want to white board 
> exactly how you expect compliant proxies (or proxy B2BUAs) to 
> Similarly, some B2BUAs will send 487 immediately instead of 
> waiting for a final responses from the cancelled branches.  
> You might want to white board exactly how you expect 
> compliant B2BUAs (which behave this way) to behave when the 
> caller cancels.
> 
> Similarly, both of the above can occur after 100 response (no 
> 101-199 responses).  You might want to white board exactly 
> how you expect a compliant proxy/B2BUA to behave."
> 
> Thanks,
> Brett
> 
> -------
> 
> The chairs believe the document has been well reviewed and 
> will now proceed with the publication request writeup.
> 
> If you do still have comments out there that are yet to be 
> submitted, then please contact the chairs to at least 
> indicate they are coming, and we will make appropriate 
> arrangements to handle them.
> 
> Regards
> 
> Keith
>