Subject: [Int-area] PPP-to-ethernet

From: Derick Winkworth <[email-masked]>
Date: Fri, 15 Feb 2008 15:43:02 -0800 (PST)

All:

Mulitple router vendors have a feature in which you can essentially "bridge" a PPP link to an ethernet link. Cisco calls this feature "local-switching." Juniper calls it "translational cross-connects."

I find that both of these vendors implementations have their shortcomings, and I think there could be some benefit to creating a standard for accomplishing this. I am not aware of any standard for doing this.

My thought was essentially using the address field as defined in RFC 1662. Differing addresses in this field would be used by the translating router to forward traffic to differing neighboring routers on the ethernet segment. So there would effectively be a PPP-address-TO-Ethernet-MAC table. Neighboring routers would be discovered via IGMP or IRDP (as Cisco kind of does it today, but "not really") on the ethernet segment. Routers responding would have PPP addresses created for them in a state-table, which is link-scoped. So there would be a different table for every PPP link.

At the IP layer, the remote-end PPP device would obviously have an address that is native to the IP subnet of the ethernet link.
Anyway, anyone have any thoughts on this?

Derick

      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs

_______________________________________________
Int-area mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/int-area

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Tue, 19 Feb 2008 10:39:15 +0100

On 16 feb 2008, at 0:43, Derick Winkworth wrote:

> My thought was essentially using the address field as defined in RFC  
> 1662. Differing addresses in this field would be used by the  
> translating router to forward traffic to differing neighboring  
> routers on the ethernet segment. So there would effectively be a PPP- 
> address-TO-Ethernet-MAC table.

RFC 1662 defines the address field to be 0xff, so it's not possible to  
do this and be compatible with RFC 1662.

Wouldn't it be easier to just route the packet and do proxy ARP on the  
ethernet side?
_______________________________________________
Int-area mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/int-area