Subject: [Int-area] Name based sockets

From: Alex Burr <[email-masked]>
Date: Mon, 2 Aug 2010 09:37:33 -0700 (PDT)

[cc'd to int-area, but since I'm not subscribed it may not get through there]

Javier,
    This looks very interesting. Maybe I'm missing something, but from an API 
perspective, if you are going to the trouble of abstracting the address from the 
application by making it a name, it seems anomalous to leave the port as a 
number. Have you thought about making the port a name too?

Alex

---

From: Joe Touch <[email-masked]>
Date: Fri, 06 Aug 2010 10:14:08 -0700

> number. Have you thought about making the port a name too?

See: http://www.isi.edu/touch/pubs/draft-touch-tcp-portnames-00.txt

Joe